Subject: smtpupd-09 and ``destinations''

From: "D. J. Bernstein" <[email-masked]>
Date: 30 Jan 1999 02:12:54 -0000

> Fully-capable SMTP implementations,
  [ ... ]
> and their destinations,
> are expected to support all of the queuing, retrying,
> and alternate address functions discussed in this specification.

Why are SMTP _servers_ expected to support _client_ functions?

This prohibits the behavior of some existing hosts. It forces DNS
lookups in violation of policy at some corporate sites. It adds huge
extra costs to firewalls and POP toasters dedicated to incoming mail.

---Dan

---

From: John C Klensin <[email-masked]>
Date: Sat, 30 Jan 1999 12:58:02 -0500 (Eastern Standard Time)

> extra costs to firewalls and POP toasters dedicated to incoming mail.

Propose improved text.  But note comment in the status note
about special environments.

    john

---

From: "D. J. Bernstein" <[email-masked]>
Date: 30 Jan 1999 19:42:44 -0000

John C Klensin writes:
> Propose improved text.

Direct fix: Change ``SMTP implementations'' to ``SMTP clients'';
eliminate the screwy ``and their destinations.''

Easier fix: Eliminate the entire sentence. It's redundant.

---Dan