Subject: Ignore parameters on all headers?

From: Jacob Palme <[email-masked]>
Date: Fri, 8 Jan 1999 14:03:13 +0100

This is probably too late for drums, but the USEFOR group
has come up with a nice idea. The idea is that all
receivers SHOULD ignore all text after the first ";", if
they encounter a ";" in a header for which they do not know
that any parameters exist. This will probably be included
in the new USEFOR standard.

Senders should of course not add any parameters unless they
are standardized. But such a recommendation will avoid
problems when, in the future, the need comes up to add a
parameter to an already existing header. Usenet News has
had problems with this, existing news servers have been
known to reject and drop in a black hole any message, which
has an unknown parameter on a header.
------------------------------------------------------------------------
Jacob Palme <[email-masked]> (Stockholm University and KTH)
for more info see URL: http://www.dsv.su.se/~jpalme

---

From: Keith Moore <[email-masked]>
Date: Tue, 12 Jan 1999 11:07:54 -0500

> in the new USEFOR standard.

in general, extension mechanisms are a good idea.  but unless the new
USEFOR idea applies to new fields only, it *will* get shot down.

this is not applicable for DRUMS, since (a) DRUMS is too near to
end-of-life, and (b) DRUMS can't define new features anyway.

Keith