Subject: Re: Valid Addressing with 821bis

From: Graham Klyne <[email-masked]>
Date: Wed, 24 Feb 1999 16:03:24 +0000

At 22:38 23/02/99 GMT, Lee Thompson wrote:
>Under 821bis would "[email-masked]" be a valid syntax?

Examinination of the formal syntax suggests not, BUT

    "user..name"@domain.com

would be OK (i.e. using quotes).

#g
--

From section 3.4.1:
-------------------

addr-spec       =       local-part "@" domain

local-part      =
dot-atom / quoted-string / obs-local-part

and from 3.2.4:
---------------

atext           =       ALPHA / DIGIT / ; Any character except controls,

                     "!" / "#" /     ;  SP, and specials.

      "$" / "%" /     ;  Used for atoms
                        "&" / "'"
/
                        "*" / "+" /
                        "-" / "/" /

                      "=" / "?" /
                        "^" / "_" /

                  "`" / "{" /
                        "|" / "}" /

              "~"

atom            =       [CFWS] 1*atext [CFWS]

dot-atom
      =       [CFWS] dot-atom-text [CFWS]

dot-atom-text   =       1*atext
*("." 1*atext)

and from 4.4:
-------------

obs-local-part  =       atom *("." atom)

------------
Graham Klyne
([email-masked])

---

From: John C Klensin <[email-masked]>
Date: Thu, 25 Feb 1999 14:43:44 -0500

> would be OK (i.e. using quotes).

That is correct.  If a further distinction is made between 
"valid" and "dumb", the above would fall into both categories: 
quoted strings containing odd constructs are probably the area 
of 821 in which more "creative" ways to get things wrong have 
been found than any other.  Worse, these things often become 
non-replyable as they pass in and out of various MUA 
environments. 

So, if one had a choice about whether to use a mailbox name like
this or not, "not" would be the better operational choice.

   john