Subject: Re: smtpupd-09 requires detailed reply code inspection

From: "D. J. Bernstein" <[email-masked]>
Date: 1 Feb 1999 05:17:22 -0000

What is the interoperability benefit of requiring that SMTP clients
distinguish between 2xx and 3xx?

John C Klensin writes:
  [ sending 200 in response to DATA ]
> I can even imagine wanting to do such a thing
> in conjunction with some bizarre, but plausible, SMTP extensions. 

That's clearly wrong.

If you're talking to a normal SMTP client, you MUST NOT send 200 in
response to DATA. You're violating the protocol. RFC 821 does _not_
require that the client handle this garbage in any particular way.

Yes, you can advertise an extension that lets you send 200 in some
situations IF THE CLIENT HAS INDICATED SUPPORT FOR THE EXTENSION. But
this has no relevance to unextended clients.

---Dan

---

From: Tony Hansen <[email-masked]>
Date: Tue, 02 Feb 1999 14:19:14 -0500

John C Klensin wrote:
> 
> Tony,
> 
> Since you are the "magic fourth person", let me re-state the
> question...
> 
> What you want is to have the text read something like:
> 
>   message data MUST NOT be sent unless a continuation reply
>   (i.e., one of the form 3yz) is received.
> 
> is that correct?  Would you prefer
> 
>   message data MUST NOT be sent unless a continuation reply
>   (i.e., one of the form 3yz, normally 354) is received.

Yes. And I do prefer the latter.

	Tony Hansen
	[email-masked]