Subject: Re: Whitespace in Message Identifiers

From: Charles Lindsey <[email-masked]>
Date: Thu, 24 Feb 2000 09:15:48 +0000 (GMT)

On Wed, 23 Feb 2000 21:00:12 +0100
	Jacob Palme <[email-masked]> said...

> Message-ID is based on the e-mail address format. So if
> spaces are allowed in e-mail addresses, they should be
> allowed also in Message-IDs. Message-ID is often generated
> by combining some additional string with an e-mail address.
> 
> So if a person has the e-mail address
> "John Smith"@foo.bar
> 
> the there is a need for a Message-ID like
> "20000223205537*John Smith"@foo.bar

And would you then want to go on to allow

Message-ID: <"20000223205537*John
   Smith"@foo.bar>

? It was to prevent that that the DRUMS syntax has already been changed
so as to forbid your example. All we are asking now is for that change
to be completed by fixing the '\ ' that had slipped through the net.

The fact of the matter is that, for email, message identifiers are
entirely unimportant (very little software makes use of them, and
messages propagate happily without them). With Netnews, OTOH, message
identifiers are at the centre of the whole system. It is essential that
they can be compared instantly just by comparing the stream of octets -
otherwise the whole of Usent ceases to function. So this is a case where
email ought to follow netnews.

Charles H. Lindsey ---------At Home, doing my own thing------------------------
Email:     [email-masked]  Web:   http://www.cs.man.ac.uk/~chl
Voice/Fax: +44 161 437 4506      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9     Fingerprint: 73 6D C2 51 93 A0 01 E7  65 E8 64 7E 14 A4 AB A5

---

From: Jacob Palme <[email-masked]>
Date: Thu, 24 Feb 2000 18:52:26 +0100

> to be completed by fixing the '\ ' that had slipped through the net.

OK, I accept the drums decision. But I still think it is
not logical to allow spaces in e-mail addresses but not in
Message-IDs, since Message-IDs are usually generated from
e-mail addresses. But if that is the way it is going to be,
we will have to accept it.

My preferred solution would be to disallow spaces in both
e-mail addresses and Message-IDs.
-- 
Jacob Palme <[email-masked]> (Stockholm University and KTH)
for more info see URL: http://www.dsv.su.se/jpalme/