Subject: 10000 *.com dotted-decimal MX records

From: "D. J. Bernstein" <[email-masked]>
Date: 25 Feb 2000 22:10:16 -0000

This isn't news to MTA implementors; most MTAs---and the vast majority
by volume---deliver to these domains without trouble. But apparently
it's news to some DNSEXT and DRUMS participants, notably Randy Bush, who
has been discarding messages to the DNSEXT mailing list on this topic.

Shown below are 58 examples of .com domains whose MX records include
dotted-decimal IP addresses for currently reachable hosts. In most cases
there is only one MX record. Several of the MX records point to a single
address, but overall there are many different networks.

These examples are all from a verifiable 1/256th sample of .com domains:
namely, those with MD5 checksums starting with eight zero bits. Try
``echo -n FASB | md5'', for example.

Evidently there are roughly 15000 *.com domains whose MX records include
reachable dotted-decimal IP addresses. Roughly 10000 of them have no
other MX records.

---Dan

AAPAINTING.com: 216.149.170.212 
ANOKAEQUINE.com: swconsulting.com 207.1.200.130 
ASSESSINGCO.com: 208.232.239.130 ohare.sharpsite.com oboe.sharpsite.com 
BENTZEL-INSURANCE.com: 24.104.49.250 polaris.blazenet.net sirius.blazenet.net 
BOBYOAKFORD.com: 38.201.236.1 pop.ruralnet.org 
BODYCONTACT.com: bodycontact.com 207.106.19.173 astraweb.com 
CAMERABUSINESS.com: 209.240.132.38 
CARDIOBEAT.com: 204.245.52.113 
CAROLINACATFIGHTS.com: 207.173.185.5 
CKINC.com: 216.112.96.18 
COLORADOMOTORS.com: 216.120.21.219 
COUVRETTE.com: 209.245.55.70 
DANHOLM.com: 193.75.78.148 
DANTHEMORTGAGEMAN.com: 209.69.26.5 
DREAMBIZ4ALL.com: mail.daretolive.com 199.120.110.200 
DRUGDIGEST.com: 208.134.198.19 
DSPFILM.com: mail.thejunkie.com 64.24.9.173 
ENRON-COMMUNICATIONS.com: 209.51.83.242 ns.networkmercenaries.com 
EZALLOTMENT.com: 63.64.5.189 
FASB.com: 205.138.121.66 
FIREPLACE-SPA.com: 209.142.210.105 
FRENACK.com: 209.240.132.38 
GUILDPAGES.com: 63.193.74.202 
HEARTOFFLORIDA.com: 205.161.237.18 
HUNKS2WATCH.com: 207.155.50.213 
INETFILM.com: mail.thejunkie.com 64.24.9.173 
JAWSANDCHUCKS.com: 209.203.204.38 mail.huronmachine.com 
KELLYALEXA.com: 209.240.132.38 
KIDBEEPER.com: 209.240.132.38 
KITCHENARTOFSOUTHFLORIDA.com: 209.240.132.38 
LATINBOOTY.com: 209.51.241.24 mail.dreamcom.net 
LEATHERVESTS.com: 209.240.132.38 
MALL4NET.com: 205.252.89.125 
MCINTOSHCOLLEGE.com: 209.6.156.190 
MINDLIFTER.com: 195.94.56.80 
PEMPEO.com: 209.186.123.131 
PERSONALCAPTIONING.com: 63.64.5.189 
PILOTSINTOUCH.com: 209.240.132.38 
PROFILESNORTHTEXAS.com: 208.232.239.130 ohare.sharpsite.com oboe.sharpsite.com 
PROFILESWISCONSIN.com: 208.232.239.130 ohare.sharpsite.com oboe.sharpsite.com 
QUEENOFHEAVEN.com: 209.240.132.38 
RAPIDEC.com: 209.240.132.38 
REVOLUTIONIZE-U.com: mail.daretolive.com 199.120.110.200 
SACRAMENTOJOBS.com: 209.246.147.34 
SAFEMATCH.com: 209.218.111.61 
SANDIEGOCOUPONS.com: 204.216.147.42 
SHARPMECHANICS.com: 199.2.50.28 
SINSURFER.com: 209.240.132.38 
SPRINGCREEKPRAMS.com: 207.149.11.4 mail.web-o.net 
STORE4989.com: 209.240.132.38 
TECHNE-VI.com: 195.31.245.216 mail-backup.meditnet.com 
THESINCLAIRCOMPANY.com: 208.179.77.7 mail.thesinclaircompany.com mail.pajo.com 
THEWIRENUT.com: 207.254.129.96 
TOLLGAS.com: 209.181.244.4 
TRIPLECCC.com: xmail1.prime-c.com 216.201.147.38 
UNITEDLEGWEAR.com: 208.248.127.42 earth.cosmoweb.net moon.cosmoweb.net 
VADHYAR.com: 209.240.132.38 
WAP-BLITZER.com: 209.240.132.38

---

From: Randy Bush <[email-masked]>
Date: Fri, 25 Feb 2000 18:57:34 -0800

please report bugs in peoples zone files to the people with the bugs, not
namedroppers.

randy

[email-masked] is the mailing list for the ietf dnsext wg.  see
<http://www.ietf.org/html.charters/dnsext-charter.html> for the wg charter.
messages should be on topics appropriate to the dnsext wg, which are various
discussion of the dns protocols or administrivia of the wg itself.  the list
is moderated.

calls for papers, announcements of events not directly relevant to the dns
protocols, etc. are not appropriate.  discussion of problems with particular
implementations, announcements of releases, sites' misconfigurations, etc.
should be done on mailing lists for the particular implementations.

there is a wg for dns operational practice, dnsop, whose charter can be
found at <http://www.ietf.org/html.charters/dnsop-charter.html>.

there is a mailing list for discussion of whose implementation is better,
and why someone else's is broken.  it is [email-masked].  all
discussions of such nature should occur there or on /dev/null.  unlike the
namedroppers list, [email-masked] is not archived.

discussion of this policy is a topic for the poisson wg.  poisson's charter
can be found at <http://www.ietf.org/html.charters/poisson-charter.html>.

> Message-ID: <[email-masked]>
> Mail-Followup-To: [email-masked],
>   [email-masked]
> Mime-Version: 1.0
> Content-Type: text/plain; charset=us-ascii
> Date: 25 Feb 2000 22:10:16 -0000
> From: "D. J. Bernstein" <[email-masked]>
> To: [email-masked], [email-masked]
> Subject: 10000 *.com dotted-decimal MX records
>