Subject: Re: Substantive typo in -msg-fmt-08 -> CFWS

From: Sam Roberts <[email-masked]>
Date: Sun, 6 Feb 2000 11:15:21 -0500 (est)

Any comments on this? Roberts definition appears identical to me,
so I'm implementing it unless there's an example of a some
syntax I'll misparse.

int GetCFWS         (Ptr& p, const Ptr& e)
{
    // CFWS = *([FWS] comment) (([FWS] comment) / FWS)
    //
    // --> 1*(FWS / comment)

    int count = 0;

    while(GetFWS(p, e) || GetComment(p, e))
        ++count;

    return count;
}

Sam

Previously, you (Robert Elz) wrote:
>From:        Pete Resnick <[email-masked]>
>
>| Which, of course, is also wrong. (*Sigh*)
>| I will go back to the -07 form, which is still correct.
>
> But bog ugly and almost unfathomable.
>
> The intent is that there must be at least one FWS or comment, but
> can be any number, in any order, right?
>
> Wouldn't just
>
>   CFWS = 1*(comment / FWS)
>
> do that?
>
> kre
>
>

--
Sam Roberts, sroberts at uniserve dot com, www.emyr.net/Sam

---

From: Pete Resnick <[email-masked]>
Date: Sun, 6 Feb 2000 22:23:15 -0600

>     // CFWS = *([FWS] comment) (([FWS] comment) / FWS)

You won't misparse anything, but it allows the generation of something illegal:

comment FWS FWS comment

Two FWSs can't appear next to eachother. It would allow two folds in a row.

pr
-- 
Pete Resnick <mailto:[email-masked]>
Eudora Engineering - QUALCOMM Incorporated
Ph: (217)337-6377 or (858)651-4478, Fax: (858)651-1102