Subject: Re: RFC822's Appendix D, and X- fields

From: Charles Lindsey <[email-masked]>
Date: Tue, 8 Feb 2000 09:50:29 +0000 (GMT)

On Mon, 07 Feb 2000 17:50:19 -0500
	Keith Moore <[email-masked]> said...

> > I don't know what you mean by read/write, but X-mailer is an easy example 
> > of a field that should have been standardized.  I suspect that others can 
> > come up with more.
> 
> X-mailer is essentially write-only.  User agents don't read it (I hope).
> and I don't see why it needs to be standardized.  similar fields in
> other protocols (like HTTP) have widely been abused.

Quite so.

And FYI the USEFOR group is proposing a User-Agent header for news
(based on the one in the http protocol). It could be used as easily in
mail as in news. See our next draft, which will be submitted to the draft
site RSN.

BTW, does IANA keep a registry of established headers for news/mail,
with pointers to the RFCs where they are defined?

Charles H. Lindsey ---------At Home, doing my own thing------------------------
Email:     [email-masked]  Web:   http://www.cs.man.ac.uk/~chl
Voice/Fax: +44 161 437 4506      Snail: 5 Clerewood Ave, CHEADLE, SK8 3JU, U.K.
PGP: 2C15F1A9     Fingerprint: 73 6D C2 51 93 A0 01 E7  65 E8 64 7E 14 A4 AB A5

---

From: Jacob Palme <[email-masked]>
Date: Wed, 23 Feb 2000 17:05:28 +0100

> with pointers to the RFCs where they are defined?

I wrote a proposal for this some years ago, but it met with
rather weak interest, so I never bothered to get it accepted.
There was some contriversy about how strong the requirements
should be for getting a header entered into the registry.
Keith Moore wanted more thorough vetting, almost as for
registering a new standard, while I wanted rather limited
vetting, similar to what is done today for registering new
Content-Type subtypes.

You can find links to my proposal at
http://www.dsv.su.se/jpalme/ietf/jp-ietf-home.html#registry
and I can submit it again, if there is a communite wish to
have it processed to a standard.
-- 
Jacob Palme <[email-masked]> (Stockholm University and KTH)
for more info see URL: http://www.dsv.su.se/jpalme/