Subject: Re: Outstanding issues for smtpupd-12

From: Maurizio Codogno <[email-masked]>
Date: Thu, 08 Jun 2000 17:27:08 +0200 (MET DST)

> (i) CRLF line termination (and use of bare CR and bare LF).

>   (a) Prohibit _all_ appearances of bare CR and LF.  This is at
>   least clear.

This means we have to code them - ugly.

> 
>   (b) State clearly that bare CR and bare LF are permitted in
>   running text, but are to be considered as textual
>   characters, never line terminators.  This probably causes
>   interoperability problems but is, in principle, possible

I'd prefer this.

> (ii) 251 and 551 response codes.
> 
>   The present text deprecates 251 but continues to
>   tolerate 551. 

You mean my mailserver (which sends 551 when getting mail
from spammers) is not compliant? :-(
Let's deprecate both.

> 
> (iii) 
>   Should the statement be changed and, if so, to what?  Chris
>   suggested:

it's fine for me.

> (iv) The text, borrowing from RFC 821 if I recall, makes
>   several statements about "128 ASCII characters".  [...]
>   Any objections to
>   changing this to "127" and essentially prohibiting the use
>   of NULL?

No objection.

ciao ,.mau.

---

From: Philip Hazel <[email-masked]>
Date: Mon, 12 Jun 2000 10:32:28 +0100 (BST)

> >   interoperability problems but is, in principle, possible

Me too, as I am among those who believe in 8-bit clean mail.

-- 
Philip Hazel            University of Cambridge Computing Service,
[email-masked]      Cambridge, England. Phone: +44 1223 334714.