Subject: RE: Intserv marking

From: [email-masked]
Date: Fri, 24 Sep 1999 00:11:00 -0400

Mark it with a DSCP of 000000 - see Section 4.1 of
RFC 2474.  This is one of the very few REQUIRED
PHB mappings in Diffserv.  Other code points could
be used (e.g., to preserve the information that
the packet was remarked as best effort from GS or CL),
but that is a matter for local domain configuration.

--David

---------------------------------------------------
David L. Black, Senior Technologist
EMC Corporation, 42 South St., Hopkinton, MA  01748
+1 (508) 435-1000 x75140, FAX: +1 (508) 497-6909
[email-masked]
---------------------------------------------------

> -----Original Message-----
> From:	Shahram Davari [SMTP:[email-masked]]
> Sent:	Wednesday, September 22, 1999 7:11 PM
> To:	[email-masked]
> Subject:	Intserv marking
> 
> Hi Intservers,
> 
> In RFC 2211 and 2212 it is recommended to mark the non-compliant packets
> as
> BE traffic. Could somebody tell me how is this marking done over an IP
> packet? As far as I know the first 6 bits of the ToS field is used by
> Diffserv and the last 2 bits by ECN.
> 
> I appreciate your response.
> 
> Regards,
> 
>                             _\\|//_
>                             ( O-O )
>    ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
>           Shahram Davari
>           Systems Engineer, Product Research
>           PMC-Sierra Inc. 
>           105-8555 Baxter Place
>           Burnaby, BC V5A 4V7, Canada
>           Phone: +1 (604) 415-6000, Ext. 2428
>                          oooO
>    ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
>                           \ (    (   )
>                            \_)    ) /
>                                  (_/

---

From: Steve Blake <[email-masked]>
Date: Fri, 24 Sep 1999 13:26:40 -0400

> but that is a matter for local domain configuration.

You can always use any value of DSCP as long you are picking out the
non-comforming packets using a MF classifier (which includes DSCP as part
of the filter spec), but it is a mistake to associate non-conforming
IntServ packets with default (best-effort) packets.  You want non-
conforming packets to be served in the same queue as the conforming ones
(with possibly higher drop precedence) to avoid micro-flow reordering,
and you may want to restrict the bandwidth available to non-conforming
traffic to less than that reserved for default traffic.

Practically, it is probably better to choose an EXP/LU codepoint to
avoid having mysterious things happen if the classifier is misconfigured.

If one or more AFxy PHB groups are reserved for handling CL and GS traffic
then those codepoints are fine.

Regards,

=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Steven L. Blake                  <[email-masked]>
Ericsson IP Infrastructure             (919)468-8466 x232