Subject: question about RFC 2212

From: Chen Wen-Jen <[email-masked]>
Date: Wed, 3 Nov 1999 00:25:47 +0800 (CST)

hi...

I have a question about RFC 2212.
In page 3 of this document, it says

More precisely, the end-to-end delay bound is
[(b-M)/R*(p-R)/(p-r)]+(M+Ctot)/R+Dtot for p>R>=r,
and (M+Ctot)/R+Dtot for r<=p<=R

Can anybody tell me how to derive this equation?
or tell me where to find materials about this equation.

thanks very much... :)

                   Jay...

---

From: Roch Guerin <[email-masked]>
Date: Tue, 02 Nov 1999 18:13:40 -0500

> and (M+Ctot)/R+Dtot for r<=p<=R

This is based on the end-to-end delay result of PGPS
initially established by Parekh & Gallager, and which
has since then been refined in a number of ways, e.g.,
Latency rate servers, service curve models, etc.

Basically, the way to look at it is that the first
term is the time it takes to clear a burst of size
b arriving at speed p, when the service rate is R.  
The second and third terms have to do with the packet
nature of transmissions (packetization delays) and 
the property of various types of schedulers in how 
well they approximate an ideal fluid server.

You can read the original PGPS paper by Parekh and
Gallager (the multi-node case in IEEE/ACM Trans. Netw.,
aka ToN, of June 93), or the paper by Stiliadis and
Varma on latency rate servers (ToN Oct. 98), or the 
paper by Sariowan, Cruz, and Polyzos on Service Curves
(ToN Oct. 99), or for a more applied description 
specific to the Guaranteed Service, a paper we wrote
that was presented at Sigcomm'96 (1st paper of the
5th session, available at www.acm.org/sigcomm/sigcomm96).

Hope this helps,

Roch