Subject: RE: Difference in CLS and GS

From: Shahram Davari <[email-masked]>
Date: Thu, 7 Oct 1999 16:07:24 -0700

Hi Navin,

There are other differences as well. For example:

1)CLS requires policing in every node, while GS needs policing only at
ingress.
2)CLS Buffer size is network independent while GS buffer size is network and
network element dependent.
3)CLS does not permit packet fragmentation while GS permits.
4)CLS non-conformant packets must be transmitted with lower than BE
priority, while GS non-conformant packets can be transmitted as BE.
5) CLS usually requires one token bucket, while GS requires 2 token bucket.

Regards,

                            _\\|//_
                            ( O-O )
   ~~~~~~~~~~~~~~~~~~~~~~o00~~(_)~~00o~~~~~~~~~~~~~~~~~~~~~~~~
          Shahram Davari
          Systems Engineer, Product Research
          PMC-Sierra Inc. 
          105-8555 Baxter Place
          Burnaby, BC V5A 4V7, Canada
          Phone: +1 (604) 415-6000, Ext. 2428
                         oooO
   ~~~~~~~~~~~~~~~~~~~~~~(   )~~ Oooo~~~~~~~~~~~~~~~~~~~~~~~~~
                          \ (    (   )
                           \_)    ) /
                                 (_/

> -----Original Message-----
> From: Navin kumar Agrawal [mailto:[email-masked]]
> Sent: Wednesday, October 06, 1999 2:36 AM
> To: Int-Serv Mailing List
> Subject: Difference in CLS and GS
> 
> 
> Hi All,
> 
> As I didn't get any reply for my previous mail, I am resending the
> same, but this time it is in concise form.
> 
> In my opinion the only difference between GS and CLS is that
> in case of GS the bandwidth to be reserved is estimated based
> on the some info...whereas in case of CLS there is no estimation...
> 
> So from the implementation point of view, a network element, which
> supports both kind of services i.e. CLS and GS, the difference in
> implementation would differ only in the amount of bandwidth 
> to reserve.
> 
> Begin
>   If ( qos class is CLS)
>   {
>       req_bw = r
>    }
>    Else if (qos class is GS)
>    {
>        req_bw = R
>     }
>     reserve_bw (req_bw)
> End
> 
> In my opinion, the above would be the only difference in the
> implementation of GS and CLS (Here the Slack term is being
> neglected and also the updating of Adspec object is not taken up).
> And as this piece of code will be in admission control module, the
> packet classifier/scheduler code will be independent of GS, CLS.
> 
> 
> Is this understanding correct? If not, please clarify.
> 
> Regards,
> Navin
> 
>

---

From: pilar sanchez <[email-masked]>
Date: Fri, 08 Oct 1999 08:29:38 +0200

remove [email-masked]