Subject: RE: Issue with compression algorithms -Reply

From: Brad Davis <[email-masked]>
Date: Tue, 11 Nov 1997 16:54:28 -0700

>The IP Payload Compression Protocol could have been more complete with a
>default algorithm. Show me a high-performance compression algorithm, which
>is available in source-code and royalty-free, and I'll vote to define it to
>be the default in IPComp. 

How about a derivative of the GNU compression algorithm?  

I know that the standard implementation is a memory hog and there may be issues
with dictionary size, but it is royalty-free, available in source, and higher
performance than many direct competitors (that aren't royalty-free...).

Brad Davis
3Com/MCD (land of very small V.42bis dictionaries)

---

From: Robert Friend <[email-masked]>
Date: Tue, 11 Nov 1997 17:09:27 -0800

Well, there's also LZS221-C v3 which is available royalty-free, is *not*
a memory hog, and is available in source.

However, based on my experience I don't think the IESG will go for
either as the default.

Regards,
_____________________________________________________________

Robert C. Friend              Hi/fn
Applications Engineering      5973 Avenida Encinas, Suite 110
voice: (760) 827-4542         Carlsbad, CA 92008
FAX:   (760) 827-4577         email: [email-masked]

>-----Original Message-----
>From:	Brad Davis [SMTP:[email-masked]]
>Sent:	Tuesday, November 11, 1997 3:54 PM
>To:	[email-masked]
>Subject:	RE: Issue with compression algorithms -Reply
>