Subject: RE: IPCOMP and IPSEC

From: Stephen Waters <[email-masked]>
Date: Sat, 30 May 1998 10:38:53 +0100

I guess time will tell.  For remote-access VPN stuff (over the
Internet), there is no doubt that 
	stateless compression is what you use.  For some of the newer
VNP-focused providers offering
	QOS for LAN-to-LAN, it may be possible to use a history - even
for IPPCP.

	I've worked full-time from home for a few years now - using a
direct dial ISDN link over which the 
	average compression seems to stay stubbornly on 2:1.  I'll load
up the IPPCP image and share the results
	once I have a decent sample.  Not a bad case study considering
the use of IPPCP in the short term -
	i.e. remote-access for laptops/SOHOs.

	Cheers, Steve.

> ----------
> From: 	Avram Shacham[SMTP:[email-masked]]
> Sent: 	Friday, May 29, 1998 9:37 PM
> To: 	Eric Dean
> Cc: 	Stephen Waters; [email-masked]; [email-masked]
> Subject: 	RE: IPCOMP and IPSEC 
> 
> Eric,
> 
> At 04:20 PM 5/29/98 -0400, Eric Dean wrote:
> 
> >Streaming a contiguous file through a compression device is not 
> >indicative of real Internet traffic.  Packets of various application
> are 
> >interleaved within flows.  The Calgary files may be a good benchmark
> for 
> >comparing different compression algorithms in a stateful environment;
> 
>                                                  ^^^^^^^^ how comes?
> 
> >however, they do not represent the stateless environment that the 
> >Internet represents.
> 
> In my tests, I ftp-ed and http-ed random collection of files, with
> identical results, so it seems that the Calgary Files are a pretty
> good
> indication for non-pre-compressed files.
> 
> avram
> 
>

---

From: Eric Dean <[email-masked]>
Date: Sat, 30 May 1998 17:15:32 -0400 (EDT)

> 	i.e. remote-access for laptops/SOHOs.

For reasons stated in my previous message, as you move closer to the core 
of the Internet where traffic is highly uncorrelated, you will find 
relatively poor cases for stateful compression.  (I am aware that 
stateless compression is the proposed method for IPPCP.)

As you move far to the edge of the Internet, at the modem layer, you find 
that packets are highly correlated and tend to benefit from current stateful 
compression methodologies.

-eric