Subject: more IP compression work to do?

From: Stephen Waters <[email-masked]>
Date: Thu, 15 Oct 1998 10:48:25 +0100

Hi,

	Are there any plans to extend IPPCP to allow IP header compression
(lots of work on this in PPPext land)?
	I guess this would be limited to the case where a negotiation
protocol was present - e.g. IKE, where the extent of the 
	compression could be negotiated for an IPSEC tunnel, say.

	Regards, Steve.

---

From: Rodney Thayer <[email-masked]>
Date: Thu, 15 Oct 1998 07:03:13 -0400

Did you check the email archives?  This was discussed, I believe.

---

From: Avram Shacham <[email-masked]>
Date: Thu, 15 Oct 1998 11:07:24 -0700

Steve,

I'm not aware of any past or present discussion of IP _header_ compression in this wg. 

The IPPCP wg followed its charter, as even the wg name implies:

The IP Payload Compression Protocol Working Group will develop protocol specifications that make it possible to perform lossless compression on individual payloads before the payload is processed by a protocol that encrypts it
              ^^^^^^^^^^ 

True, the original version of the draft (RFC, soon, maybe) included the header as part of the compressed payload, but the wg decided to compress just the ULP portion of the datagram.

Regards,
avram