Subject: Re: PMP> Justification for prtAlertTime and prtAlertTimeGrou

From: Harry Lewis <[email-masked]>
Date: Thu, 20 Nov 1997 11:25:14 -0500

More mail troubles

Harry Lewis - IBM Printing Systems

---------------------- Forwarded by Harry Lewis/Boulder/IBM on 11/20/97 09:14 AM
 ---------------------------

Harry Lewis
11/19/97 11:16 PM
To: [email-masked] @ internet
cc: [email-masked]@internet
From: Harry Lewis/Boulder/IBM @ IBMUS
Subject: Re: PMP> Justification for prtAlertTime and prtAlertTimeGroup ch

I would expect Jay or Dave to chime in here because I think they are the ones
who finally realized the great benefit to knowing something about the time
related to events. My recollection is that we simply realized timing of events
is essential information and should not be considered optional. The time is in
TICKS or something related to sysUpTime, so there's no extra burden in terms of
time keeping or having to put a Timex (or Rolex) in the machine.

Harry Lewis - IBM Printing Systems

[email-masked] on 11/19/97 11:54:57 AM
Please respond to [email-masked] @ internet
To: [email-masked] @ internet
cc:
Subject: PMP> Justification for prtAlertTime and prtAlertTimeGroup ch

I am finally getting around to gathering up the justifications
for the changes between RFC1759 and the new Printer MIB. I have
been able to collect the justification for all changes except
for one. The change that I can not find any justification for
is the move of prtAlertTime from the prtAlertTimeGroup to the
prtAlertTableGroup and the subsequent deprecation of the
prtAlertTimeGroup. I have searched both the PMP and PWG mail
archives and while I can find mail that discusses the change,
I can not find any mail that says why the change was made or
why the change was required.
Help?
Lloyd
------------------------------------------------------------
Lloyd Young                       Lexmark International, Inc.
Senior Program Manager            Dept. C14L/Bldg. 035-3
Strategic Alliances               740 New Circle Road NW
internet: [email-masked]     Lexington, KY 40550
Phone: (606) 232-5150             Fax: (606) 232-6740

---

From: "Turner, Randy" <[email-masked]>
Date: Thu, 20 Nov 1997 11:00:42 -0800

For the purposes of defining the object for the MIB, we should just 
say that each implementation should "do what it can" to make
sure that prtAlertTime is relative to the sysUpTime. I don't think
we need to address implementation details.

Randy

> -----Original Message-----
> From:	Bob Pentecost [SMTP:[email-masked]]
> Sent:	Thursday, November 20, 1997 10:01 AM
> To:	[email-masked]
> Subject:	RE: PMP> Justification for prtAlertTime and
> prtAlertTimeGrou
> 
> I think Harry's got this right. 
> 
> While we're on the topic of prtAlertTime, I had a question come to me
> about this object. As I had mentioned when we were changing this
> object to mandatory, the sysUpTime is kept in our Network Interface
> Card (the issue at the time was due to problems getting the time from
> the NIC, but I don't care to revisit that aspect). What's the printer
> to do when it has two such cards installed? One might argue that
> there's one power supply so the times start when the power is turned
> on, but the time could also be kept in an external NIC that
> communicates with the printer over the parallel port. Also, I'm not
> sure, but the clock drift between two NIC timers could be significant.
> 
> Any thoughts?
> 
> Bob Pentecost
> HP
> 
> 
> 
> ----------
> 
> 11/19/97 11:16 PM

---

From: "Turner, Randy" <[email-masked]>
Date: Thu, 20 Nov 1997 11:06:42 -0800

I don't have a clear recollection of why we were talking
about the move of this object either, but it seems to me
that I did take some editorial action awhile back and 
suggested we move and group objects differently so that
implementers could see things a little clearer....

Randy

> From:	Jay Martin [SMTP:[email-masked]]
> Sent:	Thursday, November 20, 1997 10:57 AM
> To:	Bob Pentecost
> Cc:	[email-masked]
> Subject:	Re: PMP> Justification for prtAlertTime and
> prtAlertTimeGrou
> 
> Umm...I don't think so, Bob.  (I can't speak for Dave Kellerman.)
> 
> While it's true that I always had quite a bit of heartburn
> accepting the group's original decision to NOT require some
> kind of a timing value (relative or absolute) for an alert
> event, I always just accepted the group's wishes.
> 
> Later, when the group finally realized that, "Hey, we also
> must support MIB-II...and that requires time-ticks!", it
> then became pretty apparent (to me, anyway) that an alert
> time component for an alert entry should be MANDATORY, since
> all printers supporting the Printer MIB had that value, anyway.
> 
> I don't wish to fight the mandatory-vs-optional argument all over
> again.  But suffice to say, I was NOT involved in the move of the
> original alert time object from one part of the MIB to another.
> 
> Could such a move have been proposed by Tom Hastings, perhaps
> motivated by creating "a more perfect MIB"?  (Hey, let's keep
> passing this buck! ;-)
> 
> Again, Dave Kellerman may have some fond memories of this situation.
> 
> 	...jay
> 
> ----------------------------------------------------------------------
> --  JK Martin               |  Email:   [email-masked]          --
> --  Underscore, Inc.        |  Voice:   (603) 889-7000              --
> --  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
> --  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
> ----------------------------------------------------------------------
> << Message: RE: PMP> Justification for prtAlertTime and
> prtAlertTimeGrou >>

---

From: Bob Pentecost <[email-masked]>
Date: Thu, 20 Nov 1997 15:02:24 -0700

I'm not understanding something here. Jay says
"(Is there any reason a client app would want
to some way coodinate the value of MIB-II's sysUpTime with a
prtAlertTime value??  Seems unlikely...)"

What good is it to know the alert time if you don't relate it to the current sysUpTime?

Bob

----------
From:  Jay Martin[SMTP:[email-masked]]
Sent:  Thursday, November 20, 1997 12:01 PM
To:  Bob Pentecost
Cc:  [email-masked]
Subject:  Re: PMP> Justification for prtAlertTime and prtAlertTimeGrou

Bob,

Regarding the second topic of your previous reply:

> While we're on the topic of prtAlertTime, I had a question come to me about this object. As I had mentioned when we were changing this object to mandatory, the sysUpTime is kept in our Network Interface Card (the issue at the time was due to problems getting the time from the NIC, but I don't care to revisit that aspect). What's the printer to do when it has two such cards installed? One might argue that there's one power supply so the times start when the power is turned on, but the time could also be kept in an external NIC that communicates with the printer over the parallel port. Also, I'm not sure, but the clock drift between two NIC timers could be significant.
> 
> Any thoughts?

Good question.  I would think that the manufacturer would simply
choose one of the NICs as the "master" and use its values.  As
long as the same NIC values are used, then it probably wouldn't
matter that much.  (Is there any reason a client app would want
to some way coodinate the value of MIB-II's sysUpTime with a
prtAlertTime value??  Seems unlikely...)

Of course, we don't build printers, so this opinion may not be
shared with those who do.

	...jay

---

From: "Wagner, William" <[email-masked]>
Date: Thu, 20 Nov 1997 17:26:40 -0500

I agree with Bob. Having the event times refer back to MIB-II allows
determination of the clock time (although there would be some minor
calculation necessary in the application). I assumed Jay was jesting
with his comment.

The problem of two NIC's had been discussed in this context. The formal
solution  (System refers to the controller not the NIC) is practically
unpalatable and probably any consistent implementation would be quite
usable in that, in most cases, the difference would not be significant.
Of course, if the NICs can be independently reset and that reset
includes sysUpTime, then realistically, the NIC's should be
resynchronized.

W. A. Wagner (Bill Wagner)
OSICOM/DPI

> Sent:	Thursday, November 20, 1997 5:02 PM
> To:	'Jay Martin'
> Cc:	[email-masked]
> > While we're on the topic of prtAlertTime, I had a question come to
> me about this object. As I had mentioned when we were changing this