Subject: IPP> Question about Job Template Attributes

From: "Rajesh Chawla" <[email-masked]>
Date: 21 Jul 1998 13:00:21 -0000

Hi folks,

In the Job Template Attributes there are attributes
that can be a type3 keyword or a name (job-hold-until,
job-sheets, and media).  As I read the spec, these
attributes are usually type3 keywords but can optionally
be changed at the printer to a name type.  Is this
correct or did I miss something in the spec?

My question is how does an IPP client know which
type to send?  If the wrong type is sent, what should
the expected reply be?

Regards,
Rajesh

---

From: "Carl Kugler" <[email-masked]>
Date: 21 Jul 1998 15:23:28 -0000

> correct or did I miss something in the spec?

My understanding, based on my reading of the spec and questions I've asked here in the past:

Those attributes can be typed, and tagged as any of the following:

0x36	nameWithLanguage
0x42	nameWithoutLanguage
0x44	keyword

In general, an IPP Object may send any one of the three types, and must accept any one of the three.  However, for any 'name' attribute in the request that is in a different natural language than the value supplied in the "attributes-natural-language", the sender must use the nameWithLanguage form.  Type 3 keywords have standard, registered values.

If the wrong type is sent in a request, according to MOD section 16.4.3, the response should be 'client-error-request-value-too-long'.  Quote:
    "IF NOT any single 'keyword' or 'name' value less than or equal to 255 octets, REJECT/RETURN 'client-error-request-value-too-long'.")
 
> type to send?  If the wrong type is sent, what should

    -Carl

-----
Original Message: http://www.findmail.com/list/ipp/?start=4166
Start a FREE email list at http://www.FindMail.com/