Subject: IPP> TES - sharing binary IPP trace files

From: Carl Kugler <[email-masked]>
Date: Fri, 30 Jan 1998 12:40:14 -0700

Regarding the trace repository at ftp://ftp.pwg.org/pub/pwg/ipp/new_TES/Traces (described at
http://www.pwg.org/hypermail/ipp/2911.html):

These files:
    ftp://ftp.pwg.org/pub/pwg/ipp/new_TES/Traces/00012A00.trc
    ftp://ftp.pwg.org/pub/pwg/ipp/new_TES/Traces/00012B00.trc
should be demoted;  they are based on an obsolete version of the protocol.

I'm sending Pete 4 new files to replace them:

     00022A00.trc
     00022A00.txt
     00022B00.trc
     00022B00.txt

00022A00.txt and 00022B00.txt are attached.

We believe these to be compliant with the current version of the IPP specs, with no privacy or
authentication applied.

The .trc files are suitable for use with a driver like the one described in
http://www.pwg.org/hypermail/ipp/3120.html

-Carl Kugler
// a. the person posting the trace file:  Carl Kugler
// b. contact information for that person : [email-masked]
// c. the unique sequence number for the conversation (SSSS): 0002
// d. the name of the operation (O): PrintJob
// d. whether it is a request or a response (R): request
// e. the file name of the file: 00022A00
// f. the date:  January 30, 1998
// g. a comment about the intent of the operation request or response:
//    print job submission
// 
major-version-number:     0x01
minor-version-number:     0x00
PrintJob operation-id:    0x0002
request-id:       0x00000001
operation-attributes-tag: 0x01
value-tag:        0x47
name-length:      0x0012
name:     attributes-charset
value length:     0x0008
value:    US-ASCII
value-tag:        0x48
name-length:      0x001b
name:     attributes-natural-language
value length:     0x0005
value:    en-US
value-tag:        0x42
name-length:      0x0008
name:     job-name
value length:     0x0004
value:    job1
value-tag:        0x22
name-length:      0x0016
name:     ipp-attribute-fidelity
value length:     0x0001
value:    0x00
value-tag:        0x42
name-length:      0x0014
name:     requesting-user-name
value length:     0x0005
value:    steve
value-tag:        0x42
name-length:      0x000d
name:     document-name
value length:     0x0009
value:    document1
job-attributes-tag:       0x02
value-tag:        0x21
name-length:      0x0006
name:     copies
value length:     0x0004
value:    0x00000001
value-tag:        0x21
name-length:      0x000c
name:     job-priority
value length:     0x0004
value:    0x00000001
end-of-attributes-tag:    0x03
// document data follows
// a. the person posting the trace file:  Carl Kugler
// b. contact information for that person : [email-masked]
// c. the unique sequence number for the conversation (SSSS): 0002
// d. the name of the operation (O): PrintJob
// d. whether it is a request or a response (R): response
// e. the file name of the file: 00022B00
// f. the date:  January 30, 1998
// g. a comment about the intent of the operation request or response:
//    print job submission
// 
major-version-number:     0x01
minor-version-number:     0x00
status-code:      0x0000
request-id:       0x00000001
operation-attributes-tag: 0x01
value-tag:        0x42
name-length:      0x000b
name:     status-code
value length:     0x0006
value:    good 2
value-tag:        0x42
name-length:      0x000b
name:     status-code
value length:     0x0006
value:    good 2
job-attributes-tag:       0x02
value-tag:        0x42
name-length:      0x0008
name:     job-name
value length:     0x0004
value:    Job1
value-tag:        0x42
name-length:      0x0009
name:     job-state
value length:     0x0009
value:    Job1 Job2
value-tag:        0x42
name-length:      0x0009
name:     job-state
value length:     0x0009
value:    Job1 Job2
value-tag:        0x42
name-length:      0x0011
name:     job-state-reasons
value length:     0x0004
value:    Job1
value-tag:        0x42
name-length:      0x0011
name:     job-state-message
value length:     0x0004
value:    YO 2
value-tag:        0x42
name-length:      0x0011
name:     job-state-message
value length:     0x0004
value:    YO 2
unsupported-attributes-tag:       0x05
value-tag:        0x41
name-length:      0x0005
name:     sides
value length:     0x000b
value:    unsupported
end-of-attributes-tag:    0x03

---

From: Carl Kugler <[email-masked]>
Date: Fri, 30 Jan 1998 16:06:39 -0500

Another "conversation".   Binaries to be uploaded to
ftp://ftp.pwg.org/pub/pwg/ipp/new_TES/Traces

---

From: Carl Kugler <[email-masked]>
Date: Fri, 30 Jan 1998 16:40:47 -0500

---

From: Carl Kugler <[email-masked]>
Date: Fri, 30 Jan 1998 16:56:33 -0500

---

From: Carl Kugler <[email-masked]>
Date: Fri, 30 Jan 1998 17:07:00 -0500

---

From: Carl Kugler <[email-masked]>
Date: Fri, 30 Jan 1998 17:15:43 -0500