Subject: Re: PMP> Last call Printer MIB comment: simple localization

From: Harry Lewis <[email-masked]>
Date: Wed, 1 Apr 1998 19:32:29 -0500

Not that I don't support good efforts to ease internationalisation... but this
topic was debated in heaps and resolved in the Printer MIB and the fact that
this is not a "v3" discussion is painful demonstration of the lack of attention
by the IETF to the Printer MIB. If the MIB is so unimportant that it can
languish so long... I don't see how or why it would be so urgent to enforce
some new rule.

Harry Lewis - IBM Printing Systems

[email-masked] on 04/01/98 05:03:40 PM
Please respond to [email-masked]
To: [email-masked], [email-masked]
cc: [email-masked], [email-masked]
Subject: Re: PMP> Last call Printer MIB comment: simple localization

Hi Chuck,

Yes, I am saying that there is NO grandfather clause in the IETF
Policy on Charsets and Languages.  In fact, it provides for
REMOVING existing RFCs from the Internet 'standards track'
for non-compliance.  If you send the current I-D for the
Printer MIB (which is dated about two weeks ago, when
Lloyd changed it) to the IESG for adoption as an RFC,
it is subject (like ALL application protocols and SNMP
MIB modules) to this policy.  While a waiver is technically
possible, NONE has been granted to any IETF 'standards track'
document in the last three months.

Cheers,
- Ira McDonald (High North)

PS - If you read Tom's and my proposal, you would have noticed
that SNMPv3, LDAPv3, System Application MIB, Service Location
Protocol (SLP) and many other IETF standards are compliant.
The argument of 'current practice' won't hold water with
the IESG.

-------------------------------------------------------------
>From [email-masked] Wed Apr  1 16:44:28 1998
Return-Path: <[email-masked]>
Received: from zombi (zombi.eso.mc.xerox.com) by snorkel.eso.mc.xerox.com
(4.1/XeroxClient-1.1)
 id AA19175; Wed, 1 Apr 98 16:44:28 EST
Received: from alpha.xerox.com by zombi (4.1/SMI-4.1)
 id AA01508; Wed, 1 Apr 98 16:38:13 EST
Received: from lists.underscore.com ([199.125.85.30]) by alpha.xerox.com with
SMTP id <52131(2)>; Wed, 1 Apr 1998 13:38:19 PST
Received: from localhost (daemon@localhost) by lists.underscore.com
(8.7.5/8.7.3) with SMTP id QAA17265 for <[email-masked]>; Wed, 1 Apr
1998 16:34:51 -0500 (EST)
Received: by pwg.org (bulk_mailer v1.5); Wed, 1 Apr 1998 16:33:40 -0500
Received: (from daemon@localhost) by lists.underscore.com (8.7.5/8.7.3) id
QAA17103 for pmp-outgoing; Wed, 1 Apr 1998 16:31:54 -0500 (EST)
Message-Id: <[email-masked]>
Date: Wed, 1 Apr 1998 13:31:15 PST
From: Chuck Adams <[email-masked]>
Organization: Tektronix, Inc.
X-Mailer: Mozilla 4.03 [en] (X11; U; SunOS 5.5.1 sun4m)
Mime-Version: 1.0
To: Ira Mcdonald x10962 <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: PMP> Last call Printer MIB comment: simple localization proposal
References: <[email-masked]>
Content-Type: text/plain; charset=us-ascii
Content-Transfer-Encoding: 7bit
Sender: [email-masked]
Status: R

Ira Mcdonald x10962 wrote:
>
> Hi Lloyd,
>
> The change in the issue is that (as we noted) the IESG has adopted
> a Policy on Character Sets and Languages which is mandatory for
> all protocols which transfer text or names.  All of the MIBs issued
> since January 1998 conform to this policy.  The Printer MIB doesn't.
>
> Cheers,
> - Ira McDonald (High North)

Ira,

 Are you saying we need to revise the INTERNET DRAFT
 dated October 15, 1997 to account for a new policy
 issued in January?

Chuck Adams

---

From: Tom Hastings <[email-masked]>
Date: Thu, 2 Apr 1998 09:55:41 PST

>languish so long... I don't see how or why it would be so urgent to enforce

I know that we are all tired of the localization discussion for the
Printer MIB.  But please take a look at our proposal, because it is
much SIMPLER than last Spring's proposal.  It add no new objects or
textual conventions.  It also documents the localization of other
objects that many implemntations have done, even though RFC 1759 didn't
allow, but leaves such additional localization all optional.

So the only new requirement is to support at least the UTF-8 char set 
(like IPP).  But UTF-8 has US-ASCII in code positions 0 to 127 decimal.
So if your product only supports English, you have no extra
work, except to add a row to the localization table to indicate the char set
is UTF-8.  (You probably don't want to remove the row that says
US-English and US-ASCII, so that existing management applications will
still find US-English and US-ASCII row).

Finally, the reason for considering this proposal is that the Printer
MIB might get held up for another year applying for a waiver from the
new Policy on Character Sets and Languages of the IETF approved in 
January, if we don't make a change to follow the policy.

Tom