Subject: IPP> IPP document set - naming convention(s)

From: "Turner, Randy" <[email-masked]>
Date: Thu, 12 Mar 1998 15:36:21 -0800

Would anyone have any problem(s) splitting the protocol (not model)
document into two documents?

Document 1 would be an encoding document
Document 2 would describe how to transport the encoding over HTTP 1.1

?

Randy

---

From: Carl-Uno Manros <[email-masked]>
Date: Thu, 12 Mar 1998 15:43:44 PST

>Document 2 would describe how to transport the encoding over HTTP 1.1

Why are we getting all these "bright" ideas after the work is supposed to
be finished? I don't know if we can do the split at this stage. 

I expect that we could try to negotiate that with the RFC editor, but it
would mean actually doing another editing run and insert new
cross-references etc. It would also impact references in all the other
documents.

Carl-Uno

Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: "Turner, Randy" <[email-masked]>
Date: Thu, 12 Mar 1998 16:38:15 -0800

Yes, this is what I am doing in creating a host-to-device version of
IPP, I noticed from a design perspective that its clearer if the
encoding and transport are isolated into separate documents.

Randy

	-----Original Message-----
	From:	Jay Martin [SMTP:[email-masked]]
	Sent:	Thursday, March 12, 1998 4:28 PM
	To:	Turner, Randy
	Cc:	[email-masked]'
	Subject:	Re: IPP> IPP document set - naming convention(s)

	If the notion of "IPP-over-anything-other-than-HTTP" is ever
going
	to be proven, then splitting the doc into two components is a
great
	idea.

		...jay

----------------------------------------------------------------------
	--  JK Martin               |  Email:   [email-masked]
--
	--  Underscore, Inc.        |  Voice:   (603) 889-7000
--
	--  41C Sagamore Park Road  |  Fax:     (603) 889-2699
--
	--  Hudson, NH 03051-4915   |  Web:
http://www.underscore.com   --

----------------------------------------------------------------------

	Turner, Randy wrote:
	> 
	> This wouldn't be changing any technical specs or
semantics...just an
	> editorial move to isolate functionality. This type of change
would make
	> it easier to address transport issues without affecting the
status or
	> advancement of an encoding specification; and vice-versa. It
would also
	> make it clearer for future IPP-related documents to reference
particular
	> aspects of IPP, without bringing any additional baggage to
have to sort
	> through.
	> 
	> Randy
	> 
	>         -----Original Message-----
	>         From:   Carl-Uno Manros
[SMTP:[email-masked]]
	>         Sent:   Thursday, March 12, 1998 3:44 PM
	>         To:     Turner, Randy; [email-masked]'
	>         Subject:        Re: IPP> IPP document set - naming
convention(s)
	>         >Would anyone have any problem(s) splitting the
protocol (not
	> model)
	>         >Document 2 would describe how to transport the
encoding over
	> HTTP 1.1
	>         >
	>         >?
	>         >
	>         >Randy
	>         >
	> 
	>         Why are we getting all these "bright" ideas after the
work is
	> supposed to
	>         I expect that we could try to negotiate that with the
RFC
	> editor, but it
	>         cross-references etc. It would also impact references
in all the
	> other
	>         documents.
	> 
	>         Carl-Uno
	> 
	>         Carl-Uno Manros
	>         Principal Engineer - Advanced Printing Standards -
Xerox
	> Corporation

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Thu, 12 Mar 1998 16:48:34 PST

Hi Randy,

Considering splitting the protocol document (recently renamed
Protocol Encoding and Transport Mappings) into two documents
should definitely be delayed until after our IETF Aread
Directors report the results of IESG last call on IPP/1.0.

My two cents,
- Ira McDonald

PS - I think splitting them makes sense, but only if EACH
transport mapping (http, tcp, smtp) becomes a separate
document.

---

From: Robert Herriot <[email-masked]>
Date: Fri, 13 Mar 1998 12:05:33 -0800

I think we had this discussion in Austin as part of Tom's proposal.  We 
decided to change the name of the protocol document. Its new name is 
“Internet Printing Protocol/1.0: Encoding and Transport”.  We decided not to 
split the two documents.

Although the IPP encoding is, in theory, transport independent.  In fact, it 
depends on HTTP chunking. With an alternate transport, we would have to 
solve the chunking problem.  It would be more efficient if the document data 
were the only part chunked, but that would require a change to the encoding 
layer.

So, at this point, I don't endorse separating the two documents.

Bob Herriot

---

From: [email-masked]
Date: Fri, 13 Mar 1998 15:45:36 -0500

I think this issue was decided in Austin with a name change for the
Protocol document.
Considering the pain separating them now would be and having to deal with
editing all
the cross references, etc. in the IETF format is just not worth it.  When
the time comes to
map IPP to another transport then Bob or whoever is editor of that protocol
document
can make the split.

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

To:   [email-masked]
cc:    (bcc: Don Wright)
bcc:  Don Wright
Subject:  IPP> IPP document set - naming convention(s)

---

From: "Turner, Randy" <[email-masked]>
Date: Fri, 13 Mar 1998 14:05:12 -0800

This issue was not brought up in Austin. Only a name change for the
current document was an issue. As far as I can tell, including the
minutes from Austin, my split proposal is new, and is derived from my
efforts at actually doing another mapping document.

Randy

	-----Original Message-----
	From:	[email-masked] [SMTP:[email-masked]]
	Sent:	Friday, March 13, 1998 12:46 PM
	To:	[email-masked]
	Cc:	[email-masked]
	Subject:	Re: IPP> IPP document set - naming convention(s)

	I think this issue was decided in Austin with a name change for
the
	Protocol document.
	Considering the pain separating them now would be and having to
deal with
	editing all
	the cross references, etc. in the IETF format is just not worth
it.  When
	the time comes to
	map IPP to another transport then Bob or whoever is editor of
that protocol
	document
	can make the split.

	Would anyone have any problem(s) splitting the protocol (not
model)
	document into two documents?
	Document 1 would be an encoding document
	Document 2 would describe how to transport the encoding over
HTTP 1.1
	?
	Randy