Subject: IPP> PRO - Support for UTF16

From: Carl-Uno Manros <[email-masked]>
Date: Thu, 22 Jan 1998 15:18:46 PST

FYI,

I picked this up from a message just sent by Yaron Goland from Microsoft to
the WEBDAV group.

----

As far as character sets go, XML requires that all XML parsers implement
UTF8/16, DAV requires XML, therefore all implementers of DAV must support
UTF8/16.
 
----

Does this put yet another requirement on IPP implementations, if we choose
to use XML?

Carl-Uno

Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: [email-masked]
Date: Fri, 23 Jan 1998 12:46:08 -0500

Yes, we would be required to support both UTF8 and UTF16 in
just the way XML requires if we want to be able to say the IPP
uses XML.  If we only want to say that IPP uses XML-like
syntax than we could stray from that position.  Should we
decide to use XML, I don't think half a loaf is the right
way to go.

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

To:   [email-masked]
cc:   [email-masked] (bcc: Don Wright)
bcc:  Don Wright
Subject:  IPP> PRO - Support for UTF16

FYI,

Carl-Uno

Carl-Uno Manros