Subject: Re: PMP> Last call Printer MIB comment: simple localization proposal

From: [email-masked] (Ira Mcdonald x10962)
Date: Wed, 1 Apr 1998 16:05:42 PST

Hi Chuck,

Yes, I am saying that there is NO grandfather clause in the IETF
Policy on Charsets and Languages.  In fact, it provides for
REMOVING existing RFCs from the Internet 'standards track'
for non-compliance.  If you send the current I-D for the
Printer MIB (which is dated about two weeks ago, when
Lloyd changed it) to the IESG for adoption as an RFC,
it is subject (like ALL application protocols and SNMP
MIB modules) to this policy.  While a waiver is technically
possible, NONE has been granted to any IETF 'standards track'
document in the last three months.

Cheers,
- Ira McDonald (High North)

PS - If you read Tom's and my proposal, you would have noticed
that SNMPv3, LDAPv3, System Application MIB, Service Location
Protocol (SLP) and many other IETF standards are compliant.
The argument of 'current practice' won't hold water with
the IESG.

-------------------------------------------------------------
>From [email-masked] Wed Apr  1 16:44:28 1998
Date: Wed, 1 Apr 1998 13:31:15 PST
From: Chuck Adams <[email-masked]>
Organization: Tektronix, Inc.
To: Ira Mcdonald x10962 <[email-masked]>
Cc: [email-masked], [email-masked]
Subject: Re: PMP> Last call Printer MIB comment: simple localization proposal
Sender: [email-masked]
Status: R

Ira Mcdonald x10962 wrote:
> 
> Hi Lloyd,
> 
> The change in the issue is that (as we noted) the IESG has adopted
> a Policy on Character Sets and Languages which is mandatory for
> all protocols which transfer text or names.  All of the MIBs issued
> since January 1998 conform to this policy.  The Printer MIB doesn't.
> 
> Cheers,
> - Ira McDonald (High North)

Ira,

	Are you saying we need to revise the INTERNET DRAFT
	dated October 15, 1997 to account for a new policy
	issued in January?

Chuck Adams

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Wed, 1 Apr 1998 18:25:34 PST

Hi Matt,

Welcome to the PWG standards work, by the way.

I'm discouraged to have to reply that Tom's and my proposal
was NOT an "April Fool joke".  RFC 2277 does NOT say that
protocols SHOULD support UTF-8 (transform of ISO 10646,
Unicode).  It says very clearly that they SHALL support
UTF-8 and MAY support other charsets.  The Printer MIB
is not compliant.  There isn't any gray area at all.

Cheers,
- Ira McDonald (High North)
-----------------------------------------------
[Matt's note]

>From [email-masked] Wed Apr  1 21:06:17 1998
Date: Wed, 1 Apr 1998 17:53:13 PST
From: Matt Young <[email-masked]>
Organization: Hewlett Packard Business LaserJet Division
To: [email-masked]
Subject: Re: PMP> Last call Printer MIB comment: simple localization proposal
Sender: [email-masked]
Status: R

Tom Hastings wrote:
<Simple localization change proposal from Tom Hastings>

Being new to PWG activities, I'm not sure what to think about a change
like this that comes just days before the Printer MIB was to step into
the next level of standards Nirvana -- is this normal? :-)

Also being new, I'm not sure if this sort of thing is standard around
April 1st.  After looking at RFC 2277, I tend to think I must be falling
for a pretty good April Fools joke because it has lots of stuff in there
about using character sets other than UTF-8.

Just in case it really isn't an April Fools joke, here's my input: 
let's change the MIB instead to say that UTF-8 SHOULD be used for all
localization.

-- 
Matt Young
([email-masked]) Hewlett-Packard Department LaserJet Division

---

From: [email-masked]
Date: Thu, 2 Apr 1998 14:28:24 -0500

I agree with Ron.  To much, too late.

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

To:   Lloyd Young@Lexmark
cc:   [email-masked] (bcc: Don Wright)
bcc:  Don Wright
Subject:  Re: PMP> Last call Printer MIB comment: simple localization
      proposal

Lloyd,
I certainly support you position in this matter.  This was the prior
agreement and we should stick to it.
If the IETF rejects the MIB for this reason, the subject should again be
opened and all proposals given a proper review.  I don't recommend that we
add this patch at the eleventh hour.
     Ron Bergman
     Dataproducts Corp.

On Wed, 1 Apr 1998 [email-masked] wrote:
>
> Tom and Ira,
>
> You guys are certainly tenacious on this issue. My opinion is
> that this issue has been closed for some time and I do not
> see any new news that would justify opening this issue again.
> However if there are significant (close to unanimous) responses
> from members of the working group by Thursday April 2nd (tomorrow)
> stating that this issue and your proposal deserves a detailed review
> then I will agree to extend the closure date. If I do not see a huge
> rally in favor of this proposal (silence will be counted as being
> against this proposal) then the closure date of Thursday April 2nd
> will stand.
>
> Regards,
> Lloyd
>
> ------------------------------------------------------------
> Lloyd Young                       Lexmark International, Inc.
> Senior Program Manager            Dept. C14L/Bldg. 035-3
> Strategic Alliances               740 New Circle Road NW
> internet: [email-masked]     Lexington, KY 40550
> Phone: (606) 232-5150             Fax: (606) 232-6740
>
>
>