Subject: PMP> Console Lights

From: Harry Lewis <[email-masked]>
Date: Mon, 13 Jul 1998 14:48:40 -0400

I know it has been a very long time since this topic has been visited. I accept
that we changed the definition for prtConsoleOnTime and OffTime because the
previous definitions were misinterpreted. A recent reading, however, strikes me
as curious why we defined On=0 and Off=0 as undefined rather than "lights off"
as defined in RFC1759.

Again, it's not that I don't support the clarification, but this specific
wording would appear to "break" existing implementations for no reason. Can
someone say why we chose this wording?

OLD DEFINITION (RFC1759)
--------------

prtConsoleOnTime OBJECT-TYPE
    SYNTAX     Integer32
    MAX-ACCESS read-write
    STATUS     current
    DESCRIPTION
        "The on time in milliseconds of blinking of
        this light; 0 indicates off always.  If both
        prtConsoleOnTime and prtConsoleOffTime are 0,
        then the light is always off."
    ::= { prtConsoleLightEntry 2 }

prtConsoleOffTime OBJECT-TYPE
    SYNTAX     Integer32
    MAX-ACCESS read-write
    STATUS     current
    DESCRIPTION
        "The off time in milliseconds of blinking of
        this light; 0 indicates on always.  If both
        prtConsoleOnTime and prtConsoleOffTime are 0,
        then the light is always off."
    ::= { prtConsoleLightEntry 3 }

NEW DEFINITION
--------------

prtConsoleOnTime OBJECT-TYPE
    SYNTAX     Integer32
    MAX-ACCESS read-write
    STATUS     current
    DESCRIPTION
        "This object, in conjunction with
        prtConsoleOffTime, defines the current status
        of the light. If both prtConsoleOnTime and
        prtConsoleOffTime are non-zero, the lamp is
        blinking and the values presented define the
        on time and off time, respectively, in
        milliseconds. If prtConsoleOnTime is zero and
        prtConsoleOffTime is non-zero, the lamp is
        off. If prtConsoleOffTime is zero and
        prtConsoleOnTime is non-zero, the lamp is on.
        If both values are zero the status of the lamp
        is undefined."
    ::= { prtConsoleLightEntry 2 }

prtConsoleOffTime OBJECT-TYPE
    SYNTAX     Integer32
    MAX-ACCESS read-write
    STATUS     current
    DESCRIPTION
        "This object, in conjunction with
        prtConsoleOnTime, defines the current status
        of the light. If both prtConsoleOnTime and
        prtConsoleOffTime are non-zero, the lamp is
        blinking and the values presented define the
        on time and off time, respectively, in
        milliseconds. If prtConsoleOnTime is zero and
        prtConsoleOffTime is non-zero, the lamp is
        off. If prtConsoleOffTime is zero and
        prtConsoleOnTime is non-zero, the lamp is on.
        If both values are zero the status of the lamp
        is undefined."
    ::= { prtConsoleLightEntry 3 }

Harry Lewis - IBM Printing Systems

---

From: [email-masked]
Date: Tue, 21 Jul 1998 15:32:07 -0400

Harry,

I believe the new wording makes sense for these objects if 1759 is not 
considered, but I don't see the justification in changing the 0, 0 case from OFF
to Undefined when current implementations are considered.

Stuart

______________________________ Reply Separator _________________________________
Subject: PMP> Console Lights
Author:  INTERNET:[email-masked] at CSERVE
Date:    7/13/98 2:52 PM

OLD DEFINITION (RFC1759)
--------------

NEW DEFINITION
--------------

prtConsoleOnTime OBJECT-TYPE
    SYNTAX     Integer32
    MAX-ACCESS read-write
    STATUS     current
    DESCRIPTION
        "This object, in conjunction with
        prtConsoleOffTime, defines the current status 
        of the light. If both prtConsoleOnTime and 
        prtConsoleOffTime are non-zero, the lamp is 
        blinking and the values presented define the on 
        time and off time, respectively, in 
        milliseconds. If prtConsoleOnTime is zero and 
        prtConsoleOffTime is non-zero, the lamp is off. 
        If prtConsoleOffTime is zero and 
        prtConsoleOnTime is non-zero, the lamp is on. 
        If both values are zero the status of the lamp 
        is undefined."
    ::= { prtConsoleLightEntry 2 }

prtConsoleOffTime OBJECT-TYPE
    SYNTAX     Integer32
    MAX-ACCESS read-write
    STATUS     current
    DESCRIPTION
        "This object, in conjunction with
        prtConsoleOnTime, defines the current status of 
        the light. If both prtConsoleOnTime and 
        prtConsoleOffTime are non-zero, the lamp is 
        blinking and the values presented define the on 
        time and off time, respectively, in 
        milliseconds. If prtConsoleOnTime is zero and 
        prtConsoleOffTime is non-zero, the lamp is off. 
        If prtConsoleOffTime is zero and 
        prtConsoleOnTime is non-zero, the lamp is on. 
        If both values are zero the status of the lamp 
        is undefined."
    ::= { prtConsoleLightEntry 3 }

---

From: [email-masked]
Date: Tue, 21 Jul 1998 15:32:01 -0400

Harry,

Stuart

OLD DEFINITION (RFC1759)
--------------

NEW DEFINITION
--------------