Subject: IPP> MOD - Should enums be 0 to 2**31-1, not -2**31 to 2**31-1?

From: Tom Hastings <[email-masked]>
Date: Wed, 3 Jun 1998 16:47:32 PDT

In section 4.1.6 'enum' it says that the "integer value is in the range
from -2**31 (MIN) to 2**31-1(MAX)."

Shouldn't enums be 0 to 2**31-1, not -2**31 to 2**31-1?

There shouldn't be negative values, correct?

We also don't happen to use 0 values either to align with SNMP MIB
enums, but I don't see that we should make the range start at 1.

Tom

---

From: "Carl Kugler" <[email-masked]>
Date: 4 Jun 1998 06:45:05 -0000

> enums, but I don't see that we should make the range start at 1.
I do.  I say make them  1 to 2**31-1.  They're just arbitrary values anyway, and it's not like we're going to run out.