Subject: RE: IPP> New IPP Model Document

From: "Turner, Randy" <[email-masked]>
Date: Fri, 29 May 1998 14:41:29 -0700

This may be a difficult requirement to meet if an IPP implementation is
built as an extension to a generic web server (like Apache).

Randy

	-----Original Message-----
	From:	Jay Martin [SMTP:[email-masked]]
	Sent:	Friday, May 29, 1998 2:34 PM
	To:	[email-masked]
	Cc:	Puru Bish
	Subject:	Re: IPP> New IPP Model Document

	After thinking about this, I tend to agree with Puru's
	statement:

	>From "Tom Hastings"
	>
	> :: In fact, the HTTP request header URI, if persent, takes
precedence"
	> (over printer-uri/job-uri operation attributes).
	> 
	> I think it should  be the other way around. I feel the
	> printer-uri/job-uri, supplied by IPP client, should have
higher
	> precedence to an IPP server than the HTTP header URI.

		...jay

----------------------------------------------------------------------
	--  JK Martin               |  Email:   [email-masked]
--
	--  Underscore, Inc.        |  Voice:   (603) 889-7000
--
	--  41C Sagamore Park Road  |  Fax:     (603) 889-2699
--
	--  Hudson, NH 03051-4915   |  Web:
http://www.underscore.com   --
	
----------------------------------------------------------------------

---

From: Jay Martin <[email-masked]>
Date: Fri, 29 May 1998 17:51:09 -0400

Randy,

> built as an extension to a generic web server (like Apache).

Are you sure about this?  I mean, I can see you point to
a certain extent, but wouldn't it be advantageous for an
IPP server implemented as a front-end on a generic platform
to be used as a multiplexor to several Printers and Jobs?

On the other hand, if the HTTP request header takes precedent,
then why are we specifying printer-uri/job-uri at all at the
IPP protocol level?  Aren't we asking for trouble when the
HTTP request header and the corresponding IPP attributes don't
match (with regard to interoperability)?

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------