Subject: RE: IPP> Implementation question re.: chunking

From: "Manros, Carl-Uno B" <[email-masked]>
Date: Fri, 24 Jul 1998 10:13:44 PDT

Carl,

I think this is a good example of the things that we need to put in an
Implementor's Guide document. Formally, as we are referencing IETF's
HTTP 1.1, all IPP implementations MUST support "chunking". However, I
think it would be smart for an actual implementation to also support
using HTTP 1.0 to allow for maximum interoperability. E.g. in Xerox we
have had to base our current client code (written in Java) on HTTP 1.0,
as the JavaSoft libraries do not yet support some of the HTTP 1.1
features. These problems will disappear over time, but we also need to
get things working short term.

Carl-Uno

> -----Original Message-----
> From: Carl Kugler [mailto:[email-masked]]
> Sent: Friday, July 24, 1998 9:52 AM
> To: [email-masked]
> Subject: IPP> Implementation question re.: chunking
> 
> 
> draft-ietf-ipp-protocol-06.txt says the client and server 
> MUST support the "chunked" transfer encoding when receiving.  
> My question is:  Can we count on this?  I.e., if our client 
> always transmits requests using the "chunked" transfer 
> encoding, will we be able to interoperate with the vast 
> majority of IPP server implementations?
> 
>     -Carl
>

---

From: "Turner, Randy" <[email-masked]>
Date: Fri, 24 Jul 1998 10:48:19 -0700

Well, I'm assuming since we "last-call'd" these documents in the WG,
that everybody is in agreement that an implementation that doesn't
support chunking isn't compliant.

Randy

		-----Original Message-----
		From:	Paul Moore [mailto:[email-masked]]
		Sent:	Friday, July 24, 1998 10:25 AM
		To:	'Randy Turner'; Carl Kugler
		Cc:	[email-masked]
		Subject:	RE: IPP> Implementation question re.:
chunking

		You might find that some implementations dont support
chunking.

		> From:	Randy Turner [SMTP:[email-masked]]
		> Sent:	Friday, July 24, 1998 10:05 AM
		> To:	Carl Kugler
		> Cc:	[email-masked]
		> Subject:	Re: IPP> Implementation question re.:
chunking
		> 
		> At 04:51 PM 7/24/98 +0000, you wrote:
		> >draft-ietf-ipp-protocol-06.txt says the client and
server MUST support
		> the
		> "chunked" transfer encoding when receiving.  My
question is:  Can we count
		> on this?  I.e., if our client always transmits
requests using the
		> "chunked"
		> transfer encoding, will we be able to interoperate
with the vast majority
		> of IPP server implementations?
		> >
		> >    -Carl
		> 
		> 
		> There are no vast majority of IPP server
implementations (yet). I think
		> the
		> only worry is if someone plans to deploy IPP behind a
generic web server
		> that doesn't support chunking. However, Apache and
most other of the more
		> popular HTTP/1.1 servers will support this. It should
definitely be a
		> bullet item (checkoff item) at the upcoming bake-off,
however.
		> Randy