Subject: RE: IPP> Re: New IPP Scheme

From: [email-masked]
Date: Thu, 16 Jul 1998 12:55:00 -0400

Carl:

The implementation MUST support port 631 however, mine is administratively
set to only OPERATE on port 80.  The code is compliant.

Don

"Carl Kugler" <[email-masked]> on 07/16/98
12:18:26 PM

To:   [email-masked]
cc:    (bcc: Don Wright)
bcc:  Don Wright
Subject:  RE: IPP> Re: New IPP Scheme

...
> Sorry Larry, but my printer isn't on the default IPP port of 631.  Mine
is
> on 80 so my URL is exactly right.  Not all implementations MUST be on
631.
...
That's not how I read ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630

It says "It is REQUIRED that a printer implementation support HTTP over the
IANA assigned Well Known Port 631...".  Therefore, a conforming
implementation MUST be on 631, although it might also be on some other port
simultaneously.

-----
Original Message: http://www.findmail.com/list/ipp/?start=4106
Start a FREE email list at http://www.FindMail.com/

---

From: "Carl Kugler" <[email-masked]>
Date: 16 Jul 1998 17:24:17 -0000

> set to only OPERATE on port 80.  The code is compliant.
Hmmm... I think we need some clarification in the wording here, because I think it's ambiguous as it stands.  Here's another quote:  "IPP server implementations MUST offer IPP services using HTTP over the IANA assigned Well Known Port 631 (the IPP default port). IPP server implementations may support other ports, in addition to this port."

So you read "suport" and "offer IPP services" to mean "can be configured to listen on" rather than "is required to listen on"?

    -Carl

> Start a FREE email list at http://www.FindMail.com/

-----
Original Message: http://www.findmail.com/list/ipp/?start=4138
Start a FREE email list at http://www.FindMail.com/

---

From: Jay Martin <[email-masked]>
Date: Thu, 16 Jul 1998 14:08:46 -0400

I believe that if a product offers compliant operation--but also
offers configuration options to disable compliant operation--that
the product is still considered compliant.

Letting the customer do what the CUSTOMER wants should be ok, right?

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

---

From: Robert Herriot <[email-masked]>
Date: Thu, 16 Jul 1998 12:09:49 -0700

I wrote the sentences that you are asking about.  I tried to pick words that 
would be unambiguous.

The intention is that IPP software must be able to listen on port 631 and 
may be able to listen on other ports.
If such software allows an administrator to configure the ports, then such 
an adminstrator may be able to have IPP software listen other ports, such as 
port 80 and might make it be the only port that the IPP server listens on.  
The customer has the right to do what he wants, even if we don't think it is 
the wisest choice.

Bob Herriot

At 10:24 AM 7/16/98 , Carl Kugler wrote:
>Hmmm... I think we need some clarification in the wording here, because I
think it's ambiguous as it stands.  Here's another quote:  "IPP server
implementations MUST offer IPP services using HTTP over the IANA assigned Well
Known Port 631 (the IPP default port). IPP server implementations may support
other ports, in addition to this port."
>
>So you read "suport" and "offer IPP services" to mean "can be configured to
listen on" rather than "is required to listen on"?

---

From: "Carl Kugler" <[email-masked]>
Date: 16 Jul 1998 21:09:37 -0000

--=====================_160811464==_.ALT
> Content-Type: text/plain; charset="us-ascii"
> 

What I find ambiguous, then, are the words "in addition to" and "as well" in these sentences:

    "IPP server implementations may support other ports, in addition to this port."

    "It is REQUIRED that a printer implementation support HTTP over the IANA assigned Well Known Port 631 (the IPP default port), though a printer implementation may support HTTP over port some other port as well." 

Maybe it should say:

    "It is REQUIRED that a printer implementation support HTTP over the IANA assigned Well Known Port 631 (the IPP default port), though a printer implementation may be configured to listen on some other port instead." 

    -Carl

> --=====================_160811464==_.ALT
> Content-Type: text/html; charset="us-ascii"
> 
> <html>
> <font size=3>I wrote the sentences that you are asking about.&nbsp; I
> tried to pick words that <br>
> would be unambiguous.<br>
> <br>
> <br>
> may be able to listen on other ports.<br>
> If such software allows an administrator to configure the ports, then
> such <br>
> an adminstrator may be able to have IPP software listen other ports, such
> as <br>
> port 80 and might make it be the only port that the IPP server listens
> on.&nbsp; <br>
> The customer has the right to do what he wants, even if we don't think it
> is <br>
> the wisest choice.<br>
> <br>
> Bob Herriot<br>
> <br>
> <br>
> At 10:24 AM 7/16/98 , Carl Kugler wrote:<br>
> &gt;Carl:<br>
> &gt;&gt; <br>
> &gt;&gt; The implementation MUST support port 631 however, mine is
> administratively<br>
> &gt;&gt; set to only OPERATE on port 80.&nbsp; The code is
> compliant.<br>
> &gt;&gt; <br>
> &gt;&gt; Don<br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;Hmmm... I think we need some clarification in the wording here,
> because I think it's ambiguous as it stands.&nbsp; Here's another
> quote:&nbsp; &quot;IPP server implementations MUST offer IPP services
> using HTTP over the IANA assigned Well Known Port 631 (the IPP default
> port). IPP server implementations may support other ports, in addition to
> this port.&quot;<br>
> &gt;<br>
> &gt;So you read &quot;suport&quot; and &quot;offer IPP services&quot; to
> mean &quot;can be configured to listen on&quot; rather than &quot;is
> required to listen on&quot;?<br>
> &gt;<br>
> &gt;&nbsp;&nbsp;&nbsp; -Carl<br>
> &gt;<br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; &quot;Carl Kugler&quot;
> &lt;[email-masked]&gt; on 07/16/98<br>
> &gt;&gt; 12:18:26 PM<br>
> &gt;&gt; <br>
> &gt;&gt; To:&nbsp;&nbsp; [email-masked]<br>
> &gt;&gt; cc:&nbsp;&nbsp;&nbsp; (bcc: Don Wright)<br>
> &gt;&gt; bcc:&nbsp; Don Wright<br>
> &gt;&gt; Subject:&nbsp; RE: IPP&gt; Re: New IPP Scheme<br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; ...<br>
> &gt;&gt; &gt; Sorry Larry, but my printer isn't on the default IPP port
> of 631.&nbsp; Mine<br>
> &gt;&gt; is<br>
> &gt;&gt; &gt; on 80 so my URL is exactly right.&nbsp; Not all
> implementations MUST be on<br>
> &gt;&gt; 631.<br>
> &gt;&gt; ...<br>
> &gt;&gt; That's not how I read
> <a href="ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630" eudora="autourl"><font size=3>ftp://ftp.pwg.org/pub/pwg/ipp/new_PRO/ipp-pro-980630</a><br>
> <font size=3>&gt;&gt; <br>
> &gt;&gt; It says &quot;It is REQUIRED that a printer implementation
> support HTTP over the<br>
> &gt;&gt; IANA assigned Well Known Port 631...&quot;.&nbsp; Therefore, a
> conforming<br>
> &gt;&gt; implementation MUST be on 631, although it might also be on some
> other port<br>
> &gt;&gt; simultaneously.<br>
> &gt;&gt; <br>
> &gt;&gt; -----<br>
> &gt;&gt; Original Message:
> <a href="http://www.findmail.com/list/ipp/?start=4106" eudora="autourl"><font size=3>http://www.findmail.com/list/ipp/?start=4106</a><br>
> <font size=3>&gt;&gt; Start a FREE email list at
> <a href="http://www.findmail.com/" eudora="autourl"><font size=3>http://www.FindMail.com/</a><br>
> <font size=3>&gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;&gt; <br>
> &gt;<br>
> &gt;<br>
> &gt;<br>
> &gt;-----<br>
> &gt;Original Message:
> <a href="http://www.findmail.com/list/ipp/?start=4138" eudora="autourl"><font size=3>http://www.findmail.com/list/ipp/?start=4138</a><br>
> <font size=3>&gt;Start a FREE email list at
> <a href="http://www.findmail.com/" eudora="autourl"><font size=3>http://www.FindMail.com/</a><br>
> <font size=3>&gt; </font><br>
> </html>
> 
> --=====================_160811464==_.ALT--
> 
> 
> 

-----
Original Message: http://www.findmail.com/list/ipp/?start=4144
Start a FREE email list at http://www.FindMail.com/

---

From: Jay Martin <[email-masked]>
Date: Thu, 16 Jul 1998 17:29:49 -0400

> Maybe it should say:
> 
> "It is REQUIRED that a printer implementation support HTTP over
> the IANA assigned Well Known Port 631 (the IPP default port), though
> a printer implementation may be configured to listen on some other port
> instead."

Or perhaps:

  "...may be configured to listen on one or more ports instead."
                                     ^^^^^^^^^^^
	...jay