Subject: RE: IPP> Re: Implications of introducing new scheme and port for existing HTTP servers

From: Josh Cohen <[email-masked]>
Date: Mon, 1 Jun 1998 10:51:56 -0700

I think its fine to have a new default dest port 
associated with IPP, but a new URL scheme seems like more
trouble than may be apparent.

For one, even though IPP is a different service than HTTP,
an IPP client *is* speaking HTTP, IMHO.  HTTP is used as
a layer underneath IPP.  So, I think the URL scheme
should continue to be http://..

Using a new URL scheme will certainly break compatibility
with existing proxies.  Proxy server's encountering a new
scheme will fail unless they are modified to understand it.

As I've stated before, I think the best way to differentiate
the service and remain compatible with existing proxy servers
is to use a new method on the request line.

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]
> Sent: Monday, June 01, 1998 10:31 AM
> To: Carl-Uno Manros; [email-masked]
> Cc: [email-masked]
> Subject: IPP> Re: Implications of introducing new scheme and port for
> existing HTTP servers
> 
> 
> Carl-Uno,
> 	By "scheme" in the text below, do you mean a
> new HTTP method, parallel to GET and POST, or something
> else?
> 		regards,
> 			Ted Hardie
> 			NASA NIC
> 
> > 1) the introduction of a new scheme called "ipp"
> > 2) the introduction a new default port number for IPP servers.
> >
> > Before the IPP WG responds to those suggestions, the IPP WG 
> would like to
> > get some advice from the HTTP WG on the implications of 
> such a change.
> > In particular, we want some feedback on how easy or 
> difficult it would be
> > to configure existing web servers to accomodate the 
> suggested changes.
>

---

From: Jay Martin <[email-masked]>
Date: Mon, 01 Jun 1998 15:10:11 -0400

Josh,

> is to use a new method on the request line.

How would a typical proxy server deal with a new method?
(Please forgive my ignorance here.)  Or do proxies
handle data entirely by port number such that the proxied
request is opaque?

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------