Subject: PWG-ANNOUNCE> Last Call: New Printer MIB Enums for FIN MIB

From: Ron Bergman <[email-masked]>
Date: Wed, 27 May 1998 10:37:35 -0700 (Pacific Daylight Time)

The Finisher MIB has defined several new enumerations to be added to 
the PrtAlertGroupTC and the PrtMarkerSuppliesTypeTC.  These are being 
added to the Textual Conventions in the Printer MIB, rather than 
creating new TCs exclusively for the Finisher MIB, because the 
Finisher MIB is defines as an extension of the Printer MIB and these 
new enums logically belong within the above named groups.

This announcement is a last call for comments regarding the addition 
of these new enumeration values.  

All comments should be directed to the PWG-ANNOUNCE mail list.

The last call for comments will close on June 12, 1998.

1.  Alert Group enumerations:

PrtAlertGroupTC ::= TEXTUAL-CONVENTION
-- This value is a type 1 enumeration for values in the range
-- 1 to 29.
-- Values of 30 and greater are type 2 enumerations and are
-- for use in other MIBs that augment tables in the Printer
-- MIB. Therefore, other MIBs may assign alert codes of 30 or
-- higher to use the alert table from the Printer MIB without
-- requiring revising and re-publishing this document.
    STATUS     current
    DESCRIPTION
      "The type of sub-unit within the printer model that this
       alert is related.  Input, output, and markers are
       examples of printer model groups, i.e., examples of
       types of sub-units. Wherever possible, these
       enumerations match the sub-identifier that identifies
       the relevant table in the printer MIB.

       NOTE: Alert type codes have been added for the host
       resources MIB storage table and device table. These
       additional types are for situations in which the
       printer's storage and device objects
       must generate alerts (and possibly traps for critical
       alerts)."
    SYNTAX     INTEGER {
         other(1),
         hostResourcesMIBStorageTable(3),
         hostResourcesMIBDeviceTable(4),
         generalPrinter(5),
         cover(6),
         localization(7),
         input(8),
         output(9),
         marker(10),
         markerSupplies(11),
         markerColorant(12),
         mediaPath(13),
         channel(14),
         interpreter(15),
         consoleDisplayBuffer(16),
         consoleLights(17),
         alert(18),
    -- Added values for Finisher MIB
         finDevice(30),
         finSupply(31),
         finSupplyMediaInput(32)
    -- End of added values
         }

2. Marker Supplies Type enumerations:

PrtMarkerSuppliesTypeTC ::= TEXTUAL-CONVENTION
-- This is a type 3 enumeration 
    STATUS       current
    DESCRIPTION
      "The type of this supply."
    SYNTAX       INTEGER {
         other(1),
         unknown(2),
         toner(3),
         wasteToner(4),
         ink(5),
         inkCartridge(6),
         inkRibbon(7),
         wasteInk(8),
         opc(9),    --photo conductor
         developer(10),
         fuserOil(11),
         solidWax(12),
         ribbonWax(13),
         wasteWax(14),
         fuser(15),
         coronaWire(16),
         fuserOilWick(17),
         cleanerUnit(18),
         fuserCleaningPad(19),
         transferUnit(20),
         tonerCartridge(21),
         fuserOiler(22),
    -- Added values for Finisher MIB
         water(23),
         wasteWater(24),
         glueWaterAdditive(25),
         wastePaper(26),
         bindingSupply(27),
         bandingSupply(28),
         stitchingWire(29),
         shrinkWrap(30),
         paperWrap(31),
         staples(32),
         inserts(33),
         covers(34)
    -- End of added values
     }

----------------------------------------------------
	Ron Bergman
	Dataproducts Corp.

---

From: Paul Gloger <[email-masked]>
Date: Wed, 27 May 1998 23:12:03 PDT

Ron,

Great work, thank you.

My one comment:  Please remind me...  Assuming this proposal is approved,
where will the result be recorded?  In what publicly accessible place does
the PWG always maintain the list of approved extensions to the enums?

Thanks again,
Paul

---------------------------------------
Date: Wed, 27 May 1998 10:37:35 PDT
From: Ron Bergman <[email-masked]>
To: [email-masked]
cc: Lloyd Young <[email-masked]>
Subject: PWG-ANNOUNCE> Last Call: New Printer MIB Enums for FIN MIB

....

---

From: Ron Bergman <[email-masked]>
Date: Fri, 29 May 1998 07:42:55 -0700 (Pacific Daylight Time)

Paul,

Currently the newly registered enums will be posted on the PWG FTP site
(ftp://ftp.pwg.org/pub/pwg).  I am not sure of the exact URL, but I will
send a notice out when the last call expires and the enums are approved.

Tom Hastings has already posted the new enums that were added to the Job
MIB.

I do not know if an HTTP link is included to this directory.

Hope this info helps.

	Ron Bergman
	Dataproducts Corp.

---

From: Tom Hastings <[email-masked]>
Date: Fri, 29 May 1998 17:08:11 PDT

Ron wondered where the registration proposals and approvals would be
posted.  According to our PWG process white paper reviewed at the 5/20 PWG 
meeting, section 7. Maintenance, step 4:

  4. To make the status of proposed registrations and clarifications clear to
   PWG participants and others, the Maintenance Editor will keep them in the 
   appropriate sub-directory 
      ftp://ftp.pwg.org/pub/pwg/xxx/DOC/proposed-registrations
      ftp://ftp.pwg.org/pub/pwg/xxx/DOC/proposed-clarifications
   where xxx is the project and DOC is the base document against which 
   changes are proposed.

In this case, the xxx is pmp, and the DOC is, say, rfc1759, if we don't
have a new RFC, or the new rfcnnnn for the Draft Printer MIB.

and step 8 says:

  8. If, in the opinion of the WG Chair, the Last Call discussions achieve a
   consensus of approval, the Maintenance Editor will move the approved
   registration or clarification to the appropriate sub-directory for each
   project 
      ftp://ftp.pwg.org/pub/pwg/xxx/DOC/approved-registrations
      ftp://ftp.pwg.org/pub/pwg/xxx/DOC/approved-clarifications
   and announce the approval to the entire PWG via the PWG-ANNOUNCE DL. 

In this case, the xxx is pmp, and the DOC is, say, rfc1759, if we don't
have a new RFC for the Draft Printer MIB, or the new rfcnnnn for the Draft 
Printer MIB, if we do.

Tom

---

From: Tom Hastings <[email-masked]>
Date: Thu, 4 Jun 1998 18:15:36 PDT

A simple addition to the proposal:

At its last meeting the FIN WG decided NOT to include the
Finisher MIB attributes table as a source of traps because we couldn't
see how an attribute table could generate traps.  However, we could
have an event when a Finisher MIB attribute changes (added, removed,
or value changed).  For example, a constraint might change when a new
medium type or size was loaded.

If we did allow for alerts on attribute changes, the alert group
would be numbered 33.  And would mean that all four tables in the 
Finisher MIB, corresponding to 30, 31, 32 and 33, would have alert 
code numbers with the same value as the sub-identifier for the table.

The event that would apply would be configurationChanged(7)

I propose that finAttributeTable(33) be added as follows
to the end of the prtAlertGroupTC: 

    finAttributeTable(33)   -- used with configurationChanged(7) alert

Thanks,
Tom