Subject: Re: IPP> MOD/PRO - simple proposal for providing dictionary-like capability

From: [email-masked] (Ira Mcdonald x10962)
Date: Wed, 1 Apr 1998 16:16:45 PST

Hi Jay and Paul,

Yes, I'm interested to hear more about the 'decision' to do
IPPv2 on XML in Maui.  It sure didn't widely penetrate the
mailing list for the rest of us people.  And it sure TOTALLY
breaks backward compatibility.

Cheers,
- Ira McDonald (High North)
-----------------------------------------------------------
[Jay's note]
>From [email-masked] Wed Apr  1 15:37:41 1998
Date: Wed, 1 Apr 1998 12:19:57 PST
From: Jay Martin <[email-masked]>
Organization: Underscore, Inc.
To: Paul Moore <[email-masked]>
Cc: [email-masked]
Subject: Re: IPP> MOD/PRO - simple proposal for providing dictionary-like 
		capability
Sender: [email-masked]
Status: R

Paul,

Sorry, but I wasn't able to attend the Maui meeting, so perhaps
you can clarify something about the perceptions of "IPP v2"
for me.

The way I read your message (below), IPP v2 will have a totally
different encoding than IPP v1 (ie, non-standard BER-like
quasi-binary encoding vs. structured text).

Is this correct?

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

---

From: Paul Moore <[email-masked]>
Date: Wed, 1 Apr 1998 16:15:48 -0800

As I said below - this was an informal consensus. Everybody I spoke to about
it said that they thought that we would have to do XML to handle things like
dictionaries, etc.

Yes it completely breaks compatability - this is why I raised the issue as
strongly as I did. I still think that the Maui decision was wrong (but that
is water under the bridge now).

> -----Original Message-----
> From:	[email-masked] [SMTP:[email-masked]]
> Sent:	Wednesday, April 01, 1998 4:17 PM
> To:	[email-masked]; Paul Moore
> Cc:	[email-masked]
> Subject:	Re: IPP> MOD/PRO - simple proposal for providing
> dictionary-like capability
> 
> Hi Jay and Paul,
> 
> Return-Path: <[email-masked]>
> Received: from zombi (zombi.eso.mc.xerox.com) by snorkel.eso.mc.xerox.com
> (4.1/XeroxClient-1.1)
> 	id AA19155; Wed, 1 Apr 98 15:37:40 EST
> Received: from alpha.xerox.com by zombi (4.1/SMI-4.1)
> 	id AA24661; Wed, 1 Apr 98 15:31:25 EST
> Received: from lists.underscore.com ([199.125.85.30]) by alpha.xerox.com
> with SMTP id <52295(4)>; Wed, 1 Apr 1998 12:31:32 PST
> Received: from localhost (daemon@localhost) by lists.underscore.com
> (8.7.5/8.7.3) with SMTP id PAA16498 for <[email-masked]>; Wed,
> 1 Apr 1998 15:28:01 -0500 (EST)
> Received: by pwg.org (bulk_mailer v1.5); Wed, 1 Apr 1998 15:20:22 -0500
> Received: (from daemon@localhost) by lists.underscore.com (8.7.5/8.7.3) id
> PAA15724 for ipp-outgoing; Wed, 1 Apr 1998 15:20:09 -0500 (EST)
> Message-Id: <[email-masked]>
> X-Mailer: Mozilla 4.03 [en] (WinNT; I)
> Mime-Version: 1.0
> References:
> <[email-masked]>
> Content-Type: text/plain; charset=us-ascii
> Content-Transfer-Encoding: 7bit

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 1 Apr 1998 16:39:19 -0800

We did talk about future IPPv2 encodings and transports, but no formal
WG concensus was declared since it wouldn't have been appropriate when
we don't even have version 1.0 documents at "proposed" yet.

Randy

	-----Original Message-----
	From:	Paul Moore [SMTP:[email-masked]]
	Sent:	Wednesday, April 01, 1998 4:16 PM
	To:	[email-masked]'; [email-masked]
	Cc:	[email-masked]
	Subject:	RE: IPP> MOD/PRO - simple proposal for providing

	As I said below - this was an informal consensus. Everybody I
spoke to about
	it said that they thought that we would have to do XML to handle
things like
	dictionaries, etc.

	Yes it completely breaks compatability - this is why I raised
the issue as
	strongly as I did. I still think that the Maui decision was
wrong (but that
	is water under the bridge now).

	> - Ira McDonald (High North)
dictionary-like

---

From: Carl-Uno Manros <[email-masked]>
Date: Wed, 01 Apr 1998 23:00:11 -0800

As far as I remember, we said that we might revisit the subject for a later
version of IPP, possibly in combination with a new mapping onto e.g. HTTP NG,
at which time missing XML features will hopefully also be stable. Anybody can
speculate about what they would prefer to see in a future IPP version, for which
we do not even have a plan yet. In addition, this kind of decision is never
made in neither a PWG nor an IETF meeting; decisions are made by consensus
on the DL, in case somebody has missed that important piece of information.

There are certainly other possible solutions for the dictionary attribute
than using XML, please read Tom's latest proposal on how it can be done with
the current IPP tools for syntax and encoding.

Carl-Uno

---