Subject: IPP> PRO Where are the operation-id enums specified?

From: Carl Kugler <[email-masked]>
Date: Wed, 15 Apr 1998 16:35:17 -0400

Where are the operation-id enumerations specified?

 -Carl

---

From: Carl Kugler <[email-masked]>
Date: Wed, 15 Apr 1998 19:17:01 -0400

Thanks!   I was hunting in the wrong document.  BTW while searching for
operation-id I noticed a small document problem in MOD:
 15.3.2 Validate operation identifier
 The Printer object checks to see if the "operation-id" attribute
supplied by the client
 is supported as indicated in the Printer object's
"printer-operations-supported" attribute.

I don't think "printer-operations-supported" is a defined attribute.

  - Carl

[email-masked] on 04/15/98 04:19:59 PM
Please respond to [email-masked]
To: Carl Kugler/Boulder/IBM@ibmus
cc:
Subject: Re: IPP> PRO Where are the operation-id enums specified?

>Where are the operation-id enumerations specified?

IPP/1.0: Model and Semantics

4.4.13 operations-supported (1setOf type2 enum)
This MANDATORY Printer attribute specifies the set of supported
operations for this Printer object and contained Job objects.  No 32-
bit enum value for this attribute SHALL exceed 0x8FFF, since these
values are passed in two octets in each Protocol request [IPP-PRO].

The following standard values are defined:

  Value               Operation Name
  -----------------   -------------------------------------
  0x0000              reserved, not used
  0x0001              reserved, not used
  0x0002              Print-Job
  0x0003              Print-URI
  0x0004              Validate-Job
  0x0005              Create-Job
  0x0006              Send-Document
  0x0007              Send-URI
  0x0008              Cancel-Job
  0x0009              Get-Job-Attributes
  0x000A              Get-Jobs
  0x000B              Get-Printer-Attributes
  0x000C-0x3FFF       reserved for future operations
  0x4000-0x8FFF       reserved for private exteAt 01:35 PM 4/15/98 PDT, you
wrote: