Subject: PMP> Printer MIB to follow new PWG process?

From: [email-masked]
Date: Thu, 2 Jul 1998 13:09:02 -0400

This is in response to Tom's question about whether the
Printer MIB should follow the new PWG process. My simple
answer is no. The Printer MIB is in a semi-dormant state
waiting on the HR MIB to progress to IETF Draft Standard.
I am willing to perform minor edits and corrections to the
document as things come up. I do not see the value in sending
the Printer MIB through a new process in its final stages.
Regards,
Lloyd
------------------------------------------------------------
Lloyd Young                       Lexmark International, Inc.
Senior Program Manager            Dept. C08L/Bldg. 035-3
Strategic Alliances               740 New Circle Road NW
internet: [email-masked]     Lexington, KY 40550
Phone: (606) 232-5150             Fax: (606) 232-6740

---

From: Chuck Adams <[email-masked]>
Date: Thu, 02 Jul 1998 10:52:49 -0700

PMP,

> the Printer MIB through a new process in its final stages.

	I agree with Lloyd.

Chuck Adams
Tektronix, Inc.

---

From: Ron Bergman <[email-masked]>
Date: Thu, 2 Jul 1998 10:53:18 -0700 (Pacific Daylight Time)

Lloyd,

I fully support your position.  Especially in this case where the changes
are required for another document, have been fully review by the group
developing the document, and were twice sent out for last call comments
with only 1 response which resulted in the second last call.

Let's just be done with it.

	Ron Bergman
	Dataproducts Corp.

---

From: Tom Hastings <[email-masked]>
Date: Fri, 3 Jul 1998 14:52:49 PDT

Lloyd,

I see I wasn't very clear about my proposal to follow the new PWG process.
My subject line was certainly mis-leading too.  It should have been:

PMP> Printer MIB enum registration to follow new PWG process?

I was not suggesting that we vote on the Printer MIB draft and get
Formal Approval of that.  I agree that would be out of order.

I was only suggesting that the enum registrations follow the new PWG process
for enum registration and have a Formal Approvement, not the Printer MIB 
document itself.

So I was suggesting that at the PWG meeting next week during the PMP
status, we could just take a Formal Approval vote on the registration
of the new enums that the Finisher MIB needs.  It should take about a
minute.  We've done the Last Call according to the new PWG process.

Tom

At 13:06 6/30/98 PDT, Tom Hastings wrote:
>Lets follow our new PWG Process (just posted in /pub/pwg/general).
>
>We've now past the Last Call and need the Formal Approval step.
>
>Currently Formal Approval is a vote by organization.  It can be conducted
>either at a meeting or on the PMP mailing list (after announcement
>on the PWG-ANNOUNCE mailing list).
>
>Since the meeting is coming up we could do the vote during the Printer MIB
>status section of the PWG meeting.  On the other hand, since the 
>Printer MIB WG is fairly dormant, we might want to take the vote on the
>mailing list.  Ron's and/or Lloyd's call, I think.
>
>Tom
>
>
>At 08:19 6/29/98 PDT, Ron Bergman wrote:
>>The last call for comments on the additional Printer MIB enums has expired.
>>The following changes for the Finisher MIB will be added.
>>
>>
>>1.  Alert Group enumerations:
>>
>>PrtAlertGroupTC ::= TEXTUAL-CONVENTION
>>-- This value is a type 1 enumeration for values in the range
>>-- 1 to 29.
>>-- Values of 30 and greater are type 2 enumerations and are
>>-- for use in other MIBs that augment tables in the Printer
>>-- MIB. Therefore, other MIBs may assign alert codes of 30 or
>>-- higher to use the alert table from the Printer MIB without
>>-- requiring revising and re-publishing this document.
>>    STATUS     current
>>    DESCRIPTION
>>      "The type of sub-unit within the printer model that this
>>       alert is related.  Input, output, and markers are
>>       examples of printer model groups, i.e., examples of
>>       types of sub-units. Wherever possible, these
>>       enumerations match the sub-identifier that identifies
>>       the relevant table in the printer MIB.
>>
>>       NOTE: Alert type codes have been added for the host
>>       resources MIB storage table and device table. These
>>       additional types are for situations in which the
>>       printer's storage and device objects
>>       must generate alerts (and possibly traps for critical
>>       alerts)."
>>    SYNTAX     INTEGER {
>>         other(1),
>>         hostResourcesMIBStorageTable(3),
>>         hostResourcesMIBDeviceTable(4),
>>         generalPrinter(5),
>>         cover(6),
>>         localization(7),
>>         input(8),
>>         output(9),
>>         marker(10),
>>         markerSupplies(11),
>>         markerColorant(12),
>>         mediaPath(13),
>>         channel(14),
>>         interpreter(15),
>>         consoleDisplayBuffer(16),
>>         consoleLights(17),
>>         alert(18),
>>    -- Values for Finisher MIB
>>         finDevice(30),
>>         finSupply(31),
>>         finSupplyMediaInput(32),
>>         finAttributeTable(33)
>>    -- End of values for Finisher MIB
>>         }
>>
>>
>>2. Marker Supplies Type enumerations:
>>
>>PrtMarkerSuppliesTypeTC ::= TEXTUAL-CONVENTION
>>-- This is a type 3 enumeration 
>>    STATUS       current
>>    DESCRIPTION
>>      "The type of this supply."
>>    SYNTAX       INTEGER {
>>         other(1),
>>         unknown(2),
>>         toner(3),
>>         wasteToner(4),
>>         ink(5),
>>         inkCartridge(6),
>>         inkRibbon(7),
>>         wasteInk(8),
>>         opc(9),    --photo conductor
>>         developer(10),
>>         fuserOil(11),
>>         solidWax(12),
>>         ribbonWax(13),
>>         wasteWax(14),
>>         fuser(15),
>>         coronaWire(16),
>>         fuserOilWick(17),
>>         cleanerUnit(18),
>>         fuserCleaningPad(19),
>>         transferUnit(20),
>>         tonerCartridge(21),
>>         fuserOiler(22),
>>    -- Values for Finisher MIB
>>         water(23),
>>         wasteWater(24),
>>         glueWaterAdditive(25),
>>         wastePaper(26),
>>         bindingSupply(27),
>>         bandingSupply(28),
>>         stitchingWire(29),
>>         shrinkWrap(30),
>>         paperWrap(31),
>>         staples(32),
>>         inserts(33),
>>         covers(34)
>>    -- End of values for Finisher MIB
>>     }
>>
>>
>>	Ron Bergman
>>	Dataproducts Corp.
>>
>>
>>
>>
>
>