Subject: JMP> Job MIB - trials and tribulations

From: [email-masked]
Date: Mon, 10 Nov 1997 18:08:57 -0500

After much thought and reading of the mail, I personally have come
to the conclusion that in the case of MIBs, operating under the IETF
(even if it were possible) does not really buy us anything.  Publishing
the MIB as an informational RFC and making it available on the
PWG servers as well as the IETF servers should meet the needs
of the users of a MIB.  That really raises the question of who are
the customers of a MIB.  In my mind, the end-user of a printer is
not the customer of the MIB rather the printer manufacturers and
the printer management utilities developers are really the customers.
As an IT community, we all understand what is really going on and
what is important - a widely implemented and functionally complete
standard -- not one necessarily blessed by the IETF.  Considering the
membership of this group and the effort that has gone into the
development of the Job MIB, I really believe we will have both.  While
there may be technically astute customers who may specify that a product
they are going to buy must support specific standards, it is obvious
to me that for Job management, if they chose to specify a
standard, they can only specify our Job MIB -- there simply is
no competing standard.

Therefore, I strongly urge this group to discontinue its efforts
to place the Job MIB in the IETF MIB OID space and simply
utilize the enterprise space we have obtained for the PWG.
We can learn from what the IETF has done, embracing the
good points of the IETF process and improving on those that
don't meet our needs.

On a more technical note, I would suggest that we
consider moving the Job MIB down one level in the
OID space.  I would prefer something like

..... 2699.1.1......  Job Mib
......2699.1.2......  Finisher MIB

...... 2699.2.1 ...... maybe IPP space?
...... 2699.3.1 ..... something else using OID space

etc.

Comments!

Don

**********************************************
* Don Wright                 [email-masked] *
* Manager, Strategic Alliances and Standards *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

---

From: Jay Martin <[email-masked]>
Date: Wed, 12 Nov 1997 10:40:53 -0500

Don,

> (even if it were possible) does not really buy us anything.

Note that, to date, there have been no objections whatsoever to
the notion of having the PWG maintain its own standards.  This is
a good sign, I believe.

> ...... 2699.3.1 ..... something else using OID space

What is your thinking here?  I mean, what is the significance
of putting JMP/FIN under ...2699.1 versus having IPP under .3,
etc?  Are you in some way suggesting a set of categories for
the top-level OID (ie, .2699.1, .2699.2, etc)?

This approach sounds good to me; it's just that I'm trying to
figure out your plan here.

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------