Subject: JMP> Collated/Uncollated

From: Harry Lewis <[email-masked]>
Date: Thu, 20 Nov 1997 12:26:36 -0500

I tried to send this a couple times... appoligize if older versions catch up
later.

There hasn't been a whole lot of discussion regarding my proposal (below) other
than Ron indicating he believes it should be accepted.

I would like to modify it slightly, in a manner which I believe better
accomplishes the goal of distinguishing between collated and uncollated copies
yet results in fewer changes to the Mib.

To put it as simply as I can, I propose to add

currentCopyNumber
currentDocumentNumber
copyType

and to keep

sheetsCompletedCurrentCopy
impressionsCompletedCurrentCopy
documentCopiesCompleted
jobCopiesCompleted

The example flows the same as before:

For a 3 impression job with a request for 3 copies.

Uncollated 3/3  (copyType = External Collation)
--------------

sheetsCompleted    sheetsCompletedCurrentCopy    currentCopyNumber
---------------    --------------------------    -----------------
1                  1                             1
2                  1                             2
3                  1                             3
4                  2                             1
5                  2                             2
6                  2                             3
7                  3                             1
8                  3                             2
9                  3                             3

Collated 3/3  (copyType = Internal Collation)
------------

sheetsCompleted    sheetsCompletedCurrentCopy    currentCopyNumber
---------------    --------------------------    -----------------
1                  1                             1
2                  2                             1
3                  3                             1
4                  1                             2
5                  2                             2
6                  3                             2
7                  1                             3
8                  2                             3
9                  3                             3

The reason for the change from currentSheetNumber and currentImpressonNumber is
that there may be several sheets in the paper path, (different) impressions may
be ripping and printing at the same time etc. It's very hard to say which is
the "currentImpression" or "currentSheet" but easier to say which is the
current copy. It is easy to say which sheet has just completed (stacked).

Note that, while drivers should protect from this, it is theoretically possible
to mix collated and uncollated copies (try it with your favorite printer...
it's fun!). At this point, attributes like current copy really break down. We
feel, rather then try and define even more attributes to handle this
pathological case we should just say behavior of the MIB, at this point, is
device specific.

Harry Lewis

---

From: Jay Martin <[email-masked]>
Date: Thu, 20 Nov 1997 13:44:32 -0500

I haven't done due diligence on your proposal, Harry, but I believe
the proposal is acceptable as presented.  It's also pretty apparent
(or should be to most folks by now!) that you are not proposing
"theoretical" additions; instead, these proposals are the direct
result of IBM's current product development surrounding the proposed
Job MIB.

Real world needs always out-weigh those proposals submitted in the
vein of "just in case someone needs it"...  ;-)

Ron (Mr. Chairman): would a "deadline for objections" be possible
so that Harry et al can get a better handle on planning?

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

---

From: Ron Bergman <[email-masked]>
Date: Thu, 20 Nov 1997 10:48:40 -0800 (Pacific Standard Time)

Harry, Jay, et al,

Harry has posted the original request quite some time ago and I have not
seen any objections.  The new proposal is "close enough" to the original
that I doubt that it will raise any objections.

Unless a comment is received by the end of this week, the proposal is
declared accepted!!

	Ron

---

From: Tom Hastings <[email-masked]>
Date: Thu, 20 Nov 1997 16:29:22 PST

I agree with Harry's proposal, but want to build on it by handling
IPP where there can be multiple documents per job.

First a nit.  The examples show sheetsCompleted.  They should show
impressionsCompleted.  The examples are only true for single sided
printing, correct?  So I've changed them below and abbreviated as Impres.

As discussed on the telecon and agreed in principle by Harry, we would
need one more attribute called currentDocumentNumber.  It goes from
0 before any processing takes place to n when the nth document in the
job submission is taking place.  If a job as documents A and B, whenever
A is being processed, the currentDocumentNumber is 1, and when B is
being processed, the currentDocumentNumber is 2.  If an implementation
only supports one document jobs, this attribute NEED NOT be implemented
when implementing the others.

IPP has collated documents within a job and uncollated documents within
a job.  If a job has documents A and B, and wants n copies, collated
documents come out: A, B, A, B, ....   and uncollated documents
come out:  A, A, ..., B, B, ...

So the examples become:

For a 3 impression job with a request for 3 copies and two documents.
 
Uncollated 3/3  (copyType = External Sheet Collation - either by a physical)
--------------   output bin collator or uncollated - so user does by hand
                 and 'separate-document-uncollated-copies' is assumed)
 
                   ImpresCompleted
ImpresCompleted    CurrentCopy      currentCopyNumber  currentDocumentNumber
---------------    -----------      -----------------  ---------------------
1                  1                1                  1
2                  1                2                  1
3                  1                3                  1
4                  2                1                  1
5                  2                2                  1
6                  2                3                  1
7                  3                1                  1
8                  3                2                  1
9                  3                3                  1
10                 1                1                  2
11                 1                2                  2
12                 1                3                  2
13                 2                1                  2
14                 2                2                  2
15                 2                3                  2
16                 3                1                  2
17                 3                2                  2
18                 3                3                  2

Collated 3/3  (copyType = Internal Collation - Mopier
------------   and 'separate-document-uncollated-copies')

                   ImpressCompleted   
ImpresCompleted    CurrentCopy      currentCopyNumber  currentDocumentNumber
---------------    -----------      -----------------  ---------------------
1                  1                1                  1
2                  2                1                  1
3                  3                1                  1
4                  1                2                  1
5                  2                2                  1
6                  3                2                  1
7                  1                3                  1
8                  2                3                  1
9                  3                3                  1
10                 1                1                  2
11                 2                1                  2
12                 3                1                  2
13                 1                2                  2
14                 2                2                  2
15                 3                2                  2
16                 1                3                  2
17                 2                3                  2
18                 3                3                  2

Collated 3/3  (copyType = Internal Collation - Mopier
------------   and 'separate-document-collated-copies')

                   ImpresCompleted   
ImpresCompleted    CurrentCopy      currentCopyNumber  currentDocumentNumber
---------------    -----------      -----------------  ---------------------
1                  1                1                  1
2                  2                1                  1
3                  3                1                  1
4                  1                1                  2
5                  2                1                  2
6                  3                1                  2
7                  1                2                  1
8                  2                2                  1
9                  3                2                  1
10                 1                2                  2
11                 2                2                  2
12                 3                2                  2
13                 1                3                  1
14                 2                3                  1
15                 3                3                  1
16                 1                3                  2
17                 2                3                  2
18                 3                3                  2

It seems that it isn't possible to do External Collation with
'separate-document-collated-copies'.

We also need to divide the copyType Internal Collation enum into two enums:
   Internal Collation with 'separate-document-collated-copies'
   Internal Collation with 'separate-document-uncollated-copies'

The two are the same for one document jobs and one document implemetnations,
so we need to pick the value to use for the simple case of one document
jobs.

We also need to pick some good names, since we are overloading the 
term "collation" to mean sheets within a copy and documents within a job.

Tom