Subject: IPP>MOD maximum lengths of some strings not explicitly stated in model

From: [email-masked] (Robert Herriot)
Date: Tue, 18 Nov 1997 14:08:27 -0800

The model document specifies the maximum lengths for text, name,
keywords and octet-string, but NOT for charset, natural-language,
mimeMediaType, uri and uri-scheme.  Instead the model refers to other
documents which specify no upper bound.

Although in practice, all of these types except uri are short, probably less
that 255 bytes, the question is what must all of the interoperable
implementations minimally support.

Bob Herriot

---

From: Larry Masinter <[email-masked]>
Date: Tue, 18 Nov 1997 18:08:05 PST

> implementations minimally support.

Make it 100K bytes. That should hold them.

Honestly, is there any reason to make the minimum any smaller? Given
that the printers have to spool large documents, anyway?

Larry