Subject: PWG> Charter: Traps for use with the Job Monitoring MIB

From: Ron Bergman <[email-masked]>
Date: Tue, 17 Feb 1998 17:31:39 -0800 (Pacific Standard Time)

Here is a draft charter to stimulate some discussion regarding Job MIB
traps.  This will be reviewed at the meeting in Austin, so get your
comments in early.

I am sending this to the PWG and JMP mail list in case this is of
interest to somwone who is not on the JMP mail list. Anyone who desires 
to follow this subject in the future should join the JMP mail list.

Job Monitoring MIB Traps
------------------------

Statement of Charter:

This project shall develop an extension to the PWG Job Monitoring MIB that defines a set of 
SNMP traps related to monitoring of the status and progress of print jobs.  Examples of some 
of the conditions that will be investigated for traps are:

  + Start of Job
  + End of Job
  + Job progress information  (e.g. page counts)
  + Errors interrupting the Job
  + Job hold notification
  + Job release notification

Traps were purposely not included in the current Job Monitoring MIB in an effort to limit the 
scope of the MIB development.  In retrospect, this was an excellent decision since the Job 
Monitoring MIB proved to be a task more difficult than was initially imagined.  With the Job 
Monitoring MIB development completed, is now an appropriate time to open this effort.  

It is also now evident that most implementations of a Job Monitoring MIB, either the PWG or 
Private version, have incorporated traps.  It is the desire of the PWG to standardize the 
implementations of traps to provide for better interoperability of management applications 
and printers.

Goals:

One of the major obstacles expected in this project is the definition of a method for the 
registration of traps.  There have been several registration methods recently proposed, most 
notably in the SNMP v3 documents.  This project will examine all published methods and a 
unique method will be proposed only if an externally generated proposal is deficient. 

Methods relating to the generation and processing traps will also be included as discussion 
items.  Specific goals in this area are dependent upon the results of the findings.

Schedule:

 March meeting;
   - Establish Chairman, Editor, Secretary, etc.
   - Review charter and goals
   - Define trap types for consideration
   - Assignments for registration methods review
   - Scope effort relative to 'generation and processing traps'
   - Review and revise proposed schedule 

 April meeting;
   - Finalize charter and goals
   - First cut at traps descriptions
   - Presentation of registration methods review
   - Text for 'generation and processing traps'

 May meeting;
   - Finalize traps descriptions
   - Select registration method(s) 
   - Start registration method specification
   - Start draft of final document.

 July meeting;
   - Review registration method draft specification
   - Incorporate registration method in base document
   - First review of final document 

 November meeting;
   - Final document ready to submit to the IESG

	Ron Bergman
	Dataproducts Corp.

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Tue, 17 Feb 1998 20:00:12 PST

Hi Ron,

Would you consider having a telecon during the upcoming PWG meeting
in March, to widen the participation on the Job Mon MIB traps
project discussion?  All of the key people at Xerox who have
participated in Xerox (private) specification of job monitoring
traps and trap registration methods are unable to attend in March
(I know - I've been checking with them).

Thanks for pushing this IMPORTANT issue along.  As the first
PWG standard and NOT an IETF standard, I believe the PWG Job
Mon MIB has a unique opportunity to address domain-specific
traps sensibly and MUCH more quickly than could be done
for an IETF 'standards track' document.

To stimultate discussion, my two cents on trap registration
1)  SNMPv3 carries way to much security baggage, to be a
    good trap registration method
2)  There AREN'T any other IETF 'standards track' trap
    registration methods
3)  A PWG standardized solution for the PWG Job Mon MIB
    could also EASILY be a PWG standardized solution
    for the IETF/PWG Printer MIB (different OID subtree)
4)  A PWG standardized solution could EASILY be SNMP
    version independent (ie, SNMPv1, SNMPv1Secure[obsolete],
    SNMPv2Historic[RFC144x series], SNMPv2[RFC 190x series],
    and SNMPv3 [RFC227x series, last month])

Cheers,
- Ira McDonald

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 18 Feb 1998 01:25:41 -0800

I'm assuming with the addition of traps for the job monitoring MIB, as
well as the existing printer MIB traps (alerts), and our desire to
include printer MIB alerts, as well as job notifications to IPP, we now
have a completely redundant, overlapping solution set ;) ;)

Randy

	-----Original Message-----
	From:	[email-masked]
[SMTP:[email-masked]]
	Sent:	Tuesday, February 17, 1998 8:00 PM
	To:	[email-masked]; [email-masked]; [email-masked]
	Subject:	Re:  PWG> Charter: Traps for use with the Job
Monitoring MIB

	Hi Ron,

	Would you consider having a telecon during the upcoming PWG
meeting
	in March, to widen the participation on the Job Mon MIB traps
	project discussion?  All of the key people at Xerox who have
	participated in Xerox (private) specification of job monitoring
	traps and trap registration methods are unable to attend in
March
	(I know - I've been checking with them).

	Cheers,
	- Ira McDonald

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 18 Feb 1998 01:25:41 -0800

Randy

	-----Original Message-----

	Hi Ron,

	Cheers,
	- Ira McDonald