Subject: [103attendees] Visa problems - need a different invitation letter

From: Balazs Lengyel <[email-masked]>
Date: Tue, 4 Sep 2018 10:29:55 +0200

Hello,

This morning the Embassy of Thailand rejected my visa application as 
they found the invitation letter lacking. They sent me a 23 page 
template in Thai language that the invitation letter should follow.

Have you had similar problems?

regards Balazs

-- 
Balazs Lengyel                       Ericsson Hungary Ltd.
Senior Specialist
Mobile: +36-70-330-7909              email: [email-masked]

---

From: Ori Finkelman <[email-masked]>
Date: Tue, 4 Sep 2018 12:33:10 +0300

Is there a requirement to get a non tourist visa ?
For tourism you don't need a visa.

On Tue, Sep 4, 2018 at 11:29 AM, Balazs Lengyel <[email-masked]
> wrote:

> Hello,
>
> This morning the Embassy of Thailand rejected my visa application as they
> found the invitation letter lacking. They sent me a 23 page template in
> Thai language that the invitation letter should follow.
>
> _______________________________________________
> 102attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/102attendees
>

-- 

*Ori Finkelman*Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189 |
[email-masked]

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 4 Sep 2018 12:14:15 +0200

At least for us Hungarians there is. For tourists we do not need
a visa, but for ANY business we do need a non-immigrant visa.

You might get away with visiting as a tourist, but I tried to do
the correct thing.

regards Balazs

On 9/4/2018 11:33 AM, Ori Finkelman
wrote:

On Tue, Sep 4, 2018 at 11:29 AM, Balazs
Lengyel <[email-masked]>
wrote:

Hello,

This morning the Embassy of Thailand rejected my visa
application as they found the invitation letter lacking.
They sent me a 23 page template in Thai language that the
invitation letter should follow.

regards Balazs

--

Balazs Lengyel                       Ericsson Hungary
Ltd.

Senior Specialist

[email-masked]

--

Ori Finkelman

Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189
| [email-masked]

---

From: Ori Finkelman <[email-masked]>
Date: Tue, 4 Sep 2018 13:27:57 +0300

Got you, thanks.

On Tue, Sep 4, 2018 at 1:14 PM, Balazs Lengyel <[email-masked]>
wrote:

> At least for us Hungarians there is. For tourists we do not need a visa,
> but for ANY business we do need a non-immigrant visa.
> You might get away with visiting as a tourist, but I tried to do the
> correct thing.
>
> regards Balazs
> On 9/4/2018 11:33 AM, Ori Finkelman wrote:
>
> On Tue, Sep 4, 2018 at 11:29 AM, Balazs Lengyel <
> [email-masked]> wrote:
>
>> Hello,
>>
> *Ori Finkelman *Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189 |
> [email-masked]
>
> --

--

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Tue, 4 Sep 2018 18:30:18 +0800

Is IETF a real business?..

Probably the only place where you're going to trade something for something
is actually the whisky BoF.

---

From: Mehmet Ersue <[email-masked]>
Date: Tue, 04 Sep 2018 13:56:06 +0300

From immigrations pov. you do business if you sell or meet with the purpose to sell products.IOW attending an IETF meeting where you have discussions is not business. 
Cheers, Mehmet
Von meinem Samsung Galaxy Smartphone gesendet.
-------- Ursprüngliche Nachricht --------Von: Balazs Lengyel <[email-masked]> Datum: 04.09.18  13:14  (GMT+03:00) An: Ori Finkelman <[email-masked]> Cc: [email-masked], 102attendees <[email-masked]>, [email-masked] Betreff: Re: [102attendees] Visa problems - need a different invitation letter 

    

          Hello,

            regards Balazs

                -- 

                Senior Specialist

                [email-masked]

        

        
        -- 

          Ori Finkelman

---

From: Balazs Lengyel <[email-masked]>
Date: Tue, 4 Sep 2018 12:57:54 +0200

The Thai embassy had a different opinion. They sad a conference
is business, not tourism. Maybe I should not have asked. :-(

regards Balazs

On 9/4/2018 12:56 PM, Mehmet Ersue
wrote:

From immigrations pov. you do business if you sell or meet
with the purpose to sell products.

IOW attending an IETF meeting where you have discussions is
not business.

Cheers,

Mehmet

Von meinem
Samsung Galaxy Smartphone gesendet.

-------- Ursprüngliche Nachricht --------

Von: Balazs Lengyel <[email-masked]>

Datum: 04.09.18 13:14 (GMT+03:00)

An: Ori Finkelman <[email-masked]>

Cc: [email-masked], 102attendees
<[email-masked]>, [email-masked]

Betreff: Re: [102attendees] Visa problems - need a
different invitation letter

At least for us Hungarians there is. For tourists we do not
need a visa, but for ANY business we do need a non-immigrant
visa.

regards Balazs

Is there a requirement to get a non tourist visa
?

On Tue, Sep 4, 2018 at 11:29 AM,
Balazs Lengyel <[email-masked]>
wrote:

Hello,

regards Balazs

--

Senior Specialist

[email-masked]

--

Ori Finkelman

Qwilt | Work: +972-72-2221647 | Mobile:
+972-52-3832189 | [email-masked]

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Tue, 4 Sep 2018 19:03:38 +0800

NB: we might want to omit CCing ietf-registrar@ within this thread in
future. Apparently each message ends up as a new support ticket.

вт, 4 сент. 2018 г., 18:58 Balazs Lengyel <[email-masked]>:

> The Thai embassy had a different opinion. They sad a conference is
> business, not tourism. Maybe I should not have asked. :-(
>
> regards Balazs
>
>
> On 9/4/2018 12:56 PM, Mehmet Ersue wrote:
>
> From immigrations pov. you do business if you sell or meet with the
> purpose to sell products.
> IOW attending an IETF meeting where you have discussions is not business.
>
> Cheers,
> Mehmet
>
> <[email-masked]>
> An: Ori Finkelman <[email-masked]> <[email-masked]>
> Cc: [email-masked], 102attendees <[email-masked]>
> Betreff: Re: [102attendees] Visa problems - need a different invitation
> letter
>

---

From: Ray Bellis <[email-masked]>
Date: Tue, 4 Sep 2018 12:48:18 +0100

> business, not tourism. Maybe I should not have asked. :-(

According to this page:

<http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html>

There is (was?) such a thing as a "MICE event" which is one that is
"endorsed or sponsored by the Thailand Convention and Exhibition Burea
(TCEB)"

where the page also says:

"Foreign nationals wishing to enter the Kingdom of Thailand to attend a
MICE event, which is endorsed or sponsored by TCEB, without being
employed or working for income, are regarded as tourists"

Is there any possibility that IETF 103 could be registered as such an event?

Ray

---

From: Ilpo Järvinen <[email-masked]>
Date: Tue, 4 Sep 2018 15:09:48 +0300 (EEST)

> Is there any possibility that IETF 103 could be registered as such an event?

That magic TCEB representative has informed IETF that no visa (other than 
the tourism one) is required:
  https://www.ietf.org/mail-archive/web/ietf-announce/current/msg17996.html

-- 
 i.

---

From: Mehmet Ersue <[email-masked]>
Date: Tue, 04 Sep 2018 15:14:38 +0300

Never tell you want to do business.Actually IETF is a technical meeting.
Me
Von meinem Samsung Galaxy Smartphone gesendet.
-------- Ursprüngliche Nachricht --------Von: Balazs Lengyel <[email-masked]> Datum: 04.09.18  13:57  (GMT+03:00) An: Mehmet Ersue <[email-masked]>, Ori Finkelman <[email-masked]> Cc: [email-masked], 102attendees <[email-masked]>, [email-masked] Betreff: Re: [102attendees] Visa problems - need a different invitation letter 

    

      

      Cheers, 
      Mehmet

      
        Von meinem

      
        -------- Ursprüngliche Nachricht --------
        Von: Balazs Lengyel <[email-masked]> 
        Datum: 04.09.18 13:14 (GMT+03:00) 
        An: Ori Finkelman <[email-masked]> 
        Cc: [email-masked], 102attendees
          <[email-masked]>, [email-masked] 
        Betreff: Re: [102attendees] Visa problems - need a
          different invitation letter 

      

      

            Hello,

              regards Balazs

                  -- 

                  Senior Specialist

                  [email-masked]

          

          
          -- 

            Ori Finkelman

---

From: Ray Bellis <[email-masked]>
Date: Tue, 4 Sep 2018 13:19:51 +0100

>   https://www.ietf.org/mail-archive/web/ietf-announce/current/msg17996.html

Thanks for the link, although if that is the case it would be good if
IETF were to appear on the TCEB calendar of events such that their
endorsement is documented somewhere.

Ray

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 4 Sep 2018 15:17:53 +0200

Balazs,

I will simply print out: 

https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/
(thanks Andy!)

and go to Thailand as a tourist and mark that field in any
immigration form. If asked by a border agents, i will
say that i am attending the IETF103 technical conference. If
asked how that is tourism, i will pull the printout.

Also check if you can get to this TIMATIC page, you may need an
account at united, else check your own airline:

https://www.businesseventsthailand.com/plan-your-events/general-travel-information/visa-requirements/

When i entered hungarian data, it also showed that one does not need a
visa.

I did similarily to you for IETF Buenos Aires ask consulates in
USA/Germany what i would need to enter the country when i attend a conference,
and they could not figure it out, so they recommended me a business
visa. Through the discussion on the IETF mailing list (thanks Mehmet)
i also came to recognize that i am not doing business when i am attending
a conference (no money involved). Just that Argentina didn't have a
good web page like that above one from the Thailand ministry. But
i also went to IETF Buenos Aires fine as a tourist. Like probably most
everybody else attending IETF and who is visa exempt as a tourist.

Thats just me. No recommendation what you or anybody else should do.
You'll have to figure out yourself how much useless paper work you need in your life. 
There is still enough time to get an invitation letter from IETF and
retry to visa if thats what you want to do.

Cheers
    Toerless

On Tue, Sep 04, 2018 at 10:29:55AM +0200, Balazs Lengyel wrote:
> found the invitation letter lacking. They sent me a 23 page template in Thai
> language that the invitation letter should follow.
> 

-- 
---
[email-masked]

---

From: Niel Harper <[email-masked]>
Date: Tue, 4 Sep 2018 13:57:19 +0000

Toerless,

I'm with you on this.

The Royal Thai Embassy Washington D.C. informational web page states that visiting Thailand for the following requires a tourist visa:

            2.1 Participating in meetings, conferences or seminars

            2.2  Attending exhibitions or trade shows

            2.3 Visiting businesses or having business meetings

The URL is http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html

Regards,

-----------------------------

Niel Harper

Director, NGL & Fellowships

Internet Society

11710 Plaza America Drive

Reston, VA 20190

Email: [email-masked]

Skype: OlokunBB

Follow us on Twitter @ISOC_NextGen <https://twitter.com/ISOC_NextGen>

On 9/4/18, 9:18 AM, "103attendees on behalf of Toerless Eckert" <[email-masked] on behalf of [email-masked]> wrote:

    Balazs,

    I will simply print out: 

    (thanks Andy!)

    visa.

    Cheers

        Toerless

    > Hello,

    > 

    > This morning the Embassy of Thailand rejected my visa application as they

    > found the invitation letter lacking. They sent me a 23 page template in Thai

    > language that the invitation letter should follow.

    > 

    > Have you had similar problems?

    > 

    > regards Balazs

    > 

    > -- 

    > Balazs Lengyel                       Ericsson Hungary Ltd.

    > Senior Specialist

    > Mobile: +36-70-330-7909              email: [email-masked]

    > 

    > _______________________________________________

    > 102attendees mailing list

    > [email-masked]

    > https://www.ietf.org/mailman/listinfo/102attendees

    -- 

    ---

    [email-masked]

    -- 

    103attendees mailing list

    [email-masked]

    https://www.ietf.org/mailman/listinfo/103attendees

---

From: Ray Bellis <[email-masked]>
Date: Tue, 4 Sep 2018 15:03:14 +0100

On 04/09/2018 14:57, Niel Harper wrote:

> The Royal Thai Embassy Washington D.C. informational web page states
> that visiting Thailand for the following requires a tourist visa:
> 
> */2.1/*/Participating in meetings, conferences or seminars/
> 
> *2.2*  Attending exhibitions or trade shows/
>> *2.3* Visiting businesses or having business meetings/
>  
> The URL is
> http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html
Right, that's the same URL that I posted earlier (actually from the Thai
Embassy in Finland) but you omitted the previous sentences:

"Foreign nation wishing to enter Thailand for MICE purposes to attend a
MICE event, which endorsed or sponsored by the Thailand Convention and
Exhibition Burea (TCEB)*, to conduct the following trade or investment
activities are not regarded as “working”. They do not need a work permit
and are not required to submit a Form WP.10 notification."

So the clarification I was seeking is whether IETF is indeed endorsed by
TECB.   The IAD has said it is, but the rest of us don't have that in
writing.

Ray

---

From: Portia Wenze-Danley <[email-masked]>
Date: Tue, 4 Sep 2018 10:09:49 -0400

Hello Ray,

We will follow up with the TCEB to request endorsement on their site and follow up with an announcement.

Thank you for your patience and I will return as soon as I have confirmed information.
________________________________
Portia Wenze-Danley
IETF Administrative Director (IAD)	
Internet Engineering Task Force (IETF)
[email-masked]

> On Sep 4, 2018, at 10:03 AM, Ray Bellis <[email-masked]> wrote:
>

---

From: Ben Campbell <[email-masked]>
Date: Tue, 4 Sep 2018 12:48:09 -0500

Hi Niel,

I don’t disagree with the answers, but the URL you sent is for the Thai Embassy in Finland, not Washington DC.

Thanks!

Ben.

> On Sep 4, 2018, at 8:57 AM, Niel Harper <[email-masked]> wrote:
> 
> Toerless,
> 
> I'm with you on this.
> 
> The URL is http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html <http://www.thaiembassy.org/helsinki/en/customize/28150-ConferenceBusiness-meetingSeminar.html>
> 
> Regards,
> 
> Email: [email-masked] <mailto:[email-masked]>
> Skype: OlokunBB
> Follow us on Twitter @ISOC_NextGen <https://twitter.com/ISOC_NextGen <https://twitter.com/ISOC_NextGen>>
> 
> On 9/4/18, 9:18 AM, "103attendees on behalf of Toerless Eckert" <[email-masked] <mailto:[email-masked]> on behalf of [email-masked] <mailto:[email-masked]>> wrote:
> 
>     Balazs,
> 
>     I will simply print out:
> 
>     [email-masked] <mailto:[email-masked]>
>     https://www.ietf.org/mailman/listinfo/103attendees <https://www.ietf.org/mailman/listinfo/103attendees>
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/102attendees <https://www.ietf.org/mailman/listinfo/102attendees>

---

From: Niel Harper <[email-masked]>
Date: Tue, 4 Sep 2018 17:57:07 +0000

Hello Ben,

I recognized that after the fact.

I was directed to that URL because the Thai Embassy in DC doesn’t provide a lot of detailed information about visas.

Regards,

Niel Harper

Internet Society

Reston, VA 20190

Email: [email-masked]

Skype: OlokunBB

Follow us on Twitter @ISOC_NextGen

From: Ben Campbell <[email-masked]>
Date: Tuesday, September 4, 2018 at 1:48 PM
To: Niel Harper <[email-masked]>
Cc: Toerless Eckert <[email-masked]>, Balazs Lengyel <[email-masked]>, "[email-masked]" <[email-masked]>, 102attendees <[email-masked]>
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

Hi Niel,

Thanks!

Ben.

Toerless,

I'm with you on this.

Regards,

Niel Harper

Internet Society

Reston, VA 20190

Email: [email-masked]

Skype: OlokunBB

    Balazs,

    I will simply print out: 

    (thanks Andy!)

    visa.

    Cheers

        Toerless

    -- 

    ---

    [email-masked]

    -- 

    [email-masked]

---

From: John C Klensin <[email-masked]>
Date: Tue, 04 Sep 2018 14:07:57 -0400

Hi.

If only to keep mailing list traffic down, can I encourage
everyone who is speculating on what type of visa is needed to
find the note that Andrew Sullivan posted on the subject a few
weeks ago and reread it carefully.

WIth a very small number of exceptions, the final decision about
what category of visa is, or is not, required belongs to the
authorities at the border when you try to enter the country.  If
you appear with a tourist visa or waiver and they ask questions
and conclude that category is inappropriate, you are either
headed home or in for a long conversation (and maybe an exercise
in filling out forms) while your status is sorted out.  If you
have a letter from you local consulate or a copy of their web
page indicating that your choice was consistent with their
guidance, the actual border authorities might accept that as
evidence that you should get in on that category of visa, might
accept it as evidence that whatever decision you made was made
in good faith, or might ignore it entirely. 

Again, Andrew's summary and comments are much better than mine.
But my point is that these decision belong to border authorities
in the country you are trying to enter and we really cannot
accomplish very much (other that causing noise on the lists) by
crowdsourcing opinions about what is needed or appropriate.
This is one area in which IETF Consensus, even if it existed,
would be of little value.

best,
    john

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Wed, 5 Sep 2018 02:18:32 +0800

On Wed, Sep 5, 2018 at 2:08 AM John C Klensin <[email-masked]> wrote:
> [..] can I encourage
> weeks ago

Sure. Which mailing list was it?

> in filling out forms) while your status is sorted out.

Unfortunately, that (small) number of exceptions includes a case when
you occasionally don't get any questions at the border and then after
a couple of days simply go to jail for several years for violating the
visa regulations. And, the government of Thailand is famous for its
strict policies on working without a permit.

| Töma Gavrichenkov
| gpg: 2deb 97b1 0a3c 151d b67f 1ee5 00e7 94bc 4d08 9191
| mailto: [email-masked]
| fb: ximaera
| telegram: xima_era
| skype: xima_era
| tel. no: +7 916 515 49 58

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 4 Sep 2018 21:17:56 +0200

> weeks ago and reread it carefully.

Ok......... failed. Please provide URL.

> in filling out forms) while your status is sorted out. 

Sure.

> If you

Sure. Sure. But also Visas do not guarantee entry either. I am
also not aware of data points that entereing on visa waiver has a
higher chance of failure on the places we go to. 

> Again, Andrew's summary and comments are much better than mine.

Please provide URL. The only one i found is that IASA can not
provide legal guidance *doh* (obvious).

> in the country you are trying to enter

Sure.

> and we really cannot

No idea how the points you made above are evidence for that conclusion.
With contradicting information from different consulates for the same
trip, the insight i got from these mailing  lists was in the past a 
lot more useful than what consulates told me.

> would be of little value.

I though the main benefit of this thread is more BCP than consensus.

Cheers
    Toerless

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 4 Sep 2018 21:04:43 +0100

John,

While all this is true, it is also not very useful. The equivalent advice for US visitors would be that you can be shot every moment by a police officer that got a bit agitated. That is not useful advice. Useful advice would be how not to get into situations with those dangerous people. While some legal advice can be useful here, this is mostly about being street-smart. It is hard to be this without some experience, and this is why the only useful posts here have been on previous experience. 

Sent from mobile

> On 4. Sep 2018, at 19:07, John C Klensin <[email-masked]> wrote:
> 
> Hi.
>

---

From: Philip Prindeville <[email-masked]>
Date: Tue, 4 Sep 2018 13:32:21 -0700

That’s a bit of an apples to oranges comparison.

I think as North Americans (Canadians and Americans) and Western Europeans, we’re used to the rule of law and the equal application of it.

Not always the case in less developed countries.

I think that’s part of John’s point.

> On Sep 4, 2018, at 1:04 PM, Carsten Bormann <[email-masked]> wrote:
> 
> John,
> 
> On 4. Sep 2018, at 19:07, John C Klensin <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Hi.
>>

---

From: Fred Baker <[email-masked]>
Date: Tue, 4 Sep 2018 18:26:44 -0700

Well, and the US has issues in that respect. That said, Carsten is correct that a vanishingly small percentage of our police force seems to be xenophobic, and that vanishingly small percentage seems to dominate the papers.

> On Sep 4, 2018, at 1:32 PM, Philip Prindeville <[email-masked]> wrote:
> 
> Signed PGP part

--------------------------------------------------------------------------------
The fact that there is a highway to hell and a stairway to heaven is an interesting comment on projected traffic volume...

---

From: Mike Bishop <[email-masked]>
Date: Wed, 5 Sep 2018 04:35:18 +0000

Personally, I think the key takeaway of this is that we should probably have included some more precise language about visas in the mtgvenue docs or we should read the existing language to include new evaluations based on this experience.  What we wrote was:

      Travel barriers to entry, *including visa requirements*, are likely
      to be such that an overwhelming majority of participants who wish
      to do so can attend.  The term "travel barriers" is to be read
      broadly by the IASA in the context of whether a successful meeting
      can be had.

We're having direct experience now that another of these barriers to entry is determining whether a visa is needed in the first place.  If that can't be readily ascertained for participants from most countries, that might be a strike against a choice of venue.

I know that if Thailand shows up on the venue feedback e-mails again, I'll give feedback on that as a reason not to meet in Bangkok unless the Thai government seriously overhauls their immigration guidance.

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Toerless Eckert
Sent: Tuesday, September 4, 2018 12:18 PM
To: John C Klensin <[email-masked]>
Cc: Ben Campbell <[email-masked]>; Niel Harper <[email-masked]>; [email-masked]; 102attendees <[email-masked]>; Balazs Lengyel <[email-masked]>
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

On Tue, Sep 04, 2018 at 02:07:57PM -0400, John C Klensin wrote:
> Hi.
> 
> If only to keep mailing list traffic down, can I encourage everyone 
> who is speculating on what type of visa is needed to find the note 
> that Andrew Sullivan posted on the subject a few weeks ago and reread 
> it carefully.

> WIth a very small number of exceptions, the final decision about what 
> category of visa is, or is not, required belongs to the authorities at 
> the border when you try to enter the country.  If you appear with a 
> tourist visa or waiver and they ask questions and conclude that 
> category is inappropriate, you are either headed home or in for a long 
> conversation (and maybe an exercise in filling out forms) while your 
> status is sorted out.

Sure.

> If you
> have a letter from you local consulate or a copy of their web page 
> indicating that your choice was consistent with their guidance, the 
> actual border authorities might accept that as evidence that you 
> should get in on that category of visa, might accept it as evidence 
> that whatever decision you made was made in good faith, or might 
> ignore it entirely.

Sure. Sure. But also Visas do not guarantee entry either. I am also not aware of data points that entereing on visa waiver has a higher chance of failure on the places we go to. 

> Again, Andrew's summary and comments are much better than mine.

Please provide URL. The only one i found is that IASA can not provide legal guidance *doh* (obvious).

> But my point is that these decision belong to border authorities in 
> the country you are trying to enter

Sure.

No idea how the points you made above are evidence for that conclusion.
With contradicting information from different consulates for the same trip, the insight i got from these mailing  lists was in the past a lot more useful than what consulates told me.

> This is one area in which IETF Consensus, even if it existed, would be 
> of little value.

Cheers
    Toerless

---

From: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Wed, 5 Sep 2018 20:08:30 +0000

Here is the answer from the US Thai Embassy.
Nicely dodged the question.
I can just imagine trying to convince a border guard that no business is conducted at a conference.
All they have to do is ask: "Are you attending the conference in that hotel you are staying at?"
Say "no" and go to jail.

Regards,
Jakob.

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Toerless Eckert
Sent: Tuesday, September 4, 2018 12:18 PM
To: John C Klensin <[email-masked]>
Cc: Ben Campbell <[email-masked]>; Niel Harper <[email-masked]>; [email-masked]; 102attendees <[email-masked]>; Balazs Lengyel <[email-masked]>
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

Sure.

Sure.

Cheers
    Toerless

Subject: Re: New submission from Contact En
From: "Thai Embassy DC (Visa)" <[email-masked]>
To: "Jakob Heitz (jheitz)" <[email-masked]>
Date: Wed, 5 Sep 2018 18:05:33 +0000

Dear Sir/Madame

    For business purposes, visa is required.

    For your information, you could apply for the visa by hand or by mail at the Royal Thai Embassy in Washington, D.C., or the Royal Thai Consulate General in Chicago, Los Angeles or New York. And you should do so approximately a month before your departure.

    And regarding the location/mailing information and required documents please check the homepage of the office in your area.

Best,
Visa Section
Consular Office,
Royal Thai Embassy,
2300 Kalorama Rd., N. W.,
Washington, DC 20008.
E-mail - [email-masked]<mailto:[email-masked]>

On Tue, Sep 4, 2018 at 2:19 PM, [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>> wrote:

Name
         Jakob Heitz
Email
         [email-masked]<mailto:[email-masked]>
Subject
         Visa
Message
         Is a business visa required to attend the IETF conference in Bangkok?
The IETF is an organization of internet equipment vendors that produces standards for internet equipment. We do not conduct commerce. More info at http://ietf.org/.
The conference is held on 3 Nov to 9 Nov 2018.
If I attend the conference, I intend to stay a few more days, but not more than 30 days in total.

Kind Regards,
Jakob.

---

From: Randy Bush <[email-masked]>
Date: Wed, 05 Sep 2018 16:40:54 -0700

s/102/103/

>>> AFAICT from reading this, all of the secretariat will need business
>>> visa's, all of the rest of us
>> /me imagines the outcome if the secretariat didn't get to the
>> venue but the rest of us did...  :-)
> *heh*  Much worse than the secretariat getting there and the rest of
> us being stopped at the border!

that may be a matter of viewpoint

---

From: Cj Aronson <[email-masked]>
Date: Thu, 6 Sep 2018 08:06:53 -0600

I found this site that specifically says conferences are not considered
business..

-----Cathy

{Ô,Ô}
  (( ))
  ◊  ◊

On Tue, Sep 4, 2018 at 4:30 AM, Artyom Gavrichenkov <[email-masked]>
wrote:

> Probably the only place where you're going to trade something for
> something is actually the whisky BoF.
>
>>> they found the invitation letter lacking. They sent me a 23 page template
>>> in Thai language that the invitation letter should follow.
>>>
>> *Ori Finkelman *Qwilt | Work: +972-72-2221647 | Mobile: +972-52-3832189
>> | [email-masked]
>>
>> --

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Thu, 06 Sep 2018 11:09:49 -0300

The honorary consul of the Kingdom of Thailand in Uruguay is of the same 
opinion, conferences are not business.

So far I’m betting for my tourist status.

S2

/Carlos

On 6 Sep 2018, at 11:06, Cj Aronson wrote:

>>>> template

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Thu, 6 Sep 2018 23:01:03 +0800

Is it an overly optimistic idea to bring someone from the host to the
thread and ask them for advice? A host proposing an event in their country
must have known about the visa regulations beforehand.

I'm perfectly aware there are complicated scenarios out there which the
host may not know how to handle, but the case of a EU citizen coming to the
proposed international event looks rather straightforward and typical for
me.

---

From: Jim Reid <[email-masked]>
Date: Thu, 6 Sep 2018 16:15:34 +0100

On 6 Sep 2018, at 16:01, Artyom Gavrichenkov <[email-masked]> wrote:
> 
> Is it an overly optimistic idea to bring someone from the host to the thread and ask them for advice?

Yes. It’s utterly impractical to expect anyone to provide advice on visa issues which will or won’t apply to everyone going to an IETF meeting. See the earlier comments by Andrew Sullivan and John Klensin. Everybody has to make their own decisions about this and get definitive advice specific to their individual circumstances from the relevant embassy/consulate. It’s that simple.

Further discussion on this topic/thread is just pointless noise. It’s time to shut it down.

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Thu, 6 Sep 2018 23:27:08 +0800

"Further discussion on this topic/thread is just pointless noise"

Sorry, it's not. There's already a lot of valuable information in this
thread regarding actual visa processing cases, and more is to come.

чт, 6 сент. 2018 г., 23:15 Jim Reid <[email-masked]>:

> thread and ask them for advice?
>
> Yes. It’s utterly impractical to expect anyone to provide advice on visa
> issues which will or won’t apply to everyone going to an IETF meeting. See
> the earlier comments by Andrew Sullivan and John Klensin. Everybody has to
> make their own decisions about this and get definitive advice specific to
> their individual circumstances from the relevant embassy/consulate. It’s
> that simple.
>

---

From: Ilpo Järvinen <[email-masked]>
Date: Thu, 6 Sep 2018 20:21:30 +0300 (EEST)

Hi,

I've digged more into this using the legislation reference numbers and 
finally came across even more recent amendment than what you're refering 
to:
  https://www.bakermckenzie.com/en/insight/publications/2018/04/new-amendments-to-the-work-permit-law

I'm yet to find the actual text for it instead of the interpretation on 
that webpage but luckily it seems to finally settle it for good (From 
what I gathered elsewhere, in the earlier legislation there was a word 
trap that "attending" something did not including the right to present 
there and the latter might have required to apply for a work permit(!) 
besides the B visa).

--
 i.

On Thu, 6 Sep 2018, Michael StJohns wrote:

> Yup - found this as well.   If you read the article and then google for
> "Memo of Office of the Council of State No. 152/2556 thailand" to find:
> 
> http://www.pricesanond.com/knowledge/visas-and-work-permits/new-exemptions-
> to-thailands-urgent-work-permit-requirements.php - a lawyer interpreting
> above and indicating in response to the issuance of that document that
>       the Office of Foreign Workers Administration of the Department
>       of Labor (Office of Foreign Workers) issued new guidelines
>       providing that a work permit is not required for the following
>       activities:
>        o  attending a conference or seminar
>        o  attending an exhibition or trade show
>        o  attending a business visit or business negotiation
>        o  attending an academic lecture
>        o  attending a training course or technical seminar
>        o  purchasing goods at a trade show
> 
> 
> YMMV.  I couldn't find the "new guidelines" document mentioned above, only
> this summary of it.

---

From: Artyom Gavrichenkov <[email-masked]>
Date: Fri, 7 Sep 2018 01:58:18 +0800

I have decided it's a good idea to be more explicit regarding this
piece. Answers inline,

> See the earlier comments by Andrew Sullivan

...which no one to date has bothered to give a hyperlink to (though
Mr. Eckert and me have both kindly asked for that quite a few times).

The best direction on where to look for those comments was: "Andrew
Sullivan's explanation on the IETF list". Nah. Never knew there's only
one mailing list in the IETF.

> and John Klensin.
> Everybody has to make their own decisions about this and get definitive advice specific to their individual circumstances from the relevant embassy/consulate. It’s that simple.

Sorry, but it is *not* that simple.

Though I'm somewhat younger and definitely less experienced than you,
I've lived most of my life under a citizenship which pretty much
doesn't get you a visa waiver in most of the countries out there, and
I have a different view over this one.

With all due respect to all the countries in the world, for *most* of
them, it is *not* possible to get a definitive advice from a consulate
or embassy. Sometimes the [visa] regulations are vague and unclear.
Sometimes, on the other hand, they are overly strict and the consulate
is afraid of assigning too much of permissions to you. Sometimes, the
consulate doesn't know much about those regulations at all and is just
acting according to their own common sense.

Each time you face it, it's one-on-one. The other side might be too
strict or too permissive. The more information you have, the more
definitive facts you're able to bring into play — the more chances you
have to ask the right questions and convince the other side to settle
on a decision which is best to you.

> Yes. It’s utterly impractical to expect anyone to provide advice on visa issues which will or won’t apply to everyone going to an IETF meeting.

Repeating once again: "I'm perfectly aware there are complicated
scenarios out there which the host may not know how to handle, but the
case of a EU citizen coming to the proposed international event looks
rather straightforward and typical for me."

See? I wasn't speaking about "everyone" from the very beginning.

| Töma Gavrichenkov

---

From: Tobias Fiebig <[email-masked]>
Date: Thu, 6 Sep 2018 18:18:49 +0000

So, my reading is that this just solves the "work permit" part, and not the "Visa Type" question, does it?

Met vriendelijke groet,
 
Dr.-Ing. Tobias Fiebig,
Assistant Professor / Universitair Docent
Department Engineering Systems and Services

Informatie- en Communicatie Technologie (ICT)
 
TU Delft / Dept. ESS
Faculty of Technology, Policy and Management (TBM)
Building 31
Jaffalaan 5 - room B3.170
2628 BX  Delft
P.O.Box 5015
2600 GA Delft, The Netherlands
T +31 (0)15 27 85700
E  [email-masked]

Present: Monday t/m Friday

-----Original Message-----
From: 102attendees <[email-masked]> On Behalf Of Ilpo Järvinen
Sent: Thursday, September 6, 2018 7:22 PM
To: Michael StJohns <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [102attendees] Visa problems - need a different invitation letter

Hi,

I've digged more into this using the legislation reference numbers and finally came across even more recent amendment than what you're refering
to:
  https://www.bakermckenzie.com/en/insight/publications/2018/04/new-amendments-to-the-work-permit-law

I'm yet to find the actual text for it instead of the interpretation on that webpage but luckily it seems to finally settle it for good (From what I gathered elsewhere, in the earlier legislation there was a word trap that "attending" something did not including the right to present there and the latter might have required to apply for a work permit(!) besides the B visa).

--
 i.

On Thu, 6 Sep 2018, Michael StJohns wrote:

> Yup - found this as well.   If you read the article and then google 
> for "Memo of Office of the Council of State No. 152/2556 thailand" to find:
> 
> http://www.pricesanond.com/knowledge/visas-and-work-permits/new-exempt
> ions- to-thailands-urgent-work-permit-requirements.php - a lawyer 
> interpreting above and indicating in response to the issuance of that 
> document that
> YMMV.  I couldn't find the "new guidelines" document mentioned above, 
> only this summary of it.

---

From: Michael Richardson <[email-masked]>
Date: Thu, 06 Sep 2018 15:16:53 -0400

(I don't know why this is CC'ed to 102attendees, I've removed that}

    > one mailing list in the IETF.

"*The* *IETF* List" is a specific list, [email-masked].

I believe that this is the email being referred to:
  https://mailarchive.ietf.org/arch/msg/ietf/v_vECz7MtHUiMfu7INCh9VmJSKc

I didn't find that email very useful, btw.

Given that Thailand has this list of conferences, it seems that we ought to
be on that list.  While the IETF/IAOC/ISOC can't give anyone specific advice
about whether or not *THEY* need a VISA, I think that it is reasonable to
get specific advice about whether we need a business or tourism VISA.

--
]               Never tell me the odds!                 | ipv6 mesh networks [
]   Michael Richardson, Sandelman Software Works        | network architect  [
]     [email-masked]  http://www.sandelman.ca/        |   ruby on rails    [

---

From: Robert Moskowitz <[email-masked]>
Date: Thu, 6 Sep 2018 17:16:52 -0400

I wonder what IEEE 802 is doing for their meeting the following week?  I 
think they have been to Bangkok before?

Can some of the current 802 participants chime in here?

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Charlie Perkins <[email-masked]>
Date: Thu, 6 Sep 2018 14:22:38 -0700

Hello Robert and all,

I've been to Bangkok about 5 times.  Never a problem with visa or 
passport control.  I'm willing to take my chances that this time will be 
about the same.  But this is not in any way to dismiss the possibilities 
that have been illustrated by other peoples' experiences.

Regards,
Charlie P.

On 9/6/2018 2:16 PM, Robert Moskowitz wrote:
> I wonder what IEEE 802 is doing for their meeting the following week?  
> I think they have been to Bangkok before?
>
>> Artyom Gavrichenkov<[email-masked]>  wrote:
>> "*The* *IETF* List" is a specific list,[email-masked].
>>
>> ][email-masked]   http://www.sandelman.ca/         |   ruby on rails    [
>>
>
> --

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 6 Sep 2018 18:46:07 -0400

There was an IEEE 802 wireless interim in Bangkok in September 2015 at
the Centara Grand hotel which seems to be a good venue as it is
directly connected to a Mall with a variety of restaurants. I did not
have any problems without a visa.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 1424 Pro Shop Court, Davenport, FL 33896 USA
 [email-masked]
On Thu, Sep 6, 2018 at 5:17 PM Robert Moskowitz
<[email-masked]> wrote:
>
> I wonder what IEEE 802 is doing for their meeting the following week?  I think they have been to Bangkok before?
>
> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets the credit
> --

---

From: Robert Wilton <[email-masked]>
Date: Fri, 7 Sep 2018 10:18:20 +0100

Hi Artyom,

I presume that Andrew's email is probably this one:
https://mailarchive.ietf.org/arch/msg/ietf/v_vECz7MtHUiMfu7INCh9VmJSKc

Or, otherwise this query makes it fairly easy to see other likely 
candidate emails:
https://mailarchive.ietf.org/arch/browse/ietf/?q=Andrew#

Personally I'm not inclined to apply for work visa, it seems a bit 
arduous, so the choice I'm trying to decide between is do I travel on 
the tourist visa-waver, or do I skip this meeting.

FWIW, my current conclusion of this thread (traveling from the UK) is 
that a tourist visa/visa-waver is sufficient, but I would need to be 
careful about what I say when entering, along the lines of what Mehmet 
suggested previously, i.e. attending a technical conference, etc.

I've never been to Thailand before, so may also tack a couple of extra 
days of tourism on the end anyway.

Regards,
Rob

---

From: Christian Hopps <[email-masked]>
Date: Fri, 07 Sep 2018 07:01:22 -0400

+1

I have to admit this thread has made me wonder if I should skip this one. I'll probably go, but I'm not going to go through all the hassle of getting a work-visa. I guess I'm risking being turned around at the border, which is annoying given it takes more than 24 hours of travel for me to get there.

Thanks,
Chris.

---

From: Lawrence M <[email-masked]>
Date: Fri, 7 Sep 2018 14:21:16 +0300

Hi guys,
The Embassy informed me that for any conference, training, i have to apply
for a Non-Immigrant VISA and not the Tourist visa.

-- 
with kind regards
Muchilwa Lawrence
Solutions Engineer

---

From: Heinrich Singh <[email-masked]>
Date: Fri, 7 Sep 2018 14:28:35 +0300

Hello Lawrence,

Can you tell which embassy was this. Where is it located so that others can
benefit from this information.

Ciao
Heinrich

On Fri, 7 Sep 2018 at 14:22, Lawrence M <[email-masked]> wrote:

> On Tue, Sep 4, 2018 at 11:30 AM Balazs Lengyel <
>> Mobile: +36-70-330-7909              email: [email-masked]
>> <[email-masked]>
>>
>> --

---

From: Toerless Eckert <[email-masked]>
Date: Fri, 7 Sep 2018 14:05:22 +0200

Kenya ?

-- 
---
[email-masked]

---

From: "Pete Resnick" <[email-masked]>
Date: Fri, 07 Sep 2018 16:36:03 -0500

> not the "Visa Type" question, does it?

For what it’s worth, on the Ministry of Foreign Affairs website:

http://www.mfa.go.th/main/en/services/4908/15398-Issuance-of-Visa.html

1. TRANSIT VISA

...

2. TOURIST VISA

...

3. NON-IMMIGRANT VISA	
  	
  	1. REQUIREMENT
  	
		This type of visa is issued to applicants who wish to enter the 
Kingdom for the following purposes:
	- to perform official duties (Category "F")
	- to conduct business / to work (Category "B")
	- to invest with the concurrence of the Thai Ministries and Government 
Departments concerned (Category "IM")
	- to invest or perform other activities relating to investment, subject 
to the provision of the established laws on investment promotion 
(Category "IB")
	- to study, to come on a work study tour or observation tour , to 
participate in projects or seminars , **to attend a conference or 
training course** , to study as a foreign Buddhist monk (Category "ED")
	- to work as a film-producer, journalist or reporter (Category "M")
	- to perform missionary work or other religious activities with the 
concurrence of the Thai Ministries or Government Departments concerned 
(Category "R")
	- to conduct scientific research or training or teaching in a research 
institute (Category "RS")
	- to undertake skilled work or to work as an expert or specialist 
(Category "EX")
	- other activities (Category "O") as follows:
		to stay with the family, to perfrom duties for the state enterprise or 
social welfare organizations, to stay after retirement for the elderly, 
to receive medical treatment, to be a sport coach as required by Thai 
Government, to be a contestant or witness for the judicial process.

Notice that the fifth sub-bullet under "non-immigrant visa" says that if 
you come in "to attend a conference or training course", you get a 
category "ED" visa.

I still may roll the dice and go for the tourist visa as per the advice 
on the Thailand Convention & Exhibition Bureau (TCEB) page on meetings, 
incentives, conferences and exhibitions (MICE):

But if you're going to apply for a visa, "ED" sounds like the right 
category, and it has less documentation requirements than a 
business/work ("B") visa.

pr

---

From: Lawrence M <[email-masked]>
Date: Sun, 9 Sep 2018 18:35:41 +0300

This is the embassy in Kenya.

Regards,
Muchilwal Lawrence,
Systems Solutions Architect

On Fri, Sep 7, 2018, 2:28 PM Heinrich Singh <[email-masked]> wrote:

> Hello Lawrence,
>
> Can you tell which embassy was this. Where is it located so that others
> can benefit from this information.
>
> Ciao
> Heinrich
>
>> The Embassy informed me that for any conference, training, i have to
>> apply for a Non-Immigrant VISA and not the Tourist visa.
>>

---

From: Michael Richardson <[email-masked]>
Date: Sun, 09 Sep 2018 15:20:43 -0400

Pete Resnick <[email-masked]> wrote:
    > * to study, to come on a work study tour or observation tour , to
    > participate in projects or seminars , to attend a conference or
    > training course , to study as a foreign Buddhist monk (Category "ED")

...

    > business/work ("B") visa.

Thank you for posting this.
If anything, I think that IETF WG meetings are best described as seminars.

I will also enter on a tourism visa.  I can well understand that many
not from G7 countries will not want to do that.

It would be nice if IETF103 was on that TCEB list, and I could print it
off to carry with me.  I haven't been able to load the page with the list
on it yet.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Tue, 11 Sep 2018 16:44:51 +0000

I was planning on doing the same (tourist visa waiver)  but then a Canadian colleague sent this response from Thai embassy in Canada (FYI).

===================================================

Sent: September 6, 2018 10:15 AM
Subject: visas
 
for those who travel to Thailand for business purposes, attend conferences you will need to apply for a Non-Immigrant visa and send the following to the Embassy:
 
- original passport (no copies)
- one visa application filled out completely and singed
 
- one photo Canadian passport size and stamped in the back from the store purchased from
 
- either an official letter from your office addressed to the Embassy or invitation letter from Thailand stating that you will attend a meeting conference. the letter must mention your name and nationality
 
- visa fee $100.- in Canadian funds, money order only payable to the "Royal Thai Embassy"
 
- a prepaid express post envelop must be included for the return of your passport.

On 2018-09-07, 5:18 AM, "102attendees on behalf of Robert Wilton" <[email-masked] on behalf of rwilton=[email-masked]> wrote:

    Hi Artyom,

    

    
    Regards,
    Rob

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 11 Sep 2018 16:56:43 +0000

I had a similar experience for Buenos Aires (although one person at one Argentinian consulate finally did verbally say that a conference isn't considered "business"). Nobody at the embassy is really motivated to try and find a way to confirm that a visa isn't required so they'll just say to get one to avoid any risk.  Maybe one is actually needed but personally I doubt it.

Everyone has their own circumstances, but it is really a shame that we (IETF as an organization) can't get a definitive statement from the Thai authorities (i.e. in writing that we can all print & bring) that attending this conference is not considered as "business" by Thailand.  That would save a lot of grief (and same was true for Buenos Aires and will be true for many future IETFs).

Jason

> From: 102attendees <[email-masked]> On Behalf Of Reshad
> Rahman (rrahman)
> Sent: Tuesday, September 11, 2018 12:45 PM
> To: Robert Wilton <rwilton=[email-masked]>; Artyom
> Gavrichenkov <[email-masked]>; [email-masked]
> Cc: 102attendees <[email-masked]>
> I was planning on doing the same (tourist visa waiver)  but then a Canadian
> colleague sent this response from Thai embassy in Canada (FYI).
> 
> for those who travel to Thailand for business purposes, attend conferences
> you will need to apply for a Non-Immigrant visa and send the following to the
> Embassy:
> 
> - either an official letter from your office addressed to the Embassy or
> invitation letter from Thailand stating that you will attend a meeting
> conference. the letter must mention your name and nationality
> 
> On 2018-09-07, 5:18 AM, "102attendees on behalf of Robert Wilton"
> <[email-masked] on behalf of
> rwilton=[email-masked]> wrote:
> 
>     Hi Artyom,
> 
>     >> Everybody has to make their own decisions about this and get definitive
> advice specific to their individual circumstances from the relevant
> embassy/consulate. It’s that simple.
> issues which will or won’t apply to everyone going to an IETF meeting.

---

From: Christian Hopps <[email-masked]>
Date: Tue, 11 Sep 2018 13:57:47 -0400

> Everyone has their own circumstances, but it is really a shame that we (IETF as an organization) can't get a definitive statement from the Thai authorities (i.e. in writing that we can all print &…

This sure would be nice. Just the simple declaration that attending the conference is not considered conducting business would be enough I think.

Thanks,
Chris.

---

From: "Marc Blanchet" <[email-masked]>
Date: Tue, 11 Sep 2018 14:01:46 -0400

On 11 Sep 2018, at 13:57, Christian Hopps wrote:

>> Everyone has their own circumstances, but it is really a shame that 
>> we (IETF as an organization) can't get a definitive statement from 
>> the Thai authorities (i.e. in writing that we can all print & bring) 
>> that attending this conference is not considered as "business" by 
>> Thailand.  That would save a lot of grief (and same was true for 
>> Buenos Aires and will be true for many future IETFs).
>
> This sure would be nice. Just the simple declaration that attending 
> the conference is not considered conducting business would be enough I 
> think.

+1

Marc.

---

From: John C Klensin <[email-masked]>
Date: Tue, 11 Sep 2018 14:06:25 -0400

--On Tuesday, September 11, 2018 16:56 +0000 "Sterne, Jason
(Nokia - CA/Ottawa)" <[email-masked]> wrote:

>...
> Everyone has their own circumstances, but it is really a shame
> that we (IETF as an organization) can't get a definitive
> statement from the Thai authorities (i.e. in writing that we
> can all print & bring) that attending this conference is not
> considered as "business" by Thailand.  That would save a lot
> of grief (and same was true for Buenos Aires and will be true
> for many future IETFs).

First of all, this is not really about Thailand but about
general practices.  Your comments about Argentina reinforce
that.  Second, it could be "business" for some of us and not for
others, so, in the case of some countries and circumstances, the
answer may not be that the meeting is or is not "business" for
all participants.

It may well be a shame, and probably is, but the only times I'm
aware of getting that sort of guarantee (or clear and binding
statement) from a government (at least a government that has not
established a visa category for "standards body meeting" or
equivalent) is when the government is actually a sponsor of the
meeting.   There may well be exceptions (my experience is
definitely not comprehensive) but, by and large, what people
have been experiencing is fairly normal.   And, for whatever it
worth, there are actually reasons for it that, from the
perspective of the government, provide motivation to behave
exactly the way people, especially local consulates, are
behaving.  Those reasons go well beyond lack of motivation even
though, in some cases, that might be part of the picture too. 

Get the best information you can about your situation and people
holding passports (or other travel documents) from your country,
act as conservatively about it as you think appropriate, and
then go for it, hoping for the best and making whatever
contingency plans you think appropriate.  

If you need guarantees, especially guarantees you can enforce,
you are probably better off participating remotely.

   john

---

From: Philip Prindeville <[email-masked]>
Date: Tue, 11 Sep 2018 14:26:27 -0400

At the very least it raises the question of whether it’s worth having further IETF’s in Thailand.

-Philip

> On Sep 7, 2018, at 7:01 AM, Christian Hopps <[email-masked]> wrote:
> 
> 
> +1
>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 11 Sep 2018 20:42:46 +0200

What type of interactions do the folks setting up IETF meetings have
with local authorities about this ? Why is it not possible to ask:

What is the best written guidance for attendees to our conference
whether or not your countries Visa Waiver program is sufficient to enter
the country if one is attending our conference ?

Since i raised this question firt before argentina, i have seen no one
from the meetings committee or the like provide any answer to this
question.

Cheers
    Toerless

-- 
---
[email-masked]

---

From: "Sterne, Jason (Nokia - CA/Ottawa)" <[email-masked]>
Date: Tue, 11 Sep 2018 18:44:19 +0000

Hi John,

Whether an individual person needs a VISA is based on individual circumstances (origin country,etc).

But I think whether Thailand considers (typical) participation at IETF to be "business" vs "tourist" (or whatever categories Thailand uses) is the same for everyone and purely based on Thailand immigration authority determination of how they consider IETF attendance.

Why do you say it could be "business for some" and not for others ?  I think this thread is mainly concerned with the typical conference attendee.

Jason

> From: John C Klensin <[email-masked]>
> Sent: Tuesday, September 11, 2018 2:06 PM
> To: Sterne, Jason (Nokia - CA/Ottawa) <[email-masked]>
> Cc: [email-masked]; 102attendees <[email-masked]>

---

From: Toerless Eckert <[email-masked]>
Date: Tue, 11 Sep 2018 20:52:50 +0200

> Why do you say it could be "business for some" and not for others ?  I think this thread is mainly concerned with the typical conference attendee.

One distinction of course is how you receive money for your conference
attendance. For example, it was not clear to me from the refernces to
thai law circulated on this thread why for example IETF secretariat
staff might need a visa if they would not need one (as per their
passport) if they where attendees. In both cases, you get paid by your
employer to be at the conference and perform likely your "normal" job chores.
But someone here on the thread suggested that IETF staff might need
visa. The way i read the information available, you would have to be
paid for by a thai source before you needed a work/business visa.

Maybe the real issue is that countries with Visa Waiver programs need
a contact specifically for those visa waiver programs. The consulates/
embassies have a clear conflict of interest and maybe are also
unqualified to provide Visa Waiver guidance.

Toerless

-- 
---
[email-masked]

---

From: [email-masked]
Date: 11 Sep 2018 15:03:15 -0400

>the country if one is attending our conference ?

It's entirely possible to ask and we have done so.

Asking, of course, is not the same as getting an answer.

R's,
John

---

From: Bob Hinden <[email-masked]>
Date: Tue, 11 Sep 2018 12:27:47 -0700

Phillip,

> On Sep 11, 2018, at 11:26 AM, Philip Prindeville <[email-masked]> wrote:
> 
> Signed PGP part

As far as I can tell, the issue here is what kind of visa one needs (tourist or business).  It’s not about getting into the country at all.

This doesn’t seem like an issue that should keep the IETF from having another meeting in Thailand.

We wouldn’t be having any IETF meetings anywhere if there was a requirement like visas are not required for anyone.

Bob

---

From: Jim Reid <[email-masked]>
Date: Tue, 11 Sep 2018 20:30:17 +0100

> At the very least it raises the question of whether it’s worth having further IETF’s in Thailand.

To be fair that question applies to any country under consideration for hosting an IETF meeting.

Pretty much no country has sane, unambigiuous immigration/visa requirements. Good luck searching for one.

---

From: Heinrich Singh <[email-masked]>
Date: Tue, 11 Sep 2018 22:39:46 +0300

Hello Bob and Jim,

I strongly disagree. I have never had this much lack of clarity when
applying for visas (whether I need one or not and which one is needed).
Yes, countries like US have more stringent visa processes, but they are
very clear. Note: I am not from the US and need visa to travel.

I would support thinking twice about doing IETF in Thailand.

Ciao
Heinrich

On Tue, 11 Sep 2018 at 22:32, Jim Reid <[email-masked]> wrote:

> Pretty much no country has sane, unambigiuous immigration/visa
> requirements. Good luck searching for one.
>
> --

---

From: Jim Reid <[email-masked]>
Date: Tue, 11 Sep 2018 20:46:55 +0100

> Why do you say it could be "business for some" and not for others ?  I think this thread is mainly concerned with the typical conference attendee.

It might be obvious to you (and me) who is the typical IETF attendee. That’s not likely to be the case for embassy and immigration officials.

The IETF demographic is not homogenous eiher. In all probability it will light up all the corner cases in any country’s immigration policy. So there’s no “one size fits all” answer. We all have to make our own decisions about which visas to use (or not) based on the advice provided by the competent authority at our local embassy or consulate. That advice is by definition specific to individual circumstances. It would be unwise to extrapolate that advice into something more generic.

---

From: Philip Prindeville <[email-masked]>
Date: Tue, 11 Sep 2018 17:32:25 -0400

> On Sep 11, 2018, at 3:30 PM, Jim Reid <[email-masked]> wrote:
> 

Yes, I meant as a general consideration, with Thailand being a specific exemplar.

I wasn’t trying to single out Thailand in particular.

It’s a question of whether the host organization has sufficient juice to facilitate cooperation from all of the relevant branches of government in countries where the bureaucracy might be lacking motivation, information or professionalism.

Disclaimer: my father spent 8 years as a consular officer in Asia.

---

From: "Jiankang Yao" <[email-masked]>
Date: Wed, 12 Sep 2018 09:08:28 +0800

From: Bob Hinden
Date: 2018-09-12 03:27
To: Philip Prindeville
CC: Christian Hopps; 102attendees; Robert Wilton; Bob Hinden; 103attendees; Artyom Gavrichenkov
Subject: Re: [102attendees] [103attendees] Visa problems - need a different invitation letter

>This doesn’t seem like an issue that should keep the IETF from having another meeting in Thailand.

Agree.  Thailand is a very friendly country. I have been there for international conferences many times.

Best Regards.
Jiankang Yao

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 12 Sep 2018 09:41:41 -0500

On Tue, Sep 11, 2018 at 11:57 AM Sterne, Jason (Nokia - CA/Ottawa) <
[email-masked]> wrote:

> I had a similar experience for Buenos Aires (although one person at one
> Argentinian consulate finally did verbally say that a conference isn't
> considered "business"). Nobody at the embassy is really motivated to try
> and find a way to confirm that a visa isn't required so they'll just say to
> get one to avoid any risk.  Maybe one is actually needed but personally I
> doubt it.
>
>
My recollection for Buenos Aires in March 2015 was, I did pay some money
and get a visa but right after there was a presidential visit from US to
Argentina and Argentina waived the visa requirement so I  did not need any
visa.

My suggestion is to go there as a tourist and try to get in.
If not successful, just arrange a few days in a Tai resort, possibly in
Phuket :)
There I guarantee, they would not turn you down.

Behcet

> Everyone has their own circumstances, but it is really a shame that we
> (IETF as an organization) can't get a definitive statement from the Thai
> authorities (i.e. in writing that we can all print & bring) that attending
> this conference is not considered as "business" by Thailand.  That would
> save a lot of grief (and same was true for Buenos Aires and will be true
> for many future IETFs).
>
> Jason
>
> > - visa fee $100.- in Canadian funds, money order only payable to the
> "Royal
> > Thai Embassy"
> >

---

From: [email-masked]
Date: 12 Sep 2018 14:55:36 -0400

In article <[email-masked]> you write:
>Argentina and Argentina waived the visa requirement so I  did not need any visa.

That wasn't a visa, it was a "reciprocity fee" set to charge US
visitors to Argentina the same amount that Argentines pay for a US
visa.  You just went to their web site, filled out a form including
your credit card number, and you instantly got a printable form to
keep with your passport.

You are correct that due to thawing relations they stopped requiring
them for US passport holders shortly before the meeting.  I flew from
Canada and Canadians still needed them.

R's,
John