Subject: [106attendees] laundry?

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 20 Nov 2019 09:15:12 +0800

Heya, Randy is usually the go-to local laundry guru, but wondering if
anyone has a nearby laundry service that they like?

---

From: Justin Henck <[email-masked]>
Date: Wed, 20 Nov 2019 09:38:28 +0800

I couldn't find anything reasonably priced nearby for 24 hour turnaround,
and ended up using a local app-based service called Piing. (Clicking a
search ad will get you $10 off.)

If you're staying at the Sofitel, they said they could have an external
service pick it up.

Justin Henck
Product Manager
212-565-9811
google.com/jigsaw

PGP: EA8E 8C27 2D75 974D B357 482B 1039 9F2D 869A 117B

On Wed, Nov 20, 2019 at 9:15 AM Joseph Lorenzo Hall <[email-masked]>
wrote:

> --
> 106attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/106attendees
>

---

From: Ross Finlayson <[email-masked]>
Date: Wed, 20 Nov 2019 10:02:15 +0800

> On Nov 20, 2019, at 9:15 AM, Joseph Lorenzo Hall <[email-masked]> wrote:
> 
> Heya, Randy is usually the go-to local laundry guru, but wondering if anyone has a nearby laundry service that they like?

When the IETF was here two years ago, the meeting wiki listed the following (which still seems to be in business):
	http://www.laundrymart.com.sg/contact.php

---

From: Mike Bishop <[email-masked]>
Date: Wed, 20 Nov 2019 02:09:33 +0000

Last time, I used a place called “Laundry Day.”  It’s about 2km away, but an easy bus ride.

From: 106attendees <[email-masked]> On Behalf Of Justin Henck
Sent: Wednesday, November 20, 2019 9:38 AM
To: Joseph Lorenzo Hall <[email-masked]>
Cc: 106Attendees <[email-masked]>
Subject: Re: [106attendees] laundry?

I couldn't find anything reasonably priced nearby for 24 hour turnaround, and ended up using a local app-based service called Piing. (Clicking a search ad will get you $10 off.)

If you're staying at the Sofitel, they said they could have an external service pick it up.

[Image removed by sender.]
Justin Henck
Product Manager
212-565-9811
google.com/jigsaw<https://google.com/jigsaw>

On Wed, Nov 20, 2019 at 9:15 AM Joseph Lorenzo Hall <[email-masked]<mailto:[email-masked]>> wrote:
Heya, Randy is usually the go-to local laundry guru, but wondering if anyone has a nearby laundry service that they like?
--
106attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/106attendees

---

From: Ross Finlayson <[email-masked]>
Date: Wed, 20 Nov 2019 10:28:11 +0800

I also found (using Google Maps) this place (which is near the Somerset MRT station):
	https://tinyurl.com/tul89wl

---

From: "Pete Resnick" <[email-masked]>
Date: Wed, 20 Nov 2019 11:00:50 +0800

> anyone has a nearby laundry service that they like?

For dropoff/pickup service, I used May Tailor & Laundry 
<http://www.maytailor.com.sg>. They cost S$10 per kg, with a 2kg 
minimum. You can get to them completely inside: Go down to B1 level, 
follow signs to the Esplanade, go all the way through to the Marina 
Square (down a short escalator), and they are at the end of the hall on 
the left.

pr
-- 
Pete Resnick https://www.episteme.net/
All connections to the world are tenuous at best

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Wed, 20 Nov 2019 11:02:33 +0800

Thank you, everyone! Much appreciated.

---

From: Avri <[email-masked]>
Date: Wed, 20 Nov 2019 11:13:28 +0800

hi,

thanks.

onm day service?

avri

 
 
>  
> On Nov 20, 2019 at 11:00,  <Pete Resnick (mailto:[email-masked])>  wrote:
>  
>  
>  
>

---

From: "Pete Resnick" <[email-masked]>
Date: Wed, 20 Nov 2019 11:24:52 +0800

Yep. Dropped off at 2pm, picked up 2pm the next day. Don't know if 
they'll do same day.

pr

---

From: Michael Richardson <[email-masked]>
Date: Wed, 20 Nov 2019 14:49:20 +0800

My hotel, the Red Door on Victoria, has a pair of washer/dryers in the back parking spot.
It's actually outside, sheltered under an overhang.
It's S$8 for each, available 24h.  I used it last night around 23:00.
It's two blocks away from the conference hotel.
Soap is included in the price.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-