Subject: [106attendees] Sushi options at Changai

From: Phillip Hallam-Baker <[email-masked]>
Date: Fri, 22 Nov 2019 09:37:03 +0800

Anyone know what the options are for buying Sushi in the airport to take on
the plane? I have a 9am flight tomorrow and just realized that I probably
don't have time to squeeze in a sushi run before going to the airport.
Though once I am there it is going to be hurry up and wait...

Thanks

---

From: Sanjeev Gupta <[email-masked]>
Date: Fri, 22 Nov 2019 10:52:56 +0800

Phillip,

There are half-a-dozen Sushi restaurants at the Airport, but they will open
around 11am.

The TGM transit lounge, Terminal 2, is reputed to have a great Japanese and
Korean menu, and is open from 6am.  Your credit card may allow privileges.

There is also a Supermarket, Fairprice Finest, in T3 Basement (before
checkin).  Other branches of it in town have sushi on sale.

-- 
Sanjeev Gupta
+65 98551208     http://www.linkedin.com/in/ghane

On Fri, Nov 22, 2019 at 9:37 AM Phillip Hallam-Baker <[email-masked]>
wrote:

> Anyone know what the options are for buying Sushi in the airport to take
> on the plane? I have a 9am flight tomorrow and just realized that I
> probably don't have time to squeeze in a sushi run before going to the
> airport.. Though once I am there it is going to be hurry up and wait...
>
> Thanks
> --
> 106attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/106attendees
>

---

From: "De Wilde, Bart (Nokia - SG/Singapore)" <[email-masked]>
Date: Fri, 22 Nov 2019 02:59:36 +0000

Check changi jewel mall (connected to all terminal buildings), there is a food court with shops at the lower levels. With places open 24h, dunno for the sushi specifics

From: 106attendees <[email-masked]> On Behalf Of Sanjeev Gupta
Sent: Friday, November 22, 2019 10:53 AM
To: Phillip Hallam-Baker <[email-masked]>
Cc: [email-masked]
Subject: Re: [106attendees] Sushi options at Changai

Phillip,

There are half-a-dozen Sushi restaurants at the Airport, but they will open around 11am.

The TGM transit lounge, Terminal 2, is reputed to have a great Japanese and Korean menu, and is open from 6am.  Your credit card may allow privileges.

There is also a Supermarket, Fairprice Finest, in T3 Basement (before checkin).  Other branches of it in town have sushi on sale.

On Fri, Nov 22, 2019 at 9:37 AM Phillip Hallam-Baker <[email-masked]<mailto:[email-masked]>> wrote:
Anyone know what the options are for buying Sushi in the airport to take on the plane? I have a 9am flight tomorrow and just realized that I probably don't have time to squeeze in a sushi run before going to the airport.. Though once I am there it is going to be hurry up and wait...

Thanks
--
106attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/106attendees