Subject: Re: [107attendees] [107all] Jabber Service Information for IETF 107

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 21 Mar 2020 16:41:33 -0400

Glen,

The referenced webpage recommends Adium as a Mac jabber client.
Unfortunately, Adium hasn't been supported for some time and no longer
works on more recent MacOS releases (and may also be problematic for older
ones as well). I'm using Swift (https://swift.im/) and that's working well
for me.

Cheers,
Andy

On Fri, Mar 20, 2020 at 9:31 PM Glen <[email-masked]> wrote:

> Jabber is an instant messaging service used by the IETF during
> meetings to allow participants to interact with and ask questions of
> presenters (and each other).
>
> As a result of recent feedback received from IETF participants, we
> have updated the Jabber information page here:
> https://www.ietf.org/how/meetings/jabber/
>
> The page now includes:
>
> - A specific list of clients which have been found suitable (today)
> for Jabber use with the IETF
> - A specific list of servers which have been tested (today) with the
> IETF Jabber chatrooms and from which free accounts can be obtained
> - An overview of, and instructions for, getting online with the IETF's
> Jabber service
>
> If you're not already familiar with Jabber, please refer to that page
> for assistance.
>
> Two notes:
>
> 1. If you're interested in using Jabber, you are advised to get set
> up, and test your connection, well in advance of the session(s) you
> wish to attend.  Users new to Jabber will need more than just 5
> minutes to get online, so please allow yourself enough time to get set
> up and connected.
>
> 2. As with all aspects of this meeting, we are entering a new world
> here.  Although there are fewer sessions on the agenda (so far), we
> expect larger-than-normal participation on Jabber during each session.
> While we don't anticipate any issues, we ask for everyone's
> understanding in the event that problems occur.  Jabber is a
> decentralized service, with many moving parts not under our control.
> We only have the ability to change and manage the IETF's "end" of the
> connection.  Please be patient, and we will do everything we can to
> resolve any server-side problems that may occur.
>
> Please feel free to email me privately if there are any questions.
>
> Thank you.
>
> Glen
> --
> Glen Barney
> IT Director
> AMS (IETF Secretariat)
>
> --
> 107all mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/107all
>

---

From: Glen <[email-masked]>
Date: Sat, 21 Mar 2020 13:46:24 -0700

Hi Andy -

Thanks!  Just by way of explanation, the reason I put Adium on that
page is because it is what I personally, and most of the staff at AMS,
use daily on our Macs.  While it is true that their last release was
2017, Adium is running under Catalina 10.15.3 for myself and Catalina
and Mojave for many of my team without issue, and quite reliably, so
we've never had cause to use anything else.

I'll have a look at your recommendation as soon as I get time to
update that page again.

Thanks,
Glen

On Sat, Mar 21, 2020 at 1:41 PM Andrew G. Malis <[email-masked]> wrote:
>
> Glen,
>
> The referenced webpage recommends Adium as a Mac jabber client. Unfortunately, Adium hasn't been supported for some time and no longer works on more recent MacOS releases (and may also be problematic for older ones as well). I'm using Swift (https://swift.im/) and that's working well for me.
>
> Cheers,
> Andy
>
>
>

---

From: Carsten Bormann <[email-masked]>
Date: Sat, 21 Mar 2020 21:47:24 +0100

On 2020-03-21, at 21:41, Andrew G. Malis <[email-masked]> wrote:
> 
> Unfortunately, Adium hasn't been supported for some time

That is indeed a problem.

> and no longer works on more recent MacOS releases

It seemed to work for my laptop (macOS Catalina 10.15.3 (19D76)) today in the codesprint.
Do you know how this is supposed to not work?

(Thanks for the pointer to Swift.im, I’ll sure try that.)

Grüße, Carsten

---

From: Ben Campbell <[email-masked]>
Date: Sat, 21 Mar 2020 15:50:00 -0500

Hi,

Adium runs fine for me on Catalina (10.15.3). I originally had a preoblem with it scrolling messages, but there a work around:

https://news.softpedia.com/news/how-to-fix-broken-auto-scrolling-in-adium-on-macos-catalina-527933.shtml <https://news.softpedia.com/news/how-to-fix-broken-auto-scrolling-in-adium-on-macos-catalina-527933.shtml>

(I have nothing against Swift; I just haven’t tried it.)

Ben.

> On Mar 21, 2020, at 3:41 PM, Andrew G. Malis <[email-masked]> wrote:
> 
> Glen,
> 
> The referenced webpage recommends Adium as a Mac jabber client. Unfortunately, Adium hasn't been supported for some time and no longer works on more recent MacOS releases (and may also be problematic for older ones as well). I'm using Swift (https://swift.im/ <https://swift.im/>) and that's working well for me.
> 
> Cheers,
> Andy
> 
> 
> 
> On Fri, Mar 20, 2020 at 9:31 PM Glen <[email-masked] <mailto:[email-masked]>> wrote:
> https://www.ietf.org/how/meetings/jabber/ <https://www.ietf.org/how/meetings/jabber/>
> 
> The page now includes:
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/107all <https://www.ietf.org/mailman/listinfo/107all>
> --
> 107attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/107attendees

---

From: "John Levine" <[email-masked]>
Date: 21 Mar 2020 17:09:54 -0400

In article <CAA=duU0_Z_0H4HNcW63K=[email-masked]> you write:
> I'm using Swift (https://swift.im/) and that's working well for me.

I use Swift under Mojave, works well.

I also use BeagleIM, web page at https://beagle.im/, download from the
app store.  I like its window organization a little better than Swift
but that's definitely a matter of taste.

Adium's OK but if you're installing a client I would try something
that isn't abandonware.

---

From: "Andrew G. Malis" <[email-masked]>
Date: Sat, 21 Mar 2020 17:23:44 -0400

Ben, Glen, et al,

Thanks for the updates. I used to use Adium, but it stopped connecting for
me. But seeing as I have Swift, I don't have to figure out why I was having
a problem with Adium. :-)

Cheers,
Andy

On Sat, Mar 21, 2020 at 4:50 PM Ben Campbell <[email-masked]> wrote:

> Hi,
>
> Adium runs fine for me on Catalina (10.15.3). I originally had a preoblem
> with it scrolling messages, but there a work around:
>
>
> https://news.softpedia.com/news/how-to-fix-broken-auto-scrolling-in-adium-on-macos-catalina-527933.shtml
>
> ones as well). I'm using Swift (https://swift.im/) and that's working
> well for me.
>
> Cheers,
> Andy
>
>
>

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Sat, 21 Mar 2020 20:39:16 -0300

Trillian also works well, although it requires a previous registration 
(a “Trillian” account”)

/Carlos

On 21 Mar 2020, at 17:41, Andrew G. Malis wrote:

> well

---

From: Bob Hinden <[email-masked]>
Date: Sat, 21 Mar 2020 17:48:37 -0700

Adium stopped working for me on 10.14.6.   It crashes when I start up.

I installed Jitsi yesterday and am able join the IETF Hallway.  I will check out Swift.

Bob

> On Mar 21, 2020, at 2:09 PM, John Levine <[email-masked]> wrote:
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 21 Mar 2020 21:18:14 -0400

I have attempted to get Adium to work on multiple occasions without
success. Possibly because the account service I was trying to use is no
longer being maintained. The built in service list is stale.

If we are going to use jabber at all, we need some easily accessible means
of opening accounts on a service that is going to be maintained.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 21 Mar 2020 21:27:48 -0400

What should be dispositive here is the number of people for whom Adium DOES
NOT WORK

The fact that some people manage to run Adium under the right conditions
does not mean it should be recommended. If it fails to work for even 10%,
it is irresponsible to recommend it.

On Sat, Mar 21, 2020 at 8:49 PM Bob Hinden <[email-masked]> wrote:

> > In article <CAA=duU0_Z_0H4HNcW63K=
> [email-masked]> you write:

---

From: Jay Daley <[email-masked]>
Date: Sun, 22 Mar 2020 14:42:04 +1300

Phillip

The page that Glen has helpfully prepared [1] lists five public jabber servers that he has verified allow public account creation and can connect to IETF rooms. 

I’m not sure how we can make any statement about the ongoing maintenance of any third-party service. 

[1] https://ietf.org/how/meetings/jabber/

Jay

(sent from a device that insists on top posting)

-- 
Jay Daley
IETF Executive Director

> On 22/03/2020, at 2:18 PM, Phillip Hallam-Baker <[email-masked]> wrote:
> 
> 
> I have attempted to get Adium to work on multiple occasions without success. Possibly because the account service I was trying to use is no longer being maintained. The built in service list is stale.
> 
> If we are going to use jabber at all, we need some easily accessible means of opening accounts on a service that is going to be maintained.
> 
> 
>

---

From: Glen <[email-masked]>
Date: Sat, 21 Mar 2020 18:43:02 -0700

> If we are going to use jabber at all, we need some easily accessible means of opening accounts on a service that is going to be maintained.

Phillip -

Perhaps I am misunderstanding you, but I think you're asking for ways
of creating a reliable Jabber account.

While it's impossible to know what Jabber providers will be here
"tomorrow" (for some value of "tomorrow") I spent quite a bit of time
yesterday updating our resource page and locating a list of Jabber
servers you can use today.

On Fri, Mar 20, 2020 at 9:31 PM Glen <[email-masked]> wrote: [1]
>> >> IETF Jabber chatrooms and from which free accounts can be obtained

I found five servers in different parts of the world with different
signup methods, and tested each one to make sure it was working and
could connect to the IETF chat rooms.   I, Jay and others worked on
getting the IETF Jabber information webpage [2] cleaned up and made
more readable, as a resource to the community. The servers I found and
tested are listed and linked on that page.

Apologies if I'm misunderstanding you, but the resources are there -
at least for "today".

And while I cannot predict which operators will maintain their servers
and which won't, I at least will do everything I can to maintain the
list on the above web page, so that we can more easily and quickly get
online when we wish.

I hope this is helpful.

[1] https://mailarchive.ietf.org/arch/msg/107all/sb8GQn0x4p4_MmvSCzJ_qWtZE78/
[2] https://www.ietf.org/how/meetings/jabber/

Glen
--
Glen Barney
IT Director
AMS (IETF Secretariat)

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sat, 21 Mar 2020 21:52:04 -0400

I was referring to the recommendation for Adium. I have at multiple IETFs
arrived to remember that I can't use my Google account any longer. Then
tried and failed to register in the services listed by Adium

Adium is a pail of fail.

It is irresponsible to recommend it. Even if you can get it to work based
on your existing config, new users simply cannot use it because it directs
them to services that aren't there.

And it isn't even apparent that the services aren't there. The Web front
ends are up for at least two but the back ends aren't. Which makes trying
to configure Adium a waste of time.

Even if this is your favorite client, for new users it is a pail of fail.

On Sat, Mar 21, 2020 at 9:42 PM Jay Daley <[email-masked]> wrote:

> Phillip
>
> The page that Glen has helpfully prepared [1] lists five public jabber
> servers that he has verified allow public account creation and can connect
> to IETF rooms.
>

---

From: Muhammad Waseem <[email-masked]>
Date: Sun, 22 Mar 2020 09:34:35 +0500

Dear admin team,

Please unsubscribe me from your mailing list.

Thank you.

On Sun, 22 Mar 2020, 06:53 Phillip Hallam-Baker, <[email-masked]>
wrote:

>> If we are going to use jabber at all, we need some easily accessible
>> means of opening accounts on a service that is going to be maintained.
>>
>>
>>

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 22 Mar 2020 06:43:24 +0100

> Adium stopped working for me on 10.14.6.   It crashes when I start up.

Have you tried reinstalling the current version (1.5.10.4)?
(There is a newer version 1.5.11... that is actually older.)

> I installed Jitsi yesterday and am able join the IETF Hallway.  

Now I’m curious — how do you “install” Jitsi?

> I will check out Swift.

Works for me.
Weirdly, something is going on with it even while my laptop power-naps…

Re Jabber accounts: I tried Glen’s suggestion sure.im, and sure I’m in :-)

Grüße, Carsten

---

From: "Bron Gondwana" <[email-masked]>
Date: Sun, 22 Mar 2020 19:45:27 +1100

On Sun, Mar 22, 2020, at 12:52, Phillip Hallam-Baker wrote:
> I was referring to the recommendation for Adium. I have at *multiple IETFs* arrived to remember that I can't use my Google account any longer. *Then tried and failed* to register in the services listed by Adium 
> 
> Adium is a pail of fail.

It seems from the data above that maybe it's not just Adium at fault here. I arrive at every IETF and my jabber.at pidgin account still works, but if it failed I wouldn't blame Pidgin, even if it still had jabber.at as a suggested service. I'd blame myself for not preparing properly and checking that my tools worked.

If there's a better XMPP client for MacOS which comes with a built in set of services which work out of the box, perhaps suggesting that it also get added to the recommended client list would be a more productive approach than bagging something which clearly works for many others.

Cheers,

Bron.

--
 Bron Gondwana, CEO, Fastmail Pty Ltd
 [email-masked]

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Sun, 22 Mar 2020 12:34:27 +0000

(I work at the Internet Society but speak for myself here.)

Hear hear, Adium has at least 2 critical vulnerabilities; you shouldn't use it and IETF shouldn't recommend it:

https://www.cvedetails.com/vulnerability-list.php?vendor_id=9415&product_id=&version_id=&page=1&hasexp=0&opdos=0&opec=0&opov=0&opcsrf=0&opgpriv=0&opsqli=0&opxss=0&opdirt=0&opmemc=0&ophttprs=0&opbyp=0&opfileinc=0&opginf=0&cvssscoremin=0&cvssscoremax=0&year=0&month=0&cweid=0&order=3&trc=6&sha=24e7858a9b3d4223195aa4016c06e487c241a742

--
Joseph Lorenzo Hall, Senior Vice President, Strong Internet
[email-masked] | +1-703-483-9504
internetsociety.org | @internetsociety
pgp: https://josephhall.org/gpg-key
3CA28D7B9F6DDBD34B1016075F86698740A9A871
________________________________
From: 107attendees <[email-masked]> on behalf of Phillip Hallam-Baker <[email-masked]>
Sent: Saturday, March 21, 2020 9:52:04 PM
To: Jay Daley <[email-masked]>
Cc: [email-masked] <[email-masked]>; Andrew G. Malis <[email-masked]>; Glen <[email-masked]>
Subject: Re: [107attendees] [107all] Jabber Service Information for IETF 107

I was referring to the recommendation for Adium. I have at multiple IETFs arrived to remember that I can't use my Google account any longer. Then tried and failed to register in the services listed by Adium

Adium is a pail of fail.

It is irresponsible to recommend it. Even if you can get it to work based on your existing config, new users simply cannot use it because it directs them to services that aren't there.

And it isn't even apparent that the services aren't there. The Web front ends are up for at least two but the back ends aren't. Which makes trying to configure Adium a waste of time.

On Sat, Mar 21, 2020 at 9:42 PM Jay Daley <[email-masked]<mailto:[email-masked]>> wrote:
Phillip

Jay

--
Jay Daley
IETF Executive Director

On 22/03/2020, at 2:18 PM, Phillip Hallam-Baker <[email-masked]<mailto:[email-masked]>> wrote:

On Sat, Mar 21, 2020 at 4:47 PM Glen <[email-masked]<mailto:[email-masked]>> wrote:
Hi Andy -

Thanks,
Glen

On Sat, Mar 21, 2020 at 1:41 PM Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:
> On Fri, Mar 20, 2020 at 9:31 PM Glen <[email-masked]<mailto:[email-masked]>> wrote:
>>
>> [email-masked]<mailto:[email-masked]>

--
107attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/107attendees
--
107attendees mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/107attendees

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 22 Mar 2020 13:41:43 +0100

> Hear hear, Adium has at least 2 critical vulnerabilities; you shouldn't use it and IETF shouldn't recommend it:

I may have trouble decoding this list, but I remember seeing these vulns a decade ago and seeing them fixed (or becoming irrelevant as, e.g., MSN hasn’t been in use for half a decade).  Does any of these CVEs still apply to the current version (1.5.10.4, when used with jabber?

(I’m also not happy with Adium not having been updated for three years, but maybe one reason is that this wasn’t necessary as instant messaging is, er, “stable".)

Grüße, Carsten

---

From: Jared Mauch <[email-masked]>
Date: Sun, 22 Mar 2020 09:03:47 -0400

> On Mar 21, 2020, at 9:43 PM, Glen <[email-masked]> wrote:
> 

I think it is, but I suspect we should have a longer-term discussion about the future of jabber and if it should be required for the IETF meetings.  I’ve had issues with various clients and ceased using jabber about 3 years ago due to this and the jabber chat/spam bots that popped up as well.  This caused many people to close their systems down to s2s communications.

When someone is asking for a jabber scribe, unless you’ve already done the arcane dance it may not be something one can turn on quickly.  Many of the suggestions in the thread have me revisiting this and trying new clients with various levels of success.

Thanks for the many suggestions and advice all.

- Jared

---

From: Mohammad Faisal <[email-masked]>
Date: Sun, 22 Mar 2020 13:13:01 +0000 (UTC)

Please unsubscribe me from the list 

Sent from Yahoo Mail for iPhone

- Jared

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Sun, 22 Mar 2020 10:19:42 -0300

Dear Mohammad, you should be easily able to unsubscribe yourself from 
the ML using the link below.

On 22 Mar 2020, at 10:13, Mohammad Faisal wrote:

> <https://www.ietf.org/mailman/listinfo/107attendees>

---

From: "Carlos M. Martinez" <[email-masked]>
Date: Sun, 22 Mar 2020 10:21:27 -0300

Hi,

Now that we have some time in our hands, I’d definitely +1 the idea of 
looking beyond Jabber. It’s not an issue with the protocol itself, the 
protocol is just fine. However, the lack of decent clients makes it hard 
to use.

/Carlos

On 22 Mar 2020, at 10:03, Jared Mauch wrote:

> I think it is, but I suspect we should have a longer-term discussion 
> about the future of jabber and if it should be required for the IETF 
> meetings.  I’ve had issues with various clients and ceased using 
> jabber about 3 years ago due to this and the jabber chat/spam bots 
> that popped up as well.  This caused many people to close their 
> systems down to s2s communications.

---

From: Alexandre PETRESCU <[email-masked]>
Date: Sun, 22 Mar 2020 14:25:00 +0100

Mohammad,

Typically the operation of unsubscribing is initiated by the individual; 
it is a voluntary action.

If ever an admin unsubscribes you from some list it means there is 
something wrong: either you upset somebody or somebody is upset.  I 
think now that is not the case.  I think now you are upset of too much 
information coming from so many different directions.

If you want to unsubscribe, voluntarily, please go to 
https://www.ietf.org/mailman/listinfo/107attendees There there are easy 
options to unsubscribe.

For my part I stay on this list because there will be a Plenary in one 
of the next days, and maybe I learn new interesting things.

I learned many interesting things at IETF in recent months.  For 
example, the ability to use accents in xml2rfc while writing Internet 
Drafts led me to develop my skill with the text editor emacs, which 
further led me to understand better public and new rules in the country 
where I live.

Yours,

--
Alexandre Petrescu
[email-masked], tél 0169089223, LF/HF 3 (stress)

Le 22/03/2020 à 14:13, Mohammad Faisal a écrit :
> <https://overview.mail.yahoo.com/?.src=iOS>
>
>     > On Mar 21, 2020, at 9:43 PM, Glen <[email-masked]
>     <mailto:[email-masked]>> wrote:
>     >
>     I think it is, but I suspect we should have a longer-term
>     discussion about the future of jabber and if it should be required
>     for the IETF meetings.  I’ve had issues with various clients and
>     ceased using jabber about 3 years ago due to this and the jabber
>     chat/spam bots that popped up as well.  This caused many people to
>     close their systems down to s2s communications.
>
>     When someone is asking for a jabber scribe, unless you’ve already
>     done the arcane dance it may not be something one can turn on
>     quickly..  Many of the suggestions in the thread have me
>     revisiting this and trying new clients with various levels of success.
>
>     [email-masked] <mailto:[email-masked]>

---

From: Alexandre PETRESCU <[email-masked]>
Date: Sun, 22 Mar 2020 14:25:30 +0100

I agree

--
Alexandre Petrescu
[email-masked], tél 0169089223, LF/HF 3

---

From: Joseph Lorenzo Hall <[email-masked]>
Date: Sun, 22 Mar 2020 13:26:21 +0000

> On Mar 22, 2020, at 08:41, Carsten Bormann <[email-masked]> wrote:
> 

That's a good point; I don't see much in the way of specific security attention in the recent release notes (which seem to focus on Twitter API integration). I would beware.

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 22 Mar 2020 14:32:30 +0100

> That's a good point; I don't see much in the way of specific security attention in the recent release notes (which seem to focus on Twitter API integration). I would beware.

Indeed.  

At this point I’m much more wary of the various vendor-supplied teleconferencing applications that are experience sudden surges in use; these are typically done by vendors that don’t care about security (or have a company policy to actively work against security, such as Zoom).

So whatever I can do with WebRTC, wins, because I don’t have to install questionable vendor blobs that run outside sandboxes providing reasonable containment.

Similarly, a Web-based IM client wins over installable ones; for previous IETF meetings that was meetecho; what can we use now?

Grüße, Carsten

---

From: Alexandre PETRESCU <[email-masked]>
Date: Sun, 22 Mar 2020 14:51:59 +0100

To avoid information overload, one could use filters in the Mail User 
Agent (MUA, email reader, email application).

For my part I use thunderbird with Message Filters in the menu, and use 
"[email-masked]" as a criterion to filter and move the mails in a 
folder.

Yours,

Le 22/03/2020 à 14:25, Alexandre PETRESCU a écrit :
>
> Mohammad,
>
> Typically the operation of unsubscribing is initiated by the 
> individual; it is a voluntary action.
>
> https://www.ietf.org/mailman/listinfo/107attendees There there are 
> easy options to unsubscribe.
>
> further led me to understand better public and new rules in the 
> country where I live.
>
> Yours,
>
> --
> Alexandre Petrescu
>>     discussion about the future of jabber and if it should be
>>     required for the IETF meetings.  I’ve had issues with various
>>     clients and ceased using jabber about 3 years ago due to this and
>>     the jabber chat/spam bots that popped up as well.  This caused
>>     many people to close their systems down to s2s communications.
>>

---

From: Ted Lemon <[email-masked]>
Date: Sun, 22 Mar 2020 10:23:57 -0400

It’s not clear to me that we need an alternative to Jabber, because I don’t think there is a cross-platform alternative.  But we need to acknowledge that Jabber is dying right now, and if we want to rely on it, we need to take responsibility for doing something about that, and not just keep using it until it withers away completely.

I had suggested to Glen privately that one of the things we could do that would improve the situation would be to set up an IETF Jabber server that uses the same authentication we use for the datatracker.  This would at least solve the problem of “does this server work anymore and is it a spam nightmare.”

Separately, if we really want to use Jabber clients, we should think about what that looks like.  There doesn’t really seem to be a significant market for Jabber clients—I think that’s what we’re seeing here, with Adium dying out.  None of the clients I’ve worked with seem well-supported.

Maybe this is an additional tool that we need to work on.  Maybe not, but it’s worth thinking about.  How hard would a Javascript jabber client that runs on all modern browsers be?

Separately, is the reason Jabber is dying that it’s not the right design for modern times?  I always felt that it was inordinately complicated, and didn’t have a very good trust model.   Do we need to do something like JMAP for Jabber?

Sent from my iPad

> On Mar 22, 2020, at 9:21 AM, Carlos M. Martinez <[email-masked]> wrote:
> 
> Hi,
> 
> Now that we have some time in our hands, I’d definitely +1 the idea of looking beyond Jabber. It’s not an issue with the protocol itself, the protocol is just fine. However, the lack of decent clients makes it hard to use.
> 
> /Carlos
>

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 22 Mar 2020 11:27:01 -0400

I have spent years deliberately cultivating a high degree of intolerance
for fail.

Why? Because that is what Steve did.

Steve as in Steve Jobs. He turned a company that was weeks away from
bankruptcy into trillion dollar company by focusing ruthlessly on the user
experience. Don't you ever dare lecture the user when it doesn't work.

This is a technology organization or it is nothing. If people choose to use
obsolete tools I do actually see that as a reflection on their skills.

On Sun, Mar 22, 2020 at 4:45 AM Bron Gondwana <[email-masked]>
wrote:

> I was referring to the recommendation for Adium. I have at *multiple
> IETFs* arrived to remember that I can't use my Google account any longer. *Then
> tried and failed* to register in the services listed by Adium
>
> Adium is a pail of fail.
>
>
> It seems from the data above that maybe it's not just Adium at fault
> here.  I arrive at every IETF and my jabber.at pidgin account still
> works, but if it failed I wouldn't blame Pidgin, even if it still had
> jabber.at as a suggested service.  I'd blame myself for not preparing
> properly and checking that my tools worked.
>
> If there's a better XMPP client for MacOS which comes with a built in set
> of services which work out of the box, perhaps suggesting that it also get
> added to the recommended client list would be a more productive approach
> than bagging something which clearly works for many others.
>
> Cheers,
>
> Bron.
>
> --

---

From: Christian Hopps <[email-masked]>
Date: Sun, 22 Mar 2020 11:46:09 -0400

> On Mar 22, 2020, at 10:23 AM, Ted Lemon <[email-masked]> wrote:
> 

Server side issues:

- Some orgs like to just buy chat as a service so e.g., slack.
- People like the full history that is presented automatically to the client on these non-jabber services.
- People like the server side notification options that jabber is lacking.
- People like the development integration (e.g., auto hyper-linking issue numbers, commit SHAs, pull requests, etc) that things like gitter (github) or mattermost (gitlab) have.

I think the technical things could actually be done with jabber, but I don't think anyone has had want or perhaps time to do it (e.g., if I had infinite time I might take a shot at the auto hyper-linking to project resources in one of the open source jabber servers).

I also think the people that did have time to address these issues maybe end up starting their own "chat as a service" companies/services. :)

The client side suffers I think b/c of lack of adoption due to the server side issues.

Thanks,
Chris.

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 22 Mar 2020 12:01:22 -0400

On Sun, Mar 22, 2020 at 10:24 AM Ted Lemon <[email-masked]> wrote:

> It’s not clear to me that we need an alternative to Jabber, because I
> don’t think there is a cross-platform alternative.  But we need to
> acknowledge that Jabber is dying right now, and if we want to rely on it,
> we need to take responsibility for doing something about that, and not just
> keep using it until it withers away completely.
>

I agree. The big problem with Jabber is that it competes directly with
Signal, KeyBase etc. which are all very slick, easy to use with end-to
end security and locked in to single -point proprietary services. Open
source code is irrelevant to me if I can't use the service of my choice.
Not-for-profit doth not convince me, I have found myself competing directly
against a for-profit company built out of a not-for-profit so many times in
the past.

For some reason, messaging has never made the leap to a federated system so
I can be [email-masked]. Jabber failed to compete with AOL instant
messenger.

One missing part of the Jabber story is security. It is not end-to-end
secure and one consequence is that it is vulnerable to spam.

If people are interested, my plan with the Mesh all along was to build a
true end-to-end secure messaging service using the cryptographic tools
developed after PGP was launched. A tool that is genuinely federated
allowing anyone to set up their own service and allows for persistence.

> I had suggested to Glen privately that one of the things we could do that
> would improve the situation would be to set up an IETF Jabber server that
> uses the same authentication we use for the datatracker.  This would at
> least solve the problem of “does this server work anymore and is it a spam
> nightmare.”
>

That seems to me to be the way forward in the short term.

Separately, is the reason Jabber is dying that it’s not the right design
> for modern times?  I always felt that it was inordinately complicated, and
> didn’t have a very good trust model.   Do we need to do something like JMAP
> for Jabber?
>

It is a crowded market. But everyone wants to be the lone surviving
monopolist and users are getting really upset about the need to maintain 12
accounts just to be able to talk to everyone. See the XKCD on this. It is
clear that there isn't really going to be a single global monopolist and
even if that happened, the EU and certain US politicians have made clear
that they weren't going to tolerate that even before current circumstances
caused a rediscovery of the value of government action.

If people are interested, we can have a design discussion offline. My
criteria are as follows:

1) Federated using the DNS using [email-masked] type contact addresses

2) Easy configuration for domain owners so they don't have to run their own
presence or reflector service. SRV record discovery as the primary means of
contact, HTTPS well known service as fallback for discovery.

3) End to end secure with both persistence and off the record modes
available. If I am running a collaboration in an enterprise team, I want to
be able to onboard a new employee and have them instantly have access to
prior chats etc.

4) Support all communication modes: email, messaging, sharable file store,
voice, video, desktop

---

From: Jared Mauch <[email-masked]>
Date: Sun, 22 Mar 2020 13:32:05 -0400

> On Mar 22, 2020, at 12:01 PM, Phillip Hallam-Baker <[email-masked]> wrote:
> 
> 
> I agree. The big problem with Jabber is that it competes directly with Signal, KeyBase etc. which are all very slick, easy to use with end-to end security and locked in to single -point proprietary services. Open source code is irrelevant to me if I can't use the service of my choice. Not-for-profit doth not convince me, I have found myself competing directly against a for-profit company built out of a not-for-profit so many times in the past.
> 
> For some reason, messaging has never made the leap to a federated system so I can be [email-masked]. Jabber failed to compete with AOL instant messenger.
> 
> One missing part of the Jabber story is security. It is not end-to-end secure and one consequence is that it is vulnerable to spam. 
> 

I think one of the key reasons that Slack is useful for me at my job is it doesn’t suffer from the problems that XMPP had where I could 

a) only login from one device
b) messages could be directed to specific instances of “me” that were not monitored (eg: desktop when I’m mobile, or laptop when I’m at desktop and laptop may be in travel bag)
c) I did not have full message consistency over the devices, chat history would be in shards on different devices

There are other things that work similarly (eg: Webex teams) as well.  They have APIs for integration and both public (group) and private (DM) capabilities.

I do want to nudge people that the 107 attendees list is perhaps not the best place to discuss

a) is XMPP still viable for future meetings
b) are we replacing XMPP
c) what do we replace it with
d) what are the requirements (eg: I can expect that some in the community would expect forward-secrecy, but there are places where it’s not applicable such as WG discussions that should be public).

I still haven’t managed to get my jabber setup working again.  Going to try again later tonight before I go fully to a 3rd party system/solution.

- Jared

---

From: Phillip Hallam-Baker <[email-masked]>
Date: Sun, 22 Mar 2020 14:07:40 -0400

Lets take the design conversation to many couches as requested.

I think the point has now been made that Jabber was a valiant effort and
while we will continue to use it in the short term it is time to look
beyond it.

On Sun, Mar 22, 2020 at 1:32 PM Jared Mauch <[email-masked]> wrote:

> Signal, KeyBase etc. which are all very slick, easy to use with end-to end
> security and locked in to single -point proprietary services. Open source
> code is irrelevant to me if I can't use the service of my choice.
> > For some reason, messaging has never made the leap to a federated system
> so I can be [email-masked]. Jabber failed to compete with AOL instant
> messenger.
> >
> I think one of the key reasons that Slack is useful for me at my job is it
> doesn’t suffer from the problems that XMPP had where I could
>
> b) messages could be directed to specific instances of “me” that were not
> monitored (eg: desktop when I’m mobile, or laptop when I’m at desktop and
> laptop may be in travel bag)
> There are other things that work similarly (eg: Webex teams) as well.
> They have APIs for integration and both public (group) and private (DM)
> capabilities.
>
> d) what are the requirements (eg: I can expect that some in the community
> would expect forward-secrecy, but there are places where it’s not
> applicable such as WG discussions that should be public).
>
> I still haven’t managed to get my jabber setup working again.  Going to
> try again later tonight before I go fully to a 3rd party system/solution.
>
> - Jared

---

From: Sam Gammon <[email-masked]>
Date: Sun, 22 Mar 2020 19:15:49 -0700

Hey All,

Could I suggest IRC, with rooms for different sessions? W3C or a few WG
have IRC bots that can also relay to Github, or other places. Just a
thought, and I appreciate the discussion.

-

On Sun, Mar 22, 2020 at 11:08 Phillip Hallam-Baker <[email-masked]>
wrote:

>> > For some reason, messaging has never made the leap to a federated
>> system so I can be [email-masked]. Jabber failed to compete with AOL
>> instant messenger.
>> >
>> I think one of the key reasons that Slack is useful for me at my job is
>> it doesn’t suffer from the problems that XMPP had where I could
>>
-- 

-sam

sam gammon
founder and CEO, Bloomworks <https://bloomworks.io/>
916.341.9482 <+19163419482> // [email-masked]
PGP: F6465D6FCE108644731B2A3AEABC7900D506BFF3

-- 

This message (and any associated files) may contain confidential 
and/or privileged information. If you are not the intended recipient or 
authorized to receive this for the intended recipient, you must not use, 
copy, disclose or take any action based on this message or any information 
herein. If you have received this message in error, please advise the 
sender immediately and delete this message. Thank you for your cooperation.

---

From: Alexandre PETRESCU <[email-masked]>
Date: Mon, 23 Mar 2020 10:30:16 +0100

At work they pondered over a number of messaging apps publicly and 
freely available on the Internet: Signal, WhatsApp and a few others.  
Claims were made about WhatsApp weaknesses in 'security' of last year, 
and some Gold version these days, although I am not sure.  From security 
standpoint (whatever that means these days), last recommendation is for 
Signal use.  Signal has some difficulty on installation in that Google 
Play has some old version not up to date and, if I install the 'apk' 
from Signal, my Android warns me about Security risks.  With Signal on 
Windows one can see the names of others in some cases, but in other 
cases one can only see the phone numbers so you dont know who you talk 
to (and there is no means to create 'contacts').

For IETF work I tested Exodus on Windows 10 last week during the webex 
trial of IETF for Plenay, and it worked.  In my earlier IETF virtual 
meetings there were some times up to 30 people in Exodus jabber room, 
and at times it scrolled with hickups.  I dont know how that would 
scroll (smoothly?  too fast?) if there were hundreds in the room.

Yours,

Le 23/03/2020 à 03:15, Sam Gammon a écrit :
> Hey All,
>
> Could I suggest IRC, with rooms for different sessions? W3C or a few 
> WG have IRC bots that can also relay to Github, or other places. Just 
> a thought, and I appreciate the discussion.
>
>
> -
>
> On Sun, Mar 22, 2020 at 11:08 Phillip Hallam-Baker 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I think the point has now been made that Jabber was a valiant
>     effort and while we will continue to use it in the short term it
>     is time to look beyond it.
>
>     On Sun, Mar 22, 2020 at 1:32 PM Jared Mauch <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>
>
>         > On Mar 22, 2020, at 12:01 PM, Phillip Hallam-Baker
>         <[email-masked] <mailto:[email-masked]>> wrote:
>         >
>         >
>         > On Sun, Mar 22, 2020 at 10:24 AM Ted Lemon <[email-masked]
>         <mailto:[email-masked]>> wrote:
>         > It’s not clear to me that we need an alternative to Jabber,
>         because I don’t think there is a cross-platform alternative. 
>         But we need to acknowledge that Jabber is dying right now, and
>         if we want to rely on it, we need to take responsibility for
>         doing something about that, and not just keep using it until
>         it withers away completely.
>         >
>         > I agree. The big problem with Jabber is that it competes
>         directly with Signal, KeyBase etc. which are all very slick,
>         easy to use with end-to end security and locked in to single
>         -point proprietary services. Open source code is irrelevant to
>         me if I can't use the service of my choice. Not-for-profit
>         doth not convince me, I have found myself competing directly
>         against a for-profit company built out of a not-for-profit so
>         many times in the past.
>         >
>         > For some reason, messaging has never made the leap to a
>         federated system so I can be [email-masked]
>         <mailto:[email-masked]>. Jabber failed to compete with AOL
>         instant messenger.
>         >
>         > One missing part of the Jabber story is security. It is not
>         end-to-end secure and one consequence is that it is vulnerable
>         to spam.
>         >
>
>         I think one of the key reasons that Slack is useful for me at
>         my job is it doesn’t suffer from the problems that XMPP had
>         where I could
>
>         b) messages could be directed to specific instances of “me”
>         that were not monitored (eg: desktop when I’m mobile, or
>         laptop when I’m at desktop and laptop may be in travel bag)
>         c) I did not have full message consistency over the devices,
>         chat history would be in shards on different devices
>
>         There are other things that work similarly (eg: Webex teams)
>         as well.  They have APIs for integration and both public
>         (group) and private (DM) capabilities.
>
>         d) what are the requirements (eg: I can expect that some in
>         the community would expect forward-secrecy, but there are
>         places where it’s not applicable such as WG discussions that
>         should be public).
>
>         I still haven’t managed to get my jabber setup working again. 
>         Going to try again later tonight before I go fully to a 3rd
>         party system/solution.
>
>         - Jared
>
>     -- 
> 916.341.9482 <tel:+19163419482>//[email-masked] 
> <mailto:[email-masked]>
> ------------------------------------------------------------------------
> and/or privileged information. If you are not the intended recipient 
> or authorized to receive this for the intended recipient, you must not 
> use, copy, disclose or take any action based on this message or any 
> information herein. If you have received this message in error, please 
> advise the sender immediately and delete this message. Thank you for 
> your cooperation.
>

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 23 Mar 2020 12:27:08 -0400

I am in the [email-masked] as rgmhtt.  I amconnected via jabb.im

I am using pidgin on Fedora.

When I joined the hallway conversation, I provided my ID and domain, and 
did not provide a password.

I can see join and leave messages but I am not seeing any talk.

I sent a message but did not see it in the dialog window.

How do I get to see messages (or are people just walking around in the 
hallway :) )?

thanks

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 23 Mar 2020 13:59:11 -0400

Robert,

I see you as signed in. I just tried sending a message for you (well, like
twitter, everything's public, but I addressed it to you). Did you see it?

Cheers,
Andy

---

From: Robert Moskowitz <[email-masked]>
Date: Mon, 23 Mar 2020 14:06:27 -0400

Andy,

No I did not see it.  Is anyone else connecting via jabb.im?

Or using Pidgin on Linux?

When people join, do they provide any login information with their IETF, 
maybe datatracker, ID?

Bob

On 3/23/20 1:59 PM, Andrew G. Malis wrote:
> Robert,
>
> I see you as signed in. I just tried sending a message for you (well, 
> like twitter, everything's public, but I addressed it to you). Did you 
> see it?
>
> Cheers,
> Andy
>
>
> On Mon, Mar 23, 2020 at 12:29 PM Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     I am in the [email-masked]
>     <mailto:[email-masked]> as rgmhtt.  I amconnected via
>     jabb.im <http://jabb.im>
>

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 23 Mar 2020 14:18:36 -0400

Bob,

I'm on a Mac, so I can't help on Linux. I'm using Swift, which also has a
Linux version at swift.im. I'm using jabber.hot-chilli.net for my XMPP
account.

You can just join a room without needing a password. The room gets all of
the information it needs via your XMPP account information that's
configured in the client.

Cheers,
Andy

On Mon, Mar 23, 2020 at 2:06 PM Robert Moskowitz <[email-masked]>
wrote:

> On Mon, Mar 23, 2020 at 12:29 PM Robert Moskowitz <
> [email-masked]> wrote:
>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 23 Mar 2020 12:04:50 -0700

Hi Glen,

First of all, thanks for putting the page together. For years I have tried to get one place to resolve all issues, but have struggled.

After getting an account on one of the servers, the issue I seem to have is connecting to any of the chat rooms, e.g. [email-masked] <mailto:[email-masked]>.

I am trying to File->Join Group Chat

In addition to the Chat Room Name which I give as [email-masked] <mailto:[email-masked]>, it wants Server address. If I do not fill any information other that the chat room, I get the error:

Invalid Room Name. [email-masked] <mailto:[email-masked]> is not a valid room name.

What am I doing wrong?

> On Mar 20, 2020, at 6:30 PM, Glen <[email-masked] <mailto:[email-masked]>> wrote:
>

---

From: "Black, David" <[email-masked]>
Date: Mon, 23 Mar 2020 19:11:33 +0000

Dell Customer Communication - Confidential

Chat Room = hallway
Server = jabber.ietf.org

Thanks, --David

From: 107attendees <[email-masked]> On Behalf Of Mahesh Jethanandani
Sent: Monday, March 23, 2020 3:05 PM
To: Glen
Cc: [email-masked]
Subject: Re: [107attendees] [107all] Jabber Service Information for IETF 107

[EXTERNAL EMAIL]

Hi Glen,

After getting an account on one of the servers, the issue I seem to have is connecting to any of the chat rooms, e.g. [email-masked]<mailto:[email-masked]>.

In addition to the Chat Room Name which I give as [email-masked]<mailto:[email-masked]>, it wants Server address. If I do not fill any information other that the chat room, I get the error:

Invalid Room Name. [email-masked]<mailto:[email-masked]> is not a valid room name.

What am I doing wrong?

On Mar 20, 2020, at 6:30 PM, Glen <[email-masked]<mailto:[email-masked]>> wrote:

The page now includes:

Two notes:

Thank you.

Glen
--
Glen Barney
IT Director
AMS (IETF Secretariat)

---

From: Glen <[email-masked]>
Date: Mon, 23 Mar 2020 12:44:51 -0700

Hi Mahesh -

File->Join Group Chat
Room Name:  hallway
Server Address:  jabber.ietf.org

Let me know!

Thanks,
Glen

On Mon, Mar 23, 2020 at 12:04 PM Mahesh Jethanandani
<[email-masked]> wrote:
> After getting an account on one of the servers, the issue I seem to have is connecting to any of the chat rooms, e.g. [email-masked].
>
> In addition to the Chat Room Name which I give as [email-masked], it wants Server address. If I do not fill any information other that the chat room, I get the error:
>
> Invalid Room Name. [email-masked] is not a valid room name.
>
> What am I doing wrong?
>
> On Mar 20, 2020, at 6:30 PM, Glen <[email-masked]> wrote:
>

---

From: Michael Richardson <[email-masked]>
Date: Mon, 23 Mar 2020 17:05:21 -0400

Phillip Hallam-Baker <[email-masked]> wrote:
    > arrived to remember that I can't use my Google account any longer.

I wish I understood why the Google account doesn't work regularly.
For better or worse, I'm using pidgin and libpurple.
It seems that it being maintained again.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "John Levine" <[email-masked]>
Date: 23 Mar 2020 19:33:09 -0400

>I wish I understood why the Google account doesn't work regularly.

When Google went from Talk to Hangouts they abandoned XMPP support
and the bits have rotted pretty badly since then.

R's,
John

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 24 Mar 2020 09:22:34 -0500

>     > arrived to remember that I can't use my Google account any longer.

I think Adium works fine on Mac. Not with your Google account. Just get an
account on lightswitch.

Behcet

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 25 Mar 2020 18:56:08 -0400

I tried using Adium today on my Mac. Appeared to work except that I
couldn't see any messages, just room arrival/departure notices.

Thanks,
Donald
===============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 2386 Panoramic Circle, Apopka, FL 32703 USA
 [email-masked]

On Tue, Mar 24, 2020 at 10:24 AM Behcet Sarikaya <[email-masked]> wrote:
>
>
>
> On Mon, Mar 23, 2020 at 4:08 PM Michael Richardson <[email-masked]> wrote:
>>
>>
> I think Adium works fine on Mac. Not with your Google account. Just get an account on lightswitch.
>
>
> Behcet
>>

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 25 Mar 2020 16:23:35 -0700

Did you try [email-masked] <mailto:[email-masked]>? I see people still logged in.

> On Mar 25, 2020, at 3:56 PM, Donald Eastlake <[email-masked]> wrote:
>

---

From: Robert Moskowitz <[email-masked]>
Date: Wed, 25 Mar 2020 19:48:15 -0400

I had that using the jabb.im server.

I switched to hot-chilli.net and it worked fine.

I am using pidgin.

-- 
Standard Robert Moskowitz
Owner
HTT Consulting
C:248-219-2059
F:248-968-2824
E:[email-masked]

There's no limit to what can be accomplished if it doesn't matter who 
gets the credit

---

From: Donald Eastlake <[email-masked]>
Date: Wed, 25 Mar 2020 20:02:35 -0400

> I switched to hot-chilli.net and it worked fine.

Thanks, I switched to that and it works now.

Thanks,
Donald

> Robert Moskowitz
> C:      248-219-2059
> F:      248-968-2824
> E:      [email-masked]
>
> There's no limit to what can be accomplished if it doesn't matter who gets the credit