Subject: [107attendees] Where the action is, at virtual meetings ...

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 27 Mar 2020 11:17:50 -0500

I've heard almost every session chairs saying words like "we have X people
who have signed the bluesheets, and 2X people who are in WebEx now, please
go sign the bluesheet". So that's fine.

But I'm also noticing that there are about X people in Jabber, and
honestly, this week, the jabber rooms are incredibly active - probably
because they're playing the part of hallway discussions for each session.
That's been especially true for BOFs, but almost every session has had a
non-stop active jabber room for most/all of the session.

There are a lot of conversations there, that aren't making it into the mike
line, so roughly half the people in WebEx aren't seeing them, and in the
cases I'm familiar with, the jabber conversation has been at least as
well-informed and serious as the voice conversation. And the voice
conversation doesn't always end up in the same place as the jabber
conversation.

Are other people noticing the same thing?

Best,

Spencer

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Mar 2020 12:58:26 -0400

On Mar 27, 2020, at 12:17 PM, Spencer Dawkins at IETF <[email-masked]> wrote:
> There are a lot of conversations there, that aren't making it into the mike line, so roughly half the people in WebEx aren't seeing them, and in the cases I'm familiar with, the jabber conversation has been at least as well-informed and serious as the voice conversation. And the voice conversation doesn't always end up in the same place as the jabber conversation. 

This is natural.  The way the IETF does mic lines is useful for making progress on technical issues, but kind of sucks for controversial issues.  We could almost certainly come up with a more effective consensus-building process than a linear mic line.  Jabber has better quality because it’s free-form, so people don’t just get one shot at expressing themselves.  Communication is an iterative process—often when I speak at the mic and then hear the next people, I realize that I didn’t express myself well and want to clarify, but it’s too late.  This isn’t a problem when there aren’t very many people in the discussion, but it breaks down quickly when there are.

> Are other people noticing the same thing?

Yes.  However.

Jabber is not point and click.  It took me until halfway through the second meeting I attended before I figured out what I was doing wrong and got it working.   Yes, there is a lot of good conversation in the jabber room, although it goes by pretty fast.   If we want jabber to be more democratic, we need to make it point and click.  Which probably means we need something other than jabber, or else need to spend a lot of money building better tools.

---

From: Carrick Bartle <[email-masked]>
Date: Fri, 27 Mar 2020 10:10:48 -0700

What do you mean by "point and click"?

> On Mar 27, 2020, at 9:58 AM, Ted Lemon <[email-masked]> wrote:
> 
> On Mar 27, 2020, at 12:17 PM, Spencer Dawkins at IETF <[email-masked] <mailto:[email-masked]>> wrote:
> -- 
> 107attendees mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/107attendees

---

From: Puneet Sood <[email-masked]>
Date: Fri, 27 Mar 2020 13:14:09 -0400

On Fri, Mar 27, 2020 at 1:00 PM Ted Lemon <[email-masked]> wrote:

> There are a lot of conversations there, that aren't making it into the
> mike line, so roughly half the people in WebEx aren't seeing them, and in
> the cases I'm familiar with, the jabber conversation has been at least as
> This is natural.  The way the IETF does mic lines is useful for making
> progress on technical issues, but kind of sucks for controversial issues.
> We could almost certainly come up with a more effective consensus-building
> process than a linear mic line.  Jabber has better quality because it’s
> free-form, so people don’t just get one shot at expressing themselves.
> Communication is an iterative process—often when I speak at the mic and
> then hear the next people, I realize that I didn’t express myself well and
> want to clarify, but it’s too late.  This isn’t a problem when there aren’t
> very many people in the discussion, but it breaks down quickly when there
> are.
>
> Jabber is not point and click.  It took me until halfway through the
> second meeting I attended before I figured out what I was doing wrong and
> got it working.   Yes, there is a lot of good conversation in the jabber
> room, although it goes by pretty fast.   If we want jabber to be more
> democratic, we need to make it point and click.  Which probably means we
> need something other than jabber, or else need to spend a lot of money
> building better tools.
>

+100 to that. As a 2-year newbie to IETF I have found it hard to get into
the Jabber rooms for the meetings. I have only read the logs of the Jabber
discussions after the meetings so have not been able to participate live.

Another usability issue with Jabber for newcomers: Most members use less
descriptive names on Jabber so it takes a while to map a person I know in
the physical world (from their WG list comments/document names/hallways
discussions) to their Jabber handle. Not sure of the solution but something
that more directly maps the handle to the person's name.

---

From: Carsten Bormann <[email-masked]>
Date: Fri, 27 Mar 2020 18:19:19 +0100

On 2020-03-27, at 17:58, Ted Lemon <[email-masked]> wrote:
> 
> often when I speak at the mic and then hear the next people, I realize that I didn’t express myself well and want to clarify, but it’s too late.  

Oh, so I’m not the only one who thinks that way? :-)

> Which probably means we need something other than jabber, or else need to spend a lot of money building better tools.

Meetecho already has the jabber support; that money was already spent.

Grüße, Carsten

---

From: Carrick Bartle <[email-masked]>
Date: Fri, 27 Mar 2020 10:24:41 -0700

> As a 2-year newbie to IETF I have found it hard to get into the Jabber rooms for the meetings. 

As a <1-year newbie, I've also had difficulty with Jabber. When Adium wasn't sending my messages, I ended up creating an entirely new account and getting a different client, which worked once, but the second time, I couldn't get into a room for unknown reasons until it just magically worked about 10 minutes later.

> On Mar 27, 2020, at 10:14 AM, Puneet Sood <puneets=[email-masked]> wrote:
> 
> 
> 
> On Fri, Mar 27, 2020 at 1:00 PM Ted Lemon <[email-masked] <mailto:[email-masked]>> wrote:
> +100 to that. As a 2-year newbie to IETF I have found it hard to get into the Jabber rooms for the meetings. I have only read the logs of the Jabber discussions after the meetings so have not been able to participate live.
> 
> Another usability issue with Jabber for newcomers: Most members use less descriptive names on Jabber so it takes a while to map a person I know in the physical world (from their WG list comments/document names/hallways discussions) to their Jabber handle. Not sure of the solution but something that more directly maps the handle to the person's name.
>  
> 
> 
> -- 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/107attendees <https://www.ietf.org/mailman/listinfo/107attendees>
> -- 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/107attendees <https://www.ietf.org/mailman/listinfo/107attendees>

---

From: Alexandre PETRESCU <[email-masked]>
Date: Fri, 27 Mar 2020 18:37:43 +0100

Le 27/03/2020 à 17:17, Spencer Dawkins at IETF a écrit :
> I've heard almost every session chairs saying words like "we have X 
> people who have signed the bluesheets, and 2X people who are in WebEx 
> now, please go sign the bluesheet". So that's fine.
>
> because they're playing the part of hallway discussions for each 
> session. That's been especially true for BOFs, but almost every 
> session has had a non-stop active jabber room for most/all of the 
> session.
>
> mike line, so roughly half the people in WebEx aren't seeing them, and 
> in the cases I'm familiar with, the jabber conversation has been at 
> least as well-informed and serious as the voice conversation. And the 
> voice conversation doesn't always end up in the same place as the 
> jabber conversation.
>

Hi,

Thanks for asking.

I followed a big part of Plenary on webex and jabber.  For the unknown 
X, I think I noted down 286 max people in webex of Plenary, and around 
100-something on Blue Sheet of Plenary, and about 20 on jabber of 
hallway during Plenary.  One slide presented during the Plenary said 
something like 300-or-so registered people for IETF 107 (no fee, and 
registration is an approximative indication).

With respect to the question whether I have noticed the same activity on 
jabber, about WG meetings.

For my part I have not checked the jabber rooms, because my first WG of 
concern  virtually meets only on March 31st - 6MAN.

At that date, I hope there will be chatter on jabber.

Until then, probably I will not go to jabber, because of the 
post-scriptum below.

Yours,

Alex, LF/HF 3

---------------

PS: A big parenthesis:

(

BEsides, I am in a deep thinking trouble: I need to strike a balance 
between trying to do work as before, or maybe try to adapt something, or 
do something new about it, I really dont know what.

The reasons that make me think that way are simple indicators such as:

- what does an out-of-office automated message means under these new 
circumstances where it's normal to not be in office.  How can I still 
understand people correctly who are on different layer of lockdown, or 
of fear, or of hunger.  Some people might not be locked down at all, 
while others might have worse problems.

- the Internet is fundamentally a best technology now literraly helping 
us to survive (skype-glued separations of elderly, and tele-work)  - 
there is not enough thanks for that.  But are there any doubts about it 
in first place.  Is the Internet something that might have influenced 
negatively these days (situation-related socially engineered email spam, 
etc), or is it entirely clean.

- what does a Together on t-shirt mean when it shoudl be something like 
'Distanced Physically but Minded Together' or something like that. For a 
joke:  what does 'Standing on Giants' Shoulders' mean when all contact 
is prohibited for some while now.  What does 'Unite' mean when we should 
actually disunite physically.  These are profound dilemmas for me.

Besides that, I personally need to deal with some urgent matters, such as:

- how to best get food without risking being infected or risking 
transmitting it to others.  Getting food in a scalable manner, ie now, 
and again each week.

- when will I be able to get out?

There are also other questions that I have:

- could something that I do at IETF be converted to help with ongoing 
Emergencies?  (e.g. could a communicaiton system be designed to help 
with number reporting from  Hospital to Citizen (instead of from 
Hospital-to-Autority-to-Citizen), could a comm system be used to 
communicate with a yet-to-be-designed air detector of virus, etc ).

- If the Web changed the Society for the best, maybe something could be 
done now to start something to change it again for even Better.

- it might be that all these questions of re-targetting some activities 
are too early to think of because it wont ever be needed, because 
correct medication will pop up sooner.

- it might be that there is no need at all of a Continuity plan for IETF 
meetings, because the lockdown period will last not long enough for 
people to forget the custom, which will come back naturally.

)

Alex, LF/HF 3

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 13:41:18 -0400

On 3/27/20 1:14 PM, Puneet Sood wrote:
>     On Mar 27, 2020, at 12:17 PM, Spencer Dawkins at IETF
>     <[email-masked]
>     <mailto:[email-masked]>> wrote:
>>     There are a lot of conversations there, that aren't making it
>>     into the mike line, so roughly half the people in WebEx aren't
>>     seeing them, and in the cases I'm familiar with, the jabber
>>     conversation has been at least as well-informed and serious as
>>     the voice conversation. And the voice conversation doesn't always
>>     end up in the same place as the jabber conversation. 
>
>     This is natural.  The way the IETF does mic lines is useful for
>     making progress on technical issues, but kind of sucks for
>     controversial issues.  We could almost certainly come up with a
>     more effective consensus-building process than a linear mic line.
>     Jabber has better quality because it’s free-form, so people don’t
>     just get one shot at expressing themselves.  Communication is an
>     iterative process—often when I speak at the mic and then hear the
>     next people, I realize that I didn’t express myself well and want
>     to clarify, but it’s too late. This isn’t a problem when there
>     aren’t very many people in the discussion, but it breaks down
>     quickly when there are.
>
>     Jabber is not point and click.  It took me until halfway through
>     the second meeting I attended before I figured out what I was
>     doing wrong and got it working. Yes, there is a lot of good
>     conversation in the jabber room, although it goes by pretty fast.
>       If we want jabber to be more democratic, we need to make it
>     point and click.  Which probably means we need something other
>     than jabber, or else need to spend a lot of money building better
>     tools.
>
>
> +100 to that. As a 2-year newbie to IETF I have found it hard to get 
> into the Jabber rooms for the meetings. I have only read the logs of 
> the Jabber discussions after the meetings so have not been able to 
> participate live.
>
> Another usability issue with Jabber for newcomers: Most members use 
> less descriptive names on Jabber so it takes a while to map a person I 
> know in the physical world (from their WG list comments/document 
> names/hallways discussions) to their Jabber handle. Not sure of the 
> solution but something that more directly maps the handle to the 
> person's name.

I had to notice, and then be consistant, to set my 'conversation' handle 
to my name instead of my account with my jabber server (hot-chilli.net).

So this is app and app user dependent.

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 13:42:39 -0400

> Meetecho already has the jabber support; that money was already spent.

And since we were not using Meetecho, we did not have that option 
available?  I did not see Meetecho as one of the options for setting up 
Jabber access for this week.

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 13:44:37 -0400

On 3/27/20 1:24 PM, Carrick Bartle wrote:
> As a <1-year newbie, I've also had difficulty with Jabber. When Adium 
> wasn't sending my messages, I ended up creating an entirely new 
> account and getting a different client, which worked once, but the 
> second time, I couldn't get into a room for unknown reasons until it 
> just magically worked about 10 minutes later.

I hope that after this week, there will be some good work in wringing 
out the bumps and making test enviornments available.  Also if wg's 
interim virtual meetings were to use Jabber, more people will gain the 
needed skillls to guide new comers.

>
>
>
>> On Mar 27, 2020, at 10:14 AM, Puneet Sood 
>> <puneets=[email-masked] 
>> <mailto:puneets=[email-masked]>> wrote:
>>
>>
>>
>>>     the voice conversation. And the voice conversation doesn't
>>>     always end up in the same place as the jabber conversation. 
>>
>>     more effective consensus-building process than a linear mic
>>     line.  Jabber has better quality because it’s free-form, so
>>     people don’t just get one shot at expressing themselves. 
>>     Communication is an iterative process—often when I speak at the
>>     mic and then hear the next people, I realize that I didn’t
>>     express myself well and want to clarify, but it’s too late.  This
>>     isn’t a problem when there aren’t very many people in the
>>     discussion, but it breaks down quickly when there are.
>>
>> less descriptive names on Jabber so it takes a while to map a person 
>> I know in the physical world (from their WG list comments/document

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Mar 2020 13:51:26 -0400

On Mar 27, 2020, at 1:10 PM, Carrick Bartle <[email-masked]> wrote:
> What do you mean by "point and click”?

I mean that when you click on the light bulb icon in the agenda, it pulls up a new tab in your browser that contains the chat session for the meeting.

Right now, on my iPad or Mac, clicking on that link brings up a fairly random app that I guess claims to serve the jabber:// <jabber://> protocol but in fact does nothing.  I installed three different apps before I found one that actually worked (many thanks to Glen Barney for putting up the informational page on this, BTW).  The one that worked provided no feedback when I entered [email-masked] <mailto:[email-masked]> where it expected “meeting” and accepted the default jabber server where I should have typed jabber.ietf.org <http://jabber.ietf.org/>.  At this point I gave up and didn’t try again until the next meeting, when I finally had a brainstorm that turned out to be correct as to what to type.  The UI gave me no clue that there was a problem—I simply wasn’t in the jabber room and didn’t see the conversation.

This is a total usability fail.  Only people who really, really want to use Jabber, or who have been using it for years and understand it well, will be able to make it work.   I think that’s why a relatively limited number of people participated on jabber as compared to webex, where in order to join I just clicked on the URL and was immediately in the meeting room.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Mar 2020 13:53:55 -0400

> Oh, so I’m not the only one who thinks that way? :-)

I believe it is simply the human condition. :)

> Meetecho already has the jabber support; that money was already spent.

I don’t know if we paid them for that or they did it for free, but the sunk cost fallacy obviously applies here… :)

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Mar 2020 13:55:57 -0400

On Mar 27, 2020, at 1:44 PM, Robert Moskowitz <[email-masked]> wrote:
> I hope that after this week, there will be some good work in wringing out the bumps and making test enviornments available.  Also if wg's interim virtual meetings were to use Jabber, more people will gain the needed skillls to guide new comers.

Unfortunately that can’t happen because it presupposes that they are already on jabber where they can get help.  Since they are not, there’s no way to bootstrap it.  We weren’t allowed to discuss this in the Webex chat because that was being held clear for managing the mic line.

---

From: Carrick Bartle <[email-masked]>
Date: Fri, 27 Mar 2020 10:59:44 -0700

Ah, I see.

> This is a total usability fail. 

Agreed.

> On Mar 27, 2020, at 10:51 AM, Ted Lemon <[email-masked]> wrote:
> 
> On Mar 27, 2020, at 1:10 PM, Carrick Bartle <[email-masked] <mailto:[email-masked]>> wrote:

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 14:05:42 -0400

On 3/27/20 1:55 PM, Ted Lemon wrote:
> On Mar 27, 2020, at 1:44 PM, Robert Moskowitz 
> <[email-masked] <mailto:[email-masked]>> wrote:
>> interim virtual meetings were to use Jabber, more people will gain 
>> the needed skillls to guide new comers.
>
> Unfortunately that can’t happen because it presupposes that they are 
> already on jabber where they can get help.  Since they are not, 
> there’s no way to bootstrap it.  We weren’t allowed to discuss this in 
> the Webex chat because that was being held clear for managing the mic 
> line.
>
For Interims, you have the workgroup lists.  And for bigger calls for 
help, you have this list.

I remember when I joined around Dec '92 and was accessing this list via 
MCImail, as we did not have external email access yet at Chrysler (you 
will see my old MCImail account in RFCs 1527 and 1918).  I had to 
'learn' about things like dress code; yes Vint told me to come in my 
suit and it would be the 2 of use against all of them...

 From email we SHOULD be able to bootstrap meeting use of Jabber (or 
some other chat facility).

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Mar 2020 14:09:16 -0400

On Mar 27, 2020, at 2:05 PM, Robert Moskowitz <[email-masked]> wrote:
> From email we SHOULD be able to bootstrap meeting use of Jabber (or some other chat facility).

Yes, for those people who choose to ask and don’t just remain silent.  If we make it point-and-click, that problem goes away, and we aren’t wasting time helping people to learn how to jump through hoops.

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 14:17:42 -0400

On 3/27/20 2:09 PM, Ted Lemon wrote:
> On Mar 27, 2020, at 2:05 PM, Robert Moskowitz 
> Yes, for those people who choose to ask and don’t just remain silent. 
>  If we make it point-and-click, that problem goes away, and we aren’t 
> wasting time helping people to learn how to jump through hoops.
>
point-and-click only works for special plugins like WebEx.  I can't 
point-and-click to send an email, as I have 4 email clients running at 
any time.  I have to right-click, copy, switch, open , and paste....

And each Jabber client is different in how it takes info to open a 
conversation.  Pidgin did not work with what was there.  So a lot of 
work will be needed here.  Maybe a new protocol?

It would be nice.

Oh and I kind of dread something like Etherpad in place of Jabber. All 
these interactive Web apps, like Github are CPU and bandwidth killers.

---

From: Ted Lemon <[email-masked]>
Date: Fri, 27 Mar 2020 14:29:35 -0400

On Mar 27, 2020, at 2:17 PM, Robert Moskowitz <[email-masked]> wrote:
> point-and-click only works for special plugins like WebEx.  I can't point-and-click to send an email, as I have 4 email clients running at any time.  I have to right-click, copy, switch, open , and paste….

Yes, if you shoot yourself in the foot with a double-barreled shotgun, the IETF is not going to be able to protect you.   When I click on a mailto: link, I get a compose window in my MUA, because I’m not doing something weird.  I say this not as a criticism, but simply to point out that we can do a lot to improve UX without solving every edge case.

> And each Jabber client is different in how it takes info to open a conversation.  Pidgin did not work with what was there.  So a lot of work will be needed here.  Maybe a new protocol?

Slack works orders of magnitude better than jabber for this.  If we don’t want slack, then we need better jabber.   Slack is a really easy solution to the problem, though—I don’t think better jabber is worth spending time on, honestly.

---

From: Carrick Bartle <[email-masked]>
Date: Fri, 27 Mar 2020 11:40:34 -0700

> Yes, if you shoot yourself in the foot with a double-barreled shotgun, the IETF is not going to be able to protect you.

LOL

> Slack is a really easy solution to the problem, though—I don’t think better jabber is worth spending time on, honestly.

+1

> On Mar 27, 2020, at 11:29 AM, Ted Lemon <[email-masked]> wrote:
> 
> On Mar 27, 2020, at 2:17 PM, Robert Moskowitz <[email-masked] <mailto:[email-masked]>> wrote:

---

From: Robert Moskowitz <[email-masked]>
Date: Fri, 27 Mar 2020 14:51:26 -0400

On 3/27/20 2:29 PM, Ted Lemon wrote:
> On Mar 27, 2020, at 2:17 PM, Robert Moskowitz 
>> point-and-click to send an email, as I have 4 email clients running 
>> at any time.  I have to right-click, copy, switch, open , and paste….
>
> Yes, if you shoot yourself in the foot with a double-barreled shotgun, 
> the IETF is not going to be able to protect you.

It was a eyes-wide-open decision:  Multiple instances of Thunderbird or 
multiple mail accounts in one Thunderbird instance.  Lots of things do 
not support the first decision, but it is what I have done for years.

That said...

>   When I click on a mailto: link, I get a compose window in my MUA, 
> because I’m not doing something weird.  I say this not as a criticism, 
> but simply to point out that we can do a lot to improve UX without 
> solving every edge case.
>
> Slack works orders of magnitude better than jabber for this.  If we 
> don’t want slack, then we need better jabber.   Slack is a really easy 
> solution to the problem, though—I don’t think better jabber is worth 
> spending time on, honestly.
>
I have looked around a bit on what xmpp:jaberserver is suppose to do.  
Best I can figure out is Pidgin has not figured this out.  This is out 
of my area of work.  I will try my best to follow along behind others.

---

From: Mary B <[email-masked]>
Date: Fri, 27 Mar 2020 14:05:22 -0500

I had problems with Jabber so didn't see all that chatter. ISTM that since
we are recording sessions, it might be much better to have the chat in the
Webex, so that it's recorded. So, ISTM that running the queue in Jabber
might be a better option.

Regards,
Mary.

---

From: Yoav Nir <[email-masked]>
Date: Fri, 27 Mar 2020 22:59:04 +0300

> On 27 Mar 2020, at 19:17, Spencer Dawkins at IETF <[email-masked]> wrote:
> 
> I've heard almost every session chairs saying words like "we have X people who have signed the bluesheets, and 2X people who are in WebEx now, please go sign the bluesheet". So that's fine.
> 
> But I'm also noticing that there are about X people in Jabber, and honestly, this week, the jabber rooms are incredibly active - probably because they're playing the part of hallway discussions for each session. That's been especially true for BOFs, but almost every session has had a non-stop active jabber room for most/all of the session. 
> 

Yes, and in some ways this is concerning. I don’t think the Webex is giving chairs and ADs a “feel of the room”.

For example, yesterday in privacypass we had a presentation about the problem they are solving complete with swimtrack diagrams.  The presentation ended with a slide asking if people understood the issues and the proposed solution. There were some questions, but that’s not where the real conversation was. The real conversation happened in Jabber, and people were questioning the assumptions, what the problem was, and what was this privacy that it was supposed to be protecting.  It was a very real, technical discussion, but the proponents were not really there. They were busy with the presentations.

The Webex session moved on to proposed token formats, which is a solution detail, and to conversation about whether the (proposed) group should deal only with the web or also other things. All this time, the Jabber conversation was still about the basic assumptions.

If you listen to nothing but the Webex recording, it seems like there was consensus and a bunch of people volunteering to review/contribute/implement.  If you read the Jabber log, it looks like we’re not even sure what this is trying to accomplish.  In a real face-to-face meeting, some of this jabber conversation would spill into the mic line. Here they were rather separate.  I don’t know how we can judge consensus for such a session.  

Yoav

---

From: Alexandre PETRESCU <[email-masked]>
Date: Fri, 27 Mar 2020 22:27:16 +0100

> For example, yesterday in privacypass we had a presentation about the problem they are solving complete with swimtrack diagrams.  The presentation ended with a slide asking if people understood the…

In such busy discussions I some times had on jabber in a WG meeting I 
missed something: there was only one focus point, one single scrolling 
sequence; there should have been 2 or 3 parallel advancing lines of 
chatter visible simultaneously.

The discussions were inter-twinned, but they should have been in 
parallel, but visible simultaneously.

Email clients solve this with 'threads' of discussion, but chat clients 
dont have such feature.  Slack has a channel feature (#channelname) but 
channels are not visible simultaneously, one has to 'switch' between 
channels.

Alex

---

From: Carrick Bartle <[email-masked]>
Date: Fri, 27 Mar 2020 14:59:26 -0700

> Slack has a channel feature (#channelname) but channels are not visible simultaneously, one has to 'switch' between channels.

Slack also has threading, which I agree would be super helpful in these discussions.

> On Mar 27, 2020, at 2:27 PM, Alexandre PETRESCU <[email-masked]> wrote:
> 
> In such busy discussions I some times had on jabber in a WG meeting I missed something: there was only one focus point, one single scrolling sequence; there should have been 2 or 3 parallel advancing lines of chatter visible simultaneously.
> 
> The discussions were inter-twinned, but they should have been in parallel, but visible simultaneously.
> 
> Email clients solve this with 'threads' of discussion, but chat clients dont have such feature.  Slack has a channel feature (#channelname) but channels are not visible simultaneously, one has to 'switch' between channels.
> 
> Alex
> 
>>

---

From: Yoav Nir <[email-masked]>
Date: Sat, 28 Mar 2020 01:06:53 +0300

I’m not sure threading and forking are things we want to encourage in a back-channel to a physical or virtual “room” where the actual discussion is going on.

My issue though is not with the quality of the conversation in Jabber, but with the perception of the “room” that everyone is on the same page, when fervent discussion is going on in the Jabber room.

> On 28 Mar 2020, at 0:59, Carrick Bartle <cbartle891=[email-masked]> wrote:
>

---

From: Alexandre PETRESCU <[email-masked]>
Date: Fri, 27 Mar 2020 23:23:23 +0100

> I’m not sure threading and forking are things we want to encourage in a back-channel to a physical or virtual “room” where the actual discussion is going on.

But there are at least two important threads in a jabber session: the 
minute taking, and the discussion.

Was there minute taking in the jabber room?

> My issue though is not with the quality of the conversation in Jabber, but with the perception of the “room” that everyone is on the same page, when fervent discussion is going on in the Jabber roo…

That looks to me to be indeed a point.  I suspect too that people on 
webex dont read jabber at the same time.

One can check that:  if the jabber discussion is heated, and the webex 
presentation continues as usual, then there is disconnect.

In real f2f meeting such situation is desirable, but when there is no 
f2f then webex should be silent if jabber scrolls.

(I so think)

Alex

---

From: Alexandre PETRESCU <[email-masked]>
Date: Fri, 27 Mar 2020 23:39:08 +0100

> Slack also has threading, which I agree would be super helpful in these discussions.

Ah, thanks!  I think I have noticed that.

Some people spawn a thread out of a main slack discussion, but it seems 
to me that spawned thread becomes a 1-to-1 private discussion, invisible 
to others.  I wll check that slack threading tomorrow with my group at work.

Alex

------------

PS:

I meant 2 to 4 simultaneous threads visible by all in the jabber room.  
Something like when I have 2 buffers in emacs and see both 
simultaneously.  Or like in side-by-side windows.

There should be a thread with minute taking, one with slide advancement 
(next slide please), maybe a few threads with live translatins of the 
webex speech, and then a few threads with discussion, maybe a AD-talk 
SuperThread.  Some such threads should have priority over the webex 
discussion, I think.

I take advantage to make a related remark.  I think I have noticed in 
real f2f discussion two or three people can talk simultaneously and a 
separate listener can say s/he understands the three of them.  Yet, 
there is no single person that can listen while talking, or that can 
talk while listening.   Some people need about half a second after 
talking in order to listen, others need more.

This semantics (3 person talk simultaneously, and one understands the 3) 
is happening with some TV talk shows, and happens in some WG f2f 
meetings, but I think it can not happen with webex.  In webex only one 
person can talk meaningfully; if there are two persons that talk a third 
person will only receive one of the talks.  That's how I think it is, 
but I might be wrong.  The only way to check is to have a f2f meeting 
and webex in same place, and check.  But that's not for now :-)

Alex

---

From: Spencer Dawkins at IETF <[email-masked]>
Date: Fri, 27 Mar 2020 20:33:03 -0500

On this question,

On Fri, Mar 27, 2020 at 5:24 PM Alexandre PETRESCU <
[email-masked]> wrote:

> > I’m not sure threading and forking are things we want to encourage in a
> back-channel to a physical or virtual “room” where the actual discussion is
> going on.
>

Not in any of the sessions I participated in. The minute-takers who were
doing that in public were using Etherpad.

Best,

Spencer

---

From: Benjamin Kaduk <[email-masked]>
Date: Fri, 27 Mar 2020 20:46:11 -0700

> needed skillls to guide new comers.

I will note that this meeting seems to have had enough load to induce
severe lag and maybe even full-on disconnections.  I am regularly in jabber
and hold a weekly meeting via jabber, but had to frantically engage an
alternate solution because my normal setup was not getting me all the
traffic in a timely fashion.  (I saw a couple other people comment about
lag, too, so at least that part is not just me.)

-Ben

---

From: Watson Ladd <[email-masked]>
Date: Fri, 27 Mar 2020 22:00:59 -0700

On Fri, Mar 27, 2020 at 6:46 PM Spencer Dawkins at IETF
<[email-masked]> wrote:
>
> On this question,
>
> On Fri, Mar 27, 2020 at 5:24 PM Alexandre PETRESCU <[email-masked]> wrote:
>>
>>
> Not in any of the sessions I participated in. The minute-takers who were doing that in public were using Etherpad.

There was notetaking in the jabber channel in a few of the sessions I was in.

I think it at least privacypass a bunch of the jabber disconnect was
from people asking basic clarifying questions that they wouldn't in an
f2f or necessary on a mailing list. Lower activation energy=more
activity.

--
"Man is born free, but everywhere he is in chains".
--Rousseau.

---

From: Yoav Nir <[email-masked]>
Date: Sat, 28 Mar 2020 11:00:42 +0300

> On 28 Mar 2020, at 8:00, Watson Ladd <[email-masked]> wrote:
> 
> <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> On this question,
>> 

I tend to disagree. In a F2F meeting those questions do get asked. 

But even before running to the room mic, when the presenter sees a room full of puzzled faces, they begin to explain more all on their own. So it’s not even necessary to run to the mic.

Yoav

---

From: Michael Richardson <[email-masked]>
Date: Sun, 29 Mar 2020 12:39:22 -0400

> lag, too, so at least that part is not just me.)

I once saw a 2 minute lag in seeing my comments echo back.
All the traffic showed up for me, eventually.

I think it was during plenary.
I don't know if there was a new TCP session or not, it didn't persist long
enough for me to investigate, but I certainly did notice and was perplexed.

I didn't remember it until reading your comment.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Tero Kivinen <[email-masked]>
Date: Sun, 29 Mar 2020 19:55:17 +0300

Ted Lemon writes:
>     conversation.  Pidgin did not work with what was there.  So a lot of work
>     will be needed here.  Maybe a new protocol?
> 
> Slack works orders of magnitude better than jabber for this.  If we don’t want
> slack, then we need better jabber.   Slack is a really easy solution to the
> problem, though—I don’t think better jabber is worth spending time on,
> honestly.

Slack does not work with any of the browsers I use (seamonkey). It
simply returns page saysing "This browser is no longer supported".
Yes, I know I can get it working if I simply find out what is the
exact string it wants to have in the User-Agent header, and change my
browser to fake the User-Agent header and send that exact string, but
it is bit annoying, as almost every time when I need that feature, I
need to google up that string to see what it is they need this week.

Of course as they are using standard html stuff anyways everything
works fine with my browser after faking UA, it is just that they do
not want people to use any other browsers than those 4 approved ones.

Earlier they did just say your browser is no longer supported, are you
sure you want to continue, and then you could click "yes, go forward",
but they stopped doing that few years back. That just indicates the
attitude the developers have, meaning we do not care what you want, we
do things as we like to do things, and there is nothing you can do for
that.

So using pidgin to use jabber is much easier for me than using slack.
With jabber I needed to set up pidgin settings once, I do not need to
redo settings every single ietf.
-- 
[email-masked]

---

From: Tom Pusateri <[email-masked]>
Date: Sun, 29 Mar 2020 13:38:54 -0400

> On Mar 29, 2020, at 12:55 PM, Tero Kivinen <[email-masked]> wrote:
> 
> Ted Lemon writes:

For me, most of these solutions are missing searchable archives. This is built in to email. In the past, the IETF has published the jabber logs and I have written scripts to sync them with audio and slides. Slack limits history in most cases I’ve used it.

Any solution going forward should have:

1. history is kept forever
2. easily searchable.
3. timestamps for synchronization
4. source of message can be correlated to IETF person database
5. archive available in standard format (no HTML screen scraping please. Yeah, I know, Beautiful Soup is amazing, but I have better things to do.)

Tom

---

From: Ted Lemon <[email-masked]>
Date: Sun, 29 Mar 2020 14:20:42 -0400

Slack history is kept if you pay them. If we use slack we should do that. If you use a weird browser, it’s not that hard to tweak the browser type string. Much like if you run 4 different MUAs, you will have to make some accommodation. 

> On Mar 29, 2020, at 13:38, Tom Pusateri <[email-masked]> wrote:
> 
> 
>

---

From: Yoav Nir <[email-masked]>
Date: Sun, 29 Mar 2020 23:49:01 +0300

> On 29 Mar 2020, at 19:55, Tero Kivinen <[email-masked]> wrote:
> 
> Ted Lemon writes:

I’m not that big a fan of Slack, but I’ve never used its web interface.

They have an installable client for the platforms most people use (yes, including Linux), and that works pretty well.

I’m not advocating that we use Slack, but I wouldn’t judge it based on the web interface.

Yoav

---

From: Benjamin Kaduk <[email-masked]>
Date: Sun, 29 Mar 2020 13:54:37 -0700

> For me, most of these solutions are missing searchable archives. This is built in to email. In the past, the IETF has published the jabber logs and I have written scripts to sync them with audio an…

To be clear, the IETF still does publish the jabber logs, not just "in the
past": https://www.ietf.org/jabber/logs/

-Ben

---

From: Alexandre PETRESCU <[email-masked]>
Date: Mon, 30 Mar 2020 10:09:44 +0200

> All the traffic showed up for me, eventually.

I confirm about that lag, me too.

The problem is also the text I just typed disappears from the screen and 
appears in the discussion window only after that lag. It is confusing.

Alex, LF/HF 2

---

From: Michael Richardson <[email-masked]>
Date: Mon, 30 Mar 2020 12:24:32 -0400

> appears in the discussion window only after that lag. It is confusing.

poor client UX in pidgin.

I have seen some clients in some IMs systems (I can't recall which), where
the outgoing message it placed at the bottom of the window, with a colour/box
around it, indicating that it's still outgoing.

I assume that my client was busy renegotiating a TCP connection during the
interval, but hasn't quite gotten around to telling me that it had failed,
because it was still in progress.