Subject: Re: [16ng] Fwd: I-D ACTION:draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt

From: "Syam Madanapalli" <[email-masked]>
Date: Mon, 19 Jun 2006 11:19:33 +0530

On 6/19/06, Myung-Ki Shin <[email-masked]> wrote:
> Syam,
>
> I reviewed draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt.

Thanks for the review.

> This document defines the operation of IPv6 over the IPv6 convergence
> sublayer of 802.16d/e within the scope of the WiMAX network
> architecture.
>
> As you know, a similar document has been almost completed/released by
> WiMAX NWG IPv6 subteam - Stage 3: IPv6 operation over IP CS.
>
> In fact, there is no big difference with the WiMAX document.
> Can you explain the differences ?
> I think we don't need to have the same - two documents.

Yes, this draft is based on the NWG subteam work in WIMAX Forum.
WiMAX forum referes to this doument if IETF publishes it. So there
will be only one document.

>
> As you see, IEEE 802.16 are limited to Layers 1 and 2,
> they may be used within any number of network architectures as well as
> WiMAX , e.g., WiBro - Korean efforts, or DSL replacement scenarios, etc.
> I think a broader view is required for IETF draft.

Sure. But where is the WiBro or any other architecure document so that we
can think of a solution?

>
> Also, you need to refer to a draft which covers a set of deployment
> scenarios of 802.16 technologies -
> draft-ietf-v6ops-802-16-deployment-scenarios-00.

I just glanced this draft. Will you please let me know where this scenarios
are coming from (WiMAX/WiBro etc) and references?

Thanks,
Syam

>
> Thanks,
> Myung-Ki,
> --
> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
> Myung-Ki Shin, Ph.D.| [email-masked]
> ETRI/PEC            | 161 Gajeong-dong Yuseong-gu
> Tel:+82-42-860-4847 | Daejeon, 305-350 Korea
>
>
> Syam Madanapalli wrote:
> > Please review and provide comments/suggestions to improve the draft.
> >
> > Thanks,
> > Syam
> >
> >
> >
> > ---------- Forwarded message ----------
> > From: [email-masked] < [email-masked]>
> > Date: Jun 16, 2006 4:20 AM
> > Subject: I-D ACTION:draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
> > To: [email-masked]
> >
> > A New Internet-Draft is available from the on-line Internet-Drafts
> > directories.
> >
> >
> >       Title           : Transmission of IPv6 over 802.16's IPv6
> > Convergence Sublayer
> >       Author(s)       : S. Madanapalli, et al.
> >       Filename        : draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
> >       Pages           : 20
> >       Date            : 2006-6-15
> >
> > IEEE 802.16d and 802.16e are air interface specifications for fixed
> > and mobile broadband wireless access systems. 802.16d/e is the air
> > interface that is used in the WiMAX (Worldwide Interoperability of
> > Microwave Access) architecture and specified by the WiMAX forum.
> > This document defines the operation of IPv6 over the IPv6 convergence
> > sublayer of 802.16d/e within the scope of the WiMAX network
> > architecture.  It specifies various aspects of IPv6 such as neighbor
> > discovery, address configuration, Path MTU and the transmission/
> > receiving of IPv6 packets.
> >
> > A URL for this Internet-Draft is:
> > http://www.ietf.org/internet-drafts/draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
> >
> > _______________________________________________
> > 16ng mailing list
> > [email-masked]
> > http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
> >
>
>
>
>From [email-masked] Mon Jun 19 16:33:23 2006
Date: Mon, 19 Jun 2006 15:33:49 +0900
From: Myung-Ki Shin <[email-masked]>
Organization: ETRI
To: Syam Madanapalli <[email-masked]>
Subject: Re: [16ng] Fwd: I-D
	ACTION:draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
cc: [email-masked]
Reply-To: [email-masked]

Syam Madanapalli wrote:

>> As you know, a similar document has been almost completed/released by
>> WiMAX NWG IPv6 subteam - Stage 3: IPv6 operation over IP CS.
>>
>> In fact, there is no big difference with the WiMAX document.
>> Can you explain the differences ?
>> I think we don't need to have the same - two documents.
> > On 6/19/06, Myung-Ki Shin <[email-masked]> wrote:
> 
> Yes, this draft is based on the NWG subteam work in WIMAX Forum.
> WiMAX forum referes to this doument if IETF publishes it. So there
> will be only one document.

   Okay,

>> As you see, IEEE 802.16 are limited to Layers 1 and 2,
>> they may be used within any number of network architectures as well as
>> WiMAX , e.g., WiBro - Korean efforts, or DSL replacement scenarios, etc.
>> I think a broader view is required for IETF draft.
> 
> 
> Sure. But where is the WiBro or any other architecure document so that we
> can think of a solution?

   I think that one of roles of 16ng is to find and define other IP
   network architectures for 802.16.

   As for the WiBro, we plan to release the document -
   "IPv6 operations over WiBro - Phase I" on September.

   Also, we needs to study ISPs' view (or plan) who want to deploy 802.16
   access technology with IPv6 (e.g., DSL replacement or hot zone
   scenarios ). (But, there are no concrete references yet.)

   Thanks,
   Myung-Ki,

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
Myung-Ki Shin, Ph.D.| [email-masked]
ETRI/PEC            | 161 Gajeong-dong Yuseong-gu
Tel:+82-42-860-4847 | Daejeon, 305-350 Korea
>From [email-masked] Mon Jun 19 17:39:23 2006
From: "Sangjin Jeong" <[email-masked]>
To: "Syam Madanapalli" <[email-masked]>
Subject: Re: [16ng] Fwd:
	I-DACTION:draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
Date: Mon, 19 Jun 2006 16:39:33 +0900
cc: [email-masked]

Hello, Syam,

> On 6/19/06, Myung-Ki Shin <[email-masked]> wrote:
>> Syam,
>>
>> I reviewed draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt.
> 
> Thanks for the review.
> 
>> This document defines the operation of IPv6 over the IPv6 convergence
>> sublayer of 802.16d/e within the scope of the WiMAX network
>> architecture.
>>
>> As you know, a similar document has been almost completed/released by
>> WiMAX NWG IPv6 subteam - Stage 3: IPv6 operation over IP CS.
>>
>> In fact, there is no big difference with the WiMAX document.
>> Can you explain the differences ?
>> I think we don't need to have the same - two documents.
> 
> Yes, this draft is based on the NWG subteam work in WIMAX Forum.
> WiMAX forum referes to this doument if IETF publishes it. So there
> will be only one document.

Do we need to produce almost same document as WiMAX NWG's? 
I think that we do not have to focus on WiMAX network model. 
The WiMAX network model is one of the possible solutions, NOT the ONLY one.

Therefore, in this WG, we need to more carefully investigate possible network deployment
scenarios and add some features which are not provided in NWG's document, for example, 
how to support IPv6 multicast capability over 802.16 link, and so on.  

Regards,

- Sangjin

> 
>>
>> As you see, IEEE 802.16 are limited to Layers 1 and 2,
>> they may be used within any number of network architectures as well as
>> WiMAX , e.g., WiBro - Korean efforts, or DSL replacement scenarios, etc.
>> I think a broader view is required for IETF draft.
> 
> Sure. But where is the WiBro or any other architecure document so that we
> can think of a solution?
> 
>>
>> Also, you need to refer to a draft which covers a set of deployment
>> scenarios of 802.16 technologies -
>> draft-ietf-v6ops-802-16-deployment-scenarios-00.
> 
> I just glanced this draft. Will you please let me know where this scenarios
> are coming from (WiMAX/WiBro etc) and references?
> 
> Thanks,
> Syam
> 
> 
>>
>> Thanks,
>> Myung-Ki,
>> --
>> =-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=
>> Myung-Ki Shin, Ph.D.| [email-masked]
>> ETRI/PEC            | 161 Gajeong-dong Yuseong-gu
>> Tel:+82-42-860-4847 | Daejeon, 305-350 Korea
>>
>>
>> Syam Madanapalli wrote:
>> > Please review and provide comments/suggestions to improve the draft.
>> >
>> > Thanks,
>> > Syam
>> >
>> >
>> >
>> > ---------- Forwarded message ----------
>> > From: [email-masked] < [email-masked]>
>> > Date: Jun 16, 2006 4:20 AM
>> > Subject: I-D ACTION:draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
>> > To: [email-masked]
>> >
>> > A New Internet-Draft is available from the on-line Internet-Drafts
>> > directories.
>> >
>> >
>> >       Title           : Transmission of IPv6 over 802.16's IPv6
>> > Convergence Sublayer
>> >       Author(s)       : S. Madanapalli, et al.
>> >       Filename        : draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
>> >       Pages           : 20
>> >       Date            : 2006-6-15
>> >
>> > IEEE 802.16d and 802.16e are air interface specifications for fixed
>> > and mobile broadband wireless access systems. 802.16d/e is the air
>> > interface that is used in the WiMAX (Worldwide Interoperability of
>> > Microwave Access) architecture and specified by the WiMAX forum.
>> > This document defines the operation of IPv6 over the IPv6 convergence
>> > sublayer of 802.16d/e within the scope of the WiMAX network
>> > architecture.  It specifies various aspects of IPv6 such as neighbor
>> > discovery, address configuration, Path MTU and the transmission/
>> > receiving of IPv6 packets.
>> >
>> > A URL for this Internet-Draft is:
>> > http://www.ietf.org/internet-drafts/draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt
>> >
>> > _______________________________________________
>> > 16ng mailing list
>> > [email-masked]
>> > http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
>> >
>>
>>
>>
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: "Syam Madanapalli" <[email-masked]>
Date: Mon, 19 Jun 2006 15:57:44 +0530

Hello Sangjin,

> Do we need to produce almost same document as WiMAX NWG's?

As there were no recommendation from IETF, WiMAX Forum NWG is currently
specifying this. Once IETF defines the IPv6 over 802.16, NWG just uses the
specification and will not do any work on this. This is my understanding.

> The WiMAX network model is one of the possible solutions, NOT the ONLY one.

Sure, but where do we get other models from? If we consider many possible
deployment scenarios (which may not be deployed in practice) the solution
may become complex and inefficient.

If there is a need to consider other other network models, we can definitely
do it.

> how to support IPv6 multicast capability over 802.16 link, and so on.

I am not sure if the on-link multicast support is useful, especially
on air-link,
which is connection oriented nature.

Or you mean multicast services over 802.16 e.g. video multicast etc?

Thank you,
Syam

>From [email-masked] Mon Jun 19 21:49:24 2006
Content-class: urn:content-classes:message
Date: Mon, 19 Jun 2006 13:49:48 +0200
From: "Riegel, Maximilian" <[email-masked]>
To: <[email-masked]>
cc: [email-masked]
Subject: [16ng] Submission of draft-riegel-16ng-ip-over-eth-over-80216-00.txt

Dear Editor,

I would like to submit the individual I-D
draft-riegel-16ng-ip-over-eth-over-80216-00.txt aimed for discussion in
the 16ng BOF/WG.

        Transmission of IP Packets over Ethernet over IEEE802.16
            draft-riegel-16ng-ip-over-eth-over-80216-00.txt

Abstract

   This document describes the special behavior of the Ethernet
   emulation on top of IEEE802.16 to efficiently support the
   transmission of IPv4 as well as IPv6 packets over IEEE802.16 radio
   links.
   Due to resource constraints of radio transmission systems and the
   limitations of the IEEE802.16 MAC layer for the emulation of
   Ethernet, the transmission of IP over an emulated LAN on top of
   IEEE802.16 may considerably benefit by adding IP specific support
   functions within the Ethernet emulation on top of IEEE802.16.

Please fetch the full document by
http://www.max.franken.de/ids/draft-riegel-16ng-ip-over-eth-over-80216-0
0.txt

Kind regards
Max

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 19 Jun 2006 09:21:55 -0700 (PDT)

Hi Myungki,

----- Original Message ----
From: Myung-Ki Shin <[email-masked]>
To: Syam Madanapalli <[email-masked]>
Cc: [email-masked]
Sent: Sunday, June 18, 2006 11:43:12 PM
Subject: Re: [16ng] Fwd: I-D ACTION:draft-madanapalli-ipv6-over-802.16-ipv6cs-00.txt

Syam,

==> This is an interesting point. However, I am confused on what to do about it.
==>draft-madanapalli has Relay DAD which is a replacement of Proxy DAD because Proxy
==>DAD violates SeND, Relay DAD has far reaching applications including in 6lowpan networks (?).
==> Should Relay DAD be written as a separate draft? If yes, would this solve the concern
==>Myungki expressed?
As you see, IEEE 802.16 are limited to Layers 1 and 2,
they may be used within any number of network architectures as well as
WiMAX , e.g., WiBro - Korean efforts, or DSL replacement scenarios, etc.
I think a broader view is required for IETF draft.

Thanks,
Myung-Ki,

==> Regards,
==>--behcet

---

From: "Syam Madanapalli" <[email-masked]>
Date: Wed, 21 Jun 2006 10:04:10 +0530

Hi Sangjin,

[cut]
> That's what we have to do in this WG from now on. Did we reach any WG consensus about
> limiting the scope of 16ng WG deliverables to the scope of WiMAX NWG?
> I do not think so. The 16ng WG chater does not define 16ng WG' scope as a
> subset of NWG's.

Yes, we can think of all possible network models that have practical use.
But somebody should come up with those models based on real requirements,
so that 16ng can work on solution. If we can come up with a solution for all
such networks that will be good, otherwise we will have multiple proposals.

Thanks,
Syam
>From [email-masked] Wed Jun 21 23:39:18 2006
Date: Wed, 21 Jun 2006 22:39:20 +0900
From: Soohong Daniel Park <[email-masked]>
To: [email-masked]
Subject: [16ng] Solicit for fixed/nomadic deployment examples in Montreal

Folks,

As you can see in the agenda, we will have
a slot for the 16e deployment wrt WiBro.
Along with that, chairs are thinking of having
other deployment examples as wide as
possible at upcoming 16ng meeting. For
example, fixed and nomadic deployments.

Please let me know if you are willing to bring
the 16 deployment examples. No draft is 
required this time. Also, a couple of slides 
are pretty much enough for folks to sense
how 16 is under deployment around us.

Otherwise, we will may focus on mobility
deployment example based on 16e at this
meeting.

The relevant 16ng deliverable is as follows:

- Produce "IP deployment over IEEE 802.16 
Networks" to illustrate the IP deployment 
scenarios including IP CS and Ethernet CS 
considerations over IEEE 802.16 networks 
based on the WiMAX and WiBro. [Informational RFC]

Thanks in advance.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
>From [email-masked] Wed Jun 21 23:49:19 2006
Date: Wed, 21 Jun 2006 22:48:22 +0900
From: Soohong Daniel Park <[email-masked]>
To: [email-masked]
Subject: [16ng] IPv6 over WiBro

>> 1) Would you please specify which group or who is drafting "IPv6 operations
>> over WiBro - Phase I"? 
> 
>   This work is being drafting by (Korean) TTA PG 210 - IPv6 over WiBro
>   subgroup. Contact - [email-masked].

As far as I am concern, this work is too much tough to
be referred to16ng. If anyone from subgroup above
believe that we should consider something in terms of
IPv6 over WiBro, please bring a presentation into 16ng
meeting. Then, we will have further details in Montreal.

Otherwise, we won't be able to sense what should be
considered in 16ng. Any volunteer from your subgroup ?

Regards.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
>From [email-masked] Thu Jun 22 02:05:37 2006
Content-class: urn:content-classes:message
Subject: RE: [16ng] Solicit for fixed/nomadic deployment examples in Montreal
Date: Wed, 21 Jun 2006 18:05:34 +0200
From: "Riegel, Maximilian" <[email-masked]>
To: "Soohong Daniel Park" <[email-masked]>
cc: [email-masked]

Daniel,

I have a couple of slides showing how 16e may be integrated with DSL
systems.
I will put together a small presentation on fixed/nomadic deployment
examples.

Bye
Max

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Soohong Daniel
Park
Sent: Wednesday, June 21, 2006 3:39 PM
To: [email-masked]
Subject: [16ng] Solicit for fixed/nomadic deployment examples in
Montreal

Folks,

As you can see in the agenda, we will have
a slot for the 16e deployment wrt WiBro.
Along with that, chairs are thinking of having
other deployment examples as wide as
possible at upcoming 16ng meeting. For
example, fixed and nomadic deployments.

Please let me know if you are willing to bring
the 16 deployment examples. No draft is 
required this time. Also, a couple of slides 
are pretty much enough for folks to sense
how 16 is under deployment around us.

Otherwise, we will may focus on mobility
deployment example based on 16e at this
meeting.

The relevant 16ng deliverable is as follows:

- Produce "IP deployment over IEEE 802.16 
Networks" to illustrate the IP deployment 
scenarios including IP CS and Ethernet CS 
considerations over IEEE 802.16 networks 
based on the WiMAX and WiBro. [Informational RFC]

Thanks in advance.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
_______________________________________________
16ng mailing list
[email-masked]
http://eeca16.sogang.ac.kr/mailman/listinfo/16ng