Subject: Re: [16ng] 16ng WG approval process - remaining issue #2

From: Soohong Daniel Park <[email-masked]>
Date: Fri, 26 May 2006 11:37:23 +0900

Jari - As you know, we received two comments
from Roger Marks as a chair of IEEE 802.16 WG.
Both seem acceptable to me, so I will update 16ng
charter following his comments. Also, we will take
care of valuable comments from IEEE 802.16 WG
if any, this thread is still silent on IEEE 802.16 WG
mailing list though...

(1) In the following sentence:

Currently, the WiMAX Forum, and, in particular, its 
NWG (Network Working Group) is defining the IEEE
802.16 network architecture.

"defining the IEEE 802.16 network architecture" should 
be changed to "defining a network architecture based on
IEEE 802.16". Reason: Because IEEE 802 standards are 
limited to Layers 1 and 2, they may be used within any 
number of network architectures.

(2) The following sentence should be deleted:

Also, other standards bodies are carrying out similar efforts
(e.g., WiBro-Wireless Broadband in Korea).

Reason: This sentence is incorrect on two point:
(a) It implies that the WiMAX Forum is a standards body. 
It is not, and it does not claim to be.
(b) It suggests that "WiBro-Wireless Broadband in Korea" 
is a standards body. WiBro is not a standards body nor even
an organization; it is the name of a wireless service based 
on IEEE 802.16 standards.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
>From [email-masked] Fri May 26 17:50:38 2006
From: "Syam Madanapalli" <[email-masked]>
To: "'Jari Arkko'" <[email-masked]>, <[email-masked]>
Subject: RE: [16ng] multiple CS issue - proposed way forward
Date: Fri, 26 May 2006 13:25:37 +0530

Hi,

One point that may be missing here is the implications of
Co-existence of multiple CSs on the same link. If we allow
two devices on same IP Link, one with IP CS and other with 
Eth CS, we may need to see how the on-link communication works.

> -----Original Message-----
> From: [email-masked] [mailto:16ng-
> [email-masked]] On Behalf Of Jari Arkko
> Sent: Friday, May 26, 2006 2:26 AM
> To: [email-masked]
> Subject: [16ng] multiple CS issue - proposed way forward
> 
> 
> We've discussed the issue of the multiple CSes on this list, based on
> comments from the IESG and by others.
> 
> What follows is my personal suggestion on a possible path forward and I
> would like to get feedback from you whether this is acceptable.
> 
> We know we are going to have multiple different CSes in real life. In
> the future possibly more than what we have now. But I'm getting the
> feeling that its not easy to agree on a global mandatory- to-implement
> option for both peers. The main reason for this is that for better or
> worse, IPCS will be used for the mobile/single device deployment
> whereas the EthCS is easier to use in, say, DSL replacement scenario by
> bridging it to a an in-home Ethernet.
> 
> However, it is easy to mandate the ability to negotiate the options.
> Some, possibly all of this functionality is already in 802.16. It might
> also be possible to mandate the support of multiple options at the
> network side this would make interoperability much easier.
> Such mandates would apply only to
> implementations, however. Its possible
> that there is no configuration on the
> operator's network that would allow
> another type of CS to be used. Also,
> if the different CSes are used in very
> different devices and networks, such
> mandate would not have much value.
> 
> I'm also getting the feeling that choosing different standard status
> for the options may not be the best approach. They both deserve to be
> documented in a PS level document, and personally I'd have some
> reservations about recommending either one as the only PS.
> 
> Finally, I believe we need to specify better what the IP over EthCS
> really means in terms of specification effort. In the DSL replacement
> scenario, for instance, IP/ARP/ND behaviour needs to be the same as we
> already have, assuming we may be bridging to regular Ethernet. So it
> seems that we are mainly talking about how bits are arranged in 802.16
> so that the end result can be mapped to regular IP over Ethernet. Its
> unclear to me exactly how much such specification work remains;
> presumably there's still some left, such as details about compression?
> But the scope is much narrower than in the IPCS case. It would also be
> useful to understand what the ambition level is for, say, introduction
> of advanced compression schemes for IP over EthCS.
> 
> So, I would suggest the following:
> 
> 1. Handle both EthCS and IPCS work in the WG.
> 
> 2. Shoot for Proposed Standard for both.
> 
> 3. Require a negotiation mechanism
>     for the CS selection.
> 
> 4. No mandatory to implement CS for
>     the client side.
[Syam Madanapalli] 

As mentioned above, we need to decide if we allow the co-existence
two devices on the same link with different CSs.

> 
>     Possibly, if we can agree on this, a
>     set of mandatory to implement
>     CSes on the network side.
[Syam Madanapalli] 

It is a good idea to recommend for network to support both the CSs.
In WiMAX Forum, NWG mandates that the Network must support both the CSs.

Thanks,
Syam

> 
> 5. Add more details about the EthCS
>     specification scope.
> 
> Comments?
> 
> --Jari
> 
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: Jari Arkko <[email-masked]>
Date: Fri, 26 May 2006 12:24:09 +0300

Soohong Daniel Park wrote:

>charter following his comments.
>
Yes, please.

>number of network architectures.
Yep.

>on IEEE 802.16 standards.
Yes.

By the way, I'll send out the charter version that IESG
used to this list. Please make your changes to that,
so that we're not editing multiple parallel version.s

--Jari