Subject: Re: [16ng] Subnet Model Analysis for 16ng

From: Myung-Ki Shin <[email-masked]>
Date: Thu, 07 Sep 2006 10:02:13 +0900

Hi J,

Thanks for your comments.
Inline ...

[email-masked] wrote:

> A few questions 
> 
> On ...
> 3.3.3.  Duplicate Address Detection
> 
> Does adding something like "such as BS performaing relay DAD-like
> functions for MS under itself" make sense? Of course, it needs to be
> worked out somewhere like the shared prefix model, but I recall that
> some early systems do something similar and it has smaller scope, just
> for a BS instead of an AR.

I think there are several ways to implement the DAD optimization
(e.g., relay DAD, proxy DAD, or some vendor-specifc functions).  Also, 
BS, AR or both can perform that kind of fuctions for MS.

In my understanding, the goal of this draft is to provides analysis and
applicability of each subnet model.  So, the isssue above can be 
discussed in solution documents for IPv6 CS and Eth-CS, respectively.

> On..
> 3.3.4.2. On-link Multicast Support & 3.3.4.5.  Effect on Dormant Mode
> I wonder if it makes sense to consider that BS can potentially block
> broadcast/multicast with known purposes to MS that do not need it and
> deliver only to intended MS MAC unicast over the air. 
> An 802.16 BS is already involved in many activities that require
> awareness of higher layer states beyond MAC (regrettably to some), so
> knowing necessary information may not be a big additional burden. Also,
> a BS needs and can act with only local information.
> Also IGMP/MLD snooping can be used for additional cases, as some
> ethernet switches already do. And finally, broadcast/multicast with
> unknown functions will have to be left to a policy and maybe subject to
> rate limits like many 802.11 implementations, where practical
> experiences to come will help guide the usage.

I know and I agree that this issue is very important for dormant mobile 
node. There are strong and weak points with this approach above.
Also, sometimes it might be not specific to IPv6 solutions and
morevover this may be a kind of BS implementation issues.

> I guess the common thing is that BS's are already very specialized nodes
> for 802.16, so I'd be inclined to limit 802.16 specifics to BS and not
> bother AR, even if there is some penalty in other aspects. (though I
> have not seen something that'd concern me too much yet.) If all or most
> of 802.16 specifics are handled at BS using only local knowledge, there
> will be even less interop issues.

I wonder if we can define or discuss about BS and/or AR behaviors here,
that is, omniscient AR and dummy BS vs. omniscient(?) BS and general AR,
even if interop issues are important, of course.

Thanks,
Myung-Ki,
ETRI

> I apologize if I'm out of context, for I am not there at the meeting
> following the discussions.
> 
> Bests.
> 
> "J" Kim
> [email-masked]
> AT&T Labs - Research
> 
> http://macsbug.googlepages.com/
> 
>From [email-masked] Fri Sep  8 01:04:03 2006
Subject: Re: [16ng] Subnet Model Analysis for 16ng
From: Pars Mutaf <[email-masked]>
To: Syam Madanapalli <[email-masked]>
Organization: INT Evry
Date: Thu, 07 Sep 2006 16:42:41 +0200
cc: [email-masked]
Reply-To: [email-masked]

Hi, 

Thanks to the contributors for this draft. 
I have a quick question. Have you decided
that in 16ng:

Subnet = paging area?

Thanks,
pars

On Wed, 2006-09-06 at 19:19 +0530, Syam Madanapalli wrote:
> Hi,
> 
> We made some analysis of subnet models for IPv6,
> please review and comment.
> I have attached the text document with this mail as
> the draft has not been published yet.
> 
> Thanks,
> Syam
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: Heejin Jang <[email-masked]>
Date: Fri, 08 Sep 2006 07:05:36 +0000 (GMT)

Hi,

Thanks for the DT's effort on it.

I have some comments on it.

1.

In case of shared & ethernet-like model, the periodical RAs may

make all of the dormant nodes awake at the same time, which

will cause 802.16e signaling messges for paging and power consumption of
all nodes

just for getting RAs.

So, how about inserting to 3.1.4.7& 3.3.4.7 (changes on router implementation)

so that RA's lifetime could be set to infinite value, or, 0xffff?

2.

in 3.2.4.5

"The AR can simply send link local multicast, for example unsolicited

Router Advertisements, and the BS can filter them out"

=> If AR sends RAs to announce some parameters such as the advertised
prefix,

it should not be filtered by BS. How BS can
differentiate this case?

So, I prefer that AR advertises RAs only when necessary
without periodical RAs, and BS allows RAs.

3.

in 3.1.4.4.

"All MSs send the packets to the AR irrespective of
the destination and scope of the IPv6 address."

=>  There could be a loopback message or decapsulation within MN
such as MIPv6.

"MSs send all the packets which are not destined to itself to the AR
irrespective of the destination

and scope of the IPv6 address." may be better.

Some comments could be considered when solution document is made.

Thanks.

-- Regards,

Heejin Jang