Subject: [16ng] Re: Call for comments on 16ng BoF

From: Soohong Daniel Park <[email-masked]>
Date: Wed, 14 Sep 2005 09:17:50 +0900

> I'm also trying to make a draft on "A consideration of IPv6 in 
> IEEE802.16 networks".  

Remind that we have to search for at least one item as Standard Track RFC, leading to clean up the issue that why we need this BoF within IETF. This is what IESG (and 802.16 guy) is speaking to me.

Your task seems a bit more informational document. Or is there any protocol issues ? If yes, that would be very useful to me at this stage...

Regards,

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory, SAMSUNG Electronics.
>From [email-masked] Wed Sep 14 09:41:19 2005
Date: Wed, 14 Sep 2005 09:29:26 +0900
From: Myung-Ki Shin <[email-masked]>
Organization: ETRI
To: Younhee Han <[email-masked]>
Subject: Re: [16ng] Re: Call for comments on 16ng BoF
cc: [email-masked]
cc: [email-masked]

Younhee Han wrote:

> > My intention was to figure out problems to put them
> > in charter items.
> >
> > Back to the general comments on propsoed charter,
> > we should focus on the scope according to problem statement
> > discussion. (to create wg :)
> 
> Yes. I understand your point.
> I really want to focus the problem definition, too.
> 
> My intention was just asking a favor to you
> that we should take a different view from IPv6/3gpp
> when we talking about  IPv6/Wibro issues.
> > We can say ND may be a problem just in 802.16 networks ?
> 
> In my opinion, ND can be a problem in IPv6/WiBro in terms of
> the multicast method of ND messages.

Okay, if so, we got something new(?) to describe problems, 
rather than other networks (e.g., 3gpp ...)

As for the other issues below, I thought considerations would be 
the same as those of 3gpp considerations, described in rfc 3316.

If we find something different, it will be good news for BoF ...

Now, I'm gathering considerations from ETRI implementation.
I can finish all of works soon, then we can share 
the information, hopefully. 

Thanks, 
Myung-Ki,

> Now, I'd like to raise another issues related to ND problem.
> 
> 1) Should we support the stateless address configuration in 802.16 networks?
> 2) If it should be supported, how to defend the address conflict?
> 
> If we try to solve the address conflict by using RFC 2462 DAD solution,
> the following issue can be also brought up:
> 
> 3) How to deliver NS message with the solicited-node multicast address as its destination?
> 
> Definitely, the issue 3) is related to ND
> 
> - Youn-Hee
>From [email-masked] Wed Sep 14 09:57:12 2005
Date: Wed, 14 Sep 2005 09:45:38 +0900
From: Soohong Daniel Park <[email-masked]>
Subject: Re: [16ng] Re: Call for comments on 16ng BoF
To: Younhee Han <[email-masked]>, Myung-Ki Shin <[email-masked]>
cc: [email-masked]
cc: [email-masked]

> 1) Should we support the stateless address configuration in 802.16 networks?
> 2) If it should be supported, how to defend the address conflict?
> 
> If we try to solve the address conflict by using RFC 2462 DAD solution,
> the following issue can be also brought up:
> 
> 3) How to deliver NS message with the solicited-node multicast address as its destination?
> 
> Definitely, the issue 3) is related to ND 

Any protocol issues to be newly defined as a Proposed Standard RFC ?
If you are saying an operational aspect, proxy ND seems a reasonable approach without any host-side requirement.

Once again, please looking for a protocol issues wrt IPv6 over 802.16(e) networks, slightly aside from ND considerations.

Regards,

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory, SAMSUNG Electronics.
>From [email-masked] Wed Sep 14 10:03:45 2005
Date: Wed, 14 Sep 2005 09:51:56 +0900
From: Myung-Ki Shin <[email-masked]>
Organization: ETRI
To: Soohong Daniel Park <[email-masked]>
cc: [email-masked]
cc: [email-masked]
Subject: [16ng] Re: Call for comments on 16ng BoF

Soohong Daniel Park wrote:
> 
> > I'm also trying to make a draft on "A consideration of IPv6 in
> > IEEE802.16 networks".
> 
> Remind that we have to search for at least one item as Standard Track RFC, leading to clean up the issue that why we need this BoF within IETF. This is what IESG (and 802.16 guy) is speaking to me.

That's what I'm saying now. 

To find protocol issues, problem statements (Info RFCs) should be
proposed first. 

So, first, basic question on this BoF was "there are problems (protocol
issues)
on IPv6 adoption in IEEE802.16, not implementation considerations ?

It would be asked by IESG, maybe.
 
> Your task seems a bit more informational document. Or is there any protocol issues ? If yes, that would be very useful to me at this stage...

I think *considerations* (in IETF) has broader view 
(protocol issues, operational issues, implementation issues)
than problem statement.

It will be a fist step to investigate the problems. 

As I said, the general steps for Internet Area's (IP over xxx) WG. 

   1) define problems and goal 
   2) produce one document to describe them  (Info RFCs)
   3) if some changes or extensions are required to current IP specs, 
      document seperated drafts to update each issues ... (Std RFCs)

Thanks, 
Myung-Ki,
>From [email-masked] Wed Sep 14 10:08:53 2005
Date: Wed, 14 Sep 2005 09:57:18 +0900
From: Soohong Daniel Park <[email-masked]>
To: Myung-Ki Shin <[email-masked]>
cc: [email-masked]
cc: [email-masked]
Subject: [16ng] Re: Call for comments on 16ng BoF

> To find protocol issues, problem statements (Info RFCs) should be
> proposed first. 

It is already under work of course...:-)

Regards,

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory, SAMSUNG Electronics.
>From [email-masked] Wed Sep 14 10:21:27 2005
Date: Wed, 14 Sep 2005 10:09:38 +0900
From: Myung-Ki Shin <[email-masked]>
Organization: ETRI
To: Soohong Daniel Park <[email-masked]>
cc: [email-masked]
cc: [email-masked]
Subject: [16ng] Re: Call for comments on 16ng BoF

Soohong Daniel Park wrote:
> 
> > To find protocol issues, problem statements (Info RFCs) should be
> > proposed first.
> 
> It is already under work of course...:-)

If so, can you clarify or summarize problems (protocol issues) ?
I didn't see the point in proposed charter, beyond ND.
At this phase, I'm not sure of ND.

Thanks, 

-- 
=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-= 
Myung-Ki Shin, Ph.D.| [email-masked]
ETRI/PEC            | 161 Gajeong-dong Yuseong-gu 
Tel:+82-42-860-4847 | Daejeon, 305-350 Korea
>From [email-masked] Wed Sep 14 22:19:22 2005
Date: Wed, 14 Sep 2005 22:07:36 +0900
From: YounHee Han <[email-masked]>
To: Soohong Daniel Park <[email-masked]>
Subject: Re: [16ng] Re: Call for comments on 16ng BoF
cc: [email-masked]
cc: [email-masked]
Reply-To: [email-masked]

Hi Daniel,

> > 1) Should we support the stateless address configuration in 802.16 networks?
> > 2) If it should be supported, how to defend the address conflict?
> >
> > If we try to solve the address conflict by using RFC 2462 DAD solution,
> > the following issue can be also brought up:
> >
> > 3) How to deliver NS message with the solicited-node multicast address as its destination?
> >
> > Definitely, the issue 3) is related to ND
> 
> Any protocol issues to be newly defined as a Proposed Standard RFC ?
> If you are saying an operational aspect, proxy ND seems a reasonable approach without any host-side requirement.
> 
> Once again, please looking for a protocol issues wrt IPv6 over 802.16(e) networks, slightly aside from ND considerations.

Ok. I understand your point. For a wg foundation,
We need a protocol of standard track, not informational one. 

As asked by Myung-Ki, however, I am also curious to know  
the protocol issues of "IPv6 over 802.16" without ND consideration.
do ND-related issues always come to end with informational document?
I am not sure at this stage.

- Youn-Hee Han

---

From: YounHee Han <[email-masked]>
Date: Wed, 14 Sep 2005 22:30:54 +0900

> If we find something different, it will be good news for BoF ...

Yes. I agree. We need a document like rfc 3316.
As you know well, however, at the current stage, 
such document seems to be not urgent one for founding BoF.
But, we should keep such work in mind steadily 
to operate IPv6 over WiBro, I think. 

> the information, hopefully.

Good news. I hope to see your work soon. 
We are also interacting with Samsung implementation team at some intervals.
Let's discuss about it continuously.

Thanks.

- Youn-Hee Han