Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)

From: gabriel montenegro <[email-masked]>
Date: Thu, 4 May 2006 20:14:12 -0700 (PDT)

I think this is the type of feedback and guidance that the IAB should give, and
the document ("multiple IP transport methods considered harmful") is a prime
candidate for an IAB document. Not that 802.16 was the first one to sin against
that future document. Ethernet did it, so did ATM. And sometimes the multiple
transports happen because of a desire to reduce layering, as in IP-over-ATM,
IP-over-SONET, IP-over-fiber, and it would be good to have some guidance for
future network designers.

-gabriel

--- Bob Hinden <[email-masked]> wrote:

> Daniel,
> 
> On May 3, 2006, at 6:06 PM, ext Soohong Daniel Park wrote:
> 
> >> I also suggest that people active in these other groups take this
> >> feedback seriously see if it is possible to revisit this design.  I
> >> assume that having .16 work well with IP (v4 and v6) is an important
> >> goal and the current design does not achieve that.
> >>
> >> Further, I think it might be useful for this w.g. to write a
> >> "multiple convergence sublayers consider harmful" document.
> >
> > What you mean by multiple convergence sublayers ?
> > If multiple CSs are defined as a Proposed Standard Or
> > If multiple CSs are enabled on the 16 station/BS ?
> >
> > If the latter, I don't think it is a harmful case althouth
> > it is not a general architecture. But I am open for more
> > opinion on that. Also, it can be described in the16ng
> > deliverable as deployment&consideration if necessary.
> 
> I think the whole idea of having multiple ways of carrying IP traffic  
> on .16 (e.g., multiple convergence sublayers) is a bad idea.  I think  
> think this would be good feedback from the IETF to .16.  This is  
> independent of if a IETF spec is PS or INFO.
> 
> Bob
> 
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
> 

__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
>From [email-masked] Fri May  5 13:33:44 2006
Date: Fri, 5 May 2006 09:12:58 +0530
From: "Syam Madanapalli" <[email-masked]>
To: "Bob Hinden" <[email-masked]>
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)
cc: [email-masked]
cc: IESG <[email-masked]>

802.16 just defines how to map certain higher layer PDUs to
802.16 connections. It just defines what fields in the higher
layer headers should be used to map to a connection. I do not
think 802.16 defines multiple ways of carrying IP traffic. Convergence
sublayer is just a look up table to map higher layer PDUs to an 802.16
connection.

- Syam

On 5/4/06, Bob Hinden <[email-masked]> wrote:
> Daniel,
>
> On May 3, 2006, at 6:06 PM, ext Soohong Daniel Park wrote:
>
> >> I also suggest that people active in these other groups take this
> >> feedback seriously see if it is possible to revisit this design.  I
> >> assume that having .16 work well with IP (v4 and v6) is an important
> >> goal and the current design does not achieve that.
> >>
> >> Further, I think it might be useful for this w.g. to write a
> >> "multiple convergence sublayers consider harmful" document.
> >
> > What you mean by multiple convergence sublayers ?
> > If multiple CSs are defined as a Proposed Standard Or
> > If multiple CSs are enabled on the 16 station/BS ?
> >
> > If the latter, I don't think it is a harmful case althouth
> > it is not a general architecture. But I am open for more
> > opinion on that. Also, it can be described in the16ng
> > deliverable as deployment&consideration if necessary.
>
> I think the whole idea of having multiple ways of carrying IP traffic
> on .16 (e.g., multiple convergence sublayers) is a bad idea.  I think
> think this would be good feedback from the IETF to .16.  This is
> independent of if a IETF spec is PS or INFO.
>
> Bob
>
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
>

---

From: "Riegel, Maximilian" <[email-masked]>
Date: Fri, 5 May 2006 13:27:52 +0200

The Extended Usage Model/stationary network currently under discussion
in WiMAX Forum is going the other direction, Ethernet-CS is mandatory,
and IP-CS may be optional. And the first WiMAX generation based on
IEEE802.16-2004 is only providing ETH-CS.

I do not understand, why the IETF has to specify, which of the
convergence sublayers of IEEE802.16 are Proposed Standard and which are
Informational.

Both, IP-CS as well as IPoETH-CS, have issues, and both specifications
should become Proposed Standard. I believe, it is out of the scope of
the IETF to specify, which of the many link layers existing in real
networks have to be used to carry IP packets. The IETF provides
standards how to carry IP packets over particular link layers, and if
there are different link layers, the IETF provides different standards.

Bye
Max

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Soohong Daniel
Park
Sent: Thursday, May 04, 2006 2:09 AM
To: Jari Arkko; [email-masked]
Cc: IESG
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)

> I would like to suggest that the interested
> parties use the review period to see if they
> can come to an agreement on which encapsulation
> (Ethernet or "raw IP" based) would be defined
> as a Proposed Standard in 16ng, with the other
> being defined as Informational.

It is incumbent upon me to ensure that the IPCS is
a mandatory and EthernetCS is an optional in WiMAX.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
_______________________________________________
16ng mailing list
[email-masked]
http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: Daniel Park <[email-masked]>
Date: Fri, 05 May 2006 13:41:27 +0000 (GMT)

Max - I don't see any troulble to make both IPCS and EthernetCS
as a Proposed Standard in 16ng, this issue was originally from
IESG view though. What I was trying to figure out at the previous
email is to ensure that IPCS is a mandatory in mobile WiMAX
as well as WiBro, not taking into consideration others use cases. 

As you know, the original intent in my mind was to ship both
IPCS and EthernetCS on the Proposed Standard track.

Daniel (Soohong Daniel Park)
Mobile Platform Laboratory. SAMSUNG Electronics

------- Original Message -------
Sender : Riegel, Maximilian<[email-masked]>
Date   : May 05, 2006 20:27
Title  : RE: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)

Bye
Max

---

From: "Riegel, Maximilian" <[email-masked]>
Date: Sat, 6 May 2006 01:27:40 +0200

First part of the answer on independent convergence sublayers for IPv4
and IPv6 (and ROHC):

IEEE802.16 is a connection oriented point-to-multipoint systems
assigning separate connections for different QoS classes. To forward a
packet through 802.16 a classification process must take place based on
payload header fields to determine the connection ID for a particular
destination and QoS class.

Due to this classification process based on payload header fields,
different types of classifiers are needed for different kind of
payloads, and the headers of IPv4, IPv6 and ROHC are different to each
other.
A convergence sublayer deploys just one type of classifier, and this
requires, that there are different convergence sublayers for different
kind of payload.

This is, how 802.16 works. I would not say, that this solution is the
only solution, or this is the best solution for a connection oriented
point-to-multipoint MAC layer, but it is the way, the IEEE802.16
standard was written.

Bye
Max

-----Original Message-----
From: Russ Housley [mailto:[email-masked]] 
Sent: Friday, May 05, 2006 9:24 PM
To: Bob Hinden; Riegel, Maximilian
Cc: [email-masked]; IESG; Soohong Daniel Park
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)

Please do not drop the IESG from this discussion.

I am very interested in the answer to Bob's question.  Why are 
independent convergence layers for IPv4 and IPv6 desirable?

Russ

At 02:46 PM 5/5/2006, Bob Hinden wrote:
>p.s. Should we drop the iesg from this discussion, or not?

---

From: "Riegel, Maximilian" <[email-masked]>
Date: Sat, 6 May 2006 01:56:37 +0200

Second part of the answer on multiple convergence sublayers:

Spectrum is a scarce resource, and many wireless carriers own just one
narrow band of spectrum for providing a variety of telecommunication
services like circuit switched voice, Ethernet-based VLANs and native
IP-connectivity.
It is not feasible to set up different radio systems for different
services within the same band leading to the requirement that a useful
radio system must be able to concurrently transfer different kind of
payloads in the same system. And this requires the coexistence of
different types of convergence sublayers.

Bye
Max

-----Original Message-----
From: Bob Hinden [mailto:[email-masked]] 
Sent: Friday, May 05, 2006 8:47 PM
To: Riegel, Maximilian
Cc: Soohong Daniel Park; [email-masked]; IESG
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)

Max,

On May 5, 2006, at 4:51 AM, ext Riegel, Maximilian wrote:

> Please be careful. IPv4-CS and IPv6-CS are different convergence
> sublayers in IEEE802.16. It is a feature (not a bug!) of IEEE802.16,
> that multiple convergence sublayers can coexist and I do not see any
> issue why multiple convergence sublayers should be considered harmful.

Please describe why you consider it a feature.

Bob

> Sent: Thursday, May 04, 2006 3:07 AM
> To: Bob Hinden; [email-masked]
> Cc: IESG
> Thanks,

---

From: Daniel Park <[email-masked]>
Date: Mon, 08 May 2006 00:19:11 +0000 (GMT)

>I'm not sure what you can do about classification of packets that have

>already been ROHCed. It seems they should have been classified before

>compression.

So far, ROHC is not taken into account in WiMAX effort. It is a kind

of future amendment of 16 features. Yes, obviously, packets should

be classified before header compression. I think it is a valuable

concern to efficiently control both 802.3 and IP header overhead

along with PHS...

>The whole point here is that it's a bad idea to offer two ways of

>doing the same thing. It causes extra work for implementors and extra

>operational decisions for users.

Well, as far as I am concern, two ways (IPCS and EthCS) do

not aim the same thing.  Also, I prefer not to make a restriction of

using both CSs. It is up to 16 implementation and even market

voices, not IETF issues. If necessary,  this aspect  can be included

in the deployment scenario & consideration deliverable from the

implementation perspective.