Subject: [16ng] DHCP issues over 802.16?

From: "Junghoon Jee" <[email-masked]>
Date: Tue, 27 Jun 2006 11:48:01 +0900

Hello,

there was a mention about DHCPv4/DHCPv6 in the
draft-jee-16ng-ps-goals-00.txt
IMHO, even if the DHCP protocol assumes the underlying broadcastable
media,
not so sure whether the adopting of DHCP protocol over 802.16 is
really an issue here.
Because, only with the unicastable channel between a SS and IP gateway
where DHCP server 
or relay can reside, DHCP can work well over 802.16 network.
Only issue which is still valid I can guess is related with the DAD
mechanism of DHCP which is optional feature though.

Any comments and thoughts?

Best Regards,
-Junghoon

---

From: "Syam Madanapalli" <[email-masked]>
Date: Tue, 27 Jun 2006 09:08:02 +0530

> or relay can reside, DHCP can work well over 802.16 network.

Yes, having DHCP Relay/Server in AR (ASN GW in WIMAX) is the solution.

> mechanism of DHCP which is optional feature though.

Are you talking about performing DAD for the addresses obtained through
DHCP? I think it is mandatory to perform the DAD irrespective how the address
is obtained (stateless autoconfiguration, manual configuration, stateful
configuration).

Thanks,
Syam

> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
>
>From [email-masked] Tue Jun 27 14:18:02 2006
Date: Tue, 27 Jun 2006 13:17:13 +0900
From: Soohong Daniel Park <[email-masked]>
To: [email-masked]
Subject: [16ng] Fw: 66th IETF Final Agenda

FYI.

Our meeting has been rescheduled on Tuesday
13:00-15:00 Afternoon Session I.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.

----- Original Message ----- 
From: "IETF Agenda" <[email-masked]>
To: "Working Group Chairs" <[email-masked]>
Cc: <[email-masked]>; <[email-masked]>
Sent: Tuesday, June 27, 2006 10:45 AM
Subject: 66th IETF Final Agenda

> The final agenda for the 66th IETF meeting can be found at
> http://www.ietf.org/meetings/IETF-66.html
>From [email-masked] Tue Jun 27 14:25:31 2006
From: "Junghoon Jee" <[email-masked]>
To: "'Syam Madanapalli'" <[email-masked]>
Subject: RE: [16ng] DHCP issues over 802.16?
Date: Tue, 27 Jun 2006 13:24:30 +0900
cc: [email-masked]

> -----Original Message-----
> From: Syam Madanapalli [mailto:[email-masked]] 
> Sent: Tuesday, June 27, 2006 12:38 PM
> To: Junghoon Jee
> Cc: [email-masked]
> Subject: Re: [16ng] DHCP issues over 802.16?
> 
> 
> On 6/27/06, Junghoon Jee <[email-masked]> wrote:
> > Hello,
> >
> > draft-jee-16ng-ps-goals-00.txt IMHO, even if the DHCP 
> protocol assumes 
> > the underlying broadcastable media, not so sure whether the 
> adopting 
> > of DHCP protocol over 802.16 is really an issue here.
> > where DHCP server or relay can reside, DHCP can work well 
> over 802.16 
> > network.
> 
> Yes, having DHCP Relay/Server in AR (ASN GW in WIMAX) is the
solution.

Need to check, could we describe this issue as a *problem* in
deploying DHCP over 802.16 network?

> Are you talking about performing DAD for the addresses 
> obtained through DHCP? I think it is mandatory to perform the 
> DAD irrespective how the address is obtained (stateless 
> autoconfiguration, manual configuration, stateful configuration).

I was thinking about that the use of ARP for DHCPv4 DAD is an option
not the only choice.

-Junghoon

> Thanks,
> Syam
> > _______________________________________________
> > 16ng mailing list
> > [email-masked]
> > http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
> >