Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)

From: Bob Hinden <[email-masked]>
Date: Wed, 3 May 2006 13:31:01 -0700

On May 3, 2006, at 1:11 PM, Jari Arkko wrote:

> Some additional information regarding the proposal to
> charter IP over 802.16 networks (16ng) WG:
>
> In their initial review of the proposal, the IESG and IAB
> were concerned that the charter suggests the standardization
> of multiple different encapsulations for the same
> functionality. It is understood that this matches
> the different convergence sublayers defined in 802.16,
> that the characteristics of the link layers are outside
> the domain of the IETF, and that the decisions about
> these sublayers have already been taken. Nevertheless,
> having multiple ways to provide the same functionality
> is almost always harmful and not in the interests of
> the Internet community or the proponents of the
> technology in question.

I also suggest that people active in these other groups take this  
feedback seriously see if it is possible to revisit this design.  I  
assume that having .16 work well with IP (v4 and v6) is an important  
goal and the current design does not achieve that.

Further, I think it might be useful for this w.g. to write a  
"multiple convergence sublayers consider harmful" document.

Bob

> I would like to suggest that the interested
> parties use the review period to see if they
> can come to an agreement on which encapsulation
> (Ethernet or "raw IP" based) would be defined
> as a Proposed Standard in 16ng, with the other
> being defined as Informational.
>
> Jari Arkko
>
>
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: Soohong Daniel Park <[email-masked]>
Date: Thu, 04 May 2006 09:08:44 +0900

> being defined as Informational.

It is incumbent upon me to ensure that the IPCS is
a mandatory and EthernetCS is an optional in WiMAX.

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
>From [email-masked] Thu May  4 10:57:10 2006
Date: Thu, 04 May 2006 10:06:55 +0900
From: Soohong Daniel Park <[email-masked]>
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)
To: Bob Hinden <[email-masked]>, [email-masked]
cc: IESG <[email-masked]>

> "multiple convergence sublayers consider harmful" document.

What you mean by multiple convergence sublayers ?
If multiple CSs are defined as a Proposed Standard Or
If multiple CSs are enabled on the 16 station/BS ?

If the latter, I don't think it is a harmful case althouth
it is not a general architecture. But I am open for more
opinion on that. Also, it can be described in the16ng 
deliverable as deployment&consideration if necessary.

Thanks, 

Daniel (Soohong Daniel Park)
Mobile Convergence Laboratory, SAMSUNG Electronics.
>From [email-masked] Fri May  5 04:01:42 2006
From: Bob Hinden <[email-masked]>
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)
Date: Thu, 4 May 2006 11:11:00 -0700
To: Soohong Daniel Park <[email-masked]>
cc: [email-masked]
cc: IESG <[email-masked]>

Daniel,

On May 3, 2006, at 6:06 PM, ext Soohong Daniel Park wrote:

> What you mean by multiple convergence sublayers ?
> If multiple CSs are defined as a Proposed Standard Or
> If multiple CSs are enabled on the 16 station/BS ?
>
> If the latter, I don't think it is a harmful case althouth
> it is not a general architecture. But I am open for more
> opinion on that. Also, it can be described in the16ng
> deliverable as deployment&consideration if necessary.

I think the whole idea of having multiple ways of carrying IP traffic  
on .16 (e.g., multiple convergence sublayers) is a bad idea.  I think  
think this would be good feedback from the IETF to .16.  This is  
independent of if a IETF spec is PS or INFO.

Bob

---

From: Soohong Daniel Park <[email-masked]>
Date: Fri, 12 May 2006 01:23:57 +0900

Jeff - Glad to see your comments, it seems a bit late though..

Otheres are inline;

> 1. Some suggested changes to the charter text are below.  Hopefully
> the propose d text will address some of the concerns raised by Russ
> Housley and Thomas Narten.

We will probably trim the charter. Let's see others opinion if any for a while.

> 2. Regarding the IPv4/v6-over-Eth-CS documents, I think that with eth
> CS, IPv4 and IPv6 can and should be addressed in the same document.
> Max, what do you think?

Um...I talked with Max in Dallas for this aspect. We should
discuss it with ADs (and IAB) while revising the charter. 

> 3. For each of these IP-over-foo-CS documents, the charter's
> deliverable definition should require description of the applicability
> of the "over-foo-CS" solution within an IP network (and maybe also
> non-IP network).  eg. IPv4-over-eth-CS is applicable in an environment
> where ARP broadcasts are acceptable - or where certain mitigations
> against excessive broadcasts have been taken.

No objection, however I prefer not to add any complex texts
in the charter. Rather, it can be described in each deliverable.

> 4. The "IP deployment over IEEE 802.16 Networks" work item is supposed
> "to illustrate the IP deployment scenarios and considerations over
> IEEE 802.16 networks based on the WiMAX and WiBro".....
> 
> I imagine the intent is to provide something along the lines of RFC
> 3314 for the mobile Wimax architecture.    If so, this is a good idea
> - however this would really be "IP deployment over Wimax" and would
> probably need coordination with Wimax Forum in order to be worthwhile.
> As well the Wimax standards are not public currently.

RFC3314 is just for IPv6 stuff. This document will be IP deployment
over WiMAX and WiBro (I am saying 802.16 technically). Sure, we
are coordinating with WMF.
 
> Specific comments on the charter text:

Pls be patient for a while...!

>From [email-masked] Mon May 15 12:08:53 2006
Date: Mon, 15 May 2006 11:15:30 +0900
From: Soohong Daniel Park <[email-masked]>
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)
To: Thomas Narten <[email-masked]>, [email-masked]
cc: IESG <[email-masked]>

Thomas - As Brian indicated, applicability statement
can help limit the number of duplications of effort. So,
I think the 16ng last deliverable as "IP deployment over
IEEE 802.16 Networks" can figure out that from the 
CS perspective. Here is a suggested change;

- Produce "IP deployment over IEEE 802.16 Networks" 
to illustrate the IP deployment scenarios and considerations 
over IEEE 802.16 networks based on the WiMAX and 
WiBro. [Informational RFC]

CHANGE TO:

- Produce "IP deployment over IEEE 802.16 Networks" 
to illustrate the IP deployment scenario, Convergence
Sublayer (IP CS and Ethernet CS) applicability statement 
and consideration over IEEE 802.16 networks based on the 
WiMAX and WiBro. [Informational RFC]

>From [email-masked] Tue May 16 05:39:21 2006
Date: Tue, 16 May 2006 04:45:23 +0900
From: Soohong Daniel Park <[email-masked]>
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)
To: [email-masked], Jari Arkko <[email-masked]>
cc: [email-masked]
cc: IESG <[email-masked]>

Jeff - My comments are inline:

> 2. Regarding the IPv4/v6-over-Eth-CS documents, I think that with eth
> CS, IPv4 and IPv6 can and should be addressed in the same document.
> Max, what do you think?

Let me keep the deliverable as it is, we will be able to make
a concensus later whetner or not merging them.

> 3. For each of these IP-over-foo-CS documents, the charter's
> deliverable definition should require description of the applicability
> of the "over-foo-CS" solution within an IP network (and maybe also
> non-IP network).  eg. IPv4-over-eth-CS is applicable in an environment
> where ARP broadcasts are acceptable - or where certain mitigations
> against excessive broadcasts have been taken.

Yes, applicability statement should be described among the deliverables.

> Specific comments on the charter text:

For off, thanks your good suggestions.

>> Description of Working Group:

<snipped>

>> Recently, the WiMAX Forum, and, in particular, its NWG (Network
>> Working Group) is defining the IEEE 802.16 network architecture.
>> Similarly, different standard bodies (e.g., WiBro-Wireless Broadband
>> in Korea) are in the progress of defining network architecture based
>> on IEEE 802.16.
> 
> Suggest changing this paragraph to:
> 
>  Recently, the WiMAX Forum as well as other standards bodies (eg.
>  WiBro-Wireless Broadband in Korea) have been defining
>  IEEE 802.16-based architectures for fixed networks (Wimax Forum ETG) and
>   - distinctly - for mobile networks (Wimax Forum Network Working Group).
>  Some of these standards are proprietary ie. as in 3GPP they may rely on
>  non-IP mechanisms eg. for datagram forwarding.

Following the IESG comments, we trimmed this sentence as
simple as possible not including others SDO mention in 16ng
charter. So, if endurable, I prefer to keep the text as it is.
 
>> IEEE 802.16 is different from existing wireless access technologies
>> such as IEEE 802.11 or 3G because of the existence of multiple
>> Convergence Sublayers which makes the specification of IP over
>> IEEE 802.16 non-trivial.
> 
> More detail here would clear up some of the recent questions.  So
> suggest changing
> this paragraph to:
> 
> IEEE 802.16 is different from fixed/nomadic-access-oriented IEEE
> technologies such as IEEE 802.11 or IEEE 802.3ah in that it does not
> include a rigid upper edge MAC service interface.  Instead, it provides 
> multiple "convergence sublayers" with the  assumption that the choice 
> and configuration of the upper edge will be done  in accordance with 
> the needs of a specific deployment environment  (which might be
> DSL replacement, mobile access, 802.11 or CDMA backhaul etc.).  
> And unlike 3G or xDSL technologies, IEEE 802.16 is not part of an 
> end-to-end system definition.

looks good. I will reuse your suggestion for the charter update.

>> For example:
> 
> Change "For example:" to "Specifically:"

done.

<snipped> 

>> Additionally - as IEEE 802.16 is a point-to-multipoint network -
>> an 802.16 subscriber station is not capable of multicasting (e.g.,
>> for neighbor discovery, ARP, IP multicasting services, etc.) or
>> direct communication to the other nodes within the same subnet
>> (prefix).
> 
> As subnet and prefix are IP concepts, they shouldn't really be used to
> describe the
> MAC capabilities.
> 
> So suggest changing the last line to:
> 
> direct communication to the other nodes attached to the same base station.

In principle, there is no any explicit difference, *same subnet (prefix)
has another implication though especially IPv6 implication. 
Here is a suggested change:

direct communication to the other nodes within the same subnet (prefix)

CHANGE TO:

direct communication to the other nodes attached to the same Base Station
within the same subnet (prefix).

<snipped>
 
>>The scope of this working group is as follows (WG Deliverables);
>>
>> - Produce "16ng Problem Statement, Goal and Requirement" to identify the
>> 16ng problem statement, goal and technical requirement of IP adoption
>> over IEEE 802.16 along with 16ng related terminology to be used
>> for the base guideline while defining solution frameworks. [Informational RFC]
> 
> Removing redundancy and adding detail:
> 
> - Produce "16ng Problem Statement, Goal and Requirement" to identify the
> specific gaps in the 802.16 MAC for IPv4/IPv6 support, describe
> possible network models (ie. point-to-point, broadcast etc.), and provide 
> 16ng related terminology to be used for the base guideline while defining 
> solution frameworks. [Informational RFC]

looks good.

<snipped>

>From [email-masked] Tue May 16 06:10:29 2006
Date: Mon, 15 May 2006 23:18:36 +0300
From: Jari Arkko <[email-masked]>
To: Soohong Daniel Park <[email-masked]>
Subject: Re: [16ng] Re: WG Review: IP over IEEE 802.16 Networks (16ng)
cc: [email-masked]
cc: IESG <[email-masked]>

Soohong Daniel Park wrote:

>>2. Regarding the IPv4/v6-over-Eth-CS documents, I think that with eth
>>CS, IPv4 and IPv6 can and should be addressed in the same document.
>>Max, what do you think?
>>    
>>
>
>Let me keep the deliverable as it is, we will be able to make
>a concensus later whetner or not merging them.
>  
>
Lets focus now on what functionality (and mandatory etc status) we
want to develop. There are different ways of packaging the same
content in different documents, and I'd like to give some freedom
for the eventual WG to decide what that packaging is. (Also, given
the short time we have until Wimax Forum wants to use a reference
to an RFC, it may be necessary to develop that part first, and
bundling it with the rest could cause it to miss the deadline.)

--Jari