Subject: RE: [16ng] Assumption of the Acess Router knows all on-link addresses

From: "Junghoon Jee" <[email-masked]>
Date: Thu, 3 Aug 2006 11:30:53 +0900

Hello Pars,

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Pars MUTAF
> Sent: Wednesday, July 26, 2006 3:24 AM
> To: Erik Nordmark
> Cc: [email-masked]; [email-masked]
> Subject: Re: [16ng] Assumption of the Acess Router knows all 
> on-link addresses
> 
> 
> Hi,
> 
> Selon Erik Nordmark <[email-masked]>:
> 
> > Syam Madanapalli wrote:
> > > Hi,
> > >
> > >> From the 16ng minutes:
> > >
> > >    Dave Thaler: On IP*CS, the assumption that the router 
> knows all on-link
> > >    addresses based on DAD does not hold in the IPv6 
> architecture/protocol.
> > >    There are at least 4 reasons, probably more, why this 
> is a faulty
> > >     assumption.
> > >
> > >
> > > The current WiMAX solution is based on this assumption, 
> so will you 
> > > please provide reasons why this assumption is faulty?
> > >
> > > Learning addresses in use using DAD is one mechanism. The AR can

> > > also learn from MLD and may be from 802.16 MAC connection 
> establishment etc.
> > > And in case the AR does not know about the address, an MS 
> may not be 
> > > able to communicate using that address.
> >
> > The DAD and MLD approaches to learning might not be completely 
> > reliable, especially if we are concerned about the AR 
> crashing and rebooting.
> 
> We should be concerned IMO. It will happen sooner or later. 
> And the consequences would be really serious if everybody 
> becomes unreachable.
> In addition, the probability of crash (or temporary power cut 
> etc.) is not avoidable in some countries. These contries will 
> prefer IP because it is the cheapest, easiest solution (I guess).
> 
> Another motivation is disaster (disaster->powercut->reboot).
> 
> IP can easily recover from loss of state (normally). It was 
> designed for this (no?).

I also think that this is a important feature underlying IP
architecture.

> >
> > But learning the IPv6 address(es) of the MS from 802.16 signaling 
> > (such as the connection establishment) seems to be a 
> reliable option. 
> > If the AR crashes one would assume that all the MAC 
> connections would 
> > be dropped, which means the hosts would have to 
> re-establish the MAC 
> > connections, hence the AR would find out about the IPv6 
> addresses again.

It is better to think in this way that the 802.16 transport connection
for IP packet transfer is established from the BS to MN.
The AR which in most cases separated from the BS does not actively
involve in this procedure.

-Junghoon

> 
> I think there should be a notification that the MAC 
> connection is not available
> (lost) and the host must re-establish it. Otherwise idle 
> hosts that expect incoming sessions (using e.g. MIPv6) would 
> become unreachable without knowing it.
> 
> Does 802.16 have such notification signaling?
> 
> If not, there are two choices IMHO:
> 
> 1. Using standard neighbor discovery. Upon incoming session, 
> the access router would broadcast a neighbor solicitation 
> over the subnet. The destination host would re-establish its 
> MAC connection and receive the packet. Is this possible over 
> 802.16? If we can broadcast router advertisements, why we 
> can't broadcast a neighbor solication?
> 
> 2. If the AR needs all MAC connections and all IP addresses 
> in the subnet at the same time (for some reason that I don't 
> understand), then it can broadcast an "alert: MAC connections 
> are lost!" message. Upon receipt of this message, every host 
> would re-establish its MAC connection proactively.
> 
> The first one is of course better (more resource efficient in 
> terms of bandwidth, energy and access router CPU). It is on demand.
> 
> >
> > But we need to make sure that the above works when the host 
> is using 
> > multiple IPv6 addresses on the 802.16 network interface. Would the

> > host have a separate MAC connection for each IPv6 address? 
> Or is there 
> > a way for the host to add an IPv6 address to an existing 
> MAC connection?
> > (It seems like those capabilties would be required even without
the 
> > learning on the AR, since the AR would need to know which 
> IPv6 address 
> > should be sent to which CID AFAICT.)
> 
> 
> Thanks,
> pars
> 
> 
> >
> >     Erik
> > _______________________________________________
> > 16ng mailing list
> > [email-masked]
> > http://eeca16.sogang.ac.kr/mailman/listinfo/16ng
> >
> 
> 
> 
> 
> ----------------------------------------------------------------
> This message was sent using IMP, the Internet Messaging Program.
> _______________________________________________
> 16ng mailing list
> [email-masked]
> http://eeca16.sogang.ac.kr/mailman/listinfo/16ng

---

From: Pars Mutaf <[email-masked]>
Date: Fri, 04 Aug 2006 13:54:31 +0200

Hello Junghoon,

> I also think that this is a important feature underlying IP

Good news!

> involve in this procedure.

OK. So if I understand correctly, the only state that the ASN GW must
know/learn is: the GRE tunnel of each host. Right?

I think Neighbor Discovery (ND, or Andy? :-) 
can be used to reactively recover from loss of state, 
in this case too.

pars

---

From: Pars MUTAF <[email-masked]>
Date: Fri, 4 Aug 2006 16:39:49 +0200

> know/learn is: the GRE tunnel of each host. Right?

Looks like my question can be misinterpreted:

When there is an incoming packet, the ASN GW must know to which
GRE tunnel (i.e. BS) the packet must be forwarded.

If it doesn't know (because it was lost, or expired), it can
learn it by multicasting a neighbor solicitation.

I missed something?

Thank you,
pars

>From [email-masked] Mon Aug  7 03:31:59 2006
From: "Junghoon Jee" <[email-masked]>
To: <[email-masked]>
Subject: Re: [16ng] Assumption of the Acess Router knows all on-linkaddresses
Date: Mon, 7 Aug 2006 02:23:12 +0900
cc: [email-masked]
cc: [email-masked]

Pars,
Please find the inline replies and comments.

>> I also think that this is a important feature underlying IP

Good news to myself as well !

> know/learn is: the GRE tunnel of each host. Right?

I am still waiting to listen from Syam how an AR can learn all the link local address of SSs through the GRE tunnels.
We need to think about the detailed steps regarding the establishment of the 802.16 connection between BS and SS, 
the SS's configuration of the LLA and setting up the GRE tunnel between the AR and BS.

> can be used to reactively recover from loss of state, 

I agree. It is more better to follow the basic IPv6 operation here in managing this kind of IP level information.

Best Regards,
-Junghoon