Subject: [16NG] Comments on draft-ietf-16ng-ipv6-over-ipv6cs-09.txt

From: "John.zhao" <[email-masked]>
Date: Thu, 22 Mar 2007 22:13:34 +0800

Hello,all

	Based on the discussion in Monday,there is something about idle mode need to be clarified in current draft about ipv6cs.

	Firstly, if the movement detection will be triggered to a simple IPv6 MN when it cross difference ARs including both of the handover normally and idle mode?
		Why we need to do this?Because if we didn't specify about this scenario,then normally when the MS cross difference ARs the new AR will advertise the Router Advertisement to this MS as soon as the IPv6 link is established(section 8.2).So how about the session ongoing?Didn't support it?Or decided by network side,and the method is out of scope to this draft.
		If true,what we should to specified in current draft? Generally,seems have some choice can be chosen as the following:
			1)Change this sentence "The AR should send a number (configurable value) of router advertisements as soon as the IPv6 link is established, to the MS." to "The AR should send a number (configurable value) of router advertisements as soon as the IPv6 link is established and network policy permitted if it existed, to the MS." 
			2)If we need to involve the Anchor AR concept to distinguish the difference roles of AR to simple IPv6?Or we didn't support the action that cross different ARs to a simple IPv6 MN in current stage or our wg?
			3)Specified something detail about idle mode is out of scope.(Seems not a good resolution).

	Secondly,to mobile IPv6,there still have some network policy exist. So the same situation will occured just as the simple IPv6 that we didn't need the AR to advertise the Router Advertisement as soon as the IPv6 link is established, to the MS.So if we can also consider similar description as above?

	Thirdly,if we accept that idea above has showed,then if we also need to specify any more about idle mode for the AR behavior?Something about the following need to be considered:
		1)When a simple IPv6 wake from idle mode,if will the MS keep to use that original AR to keep the session continuable.And if that MS need to keep the IPv6 link with it's original AR when it is in normal mode.
		2)AR need to distinguish the MS is simple IPv6 or mobile IPv6 or we can push these tasks to out of scope. But state that AR need to decide if advertisement need to be sent to a MS bese on the MN movement event and network policy decision.

	IMHO,in my opinion, I suppose to support the session continuable even for simple IPv6.At lease from protocol perspective. And if does like this will be decide by operator.

	About this drafts,I think there is another problem need to be clarify is in section 6.2. In step 2, it said that the capability exchange is the REG-REQ/RSP progress. IMHO, I don't where is this come from? In IEEE802.16d-2004 and IEEE802.16e-2005,I can't find something like this decription. In IEEE802.16,the step 2 about the capability exchange is should be the SBC-REQ/RSP and REG-REQ/RSP is processed after PKMv2(this is optional).So if this is correct,the section 6.2 need to be modified as IEEE802.16 document. 

	Maybe I am right ,but maybe not. :-)

	Best Rgds,
Thanks,

　　　　　　　　 John.zhao
　	　　　　　　2007-03-22
_______________________________________________
16NG mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/16ng

---

From: "文涛" <[email-masked]>
Date: Sun, 25 Mar 2007 20:42:24 +0800

Hi, All,

    I think John.zhao is right.

   I  also think this is a problem and we need to specify the behavior of
ARs when handover esp handover in idle mode

occured.

  Tonio