Subject: [16NG] [ietfdb] #324: Move old liaison statements from hardcoded template to database

From: "16ng issue tracker" <[email-masked]>
Date: Tue, 03 Nov 2009 13:03:17 -0000

#324: Move old liaison statements from hardcoded template to database
-----------------------------------+----------------------------------------
 Reporter:  pasi.eronen@…          |       Owner:     
     Type:  enhancement            |      Status:  new
 Priority:  medium                 |   Milestone:     
Component:  liaison/               |     Version:     
 Keywords:                         |  
-----------------------------------+----------------------------------------
 Currently, ietf/templates/liaisons/liaisondetail_list.html
 contains old liaison statements up to February 2004. They should be
 in the database instead (this may require adjusting the database schema,
 too).

-- 
Ticket URL: <http://trac.tools.ietf.org/tools/ietfdb/ticket/324>
ietfdb <http://tools.ietf.org/tools/ietfdb/>

---

From: "16ng issue tracker" <[email-masked]>
Date: Tue, 03 Nov 2009 13:08:03 -0000

Comment(by pasi.eronen@…):

 Some Perl code that isn't finished, but could be useful:
 {{{
 open(INPUT, "liaisondetail_list.html");
 $/ = '<tr>';
 while ($_ = <INPUT>) {
     last if (/Legacy stuff, hardcoded/);
 }
 while ($_ = <INPUT>) {
     s/ valign=top>/>/g;
     s/ valign="top">/>/g;
     s/ nowrap>/>/g;
     s/<td>/<td>/gi;
     s/<\/td>//gi;
     s/<\/tr>//gi;
     s/<tr>//gi;
     s/<br>//gi;
     s/\s+/ /g;
     s/<.table> .. endblock ..//;
     s/^\s*<td>//;
     s/\s*<td>/\t/g;
     @cols = split /\t/;
     if (@cols != 4) {
         die "Not four columns";
     }
     $date = $cols[0];
     if ($date !~ /^\w+ \d\d\d\d$/) {
         print $_;
         die "Bad date $date";
     }
     $links = $cols[3];
     $links =~ s/\(\.?pdf file\)//g;
     $links =~ s/\(pdf\)//g;
     $links =~ s/<\/a>( \(Temporary Document [^)]+\))/\1<\/a>/g;
     if ($links !~ /^(\s*<a href="[^"]+">[^<]*<\/a>)+\s*$/i) {
         print "------\n", $links, "\n";
     }
 }

 }}}

-- 
Ticket URL: <http://trac.tools.ietf.org/tools/ietfdb/ticket/324#comment:1>
ietfdb <http://tools.ietf.org/tools/ietfdb/>