Subject: [16NG] I-D Action:draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-07.txt

From: [email-masked]
Date: Wed, 2 Jun 2010 20:00:01 -0700 (PDT)

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the IP over IEEE 802.16 Networks Working Group of the IETF.

	Title           : Transmission of IPv4 packets over IEEE 802.16's IP Convergence Sublayer
	Author(s)       : S. Madanapalli, et al.
	Filename        : draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-07.txt
	Pages           : 13
	Date            : 2010-06-02

IEEE 802.16 is an air interface specification for wireless broadband
access.  IEEE 802.16 has specified multiple service specific
Convergence Sublayers for transmitting upper layer protocols.  The
packet CS (Packet Convergence Sublayer) is used for the transport of
all packet-based protocols such as Internet Protocol (IP) and IEEE
802.3 (Ethernet).  The IP-specific part of the Packet CS enables the
transport of IPv4 packets directly over the IEEE 802.16 Media Access
Control (MAC).

This document specifies the frame format, the Maximum Transmission
Unit (MTU) and address assignment procedures for transmitting IPv4
packets over the IP-specific part of the Packet Convergence Sublayer
of IEEE 802.16.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-07.txt

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 3 Jun 2010 22:40:40 +0200

Is it really reasonable to progress this I-D towards RFC? Meanwhile
IEEE802.16 as well as WiMAX Forum are moving towards an combined IP-CS,
which is capable to transfer IPv4 packets as well as IPv6 packets over
the same service flows.

IMHO, it would make much more sense to merge the IPv6-CS and the IPv4-CS
specification text into a common IP-CS text.

Bye
Max

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of
ext [email-masked]
Sent: Thursday, June 03, 2010 5:00 AM
To: [email-masked]
Cc: [email-masked]
Subject: [16NG] I-D
Action:draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-07.txt

A New Internet-Draft is available from the on-line Internet-Drafts
directories.
This draft is a work item of the IP over IEEE 802.16 Networks Working
Group of the IETF.

	Title           : Transmission of IPv4 packets over IEEE
802.16's IP Convergence Sublayer
	Author(s)       : S. Madanapalli, et al.
	Filename        :
draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-07.txt
	Pages           : 13
	Date            : 2010-06-02

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-16ng-ipv4-over-802-dot-16
-ipcs-07.txt

---

From: <[email-masked]>
Date: Thu, 3 Jun 2010 22:43:44 +0200

Max,

Is the new IP-CS based on GPCS? If so, I believe it is better to write a
separate I-D which specifies v4 and v6 transport over such a convergence
sublayer.

-Raj 

On 6/3/10 3:40 PM, "Riegel, Maximilian" <[email-masked]> wrote:

> _______________________________________________
> 16NG mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/16ng

---

From: "Riegel, Maximilian (NSN - DE/Munich)" <[email-masked]>
Date: Thu, 3 Jun 2010 23:01:11 +0200

Raj,

The new IP-CS is not based on GP-CS, but is a special version of the
IP-CS introduced in the IEEE802.16-2009 specification. There is still
quite some legacy thinking but meanwhile a common sense is established,
that this 'common' IP-CS is the way forward for 802.16m.

Bye
Max 

-----Original Message-----
From: ext Patil Basavaraj (Nokia-D/Dallas)
[mailto:[email-masked]] 
Sent: Thursday, June 03, 2010 10:44 PM
To: Riegel, Maximilian (NSN - DE/Munich); [email-masked]
Subject: Re: [16NG] I-D
Action:draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-07.txt

Max,

-Raj

---

From: <[email-masked]>
Date: Thu, 3 Jun 2010 23:06:31 +0200

Thanks for the update.

On 6/3/10 4:01 PM, "Riegel, Maximilian" <[email-masked]> wrote:

> IP-CS introduced in the IEEE802.16-2009 specification.

So this enhanced IP-CS is different in some ways from the legacy IPv4CS and
IPv6CS? 

It may be useful to specify IPv4/v6 over this revised IP-CS rather than just
merging the previous documents into a new I-D. You could reuse quite a lot
of the text but you need to consider the changes that have been made to this
.16-2009 IP-CS version.

-Raj

> There is still

---

From: gabriel montenegro <[email-masked]>
Date: Fri, 4 Jun 2010 01:28:18 -0700 (PDT)

The "IPv4 CS" doc is the only remaining deliverable and only has one DISCUSS to clear in order to proceed.
I think it's worthwhile doing so in order to have an RFC to document the IETF's position on IPv4 over 802.16
(not necessarily WiMAX). The non-support from NWG (or at least some in NWG) is already known and
taken into consideration in the IESG deliberation process, in spite of which, the IESG has approved
except for the aforementioned DISCUSS (which this version 07 will hopefully clear).

The current plan is to finish publishing IPv4 CS and then shut down the group, given there are no more
deliverables and no energy left in the WG. 

The new developments for newer revisions of 802.16 sound interesting, but this seems like a separate effort.
It may be worthwhile, but that would require an energized community to tackle the necessary re-chartering, 
editing, participating, reviewing, chairing and we have not seen anything near that level of interest for years 
in this WG. Of course, it could be done outside of the WG, but the point is that this feels like a different
document altogether not something that should prevent this last deliverable to be published. 
When and if that new document is published, it may update and/or obsolete some of the current 
16ng documents. This is part of the IETF lifecycle for documents, so there's nothing wrong about that.

Gabriel
----- Original Message ----
> From: "[email-masked]" <[email-masked]>
> To: [email-masked]; [email-masked]
> Sent: Thu, June 3, 2010 2:06:31 PM
> Subject: Re: [16NG] I-D Action:draft-ietf-16ng-ipv4-over-802-dot-16-ipcs-07.txt
> 
> 
Thanks for the update.

On 6/3/10 4:01 PM, "Riegel, Maximilian" 
> <> href="mailto:[email-masked]">[email-masked]> 
> wrote:

> IP-CS introduced in the IEEE802.16-2009 

So this enhanced IP-CS is different in some ways from the 
> legacy IPv4CS and
IPv6CS? 

It may be useful to specify IPv4/v6 over 
> this revised IP-CS rather than just
merging the previous documents into a new 
> I-D. You could reuse quite a lot
of the text but you need to consider the 
> changes that have been made to this
.16-2009 IP-CS 
> version.

-Raj

> There is still
> quite some legacy 
> thinking but meanwhile a common sense is established,
> that this 'common' 
> [mailto:> href="mailto:[email-masked]">[email-masked]]
> 
> To: Riegel, Maximilian (NSN - 
> DE/Munich); > href="mailto:[email-masked]">[email-masked]
> Subject: Re: [16NG] 
> I-D
> On 6/3/10 3:40 PM, "Riegel, Maximilian" <> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]>
> 
> wrote:
> 
>> IEEE802.16 as well as WiMAX Forum are moving towards 
> an combined
> IP-CS,
>> IMHO, it would make much more sense to merge the IPv6-CS and 
> the
> IPv4-CS
>> From: > ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked] [mailto:> ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]] On Behalf
> 
> Of
>> ext > href="mailto:[email-masked]">[email-masked]
>> 
>> To: > ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]
>> Cc: > ymailto="mailto:[email-masked]" 
> href="mailto:[email-masked]">[email-masked]
>> Subject: [16NG] 
> I-D
>> 
>>        Filename  
>       :
>     Date            : 
> 2010-06-02
>> packet CS (Packet 
> Convergence Sublayer) is used for the transport of
>> all packet-based 
> protocols such as Internet Protocol (IP) and IEEE
>> 802.3 
> (Ethernet).  The IP-specific part of the Packet CS enables the
>> 
>> > target=_blank>ftp://ftp.ietf.org/internet-drafts/
>> 
>> 
>> 16NG mailing 
> list
>> > href="mailto:[email-masked]">[email-masked]
>> > href="https://www.ietf.org/mailman/listinfo/16ng" target=_blank 
> 16NG mailing 
> list
> > href="mailto:[email-masked]">[email-masked]
> > href="https://www.ietf.org/mailman/listinfo/16ng" target=_blank 

16NG 
> mailing list
> href="mailto:[email-masked]">[email-masked]
> href="https://www.ietf.org/mailman/listinfo/16ng" target=_blank