Subject: Re: [3gv6] draft report from the Shanghai workshop - technical topics

From: "Hui Deng" <[email-masked]>
Date: Sun, 22 Nov 2009 15:13:58 +0800

Hi, Alan

I see your points that we (maybe some forum) would better to list all "to be
done"
together to make us aware of what we would better to do.

Thanks

-Hui

> Subject: RE: draft report from the Shanghai workshop - technical topics
> 
> Hi guys - this great comment - but could we change the subject line. It
> would be really great to capture all these operational implication -
> thoughts and experiences -
> 
> Is there a top 20 FAQ list we could put together?.
> 
> Best wishes alan
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Thursday, 19 November 2009 9:06 AM
> To: [email-masked]; [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
[email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked];
> [email-masked]; [email-masked];
[email-masked];
> [email-masked]
> Subject: Re: draft report from the Shanghai workshop
> 
> 
> Hi Julien,
> 
> Comments inline:
> 
> 
> On 11/18/09 4:46 PM, "ext Laganier, Julien" <[email-masked]> wrote:
> 
> > Hi Raj,
> >
> > I think we touched the core of the issue here.
> >
> > I do not work for an operator,
> 
> Neither do I. So that would be +1 here :)
> 
> > but my understanding is that operators do not
> > want to use different APNs and PDNs for every set of 5~10M subscribers,
> > notably because there's a burden in provisioning different APNs:
> 
> I am wondering if we are confusing some terminlogy here. The PDN that
> operators need to provide connectivity to is the Internet (lets not worry
> about other PDNs for now). So all 300M subs need to connect to the same
PDN.
> However they can connect to the same PDN via different APNs, no? Or maybe
> even the APN itself is the same. But in reality an APN for a specific
> subscriber maps to a unique gateway. So even though all 300M subs connect
to
> the same PDN via a common APN, the underlying means of how this is done is
> an operational aspect, right?
> 
> >
> >  1. on the HSS for every PDN subscription of every user subscription.
> >  2. on the UEs for non default APNs.
> 
> Sure. There is some level of pain. But on the UE I think you can still
> specify a default APN (provisioning), but the GGSN that is resolved from
the
> DNS query could map to a specifc instance of the GGSN which provides
> connectivity to the PDN.
> 
> >
> > It's way simpler if they can handle all 300M subscribers with a single
APN
> and
> > PDN, while every set of 5~10M subscribers is handled by a different
> GGSN/PDN
> > GW.
> 
> Agree. And I think we are saying the same thing here. I am not advocating
> different PDNs and APNs for the 300M subs who all need connectivity to the
> Internet PDN and the APN for this is the same (lets say "Internet").
> 
> > With the limit of 17M private IPv4 addresses, this is not possible
without
> > placing a NAT between the 3GPP core (and UE) and the PDN, which might
> break
> > the operational infrastructure of the PDN (e.g. for charging) when
> subscribers
> > are identified by the private IPv4 address that was allocated to them.
> 
> But this is how most networks operate today. There is a NAT44 between the
> GGSN and the PDN (Internet). I don't think there is a charging issue here.
> 
> >
> > That being said, I am under the impression that the problem is
intractable
> > with IPv4. As a result it seems that the operational infrastructure
would
> need
> > to be upgraded to cope with different subscribers in a single PDN using
> > overlapping IPv4 addresses, or the service be transitioned to IPv6. Both
> of
> > these involve significant upgrade of the PDN and I am sure the tradeoff
> > between the two is different with every operator.
> 
> Sure. Overlapping addresses will have some implications on the operational
> infra. And operators will need to weigh the costs and complexities of the
> choice of using overlapping IPv4 addresses vs transitioning towards IPv6.
> Its a tradeoff as you say.
> 
> -Raj
> 
> >
> > --julien
> >
>

---

From: "alan lloyd" <[email-masked]>
Date: Mon, 23 Nov 2009 18:36:23 +1100

Thanks Hui -  it would be great to get some structure around the issue. I do
see we are all keen to make IPv6 happen as fast as possible and there will
be many looking for "jump start" and "dos and donts".material - .and of
course case studies. I think the commercial and govt worlds are that aware
of the issue - but not treating it with any urgency as are still going ahead
with e.g.   deploying new services and planning infrastructure projects.

What do people think?

Best wishes alan

-----Original Message-----
From: Hui Deng [mailto:[email-masked]] 
Sent: Sunday, 22 November 2009 6:14 PM
To: 'alan lloyd'
Cc: [email-masked]
Subject: RE: draft report from the Shanghai workshop - technical topics

Hi, Alan

Thanks

-Hui

[email-masked];
[email-masked];
PDN.
to
the
APN
without
intractable
would