Subject: [3gv6] Dual-stack approaches in general

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 02 Dec 2009 13:10:19 -0800

Hello folks,

I'm just joining the list, but there have not been
very many discussion topics.

Up until now, my understanding is that dual-stack
approaches do not offer any additional relief from
the pressure on the IPv4 address space, compared
to NAT.  Dual-stack is, of course, great for hosts
that have to run both IPv4 and IPv6 applications
at the same time.

Would there be some value in an IETF document
clarifying the value of dual-stack approaches?
They seem to be multiplying in the wild these days.

Regards,
Charlie P.

---

From: <[email-masked]>
Date: Wed, 2 Dec 2009 23:49:53 +0100

Hi Charlie,

DS can to a certain extent offer relief from the address exhaustion issue if the majority of the apps on the host and servers were to use IPv6. IPv4 would be used only for those applications which lag behind in the transition to v6.
Hence by providing DS connectivity, there could be some degree of relief on v4 addresses.

-Basavaraj

On 12/2/09 3:10 PM, "Charles Perkins" <[email-masked]> wrote:

Hello folks,

Regards,
Charlie P.

_______________________________________________
3gv6 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/3gv6

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 2 Dec 2009 15:00:38 -0800 (PST)

Hi Charlie,
  I don't know the answer to your question but I see a lot of discussion on DS in softwire ML lately, mainly initiated by Hui.

Regards,

Behcet

----- Original Message ----
> From: Charles E. Perkins <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Sent: Wed, December 2, 2009 3:10:19 PM
> Subject: [3gv6] Dual-stack approaches in general
> 
> 
> Hello folks,
>

---

From: "Stefano Faccin" <[email-masked]>
Date: Wed, 2 Dec 2009 19:10:30 -0500

Hello Raj,

I agree with you that DS can be beneficial. However, we need to consider
that for DS to be an effective solution, a good number of
services/applications will have first to be migrated to IPv6. For as
long as just a few of them have been migrated, the offload to IPv6
represents just a meager relief.

Cheers,

Stefano 

From: [email-masked] [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, December 02, 2009 2:50 PM
To: [email-masked]; [email-masked]
Subject: Re: [3gv6] Dual-stack approaches in general

Hi Charlie,

DS can to a certain extent offer relief from the address exhaustion
issue if the majority of the apps on the host and servers were to use
IPv6. IPv4 would be used only for those applications which lag behind in
the transition to v6. 
Hence by providing DS connectivity, there could be some degree of relief
on v4 addresses. 

-Basavaraj 

Hello folks,

Regards,
Charlie P.

---------------------------------------------------------------------
This transmission (including any attachments) may contain confidential information, privileged material (including material protected by the solicitor-client or other applicable privileges), or constitute non-public information. Any use of this information by anyone other than the intended recipient is prohibited. If you have received this transmission in error, please immediately reply to the sender and delete this information from your system. Use, dissemination, distribution, or reproduction of this transmission by unintended recipients is not authorized and may be unlawful.

---

From: "Charles E. Perkins" <[email-masked]>
Date: Wed, 02 Dec 2009 16:32:57 -0800

Hello Stefano,

What if I interpreted your comment as follows:

"In order for <insert mechanism> to be effective at enabling
  IPv6 transition, a good number of services/applications will
  have first to be migrated to IPv6."

Am I missing the point?

But anyway I totally agree with you.  And, I suggest that
in order to promote the migration, services should be able
to run over IPv6.  And that means that services should be
able to serve both IPv6 and IPv4 clients, because no business
owners in their right minds would ignore the 99.99% of
existing customers that do still run only IPv4.

Back to the question about dual-stack...  Basavaraj said:

 > IPv4 would be used only for those applications which
 > lag behind in the transition to v6.

This jives well with my suggested interpretation
above.  But dual-stack doesn't provide any motivation
for migrating the applications.

Enabling full access from economically addressable
IPv6-only servers/hosts/websites to the entire IPv4
Internet _does_ provide motivation for migrating
applications.

I think that's what we should be doing.  Dual-stack
has the effect of doubling the administrative burden
for seemingly little payoff.

Regards,
Charlie P.

---

From: Fred Baker <[email-masked]>
Date: Wed, 2 Dec 2009 17:19:17 -0800

On Dec 2, 2009, at 1:10 PM, Charles E. Perkins wrote:

> Would there be some value in an IETF document clarifying the value  
> of dual-stack approaches?

I don't think dual stack approaches are multiplying, at least as I  
understand the term; ways to have only one stack and talk across or to  
a different stack are going hog-wild. The IETF is trying to identify a  
few that it can say it honestly think will work reasonably well, and  
is focusing on those that came with deployment experience behind them  
- ds-lite, 6rd, and IVI. But there are also a large group of people  
that seem to think this is a great way to publish a paper somewhere or  
something like that.

RFC 4213:
"Dual stack" implies providing complete implementations of both  
versions of the Internet Protocol (IPv4 and IPv6), and configured  
tunneling provides a means to carry IPv6 packets over unmodified IPv4  
routing infrastructures.

---

From: Fred Baker <[email-masked]>
Date: Wed, 2 Dec 2009 17:27:37 -0800

On Dec 2, 2009, at 2:49 PM, <[email-masked]> <[email-masked] 
 > wrote:

> issue if the majority of the apps on the host and servers were to  
> use IPv6. IPv4 would be used only for those applications which lag  
> behind in the transition to v6.

Well, yes; in general, RFC 4213 suggests turning on IPv6 in your IPv4  
network. The assumption is not that you're trying to do something  
about your IPv4 address space per se; it is that you are trying to  
replace your IPv4 service with IPv6 service, and it suggests that  
turning on IPv6 is the first thing you need to do to make that happen.  
Expect IPv6 to become a market requirement for applications when IPv6  
gets better service than IPv4, or some popular services are no longer  
accessible by IPv4.

As to applications, yes, of course. In point of fact, many  
applications have already been ported to IPv6 and operate just fine. I  
understand that Apple made a requirement that applications on the  
iPhone must be IPv6-capable, and as a result several tens of thousands  
of applications are in fact IPv6-capable.

---

From: <[email-masked]>
Date: Thu, 3 Dec 2009 03:13:45 +0100

Hi Stefano,

Its got to start somewhere. And at least IMO getting IPv6 connectivity up and running will be an incentive to upgrade the apps to run over v6. Otherwise it is a catch22 situation.

-Raj

On 12/2/09 6:10 PM, "ext Stefano Faccin" <[email-masked]> wrote:

Hello Raj,
I agree with you that DS can be beneficial. However, we need to consider that for DS to be an effective solution, a good number of services/applications will have first to be migrated to IPv6. For as long as just a few of them have been migrated, the offload to IPv6 represents just a meager relief.
Cheers,

Stefano

From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, December 02, 2009 2:50 PM
To: [email-masked]; [email-masked]
Subject: Re: [3gv6] Dual-stack approaches in general

Hi Charlie,

-Basavaraj

Hello folks,

Regards,
Charlie P.

---

From: <[email-masked]>
Date: Wed, 2 Dec 2009 21:48:06 -0500

The comment on the ipv6 iPhone is interesting.

Are there any references that are public on how this works?

A quick search of "IPv6 iPhone" does not seem to give hopeful news
http://www.ipv6actnow.org/2009/07/ipv6-on-the-iphone/ indicates third party support.

My question though is how should it work?  Are the app servers IPv6?  If a phone has a Ipv6 address and Ipv4 , does the indication of a AAAA record tell the phone to use the v6 stack?  If the phone is roaming, and had been using IPv6 in a previous network, and now has to come over a NAT, might this cause issues with security associations. Would the phone flush the AAAA response, or get stuck when no longer in v6.
Is there a set of test cases that address dual stack support, especially for cellular phones.

Thanks
Brian

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 3 Dec 2009 09:40:18 -0800 (PST)

----- Original Message ----
> From: Fred Baker <[email-masked]>
> To: "<[email-masked]>" <[email-masked]>
> Cc: [email-masked]
> Sent: Wed, December 2, 2009 7:27:37 PM
> On Dec 2, 2009, at 2:49 PM, 
> wrote:
> 
> > DS can to a certain extent offer relief from the address exhaustion issue if 
> the majority of the apps on the host and servers were to use IPv6. IPv4 would be 
> used only for those applications which lag behind in the transition to v6.
> 
> Well, yes; in general, RFC 4213 suggests turning on IPv6 in your IPv4 network. 
> The assumption is not that you're trying to do something about your IPv4 address 
> space per se; it is that you are trying to replace your IPv4 service with IPv6 
> service, and it suggests that turning on IPv6 is the first thing you need to do 
> to make that happen. Expect IPv6 to become a market requirement for applications 
> when IPv6 gets better service than IPv4, or some popular services are no longer 
> accessible by IPv4.
> 
> As to applications, yes, of course. In point of fact, many applications have 
> already been ported to IPv6 and operate just fine. I understand that Apple made 
> a requirement that applications on the iPhone must be IPv6-capable, and as a 
> result several tens of thousands of applications are in fact 
> IPv6-capable._

But iPhone itself is not currently IPv6-capable :).

Maybe a new version is coming to change this.

--behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 3 Dec 2009 15:40:45 -0800 (PST)

Hi Charlie,

----- Original Message ----
> for seemingly little payoff.

I agree.

Another point is prefix delegation. I think that with so many new Internet phones becoming IPv6 enabled, we would need many more point-to-point links with per-MN prefixes. This brings prefix management as an issue. 
Crica 2006 we wrote many drafts on this which they did not go far, maybe they were ahead of the times.

This problem is mentioned in Jari's slides in Shanghai Workshop.

Regards,

Behcet