Subject: [3gv6] FW: DNS Assignment for NAT64

From: <[email-masked]>
Date: Tue, 5 Jan 2010 21:46:30 -0500

Resent as requested

-----Original Message-----
From: Smith, Brian (3010640) 
Sent: January 2, 2010 7:04 PM
To: Dan Wing; 'Hui Deng'
Cc: [email-masked]
Subject: RE: [3gv6] DNS Assignment for NAT64

I believe in a Rel 8 architecture there is only the option of a v6 network or a v4 network, the concept of a rel 4/6 PDN comes in release 9. (Really need to check this)

For Rel 8 will a dual stack device or a single stack device look the same to the network, as all that can be requested is a IPv6 PDN (in LTE)?

Hence there is no way to distinguish a pure v6 network from a v4/6 network.

Thanks
Brian

-----Original Message-----
From: Dan Wing [mailto:[email-masked]] 
Sent: January 2, 2010 10:21 AM
To: 'Hui Deng'; Smith, Brian (3010640)
Cc: [email-masked]
Subject: RE: [3gv6] DNS Assignment for NAT64

> -----Original Message-----
> From: Hui Deng [mailto:[email-masked]] 
> Sent: Friday, January 01, 2010 11:08 PM
> To: 'Dan Wing'; [email-masked]
> Cc: [email-masked]
> Subject: RE: [3gv6] DNS Assignment for NAT64
> 
> > > From: Hui Deng [mailto:[email-masked]]
> > > Sent: December 31, 2009 10:07 AM
> > > To: Smith, Brian (3010640)
> > > Subject: RE: [3gv6] DNS Assignment for NAT64
> > >
> > >
> > >
> > > Your question is valid, today we have 3 solutions: dual
> > > stack/PNAT host/NAT64 host
> > >
> > > A: dual stack host need regular DNS server
> > >
> > > B: PNAT host need regular DNS server
> > >
> > > C: NAT64 host need DNS64.
> > >
> > >
> > >
> > > A and B could co-exisit,
> > >
> > > C won't be able to co-exisit with A, because IPv4 application
> > > in a won't work, but it's IPv6 application could work.
> > >
> > > B could co-exisit together with A and C
> > 
> > B requires changing the IP stack and DNS function on the
> > host.
> Changing host's platform, framework and applications are 
> really diffculty,
> but changing host's network stack is not that difficult if 
> operator could customize the mobile phone.

What about tethered PCs?  Would the mobile phone provide the
PNAT function on behalf of the tethered PC, or would the PC
do PNAT itself?

> > > So normally it will be really hard to arrange NAT64 host and
> > > Dual stack host in the same APN.
> > 
> > Yes, that's because what you are calling a "NAT64 host" (which
> > is just an IPv6-only host) needs to use a DNS64, whereas the
> > other two (dual-stack host, PNAT host) use a normal DNS
> > server.
> I guess some operator would like to get answer how to make it works.

If it's an IPv6-only network, there are only IPv6-only devices
on the network.  Those need a DNS64 function and a NAT64 function
if the devices want to access the IPv4 Internet.

If it's a dual-stack network, neither DNS64 nor NAT64 are provided
to the devices.  Just a normal DNS is provided.

If it's an IPv4-only network (which is what everyone runs today),
a normal DNS is provided.

Is there more that needs to be explained?

-d

> Thanks
> 
> -Hui
> 
> > 
> > -d
> > 
> > 
> > >
> > >
> > >
> > > Thanks for the discussion
> > >
> > >
> > >
> > > -Hui
> > >
> > >
> > >
> > > ________________________________
> > >
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Thursday, December 31, 2009 1:08 AM
> > > To: [email-masked]
> > > Subject: Re: [3gv6] DNS Assignment for NAT64
> > >
> > >
> > >
> > > Not on the same UE, on the same network, a dual stack device,
> > > and a single stack device, can we assign different DNS?
> > > --------------------------
> > > Sent from my BlackBerry Wireless Handheld
> > >
> > > ________________________________
> > >
> > > From: Hui Deng <[email-masked]>
> > > To: Smith, Brian (3010640)
> > > Sent: Wed Dec 30 10:28:38 2009
> > > Subject: RE: [3gv6] DNS Assignment for NAT64
> > >
> > > So you are asking how dual stack host could co-exisit with
> > > NAT64 IPv6 only host?
> > >
> > >
> > >
> > > Thanks
> > >
> > >
> > >
> > > -Hui
> > >
> > >
> > >
> > > ________________________________
> > >
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: Wednesday, December 30, 2009 12:24 AM
> > > To: [email-masked]
> > > Subject: Re: [3gv6] DNS Assignment for NAT64
> > >
> > >
> > >
> > > I understand for NAT64 to work properly that a DNS64 (aware
> > > of the NAT64 box) must be used.
> > > Would a dual stack device with a valid. IPv4 and 6 address
> > > makes a IPv6 request, we would invoke the NAT64 unnecessarily?
> > >
> > > Thanks
> > > Brian
> > > --------------------------
> > > Sent from my BlackBerry Wireless Handheld
> > >
> > > ________________________________
> > >
> > > From: Hui Deng <[email-masked]>
> > > To: Smith, Brian (3010640)
> > > Sent: Sat Dec 26 21:24:37 2009
> > > Subject: RE: [3gv6] DNS Assignment for NAT64
> > >
> > > Hi, Brian,
> > >
> > >
> > >
> > > Are  you saying NAT64 prefix assignment from DNS assignment?
> > >
> > > What do you mean a different DNS here?
> > >
> > >
> > >
> > > I guess that you are asking whether the device know there is
> > > a translator on the network side or not?
> > >
> > >
> > >
> > > Thanks for your discussion
> > >
> > >
> > >
> > > -Hui
> > >
> > >
> > >
> > > ________________________________
> > >
> > > From: [email-masked] [mailto:[email-masked]] On
> > > Behalf Of
> > > Sent: Friday, December 18, 2009 10:44 PM
> > > To: [email-masked]
> > > Subject: [3gv6] DNS Assignment for NAT64
> > >
> > >
> > >
> > > Hello all
> > >
> > >
> > >
> > > There was a comment on the BEHAVE working group exploder that
> > > mentioned that devices using NAT64 need a special DNS
> > > assignment.  Specifically dual stack devices should use a
> > > different DNS, presumably because they would have a route to
> > > the v4 server via the dual stack. Can this be accommodated in
> > > UTRAN? LTE (SAE)?  Do we have knowledge of the nature of the
> > > device making the address request? Could this cause a problem?
> > >
> > >
> > >
> > > Thanks
> > >
> > > Brian
> > >
> > >
> > >
> > >
> > >
> > >
> 
> 
>

---

From: <[email-masked]>
Date: Tue, 5 Jan 2010 21:46:57 -0500

Resent as requested

________________________________
From: Smith, Brian (3010640)
Sent: January 1, 2010 1:45 PM
To: Hui Deng
Cc: [email-masked]; [email-masked]
Subject: RE: [3gv6] DNS Assignment for NAT64

Thanks for the discussion; it seems we have an issue that needs some thought.

I just realized that due to using my blackberry I forgot to include the mail exploder.

Regards
Brian

Your question is valid, today we have 3 solutions: dual stack/PNAT host/NAT64 host
A: dual stack host need regular DNS server
B: PNAT host need regular DNS server
C: NAT64 host need DNS64.

A and B could co-exisit,
C won't be able to co-exisit with A, because IPv4 application in a won't work, but it's IPv6 application could work.
B could co-exisit together with A and C

So normally it will be really hard to arrange NAT64 host and Dual stack host in the same APN.

-Hui

Not on the same UE, on the same network, a dual stack device, and a single stack device, can we assign different DNS?
--------------------------
Sent from my BlackBerry Wireless Handheld

So you are asking how dual stack host could co-exisit with NAT64 IPv6 only host?

Thanks

-Hui

I understand for NAT64 to work properly that a DNS64 (aware of the NAT64 box) must be used.
Would a dual stack device with a valid. IPv4 and 6 address makes a IPv6 request, we would invoke the NAT64 unnecessarily?

Thanks
Brian

I guess that you are asking whether the device know there is a translator on the network side or not?

-Hui

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sent: Friday, December 18, 2009 10:44 PM
To: [email-masked]
Subject: [3gv6] DNS Assignment for NAT64

Hello all

There was a comment on the BEHAVE working group exploder that mentioned that devices using NAT64 need a special DNS assignment.  Specifically dual stack devices should use a different DNS, presumably because they would have a route to the v4 server via the dual stack. Can this be accommodated in UTRAN? LTE (SAE)?  Do we have knowledge of the nature of the device making the address request? Could this cause a problem?

Thanks
Brian

---

From: <[email-masked]>
Date: Tue, 5 Jan 2010 21:47:58 -0500

Resent as requested

-----Original Message-----
From: Smith, Brian (3010640) 
Sent: January 4, 2010 9:53 AM
To: Marc Blanchet; Dan Wing
Cc: 'Hui Deng'; [email-masked]
Subject: RE: [3gv6] DNS Assignment for NAT64

Thanks Marc

Yes this was one of the concerns, I had forgotten.

Regards
Brian

-----Original Message-----
From: Marc Blanchet [mailto:[email-masked]] 
Sent: January 3, 2010 11:17 AM
To: Dan Wing
Cc: 'Hui Deng'; Smith, Brian (3010640); [email-masked]
Subject: Re: [3gv6] DNS Assignment for NAT64

 > Is there more that needs to be explained?

I think the scenario is that ipv6-only nodes _and_ dual-stack nodes are 
attached to a dual-stack network. In this case, how does one direct DNS 
requests from ipv6-only and dual-stack nodes to the right DNS servers 
(dns64, normal dns)?

Marc.

> _______________________________________________
> 3gv6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/3gv6

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 6 Jan 2010 10:53:44 +0800

-----Original Message-----
From: Hui Deng [mailto:[email-masked]] 
Sent: Sunday, January 03, 2010 11:01 AM
To: 'Dan Wing'; [email-masked]'
Cc: [email-masked]'
Subject: RE: [3gv6] DNS Assignment for NAT64

> PNAT function on behalf of the tethered PC, or would the PC
It will depends on how mobile phone acts: either it will do prefix
delegation to tethered PC or just act as a modem. For either two cases,
tethered PC have to do PNAT itself.

> Is there more that needs to be explained?
There is the case: network may provide different scenarios (IPv6 only or
dual stack network) to the UE depends on subscription or device ability,
could one DNS server handle both cases?

Regards,

-Hui

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 6 Jan 2010 10:53:54 +0800

-----Original Message-----
From: Hui Deng [mailto:[email-masked]] 
Sent: Sunday, January 03, 2010 11:04 AM
To: [email-masked]'; [email-masked]'
Cc: [email-masked]'
Subject: RE: [3gv6] DNS Assignment for NAT64

The scenario you described is IPv6 only network, whatever a dual stack host
or IPv6 only host, in this case, NAT64 and DNS64 will have to be used, no
need for normal DNS server.

Regards,

-Hui

> Sent: Sunday, January 03, 2010 8:04 AM
> To: [email-masked]; [email-masked]
> Cc: [email-masked]
> I believe in a Rel 8 architecture there is only the option of a v6 network
or
> a v4 network, the concept of a rel 4/6 PDN comes in release 9. (Really
need
> to check this)
> 
> For Rel 8 will a dual stack device or a single stack device look the same
to
> the network, as all that can be requested is a IPv6 PDN (in LTE)?
>

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 6 Jan 2010 10:54:00 +0800

-----Original Message-----
From: Hui Deng [mailto:[email-masked]] 
Sent: Sunday, January 03, 2010 11:36 AM
To: [email-masked]'; [email-masked]'
Cc: [email-masked]'
Subject: RE: [3gv6] DNS Assignment for NAT64

Some dual stack OS send AAAA earlier than A, this could be regarded as
prefer v6 over v4.

I also don't see the big difference between NAT44 and NAT64, either of them
translates, and the latter one migrates to IPv6, it sounds much better.

-Hui

> For a dual stack device operating in a Rel 8 LTE network.  The network
will
> assign an IPv6 and an IPv4 address on separate PDNs.  If both address's
are
> routable, and the IPv6 address is using a DNS64, the IPv6 network side
will
> always return a valid address, even though the v4 network supplied could
work,
> leading to un-necessary traffic through the NAT64.
> 
> I think this is what will happen, there may be other scenarios.
> 
> Is there some logic in a dual stack that would prefer v6 over v4? Or visa
versa?
> 
> I am not sure of the UTRAN equivalent scenario.
> 
> If the UE could request a combo v4/6 APN, then the network could assign a
regular
> DNS, and this will work fine (unless we are using a NAT address space on
the
> v4 side, in which case it may make more sense to use the NAT64?)
> 
> 
> Regards
> Brian
> 
> 
> Sent: January 2, 2010 10:04 PM
> To: Smith, Brian (3010640); [email-masked]
> Cc: [email-masked]