Subject: Re: [3gv6] DNS Assignment for NAT64

From: <[email-masked]>
Date: Fri, 1 Jan 2010 13:45:17 -0500

Thanks for the discussion; it seems we have an issue that needs some thought.

I just realized that due to using my blackberry I forgot to include the mail exploder.

Regards
Brian

________________________________
From: Hui Deng [mailto:[email-masked]]
Sent: December 31, 2009 10:07 AM
To: Smith, Brian (3010640)
Subject: RE: [3gv6] DNS Assignment for NAT64

Your question is valid, today we have 3 solutions: dual stack/PNAT host/NAT64 host
A: dual stack host need regular DNS server
B: PNAT host need regular DNS server
C: NAT64 host need DNS64.

A and B could co-exisit,
C won't be able to co-exisit with A, because IPv4 application in a won't work, but it's IPv6 application could work.
B could co-exisit together with A and C

So normally it will be really hard to arrange NAT64 host and Dual stack host in the same APN.

Thanks for the discussion

-Hui

________________________________
From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, December 31, 2009 1:08 AM
To: [email-masked]
Subject: Re: [3gv6] DNS Assignment for NAT64

Not on the same UE, on the same network, a dual stack device, and a single stack device, can we assign different DNS?
--------------------------
Sent from my BlackBerry Wireless Handheld

________________________________
From: Hui Deng <[email-masked]>
To: Smith, Brian (3010640)
Sent: Wed Dec 30 10:28:38 2009
Subject: RE: [3gv6] DNS Assignment for NAT64
So you are asking how dual stack host could co-exisit with NAT64 IPv6 only host?

Thanks

-Hui

________________________________
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, December 30, 2009 12:24 AM
To: [email-masked]
Subject: Re: [3gv6] DNS Assignment for NAT64

I understand for NAT64 to work properly that a DNS64 (aware of the NAT64 box) must be used.
Would a dual stack device with a valid. IPv4 and 6 address makes a IPv6 request, we would invoke the NAT64 unnecessarily?

Thanks
Brian
--------------------------
Sent from my BlackBerry Wireless Handheld

________________________________
From: Hui Deng <[email-masked]>
To: Smith, Brian (3010640)
Sent: Sat Dec 26 21:24:37 2009
Subject: RE: [3gv6] DNS Assignment for NAT64
Hi, Brian,

Are  you saying NAT64 prefix assignment from DNS assignment?
What do you mean a different DNS here?

I guess that you are asking whether the device know there is a translator on the network side or not?

Thanks for your discussion

-Hui

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of
Sent: Friday, December 18, 2009 10:44 PM
To: [email-masked]
Subject: [3gv6] DNS Assignment for NAT64

Hello all

There was a comment on the BEHAVE working group exploder that mentioned that devices using NAT64 need a special DNS assignment.  Specifically dual stack devices should use a different DNS, presumably because they would have a route to the v4 server via the dual stack. Can this be accommodated in UTRAN? LTE (SAE)?  Do we have knowledge of the nature of the device making the address request? Could this cause a problem?

Thanks
Brian

---

From: "Dan Wing" <[email-masked]>
Date: Fri, 1 Jan 2010 19:19:50 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of [email-masked]
> Sent: Friday, January 01, 2010 10:45 AM
> Cc: [email-masked]
> C won't be able to co-exisit with A, because IPv4 application 
> in a won't work, but it's IPv6 application could work.
> 

B requires changing the IP stack and DNS function on the 
host.

> Dual stack host in the same APN.

Yes, that's because what you are calling a "NAT64 host" (which
is just an IPv6-only host) needs to use a DNS64, whereas the
other two (dual-stack host, PNAT host) use a normal DNS 
server.

-d

> Not on the same UE, on the same network, a dual stack device, 
> and a single stack device, can we assign different DNS?
> Would a dual stack device with a valid. IPv4 and 6 address 
> makes a IPv6 request, we would invoke the NAT64 unnecessarily?
> 
> Thanks 
> Brian
> There was a comment on the BEHAVE working group exploder that 
> mentioned that devices using NAT64 need a special DNS 
> assignment.  Specifically dual stack devices should use a 
> different DNS, presumably because they would have a route to 
> the v4 server via the dual stack. Can this be accommodated in 
> UTRAN? LTE (SAE)?  Do we have knowledge of the nature of the 
> device making the address request? Could this cause a problem?
> 
>  
> 
> Thanks
> 
> Brian
> 
>  
> 
>  
> 
>

---

From: "Dan Wing" <[email-masked]>
Date: Sat, 2 Jan 2010 07:20:45 -0800

> Sent: Friday, January 01, 2010 11:08 PM
> To: 'Dan Wing'; [email-masked]
> Cc: [email-masked]
> Changing host's platform, framework and applications are 
> really diffculty,
> but changing host's network stack is not that difficult if 
> operator could customize the mobile phone.

What about tethered PCs?  Would the mobile phone provide the
PNAT function on behalf of the tethered PC, or would the PC
do PNAT itself?

> I guess some operator would like to get answer how to make it works.

If it's an IPv6-only network, there are only IPv6-only devices
on the network.  Those need a DNS64 function and a NAT64 function
if the devices want to access the IPv4 Internet.

If it's a dual-stack network, neither DNS64 nor NAT64 are provided
to the devices.  Just a normal DNS is provided.

If it's an IPv4-only network (which is what everyone runs today),
a normal DNS is provided.

Is there more that needs to be explained?

-d

> > > Behalf Of