Subject: [3gv6] FW: DNS Assignment for NAT64

From: "Hui Deng" <[email-masked]>
Date: Wed, 6 Jan 2010 10:54:14 +0800

-----Original Message-----
From: Hui Deng [mailto:[email-masked]] 
Sent: Saturday, January 02, 2010 3:08 PM
To: 'Dan Wing'; [email-masked]'
Cc: [email-masked]'
Subject: RE: [3gv6] DNS Assignment for NAT64

> > From: Hui Deng [mailto:[email-masked]]
> > Sent: December 31, 2009 10:07 AM
> > To: Smith, Brian (3010640)
> > Subject: RE: [3gv6] DNS Assignment for NAT64
> >
> >
> >
> > Your question is valid, today we have 3 solutions: dual
> > stack/PNAT host/NAT64 host
> >
> > A: dual stack host need regular DNS server
> >
> > B: PNAT host need regular DNS server
> >
> > C: NAT64 host need DNS64.
> >
> >
> >
> > A and B could co-exisit,
> >
> > C won't be able to co-exisit with A, because IPv4 application
> > in a won't work, but it's IPv6 application could work.
> >
> > B could co-exisit together with A and C
> 
> B requires changing the IP stack and DNS function on the
> host.
Changing host's platform, framework and applications are really diffculty,
but changing host's network stack is not that difficult if operator could
customize the mobile phone.

> 
> > So normally it will be really hard to arrange NAT64 host and
> > Dual stack host in the same APN.
> 
> Yes, that's because what you are calling a "NAT64 host" (which
> is just an IPv6-only host) needs to use a DNS64, whereas the
> other two (dual-stack host, PNAT host) use a normal DNS
> server.
I guess some operator would like to get answer how to make it works.

Thanks

-Hui

> 
> -d
> 
> 
> >
> >
> >
> > Thanks for the discussion
> >
> >
> >
> > -Hui
> >
> >
> >
> > ________________________________
> >
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Thursday, December 31, 2009 1:08 AM
> > To: [email-masked]
> > Subject: Re: [3gv6] DNS Assignment for NAT64
> >
> >
> >
> > Not on the same UE, on the same network, a dual stack device,
> > and a single stack device, can we assign different DNS?
> > --------------------------
> > Sent from my BlackBerry Wireless Handheld
> >
> > ________________________________
> >
> > From: Hui Deng <[email-masked]>
> > To: Smith, Brian (3010640)
> > Sent: Wed Dec 30 10:28:38 2009
> > Subject: RE: [3gv6] DNS Assignment for NAT64
> >
> > So you are asking how dual stack host could co-exisit with
> > NAT64 IPv6 only host?
> >
> >
> >
> > Thanks
> >
> >
> >
> > -Hui
> >
> >
> >
> > ________________________________
> >
> > From: [email-masked] [mailto:[email-masked]]
> > Sent: Wednesday, December 30, 2009 12:24 AM
> > To: [email-masked]
> > Subject: Re: [3gv6] DNS Assignment for NAT64
> >
> >
> >
> > I understand for NAT64 to work properly that a DNS64 (aware
> > of the NAT64 box) must be used.
> > Would a dual stack device with a valid. IPv4 and 6 address
> > makes a IPv6 request, we would invoke the NAT64 unnecessarily?
> >
> > Thanks
> > Brian
> > --------------------------
> > Sent from my BlackBerry Wireless Handheld
> >
> > ________________________________
> >
> > From: Hui Deng <[email-masked]>
> > To: Smith, Brian (3010640)
> > Sent: Sat Dec 26 21:24:37 2009
> > Subject: RE: [3gv6] DNS Assignment for NAT64
> >
> > Hi, Brian,
> >
> >
> >
> > Are  you saying NAT64 prefix assignment from DNS assignment?
> >
> > What do you mean a different DNS here?
> >
> >
> >
> > I guess that you are asking whether the device know there is
> > a translator on the network side or not?
> >
> >
> >
> > Thanks for your discussion
> >
> >
> >
> > -Hui
> >
> >
> >
> > ________________________________
> >
> > From: [email-masked] [mailto:[email-masked]] On
> > Behalf Of
> > Sent: Friday, December 18, 2009 10:44 PM
> > To: [email-masked]
> > Subject: [3gv6] DNS Assignment for NAT64
> >
> >
> >
> > Hello all
> >
> >
> >
> > There was a comment on the BEHAVE working group exploder that
> > mentioned that devices using NAT64 need a special DNS
> > assignment.  Specifically dual stack devices should use a
> > different DNS, presumably because they would have a route to
> > the v4 server via the dual stack. Can this be accommodated in
> > UTRAN? LTE (SAE)?  Do we have knowledge of the nature of the
> > device making the address request? Could this cause a problem?
> >
> >
> >
> > Thanks
> >
> > Brian
> >
> >
> >
> >
> >
> >

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 05 Jan 2010 19:16:03 -0800

> customize the mobile phone.

And I assume on all the tethered PC's, since you suggested PNAT requirement
for tethered PC's in the other mail to Dan. It's not difficult or you expect
the mobile operator to control even the tethered PC's ?

Sri

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 6 Jan 2010 11:15:52 +0800

There are lots of unmodified fixed terminal, right?

-Hui

> From: Sri Gundavelli [mailto:[email-masked]]
> Sent: Wednesday, January 06, 2010 11:16 AM
> To: Hui Deng; [email-masked]
> Subject: Re: [3gv6] FW: DNS Assignment for NAT64
> 
> 
> 
>

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 05 Jan 2010 19:27:17 -0800

Yes, there are lots of unmodified fixed terminals, windows 2K, vista, XP and
many others. I assume, some one will supply a PNAT stack for all these OS
and their legacy version variants.

Sri

---

From: "Hui Deng" <[email-masked]>
Date: Wed, 6 Jan 2010 11:34:18 +0800

I am talking some fixed box, other than software
You want to supply 100,000 applications or you want to supply 5 Oss?

-Hui

> Sent: Wednesday, January 06, 2010 11:27 AM

---

From: Sri Gundavelli <[email-masked]>
Date: Tue, 05 Jan 2010 19:53:33 -0800

There are no 100'00 applications, that have a weird requirement of running
on a IPv6-only host stack, but unable to use a IPv6 socket. There may be 5
applications, you retire them or force them to add those 4 line changes to
use a IPv6 socket and use the available IPv6 transport, so we don't mess up
all the possible operating systems and the legacy versions.
 
Sri

---

From: <[email-masked]>
Date: Wed, 6 Jan 2010 17:40:16 +0100

I agree with Sri. The idea that you have in the near term millions of hosts
which are IPv6 only or there are these large number of applications that run
over v6 only is ludicrous at best.

-Raj

On 1/5/10 9:53 PM, "Sri Gundavelli" <[email-masked]> wrote:

> _______________________________________________
> 3gv6 mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/3gv6