Subject: Re: [3gv6] Demonstration

From: Cameron Byrne <[email-masked]>
Date: Wed, 24 Feb 2010 08:42:32 -0800

On Wed, Feb 24, 2010 at 8:09 AM, David Crowe
<[email-masked]> wrote:
> The video shows "Your IP Address is: 97.65.105.26"
>
> Isn't this an IPv4 address?
>

Correct that is an IPv4 address

> Are you simply demonstrating that the UE is given a public IP address
> temporarily, along with a port number? But isn't that the same as for
> standard IPv4 NAT?
>

Please note item #3 in the video walk through in the original email.
I am demonstrating that IPv4-only servers view this UE via a NAT64
server.  The solution i am pursuing is IPv6-only on the UE with NAT64
to enable access to IPv4 content.  Step #3 shows how this is realized
from the IPv4-only legacy content perspective.  In this solution and
during the video, the UE is never assigned an IPv4 address and never
invokes an IPv4 PDP.

> - David Crowe
>
>
>> Hi Cameron
>>
>> You are planning to show this demonstration in the coming workshop
>> based on Android phone?
>>
>> thanks
>>
>> -Hui
>>
>> 2010/2/24 Cameron Byrne <[email-masked]>:
>>>
>>>  Folks,
>>>
>>>  Today for the first time i used the production national RAN network to
>>>  access an IPv6 PDP context on a lab GGSN.
>>>
>>>  The significance of this is that now, any where my network has RF
>>>  coverage (200+ million people in the USA), we can have native IPv6
>>>  connections -- today.  This is a primitive beta service that does not
>>>  have all the billing and other properties worked out yet, but folks
>>>  said build it (an IPv6 network)  and they (handsets, applications)
>>>  will come.  We built it, pretty easy actually.  Now we start the long
>>>  road to integrating provisioning, backend systems, ops training ...
>>>
>>>  Here is a blurry and low-quality video of the IPv6-only UE user
>>>  experience on the production network using today's software and
>>>  hardware in the RAN, Packet Core, and UE.  The UE is IPv6-only and has
>>>  the assistance of network-based DNS64 / NAT64 to access IPv4 content.
>>>  The UE does not have an IPv4 address or IPv4 PDP.
>>>
>>  > http://www.youtube.com/watch?v=SFAZFGKIigk
>>>
>>>  A quick walk through of the video
>>>
>>>  1. Start with www.kame.net, native v6 content.
>>>  2. mobile.nytimes.com, which is IPv4 content via the NAT64 / DNS64
>>>  3. whatsmyip, to show NAT64 public side IPv4 address that the IPv4
>>> content sees

Note this step.

>>>  4.  more ipv4 content at washington post
>>>  5.  comcast6.net, which shows my IPv6 address.  This is the IPv6
>>>  address of the UE [sorry it's blurry]
>>>  6.  more IPv4 content at yahoo mobile
>>>  7.  the facebook application, viewing photos.
>>>  8.  access an IPv4 IMAP (tcp 993) email account at GMX.com, and send an
>>> email.
>>>  9.  Google maps.  I did a previous search for coffee shops, and then
>>>  it also shows panning for map updates.
>>>
>>>  The T-Mobile representatives at the 3GPP-IETF conference in San
>>>  Francisco will have this phone and it will work anywhere there is
>>>  T-Mobile USA coverage as IPv6-only.
>>>
>>>  In a few months, I plan to launch an official beta "friendly user
>>>  trial" so that handset and application developers can attach to
>>>  T-Mobile's beta IPv6 APN to develop and innovate in an IPv6-only
>>>  environment.  I will post more details about that as we get closer to
>>>  launch.
>>>
>>>  Regards,
>>>  Cameron
>>>  _______________________________________________
>>>  3gv6 mailing list
>>>  [email-masked]
>>>  https://www.ietf.org/mailman/listinfo/3gv6
>>>
>
>

---

From: David Crowe <[email-masked]>
Date: Wed, 24 Feb 2010 11:48:10 -0700

Cameron;

I understand. There is no IPv4 address in the access network, it is 
assigned (along with a port) by the NAT64 on a dynamic basis, and is 
unknown to the UE (at least not without considerable effort).

Is there no IPv6 server that can echo back your IPv6 address? That 
would be a useful testing and demonstration tool.

- David Crowe

At 8:42 AM -0800 2/24/10, Cameron Byrne wrote:
>>>   > http://www.youtube.com/watch?v=SFAZFGKIigk
>>>>

---

From: "Laganier, Julien" <[email-masked]>
Date: Wed, 24 Feb 2010 11:36:31 -0800

How about http://www.whatismyipv6.net/

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 24 Feb 2010 12:04:03 -0800

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On 
> Behalf Of David Crowe
> Sent: Wednesday, February 24, 2010 10:48 AM
> To: Cameron Byrne
> Cc: [email-masked]
> Subject: Re: [3gv6] Demonstration
> 
> Cameron;
> 

Cameron did that at 1:39 into the video, visiting www.comcast6.net 
(step 5, below).  It's blurry -- I guess we should chip in for one 
of those autofocusing webcams.  :-)

-d

---

From: Cameron Byrne <[email-masked]>
Date: Wed, 24 Feb 2010 12:29:56 -0800

> of those autofocusing webcams.  :-)

That correct.  I did outline that as step #5 in the original email.
If it's important to you, I can try and again and zoom into see the
IPv6 address.  Or you can trust me ... or trust the dancing turtle
from step #1 :)

Let me know, i really want to make this demonstration as transparent
as possible.

---

From: "Dan Wing" <[email-masked]>
Date: Wed, 24 Feb 2010 12:33:35 -0800

> From: Cameron Byrne [mailto:[email-masked]] 
> Sent: Wednesday, February 24, 2010 12:30 PM
> To: Dan Wing
> Cc: David Crowe; [email-masked]

http://www.whatismyipv6.net has really big text.

-d

---

From: Cameron Byrne <[email-masked]>
Date: Wed, 24 Feb 2010 13:39:55 -0800

> http://www.whatismyipv6.net has really big text.

Will take that as a hint that you would like to see it.

Steps I took:

1.  On IPv6-only UE, download and install screen capture app from Ovi app store.
2.  Go to www.whatismyipv6.net
3.  Take screen capture
4.  Using IPv6-only UE, email IPv4 desktop the image
5.  Post image to website
http://sites.google.com/site/tmoipv6/screenshot/Scr000001.jpg

Let me know any other request.  Also, Gary Jones will have this
handset in San Francisco 3GPP tomorrow and next week.

---

From: David Crowe <[email-masked]>
Date: Wed, 24 Feb 2010 14:59:32 -0700

Dan, Cameron etc;

I'm going to blame my aging eyes. An autofocusing webcam sounds like 
a great idea!

- David

---

From: David Crowe <[email-masked]>
Date: Wed, 24 Feb 2010 15:01:10 -0700

Cameron;

Now that is very nice! Even I can see that, and no problem with focus either :)

- David

---

From: David Crowe <[email-masked]>
Date: Thu, 25 Feb 2010 09:00:00 -0700

Thanks, hopefully the next video will have this.

Unfortunately my ISP doesn't seem to support IPv6 so I can't try this 
out even from my wired (DSL) connection.

- David Crowe