Subject: [5gangip] 5G and Slicing

From: AshwoodsmithPeter <[email-masked]>
Date: Mon, 19 Oct 2015 18:39:48 +0000

Greetings, just noticed the creation of this mailing list, not sure how much discussion has already occurred but thought I would mention a couple of points briefly.

1 - the concept of network slicing for 5G (the end to end ability to create multiple logical 5G networks from a physical infrastructure) most likely is relevant to all the different VPN technologies standardized at the IETF.

2- This could include GMPLS/WSON related TDM/DWDM to chop up the optical/TDM layer, IP VPN's and all their flavors including VxLan etc. to slice at the packet layer and SDN/NFV for slicing of resources in the DC.

3-V6 and mobility within a slice for packet core behaviors.

4-new 'non ip' protocols like ICN within a slice for new applications with different RAT's.

Cheers,

Peter

---

From: <[email-masked]>
Date: Tue, 20 Oct 2015 17:46:25 +0200

Dear Peter,
Thanks for pointing there. I agree with most ideas, especially that slicing is one of the major new issues in 5G - that may also refer to WG TEAS (Traffic Engineering Architecture and Signaling) and the concepts discussed there, especially with respect to drafts on ACTN (Abstraction and Control of TE Networks).
With respect to your 4th comment on 'non-ip ICN' (here: Information-Centric Networking?) my question would be:
- Do you mean non-IETF since ICNRG is an IRTF group (with drafts on IP isssues such as https://tools.ietf.org/html/draft-irtf-icnrg-challenges-02)?
- Or do you rather suggest to discuss also below-L3 naming issues for multi-path or heterogeneous RAN control?
My feeling is that the latter item would be slightly out of scope in an IP-related discussion, let alone that cross layer information from L2 could assist L3 decisions in finding best IP addresses for routing paths etc. ...
Or did I misunderstand you?
Thanks and Best Regards
Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of AshwoodsmithPeter
Sent: Montag, 19. Oktober 2015 20:40
To: [email-masked]
Subject: [5gangip] 5G and Slicing

Cheers,

Peter

---

From: AshwoodsmithPeter <[email-masked]>
Date: Tue, 20 Oct 2015 19:03:51 +0000

Hey Dirk,

In my mind a "slice" consists of an end to end set of sub-slices. Where a sub-slice is what you get when you virtualize one of the following:

UE
UE Os/processes
UE Antennas
Antennas
Time/Frequency
mmWave or uWave fronthaul
DWDM fronthaul
TDM fronthaul
Packet fronthaul
DC fabric
DC servers
Server VM's
Server Containers
Server bare metal
Server acceleration hardware
Inter DC packet transport
Inter DC optical transport

In other words a slice has some subset of the UE, some subset of the spectrum, of the fronthaul, of the CRAN fabric etc. and is a 5G network in its own right. In fact a slice could run a 4G network end to end or even a 3G network end to end or even multiples of them using different bands I suppose.

The method of virtualizing each of the above is different but clearly ACTN/GMPLS etc would cover DWDM/TDM fronthaul and inter C-RAN optical transport virtualization while traditional MPLS-TE/SR covers packet fronthaul/backhaul/inter C-RAN virtualization. Vxlan covers DC fabric virtualization etc. Of course the various L2/L3VPN technologies all can provide virtualization depending on the network architecture chosen and the degree of isolation desired among the slices at the packet layer.

My point 4 - is aimed at what could you do within a slice that is not IPV6 or IPv4 based. It would seem to me that one possible candidate is Information Centric Networking which "could" run in its own slice without disturbing any of the IP based operations in other slices. By doing so it can also have its own Radio Access Technology possibly better suited to low power devices, i.e. one that does not require signaling to reserve radio resources.

So the way I see it the IETF/IRTF have three first areas of interest to 5G and slicing.

Virtualization technologies ( that they are already doing) for different network technologies in the end to end slice.
Applications that can run within a slice that are perhaps better suited to problem XXX.
Technologies that can be used to improve IP mobility and therefore useful within a 5G slice running IPV6.

Cheers,

Peter

From: [email-masked] [mailto:[email-masked]]
Sent: Tuesday, October 20, 2015 11:46 AM
To: AshwoodsmithPeter; [email-masked]
Subject: RE: 5G and Slicing

Dear Peter,

From: 5gangip [mailto:[email-masked]] On Behalf Of AshwoodsmithPeter
Sent: Montag, 19. Oktober 2015 20:40
To: [email-masked]<mailto:[email-masked]>
Subject: [5gangip] 5G and Slicing

Cheers,

Peter

---

From: <[email-masked]>
Date: Mon, 26 Oct 2015 14:03:43 +0100

Dear Peter,
I very much agree with what you detailed below - thanks a lot for that. Presuming that your list was not meant to be exhaustive, I would just add (still not achieving thus completeness) inline below as denoted by Dh>:
What do you think?

Thanks and Best Regards
Dirk

From: AshwoodsmithPeter [mailto:[email-masked]]
Sent: Dienstag, 20. Oktober 2015 21:04
To: von Hugo, Dirk; [email-masked]
Subject: RE: 5G and Slicing

Hey Dirk,

UE
UE Os/processes
UE Antennas
Antennas

Dh> here I would add: antenna elements (as in massive MIMO)

Time/Frequency

Dh> here I would add: / code

Dh> I would replace IP mobility by more general IP connectivity including: mobility, (multi-(routing)) path selection, ...

Cheers,

Peter

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, October 20, 2015 11:46 AM
To: AshwoodsmithPeter; [email-masked]<mailto:[email-masked]>
Subject: RE: 5G and Slicing

Dear Peter,

Cheers,

Peter

---

From: Dirk Kutscher <[email-masked]>
Date: Mon, 26 Oct 2015 14:28:04 +0000

Dear all,

good discussion, and I agree to what has been said so far.

A comprehensive virtualization and programmability approach in 5G could enable new, more adequate technologies for accessing named data, in-network storage and object-level security.

Such an ICN layer could then again used for different service slices, for example IoT, real-time multimedia, web access.

One interesting question would be what assumptions should be made on the underlay and its service model. In other words: what would be the common denominator for forwarding abstractions.

Is that just L2 connectivity? Is it IPv6 as a pseudo L2?

It would be great if the underlay would not get into the way of ICN multipath and broadcast communication capabilities, i.e., it should at least be possible to run over virtualized link layers in the access.

BTW, there is a workshop at Waseda University on the Friday  before the IETF (i.e., this week) with a panel discussion that will touch upon some of those questions:
http://jp.greenicn.org/workshop.html

Best regards,
Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Montag, 26. Oktober 2015 14:04
To: [email-masked]; [email-masked]
Subject: Re: [5gangip] 5G and Slicing

Dear Peter,

Thanks and Best Regards
Dirk

From: AshwoodsmithPeter [mailto:[email-masked]]
Sent: Dienstag, 20. Oktober 2015 21:04
To: von Hugo, Dirk; [email-masked]<mailto:[email-masked]>
Subject: RE: 5G and Slicing

Hey Dirk,

UE
UE Os/processes
UE Antennas
Antennas

Time/Frequency

Cheers,

Peter

Dear Peter,

Cheers,

Peter

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 26 Oct 2015 13:49:51 -0500

Hi Dirk,

On Mon, Oct 26, 2015 at 9:28 AM, Dirk Kutscher <[email-masked]> wrote:
> A comprehensive virtualization and programmability approach in 5G could
> enable new, more adequate technologies for accessing named data, in-network
> storage and object-level security.
>
>
>
> Such an ICN layer could then again used for different service slices, for
> example IoT, real-time multimedia, web access.
>
>
>
> One interesting question would be what assumptions should be made on the
> underlay and its service model. In other words: what would be the common
> denominator for forwarding abstractions.
>
>
>
> It would be great if the underlay would not get into the way of ICN
> multipath and broadcast communication capabilities, i.e., it should at least
> be possible to run over virtualized link layers in the access.
>
>
>
> BTW, there is a workshop at Waseda University on the Friday  before the IETF
> (i.e., this week) with a panel discussion that will touch upon some of those
> questions:
>

Since you are giving a talk in this workshop, can you please invite
the attendees to subscribe to 5G IP list?

Regards,

Behcet
> I very much agree with what you detailed below – thanks a lot for that.
> Presuming that your list was not meant to be exhaustive, I would just add
> (still not achieving thus completeness) inline below as denoted by Dh>:
>
> What do you think?
>
>
>
> Thanks and Best Regards
> Dirk
>
>
>
> In my mind a “slice” consists of an end to end set of sub-slices. Where a
> sub-slice is what you get when you virtualize one of the following:
>
>
>
> UE
>
> UE Os/processes
>
> UE Antennas
>
> Antennas
>
>
>
> Server VM’s
> In other words a slice has some subset of the UE, some subset of the
> spectrum, of the fronthaul, of the CRAN fabric etc. and is a 5G network in
> its own right. In fact a slice could run a 4G network end to end or even a
> 3G network end to end or even multiples of them using different bands I
> suppose.
>
>
>
> The method of virtualizing each of the above is different but clearly
> ACTN/GMPLS etc would cover DWDM/TDM fronthaul and inter C-RAN optical
> transport virtualization while traditional MPLS-TE/SR covers packet
> fronthaul/backhaul/inter C-RAN virtualization. Vxlan covers DC fabric
> virtualization etc. Of course the various L2/L3VPN technologies all can
> provide virtualization depending on the network architecture chosen and the
> degree of isolation desired among the slices at the packet layer.
>
>
>
> My point 4 – is aimed at what could you do within a slice that is not IPV6
> or IPv4 based. It would seem to me that one possible candidate is
> Information Centric Networking which “could” run in its own slice without
> disturbing any of the IP based operations in other slices. By doing so it
> can also have its own Radio Access Technology possibly better suited to low
> power devices, i.e. one that does not require signaling to reserve radio
> resources.
>
>
>
> Virtualization technologies ( that they are already doing) for different
> network technologies in the end to end slice.
>
> Dh> I would replace IP mobility by more general IP connectivity including:
> mobility, (multi-(routing)) path selection, …
>
>
>
> Cheers,
>
>
>
> Peter
>
>
>
> Thanks for pointing there. I agree with most ideas, especially that slicing
> is one of the major new issues in 5G – that may also refer to WG TEAS
> (Traffic Engineering Architecture and Signaling) and the concepts discussed
> there, especially with respect to drafts on ACTN (Abstraction and Control of
> TE Networks).
>
> With respect to your 4th comment on ‘non-ip ICN’ (here: Information-Centric
> Networking?) my question would be:
>
> - Do you mean non-IETF since ICNRG is an IRTF group (with drafts on IP
> isssues such as https://tools.ietf.org/html/draft-irtf-icnrg-challenges-02)?
>
> My feeling is that the latter item would be slightly out of scope in an
> IP-related discussion, let alone that cross layer information from L2 could
> assist L3 decisions in finding best IP addresses for routing paths etc. …
>
> Greetings, just noticed the creation of this mailing list, not sure how much
> discussion has already occurred but thought I would mention a couple of
> points briefly.
>
>
>
> 1 – the concept of network slicing for 5G (the end to end ability to create
> multiple logical 5G networks from a physical infrastructure) most likely is
> relevant to all the different VPN technologies standardized at the IETF.
>
>
>
> 2- This could include GMPLS/WSON related TDM/DWDM to chop up the optical/TDM
> layer, IP VPN’s and all their flavors including VxLan etc. to slice at the
> packet layer and SDN/NFV for slicing of resources in the DC.
>
>
>
> 4-new ‘non ip’ protocols like ICN within a slice for new applications with
> different RAT’s.
>
>
>
> Cheers,
>
>
>
> Peter
>
>
>
>
>
>
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>

---

From: <[email-masked]>
Date: Thu, 29 Oct 2015 17:17:34 +0100

Dear all 5G enthusiasts,
We would like to have a short Bar BOF (e.g. side meeting at breakfast time) next week ... Behcet will be in Yokohama and announce the logistics so that all who are available could contribute their ideas for further activities here. 
Thanks!

Best Regards
Dirk 

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Montag, 26. Oktober 2015 19:50
To: Dirk Kutscher
Cc: [email-masked]; [email-masked]; von Hugo, Dirk
Subject: Re: [5gangip] 5G and Slicing

Hi Dirk,

On Mon, Oct 26, 2015 at 9:28 AM, Dirk Kutscher <[email-masked]> wrote:
> A comprehensive virtualization and programmability approach in 5G 
> could enable new, more adequate technologies for accessing named data, 
> in-network storage and object-level security.
>
>
>
> Such an ICN layer could then again used for different service slices, 
> for example IoT, real-time multimedia, web access.
>
>
>
> One interesting question would be what assumptions should be made on 
> the underlay and its service model. In other words: what would be the 
> common denominator for forwarding abstractions.
>
>
>
> multipath and broadcast communication capabilities, i.e., it should at 
> least be possible to run over virtualized link layers in the access.
>
>
>
> BTW, there is a workshop at Waseda University on the Friday  before 
> the IETF (i.e., this week) with a panel discussion that will touch 
> upon some of those
> questions:
>

Since you are giving a talk in this workshop, can you please invite the attendees to subscribe to 5G IP list?

Regards,

Behcet
> Presuming that your list was not meant to be exhaustive, I would just 
> add (still not achieving thus completeness) inline below as denoted by Dh>:
>
> What do you think?
>
>
>
> Thanks and Best Regards
> Dirk
>
>
>
> In my mind a “slice” consists of an end to end set of sub-slices. 
> Where a sub-slice is what you get when you virtualize one of the following:
>
>
>
> UE
>
> UE Os/processes
>
> UE Antennas
>
> Antennas
>
>
>
> spectrum, of the fronthaul, of the CRAN fabric etc. and is a 5G 
> network in its own right. In fact a slice could run a 4G network end 
> to end or even a 3G network end to end or even multiples of them using 
> different bands I suppose.
>
>
>
> virtualization etc. Of course the various L2/L3VPN technologies all 
> can provide virtualization depending on the network architecture 
> chosen and the degree of isolation desired among the slices at the packet layer.
>
>
>
> My point 4 – is aimed at what could you do within a slice that is not 
> IPV6 or IPv4 based. It would seem to me that one possible candidate is 
> Information Centric Networking which “could” run in its own slice 
> without disturbing any of the IP based operations in other slices. By 
> doing so it can also have its own Radio Access Technology possibly 
> better suited to low power devices, i.e. one that does not require 
> signaling to reserve radio resources.
>
>
>
> Virtualization technologies ( that they are already doing) for 
> different network technologies in the end to end slice.
>
> Thanks for pointing there. I agree with most ideas, especially that 
> slicing is one of the major new issues in 5G – that may also refer to 
> WG TEAS (Traffic Engineering Architecture and Signaling) and the 
> concepts discussed there, especially with respect to drafts on ACTN 
> (Abstraction and Control of TE Networks).
>
> My feeling is that the latter item would be slightly out of scope in 
> an IP-related discussion, let alone that cross layer information from 
> L2 could assist L3 decisions in finding best IP addresses for routing 
> paths etc. …
>
> Greetings, just noticed the creation of this mailing list, not sure 
> how much discussion has already occurred but thought I would mention a 
> couple of points briefly.
>
>
>
> 1 – the concept of network slicing for 5G (the end to end ability to 
> create multiple logical 5G networks from a physical infrastructure) 
> most likely is relevant to all the different VPN technologies standardized at the IETF.
>
>
>
> 2- This could include GMPLS/WSON related TDM/DWDM to chop up the 
> optical/TDM layer, IP VPN’s and all their flavors including VxLan etc. 
> to slice at the packet layer and SDN/NFV for slicing of resources in the DC.
>
>
>
> 4-new ‘non ip’ protocols like ICN within a slice for new applications 
> with different RAT’s.
>
>
>
> Cheers,
>
>
>
> Peter
>
>
>
>
>
>

---

From: PEDRO ANDRES ARANDA GUTIERREZ <[email-masked]>
Date: Fri, 30 Oct 2015 03:36:21 +0000

Count on me :-)
---
Dr. Pedro A. Aranda Gutiérrez

Technology Exploration -
Network Innovation & Virtualisation
email: pedroa d0t aranda At telefonica d0t com
Telefónica, Investigación y Desarrollo
C/ Zurbarán,12
28010 Madrid, Spain

Fragen sind nicht da, um beantwortet zu werden.
Fragen sind da, um gestellt zu werden.
Georg Kreisler

-----Mensaje original-----
De: 5gangip <[email-masked]> en nombre de "[email-masked]" <[email-masked]>
Fecha: jueves, 29 de octubre de 2015, 17:17
Para: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
CC: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Asunto: Re: [5gangip] 5G and Slicing

>> 4-new ‘non ip’ protocols like ICN within a slice for new applications

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: Frank Fitzek <[email-masked]>
Date: Fri, 30 Oct 2015 12:41:49 +0100

Dear all,

we from 5G Lab Gemrany would like to particpate if there is A/V support. 
IF not this time, next time.
Greetings to the 5G family
FF

http://5glab.de/

-- 
Frank Fitzek
Professor
Chair of Communication Networks
Institute of Communication Technology
TU Dresden

phone:  +49 351 463 33945
fax:    +49 351 463 37163
mobile: +49 173 548 2947
web:    www.fitzek.net
skype:	fitzek

5G Lab Germany Coordinator 5Glab.de
CFAED Resilience Path Leader
HAEC Architecture Group Co-leader

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 31 Oct 2015 08:22:39 +0000

IMHO, a host-based id/locator separation protocol may be a very promising way to address the mobility management (MM) requirements of 5G networks, especially the ultra-low-latency requirement, since it would eliminate mobility anchors completely. Of course, it means a big Internet architecture transition. However, as two-thirds of the Internet traffic would originate with mobile devices by 2020 and smart mobility devices such as smart-phones would been more widely used by 2020, it seems reasonable for us to design a mobility-centric Internet architecture from now on.

Best regards,

Xiaohu

Cheers,

Peter

Dear Peter,

Cheers,

Peter