Subject: Re: [5gangip] 5G and Slicing

From: "Haeffner, Walter, Vodafone DE" <[email-masked]>
Date: Sun, 1 Nov 2015 12:46:22 +0000

Hi Xiaohu,

Not clear to me what you have in mind. Do you think of a LISP (like) mechanism instead of GTP?

Do you think about alternatives to 3GPP?

Wrt ultra-low latencies a mobility use case would be autonomous cars. OK?

How you like to ensure ultra-fast switch-over to another cell in case of 1ms apps?

There are currently "cloudlets" on the way, that is edge clouds (at radio or BBU) supporting moving VMs which support an application moving with a user terminal. Currently becomes a part of Openstack. Driver is Satya, Carnegie Mellon University. Huawei, Vodafone are part of the project.

Fully agree with your mobility-centric Internet architecture remark.

Cheers,
Walter

Von: 5gangip [mailto:[email-masked]] Im Auftrag von Xuxiaohu
Gesendet: Samstag, 31. Oktober 2015 09:23
An: [email-masked]; AshwoodsmithPeter; [email-masked]
Betreff: Re: [5gangip] 5G and Slicing

Technologies that can be used to improve IP mobility and therefore useful within a 5G slice running IPV6.

Dh> I would replace IP mobility by more general IP connectivity including: mobility, (multi-(routing)) path selection, ...

IMHO, a host-based id/locator separation protocol may be a very promising way to address the mobility management (MM) requirements of 5G networks, especially the ultra-low-latency requirement, since it would eliminate mobility anchors completely. Of course, it means a big Internet architecture transition. However, as two-thirds of the Internet traffic would originate with mobile devices by 2020 and smart mobility devices such as smart-phones would been more widely used by 2020, it seems reasonable for us to design a mobility-centric Internet architecture from now on.

Best regards,

Xiaohu

Cheers,

Peter

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Tuesday, October 20, 2015 11:46 AM
To: AshwoodsmithPeter; [email-masked]<mailto:[email-masked]>
Subject: RE: 5G and Slicing

Dear Peter,
Thanks for pointing there. I agree with most ideas, especially that slicing is one of the major new issues in 5G - that may also refer to WG TEAS (Traffic Engineering Architecture and Signaling) and the concepts discussed there, especially with respect to drafts on ACTN (Abstraction and Control of TE Networks).
With respect to your 4th comment on 'non-ip ICN' (here: Information-Centric Networking?) my question would be:
- Do you mean non-IETF since ICNRG is an IRTF group (with drafts on IP isssues such as https://tools.ietf.org/html/draft-irtf-icnrg-challenges-02)?
- Or do you rather suggest to discuss also below-L3 naming issues for multi-path or heterogeneous RAN control?
My feeling is that the latter item would be slightly out of scope in an IP-related discussion, let alone that cross layer information from L2 could assist L3 decisions in finding best IP addresses for routing paths etc. ...
Or did I misunderstand you?
Thanks and Best Regards
Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of AshwoodsmithPeter
Sent: Montag, 19. Oktober 2015 20:40
To: [email-masked]<mailto:[email-masked]>
Subject: [5gangip] 5G and Slicing

Greetings, just noticed the creation of this mailing list, not sure how much discussion has already occurred but thought I would mention a couple of points briefly.

1 - the concept of network slicing for 5G (the end to end ability to create multiple logical 5G networks from a physical infrastructure) most likely is relevant to all the different VPN technologies standardized at the IETF.

2- This could include GMPLS/WSON related TDM/DWDM to chop up the optical/TDM layer, IP VPN's and all their flavors including VxLan etc. to slice at the packet layer and SDN/NFV for slicing of resources in the DC.

3-V6 and mobility within a slice for packet core behaviors.

4-new 'non ip' protocols like ICN within a slice for new applications with different RAT's.

Cheers,

Peter

---

From: Xuxiaohu <[email-masked]>
Date: Mon, 2 Nov 2015 01:33:25 +0000

Hi Walter,

Please see my response inline.

________________________________
发件人: Haeffner, Walter, Vodafone DE [[email-masked]]
发送时间: 2015年11月1日 20:46
收件人: Xuxiaohu; [email-masked]; AshwoodsmithPeter; [email-masked]
主题: AW: 5G and Slicing

Hi Xiaohu,

[Xiaohu] Yes. a LISP-like mechanism where xTR functionality is implemented on hosts rather than border routers. Maybe HIP is a more proper example.

[Xiaohu] Not an alternative to 3GPP. Insteads, I think it may be worthwhile to be adopted as an optional mobility management mechanism for 3GPP especially for those low-latency communication scenarios.

[Xiaohu] Car-2-Car is just one use case.

[Xiaohu] In my mind, it's better to decouple the wireless Internet access management service from the mobility managment service completely in the id/locator separation-based mobile Internet architecture. The wireless Internet access management service could be provided by any WiFi network operator and any celluar network operator. Since there is no need for them to offer wide-area mobility service anymore (i.e., they only need to allocate locators to those mobile devices on which some id/locator separation protocol is enabled), the AC or EPC functionality which allocates IP addresses (i.e., locators in this case) to mobile devices could be move to  users as close as possible. In contrast, mobility managment service could be provided by those entities who may not have any wireless network assets. To some extent, the business model of mobility managment service looks a bit similar with that of the DNS.

Best regards,
Xiaohu

There are currently “cloudlets” on the way, that is edge clouds (at radio or BBU) supporting moving VMs which support an application moving with a user terminal. Currently becomes a part of Openstack. Driver is Satya, Carnegie Mellon University. Huawei, Vodafone are part of the project.

Cheers,
Walter

Dh> I would replace IP mobility by more general IP connectivity including: mobility, (multi-(routing)) path selection, …

Best regards,

Xiaohu

Cheers,

Peter

Dear Peter,
Thanks for pointing there. I agree with most ideas, especially that slicing is one of the major new issues in 5G – that may also refer to WG TEAS (Traffic Engineering Architecture and Signaling) and the concepts discussed there, especially with respect to drafts on ACTN (Abstraction and Control of TE Networks).
With respect to your 4th comment on ‘non-ip ICN’ (here: Information-Centric Networking?) my question would be:
- Do you mean non-IETF since ICNRG is an IRTF group (with drafts on IP isssues such as https://tools.ietf.org/html/draft-irtf-icnrg-challenges-02)?
- Or do you rather suggest to discuss also below-L3 naming issues for multi-path or heterogeneous RAN control?
My feeling is that the latter item would be slightly out of scope in an IP-related discussion, let alone that cross layer information from L2 could assist L3 decisions in finding best IP addresses for routing paths etc. …
Or did I misunderstand you?
Thanks and Best Regards
Dirk

1 – the concept of network slicing for 5G (the end to end ability to create multiple logical 5G networks from a physical infrastructure) most likely is relevant to all the different VPN technologies standardized at the IETF.

2- This could include GMPLS/WSON related TDM/DWDM to chop up the optical/TDM layer, IP VPN’s and all their flavors including VxLan etc. to slice at the packet layer and SDN/NFV for slicing of resources in the DC.

4-new ‘non ip’ protocols like ICN within a slice for new applications with different RAT’s.

Cheers,

Peter

---

From: AshwoodsmithPeter <[email-masked]>
Date: Mon, 2 Nov 2015 20:51:47 +0000

Unfortunately I can't be in Japan, however I'm very interested in future work in this area and in fact am doing some work on behalf of the ITU to try to nail down some of the future requirements. Please add a +1 from me for any informal votes on upcoming BOF's on the subject.

Cheers

Peter

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Thursday, October 29, 2015 12:18 PM
To: [email-masked]; [email-masked]
Cc: [email-masked]; AshwoodsmithPeter
Subject: RE: [5gangip] 5G and Slicing

Dear all 5G enthusiasts,
We would like to have a short Bar BOF (e.g. side meeting at breakfast time) next week ... Behcet will be in Yokohama and announce the logistics so that all who are available could contribute their ideas for further activities here. 
Thanks!

Best Regards
Dirk 

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Montag, 26. Oktober 2015 19:50
To: Dirk Kutscher
Cc: [email-masked]; [email-masked]; von Hugo, Dirk
Subject: Re: [5gangip] 5G and Slicing

Hi Dirk,

On Mon, Oct 26, 2015 at 9:28 AM, Dirk Kutscher <[email-masked]> wrote:
> Dear all,
>
>
>
> good discussion, and I agree to what has been said so far.
>
>
>
> A comprehensive virtualization and programmability approach in 5G 
> could enable new, more adequate technologies for accessing named data, 
> in-network storage and object-level security.
>
>
>
> Such an ICN layer could then again used for different service slices, 
> for example IoT, real-time multimedia, web access.
>
>
>
> One interesting question would be what assumptions should be made on 
> the underlay and its service model. In other words: what would be the 
> common denominator for forwarding abstractions.
>
>
>
> Is that just L2 connectivity? Is it IPv6 as a pseudo L2?
>
>
>
> It would be great if the underlay would not get into the way of ICN 
> multipath and broadcast communication capabilities, i.e., it should at 
> least be possible to run over virtualized link layers in the access.
>
>
>
> BTW, there is a workshop at Waseda University on the Friday  before 
> the IETF (i.e., this week) with a panel discussion that will touch 
> upon some of those
> questions:
>
> http://jp.greenicn.org/workshop.html
>

Since you are giving a talk in this workshop, can you please invite the attendees to subscribe to 5G IP list?

Regards,

Behcet
>
>
> Best regards,
>
> Dirk
>
>
>
>
>
> From: 5gangip [mailto:[email-masked]] On Behalf Of 
> [email-masked]
> Sent: Montag, 26. Oktober 2015 14:04
> To: [email-masked]; [email-masked]
> Subject: Re: [5gangip] 5G and Slicing
>
>
>
> Dear Peter,
>
> I very much agree with what you detailed below – thanks a lot for that.
> Presuming that your list was not meant to be exhaustive, I would just 
> add (still not achieving thus completeness) inline below as denoted by Dh>:
>
> What do you think?
>
>
>
> Thanks and Best Regards
> Dirk
>
>
>
> From: AshwoodsmithPeter [mailto:[email-masked]]
> Sent: Dienstag, 20. Oktober 2015 21:04
> To: von Hugo, Dirk; [email-masked]
> Hey Dirk,
> In my mind a “slice” consists of an end to end set of sub-slices. 
> Where a sub-slice is what you get when you virtualize one of the following:
>
>
>
> UE
>
> UE Os/processes
>
> UE Antennas
>
> Antennas
>
>
>
> Dh> here I would add: antenna elements (as in massive MIMO)
>
>
>
> Time/Frequency
>
>
>
> Dh> here I would add: / code
>
>
>
> mmWave or uWave fronthaul
>
> DWDM fronthaul
>
> TDM fronthaul
>
> Packet fronthaul
>
> DC fabric
>
> DC servers
>
> Server VM’s
>
> Server Containers
>
> Server bare metal
>
> Server acceleration hardware
>
> Inter DC packet transport
>
> Inter DC optical transport
>
>
>
> In other words a slice has some subset of the UE, some subset of the 
> spectrum, of the fronthaul, of the CRAN fabric etc. and is a 5G 
> network in its own right. In fact a slice could run a 4G network end 
> to end or even a 3G network end to end or even multiples of them using 
> different bands I suppose.
>
>
>
> The method of virtualizing each of the above is different but clearly 
> ACTN/GMPLS etc would cover DWDM/TDM fronthaul and inter C-RAN optical 
> transport virtualization while traditional MPLS-TE/SR covers packet 
> fronthaul/backhaul/inter C-RAN virtualization. Vxlan covers DC fabric 
> virtualization etc. Of course the various L2/L3VPN technologies all 
> can provide virtualization depending on the network architecture 
> chosen and the degree of isolation desired among the slices at the packet layer.
>
>
>
> My point 4 – is aimed at what could you do within a slice that is not
> IPV6 or IPv4 based. It would seem to me that one possible candidate is 
> Information Centric Networking which “could” run in its own slice 
> without disturbing any of the IP based operations in other slices. By 
> doing so it can also have its own Radio Access Technology possibly 
> better suited to low power devices, i.e. one that does not require 
> signaling to reserve radio resources.
>
>
>
> So the way I see it the IETF/IRTF have three first areas of interest 
> to 5G and slicing.
>
>
>
> Virtualization technologies ( that they are already doing) for 
> different network technologies in the end to end slice.
>
> Applications that can run within a slice that are perhaps better 
> suited to problem XXX.
>
> Dh> I would replace IP mobility by more general IP connectivity including:
> mobility, (multi-(routing)) path selection, …
>
>
>
> Cheers,
>
>
>
> Peter
>
>
>
> From: [email-masked] [mailto:[email-masked]]
> To: AshwoodsmithPeter; [email-masked]
> Thanks for pointing there. I agree with most ideas, especially that 
> slicing is one of the major new issues in 5G – that may also refer to 
> WG TEAS (Traffic Engineering Architecture and Signaling) and the 
> concepts discussed there, especially with respect to drafts on ACTN 
> (Abstraction and Control of TE Networks).
>
> With respect to your 4th comment on ‘non-ip ICN’ (here: 
> Information-Centric
> Networking?) my question would be:
>
> - Do you mean non-IETF since ICNRG is an IRTF group (with drafts on IP 
> isssues such as https://tools.ietf.org/html/draft-irtf-icnrg-challenges-02)?
>
> My feeling is that the latter item would be slightly out of scope in 
> an IP-related discussion, let alone that cross layer information from
> L2 could assist L3 decisions in finding best IP addresses for routing 
> paths etc. …
>
> To: [email-masked]
> Greetings, just noticed the creation of this mailing list, not sure 
> how much discussion has already occurred but thought I would mention a 
> couple of points briefly.
>
>
>
> 1 – the concept of network slicing for 5G (the end to end ability to 
> create multiple logical 5G networks from a physical infrastructure) 
> most likely is relevant to all the different VPN technologies standardized at the IETF.
>
>
>
> 2- This could include GMPLS/WSON related TDM/DWDM to chop up the 
> optical/TDM layer, IP VPN’s and all their flavors including VxLan etc.
> to slice at the packet layer and SDN/NFV for slicing of resources in the DC.
>
>
>
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>

_______________________________________________
5gangip mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/5gangip

---

From: AshwoodsmithPeter <[email-masked]>
Date: Mon, 2 Nov 2015 21:15:03 +0000

There are numerous 5G goals. If you look at the ITU-R IMT.VISION document you can see some of them.

Protocols like LISP and ICN are potentially interesting in that they address shortcomings of the current 4G core. For example ICN addresses delay issues with distant content and reduces bandwidth in the fronthaul. LISP can address the congestion at mobility gateways issues.

Anyway I think there are a couple of levels involved here. First are  the slicing mechanisms. As I mentioned various VPN technologies for L4/l2/l1 are relevant. Likewise within a slice there are enhancements for mobility, content distribution etc. that are relevant.

I think it’s important to make this distinction otherwise it gets quite confusing. For example and limiting to a few examples each:

Above a Slice
- Slice control/hierarchy
- Slice data path isolation

Within a Slice
- Scaling up the mobility (i.e. distributed gateways or equivalent).
- Bandwidth optimizations, delay reductions (i.e. content distribution)
- Completely new signaling free cores for IOT etc.

Note that we are just in the process of finishing a first study on wireline gaps needed to address 5G requirements. It has quite a bit of information on ICN etc. done by members of the IRTF which could be interesting to those on this mailing list. The (very rough) document will be available next week.

Peter

From: Xuxiaohu
Sent: Sunday, November 01, 2015 8:33 PM
To: Haeffner, Walter, Vodafone DE; [email-masked]; AshwoodsmithPeter; [email-masked]
Subject: Re: 5G and Slicing

Hi Walter,

________________________________
发件人: Haeffner, Walter, Vodafone DE [[email-masked]]
发送时间: 2015年11月1日 20:46
收件人: Xuxiaohu; [email-masked]<mailto:[email-masked]>; AshwoodsmithPeter; [email-masked]<mailto:[email-masked]>
主题: AW: 5G and Slicing
Hi Xiaohu,

Best regards,
Xiaohu

Cheers,
Walter

Von: 5gangip [mailto:[email-masked]] Im Auftrag von Xuxiaohu
Gesendet: Samstag, 31. Oktober 2015 09:23
An: [email-masked]<mailto:[email-masked]>; AshwoodsmithPeter; [email-masked]<mailto:[email-masked]>
Betreff: Re: [5gangip] 5G and Slicing

Best regards,

Xiaohu

Cheers,

Peter

Dear Peter,

Cheers,

Peter

---

From: <[email-masked]>
Date: Tue, 10 Nov 2015 17:45:02 +0100

Dear all,
Most of the presentations from the announced workshop are meanwhile available from the site below (http://jp.greenicn.org/workshop.html)  
@Dirk: Do you know when/whether the remaining ones will be linked? 
Thanks a lot in advance!
Best Regards
Dirk 

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Montag, 26. Oktober 2015 19:50
To: Dirk Kutscher
Cc: [email-masked]; [email-masked]; von Hugo, Dirk
Subject: Re: [5gangip] 5G and Slicing

Hi Dirk,

Regards,

Behcet
> AshwoodsmithPeter