Subject: Re: [5gangip] tunnels (was Introducing: Brand-new Internet Protocol "Five Fields")

From: <[email-masked]>
Date: Wed, 16 Dec 2015 11:34:11 +0100

Hi Mikael,

>So, in my mind any 5G mobile network would be built on top of IPv6, but it might contain new transport/tunneling protocols to solve specific requirements. As Dino suggested, LISP or similar >protocols might be solutions for part of this problem space. I would like to avoid all traffic being tunneled if possible, and that we only tunnel the traffic that needs to be tunneled.

I agree that this might be a major discussion in 5G and the concept of network slicing - as pointed out by you and Dino.
Especially the idea: Only to use specific protocols (with all their overhead) where really needed ...

Would it come to a 'flow forwarding vs. tunneling'?

... thinking of e.g. scalability and security issues 

Best  regards
Dirk

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 16 Dec 2015 11:40:33 +0100 (CET)

> Would it come to a 'flow forwarding vs. tunneling'?

Having been exposed to flow based forwarding in the 90ties and seeing that 
fail horribly, as soon as someone says SDN and flow forwarding, I get 
curious how this is going to work on Internet scale (even in the access 
network). I have yet to see something that answers this question to my 
satisfaction.

Even having a /64 per device and moving that around poses substantial 
scalability issues in the access network.

-- 
Mikael Abrahamsson    email: [email-masked]