Subject: [5gangip] Hybrid UniMulticast Routing research : reasonable approach ?

From: Alexey Eromenko <[email-masked]>
Date: Mon, 18 Jan 2016 14:25:39 +0200

Rex Buddenberg, rightfully complained, that I don't offer any Multicast
innovation in my IP-FF protocol stack.

IP-FF is not just a copy-paste on existing TCP/IP ideas, but it is an
innovation attempt across all the Internet stack,
where I attempt to improve the Internet at various places, and see what
sticks.

After some Multicast research, I have came out with a very different
approach. Not even close to traditional Multicast.
Hybrid Unicast + Multicast routing, called UniMulticast Routing.

That is: if a destination is visible in Multicast Routing table, it is
routed using Multicast approach, but if it is not in routing table, then it
is routing using Unicast. This implies, that we need source address and two
(!) destination addresses in IP header:
Multicast group address as well as Unicast address. Group address can be
sent inside IP options.

This new approach requires some new protocols: namely IGMPv4, and Enhanced
PIM to work.

Here is my new research paper on this approach:
https://docs.google.com/document/d/1NbDEaItYCrVNgYwOsNF6cps7dCO_VgLzb9bWLxXu3b0/edit?usp=sharing

It is incomplete, but gives a rough idea on my approach.

Is this reasonable ?
-- 
-Alexey Eromenko "Technologov"

---

From: AshwoodsmithPeter <[email-masked]>
Date: Mon, 18 Jan 2016 14:50:41 +0000

Just a quick note on multicast and 5G etc.

It seems to me that the most important bandwidth to economize is the RF bandwidth (spectrum way more expensive than fiber). This means that any multicast method needs to map to multicast on the air interface otherwise its missing the most important savings, and god forbid it ended up implemented as serial unicast on the last hop (i.e. RF) it would be a pretty horrific use of the air interface and its precious spectrum.

I have made this same comment about ICN/CCNx and any potential use within a 5G slice. I.e. that ICN/CCNx multicast from the point where digital/packet to analog (RF) is done (eNODEB in LTE, perhaps CRAN in 5G) needs to map the ICN/CCNx multicast to a single analog transmission. This is of course quite tricky because you need to know what sectors, frequencies, time slots etc. a given UE subscribing to the multicast is using.

Peter

From: 5gangip [mailto:[email-masked]] On Behalf Of Alexey Eromenko
Sent: Monday, January 18, 2016 7:26 AM
To: [email-masked]
Subject: [5gangip] Hybrid UniMulticast Routing research : reasonable approach ?

Rex Buddenberg, rightfully complained, that I don't offer any Multicast innovation in my IP-FF protocol stack.

IP-FF is not just a copy-paste on existing TCP/IP ideas, but it is an innovation attempt across all the Internet stack,
where I attempt to improve the Internet at various places, and see what sticks.

After some Multicast research, I have came out with a very different approach. Not even close to traditional Multicast.
Hybrid Unicast + Multicast routing, called UniMulticast Routing.

That is: if a destination is visible in Multicast Routing table, it is routed using Multicast approach, but if it is not in routing table, then it is routing using Unicast. This implies, that we need source address and two (!) destination addresses in IP header:
Multicast group address as well as Unicast address. Group address can be sent inside IP options.

This new approach requires some new protocols: namely IGMPv4, and Enhanced PIM to work.

Is this reasonable ?