Subject: Re: [5gangip] Development of Internet Protocol "Five Fields" (IP-FF): new Presentation

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 4 Jan 2016 13:44:31 -0600

Hello Alexey,

Thank you for your post.
Looking at your list, I still don't see any multicast protocol.

Happy New Year to everyone on 5gangip!

Behcet

On Mon, Dec 28, 2015 at 12:39 PM, Alexey Eromenko <[email-masked]> wrote:
> Hello,
>
> In the meantime I have improved my protocol a lot, added details and new modules
> (TCP.64-bit, DHCPv5, new NAT, ...), and even made a nice presentation
> of IP-FF and it's features:
>
> https://docs.google.com/presentation/d/1XbqWOwv0GASmSjYZimfK64QKQQ-0yK9xQ1_spRhlf8Y/edit?usp=sharing
>
> It now consists of 10 parts:
>
> 1. Internet Protocol - Five Fields:
> https://datatracker.ietf.org/doc/draft-eromenko-ipff/
>
> 2. Internet Protocol - Five Fields: Addressing Architecture
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-addressing/
>
> 3. Internet Protocol - Five Fields: Babysitter (new NAT)
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-babysitter/
>
> 4. Internet Protocol - Five Fields: DHCP
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-dhcp/
>
> 5. Internet Protocol - Five Fields: DNS extensions
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-dns/
>
> 6. Internet Protocol - Five Fields: ICMP
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-icmp/
>
> 7. Internet Protocol - Five Fields: Link Address Resolution Algorithm
> (ARP replacement)
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-lara/
>
> 8. Internet Protocol - Five Fields: Mobile TCP (Mobile IP replacement)
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-mops/
>
> 9. Internet Protocol - Five Fields: TCP.64 extensions
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-tcp64/
>
> 10. Internet Protocol - Five Fields: UDP
> https://datatracker.ietf.org/doc/draft-eromenko-ipff-udp/
>
> Best wishes,
> --
> -Alexey Eromenko "Technologov"
>
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip

---

From: Alexey Eromenko <[email-masked]>
Date: Mon, 4 Jan 2016 22:02:56 +0200

> Looking at your list, I still don't see any multicast protocol.

Multicast Protocol will be a modified IGMP. (similar to IPv4)

But additionally, I have a so-called "Silent Multicast Mode", which
sits between traditional "Multicast" and "Broadcast", which doesn't
require a "Protocol", and is explained here:
https://docs.google.com/presentation/d/1XbqWOwv0GASmSjYZimfK64QKQQ-0yK9xQ1_spRhlf8Y/edit#slide=id.gfa725dfbc_46_207

Regards,
-Alexey

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 4 Jan 2016 14:17:23 -0600

> https://docs.google.com/presentation/d/1XbqWOwv0GASmSjYZimfK64QKQQ-0yK9xQ1_spRhlf8Y/edit#slide=id.gfa725dfbc_46_207

I think you should try to make some case for these features in IPFF
for 5G. Then people in this list will be more interested in looking
into.

Another point is so-called point-to-point links as opposed to the
shared links. Did you think about point-to-point links which exist in
the wireless world?

Regards,

Behcet

---

From: Alexey Eromenko <[email-masked]>
Date: Mon, 4 Jan 2016 22:31:33 +0200

> shared links. Did you think about point-to-point links which exist in

I don't see much difference between Wireless world (WiFi) and Ethernet
Switches with VLANs.
Both offer me "broadcast domains".

Conceptually: WiFi SSID = Ethernet VLAN
And Wireless 4G/LTE PtP links are conceptually similar to serial
Point-to-Point links.

Is there anything special to be aware of, in your opinion ? (that is
poorly covered by IPv4, and should be improved)

---

From: Rex Buddenberg <[email-masked]>
Date: Mon, 04 Jan 2016 13:23:59 -0800

> poorly covered by IPv4, and should be improved)

Yes.  

> Looking at your list, I still don't see any multicast protocol.

Multicast IP (v4) is a glue-on to existing IPv4.  

Meanwhile, we have significant changes in the internet.  At the time
Steve Deering wrote up RFC 1112, most of the internet was wired.  Today,
most of the internet is still wired, except for WiFi LANs at the fringe.
But the real change is with radio-WANs (router to router) in the
interior of the network.  This is work in progress now -- the diff is
that instead of lighting up your cellphone in your car, you're reaching
a router in the car and your cellphone ... and a seabag full of other
stuff ... is attached to the in-auto LAN (wired or wireless, probably a
combination of both).  

First, the meta, then some protocol comments.  Multicast has not had
much uptake on the internet because:
  - supply side, most of the multicast applications involve mobile
platforms (e.g. police cruisers and all-points bulletins).  
  - demand side.  With a wired internet, we can consistently
overprovision so the payoff to multicast is not worth the effort.  

With radio-WANs, this changes:
  - increase in data that is multicast in nature
  - capacity bottleneck at the radio-WAN.  God only made so much
spectrum.

Protocol comments.  I see problems but not at layers 2 and 3:
  - there are a few multicast transport protocols but they're not very
mature and not very widespread ... yet.  (see my earlier comment on next
gen transport protocols, I'll not repeat it here)
  - security.  End-end security of the data (infrastructure independent)
will continue to be important.  This requires a layer 6/7 solution.
Multicast + authenticity is not too bad (the sender's public key is
required by all recipients).  But tell me how you handle the
authenticity problem where the sender needs every recipient's public
key?  
   - rapid config.  multicast groups, at least some of them, will come
and go with rapidity and their membership will change constantly
(consider freeway traffic, for example).  Boggling.

> And Wireless 4G/LTE PtP links are conceptually similar to serial

The differences were deliberately masked when WiFi was cooked up.  But
they're there:
   - wired internet (including UTP ethernet) is point-to-point.  The
contention that used to be out on the coaxial cable is now in the LAN
switch.  In the rest of the terrestrial internet, most of the plumbing
is point-to-point (as in fiber).  
     Backbones are routinely provisioned at 10G and better and we can
always run a second fiber pair.  
     - wireless necessarily has the MAC right in your face.  Whether
it's CSMA/CA (in WiFi) or the contention-free MACs in the 4G protocols
-- you're sharing the spectrum with all the other stations on the
network segment.  Provisioning here, on a good day, gets you to M
capacities -- four orders of magnitude less than in the wired network.
(Four orders=1000 times).

b

---

From: Alexey Eromenko <[email-masked]>
Date: Tue, 5 Jan 2016 00:18:24 +0200

Ahh, you meant Internet-scale Multicast Transport !
(I thought you asked about Multicast group advertisement,  like IGMP)

OK.
Let's see what I can do...

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 5 Jan 2016 09:48:51 +0100 (CET)

> for 5G. Then people in this list will be more interested in looking

I still don't see realistically how anything that isn't IPv6 would be the 
main L3 part of 5G networking. As I stated before, we're now 20 years 
after basic design of IPv6 was done, and we've now reached 10% adoption on 
the Internet. Deploying new L3 protocols take huge time, effort and money.

If 5G is supposed to be done by 2020 and contain IPFF as its main 
protocol, what would it speak IPFF to? The rest of the Internet isn't 
going to speak IPFF, it's going to speak IPv6, most likely by then IPv6 
will be available for at least half the hosts of the Internet and 
considering where mobile is going, most of the mobile hosts will by then 
be IPv6 only with some kind of IPv4 reachability via AFTR.

IPFF would have been an interesting contender if it was 1993 today, but 
now it's 2016 and IPv6 is the only viable alternative.

I am impressed by the effort Alexey is putting into writing documents for 
IPFF, but I just don't see the viability for it to be deployed.

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Ca By <[email-masked]>
Date: Tue, 5 Jan 2016 05:47:52 -0800

On Tuesday, January 5, 2016, Mikael Abrahamsson <[email-masked]> wrote:

> main L3 part of 5G networking. As I stated before, we're now 20 years after
> basic design of IPv6 was done, and we've now reached 10% adoption on the
> Internet. Deploying new L3 protocols take huge time, effort and money.
>
> protocol, what would it speak IPFF to? The rest of the Internet isn't going
> to speak IPFF, it's going to speak IPv6, most likely by then IPv6 will be
> available for at least half the hosts of the Internet and considering where
> mobile is going, most of the mobile hosts will by then be IPv6 only with
> some kind of IPv4 reachability via AFTR.
>

Agreed, IPFF is not viable now or in the future.

The argument that ipv6 is too complicated to be deployed is just false
given that 37% of USA mobile traffic is already ipv6.

http://www.worldipv6launch.org/2015-wrapup-more-than-13-us-mobile-traffic-is-ipv6-and-still-growing/

If 5G is to impact the internet vs just integrate with the internet, 5G
could build on ipv6 to truly evolve the internet with ILNP.  ILNP could
vastly simplify the packet core by moving mobility to the UE, which would
allow the packet core to reduce signalling to properly scale with iot

CB

--

---

From: AshwoodsmithPeter <[email-masked]>
Date: Tue, 5 Jan 2016 14:48:34 +0000

While I’m not familiar with IPFF, one of the points that we have made about ‘non ip’ technologies in 5G is that these ‘may’ be possible because the radio access and hence the users hardware has to change. This means that there will be a point when people start upgrading hundreds of millions if not billions of smart phones etc. world wide. It is not impossible to imagine that in addition to new antenna designs, radios etc. that the software stacks could not also be new.

That’s not to say its easy or highly likely, but there is a vehicle to do it with 5G that does not exist out in the wireline world where there are fewer disruptive events that effect all the end devices.

Peter

From: 5gangip [mailto:[email-masked]] On Behalf Of Ca By
Sent: Tuesday, January 05, 2016 8:48 AM
To: Mikael Abrahamsson
Cc: Alexey Eromenko; [email-masked]; [email-masked]
Subject: Re: [5gangip] Development of Internet Protocol "Five Fields" (IP-FF): new Presentation

On Tuesday, January 5, 2016, Mikael Abrahamsson <[email-masked]<mailto:[email-masked]>> wrote:
On Mon, 4 Jan 2016, Behcet Sarikaya wrote:
I think you should try to make some case for these features in IPFF
for 5G. Then people in this list will be more interested in looking
into.

I still don't see realistically how anything that isn't IPv6 would be the main L3 part of 5G networking. As I stated before, we're now 20 years after basic design of IPv6 was done, and we've now reached 10% adoption on the Internet. Deploying new L3 protocols take huge time, effort and money.

If 5G is supposed to be done by 2020 and contain IPFF as its main protocol, what would it speak IPFF to? The rest of the Internet isn't going to speak IPFF, it's going to speak IPv6, most likely by then IPv6 will be available for at least half the hosts of the Internet and considering where mobile is going, most of the mobile hosts will by then be IPv6 only with some kind of IPv4 reachability via AFTR.

IPFF would have been an interesting contender if it was 1993 today, but now it's 2016 and IPv6 is the only viable alternative.

I am impressed by the effort Alexey is putting into writing documents for IPFF, but I just don't see the viability for it to be deployed.

The argument that ipv6 is too complicated to be deployed is just false given that 37% of USA mobile traffic is already ipv6.

If 5G is to impact the internet vs just integrate with the internet, 5G could build on ipv6 to truly evolve the internet with ILNP.  ILNP could vastly simplify the packet core by moving mobility to the UE, which would allow the packet core to reduce signalling to properly scale with iot

CB

--
Mikael Abrahamsson    email: [email-masked]<mailto:[email-masked]>

_______________________________________________
5gangip mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/5gangip