Subject: Re: [5gangip] Multiple access management framework

From: <[email-masked]>
Date: Thu, 5 Jan 2017 17:43:56 +0000

Dear Satish and co-authors,
Thanks for sharing your draft. Very much appreciated!

If I have understood it correctly you introduce another level of indirection to abstract connectivity from both access technologies (below L3) and IP transmission protocols (>= L3) to achieve a scalable adaptable link performance according to applications/services/entities demands and capabilities, respectively ... and thus it fits well to both IETF practice and 5G concepts (e.g. as of logical network slicing).

As a first attempt cost, effort, reality constraints are not in focus but the pure concept (and thus would allow to achieve a kind of reference benchmark) which is fine for me and helps to better shape the requirements.

Regarding implementation details an open question for me is whether you aim at an OTT (over the top - of the network) solution across different network operators domains - so any admission  and AAA details should be agreed before/below, but then also network path negotiation becomes difficult.
Or is there only one NCM as shown in Figs. 1 and 2 - on the other hand in section 6.14 you say ' ... one of the available NCM's ...'

MAMS control plane traffic is exchanged over user plane paths - does this really allow for clear CP/UP separation?

The aspect in 6.10 to support fragmentation ..[in order]... to avoid fragmentation - seems to be required since no changes and restrictions to underlying protocols should be made. And MAMS seems to produce a lot of overhead ... unfortunately also on the radio interface ;-(

It's a pity that the terminal/device/client needs a new software stack ... what PMIP has tried to overcome with respect to mobility support.

Please clarify whether I have misunderstood things.

And again, thanks for your proposal - let's discuss and see what we can learn and gain!

Best Regards
Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of K, Satish (Nokia - IN)
Sent: Mittwoch, 28. Dezember 2016 11:49
To: [email-masked]; [email-masked]
Cc: Flinck, Hannu (Nokia - FI/Espoo); [email-masked]; Vasudevan, Vasu (Nokia - US); [email-masked]; von Hugo, Dirk; Sprecher, Nurit (Nokia - IL/Hod HaSharon); pengshuping
Subject: Re: [5gangip] Multiple access management framework

Thanks Behcet for sharing the MAMS draft for discussion on the 5gangip list.

MAMS (Multi-Access Management Services) is a framework that allows clients and networks in
a multi-network scenario to negotiate the combination of uplink and downlink paths taking into
account client's application needs and network conditions. It allows dynamic adaptation of the
network paths guided by network intelligence supplemented by information conveyed by the clients.

MAMS can co-exist with and complement IETF protocols like TCP, UDP, GRE, MPTCP by providing a
mechanism to negotiate and configure these protocols based on deployment needs (e.g. IPsec where
network level security is needed), application needs (e.g. packet/flow switching or aggregation using
protocols like MPTCP), network conditions (e.g Switching or Aggregation modes based on differential link
delay), transport type, etc. and including client/network capabilities. We have also been discussing this
in the context of INTAREA WG, and attached slides provide a brief overview as well.

We believe that the negotiable, network intelligence assisted smart path and user plane protocol selection in

MAMS, complements the different protocol solutions being discussed as part of the 5gangip list

(https://www.ietf.org/id/draft-vonhugo-5gangip-ip-issues-01.txt), and provides an ideal framework for enabling

the 5G use cases.

We would welcome your review of the draft (https://www.ietf.org/id/draft-kanugovi-intarea-mams-protocol-01.txt)

and look forward to the feedback.

BR
Satish

Satish Kanugovi ([email-masked]<mailto:[email-masked]>), DMTS, :Core Networks Evolution Group:
Core, Cloud & Software Innovation Planning  @ Mobile Networks CTO
Call/Text: +91 98861 24678 (cell), https://www.linkedin.com/in/satishkanugovi

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Friday, December 02, 2016 10:53 PM
To: [email-masked]<mailto:[email-masked]>
Cc: pengshuping <[email-masked]<mailto:[email-masked]>>; Vasudevan, Vasu (Nokia - US) <[email-masked]<mailto:[email-masked]>>; K, Satish (Nokia - IN) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [5gangip] Multiple access management framework

Folks,

Please check this draft:

https://tools.ietf.org/html/draft-kanugovi-intarea-mams-protocol-01

The draft presents a framework for multiple access management. It has been presented in intarea in Seoul.

This draft has been pointed to our attention: It seems to be relevant to

Session Management and

Core and Access Functional Division

key issues in next generation Fixed-Mobile Convergence.

We thought a list discussion could be good.

Regards,

Behcet

_______________________________________________

5gangip mailing list

[email-masked]<mailto:[email-masked]>

https://www.ietf.org/mailman/listinfo/5gangip

---

From: "K, Satish (Nokia - IN)" <[email-masked]>
Date: Mon, 9 Jan 2017 09:46:56 +0000

Hi Dirk:

Thanks a lot for your detailed review and comments.
Please see some responses embedded inline, and would appreciate further thoughts and feedback.

BR
Satish

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, January 05, 2017 11:14 PM
To: K, Satish (Nokia - IN) <[email-masked]>; [email-masked]; [email-masked]
Cc: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]>; [email-masked]; Vasudevan, Vasu (Nokia - US) <[email-masked]>; [email-masked]; Sprecher, Nurit (Nokia - IL/Hod HaSharon) <[email-masked]>; [email-masked]
Subject: RE: [5gangip] Multiple access management framework

Regarding implementation details an open question for me is whether you aim at an OTT (over the top - of the network) solution across different network operators domains - so any admission  and AAA details should be agreed before/below, but then also network path negotiation becomes difficult.
Or is there only one NCM as shown in Figs. 1 and 2 - on the other hand in section 6.14 you say ' ... one of the available NCM's ...'
[sak] There is only one NCM in the network that the client interacts with.
There can be multiple instances and locations of NCM in the network e.g. NCM functionality can be collocated with an edge-cloud (say MEC) or core-network user plane gateway (say PGW).
The client can pick one of the available NCM for MAMS operation.

MAMS control plane traffic is exchanged over user plane paths - does this really allow for clear CP/UP separation?
[sak] The user plane functions and control plane function of MAMS can be independently located and configured.
I concede that the statement "MAMS control plane traffic is exchanged over user plane paths" is a bit confusing.
The intention is to indicate that the control signaling messages are not tied to a particular network/access type but can be carried over any path that connects NCM and CCM.

The aspect in 6.10 to support fragmentation ..[in order]... to avoid fragmentation - seems to be required since no changes and restrictions to underlying protocols should be made.

And MAMS seems to produce a lot of overhead ... unfortunately also on the radio interface ;-(
[sak] Can you please elaborate on the overhead aspect?
MAMS provides a way for multi-network integration without impacting and independent of the actual protocols/procedures of the underlying networks.
So, the MAMS control signaling, over and above the procedures for individual network path setup, can considered as tradeoff to achieve such flexibility.
For large bandwidth networks, the overhead may not even be significant.
But optimizing overhead will certainly remain in our consideration, as we enter the stage of specifying the details of control procedures for MAMS.

It's a pity that the terminal/device/client needs a new software stack ... what PMIP has tried to overcome with respect to mobility support.
[sak] one of the drivers for MAMS is to risk-proof network operators technology investment by allowing a framework that can cater to heterogeneity of
device capability and availability that are critical for successful adoption. This would require the network and client to negotiate and hence have some
impact on client side functionality. As Section 9 alludes, MAMS functionality at the client side can be implemented as a software update leveraging the
commonly available functions. Based on the feedback that we have from our UE partners, the client implementation to support these functions is
relatively straightforward.
I presume you just used PMIP as a reference for a Network-only framework. The scope of MAMS and PMIP are different - I am not sure if we should
compare the 2 approaches. But, we can discuss further based on your review of the response above.

Best Regards
Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of K, Satish (Nokia - IN)
Sent: Mittwoch, 28. Dezember 2016 11:49
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Flinck, Hannu (Nokia - FI/Espoo); [email-masked]<mailto:[email-masked]>; Vasudevan, Vasu (Nokia - US); [email-masked]<mailto:[email-masked]>; von Hugo, Dirk; Sprecher, Nurit (Nokia - IL/Hod HaSharon); pengshuping
Subject: Re: [5gangip] Multiple access management framework

the 5G use cases.

BR
Satish

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Friday, December 02, 2016 10:53 PM
To: [email-masked]<mailto:[email-masked]>
Cc: pengshuping <[email-masked]<mailto:[email-masked]>>; Vasudevan, Vasu (Nokia - US) <[email-masked]<mailto:[email-masked]>>; K, Satish (Nokia - IN) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [5gangip] Multiple access management framework

Folks,

Please check this draft:

Session Management and

Regards,

Behcet

5gangip mailing list

---

From: Ca By <[email-masked]>
Date: Mon, 09 Jan 2017 13:40:59 +0000

It would be interesting for the authors to compare this with andsf, which
has not been amazing successfull

https://en.m.wikipedia.org/wiki/Access_network_discovery_and_selection_function

On Fri, Dec 2, 2016 at 9:23 AM Behcet Sarikaya <[email-masked]>
wrote:

> The draft presents a framework for multiple access management. It has
>
> been presented in intarea in Seoul.
>
>
>
> [email-masked]

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 9 Jan 2017 14:47:19 -0600

Hi Cameron,

> https://en.m.wikipedia.org/wiki/Access_network_discovery_and_selection_function

Thank you for bringing this (ANDSF) up.
Let's see what Satish says.

Regards,

Behcet

---

From: <[email-masked]>
Date: Tue, 10 Jan 2017 12:43:57 +0000

Dear Satish,
thanks for your clarifications and answers. Please see my response below.
Best Regards
Dirk

From: K, Satish (Nokia - IN) [mailto:[email-masked]]
Sent: Montag, 9. Januar 2017 10:47
To: von Hugo, Dirk; [email-masked]; [email-masked]
Cc: Flinck, Hannu (Nokia - FI/Espoo); [email-masked]; Vasudevan, Vasu (Nokia - US); [email-masked]; Sprecher, Nurit (Nokia - IL/Hod HaSharon); [email-masked]
Subject: RE: [5gangip] Multiple access management framework

Hi Dirk:

BR
Satish

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Thursday, January 05, 2017 11:14 PM
To: K, Satish (Nokia - IN) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Flinck, Hannu (Nokia - FI/Espoo) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Vasudevan, Vasu (Nokia - US) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>; Sprecher, Nurit (Nokia - IL/Hod HaSharon) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [5gangip] Multiple access management framework

DH> I see - the NCM is seen as a VNF doing control, management and coordination between different access domains - based on policies and federation agreements between the domains owners, right?

DH> OK, CP signaling is transport agnostic and can be done via any existing link abstracted from access specifics (e.g. encryption etc.)

DH> I think I agree and understand the trade-off aspect. As you mention in case of large available bandwidth this will be negligible in terms resources - but all the negotiation effort may also produce time delay spoiling the performance for  use cases with e.g. low latency or high reliability constraints. And an overlay solution cannot easily decide on underlaying networks current characteristics.
What I have in mind is ideally a mixture of abstracting technology information but retaining essential specific information (e.g. for higher layer support) - perhaps similar to 3GPP approach (see TR23.799) where they agree on the principle to 'minimize access and core network dependencies by specifying a converged access-agnostic core with a common AN - CN interface which integrates different 3GPP and non-3GPP access types'

DH> and this would also allow for flexible deployment - OK!
I presume you just used PMIP as a reference for a Network-only framework. The scope of MAMS and PMIP are different - I am not sure if we should
compare the 2 approaches. But, we can discuss further based on your review of the response above.
DH> you are right I didn't want to compare connectivity with mobility but just refer to the device-independence ... what I see as pro from a network operator point of view - whereas from a converged service provider point of view the (more) client-centric approach has its clear advantages.
Thanks for fruitful discussion!

Best Regards
Dirk

the 5G use cases.

BR
Satish

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Friday, December 02, 2016 10:53 PM
To: [email-masked]<mailto:[email-masked]>
Cc: pengshuping <[email-masked]<mailto:[email-masked]>>; Vasudevan, Vasu (Nokia - US) <[email-masked]<mailto:[email-masked]>>; K, Satish (Nokia - IN) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [5gangip] Multiple access management framework

Folks,

Please check this draft:

Session Management and

Regards,

Behcet

5gangip mailing list

---

From: "K, Satish (Nokia - IN)" <[email-masked]>
Date: Wed, 11 Jan 2017 09:07:15 +0000

Hi Dirk:

Thanks for your feedback and comments. Please see responses inline.
Overall, your understanding is in alignment with the intent of the proposal.
We welcome further feedback from you on aspects related to practical
deployments and related work like the one with reference to 23.799 in your mail below.

BR
Satish

Sent: Tuesday, January 10, 2017 6:14 PM

Dear Satish,

From: K, Satish (Nokia - IN) [mailto:[email-masked]]
Sent: Montag, 9. Januar 2017 10:47
To: von Hugo, Dirk; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Flinck, Hannu (Nokia - FI/Espoo); [email-masked]<mailto:[email-masked]>; Vasudevan, Vasu (Nokia - US); [email-masked]<mailto:[email-masked]>; Sprecher, Nurit (Nokia - IL/Hod HaSharon); [email-masked]<mailto:[email-masked]>
Subject: RE: [5gangip] Multiple access management framework

Hi Dirk:

BR
Satish

[sak-11 Jan] Yes.

[sak-11 Jan] Yes.

DH> I think I agree and understand the trade-off aspect. As you mention in case of large available bandwidth this will be negligible in terms resources - but all the negotiation effort may also produce time delay spoiling the performance for  use cases with e.g. low latency or high reliability constraints. And an overlay solution cannot easily decide on underlaying networks current characteristics.
What I have in mind is ideally a mixture of abstracting technology information but retaining essential specific information (e.g. for higher layer support) - perhaps similar to 3GPP approach (see TR23.799) where they agree on the principle to 'minimize access and core network dependencies by specifying a converged access-agnostic core with a common AN - CN interface which integrates different 3GPP and non-3GPP access types'
[sak-11 Jan] Thanks for your insights on this - we can certainly evaluate these aspects and refine MAMS leveraging related work, e.g. in 3GPP, and would welcome your further feedback in this regard..

Best Regards
Dirk

the 5G use cases.

BR
Satish

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Friday, December 02, 2016 10:53 PM
To: [email-masked]<mailto:[email-masked]>
Cc: pengshuping <[email-masked]<mailto:[email-masked]>>; Vasudevan, Vasu (Nokia - US) <[email-masked]<mailto:[email-masked]>>; K, Satish (Nokia - IN) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [5gangip] Multiple access management framework

Folks,

Please check this draft:

Session Management and

Regards,

Behcet

5gangip mailing list

---

From: "K, Satish (Nokia - IN)" <[email-masked]>
Date: Wed, 11 Jan 2017 09:42:53 +0000

Hi Cameron:

MAMS provides a framework for devices connected to multiple networks to negotiate with 
the network to functions like, but not limited to, the following
a). selecting the combination of uplink and downlink network paths, 
b). choose and configure the appropriate user plane protocols
c). determine user plane treatment based on traffic types/classes
d). allow sharing of network intelligence/policy with the device

MAMS, thus is a broader framework with functions beyond sharing the network policy, in 
comparison to ANDSF that provides policies/rules for selecting the accesses in addition to 
assisting 3GPP devices to discover available networks.

We welcome your feedback on specific learnings from other systems that you think are 
relevant and can help improve the proposal.

BR
Satish

-----Original Message-----
From: Behcet Sarikaya [mailto:[email-masked]] 
Sent: Tuesday, January 10, 2017 2:17 AM
To: Ca By <[email-masked]>
Cc: [email-masked]; [email-masked]; pengshuping <[email-masked]>; K, Satish (Nokia - IN) <[email-masked]>; Vasudevan, Vasu (Nokia - US) <[email-masked]>
Subject: Re: [5gangip] Multiple access management framework

Hi Cameron,

On Mon, Jan 9, 2017 at 7:40 AM, Ca By <[email-masked]> wrote:
>
>
> It would be interesting for the authors to compare this with andsf, 
> which has not been amazing successfull
>

Regards,

Behcet