Subject: [5gangip] Side meeting notes

From: David Allan I <[email-masked]>
Date: Tue, 28 Mar 2017 18:04:37 +0000

Here are the notes from today's meeting....
Enjoy
D

3/28/17 5gangup Side meeting
Behcet and Dirk
~25 in the room
Agenda bash
5G IP issues - draft-vonhugo-5gangip-ip-issues-03
Current solution space consists of ILA and MAMS approaches.
Incubating groups, time to incubate ourselves.
Suggest it may be time to consider a BOF.
Want to stay in the INTAREA.  Interest in the AMF, SMF, UPF and some aspects of the AN in the context of IP.
Proposals for access, mobility, and session management.
Dave: you described nodes, and we are a protocol shop. Are you referring to N1, N2. N3. N4 and N11 interfaces? Yes
Dave: What are we going to do that 3GPP is not as this is their architecture, are these alternative protocols?
Georg Mayer: It is the job of 3GPP and the CT group to decide protocols.  For N3 and N2 we had discussions in the plenary. 3GPP will specify this, mainly in the RAN group to allow access agnostic connections. Not sure what protocols we will reuse from 4G. Not clear to my understanding what role IETF will play.  What I saw in the slicing side meeting gives me hope that coordination can be achieved.  3GPP can do the protocol work, and if IETF does not have suitable protocols we can adopt then we will specify them.
Behcet: working on a network that can be build from scratch is of interest, IoT etc.
Charter items....
Operator interest items...
Connectivity issues, centered around I-L split gaps.  ILA, ILNP, LISP....
ILA mobility use cases  [email-masked]<mailto:[email-masked]>
V2I use case:
Asking INTAREA be taken up as a WG item.
A number of requirements. Centered around security and dependency on the infrastructure.
Road side unit (RSU) does ID translation?
Dave: ILA's claim to fame was no host stack change. With both LOC and ID Xlate this seems impossible.  A: (precis) Needs some thought but there would be ways to do this.
Lorenzo:  <first question lost>
Vehicle as only one IPv6 at a time.  It could have a subnet of identifiers.  Able to form IP addresses without coordination with the network. Behcet, take to the list.
You would still need DHCP to give you an address or subnet.  You need more than one address, there is a best practice.   Read 7934.   Dave: PD wouldn't work. Lorenzo: Correct you have to give all the bits to the network.
Erik: You've reinvented IPv6 NAT.  Tom: Do we need to do extra encap.  Erik: That was fine for the DC case. But if for a bunch of hosts inside the vehicle.  It is only the routing system that knows the ILA NAT (???)
Overview of MAMs:  Hannu Flinck
Framework for selecting access and core network independently, based on traffic types, changing network conditions, etc.  includes negotiation.
Draft-herbert-ila, and draft Mueller-ila-mobility
Erik: Is there a document outlining the problems with existing 3GPP protocols like GTP.  Behcet: pointed to the von-hugo draft.  Erik: AFAIK ILA for mobility is still a tunneling solution.
Draft-zhu-intarea-mams-control/user-protocol.
Georg: Issues draft would be of interest to 3GPP.  We are starting a 6 month study in CT, which is also where the decisions will be taken, including w.r.t GTP.  I cannot judge this on a technical perspective, but you should bring the issues to 3GPP. Are you planning on doing such a thing. My expectation is that drafts take longer than 3GPP will take in making decisions.  If you send a whole document, there is a high probability of an ack but few reading it.
Marco: I think it is a valid point to investigate shortcomings, but the CT work is DP and or CP?
Georg: My understanding is all WG chairs we welcoming input but the window is short.  Do not want to be extreme or threatening, but the moment is now to provide input to 3GPP.
Rudeiger (DT):  are you discussing a special release or a number of releases?  Georg: Release 15 will provide the foundation for the 5G system. What comes into the normative part now will not be easy to change in the coming releases. Introducing new concepts will become hard, such as replacing GTP.  Note that there might be multiple soluitions.
Kalyani (Vz): There is a desire to have an alternative to GTP, we had PMIP in 4G. So an overlay plus a native routing option.  Such work would belong to INTAREA. Not sure how we can talk about functions and protocols here while 3GPP is working on them. <incomplete capture>
Lorenzo: My understanding is 3GPP assigns a /64 to a device as part of a PDU context.  ILA cannot provide ... If 3GPP cannot accept a regression down to a 128 per host, we would be contradicting our advice to 3GPP from 15 years ago.
Georg: You are working on technical solutions, that is great. If you could highlight the problems you see to 3GPP that would be great. Just a warning, if we work on issues in parallel, we will get decoupled.  If you could make 3GPP aware of alternative solutions that would be great.

---

From: Behcet Sarikaya <[email-masked]>
Date: Tue, 28 Mar 2017 13:22:27 -0500

Hi Dave,
Thanks for the notes.
A few corrections to the minutes will be issued soon.

Regards,

Behcet

On Tue, Mar 28, 2017 at 1:04 PM, David Allan I <[email-masked]>
wrote:

> Here are the notes from today’s meeting….
>
> Enjoy
>
> D
>
>
>
> *3/28/17 5gangup Side meeting*
>
> Behcet and Dirk
>
> ~25 in the room
>
> *Agenda bash*
>
> *5G IP issues – draft-vonhugo-5gangip-ip-issues-03*
>
> Dave: you described nodes, and we are a protocol shop. Are you referring
> to N1, N2. N3. N4 and N11 interfaces? Yes
>
> Dave: What are we going to do that 3GPP is not as this is their
> architecture, are these alternative protocols?
>
> Georg Mayer: It is the job of 3GPP and the CT group to decide protocols.
> For N3 and N2 we had discussions in the plenary. 3GPP will specify this,
> mainly in the RAN group to allow access agnostic connections. Not sure what
> protocols we will reuse from 4G. Not clear to my understanding what role
> IETF will play.  What I saw in the slicing side meeting gives me hope that
> coordination can be achieved.  3GPP can do the protocol work, and if IETF
> does not have suitable protocols we can adopt then we will specify them.
>
> Charter items….
> Operator interest items…
> Connectivity issues, centered around I-L split gaps.  ILA, ILNP, LISP….
>
> *ILA mobility use cases  [email-masked] <[email-masked]>*
>
> *V2I use case:*
>
> Dave: ILA’s claim to fame was no host stack change. With both LOC and ID
> Xlate this seems impossible.  A: (precis) Needs some thought but there
> would be ways to do this.
>
> Vehicle as only one IPv6 at a time.  It could have a subnet of
> identifiers.  Able to form IP addresses without coordination with the
> network. Behcet, take to the list.
>
> You would still need DHCP to give you an address or subnet.  You need more
> than one address, there is a best practice.   Read 7934.   Dave: PD
> wouldn’t work. Lorenzo: Correct you have to give all the bits to the
> network.
>
> Erik: You’ve reinvented IPv6 NAT.  Tom: Do we need to do extra encap.
> Erik: That was fine for the DC case. But if for a bunch of hosts inside the
> vehicle.  It is only the routing system that knows the ILA NAT (???)
>
> *Overview of MAMs:  Hannu Flinck*
>
> Framework for selecting access and core network independently, based on
> traffic types, changing network conditions, etc.  includes negotiation.
>
> *Draft-herbert-ila, and draft Mueller-ila-mobility*
>
> Erik: Is there a document outlining the problems with existing 3GPP
> protocols like GTP.  Behcet: pointed to the von-hugo draft.  Erik: AFAIK
> ILA for mobility is still a tunneling solution.
>
> *Draft-zhu-intarea-mams-control/user-protocol.*
>
> Georg: Issues draft would be of interest to 3GPP.  We are starting a 6
> month study in CT, which is also where the decisions will be taken,
> including w.r.t GTP.  I cannot judge this on a technical perspective, but
> you should bring the issues to 3GPP. Are you planning on doing such a
> thing. My expectation is that drafts take longer than 3GPP will take in
> making decisions.  If you send a whole document, there is a high
> probability of an ack but few reading it.
>
> Georg: My understanding is all WG chairs we welcoming input but the window
> is short.  Do not want to be extreme or threatening, but the moment is now
> to provide input to 3GPP.
>
> Rudeiger (DT):  are you discussing a special release or a number of
> releases?  Georg: Release 15 will provide the foundation for the 5G system.
> What comes into the normative part now will not be easy to change in the
> coming releases. Introducing new concepts will become hard, such as
> replacing GTP.  Note that there might be multiple soluitions.
>
> Kalyani (Vz): There is a desire to have an alternative to GTP, we had PMIP
> in 4G. So an overlay plus a native routing option.  Such work would belong
> to INTAREA. Not sure how we can talk about functions and protocols here
> while 3GPP is working on them. <incomplete capture>
>
> Lorenzo: My understanding is 3GPP assigns a /64 to a device as part of a
> PDU context.  ILA cannot provide … If 3GPP cannot accept a regression down
> to a 128 per host, we would be contradicting our advice to 3GPP from 15
> years ago.
>
> Georg: You are working on technical solutions, that is great. If you could
> highlight the problems you see to 3GPP that would be great. Just a warning,
> if we work on issues in parallel, we will get decoupled.  If you could make
> 3GPP aware of alternative solutions that would be great.
>
>
>
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>
>