Subject: [5gangip] To initiate user-plane study work in 3GPP

From: Satoru Matsushima <[email-masked]>
Date: Mon, 16 Oct 2017 18:13:19 +0900

FYI. I’d submit a contribution to propose a new study item which is to initiate user-plane protocol study work in 3GPP CT4 WG.

http://www.3gpp.org/ftp/tsg_ct/WG4_protocollars_ex-CN4/TSGCT4_80_Kochi/Docs/C4-175098.zip

Please take a look at the doc from above link. I'd appreciate any your support if you think it makes sense.

Cheers,
--satoru

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 16 Oct 2017 15:12:09 -0500

Hi Satoru,

Thanks for the info.

Can you please explain the objective items in your WID?

It seems like according to TR 29.891 that you mentioned, Release 15 user
plane protocol is GTPv1U and control plane protocol for SBA is HTTP.

Regards,
Behcet

On Mon, Oct 16, 2017 at 4:13 AM, Satoru Matsushima <
[email-masked]> wrote:

> FYI. I’d submit a contribution to propose a new study item which is to
> initiate user-plane protocol study work in 3GPP CT4 WG.
>
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>

---

From: Robert Moskowitz <[email-masked]>
Date: Tue, 17 Oct 2017 08:51:45 -0400

Behcet and Satoru,

Last year I did a study of GTPv1U and worked out a different approach 
that would better support P2P communications without the need of a home 
proxy agent.  You can see part of it in:

draft-moskowitz-hip-ipnhip-02.txt

But I learned that there is tremendous resistance to any change away 
from GTP, even a partial change.  A study group would have to work out 
what services GTP provides.  Which services it does well and which it 
does poorly.  Then how to better meet the service needs today and going 
forward.

Bob

On 10/16/2017 04:12 PM, Behcet Sarikaya wrote:
> It seems like according to TR 29.891 that you mentioned, Release 15 
> user plane protocol is GTPv1U and control plane protocol for SBA is HTTP.
>
> Regards,
> Behcet
>
> On Mon, Oct 16, 2017 at 4:13 AM, Satoru Matsushima 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     FYI. I’d submit a contribution to propose a new study item which
>     is to initiate user-plane protocol study work in 3GPP CT4 WG.
>
>     <http://www.3gpp.org/ftp/tsg_ct/WG4_protocollars_ex-CN4/TSGCT4_80_Kochi/Docs/C4-175098.zip>
>
>     Please take a look at the doc from above link. I'd appreciate any
>     your support if you think it makes sense.
>
>     Cheers,
>     --satoru
>     [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/5gangip>
>
>
>
>

---

From: <[email-masked]>
Date: Tue, 17 Oct 2017 21:15:16 +0000

Bob

This is the key statement for me:

“A study group would have to work out what services GTP provides”

Both in this group and related efforts (e.g. IDEAS at IETF, NGP at ETSI), we need to consider how it is that mobile networks are built.

In terms of P2P, traffic on today’s mobile networks is predominantly anchored at a central point, not P2P despite the associated engineering inefficiencies.   There are very good reasons for this:

  *   It makes LI very easy to implement
  *   It makes association of traffic with user clear allowing simple billing mechanisms
  *   Mobility events are handled quickly and with minimal packet loss

In terms of the major use-cases today (voice over LTE and mobile broadband) as they move to 5G, I really don’t see any need to change the underlying tunnelling protocol because It Works.

However, for NEW 5G use-cases such as Ultra-Low Latency and edge-based services we should be considering whether GTP is the correct choice provided we can meet the commercial and regulatory requirements of the MNOs in terms of LI and charging.

David

From: 5gangip [mailto:[email-masked]] On Behalf Of Robert Moskowitz
Sent: 17 October 2017 05:52
To: [email-masked]; Satoru Matsushima <[email-masked]>
Cc: [email-masked]
Subject: Re: [5gangip] To initiate user-plane study work in 3GPP

Behcet and Satoru,

Last year I did a study of GTPv1U and worked out a different approach that would better support P2P communications without the need of a home proxy agent.  You can see part of it in:

But I learned that there is tremendous resistance to any change away from GTP, even a partial change.  A study group would have to work out what services GTP provides.  Which services it does well and which it does poorly.  Then how to better meet the service needs today and going forward.

Bob
On 10/16/2017 04:12 PM, Behcet Sarikaya wrote:
Hi Satoru,
Thanks for the info.
Can you please explain the objective items in your WID?
It seems like according to TR 29.891 that you mentioned, Release 15 user plane protocol is GTPv1U and control plane protocol for SBA is HTTP.
Regards,
Behcet

On Mon, Oct 16, 2017 at 4:13 AM, Satoru Matsushima <[email-masked]<mailto:[email-masked]>> wrote:
FYI. I’d submit a contribution to propose a new study item which is to initiate user-plane protocol study work in 3GPP CT4 WG.

Cheers,
--satoru
_______________________________________________
5gangip mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/5gangip

5gangip mailing list

[email-masked]<mailto:[email-masked]>

---

From: Uma Chunduri <[email-masked]>
Date: Tue, 17 Oct 2017 21:38:51 +0000

David,

Agree mostly on what you said.  2 comments though..

> Mobility events are handled quickly and with minimal packet loss

I don’t think so. It’s an overhead for RAN mobility (X2 tunnels creation and additional control signalling for the same) and similar complication for UPF mobility.

> However, for NEW 5G use-cases such as Ultra-Low Latency and edge-based services we should be considering whether GTP is the correct choice provided we can meet the commercial and regulatory require…

I am not sure who is “we”  (I would see that as 3GPP).

But it’s good to put proposals  to show what layer 3 mobility entails -  like the one Bob mentioned below or  what Dino indicated https://www.ietf.org/mail-archive/web/5gangip/current/msg00571.html

--
Uma C.

From: 5gangip [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Tuesday, October 17, 2017 2:15 PM
To: [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: [5gangip] To initiate user-plane study work in 3GPP

Bob

-          It makes LI very easy to implement
-          It makes association of traffic with user clear allowing simple billing mechanisms
-          Mobility events are handled quickly and with minimal packet loss

David

From: 5gangip [mailto:[email-masked]] On Behalf Of Robert Moskowitz
Sent: 17 October 2017 05:52
To: [email-masked]<mailto:[email-masked]>; Satoru Matsushima <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [5gangip] To initiate user-plane study work in 3GPP

Behcet and Satoru,

Bob

Cheers,
--satoru

5gangip mailing list

---

From: <[email-masked]>
Date: Tue, 17 Oct 2017 21:52:42 +0000

Uma

I agree that X2 is a complication but this is only used temporarily to provide a fast switch-over during a mobility event.  In terms of end-to-end communication, even during an X2 event, the topology and use of a tunnel anchored at the centre remains.

The issue is not the protocol but the time the underlying equipment takes to update the tunnel path.

At the moment (note – AT THE MOMENT!) the use-case which requires the most expeditious switch-over and is least tolerant to packet drops due to mobility events is VoLTE and it survives very well in current S1 and X2 handover systems.

I think this - “I am not sure who is “we”  (I would see that as 3GPP).”   - may be where we are struggling!  Until we have a use-case which patently fails using the current anchored GTP system, we are going to find it very hard to have an alternative solution considered.

We need to work with 3GPP on this….

David

From: Uma Chunduri [mailto:[email-masked]]
Sent: 17 October 2017 14:39
To: Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>; [email-masked]; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: RE: [5gangip] To initiate user-plane study work in 3GPP

David,

--
Uma C.

From: 5gangip [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Tuesday, October 17, 2017 2:15 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [5gangip] To initiate user-plane study work in 3GPP

Bob

David

Behcet and Satoru,

Bob

Cheers,
--satoru

5gangip mailing list

---

From: Satoru Matsushima <[email-masked]>
Date: Wed, 18 Oct 2017 18:10:30 +0900

Behcet, David, and Uma,

Thank you for your comments. Those are really informative. And yes I agree that we need to work with 3GPP. That’s why the WID out there.

While there’s no clear facts on future networking in 5G, I wrote up the text in justification with facts which at least IPv6 adoption has been growth and IAB recommend SDOs to review existing standards work in IPv6-only environment. 

Cheers,
--satoru

> 2017/10/18 6:52、[email-masked]:
> 
> Uma
>  
> But it’s good to put proposals  to show what layer 3 mobility entails -  like the one Bob mentioned below or  what Dino indicatedhttps://www.ietf.org/mail-archive/web/5gangip/current/msg00571.html
>  
>  
> --
> Uma C.
>  
> 	• It makes LI very easy to implement
> 	• It makes association of traffic with user clear allowing simple billing mechanisms
> 	• Mobility events are handled quickly and with minimal packet loss
>  
> On Mon, Oct 16, 2017 at 4:13 AM, Satoru Matsushima <[email-masked]> wrote:

---

From: Uma Chunduri <[email-masked]>
Date: Wed, 18 Oct 2017 17:03:21 +0000

>I think this - “I am not sure who is “we”  (I would see that as 3GPP).”   - may be where we are struggling!  Until we have a use-case which patently fails using the current anchored GTP system,
> we are going to find it very hard to have an alternative solution considered.

David, Agree.
But it seems  some decisions are made purely based on business reasons; however, massive M2M (with lot of non-mobile connections) , uRLLC  - backhaul transport networks ought to evolve with modern mobility centric considerations.

--
Uma C.

---

From: <[email-masked]>
Date: Wed, 18 Oct 2017 17:17:23 +0000

Dear all,
I completely agree that we (i.e. at IETF community) should start work on potential protocol or framework solutions for 3GPP - even before 5G requirements (in architecture documents) are fully specified which as Georg in Prague pointed out https://datatracker.ietf.org/meeting/99/materials/slides-99-edu-sessk-3gpp-ietf-collaboration-on-5g/ is expected for end of this year.
And I also think that a major role will play Identity / Locator Separated protocols like LISP, ILNP, ILA ... supporting multiple types of mobility by choosing correspondingly adapted configurations ... which would fit to service-tailored network slicing ideas. 
Thanks!
Best Regards
Dirk 
-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Satoru Matsushima
Sent: Mittwoch, 18. Oktober 2017 11:11
To: [email-masked]; [email-masked]; [email-masked]; <[email-masked]>
Cc: [email-masked]
Subject: Re: [5gangip] To initiate user-plane study work in 3GPP

Behcet, David, and Uma,

Cheers,
--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Thu, 19 Oct 2017 11:52:37 +0900

Thank you Dirk,

Yes that presentation made by George has much encouraged ietf community. 
Other key facts which the justification text mentioned are following:

o IAB statement on IPv6
  https://www.iab.org/2016/11/07/iab-statement-on-ipv6/

o IPv6 deployment measurement
  http://www.worldipv6launch.org/measurements/

We can see big number of adoption rate for cellular operators especially in US. T-Mobile US and Verizon Wireless exceed 80%, 47.51% for ATT Wireless, and 59% for Sprint Wireless.

Cheers,
--satoru

> 2017/10/19 2:17、<[email-masked]> <[email-masked]>のメール:
> 
> Dear all,

---

From: Lorenzo Colitti <[email-masked]>
Date: Thu, 19 Oct 2017 14:23:55 +0900

On Wed, Oct 18, 2017 at 6:10 PM, Satoru Matsushima <
[email-masked]> wrote:

> Thank you for your comments. Those are really informative. And yes I agree
> that we need to work with 3GPP. That’s why the WID out there.
>
> While there’s no clear facts on future networking in 5G, I wrote up the
> text in justification with facts which at least IPv6 adoption has been
> growth and IAB recommend SDOs to review existing standards work in
> IPv6-only environment.
>

Can we also remind the SDOs to follow best current practices for IPv6
address assignment, e.g., as written down in RFC 7934? Recently several
solutions have been proposed that would not meet those best practices.

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 23 Oct 2017 11:06:11 -0500

Hi Satoru,

On Wed, Oct 18, 2017 at 9:52 PM, Satoru Matsushima <
[email-masked]> wrote:

> We can see big number of adoption rate for cellular operators especially
> in US. T-Mobile US and Verizon Wireless exceed 80%, 47.51% for ATT
> Wireless, and 59% for Sprint Wireless.
>
>
All these look good but my question is what can 3GPP CTs (CT3, etc.) do
about it?
I guess this was behind you WID and not SRv6 for 5G?

Regards,
Behcet

> > I completely agree that we (i.e. at IETF community) should start work on
> potential protocol or framework solutions for 3GPP - even before 5G
> requirements (in architecture documents) are fully specified which as Georg
> in Prague pointed out https://datatracker.ietf.org/
> meeting/99/materials/slides-99-edu-sessk-3gpp-ietf-collaboration-on-5g/
> is expected for end of this year.
> > And I also think that a major role will play Identity / Locator
> Separated protocols like LISP, ILNP, ILA ... supporting multiple types of
> mobility by choosing correspondingly adapted configurations ... which would
> fit to service-tailored network slicing ideas.
> > Thanks!
> > Best Regards
> > Dirk
> > Thank you for your comments. Those are really informative. And yes I
> agree that we need to work with 3GPP. That’s why the WID out there.
> >
> >> I agree that X2 is a complication but this is only used temporarily to
> provide a fast switch-over during a mobility event.  In terms of end-to-end
> communication, even during an X2 event, the topology and use of a tunnel
> anchored at the centre remains.
> >>
> >> At the moment (note – AT THE MOMENT!) the use-case which requires the
> most expeditious switch-over and is least tolerant to packet drops due to
> mobility events is VoLTE and it survives very well in current S1 and X2
> handover systems.
> >>
> >> I think this - “I am not sure who is “we”  (I would see that as
> 3GPP).”   - may be where we are struggling!  Until we have a use-case which
> patently fails using the current anchored GTP system, we are going to find
> it very hard to have an alternative solution considered.
> >>
> >> To: Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>;
> [email-masked]; [email-masked]; [email-masked]
> >> Cc: [email-masked]
> >> I don’t think so. It’s an overhead for RAN mobility (X2 tunnels
> creation and additional control signalling for the same) and similar
> complication for UPF mobility.
> >>
> >>> However, for NEW 5G use-cases such as Ultra-Low Latency and edge-based
> services we should be considering whether GTP is the correct choice
> provided we can meet the commercial and regulatory requirements of the MNOs
> in terms of LI and charging.
> >>
> >> But it’s good to put proposals  to show what layer 3 mobility entails
> -  like the one Bob mentioned below or  what Dino indicatedhttps://
> www.ietf.org/mail-archive/web/5gangip/current/msg00571.html
> >>
> >>
> >> --
> >> Uma C.
> >>
> >> Both in this group and related efforts (e.g. IDEAS at IETF, NGP at
> ETSI), we need to consider how it is that mobile networks are built.
> >>
> >> In terms of P2P, traffic on today’s mobile networks is predominantly
> anchored at a central point, not P2P despite the associated engineering
> inefficiencies.   There are very good reasons for this:
> >>
> >> In terms of the major use-cases today (voice over LTE and mobile
> broadband) as they move to 5G, I really don’t see any need to change the
> underlying tunnelling protocol because It Works.
> >>
> >> However, for NEW 5G use-cases such as Ultra-Low Latency and edge-based
> services we should be considering whether GTP is the correct choice
> provided we can meet the commercial and regulatory requirements of the MNOs
> in terms of LI and charging.
> >>
> >> David
> >>
> from GTP, even a partial change.  A study group would have to work out what
> services GTP provides.  Which services it does well and which it does
> poorly.  Then how to better meet the service needs today and going forward.
> >>
> >> Bob
> >>