Subject: Re: [5gangip] MINUTES of side meeting in Singapore

From: Alexandre Petrescu <[email-masked]>
Date: Tue, 28 Nov 2017 11:58:04 +0100

Le 28/11/2017 à 10:38, [email-masked] a écrit :
> Dear all,
> 
> following the fruitful and extensive discussion during the side meeting 
> which I could only follow partially via phone/webex I try to summarize 
> the outcome as follows:
> 
> About 20 people attended the 5G @IETF / ATIC / 5GangIP side meeting in 
> Singapore – with about another 20 remote.
> 
> The agenda covered presentations on ‘5G Releases Phases Road Maps’ by 
> Alex Petrescu showing the 3GPP timeline and slides which had been 
> displayed during a recent ICT Proposer's Day. EU project  calls and 
> questions completed the slot.
> 
> The slides ‘5G CT4 Protocol Choices’ on the protocol decisions taken for 
> SBA (Service Based Architecture) during last 3G meetings were prepared 
> by Georg Meyer who unfortunately couldn’t make it and have been 
> presented by Marco Liebsch.
> 
> Satoru Matsushima shared with us ‘5G CT4 WID on IPv6 and SRv6’ on a 
> proposed Study Item in 3GPP while SRv6 has also been proposed and 
> meanwhile nearly agreed on at DMM WG session.
> 
> In ‘Latest on ILNP’ Saleem Bhatti gave an overview on 
> publications/results for ILNP hand-off performance in comparison to 
> MIPv6. ILNP has been implemented in Linux.
> 
> Dino Farinacci presented ‘LISP for Mobile Network’ proposing tunneling 
> and mapping mechanisms in current EPC.
> 
> Due to lack of time the topic ‘5G Deployment Issues’ planned by Cameron 
> Baynes could not be discussed.
> 
> One issue raised by several participants, e.g. Peter Ashwood, was the 
> idea to orient this group's activities in order to eventually produce a 
> joint white paper and related contributions addressing rather 3GPP than 
> IETF on how different Identity – Locator split approaches to manage 
> mainly User Plane traffic … e.g. comparing performance estimations for 
> expected 5G architecture when applying LISP/ILNP/ILA/… instead of 
> GTP/PMIP/SRv6.

The idea of a whitepaper to progress this sounds good to me.

We would need though IETF aspects considered, in order to have IETF 
blessing on this email list hosted at IETF.

Do you know of a 3GPP document that talks id-locator split?  Because 
there are many IETF documents that do.

Alex

> 
> Other details of the discussion e.g. on different addressing issues 
> (e.g. /64 as prefix/locator in different approaches) have been discussed 
> on the list meanwhile.
> 
> We thank everybody for contributing especially the presenters for their 
> effort!
> 
> All, please add details which I missed and clarify or correct 
> misunderstandings …
> 
> Thanks!
> 
> Best regards
> 
> Dirk
> 
>     *From:*5gangip [mailto:[email-masked]
>     <mailto:[email-masked]>] *On Behalf Of *Behcet Sarikaya
>     *Sent:* Donnerstag, 16. November 2017 08:46
>     *To:* Alexandre Petrescu <[email-masked]
>     <mailto:[email-masked]>>; [email-masked]
>     <mailto:[email-masked]>
>     *Subject:* [5gangip] Agenda slides
>

---

From: <[email-masked]>
Date: Tue, 28 Nov 2017 09:38:59 +0000

Dear all,
following the fruitful and extensive discussion during the side meeting which I could only follow partially via phone/webex I try to summarize the outcome as follows:
About 20 people attended the 5G @IETF / ATIC / 5GangIP side meeting in Singapore – with about another 20 remote.
The agenda covered presentations on ‘5G Releases Phases Road Maps’ by Alex Petrescu showing the 3GPP timeline and slides which had been displayed during a recent ICT Proposer's Day. EU project  calls and questions completed the slot.
The slides ‘5G CT4 Protocol Choices’ on the protocol decisions taken for SBA (Service Based Architecture) during last 3G meetings were prepared by Georg Meyer who unfortunately couldn’t make it and have been presented by Marco Liebsch.
Satoru Matsushima shared with us ‘5G CT4 WID on IPv6 and SRv6’ on a proposed Study Item in 3GPP while SRv6 has also been proposed and meanwhile nearly agreed on at DMM WG session.
In ‘Latest on ILNP’ Saleem Bhatti gave an overview on publications/results for ILNP hand-off performance in comparison to MIPv6. ILNP has been implemented in Linux.
Dino Farinacci presented ‘LISP for Mobile Network’ proposing tunneling and mapping mechanisms in current EPC.
Due to lack of time the topic ‘5G Deployment Issues’ planned by Cameron Baynes could not be discussed.
One issue raised by several participants, e.g. Peter Ashwood, was the idea to orient this group's activities in order to eventually produce a joint white paper and related contributions addressing rather 3GPP than IETF on how different Identity – Locator split approaches to manage mainly User Plane traffic … e.g. comparing performance estimations for expected 5G architecture when applying LISP/ILNP/ILA/… instead of GTP/PMIP/SRv6.
Other details of the discussion e.g. on different addressing issues (e.g. /64 as prefix/locator in different approaches) have been discussed on the list meanwhile.
We thank everybody for contributing especially the presenters for their effort!
All, please add details which I missed and clarify or correct misunderstandings …
Thanks!
Best regards
Dirk
From: 5gangip [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Behcet Sarikaya
Sent: Donnerstag, 16. November 2017 08:46
To: Alexandre Petrescu <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [5gangip] Agenda slides

---

From: <[email-masked]>
Date: Tue, 28 Nov 2017 15:41:35 +0000

Hi Alex,
to my knowledge there is no 3GPP doc (neither TR/TS nor even TempDoc) so far on Id-Loc split ... only Saturos mentioned proposal based on SRv6 ...
But that may also well depend on the established division of work between IETF and 3GPP ...
Anyone to correct me?

Best Regards
Dirk 

-----Original Message-----
From: Alexandre Petrescu [mailto:[email-masked]] 
Sent: Dienstag, 28. November 2017 11:58
To: von Hugo, Dirk <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: MINUTES of side meeting in Singapore

Le 28/11/2017 à 10:38, [email-masked] a écrit :
> Dear all,
> 
> following the fruitful and extensive discussion during the side 
> meeting which I could only follow partially via phone/webex I try to 
> summarize the outcome as follows:
> 
> The slides ‘5G CT4 Protocol Choices’ on the protocol decisions taken 
> for SBA (Service Based Architecture) during last 3G meetings were 
> prepared by Georg Meyer who unfortunately couldn’t make it and have 
> been presented by Marco Liebsch.
> 
> idea to orient this group's activities in order to eventually produce 
> a joint white paper and related contributions addressing rather 3GPP 
> than IETF on how different Identity – Locator split approaches to 
> manage mainly User Plane traffic … e.g. comparing performance 
> estimations for expected 5G architecture when applying LISP/ILNP/ILA/… 
> instead of GTP/PMIP/SRv6.

We would need though IETF aspects considered, in order to have IETF blessing on this email list hosted at IETF.

Do you know of a 3GPP document that talks id-locator split?  Because there are many IETF documents that do.

Alex

> (e.g. /64 as prefix/locator in different approaches) have been 
> discussed on the list meanwhile.
>

---

From: Satoru Matsushima <[email-masked]>
Date: Tue, 28 Nov 2017 07:51:00 -0800

Dirk, Alex,

Let me make clear what the u-plane study proposal is: It is a proposal to study native IPv6 base protocols to be studied as _user-plane_ protocol including GTP-U. Noted that control-plane protocol study is out of scope of this SID.

The revised SID is available on the following link:

“Study on User-plane protocol"
http://www.3gpp.org/ftp/tsg_ct/WG4_protocollars_ex-CN4/TSGCT4_81_Reno/Docs/C4-176172.zip

As I said in the meeting, we have stepped back to indicate candidate protocols from specific protocol study.

Cheers,
--satoru

> 2017/11/28 7:41、<[email-masked]> <[email-masked]>のメール:
> 
> Hi Alex,
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 28 Nov 2017 12:20:05 -0800

You can also find documents in ETSI/NGP on ID/Loc split.

Dino

> On Nov 28, 2017, at 7:51 AM, Satoru Matsushima <[email-masked]> wrote:
> 
> Dirk, Alex,
>

---

From: Bill Gage <[email-masked]>
Date: Tue, 28 Nov 2017 22:40:58 +0000

Also note that the 3GPP control plane messages (e.g. Path Switch)  convey other information in addition to changes in the user plane tunnel end point. The control plane messages are out-of-band with respect to the user plane and are forwarded through control plane functions that make use of that other information. In other words, changing the tunnel end point address is almost a side-effect of the overall procedure,

During the study item phase, there was some discussion of using in-band signalling to control path switching for mobility but these solutions were deemed to be inefficient and/or caused race conditions compared to the out-of-band path switching mechanism.

With respect to GTP-U, a number of extension headers have been defined that support 3GPP-specific operations. I suspect that this is one reason that 3GPP prefers to use their in-house protocol -- they can make changes without being beholden to, or having to wait for, another SDO. This is just a practical issue.

Cheers ...

/bill

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Satoru Matsushima
Sent: Tuesday, November 28, 2017 10:51 AM
To: [email-masked]; Alexandre Petrescu <[email-masked]>
Cc: [email-masked]; AshwoodsmithPeter <[email-masked]>
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Dirk, Alex,

Cheers,
--satoru

>> About 20 people attended the 5G @IETF / ATIC / 5GangIP side meeting 
>> in Singapore – with about another 20 remote.
>> 
>> Dino Farinacci presented ‘LISP for Mobile Network’ proposing 
>> tunneling and mapping mechanisms in current EPC.
>> 
>> estimations for expected 5G architecture when applying 
>> LISP/ILNP/ILA/… instead of GTP/PMIP/SRv6.
>

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 28 Nov 2017 15:29:34 -0800

> With respect to GTP-U, a number of extension headers have been defined that support 3GPP-specific operations. I suspect that this is one reason that 3GPP prefers to use their in-house protocol -- t…

For LISP, any deployment can use JSON strings as RLOC-records. So you can add new things without a SDO specification. And a good vendor implementation will allow the customer to decide the contents of a JSON string.

That means, even people in the IETF is not beholden to the LISP WG. 

Dino

---

From: Tom Herbert <[email-masked]>
Date: Tue, 28 Nov 2017 15:49:26 -0800

> With respect to GTP-U, a number of extension headers have been defined that support 3GPP-specific operations. I suspect that this is one reason that 3GPP prefers to use their in-house protocol -- t…
Thanks for the information Bill. Could you give some examples GTP-U
extension headers that are commonly used.

Tom

---

From: Satoru Matsushima <[email-masked]>
Date: Tue, 28 Nov 2017 16:27:30 -0800

Hello Tom,

>> [...]

> extension headers that are commonly used.

They look the attached pic.
--satoru

---

From: Satoru Matsushima <[email-masked]>
Date: Tue, 28 Nov 2017 16:34:03 -0800

Oops, it should be this attached pic in terms of extension header.

sorry,
--satoru

> 2017/11/28 16:27、Satoru Matsushima <[email-masked]>のメール:
> 
> Hello Tom,
> 
>>> [...]
>

---

From: Tom Herbert <[email-masked]>
Date: Tue, 28 Nov 2017 16:46:29 -0800

On Tue, Nov 28, 2017 at 4:34 PM, Satoru Matsushima <
[email-masked]> wrote:

> Hi Satoru,

I got that, but the spec really doesn't answer my question. Are GTP
extension headers actually used in deployment with PDUs? If so, which
specific extension headers are used? Or, is this a mechanism that satisfies
the requirement for an extensible protocol, but in practice they aren't
used because interoperability is hard, they are significant on the wire
overhead, and processing them in hardware is even harder? In other words,
did they follow the same path of not being used as IPv4 options, IPv6
extension headers, and nearly every other L3 dataplane protocol
extensibility mechanism ever conceived? ;-).

Tom

> With respect to GTP-U, a number of extension headers have been defined
> that support 3GPP-specific operations. I suspect that this is one reason
> that 3GPP prefers to use their in-house protocol -- they can make changes
> without being beholden to, or having to wait for, another SDO. This is just
> a practical issue.
>

---

From: Satoru Matsushima <[email-masked]>
Date: Tue, 28 Nov 2017 18:57:17 -0800

So let me ask a question to collect your opinions:

How long do you guys expect to propose the alternative of GTP-U in your mind after fully understand how GTP-U works and covers all its features?

1. It would be okay less than half year.
2. It may require almost one year.
3. More than one year.

I’m revising SID to set time frame of the user-plane protocol study work. So any of your opinions are helpful to set the time.

Cheers,
--satoru

> 2017/11/28 16:46、Tom Herbert <[email-masked]>のメール:
> 
> 
> 
> On Tue, Nov 28, 2017 at 4:34 PM, Satoru Matsushima <[email-masked]> wrote:
> I got that, but the spec really doesn't answer my question. Are GTP extension headers actually used in deployment with PDUs? If so, which specific extension headers are used? Or, is this a mechanism that satisfies the requirement for an extensible protocol, but in practice they aren't used because interoperability is hard, they are significant on the wire overhead, and processing them in hardware is even harder? In other words, did they follow the same path of not being used as IPv4 options, IPv6 extension headers, and nearly every other L3 dataplane protocol extensibility mechanism ever conceived? ;-).
> 
> Tom
>   
> sorry,
> --satoru
>

---

From: Bill Gage <[email-masked]>
Date: Wed, 29 Nov 2017 14:18:15 +0000

Hello Tom -
	Oh yes, the extension headers are used in practice. 5G will add at least two more to define 5G-specific containers for the NG and Xn interfaces. The contents of the containers are defined in other, application layer specs.

One other thing to note -- the Path Switch transaction used to redirect traffic to a new serving base station can also change the end point address used at the other end of the tunnel, allowing a change in the mobility anchor point at the same time.

Cheers ...

/bill

-----Original Message-----
From: Tom Herbert [mailto:[email-masked]] 
Sent: Tuesday, November 28, 2017 7:46 PM
To: Satoru Matsushima <[email-masked]>
Cc: Bill Gage <[email-masked]>; [email-masked]
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Hi Satoru,

Tom
  
sorry,
--satoru

Hello Tom,

[...]

With respect to GTP-U, a number of extension headers have been defined that support 3GPP-specific operations. I suspect that this is one reason that 3GPP prefers to use their in-house protocol -- they can make changes without being beholden to, or having to wait for, another SDO. This is just a practical issue.
Thanks for the information Bill. Could you give some examples GTP-U extension headers that are commonly used.

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 29 Nov 2017 09:25:47 -0600

On Tue, Nov 28, 2017 at 8:57 PM, Satoru Matsushima <
[email-masked]> wrote:

> How long do you guys expect to propose the alternative of GTP-U in your
> mind after fully understand how GTP-U works and covers all its features?
>
> I’m revising SID to set time frame of the user-plane protocol study work.
> So any of your opinions are helpful to set the time.
>
>
I would say at least one year, the year of 2018.

Regards,
Behcet

> >>>> With respect to GTP-U, a number of extension headers have been
> defined that support 3GPP-specific operations. I suspect that this is one
> reason that 3GPP prefers to use their in-house protocol -- they can make
> changes without being beholden to, or having to wait for, another SDO. This
> is just a practical issue.
> >>>>

---

From: Ca By <[email-masked]>
Date: Wed, 29 Nov 2017 16:57:37 +0000

> I would say at least one year, the year of 2018.

More.

And just as general point of feedback, folks who are not familiar with the
operations and design requirements of existing 3GPP mobility system are
highly unlikely to find much traction for their green field approach (ILNP,
ILA, LISP)

Layering those approaches on the existing systems does not provide much
value, and replacing the existing system with something that does not
meeting existing requirements is likely to not get much traction.

There has been a lot of “outside in” approaches here, which is good. But i
think folks need to more clearly articulate the requirements they are
trying to meet. And a good starting point is knowing where 3gpp is today.

One could describe the efforts here as naive hubris, but i’ll admit that is
sometimes what innovation looks like. But, please consider that the 3gpp
mobility system is not a wifi hotspot, it identifies 5 generations of radio
systems and connects billions of users with global mobility.... and
billing... and Lawful Intercept and ....    It is 20+ years old, and has
layer upon layers of features / tech debt.

 It will not go down quickly, and the case for the successive technology
needs to be air tight (better and cheaper and faster and no risk)

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 08:59:22 -0800

> There has been a lot of “outside in” approaches here, which is good. But i think folks need to more clearly articulate the requirements they are trying to meet. And a good starting point is knowing where 3gpp is today. 

How about this sort of articulation:

A single requirement: Shortest path from UE to UE.

Can that fly without solution replacement but with solution augmentation?

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 09:01:38 -0800

> One could describe the efforts here as naive hubris, but i’ll admit that is sometimes what innovation looks like. But, please consider that the 3gpp mobility system is not a wifi hotspot, it identifies 5 generations of radio systems and connects billions of users with global mobility.... and billing... and Lawful Intercept and ....    It is 20+ years old, and has layer upon layers of features / tech debt.

So note, if this is the case and 3GPP is not open to change, then the likes of Google Fi will obviously win. I’d put my money on Fi, its going to win anyways. Because Google Fi can give me roaming across 3GPP and 802.11.

Dino

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 29 Nov 2017 11:19:17 -0600

Hi Dino,

On Wed, Nov 29, 2017 at 11:01 AM, Dino Farinacci <[email-masked]>
wrote:

> > One could describe the efforts here as naive hubris, but i’ll admit that
> is sometimes what innovation looks like. But, please consider that the 3gpp
> So note, if this is the case and 3GPP is not open to change, then the
> likes of Google Fi will obviously win. I’d put my money on Fi, its going to
> win anyways. Because Google Fi can give me roaming across 3GPP and 802.11.
>
>
Maybe so but here the issue is what to do with Satoru's WID.
I think Cameron is right, 3GPP mobility is an integrated system developed
and revised over 20+ years. It is Layer 2 (NAS) and Layer 3 it is connected
to the control plane involving entities like MME, it is QoS, LI, charging
and so on.

We seem to be looking into a small portion of this monster, i.e. .GTP-U and
say that we can do better.

In the past Bob has proposed studying the different fields in GTP-U and see
how we can refine our greenfield approach. in order to integrate beeter
with 3GPP protocols for 5G.

I am afraid if we don't do those type of things then we are going to face
another disappointment.

Regards,
Behcet

---

From: Tom Herbert <[email-masked]>
Date: Wed, 29 Nov 2017 09:38:23 -0800

On Wed, Nov 29, 2017 at 9:19 AM, Behcet Sarikaya <[email-masked]> wrote:
> how we can refine our greenfield approach. in order to integrate beeter with
> 3GPP protocols for 5G.
>
Behcet,

That makes me wonder what you consider the previous disappointments to
be :-). Maybe your referring to the fact that it took twenty years for
IPv6 to get any traction on replacing IPv4 as the Internet protocol.
No doubt that there was period of naive hubris for that also. But
nevertheless, it is getting traction as a superior protocol and
sunsetting IPv4 is in motion. If there were no early efforts to
develop IPv6 this never could have happened. I do hope that we've
learning some lessons from experiences like this that could be applied
by this group about what it takes to provide alternatives to fully
entrenched protocols.

Tom

---

From: "Sri Gundavelli (sgundave)" <[email-masked]>
Date: Wed, 29 Nov 2017 17:42:03 +0000

> One could describe the efforts here as naive hubris, but i'll admit that is sometimes what innovation looks like. But, please consider that the 3gpp mobility system is not a wifi hotspot, it identifies 5 generations of radio systems and connects billions of users with global mobility.... and billing... and Lawful Intercept and ....    It is 20+ years old, and has layer upon layers of features / tech debt.

Yes. Its a very complex system. But, I always though, at least of some of that complexity is also by design and was used as a vendor-lock, so no new players can get in so easily. Looking at what we can do today with unlicensed Wi-Fi radio in enterprises and the applications we can support, vs. the complexity with 3GPP system using a licensed radio, there is no comparison.

Sri

---

From: Ca By <[email-masked]>
Date: Wed, 29 Nov 2017 18:58:42 +0000

I believe you are saying Google Fi gives you access, not strict session IP
mobility like 3gpp... nomadic mobility is in Google Fi.

To that end, i agree.  Embracing application level resilience to addess and
topology change is much more economical and fit for purpose than network
based mobility solution (espensive, lots of centralized state, fragile)
This is why i have been fond of ILNP, but the solution is better fit in the
app than the host.

Quic is on the same trajectory.

---

From: <[email-masked]>
Date: Wed, 29 Nov 2017 19:03:22 +0000

Dino

I think in certain geographies where cellular services are still limited and expensive, the there is a place for services such as Google Fi.

However, in many geographies, cellular service is so ubiquitous and so cheap that people are starting to not use WiFi at all.   

I think we will also see changes in the ownership model of cellular infrastructure as well in the next 10-20 years more towards public transport and competing services as opposed to entire competing infrastructure (think trains, electricity, etc, where infrastructure is held either jointly or publicly). 

Just as a proof-point, my son has a 20GB LTE service attached to our DSL service (FTTC here - only 75Mbit/s) which we pay £10/month for.

I think 3GPP is open to change because the backhaul is proving to be the bottle-neck between eNB/gNB and core. 

David
-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Dino Farinacci
Sent: 29 November 2017 17:02
To: Ca By <[email-masked]>
Cc: [email-masked]; [email-masked]; Bill Gage <[email-masked]>; Satoru Matsushima <[email-masked]>; Tom Herbert <[email-masked]>
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Dino

---

From: John Kaippallimalil <[email-masked]>
Date: Wed, 29 Nov 2017 19:18:57 +0000

> A single requirement: Shortest path from UE to UE.

1. D2D (device-to-device) mode - UE can use PRoSe (Proximity Service) for discovery and radio parameter acquisition. Shortest path from UE-UE.
2. If the UEs are not "proximate"/served by a single radio node, they can use a service APN / DNN to select a distributed gateway.  Each of the UE's first hop routers are the distributed gateways (with IP routing in between).

John

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Dino Farinacci
Sent: Wednesday, November 29, 2017 10:59 AM
To: Ca By <[email-masked]>
Cc: [email-masked]; Behcet Sarikaya <[email-masked]>; Bill Gage <[email-masked]>; Satoru Matsushima <[email-masked]>; Tom Herbert <[email-masked]>
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Dino

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 29 Nov 2017 13:40:27 -0600

On Wed, Nov 29, 2017 at 12:58 PM, Ca By <[email-masked]> wrote:

>> > One could describe the efforts here as naive hubris, but i’ll admit
>> that is sometimes what innovation looks like. But, please consider that the
>> 3gpp mobility system is not a wifi hotspot, it identifies 5 generations of
>> radio systems and connects billions of users with global mobility.... and
>  I believe you are saying Google Fi gives you access, not strict session
> IP mobility like 3gpp... nomadic mobility is in Google Fi.
>
> To that end, i agree.  Embracing application level resilience to addess
> and topology change is much more economical and fit for purpose than
> network based mobility solution (espensive, lots of centralized state,
> fragile) This is why i have been fond of ILNP, but the solution is better
> fit in the app than the host.
>
>
Yes but ILNP has nothing defined for the hosts that are not upgraded to
support ILNP, e.g. servers, and also its source code is not in Linux
distribution and it requires transport layer compatibility, and so on.
Are you still on ILNP?

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 12:53:25 -0800

> I think Cameron is right, 3GPP mobility is an integrated system developed and revised over 20+ years. It is Layer 2 (NAS) and Layer 3 it is connected to the control plane involving entities like MME, it is QoS, LI, charging and so on.

That is not a useful point but to only convey they don’t know how to change and innovate. Part of innovation is deciding what to throw out that is old and costly.

> We seem to be looking into a small portion of this monster, i.e. .GTP-U and say that we can do better.

People don’t yet understand how the mapping system can help. I am proposing lisp-mobile-network just as a first use-case for GTP-U. Once that simple use-case for shortest path UE-to-UE can be tried (maybe in a slice), they you can leverage the mapping system that is already deployed for future stuff.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 12:56:38 -0800

>  I believe you are saying Google Fi gives you access, not strict session IP mobility like 3gpp... nomadic mobility is in Google Fi. 

That is right.

> To that end, i agree.  Embracing application level resilience to addess and topology change is much more economical and fit for purpose than network based mobility solution (espensive, lots of centralized state, fragile) This is why i have been fond of ILNP, but the solution is better fit in the app than the host. 

I keep going back and forth on this. But you having said that, all of ILNP, ILA, and LISP-MN can run in the UE.

> Quic is on the same trajectory. 

Yes indeed.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 12:57:36 -0800

I intended UE-to-UE ANYWHERE. Even to a Wifi only connected UE.

Dino

> On Nov 29, 2017, at 11:18 AM, John Kaippallimalil <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 13:01:15 -0800

> I think in certain geographies where cellular services are still limited and expensive, the there is a place for services such as Google Fi.

I think its independent of geographies where Google can offer cheaper and simpler billing mechanisms. The end-user will make the choice.

> However, in many geographies, cellular service is so ubiquitous and so cheap that people are starting to not use WiFi at all.   

What about concrete walls in basements?

> I think we will also see changes in the ownership model of cellular infrastructure as well in the next 10-20 years more towards public transport and competing services as opposed to entire competin…

Yep.

> Just as a proof-point, my son has a 20GB LTE service attached to our DSL service (FTTC here - only 75Mbit/s) which we pay £10/month for.

But he can only send 50mbps to my AT&T phone. ;-)

> I think 3GPP is open to change because the backhaul is proving to be the bottle-neck between eNB/gNB and core. 

From many I have talked to experienced with the SDO, that is not at all clear.

Dino

---

From: <[email-masked]>
Date: Wed, 29 Nov 2017 21:59:42 +0000

It's all about the economics...

We've not see Google Fi take off over here as there really is no need for it.  I have my Three SIM for 4G when I'm travelling and it just works.  Compared to trying to attach to WiFI networks in hotels, it is a breeze (and cheap - I stayed at an hotel recently that charged £22/day for WiFi - that is more than I pay for 15GB of LTE on my Three SIM for a month). 

(BTW, the comment about the DSL was from a billing perspective - I pay £39.99/month for 75Mbit/s broadband and then can buy a SIM on EE for an additional £10/month.  The UK is still quite expensive for broadband service unfortunately).

D

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: 29 November 2017 21:01
To: Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Tom Herbert <[email-masked]>
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Yep.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 14:10:33 -0800

> We've not see Google Fi take off over here as there really is no need for it.  I have my Three SIM for 4G when I’m 

It’s not about the product, its about the idea and how the idea can be disruptive.

> travelling and it just works.  Compared to trying to attach to WiFI networks in hotels, it is a breeze (and cheap - I stayed at an hotel recently that charged £22/day for WiFi - that is more than I pay for 15GB of LTE on my Three SIM for a month). 

What about when hand-sets want to be carrier agnostic/independent and want to roam without transport session disruption?

> (BTW, the comment about the DSL was from a billing perspective - I pay £39.99/month for 75Mbit/s broadband and then can buy a SIM on EE for an additional £10/month.  The UK is still quite expensive…

Got it.

Dino

---

From: Ted Hardie <[email-masked]>
Date: Wed, 29 Nov 2017 14:21:59 -0800

On Wed, Nov 29, 2017 at 1:59 PM, <[email-masked]> wrote:

> We've not see Google Fi take off over here as there really is no need for
> it.  I have my Three SIM for 4G when I'm travelling and it just works.
> Compared to trying to attach to WiFI networks in hotels, it is a breeze
> (and cheap - I stayed at an hotel recently that charged £22/day for WiFi -
> that is more than I pay for 15GB of LTE on my Three SIM for a month).
>

Fi is a multi-network MVNO; it uses several different cellular networks
within its "native" coverage area, and it provides global roaming using the
same method.  It does not require the use of WiFi, though using it of
course reduces the amount of data delivered over the cellular networks.

regards,

Ted

> (BTW, the comment about the DSL was from a billing perspective - I pay
> £39.99/month for 75Mbit/s broadband and then can buy a SIM on EE for an
> additional £10/month.  The UK is still quite expensive for broadband
> service unfortunately).
>
> D
>
>
> Cc: [email-masked]; [email-masked]; [email-masked];
> [email-masked]; [email-masked]; Tom Herbert <
> [email-masked]>
> > I think in certain geographies where cellular services are still limited
> and expensive, the there is a place for services such as Google Fi.
>
> I think its independent of geographies where Google can offer cheaper and
> simpler billing mechanisms. The end-user will make the choice.
>
> > However, in many geographies, cellular service is so ubiquitous and so
> cheap that people are starting to not use WiFi at all.
>
> > I think we will also see changes in the ownership model of cellular
> infrastructure as well in the next 10-20 years more towards public
> transport and competing services as opposed to entire competing
> infrastructure (think trains, electricity, etc, where infrastructure is
> held either jointly or publicly).
>
> Yep.
>
> > Just as a proof-point, my son has a 20GB LTE service attached to our DSL
> service (FTTC here - only 75Mbit/s) which we pay £10/month for.
>
> > Cc: [email-masked]; [email-masked]; Bill Gage <[email-masked]>;
> Satoru Matsushima <[email-masked]>; Tom Herbert <
> [email-masked]>

---

From: Bill Gage <[email-masked]>
Date: Wed, 29 Nov 2017 22:26:20 +0000

Note that even for UE to UE, the path may not always be the shortest path. The traffic may need to pass through specific network functions (e.g. for firewalls, LI, policy enforcement, etc) so some traffic steering may be required. You might be better to say "the shortest path that traverses all of the required network functions". Now we start to get into the realm of slicing and/or SFC where something like a mobility anchor is just one of several required NFs along the selected SFP.

Cheers ... 

/bill

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Wednesday, November 29, 2017 3:53 PM
To: [email-masked]
Cc: Ca By <[email-masked]>; [email-masked]; Bill Gage <[email-masked]>; Satoru Matsushima <[email-masked]>; Tom Herbert <[email-masked]>
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 14:33:17 -0800

And that is a feature. And why not extend it to other data-links. 

Dino

> On Nov 29, 2017, at 2:21 PM, Ted Hardie <[email-masked]> wrote:
> 
> Fi is a multi-network MVNO; it uses several different cellular networks within its "native" coverage area, and it provides global roaming using the same method.  It does not require the use of WiFi, though using it of course reduces the amount of data delivered over the cellular networks.  
> 
> regards,
> 
> Ted
> 
>

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 29 Nov 2017 14:34:34 -0800

> Note that even for UE to UE, the path may not always be the shortest path. The traffic may need to pass through specific network functions (e.g. for firewalls, LI, policy enforcement, etc) so some…

That’s the problem. You don’t do these things in the data-plane. You do them at the control-plane. And 3GPP knows how to do setup stuff, that is control-plane stuff.

Dino

---

From: <[email-masked]>
Date: Wed, 29 Nov 2017 22:55:18 +0000

I understand that, but when you can walk into any shop and pick up a SIM for free for any one of the dozens of MVNO all competing on price and pop it into your device, it is difficult to say what it is that it is providing.

After all, the truth is that there are only four (you could say five) carrier networks all offering roughly similar coverage patterns and services.  The issue is how to serve the areas which are commercially uneconomic to serve (rural communities) but that requires a more enlightened attitude to the ownership of infrastructure than our current short-term government has in mind…. (political point over 😊)

And global roaming really isn’t too much of a thing any more – at least with the EU directive now fully implemented and several MNOs extending that to non-EU countries, I really find I don’t think about roaming any more (at least to the destinations I go which is the US and with the EU).

From: Ted Hardie [mailto:[email-masked]]
Sent: 29 November 2017 22:22
To: Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>
Cc: [email-masked]; [email-masked]; Tom Herbert <[email-masked]>; [email-masked]; [email-masked]; [email-masked]; Cameron Byrne <[email-masked]>
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

On Wed, Nov 29, 2017 at 1:59 PM, <[email-masked]<mailto:[email-masked]>> wrote:
It's all about the economics...

D

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]<mailto:[email-masked]>]
Sent: 29 November 2017 21:01
To: Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Tom Herbert <[email-masked]<mailto:[email-masked]>>
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Yep.

Dino

> From: 5gangip [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Dino Farinacci
> To: Ca By <[email-masked]<mailto:[email-masked]>>
> Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Bill Gage <[email-masked]<mailto:[email-masked]>>; Satoru Matsushima <[email-masked]<mailto:[email-masked]>>; Tom Herbert <[email-masked]<mailto:[email-masked]>>
> [email-masked]<mailto:[email-masked]>

_______________________________________________
5gangip mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/5gangip

---

From: Tom Herbert <[email-masked]>
Date: Wed, 29 Nov 2017 15:15:09 -0800

> That’s the problem. You don’t do these things in the data-plane. You do them at the control-plane. And 3GPP knows how to do setup stuff, that is control-plane stuff.
+1

Also it's not clear that any of this is _required_ for 5G. Any
circuitous route adds latency to the point where even speed of light
is a bottleneck, and every hop in the path decreases reliability. This
will make it harder to provide any real-time latency guarantees.
Consider V2V applications where urgent advisory information is being
exchanged so that latency is critical (this is where the 1ms latency
goal becomes relevant). In this scenario we really don't want packets
to go through a base station, much less go through several levels of
network functions deep within the network.

Tom

---

From: Satoru Matsushima <[email-masked]>
Date: Wed, 29 Nov 2017 17:53:31 -0800

Thank you Behcet, Cameron,

Yes I agree, it’ll take one or more years. Thanks.

Best regards,
--satoru

> 2017/11/29 8:57、Ca By <[email-masked]>のメール:
> 
> 
> On Wed, Nov 29, 2017 at 7:25 AM Behcet Sarikaya <[email-masked]> wrote:
> On Tue, Nov 28, 2017 at 8:57 PM, Satoru Matsushima <[email-masked]> wrote:
> And just as general point of feedback, folks who are not familiar with the operations and design requirements of existing 3GPP mobility system are highly unlikely to find much traction for their green field approach (ILNP, ILA, LISP) 
> 
> Layering those approaches on the existing systems does not provide much value, and replacing the existing system with something that does not meeting existing requirements is likely to not get much traction. 
> 
>  It will not go down quickly, and the case for the successive technology needs to be air tight (better and cheaper and faster and no risk)
> 
> 
> 
> 
> 
> Regards,
> Behcet
> Cheers,
> --satoru
>

---

From: Jon Crowcroft <[email-masked]>
Date: Thu, 30 Nov 2017 08:06:02 +0000

> > I think Cameron is right, 3GPP mobility is an integrated system 
> developed and revised over 20+ years. It is Layer 2 (NAS) and Layer 3 it 
> is connected to the control plane involving entities like MME, it is QoS, 
> LI, charging and so on.
> 
> That is not a useful point but to only convey they don’t know how to 
> change and innovate. Part of innovation is deciding what to throw out 
> that is old and costly.
> 

> People don’t yet understand how the mapping system can help. I am 
> proposing lisp-mobile-network just as a first use-case for GTP-U. Once 
> that simple use-case for shortest path UE-to-UE can be tried (maybe in a 
> slice), they you can leverage the mapping system that is already deployed 
> for future stuff.
 
 Dino

this seems the right direction - mapping two control planes in great detail will be massively brittle
and unsustainable to boot - the ue-to-ue approach is where any ietf work should end (pun intended) imho:)

---

From: Bill Gage <[email-masked]>
Date: Thu, 30 Nov 2017 14:47:57 +0000

So what are you proposing? That IETF focus on the user plane traffic steering part (rather than the control plane path setup part)? Fair enough, but that seems to be the type of thing that SFC and SR (and MPLS) are already addressing.

In addition, something like GTP can ride above the SFC or SR solutions to convey application-specific information between the tunnel end points, so I don't see why you would need to bundle discussion of a GTP replacement into this scope.

Cheers ... 

/bill

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Wednesday, November 29, 2017 5:35 PM
To: Bill Gage <[email-masked]>
Cc: [email-masked]
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 08:51:30 -0800

> So what are you proposing? That IETF focus on the user plane traffic steering part (rather than the control plane path setup part)? Fair enough, but that seems to be the type of thing that SFC and…

Yes. A solution that can support UEs that have both IPv6 and IPv4 EIDs over an EPC/Internet that do either IPv6 and IPv4 RLOCs.

I’m all for native IPv6 but we just can depend on ubiquity (and zero IPv4 NAT-traversal) quite yet.

SFC and SR are jsut data-plane solution similar to ILNP, ILA, and LISP. Note the data-plane I am proposing does depend on a simple control-plane where the data-plane nodes have simple and fast access to a mapping database. This control-plane doesn’t need any interaction with the existing control-plane. And it can run side-by-side.

> In addition, something like GTP can ride above the SFC or SR solutions to convey application-specific information between the tunnel end points, so I don't see why you would need to bundle discussi…

If you have a look at draft-farinacci-lisp-mobile-network-01, we encourage continuing to use the GTP-U encapsulation format but just create the dynamic encapsulating tunnels via the mapping system. Note the draft allows the system to run in “legacy” mode if the mapping system says there are no RLOCs for a destination.

Dino

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 08:54:17 -0800

One other thing Bill. Here is the last slide I presented in 5gangip and LISP WG. Meaning we don’t force this down 3GPP’s throat. We say its a beginning of an idea and we evolve it a 3GGP standard, in the 3GPP study groups.

Dino

> On Nov 30, 2017, at 6:47 AM, Bill Gage <[email-masked]> wrote:
>

---

From: Satoru Matsushima <[email-masked]>
Date: Thu, 30 Nov 2017 08:59:40 -0800

Hi Deno, so which study group in 3GPP do you mention?
--satoru

> 2017/11/30 8:54、Dino Farinacci <[email-masked]>のメール:
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 09:02:26 -0800

I don’t know. I need you guys to recommend.

Dino

> On Nov 30, 2017, at 8:59 AM, Satoru Matsushima <[email-masked]> wrote:
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 30 Nov 2017 11:03:35 -0600

On Thu, Nov 30, 2017 at 10:51 AM, Dino Farinacci <[email-masked]>
wrote:

> > So what are you proposing? That IETF focus on the user plane traffic
> steering part (rather than the control plane path setup part)? Fair enough,
> but that seems to be the type of thing that SFC and SR (and MPLS) are
> already addressing.
>
> Yes. A solution that can support UEs that have both IPv6 and IPv4 EIDs
> over an EPC/Internet that do either IPv6 and IPv4 RLOCs.
>
> SFC and SR are jsut data-plane solution similar to ILNP, ILA, and LISP.
> Note the data-plane I am proposing does depend on a simple control-plane
> where the data-plane nodes have simple and fast access to a mapping
> database. This control-plane doesn’t need any interaction with the existing
> control-plane. And it can run side-by-side.
>
> > In addition, something like GTP can ride above the SFC or SR solutions
> to convey application-specific information between the tunnel end points,
> so I don't see why you would need to bundle discussion of a GTP replacement
> into this scope.
>
> If you have a look at draft-farinacci-lisp-mobile-network-01, we
> encourage continuing to use the GTP-U encapsulation format but just create
> the dynamic encapsulating tunnels via the mapping system. Note the draft
> allows the system to run in “legacy” mode if the mapping system says there
> are no RLOCs for a destination.
>
>
Folks,

Maybe it is time to ask for a consensus.

Do we have consensus on the above approach that Dino has nicely summarized?

This was mostly the sense I got from the side meeting in Singapore at the
historic IETF 100.

Behcet

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 30 Nov 2017 11:05:49 -0600

> > Hi Deno, so which study group in 3GPP do you mention?

Should be the same as where your WID is submitted, isn't that CT3?
It should be CT and SA2.

Behcet

> >> One other thing Bill. Here is the last slide I presented in 5gangip and
> LISP WG. Meaning we don’t force this down 3GPP’s throat. We say its a
> beginning of an idea and we evolve it a 3GGP standard, in the 3GPP study
> groups.
> >>
> >> Dino
> >>
> >>
> >>>> Note that even for UE to UE, the path may not always be the shortest
> path. The traffic may need to pass through specific network functions (e.g.
> for firewalls, LI, policy enforcement, etc) so some traffic steering may be
> required. You might be better to say "the shortest path that traverses all
> of the required network functions". Now we start to get into the realm of
> slicing and/or SFC where something like a mobility anchor is just one of
> several required NFs along the selected SFP.
> >>>
> >>> That’s the problem. You don’t do these things in the data-plane. You
> do them at the control-plane. And 3GPP knows how to do setup stuff, that is
> control-plane stuff.
> >>>
> >>> Dino
> >>>
> >>>
> >>

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 30 Nov 2017 18:21:48 +0100

> 1. D2D (device-to-device) mode - UE can use PRoSe (Proximity Service) for discovery and radio parameter acquisition. Shortest path from UE-UE.

I agree with a simple UE-to-UE and D2D requirement.

I want it to lead to more successful proposals than earlier 3G 'Relay' 
proposals.

> 2. If the UEs are not "proximate"/served by a single radio node, they can use a service APN / DNN to select a distributed gateway.  Each of the UE's first hop routers are the distributed gateways (…

Yes, but does that have an id-loc stance?

Alex

---

From: Alexandre Petrescu <[email-masked]>
Date: Thu, 30 Nov 2017 18:40:01 +0100

Le 29/11/2017 à 23:55, [email-masked] a écrit :
> I understand that, but when you can walk into any shop and pick up a SIM 
> for free for any one of the dozens of MVNO all competing on price and 
> pop it into your device, it is difficult to say what it is that it is 
> providing.

Uh?  Is there such a thing as 'walk in shop and pick SIM for free'?

The closest I could see is an automated dispenser of SIM cards: there's 
no human, but still one has to pay, albeit very little.

This model of SIM distribution is very advanced for some, but archaic 
for companies betting on future 'software SIM' business.

> After all, the truth is that there are only four (you could say five) 
> carrier networks all offering roughly similar coverage patterns and 
> services.  The issue is how to serve the areas which are commercially 
> uneconomic to serve (rural communities) but that requires a more 
> enlightened attitude to the ownership of infrastructure than our current 
> short-term government has in mind…. (political point over 😊)
> 
> And global roaming really isn’t too much of a thing any more – at least 

'global roaming' is still a big problem.  Attending IETF I learned that 
I need a dedicated phone per large continent: one for EU, one for Asia 
and one for America.  Or otherwise have a single phone covering all: but 
very expensive.

Second, the emergency call numbers are far from being unified.

What if 'global roaming' meant just one cheap wifi device with IP 
addresses, straight routing, VoIP and facebook for emergency calls.

> with the EU directive now fully implemented and several MNOs extending 
> that to non-EU countries, I really find I don’t think about roaming any 
> more (at least to the destinations I go which is the US and with the EU).

Inter-country roaming in Europe - true, it saw significant leaps 
recenty, butstill has issues.

The most advanced roaming agreements still miss this or that other 
country in Europe.

They have a lesser fair-use limits than in-country, most performant 
peaking at 50GB/duration, where duration varies.  This limit could be 
noticed if you have a webradio in your car (not FM radio), listen to a 
5.1 192khz web streamed radio, and commute in a cross-border area.

The voice quality differs largely when making a call at home or abroad, 
and the latency is immediately sensed even in brief conversations.

Alex

> *From:*Ted Hardie [mailto:[email-masked]]
> *Sent:* 29 November 2017 22:22
> *To:* Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>
> *Cc:* [email-masked]; [email-masked]; Tom Herbert 
> <[email-masked]>; [email-masked]; [email-masked]; 
> [email-masked]; Cameron Byrne <[email-masked]>
> *Subject:* Re: [5gangip] MINUTES of side meeting in Singapore
> 
>     We've not see Google Fi take off over here as there really is no
>     need for it.  I have my Three SIM for 4G when I'm travelling and it
>     just works.  Compared to trying to attach to WiFI networks in
>     hotels, it is a breeze (and cheap - I stayed at an hotel recently
>     that charged £22/day for WiFi - that is more than I pay for 15GB of
>     LTE on my Three SIM for a month).
> 
> within its "native" coverage area, and it provides global roaming using 
> the same method.  It does not require the use of WiFi, though using it 
> of course reduces the amount of data delivered over the cellular networks.
> 
> regards,
> 
> Ted
> 
> 
>     (BTW, the comment about the DSL was from a billing perspective - I
>     pay £39.99/month for 75Mbit/s broadband and then can buy a SIM on EE
>     for an additional £10/month.  The UK is still quite expensive for
>     broadband service unfortunately).
> 
>     D
> 
> 
> 
>     Cc: [email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; Tom Herbert
>     <[email-masked] <mailto:[email-masked]>>
>      > I think in certain geographies where cellular services are still
>     limited and expensive, the there is a place for services such as
>     Google Fi.
> 
>     I think its independent of geographies where Google can offer
>     cheaper and simpler billing mechanisms. The end-user will make the
>     choice.
> 
>      > However, in many geographies, cellular service is so ubiquitous
>     and so cheap that people are starting to not use WiFi at all.
> 
>      > I think we will also see changes in the ownership model of
>     cellular infrastructure as well in the next 10-20 years more towards
>     public transport and competing services as opposed to entire
>     competing infrastructure (think trains, electricity, etc, where
>     infrastructure is held either jointly or publicly).
> 
>     Yep.
> 
>      > Just as a proof-point, my son has a 20GB LTE service attached to
>     our DSL service (FTTC here - only 75Mbit/s) which we pay £10/month for.
> 
>      > I think 3GPP is open to change because the backhaul is proving to
>     be the bottle-neck between eNB/gNB and core.
> 
>      > From: 5gangip [mailto:[email-masked]
>     <mailto:[email-masked]>] On Behalf Of Dino Farinacci
>      > To: Ca By <[email-masked] <mailto:[email-masked]>>
>      > Cc: [email-masked] <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>; Bill Gage <[email-masked]
>     <mailto:[email-masked]>>; Satoru Matsushima
>     <[email-masked] <mailto:[email-masked]>>;
>     Tom Herbert <[email-masked] <mailto:[email-masked]>>
>      >> One could describe the efforts here as naive hubris, but i’ll
>     admit that is sometimes what innovation looks like. But, please
>     consider that the 3gpp mobility system is not a wifi hotspot, it
>     identifies 5 generations of radio systems and connects billions of
>     users with global mobility.... and billing... and Lawful Intercept
>     and ....    It is 20+ years old, and has layer upon layers of
>     features / tech debt.
>      >
>      > So note, if this is the case and 3GPP is not open to change, then
>     the likes of Google Fi will obviously win. I’d put my money on Fi,
>     its going to win anyways. Because Google Fi can give me roaming
>     across 3GPP and 802.11.
>      >
>      > Dino
>      >
>      > [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 09:53:41 -0800

> What if 'global roaming' meant just one cheap wifi device with IP addresses, straight routing, VoIP and facebook for emergency calls.

That means host-routes throughout the Internet. A non-starter. 

Dino

---

From: Bill Gage <[email-masked]>
Date: Thu, 30 Nov 2017 17:54:50 +0000

> Do we have consensus on the above approach that Dino has nicely summarized?

Sorry, but I don't understand what Dino is advocating. He says "yes" in response to my question on whether the IETF focus should be on the user plane traffic steering part (rather than the control plane path setup part) but doesn't indicate how this work (in 5gangip) would be different from work already underway in the SFC, SR and MPLS groups.

Personally, I don't think promotion of ILNP, ILA or LISP in 3GPP will yield meaningful results unless they can be shown to solve a problem that does not currently have a solution or can be shown to offer significant benefits over existing solutions. In the latter case, those benefits need to include the cost justification associated with swapping out the existing solutions.

If all you are looking for is a better mobility solution, I believe that QUIC with dynamic multi-homing offers the best way forward since it allows the mobile operator to remove equipment and mobility anchor functions from their network and push the heavy lifting for maintaining session continuity onto the mobile devices (and the servers ;-).

Cheers ... 

/bill

From: 5gangip [mailto:[email-masked]] On Behalf Of Behcet Sarikaya
Sent: Thursday, November 30, 2017 12:04 PM
To: Dino Farinacci <[email-masked]>
Cc: [email-masked]
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Folks, 

This was mostly the sense I got from the side meeting in Singapore at the historic IETF 100.

Behcet

---

From: <[email-masked]>
Date: Thu, 30 Nov 2017 18:02:57 +0000

<dl> in-line </dl>

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: 30 November 2017 17:40
To: [email-masked]
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Le 29/11/2017 à 23:55, [email-masked] a écrit :
> I understand that, but when you can walk into any shop and pick up a 
> SIM for free for any one of the dozens of MVNO all competing on price 
> and pop it into your device, it is difficult to say what it is that it 
> is providing.

The closest I could see is an automated dispenser of SIM cards: there's no human, but still one has to pay, albeit very little.

This model of SIM distribution is very advanced for some, but archaic for companies betting on future 'software SIM' business

<dl> Walk into virtually any newsagent in London and most will have SIMs for anything from giveaway to at most £1 </dl>

> enlightened attitude to the ownership of infrastructure than our 
> current short-term government has in mind…. (political point over 😊)
> 

'global roaming' is still a big problem.  Attending IETF I learned that I need a dedicated phone per large continent: one for EU, one for Asia and one for America.  Or otherwise have a single phone covering all: but very expensive.

<dl> 5 years ago, I'd have agreed, but I travel with my phone and USB data-stick and rarely have a problem.   Also, we must remember that we a atypical of the general population - most people do not travel for business and will only travel for holiday (2 weeks in the summer).   </dl>

<dl> Agreed, but this is nothing to do with connectivity.  112 has been standardised across the EU for a number of years.<dl>

<dl> My experience of WiFi is it does not offer the quality of service I expect (and get) from LTE.  Voice quality is awful on many VoIP sessions  with packet-drops and re-rates of the codec.  As a musician, I find this INCREDIBLY frustrating and annoying - I will often ask people to revert to a "lower-quality" connection that remains at a constant quality.   This can be evidenced in the reduction of quality of outside broadcast interviews on radio programmes as the broadcasters now grapple with unreliable/packet-loosing IP sessions rather than the ISDN links they used to rely on.  </dl>

> that to non-EU countries, I really find I don’t think about roaming 
> any more (at least to the destinations I go which is the US and with the EU).

Inter-country roaming in Europe - true, it saw significant leaps recenty, butstill has issues.

The most advanced roaming agreements still miss this or that other country in Europe.

<dl> Covers all EU states last time I checked?</dl>

They have a lesser fair-use limits than in-country, most performant peaking at 50GB/duration, where duration varies.  This limit could be noticed if you have a webradio in your car (not FM radio), listen to a
5.1 192khz web streamed radio, and commute in a cross-border area.

<dl> I haven't listened to FM radio for many years - the main station I listen to is BBC Radio 3 which (mostly) uses an AAC-coded multiplex on the national DAB multiplex.  192kbit/s compared to FM is pretty awful - the digital artefacts are very noticeable and annoying.   Even 320kbit/s AAC on DAB is hard-work to listen to for a while (if you want a proof point here, listen to applause on FM, 320kbit/s DAB and 192kbit/s stream and you'll find that the FM is more comfortable on the brain with the 192kbit/s being really broken).

As an aside, this year, the BBC ran a lossless streaming service for the Proms which was superb.  I was in the US for several concerts (bad planning) and ended up trying to stream across WiFi - it didn’t work well (kept buffering).   LTE roaming worked perfectly...</dl>

The voice quality differs largely when making a call at home or abroad, and the latency is immediately sensed even in brief conversations.

Alex

> Fi is a multi-network MVNO; it uses several different cellular 
> networks within its "native" coverage area, and it provides global 
> roaming using the same method.  It does not require the use of WiFi, 
> though using it of course reduces the amount of data delivered over the cellular networks.
> 
> regards,
> 
> Ted
> 
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 10:05:31 -0800

> Sorry, but I don't understand what Dino is advocating. He says "yes" in response to my question on whether the IETF focus should be on the user plane traffic steering part (rather than the control…

5gangip facilitates the interaction between IETF people and 3GPP people. I mean, that is where it COULD bring value. The solutions, not only SFC, SR, and MPLS, are done in the WGs. The draft lisp-mobile-network draft is presented in the LISP WG but I am not proposing it being a working group document. It uses mechnanisms that have been RFC’ed in that working group but really want the combined talent of IETF and 3GPP to work on the solution going foward.

Did that answer your question?

> Personally, I don't think promotion of ILNP, ILA or LISP in 3GPP will yield meaningful results unless they can be 

You could be right.

> shown to solve a problem that does not currently have a solution or can be shown to offer significant benefits over existing solutions. In the latter case, those benefits need to include the cost justification associated with swapping out the existing solutions.

Do you think 3GPP has a UE-to-UE shortest path solution?

> If all you are looking for is a better mobility solution, I believe that QUIC with dynamic multi-homing offers the best way forward since it allows the mobile operator to remove equipment and mobil…

What if the other end supports other transports and not QUIC yet? I am quite sure that Siri anytime soon may not support QUIC as they are proactive with MP-TCP.

Dino

---

From: Bill Gage <[email-masked]>
Date: Thu, 30 Nov 2017 18:19:21 +0000

> Do you think 3GPP has a UE-to-UE shortest path solution?

3GPP does not do network design, they offer a toolkit that vendors and operators can use to design and optimise their networks. And yes, I think the current toolkit can be used to realise an UE-to-UE shortest path solution.

Cheers ... 

/bill

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Thursday, November 30, 2017 1:06 PM
To: Bill Gage <[email-masked]>
Cc: [email-masked]; [email-masked]
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

You could be right.

Dino

---

From: Tom Herbert <[email-masked]>
Date: Thu, 30 Nov 2017 10:32:41 -0800

> What if the other end supports other transports and not QUIC yet? I am quite sure that Siri anytime soon may not support QUIC as they are proactive with MP-TCP.
For that matter MP-TCP could solve the mobility problem as well but
deployment of that has stalled. Or, we can always fallback the idea
that applications can just reconnect when they notice they're address
changes. The problem is that none of these transport layer solutions
are going to provide low latency, they bring in privacy issues if
application visible addresses can be correlated to geo location, and
they represent more protocol ossification.

Tom

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 10:40:41 -0800

So let’s see if the carriers can find all the right tools in the toolkit to get a shortest-path service going at decent CapEx/OpEx.

Dino

> On Nov 30, 2017, at 10:19 AM, Bill Gage <[email-masked]> wrote:
>

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 10:41:54 -0800

> they represent more protocol ossification.

Note, you want UDP to work as well. And you want ping (and traceroute) to test the same paths those other transport use. Needs to be a network-layer solution IMO.

Dino

---

From: Tom Herbert <[email-masked]>
Date: Thu, 30 Nov 2017 10:52:03 -0800

> Note, you want UDP to work as well. And you want ping (and traceroute) to test the same paths those other transport use. Needs to be a network-layer solution IMO.
... and GRE/IP, MPLS/IP, ICMP, SCTP, DCCP, IPIP, etc. There should
never be any fundamental architectural constraints in solution that
limits or precludes use of transport layer protocols over IP. If a
deployment wishes to restrict or optimize certain transport protocols
that's their business, but that cannot be specified as part of a
generic architecture in IETF. That's how the E2E model is supposed to
work.

Tom

---

From: Rex Buddenberg <[email-masked]>
Date: Thu, 30 Nov 2017 11:02:47 -0800

Hmmm,

Jon, the discussion triggers a thought: the best place to get return on
investment for separation of user plane and data plane is _inside_ the
UEs.  
   Consider the case of e-mail.  There are only a few operations by the
OS on the data itself.  Most operations are simply pushing it from one
place to another -- for example, for the I/O port to the hard drive.
Right now the entire OS has ability to monkey with the data (a digital
signature will cut a lot of this down).  Would not a up/dp partition of
the OS help?

</half baked thought>

On Thu, 2017-11-30 at 08:06 +0000, Jon Crowcroft wrote:
> > > We seem to be looking into a small portion of this monster, i.e.
> > > .GTP-U 
> > and say that we can do better.
> >

---

From: Dino Farinacci <[email-masked]>
Date: Thu, 30 Nov 2017 11:03:38 -0800

Couldn’t agree more.

Dino

> On Nov 30, 2017, at 10:52 AM, Tom Herbert <[email-masked]> wrote:
>

---

From: Tom Herbert <[email-masked]>
Date: Thu, 30 Nov 2017 11:44:24 -0800

> signature will cut a lot of this down).  Would not a up/dp partition of
Hi Rex,

This idea comes up every once in a while to turn the problem in an end
host one. It seems to make sense on paper per the smart edge
devices/dumb network model. The problem is that it's simply not
practical. Any solution that requires changes to all hosts on the
Internet for it to work is a non-starter. Obviously the numbers are
staggering: billions of devices, legacy considerations, several
different OSes, thousands of different applications, many protocols.
It's even worse if changes are required on every server as well. It's
many years of development and deployment to just make a dent. IPv6 and
MP-TCP can attest to how hard this is.

There is also a problem in this use case with control. End user
devices can easily be hacked so they can never be trusted. We know
users will attempt to abuse the network by circumventing service
constraints, privacy, and security (example is if we allow
applications to set QoS without cost they tend to set for the highest
service). So in the end, the network cannot trust the UE and so still
needs to implement a significant amount of logic to prevent end
devices from abusing the system.

IMO, the first requirement is that UEs and their applications "just
work". Once they have gotten an IP address from the network the only
thing they need to see is the network delivering they're packets.
Mobility should be transparent for all applications. There will be a
need for an application to signal that flows should get different
service (like a live video versus a movie download), but this is
extended feature applications would want, not something fundamental to
connectivity or mobility. This is a well scoped problem that can
mostly be solved in a UEs local network.

Tom

---

From: John Kaippallimalil <[email-masked]>
Date: Thu, 30 Nov 2017 19:44:52 +0000

> I want it to lead to more successful proposals than earlier 3G 'Relay' 

Both relay and direct are supported in D2D. Control assistance is via the eNB. 
Direct communication UE - UE is possible at distances greater than either WiFi or Bluetooth (~50 m vs. 500 m).
Beyond that, the relay model - where both source UE and Relay links are controlled by the eNB.

> Yes, but does that have an id-loc stance?

Only IP-in-IP with S2c (Mobile IP) and not sure how much is deployed.
Otherwise it is S1 /S2 (network mobility, GTP/PMIP) or S2a/b (network mobility - trusted and untrusted WiFi, - PMIP /GTP). 
S1 with GTP is the most widely deployed. 

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Thursday, November 30, 2017 11:22 AM
To: [email-masked]
Subject: Re: [5gangip] MINUTES of side meeting in Singapore

Alex