Subject: [5gangip] Links to 5G routing evolution live demo slides and video

From: Arashmid Akhavain <[email-masked]>
Date: Fri, 8 Dec 2017 19:01:35 +0000

Hi Everyone,
I would like to thank those who took the time out of their busy schedule and attend our 5G routing evolution live demos. 
We had 3 separate sessions, conducted very productive discussions at the end of each, and received 
valuable comments and feedback that I am sure will be very useful in our ongoing debates.

To summarise, anchorless mobile back-haul via the use of EID-RLOC and a mapping system provides an alternative to existing data path architecture.
The proposed architecture

- Reduces complexity for FMC support and moving between different access technologies
- Simplifies data path and likely the control paths too
- Can reduce delays
- Allows UPF movement in the network
- Can be used to remove GTP and anchor points from the data path
- Enables us to eliminate traffic tromboning effect
- Easily supports UPF load balancing (even for different flows from the same UE)

However, as we all pointed out during these sessions, although packet forwarding, encapsulation method, EID-RLOC distribution and the required control plane require work, these items address one aspect of the mobile back haul: the data path.
In order for EID-RLOC architecture to be viable, it must be able to address all the crucial UPFs that today are provided via the use of GTP tunnels and anchor points such as:

- Policy Enforcement, QoS
- Billing, Statistics, Accounting, Metering
- Lawful Interception, Traffic Monitoring
- Roaming
- MVNO
- IMS interaction
- Inter Carrier Communication
- Interaction with Voice Network
- What about 3G, 2G
- Etc.

Each of the above UPFs require solid investigation, and EID-RLOC architecture should be able to clearly provide an answer in each case before it can be seen as a viable solution. Furthermore, as many of you have already indicated in the mailing list, any proposal should start by talking about issues with the existing architecture, and then focus on how EID-RLOC can resolve these problems. 
It seems that a new study item on U-plane protocol for 5GC was agreed in 3GP CT4 last week. This can provide us with an opportunity to study the above mentioned items, hash out the issues and see if we can use EID-RLOC architecture or other solutions to address them.
 
We have stored all demo materials along with an accompanying white paper on WebEx.

5G Routing Evolution white paper:
https://meetings.webex.com/collabs/url/VkonUGsFDdkEErJGrYRldUt3rrkjRjrEQVnT09Sieku00000

Demo Video Download link: https://meetings.webex.com/collabs/url/Sa6LIiLRCBd98t96ssQK789kWzY_b2cZb9J2_vn_qba00000
Demo Video Streaming link: https://meetings.webex.com/collabs/url/L2ivwvc-mVCJdTL9laqfVT51JfBwtS1ObjUZudCDC_a00000

Demo Slide deck:
https://meetings.webex.com/collabs/url/JGxN7khjhPvMKb4BOh9YYezGqZqugmlIHMX1FcjXxfW00000

I will be out of office on holidays till Jan 07, 2018. But for those who would like to continue our technical discussions, I can start arranging a set of WebEx meetings when I come back to prioritise the UPFs in the above list and conduct technical discussions on how we can apply EID-RLOC + mapping system architecture or other solutions to address them. IMO, an alternative approach to Mobile back-haul goes far beyond IETF mandates which can efficiently address data path, and packet forwarding. We need to expand our focus and research to encompass this wide variety of UPFs that existing mobile back-hauls are dealing with.

Please let me know what you think and if you are interested,  I can arrange whatever venue that suits best to conduct our investigation.

Merry Christmas and Happy New Year Everyone,

Arashmid

---

From: Dino Farinacci <[email-masked]>
Date: Sun, 10 Dec 2017 12:08:05 -0800

I would like to take this opportunity to give major kudos and thanks to Arash and Peter for putting in so much time, effort, and detail for making this demo a big success. 

This proof of concept is just another example how locator/ID separation can be used in production networks. 

Dino

> On Dec 8, 2017, at 11:01 AM, Arashmid Akhavain <[email-masked]> wrote:
> 
> Hi Everyone,

---

From: AshwoodsmithPeter <[email-masked]>
Date: Mon, 11 Dec 2017 15:25:53 +0000

Thanks Dino,

All Arash's work really. I just waive my hands a lot.

Peter

-----Original Message-----
From: Dino Farinacci [mailto:[email-masked]] 
Sent: Sunday, December 10, 2017 3:08 PM
To: Arashmid Akhavain <[email-masked]>
Cc: [email-masked]; [email-masked]; TongWen <[email-masked]>; Liyungang (Wireless) <[email-masked]>; AshwoodsmithPeter <[email-masked]>
Subject: Re: Links to 5G routing evolution live demo slides and video

Dino

> We had 3 separate sessions, conducted very productive discussions at 
> the end of each, and received valuable comments and feedback that I am sure will be very useful in our ongoing debates.
> 
> Demo Video Download link: 
> https://meetings.webex.com/collabs/url/Sa6LIiLRCBd98t96ssQK789kWzY_b2c
> Zb9J2_vn_qba00000 Demo Video Streaming link: 
> https://meetings.webex.com/collabs/url/L2ivwvc-mVCJdTL9laqfVT51JfBwtS1
> ObjUZudCDC_a00000
> 
> Demo Slide deck: