Subject: [5gangip] 5G & IP - BoF at IETF #101?

From: <[email-masked]>
Date: Fri, 5 Jan 2018 17:10:54 +0000

Dear all,
First of all a Happy and Prosperous New Year to all of you!

As already mentioned several time on the list we (still) think of planning a BoF for the London meeting to have a discussion session beside what is already planned in DMM WG.

Currently we are thinking of a title like

‘Framework document on ID/Locator split for 5G’
… having in mind although that ‘our topics’ cover much more than that.

The details to be explained in a to-do PS draft could include identified gaps as

-          ID size (are 64 bits enough for a globally unique ID as proposed by some approaches?) and

-          charging issue (how could a solution look like to overcome current approaches of charging systems relying on tunneling?).

-          Privacy is of course an always active issue we have in mind … but we are not sure to open the discussion on the corresponding solution space here.

We would like to solicit your opinion on this!
Maybe we should change from ID/Loc topic based on the ADs reaction?
Would you propose other or additional topics or another way forward?

Deadline for BoF proposal is Feb 2, 2018 … so we hopefully will achieve clarification until then.
Thanks a lot!

Best Regards (also on behalf of Behcet)
Dirk

---

From: <[email-masked]>
Date: Tue, 9 Jan 2018 16:22:50 +0000

Dear all,

friendly reminder or update for clarification:
We would like to ask for your opinion on applying for BoF approval in London?
What do you think?
Who could provide support?
Thanks a lot!
Best Regards – also on behalf of Behcet
Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of von Hugo, Dirk
Sent: Freitag, 5. Januar 2018 18:11
To: [email-masked]
Subject: [5gangip] 5G & IP - BoF at IETF #101?

Dear all,

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 10 Jan 2018 10:11:03 +0100

I would support.

I think the time is appropriate to make our minds of what IP 
technologies go into 5G networks.

5G is an opportunity.  Many people ask what are the applications that 
need this kind of 1GBps bandwidth and micro-second latency; questions on 
the use of (un)licensed spectrum in direct communications abound.

Are IP protocols ready to carry this data and scale.

What is the feedback from the running 5G trials, do they use IP.

Alex

Le 09/01/2018 à 17:22, [email-masked] a écrit :
> *From:*5gangip [mailto:[email-masked]] *On Behalf Of *von 
> Hugo, Dirk
> *Sent:* Freitag, 5. Januar 2018 18:11
> *To:* [email-masked]
> *Subject:* [5gangip] 5G & IP - BoF at IETF #101?
> 
> Dear all,
> 
> As already mentioned several time on the list we (still) think of 
> planning a BoF for the London meeting to have a discussion session 
> beside what is already planned in DMM WG.
> 
> -ID size (are 64 bits enough for a globally unique ID as proposed by 
> some approaches?) and
> 
> -charging issue (how could a solution look like to overcome current 
> approaches of charging systems relying on tunneling?).
> 
> -Privacy is of course an always active issue we have in mind … but we 
> are not sure to open the discussion on the corresponding solution space 
> here.
> 
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>

---

From: Jon Crowcroft <[email-masked]>
Date: Wed, 10 Jan 2018 09:16:47 +0000

i shall be there if it is on:)
> I would support.
> 
> 
> I think the time is appropriate to make our minds of what IP technologies
> go into 5G networks.
> 
> 
> 
> 5G is an opportunity. Many people ask what are the applications that need
> this kind of 1GBps bandwidth and micro-second latency; questions on the 
> use
> of (un)licensed spectrum in direct communications abound.
> 
> 
>     Deadline for BoF proposal is Feb 2, 2018 … so we hopefully will 
> achieve
>     clarification until then.
> 
> 
>     Thanks a lot!
>

---

From: <[email-masked]>
Date: Wed, 10 Jan 2018 09:25:51 +0000

I will support.

David

Sent from my iPhone
________________________________
From: 5gangip <[email-masked]> on behalf of [email-masked] <[email-masked]>
Sent: Tuesday, January 9, 2018 4:22:50 PM
To: [email-masked]
Subject: Re: [5gangip] 5G & IP - BoF at IETF #101?

Dear all,

Dear all,

---

From: Dino Farinacci <[email-masked]>
Date: Wed, 10 Jan 2018 10:06:03 -0800

Then I’m going.  ;-)  I support.

Dino

> On Jan 10, 2018, at 1:16 AM, Jon Crowcroft <[email-masked]> wrote:
>

---

From: CARLOS JESUS BERNARDOS CANO <[email-masked]>
Date: Thu, 11 Jan 2018 23:31:10 +0100

Hi Dirk, all,

I support going for a BoF if we clarify and narrow the scope. As expressed
in the list, I think understanding what are the implications of 5G in IP is
topic deserving attention, but we need to go deeper and narrow it down to
what we think should be tackled at the IETF (I'm assuming we find topics
:D).

Thanks,

Carlos

2018-01-09 17:22 GMT+01:00 <[email-masked]>:

> *From:* 5gangip [mailto:[email-masked]] *On Behalf Of *von
> Hugo, Dirk
> As already mentioned several time on the list we (still) think of planning
> a BoF for the London meeting to have a discussion session beside what is
> already planned in DMM WG.
>
>
>
> -          charging issue (how could a solution look like to overcome
> current approaches of charging systems relying on tunneling?).
>
> -          Privacy is of course an always active issue we have in mind …
> but we are not sure to open the discussion on the corresponding solution
> space here.
>
>
>

---

From: <[email-masked]>
Date: Wed, 17 Jan 2018 16:34:15 +0000

Dear all,
thanks for incoming support mails so far. To keep you updated there was a phone call between some active ML members with the following outcome regarding topics:
should we focus on white paper on ID/Loc split (ILNP/ILA) for 5G and 3GPP or BoF preparation for London meeting?
While the 1st topic would be interesting in general and anyway – for the 2nd we would have to clarify whether we

-          Either start from a specific protocol proposal (e.g. ILA) which can be applied to multiple use cases

-          Or start from a PS with respect to open issues and gaps in 5G – and try to narrow down the solution space
Opinions:

-          Divergent multiple protocols in different WGs would lead to dispersion …

-          it is appropriate time to start new work on 5G in IETF

-          multiple new ideas as Shim6 et al. proposed solutions which failed – lessons learnt: with respect to 5G a convergence could happen to join forces

-          one proposal: start with low hanging fruit, e.g. draft for GTP over IPv6 (currently mainly over UDPv4)

-          addressing IRTF (where ILNP was RFCed) may result in missing implementation (and thus uselessness)

-          5G related topics identified could be

o   ILSR (ID/Loc Split Routing) protocol in general

o   GTP via IPv6

o   Tunnel- and anchor-less mobility needs new approaches for NMO topics such as security, charging, i.e. how to route the traffic to the charging gateway  and how to handle mobility without a mobility anchor, i.e. 3GPP PGW in operator network – is ILA probably better positioned to provide solutions here?

-          where is the line between 3GPP and IETF? See e.g. 3GPP study item to be worked on in DMM WG (proposing SRv6 as solution for UP N9 interface between UPFs in 3GPP Rel. 15 architecture)

-          how to reduce competition between DMM WG and 5GangIP ML activity – we should search for cooperation and completion (e.g. document by DMM to 3GPP with other stuff/ideas (?))

-          will aim of BoF be to  solve a problem or set up a new WG? Some problems as proceeding with ILA to standard have no chance to be done in existing WG so BoF is recommended

-          already existing and implemented solution such as ILA can also continue as AD sponsored draft outside a WG

-          DMM is focusing on tunneling solution – so ID/Loc split approach cannot be followed there

-          a clear PS (draft) is needed and we may learn from others (e.g. IDEAS BoF)

-          Shouldn’t we concentrate on a single BoF instead of multiple different ones per area and join forces instead of fractioning?
Potential take away could be to not disperse and go forward separately … and have to agree to a clear (solvable - not too broad) list of issues, gaps, etc.
Thanks & Best Regards
Dirk
From: CARLOS JESUS BERNARDOS CANO [mailto:[email-masked]]
Sent: Donnerstag, 11. Januar 2018 23:31
To: von Hugo, Dirk <[email-masked]>
Cc: [email-masked]
Subject: Re: [5gangip] 5G & IP - BoF at IETF #101?

Hi Dirk, all,

I support going for a BoF if we clarify and narrow the scope. As expressed in the list, I think understanding what are the implications of 5G in IP is topic deserving attention, but we need to go deeper and narrow it down to what we think should be tackled at the IETF (I'm assuming we find topics :D).

Thanks,

Carlos

2018-01-09 17:22 GMT+01:00 <[email-masked]<mailto:[email-masked]>>:
Dear all,

From: 5gangip [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of von Hugo, Dirk
Sent: Freitag, 5. Januar 2018 18:11
To: [email-masked]<mailto:[email-masked]>
Subject: [5gangip] 5G & IP - BoF at IETF #101?

Dear all,

_______________________________________________
5gangip mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/5gangip

---

From: <[email-masked]>
Date: Wed, 17 Jan 2018 17:26:25 +0000

Dirk

“Or start from a PS with respect to open issues and gaps in 5G – and try to narrow down the solution space”
Looking broader than 5gangip, this is the key piece which is missing for me.

My own view is that we need to take the same systems-level view that 3GPP does in terms of 5G in terms of an architecture which will then lead to protocol development.   This is the same issue that the NetSlices mailing list (proto WG) has been struggling with which has led to a severe limiting of the scope.

“Shouldn’t we concentrate on a single BoF instead of multiple different ones per area and join forces instead of fractioning?”

Yes, and I think that BoF should/could include a 101 on the 3GPP standards around 5G.   We in IETF/IRTF are fragmented in our approach to 5G currently, especially if you compare it to the top-down design model which 3GPP employs (not saying that that is correct thing to do – we just need to be aware of the cultural differences between the organisations!).

In some respects, I think we may have tried to form WGs addressing “5G” too quickly (IDEAS, 5gangip, NetSlices, potentially IRTF groups such as ICNRG, etc) and what is needed is an architectural approach which is informed by 3GPP and from which as we identify gaps, we create WGs to solve those issues?

My £/€/$ 0.02 which, as always, may be inaccurate/incorrect.

David
From: 5gangip [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: 17 January 2018 16:34
To: [email-masked]
Subject: Re: [5gangip] 5G & IP - BoF at IETF #101?

Dear all,

  *   Either start from a specific protocol proposal (e.g. ILA) which can be applied to multiple use cases
  *   Or start from a PS with respect to open issues and gaps in 5G – and try to narrow down the solution space
Opinions:

  *   Divergent multiple protocols in different WGs would lead to dispersion …
  *   it is appropriate time to start new work on 5G in IETF
  *   multiple new ideas as Shim6 et al. proposed solutions which failed – lessons learnt: with respect to 5G a convergence could happen to join forces
  *   one proposal: start with low hanging fruit, e.g. draft for GTP over IPv6 (currently mainly over UDPv4)
  *   addressing IRTF (where ILNP was RFCed) may result in missing implementation (and thus uselessness)
  *   5G related topics identified could be
     *   ILSR (ID/Loc Split Routing) protocol in general
     *   GTP via IPv6
     *   Tunnel- and anchor-less mobility needs new approaches for NMO topics such as security, charging, i.e. how to route the traffic to the charging gateway  and how to handle mobility without a mobility anchor, i.e. 3GPP PGW in operator network – is ILA probably better positioned to provide solutions here?
  *   where is the line between 3GPP and IETF? See e.g. 3GPP study item to be worked on in DMM WG (proposing SRv6 as solution for UP N9 interface between UPFs in 3GPP Rel. 15 architecture)
  *   how to reduce competition between DMM WG and 5GangIP ML activity – we should search for cooperation and completion (e.g. document by DMM to 3GPP with other stuff/ideas (?))
  *   will aim of BoF be to  solve a problem or set up a new WG? Some problems as proceeding with ILA to standard have no chance to be done in existing WG so BoF is recommended
  *   already existing and implemented solution such as ILA can also continue as AD sponsored draft outside a WG
  *   DMM is focusing on tunneling solution – so ID/Loc split approach cannot be followed there
  *   a clear PS (draft) is needed and we may learn from others (e.g. IDEAS BoF)
  *   Shouldn’t we concentrate on a single BoF instead of multiple different ones per area and join forces instead of fractioning?
Potential take away could be to not disperse and go forward separately … and have to agree to a clear (solvable - not too broad) list of issues, gaps, etc.
Thanks & Best Regards
Dirk
From: CARLOS JESUS BERNARDOS CANO [mailto:[email-masked]]
Sent: Donnerstag, 11. Januar 2018 23:31
To: von Hugo, Dirk <[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [5gangip] 5G & IP - BoF at IETF #101?

Hi Dirk, all,

Thanks,

Carlos

Dear all,