Subject: [5gangip] EAP-5G Implementation

From: austin aigbe <[email-masked]>
Date: Fri, 12 Jan 2018 10:22:28 +0100

Hello,

According to 3GPP TS 23.501 V15.0.0 (2017-12), EAP-5G is required for the
untrusted non 3GPP access control plane between the UE and N3IWF (non 3GPP
Interworking Function).

Is there an IETF draft for EAP-5G? I am working on a test implementation.

Thanks.

Regards,
Austin

---

From: <[email-masked]>
Date: Fri, 12 Jan 2018 12:06:37 +0000

Hi
According to 3GPP TS23.502 3GPP named a vendor-specific EAP method “EAP-5G" to be used only for encapsulating NAS messages, but not for authentication – for the latter EAP-AKA’ is used as described in TS 33.501 (still in draft state in Jan 2018) detailing EAP usage in 5G referring to RFC 5448, for that an update is already drafted as https://tools.ietf.org/html/draft-arkko-eap-rfc5448bis-00 AFAIK.
Hope this helps …
Best Regards
Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of austin aigbe
Sent: Freitag, 12. Januar 2018 10:22
To: [email-masked]
Subject: [5gangip] EAP-5G Implementation

Hello,

According to 3GPP TS 23.501 V15.0.0 (2017-12), EAP-5G is required for the untrusted non 3GPP access control plane between the UE and N3IWF (non 3GPP Interworking Function).

Thanks.

Regards,
Austin