Subject: [5gangip] RE : Re: Problems I see

From: <[email-masked]>
Date: Wed, 17 Jan 2018 08:13:04 +0000

FYI: CUPS was defined for 4G and CUPS principles are reused in 5G. Not the way around :)

Lionel

Envoyé de mon Orange Nura 2
Le 17 janv. 2018 09:08, Alexandre Petrescu <[email-masked]> a écrit :
>
> Le 17/01/2018 à 08:51, [email-masked] a écrit :
> [...]
>
> > (I am not asking whether they offer IPv6 service to smartphone - I do
> > know many operators offer IPv6 service to smartphone)
> >
> > <dl> Utterly non-scientific test involving 5 mobile contracts from 4
> >  of the UK operators (3 MNOs, one MVNO) shows not one support IPv6 to
> >  the UE. </dl>
>
> So, I learn in UK there is no IPv6 as a service offered to smartphones.
>
> However, there may be some trials ongoing.  One could ask, if I may
> refer, Nick HEATLEY from bt.com, who some times posts in v6ops WG.  He
> often talks about IPv6.
>
> >> and for CUPS in the lab.
> >
> > What is CUPS?
> >
> > <dl> Control User-Plane Split.
>
> Thanks for the definition.
>
> > Fundamental building-block of 5G core architecture based which
> > allows different user-planes associated with a single control plane,
> > thereby allowing differing "services" to be offered across the
> > user-planes. HOWEVER, this is where the arguments start (see IETF
> > Netslices proto-WG list for nearly 2 years of arguments and
> > counter-arguments) as no-one is actually sure what the "services"
> > are.   One theory is that we could offer different protocol support
> > on different user-plane slices, but this is problematic now that N3
> > and N6 have been defined.  The other is that we could offer different
> > grades of service but this presupposes that we can split traffic from
> > the UE on a "session by session" or "application by application"
> > basis.
> >
> > CUPS in 5G is the action of multiple UPFs against single AMF/SMF (or
> >  some combination of AMF+SMF leading to a single control-plane
> > instance).  This allows scaling/placement of the UPF independently of
> > the control-plane elements.
> >
> > CUPS is also being retro-fitted to 4G with the concept of SGWc/PGWc
> > in the control plane and multiple SGWu/PGWu in the user-plane. </dl>
>
> Is GTP part of control plane or of data plane?
>
> Alex
>
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 17 Jan 2018 08:35:31 +0000

Ha!   That is interesting as a 5G person just yesterday told me “look - we defined CUPS as part of 5G and were able to get 4G to implement it early so 5G is real...!”

Sent from my iPhone
________________________________
From: [email-masked] <[email-masked]>
Sent: Wednesday, January 17, 2018 8:13:04 AM
To: Alexandre Petrescu; Lake D Mr (PG/R - Elec Electronic Eng)
Cc: [email-masked]; [email-masked]; Nick HEATLEY
Subject: RE : Re: [5gangip] Problems I see

Lionel

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 17 Jan 2018 09:59:54 +0100

Le 17/01/2018 à 09:35, [email-masked] a écrit :
> Ha!   That is interesting as a 5G person just yesterday told me “look - 
> we defined CUPS as part of 5G and were able to get 4G to implement it 
> early so 5G is real...!”

I heard people distinguishing user-plane from data-plane distinction 
since before 3G.  For example in MPLS.

Maybe the term 'CUPS' is specific and invented by 5G.

So it is normal to think CUPS is invented by 5G and trying to be 
retrofitted to 4G deployments.  And also normal to think control plane 
data plane was already in 4G.

Alex

> 
> 
> Sent from my iPhone
> ------------------------------------------------------------------------
> *From:* [email-masked] <[email-masked]>
> *Sent:* Wednesday, January 17, 2018 8:13:04 AM
> *To:* Alexandre Petrescu; Lake D Mr (PG/R - Elec Electronic Eng)
> *Cc:* [email-masked]; [email-masked]; Nick HEATLEY
> *Subject:* RE : Re: [5gangip] Problems I see
>

---

From: <[email-masked]>
Date: Wed, 17 Jan 2018 09:20:42 +0000

In fact CP and UP were separate a LONG time ago in SS7.....

Sent from my iPhone
________________________________
From: Alexandre Petrescu <[email-masked]>
Sent: Wednesday, January 17, 2018 8:59:54 AM
To: Lake D Mr (PG/R - Elec Electronic Eng); [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: RE : Re: [5gangip] Problems I see

Alex

---

From: <[email-masked]>
Date: Wed, 17 Jan 2018 12:29:37 +0000

CUPS has been defined inside the release 14 timeframe (so for 4G EPC), including the design of a new protocol between the control plane and the user plane.
Having people saying that it was defined for 5G does not make a fact :)

Lionel
(Humble chair of 3GPP CT4 WG in which the Packet Forward Control Protocol (PFCP) has need specified)

Le 17 janv. 2018 10:20, [email-masked] a écrit :
In fact CP and UP were separate a LONG time ago in SS7.....

Sent from my iPhone

Alex

---

From: <[email-masked]>
Date: Wed, 17 Jan 2018 12:32:24 +0000

Lionel

Understood!

I'm (personally) very interested in PFCP for UPF control and I think it could be relevant here as it is another IETF protocol which 3GPP is using.

Also, since N4 operates between SMF and UPF(s), I think that discussion could be useful for the IETF NetSlices group.

David

From: [email-masked] [mailto:[email-masked]]
Sent: 17 January 2018 12:30
To: Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE : Re: RE : Re: [5gangip] Problems I see

Lionel
(Humble chair of 3GPP CT4 WG in which the Packet Forward Control Protocol (PFCP) has need specified)
Le 17 janv. 2018 10:20, [email-masked]<mailto:[email-masked]> a écrit :
In fact CP and UP were separate a LONG time ago in SS7.....

Sent from my iPhone
________________________________
From: Alexandre Petrescu <[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, January 17, 2018 8:59:54 AM
To: Lake D Mr (PG/R - Elec Electronic Eng); [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: RE : Re: [5gangip] Problems I see

Le 17/01/2018 à 09:35, [email-masked]<mailto:[email-masked]> a écrit :
> Ha!   That is interesting as a 5G person just yesterday told me "look -
> early so 5G is real...!"

Alex

> *From:* [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
> *Cc:* [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Nick HEATLEY
> Le 17 janv. 2018 09:08, Alexandre Petrescu
> <[email-masked]<mailto:[email-masked]>> a écrit :
>  >
>  > Le 17/01/2018 à 08:51, [email-masked]<mailto:[email-masked]> a écrit :
>  > [...]
>  >
>  > [email-masked]<mailto:[email-masked]>

Thank you.

---

From: <[email-masked]>
Date: Wed, 17 Jan 2018 13:23:33 +0000

Hi David,

PFCP has been defined by 3GPP (and not IETF) in the 3GPP Technical Specification 29.244.
This TS has been updated to include N4 as it was decided to reuse the same protocol than for Sx/CUPS.
The last version of the spec in Rel-15 is: http://www.3gpp.org/ftp/Specs/archive/29_series/29.244/29244-f00.zip

Regards,

Lionel

De : [email-masked] [mailto:[email-masked]]
Envoyé : mercredi 17 janvier 2018 13:32
À : MORAND Lionel IMT/OLN; [email-masked]
Cc : [email-masked]; [email-masked]; [email-masked]
Objet : RE: RE : Re: RE : Re: [5gangip] Problems I see

Lionel

Understood!

David

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: 17 January 2018 12:30
To: Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: RE : Re: RE : Re: [5gangip] Problems I see

Lionel

Sent from my iPhone

Alex

Thank you.