Subject: [5gangip] plans for future work on Id-Loc split for 5G

From: <[email-masked]>
Date: Thu, 15 Feb 2018 09:37:33 +0000

Dear all,
After some good discussion here on the list and some initial contact with IAB, we think it could be worth to spend more thoughts on the ID-Loc split topic of a mapping system providing end-to-end privacy of both Identities and Location of peers. The use cases are 5G related route optimization for changing (mobile) points of attachment of both end terminals (UE) and network function services (e.g. UPF) …
Focus should be on concrete approaches which can be prototyped instead of pure theoretical (academic) discussions
We think the work needs a problem statement draft, a comprehensive list of requirements, and a framework document showing the environment where the solution would fit in (w/o yet a complete solution space analysis) … in that priority.
We solicit for a discussion on the list before we meet in London.
In London, IETF 101, we plan on organizing a side-meeting where we could have a set of stimulating presentations.
Topics we can imagine currently are
- 5G lab trials.
- Any initial work on the first deployment experience which potentially underline the identified problem.
Volunteers are welcome – please  announce your proposal to Behcet and Dirk!
Other ideas, proposal, comments? Please speak up!
Thanks a lot and Best Regards – also on behalf of Behcet

Dirk

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 16 Feb 2018 13:25:31 -0600

On Thu, Feb 15, 2018 at 3:37 AM, <[email-masked]> wrote:

> Dear all,
>
> After some good discussion here on the list and some initial contact with
> IAB, we think it could be worth to spend more thoughts on the ID-Loc split
> topic of a mapping system providing end-to-end privacy of both Identities
> and Location of peers. The use cases are 5G related route optimization for
> changing (mobile) points of attachment of both end terminals (UE) and
> network function services (e.g. UPF) …
>
> We think the work needs a problem statement draft, a comprehensive list of
> requirements, and a framework document showing the environment where the
> solution would fit in (w/o yet a complete solution space analysis) … in
> that priority.
>

Tom Herbert had a draft

https://www.ietf.org/id/draft-herbert-idlocd-00.txt

This draft could be relevant, let's discuss it.

Behcet

> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>
>

---

From: "David S. Misell MSc MIET MBCS CISSP" <[email-masked]>
Date: Sat, 17 Feb 2018 16:57:53 +0000

Steven, Rick,
Sally commented on security in the european context on radio 4 today, I see a derogation for this !

Best Regards,

Dave

David S. Misell MBCS MIET CISSP
[email-masked]
07710380044
misell.dave on skype

> On 17 Feb 2018, at 12:11, Dr Stephen P CASTELL <[email-masked]> wrote:
> 
> Rick
>  
> My wish list: (Mobile) Blockchain and GDPR – how can blockchain ever be compliant with Art 17 GDPR, when its permanence and immutability is its key ‘thing’?
>  
> http://www.privacy-regulation.eu/en/article-17-right-to-erasure-'right-to-be-forgotten'-GDPR.htm
> "Right to erasure ('right to be forgotten')" ... (e) the personal data have to be erased for compliance with a legal obligation in Union or Member State law to which the controller is subject;
>  
> https://hackernoon.com/forever-on-the-chain-c755838dfc79
> https://bitsonblocks.net/2016/02/29/a-gentle-introduction-to-immutability-of-blockchains/
> https://www.coindesk.com/blockchain-immutability-myth/
> https://www.forbes.com/sites/yec/2017/05/04/debunking-blockchain-myths-and-how-they-will-impact-the-future-of-business/#583e1d815609
>  
> Kind regards,
> Stephen Castell.
>  
> Dr Stephen Castell CITP CPhys FIMA MEWI MIoD
> Chairman, CASTELL Consulting
> PO Box 334, Witham, Essex CM8 3LP, UK
> Tel: +44 1621 891 776        Mob: +44 7831 349 162
> Email: [email-masked]
> http://www.CastellConsulting.com  http://www.e-expertwitness.com
>  
> Crypto: the Millennials’ Rock’n’Roll
>  
> Committee Member, Programme Development & IT Professionalism, British Computer Society Law Specialist Group
> http://www.bcs.org/category/10868
> Accredited Member, Forensic Expert Witness Association, Los Angeles Chapter
> Castell’s Dictum: “You cannot secure an ontologically unreliable technology by use of an ontologically unreliable technology”.  (1990)
> Castell’s Second Dictum: “You cannot construct an algorithm that will reliably decide whether or not any algorithm is ethical”.  (2017)
>  
> From: D S Misell [mailto:[email-masked]] 
> Sent: 16 February 2018 23:19
> To: Dr Stephen P CASTELL <[email-masked]>; Chiara Rustici <[email-masked]>; Dai Davis <[email-masked]>; Jennifer Dean <[email-masked]>
> Cc: Rick Chandler <[email-masked]>
> Subject: Fwd: [5gangip] plans for future work on Id-Loc split for 5G
>  
> Legal posse, give your wish list to rick as CMA rep he will be at Mobile world congress next week.
> Yours Faithfully,
>  
> David S. Misell MIET MBCS CISSP
> 0207 7239135
>  
> http://linkedin.com/in/misell
> https://db.tt/ncfgMm3J
> https://www.dropbox.com/s/eo7rtdi59rzufln/misell_CV_Se17.docx
>  
> Begin forwarded message:
>  
> From: [email-masked]
> Subject: [5gangip] plans for future work on Id-Loc split for 5G
> Date: 15 February 2018 at 09:37:33 GMT
> To: [email-masked]
> Cc: [email-masked]
>  
> Dear all,

---

From: Tom Herbert <[email-masked]>
Date: Sun, 18 Feb 2018 13:25:00 -0800

On Fri, Feb 16, 2018 at 11:25 AM, Behcet Sarikaya
<[email-masked]> wrote:
>> solution would fit in (w/o yet a complete solution space analysis) … in that
>> priority.
>>
We have pushed an initial implementation to git-hub as open source.
This is in github.com/quantonium/ila. The starting point to work with
this is https://github.com/quantonium/ila/blob/master/README.install.

This implements ilad as an ILA control daemon following the design of
the idloc draft. The current version implements a mapping system
database using Redis and ILA routers. The forwarding cache and ILA
mapping protocol (ILAMP
https://tools.ietf.org/html/draft-herbert-ila-ilamp-00) are TBD. For
populating the cache, ILAMP proposes to use secure redirects which are
something of a hybrid of the push and pull models described in the
idlocd draft.

The repository includes tests to emulate a RAN network in a box and
show seamless device mobility. We are currently working on bringing
this us in real radio network. We can do a demo of ilad at a 5GangIP
side meeting. If you're interested in developing and working on ilad,
please let me know!

Tom

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 19 Feb 2018 11:35:37 -0600

Hi Tom, all,

As Dirk mentioned, we are looking for problem statement, requirements,
framework, type of documents not tied to one specific
ID-Loc system.

On Sun, Feb 18, 2018 at 3:25 PM, Tom Herbert <[email-masked]> wrote:

> >> Focus should be on concrete approaches which can be prototyped instead
> of
> >> pure theoretical (academic) discussions
> >>
> that
Let's discuss this specific approach and others from the point of view of
developing the documents we need

Regards,
Behcet

---

From: Jon Crowcroft <[email-masked]>
Date: Sat, 17 Feb 2018 17:27:37 +0000

see also
https://papers.ssrn.com/sol3/papers.cfm?abstract_id=3058945

On Sat, Feb 17, 2018 at 4:57 PM, David S. Misell MSc MIET MBCS CISSP <
[email-masked]> wrote:

> My wish list: *(Mobile) Blockchain and GDPR – how can blockchain ever be
> compliant with Art 17 GDPR, when its permanence and immutability is its key
> ‘thing’?*
>
>
>
> *"Right to erasure ('right to be forgotten')" ... (e) the personal data
> have to be erased for compliance with a legal obligation in Union or Member
> State law to which the controller is subject;*
>
>
>
> https://www.forbes.com/sites/yec/2017/05/04/debunking-
> blockchain-myths-and-how-they-will-impact-the-future-of-
> business/#583e1d815609
>
>
>
> Kind regards,
>
> Stephen Castell.
>
>
>
> *Dr Stephen Castell CITP CPhys FIMA MEWI MIoD*
>
> *Chairman, CASTELL Consulting*
>
> *PO Box 334, Witham, Essex CM8 3LP, UK*
>
> *Tel: +44 1621 891 776 <+44%201621%20891776>        Mob: +44 7831 349 162
> <+44%207831%20349162>*
>
> *Email: [email-masked] <[email-masked]>*
>
> *http://www.CastellConsulting.com* <http://www.castellconsulting.com/>
> *http://www.e-expertwitness.com* <http://www.e-expertwitness.com/>
>
>
>
> *Crypto: the Millennials’ Rock’n’Roll*
>
>
>
> *Committee Member,* *Programme Development & IT Professionalism, British
> Computer Society* *Law Specialist Group*
>
> *http://www.bcs.org/category/10868*
> <https://nam02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.bcs.org%2Fcategory%2F10868&data=02%7C01%7C%7C8e3d10e02a214552270e08d56b2cf546%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636532763239292474&sdata=t2KELz1bYWqsYWDQrSXXzsUUuMVgU1HQa5BnLJ2IbPE%3D&reserved=0>
>
> Accredited Member, Forensic Expert Witness Association, *Los Angeles
> Chapter*
>
> *Castell’s Dictum: “You cannot secure an ontologically unreliable
> technology by use of an ontologically unreliable technology”**.  (1990)*
>
> *Castell’s Second Dictum: “You cannot construct an algorithm that will
> reliably decide whether or not any algorithm is ethical”**.  (2017)*
>
>
>
> *From:* D S Misell [mailto:[email-masked]
> <[email-masked]>]
> *Sent:* 16 February 2018 23:19
> *To:* Dr Stephen P CASTELL <[email-masked]>; Chiara
> Rustici <[email-masked]>; Dai Davis <[email-masked]>; Jennifer
> Dean <[email-masked]>
> *Cc:* Rick Chandler <[email-masked]>
> *Subject:* Fwd: [5gangip] plans for future work on Id-Loc split for 5G
>
>
>
> <https://www.dropbox.com/s/eo7rtdi59rzufln/misell_CV_Se17.docx?dl=0Http://linkedin.com/in/misell>
>
> https://db.tt/ncfgMm3J
>
> *From: [email-masked]
>
> *Subject: [5gangip] plans for future work on Id-Loc split for 5G*
>
> *Date: *15 February 2018 at 09:37:33 GMT
>
> *To: [email-masked]
>
> *Cc: [email-masked]
>
>
>
> Dear all,
>

---

From: Dr Stephen P CASTELL <[email-masked]>
Date: Sat, 17 Feb 2018 13:11:07 +0100

Rick

Kind regards,

Stephen Castell.

 <http://www.castellconsulting.com/> http://www.CastellConsulting.com   <http://www.e-expertwitness.com/> http://www.e-expertwitness.com

 <https://nam02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.bcs.org%2Fcategory%2F10868&data=02%7C01%7C%7C8e3d10e02a214552270e08d56b2cf546%7C84df9e7fe9f640afb435aaaaaaaaaaaa%7C1%7C0%7C636532763239292474&sdata=t2KELz1bYWqsYWDQrSXXzsUUuMVgU1HQa5BnLJ2IbPE%3D&reserved=0> http://www.bcs.org/category/10868

Yours Faithfully,

http://linkedin.com/in/misell <https://www.dropbox.com/s/eo7rtdi59rzufln/misell_CV_Se17.docx?dl=0Http://linkedin.com/in/misell> 

https://db.tt/ncfgMm3J

Begin forwarded message:

From:  <mailto:[email-masked]> [email-masked]

To:  <mailto:[email-masked]> [email-masked]

Cc:  <mailto:[email-masked]> [email-masked]

Dear all,

- 5G lab trials.

Dirk

_______________________________________________
5gangip mailing list
 <mailto:[email-masked]> [email-masked]
 <https://www.ietf.org/mailman/listinfo/5gangip> https://www.ietf.org/mailman/listinfo/5gangip