Subject: Re: [5gangip] [DMM] Mapping System scalability

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 16 Mar 2018 09:55:33 -0500

Hi Alberto,

It seems like you are not in 5G IP mailing list (cc'ed above 5gangip).
At 5gangip we decided to work on end to end privacy enabled mapping system
and the group has a side meeting as follows:

Thursday March 22nd, 10:00 - 11:30 Room: IETF Side Meetings room

We are going to take your mail as input from LISP side.

Regards,
Behcet

On Fri, Mar 16, 2018 at 3:19 AM, Alberto Rodriguez-Natal <
[email-masked]> wrote:

> Hi all,
>
> In the DMM call this week, some people asked about the scalability of the
> Mapping System. The LISP community has delivered different solutions to
> address that challenge over the years. Here are some pointers to different
> Mapping System implementations, I'm sure that the folks at the LISP WG list
> can provide even more references.
>
> LISP Delegated Database Tree (LISP DDT) [1] follows a DNS-like structure
> and it's designed to be deployed at Internet scale. For an academic work on
> a DNS-based Mapping System take a look at [2].
>
> Designs leveraging DHTs have also been considered to enable high
> scalabilty, see for instance [3][4]. For a survey on different Mapping
> System options see [5] (I wasn't able to find an open version of this
> article unfortunately).
>
> For those interested in current research efforts, recent works include
> decentralized designs [6] or even Blockchain-based approaches [7].
>
> Hope this helps,
> Alberto
>
> [1] https://tools.ietf.org/html/rfc8111
> [2] http://people.ac.upc.edu/ljakab/2010-jakab-jsac-lisp-tree.pdf
> [3] https://tools.ietf.org/html/draft-cheng-lisp-shdht-04
> [4] http://citeseerx.ist.psu.edu/viewdoc/download?doi=10.1.1.
> 139.735&rep=rep1&type=pdf
> [5] http://ieeexplore.ieee.org/document/6422285/
> [6] https://tools.ietf.org/html/draft-farinacci-lisp-decent-00
> [7] https://datatracker.ietf.org/meeting/97/materials/slides-
> 97-lisp-blockchain-based-mapping-system/
>
>
> _______________________________________________
> dmm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/dmm
>
>

---

From: Alberto Rodriguez-Natal <[email-masked]>
Date: Fri, 16 Mar 2018 15:12:27 -0700

> We are going to take your mail as input from LISP side.

Please, feel free to do so Behcet. Just note that it's not a comprehensive list.

Looking forward to the meeting on Thursday.

Best,
Alberto