Subject: [5gangip] blockchain mapping system

From: Jordi Paillissé Vilanova <[email-masked]>
Date: Mon, 26 Mar 2018 23:09:55 +0200

Dear all,

During the last side meeting the topic about a blockchain mapping system 
was raised. In short, reading the mappings from the blockchain is easy, 
but updating them not. Reading is easy because mappings are stored 
locally on the blockchain. Updating is difficult and slow because 
mapping updates have to be packed in a block, and also you have to run 
the consensus algorithm to authenticate new blocks.

That said, depending on the dynamics of the mappings the blockchain is 
suitable or not for a mapping system. If mappings change frequently, 
it's not useful, so  it does not make sense for the 5G use-case.

However, a blockchain can be useful to authenticate the servers that 
store such mappings, because this information changes way more slowly 
than mappings. A similar scenario is described in this draft: 
https://datatracker.ietf.org/doc/draft-paillisse-sidrops-blockchain/

Regards,

Jordi

---

From: Mikael Abrahamsson <[email-masked]>
Date: Tue, 27 Mar 2018 08:50:19 +0200 (CEST)

> https://datatracker.ietf.org/doc/draft-paillisse-sidrops-blockchain/

"The main outcomes of the
    analysis are that blockchain is suitable in environments with
    multiple distrusting parties and that Proof of Stake is a potential
    candidate for a consensus algorithm."

In what scenario for 5G is this applicable?

-- 
Mikael Abrahamsson    email: [email-masked]

---

From: Ca By <[email-masked]>
Date: Tue, 27 Mar 2018 12:54:46 +0000

> In what scenario for 5G is this applicable?

In the scenario where — 5G at the IETF is where all the misfit toys (1) are
left to play and try to apply unwanted solutions to unspecified problems.
So of course blockchain is here. Other panacea technology: everything in
udp, network coding, multicast, iot / nsh / nfv / sdn / pce

 (1) https://youtu.be/5SH1j1luFOw

> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>

---

From: Jordi Paillissé Vilanova <[email-masked]>
Date: Tue, 27 Mar 2018 15:25:00 +0100

Hi,

I may not have expressed my ideas clearly. Blockchains offer a trust 
model different from typical PKI schemes. This is especially useful when 
you have several distrusting parties that want to share information 
e.g., several operators publishing the location of their mapping systems.

Regards,

Jordi

PS: nice stop-motion film :)

El 27/03/18 a les 13:54, Ca By ha escrit:
>
> On Mon, Mar 26, 2018 at 11:50 PM Mikael Abrahamsson <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
> In the scenario where — 5G at the IETF is where all the misfit toys 
> (1) are left to play and try to apply unwanted solutions to 
> unspecified problems.  So of course blockchain is here. Other panacea 
> technology: everything in udp, network coding, multicast, iot / nsh / 
> nfv / sdn / pce
>
>     <mailto:[email-masked]>_______________________________________________
>     5gangip mailing list
>     [email-masked] <mailto:[email-masked]>

---

From: Jon Crowcroft <[email-masked]>
Date: Tue, 27 Mar 2018 17:11:25 +0100

- you have to trust theres no collusion - bitcoin (for example) already
demonstrates that that is hard.

- its not clear what you want to be immutably stored on the chain

- it isn't clear how fast it is appended and how fast your consensus
algorithm would have to run - in particular (as discussed in DIN RG) high
throughput blockcains are typically high latency, which is
counter-indicated in 5G, i thought...

i think in the cooperative/competitve cellular world, resources like the
cell towers being shared (or spectrum, compare, e.g. to white space) isn't
moving about terribly fast either...

cheers
j

multicast (btw) had a perfectly good use case - we had ISPs saying there's
no customers and TV companies saying "we're here, where's the bloody
service" - now most people watch on demand, that case mostly went away, but
it was there from 1988 (when we first had international multicast
connectivity and NASA and the BBC transmitted on it) for about 20 years...

so does UDP (c.f. QUIC :-) but mainly because TCP ossified...

On Tue, Mar 27, 2018 at 3:25 PM, Jordi Paillissé Vilanova <[email-masked]

> Hi,
>
> I may not have expressed my ideas clearly. Blockchains offer a trust model
> different from typical PKI schemes. This is especially useful when you have
> several distrusting parties that want to share information e.g., several
> operators publishing the location of their mapping systems.
>
> Regards,
>
> Jordi
>
> In the scenario where — 5G at the IETF is where all the misfit toys (1)
> are left to play and try to apply unwanted solutions to unspecified
> problems.  So of course blockchain is here. Other panacea technology:
> everything in udp, network coding, multicast, iot / nsh / nfv / sdn / pce
>
>> Mikael Abrahamsson    email: [email-masked]
>> _________________________________
>> 5gangip mailing list
>> [email-masked]

---

From: Jordi Paillissé Vilanova <[email-masked]>
Date: Tue, 27 Mar 2018 20:52:37 +0200

Hi Jon,

Thanks for your comments :)

See my responses inline.

Regards,

Jordi

El 27/03/18 a les 18:11, Jon Crowcroft ha escrit:
> - you have to trust theres no collusion - bitcoin (for example) 
> already demonstrates that that is hard.
Sure, there's always an upper bound on the number of dishonest players 
your blockchain can tolerate, and it will depend on the type of 
blockchain you're using. For example, in Bitcoin it's 50% (although some 
people argue it's lower), Algorand admits as much as 1/3 of them, etc.
> - its not clear what you want to be immutably stored on the chain
My fault, I was not clear enough. I am supposing that the identifiers in 
the mapping system can be aggregated in some way, like IP addresses to 
IP prefixes. Then, in the blockchain, you write pairs of (aggregated 
identifier, mapping system address). So when I want to know which server 
stores a particular mapping, I can find it in the blockchain. Then I 
connect to this server to retrieve the (identifier, locator) pair.
> algorithm would have to run - in particular (as discussed in DIN RG) 
> high throughput blockcains are typically high latency, which is 
Completely agree, storing individual mappings in the blockchain does not 
make sense, both from the latency and scalability viewpoints.
>
> i think in the cooperative/competitve cellular world, resources like 
> the cell towers being shared (or spectrum, compare, e.g. to white 
> space) isn't moving about terribly fast either...
>
> cheers
> j
>
> multicast (btw) had a perfectly good use case - we had ISPs saying 
> there's no customers and TV companies saying "we're here, where's the 
> bloody service" - now most people watch on demand, that case mostly 
> went away, but it was there from 1988 (when we first had international 
> multicast connectivity and NASA and the BBC transmitted on it) for 
> about 20 years...
>
> On Tue, Mar 27, 2018 at 3:25 PM, Jordi Paillissé Vilanova 
> <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi,
>
>     I may not have expressed my ideas clearly. Blockchains offer a
>     trust model different from typical PKI schemes. This is especially
>     useful when you have several distrusting parties that want to
>     share information e.g., several operators publishing the location
>     of their mapping systems.
>
>     Regards,
>
>     Jordi
>
>>     On Mon, Mar 26, 2018 at 11:50 PM Mikael Abrahamsson
>>     <[email-masked] <mailto:[email-masked]>> wrote:
>>
>>         <https://datatracker.ietf.org/doc/draft-paillisse-sidrops-blockchain/>
>>
>>     In the scenario where — 5G at the IETF is where all the misfit
>>     toys (1) are left to play and try to apply unwanted solutions to
>>     unspecified problems.  So of course blockchain is here. Other
>>     panacea technology: everything in udp, network coding, multicast,
>>     iot / nsh / nfv / sdn / pce
>>
>>         <https://www.ietf.org/mailman/listinfo/5gangip>
>>
>
>
>     <https://www.ietf.org/mailman/listinfo/5gangip>
>
>

---

From: Dino Farinacci <[email-masked]>
Date: Tue, 27 Mar 2018 13:58:16 -0700

What the blockchain could do for mappings is answer the question “where has Jordi been”. But that would take a exhaustive blockchain traversal as well as the privacy concerns. With the LISP mapping system, no one can just look up something if not authenticated. 

Most blockchain applications I’ve seen store transaction and block headers in the clear and only when there is a level of indirection that points to the data, its where the data is stored that more securiy is added. But on the blockchain itself. 

Dino

> On Mar 27, 2018, at 11:52 AM, Jordi Paillissé Vilanova <[email-masked]> wrote:
> 
> Hi Jon,
> 
>> - you have to trust theres no collusion - bitcoin (for example) already demonstrates that that is hard.
> Sure, there's always an upper bound on the number of dishonest players your blockchain can tolerate, and it will depend on the type of blockchain you're using. For example, in Bitcoin it's 50% (although some people argue it's lower), Algorand admits as much as 1/3 of them, etc.
>> 
> My fault, I was not clear enough. I am supposing that the identifiers in the mapping system can be aggregated in some way, like IP addresses to IP prefixes. Then, in the blockchain, you write pairs of (aggregated identifier, mapping system address). So when I want to know which server stores a particular mapping, I can find it in the blockchain. Then I connect to this server to retrieve the (identifier, locator) pair.
>> 
>> 
>> 
>> - it isn't clear how fast it is appended and how fast your consensus algorithm would have to run - in particular (as discussed in DIN RG) high throughput blockcains are typically high latency, which is counter-indicated in 5G, i thought...
> Completely agree, storing individual mappings in the blockchain does not make sense, both from the latency and scalability viewpoints.
>> 
>> i think in the cooperative/competitve cellular world, resources like the cell towers being shared (or spectrum, compare, e.g. to white space) isn't moving about terribly fast either...
>> 
>> cheers
>> j
>> 
>> multicast (btw) had a perfectly good use case - we had ISPs saying there's no customers and TV companies saying "we're here, where's the bloody service" - now most people watch on demand, that case mostly went away, but it was there from 1988 (when we first had international multicast connectivity and NASA and the BBC transmitted on it) for about 20 years...
>> 
>> On Tue, Mar 27, 2018 at 3:25 PM, Jordi Paillissé Vilanova <[email-masked]> wrote:
>> Hi,
>> 
>> I may not have expressed my ideas clearly. Blockchains offer a trust model different from typical PKI schemes. This is especially useful when you have several distrusting parties that want to share information e.g., several operators publishing the location of their mapping systems. 
>> Regards,
>> 
>> Jordi
>>> On Mon, Mar 26, 2018 at 11:50 PM Mikael Abrahamsson <[email-masked]> wrote:
>>> In the scenario where — 5G at the IETF is where all the misfit toys (1) are left to play and try to apply unwanted solutions to unspecified problems.  So of course blockchain is here. Other panacea technology: everything in udp, network coding, multicast, iot / nsh / nfv / sdn / pce
>>> 
>>> Mikael Abrahamsson    email: [email-masked]
>>> 5gangip mailing list
>>> [email-masked]

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 28 Mar 2018 07:33:11 +0200 (CEST)

> e.g., several operators publishing the location of their mapping 

Are you actually promoting using blockchain here, or just explaining 
where it could possibly be used?

Because I still don't understand the use-case for why blockchain 
technology should be used in mobile networks.

If it's supposed to be used, where, and what problem does it solve, 
concretely?

---

From: Alexandre Petrescu <[email-masked]>
Date: Wed, 28 Mar 2018 08:41:36 +0200

Le 27/03/2018 à 18:11, Jon Crowcroft a écrit :
> cheers j
> went away, but it was there from 1988 (when we first had
> international multicast connectivity and NASA and the BBC transmitted
> on it) for about 20 years...
> 

For the UDP part: GTP is on UDP I believe; so no, UDP is not a misfit.

Second, I do not know how UDP port numbers are managed.  But I do plan
to ask for an UDP port number for a particular UDP protocol in the car,
that transmits data encoded as XER format on UDP on IP.  I hope the
managers of the port number space wont say they dont have any such port
number available.

Alex

> model different from typical PKI schemes. This is especially useful 
> when you have several distrusting parties that want to share 
> information e.g., several operators publishing the location of their 
> mapping systems.
> 
> Regards,
> 
> Jordi
> 
>> 
>> "The main outcomes of the analysis are that blockchain is suitable
>> in environments with multiple distrusting parties and that Proof of
>> Stake is a potential candidate for a consensus algorithm."
>> 
>> -- Mikael Abrahamsson    email: [email-masked] 
5gangip mailing list
> _______________________________________________ 5gangip mailing list 
> _______________________________________________ 5gangip mailing list 
> [email-masked] https://www.ietf.org/mailman/listinfo/5gangip
>

---

From: <[email-masked]>
Date: Wed, 28 Mar 2018 07:35:09 +0000

Hi Mikael,
one application we had in mind and mentioned during the side meeting last week was to ensure privacy by providing security and trust relation (e.g. between UE and mapping data base or any two UEs) when in a ID-Loc split approach a look-up of the current location at the mapping system should be enabled. 
Do you think that would work efficiently?
Thanks!
Best Regards
Dirk 

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Mikael Abrahamsson
Sent: Mittwoch, 28. März 2018 07:33
To: Jordi Paillissé Vilanova <[email-masked]>
Cc: [email-masked]
Subject: Re: [5gangip] blockchain mapping system

> information e.g., several operators publishing the location of their 

Are you actually promoting using blockchain here, or just explaining where it could possibly be used?

Because I still don't understand the use-case for why blockchain technology should be used in mobile networks.

If it's supposed to be used, where, and what problem does it solve, concretely?

---

From: Mikael Abrahamsson <[email-masked]>
Date: Wed, 28 Mar 2018 09:48:48 +0200 (CEST)

On Wed, 28 Mar 2018, [email-masked] wrote:

> one application we had in mind and mentioned during the side meeting 
> last week was to ensure privacy by providing security and trust relation 
> (e.g. between UE and mapping data base or any two UEs) when in a ID-Loc 
> split approach a look-up of the current location at the mapping system 
> should be enabled. Do you think that would work efficiently?

What problem does blockchain solve in this? What downsides are there? How 
do we do "proof of stake"?

Blockchain is a huge strain on computing resources, and it's a complete 
waste of energy/time unless it solves a very specific problem that can't 
be solved in another way.

So again, what problems would we be solving by using blockchain instead of 
some other mechanism?

---

From: Behcet Sarikaya <[email-masked]>
Date: Wed, 28 Mar 2018 09:19:54 -0500

> For the UDP part: GTP is on UDP I believe; so no, UDP is not a misfit.
+!

I think Cameron's point was rhetorical, I believe many other things in his
list are not, like multicast.

Behcet

>> On Tue, Mar 27, 2018 at 3:25 PM, Jordi Paillissé Vilanova <
>> [email-masked] <mailto:[email-masked]>> wrote:
>>
>> Hi,
>>
>> you have several distrusting parties that want to share information e.g.,
>> several operators publishing the location of their mapping systems.
>>
>> Regards,
>>
>> Jordi
>>
>>> That said, depending on the dynamics of the mappings the
>>>>
>>> blockchain is
>>>
>>>> suitable or not for a mapping system. If mappings change
>>>>
>>> frequently,
>>>
>>>> However, a blockchain can be useful to authenticate the
>>>>
>>> servers that
>>>
>>>> store such mappings, because this information changes way
>>>>
>>> more slowly
>>>
>>> (1) are left to play and try to apply unwanted solutions to unspecified
>>> -- Mikael Abrahamsson    email: [email-masked] <mailto:
>>> [email-masked]>_______________________________________________
>>>
>>>
>>> 5gangip mailing list
>
>> [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/l
>>> istinfo/5gangip <https://www.ietf.org/mailman/listinfo/5gangip>
>>>
>>>
>>
>> [email-masked] <mailto:[email-masked]> https://www.ietf.org/mailman/l
>> istinfo/5gangip <https://www.ietf.org/mailman/listinfo/5gangip>
>>
>>
>>
>>

---

From: Jordi Paillissé Vilanova <[email-masked]>
Date: Thu, 29 Mar 2018 00:16:17 +0200

Hi Dirk, Michael, all,

IMHO, as I outlined before, I don't think blockchain can be used as a 
mapping system, due to the latency of adding a new mapping. In addition, 
I do not see how a blockchain can provide privacy for the mappings, 
because the locators would be stored in the blockchain and anyone could 
access them. It could be possible to encrypt them, but then management 
would be complicated.

On the other side, our proposal focuses on the cross-domain 
communication between mapping systems of *different* operators, ie, 
crossing administrative domains. In other words, the blockchain tells 
you which server to ask when looking for a mapping, not the mapping 
(equivalent to LISP-DDT). In traditional PKI schemes, this is done with 
cross-certification, which scales poorly (O(N^2)). So this blockchain 
would not be in the edge, but rather in the core of the 5G network.

Regarding Proof of Stake, one of its big advantages is that it does not 
require high computing resources. There are already several PoS 
algorithms out there, like Algorand [1], NEM's Proof of Importance [2], 
or Ouroboros [3], just to mention some of them.

Regards,

Jordi

[1] https://arxiv.org/abs/1607.01341
[2] https://nem.io/investors/harvesting-and-poi/
[3] https://link.springer.com/chapter/10.1007/978-3-319-63688-7_12

El 28/03/18 a les 09:48, Mikael Abrahamsson ha escrit:
>> last week was to ensure privacy by providing security and trust 
>> relation (e.g. between UE and mapping data base or any two UEs) when 
>> in a ID-Loc split approach a look-up of the current location at the 
>> mapping system should be enabled. Do you think that would work 
>> efficiently?
>
> What problem does blockchain solve in this? What downsides are there? 
> How do we do "proof of stake"?
>
> Blockchain is a huge strain on computing resources, and it's a 
> complete waste of energy/time unless it solves a very specific problem 
> that can't be solved in another way.
>
> So again, what problems would we be solving by using blockchain 
> instead of some other mechanism?
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 29 Mar 2018 08:22:30 +0200 (CEST)

On Thu, 29 Mar 2018, Jordi Paillissé Vilanova wrote:

> On the other side, our proposal focuses on the cross-domain communication 
> between mapping systems of *different* operators, ie, crossing administrative 
> domains. In other words, the blockchain tells you which server to ask when 
> looking for a mapping, not the mapping (equivalent to LISP-DDT). In 
> traditional PKI schemes, this is done with cross-certification, which scales 
> poorly (O(N^2)). So this blockchain would not be in the edge, but rather in 
> the core of the 5G network.
>
> require high computing resources. There are already several PoS algorithms 
> out there, like Algorand [1], NEM's Proof of Importance [2], or Ouroboros 
> [3], just to mention some of them.

What problem does blockchain solve that means it's better than other 
solutions out there?

---

From: Jordi Paillissé <[email-masked]>
Date: Thu, 29 Mar 2018 11:32:56 +0200

Hi Michael,

I may have not been clear enough, the problem is: inter-domain 
communication between mapping  systems. It scales better than 
cross-domain certification. Does this make sense?

Regards,

Jordi

El 29/3/2018 a les 8:22, Mikael Abrahamsson ha escrit:
>> (equivalent to LISP-DDT). In traditional PKI schemes, this is done 
>> with cross-certification, which scales poorly (O(N^2)). So this 
>> blockchain would not be in the edge, but rather in the core of the 5G 
>> network.
>>
>> Regarding Proof of Stake, one of its big advantages is that it does 
>> not require high computing resources. There are already several PoS 
>> algorithms out there, like Algorand [1], NEM's Proof of Importance 
>> [2], or Ouroboros [3], just to mention some of them.
>

---

From: Mikael Abrahamsson <[email-masked]>
Date: Thu, 29 Mar 2018 14:06:35 +0200 (CEST)

> cross-domain certification. Does this make sense?

Sorry, I still do not understand.

---

From: AshwoodsmithPeter <[email-masked]>
Date: Thu, 29 Mar 2018 14:08:04 +0000

A mapping system requires that the N entries be broken up into N/M per M machines and further requires that every operation take < O(Log(M)).

A block chain requires that N entries be stored on M machines and further requires that every operation takes > ½ the available CPU of all M machines.

I don’t see how they could possibly be compatible.

Peter

From: 5gangip [mailto:[email-masked]] On Behalf Of Jordi Paillissé Vilanova
Sent: Wednesday, March 28, 2018 6:16 PM
To: Mikael Abrahamsson <[email-masked]>; [email-masked]
Cc: [email-masked]; [email-masked]; Alberto Rodriguez Natal (natal) <[email-masked]>
Subject: Re: [5gangip] blockchain mapping system

Hi Dirk, Michael, all,
IMHO, as I outlined before, I don't think blockchain can be used as a mapping system, due to the latency of adding a new mapping. In addition, I do not see how a blockchain can provide privacy for the mappings, because the locators would be stored in the blockchain and anyone could access them. It could be possible to encrypt them, but then management would be complicated.

On the other side, our proposal focuses on the cross-domain communication between mapping systems of *different* operators, ie, crossing administrative domains. In other words, the blockchain tells you which server to ask when looking for a mapping, not the mapping (equivalent to LISP-DDT). In traditional PKI schemes, this is done with cross-certification, which scales poorly (O(N^2)). So this blockchain would not be in the edge, but rather in the core of the 5G network.
Regarding Proof of Stake, one of its big advantages is that it does not require high computing resources. There are already several PoS algorithms out there, like Algorand [1], NEM's Proof of Importance [2], or Ouroboros [3], just to mention some of them.

Regards,

Jordi

El 28/03/18 a les 09:48, Mikael Abrahamsson ha escrit:
On Wed, 28 Mar 2018, [email-masked]<mailto:[email-masked]> wrote:

one application we had in mind and mentioned during the side meeting last week was to ensure privacy by providing security and trust relation (e.g. between UE and mapping data base or any two UEs) when in a ID-Loc split approach a look-up of the current location at the mapping system should be enabled. Do you think that would work efficiently?

What problem does blockchain solve in this? What downsides are there? How do we do "proof of stake"?

Blockchain is a huge strain on computing resources, and it's a complete waste of energy/time unless it solves a very specific problem that can't be solved in another way.

So again, what problems would we be solving by using blockchain instead of some other mechanism?

---

From: Jordi Paillissé Vilanova <[email-masked]>
Date: Thu, 29 Mar 2018 19:24:40 +0200

Hi Peter,

Agree, but I am not storing mapping system entries in the blockchain, 
only the pointers to the mapping system.

Regards,

Jordi

El 29/03/18 a les 16:08, AshwoodsmithPeter ha escrit:
>
> A mapping system requires that the N entries be broken up into N/M per 
> M machines and further requires that every operation take < O(Log(M)).
>
> A block chain requires that N entries be stored on M machines and 
> further requires that every operation takes > ½ the available CPU of 
> all M machines.
>
> *From:*5gangip [mailto:[email-masked]] *On Behalf Of *Jordi 
> Paillissé Vilanova
> *Sent:* Wednesday, March 28, 2018 6:16 PM
> *To:* Mikael Abrahamsson <[email-masked]>; [email-masked]
> *Cc:* [email-masked]; [email-masked]; Alberto Rodriguez Natal 
> (natal) <[email-masked]>
> *Subject:* Re: [5gangip] blockchain mapping system
>
> Hi Dirk, Michael, all,
>
> mapping system, due to the latency of adding a new mapping. In 
> addition, I do not see how a blockchain can provide privacy for the 
> mappings, because the locators would be stored in the blockchain and 
> anyone could access them. It could be possible to encrypt them, but 
> then management would be complicated.
>
> [1] https://arxiv.org/abs/1607.01341 <https://arxiv.org/abs/1607.01341>
>         one application we had in mind and mentioned during the side
>         meeting last week was to ensure privacy by providing security
>         and trust relation (e.g. between UE and mapping data base or
>         any two UEs) when in a ID-Loc split approach a look-up of the
>         current location at the mapping system should be enabled. Do
>         you think that would work efficiently?
>
>
>     complete waste of energy/time unless it solves a very specific
>     problem that can't be solved in another way.
>