Subject: [5gangip] Notes from today's meeting

From: David Allan I <[email-masked]>
Date: Thu, 22 Mar 2018 12:47:54 +0000

Enjoy
D

5Gangip Side Meeting 10:00-11:30
16 in the room

Agenda
5G Deployments/Trials
5G CT4 protocol choices
Mapping and ILA
End to end privacy enabled mapping systems
Discussion & Next Steps

IN the room:  Dirk Van Hugo, Behcet, Kalyani, Dino, Alberto Natal, Bob Moskowitz, Jon Crowcroft, Saleem, Dave, Suresh, Tom Herbert, Lorenzo, Roland Schott/DT, Sri Gundaveli, Julien Maisoneuve/Nokia, David Lake/Dell-EMC

5G Trials/Alex Petrescu
Some trials mentioned.  No discussion.

CT4 protocol choices....
No discussion.

ILA /Herbert
An ILA implementation in VPP code(?)
Problem statement: - new access, new devices, new apps.
Current problems --> usual suspects + privacy in addressing.
Encap as a hit, both cycles and MTU reduction.
Tested GUE, IPv6 etc.   v4 had best performance, v6 not far behind, in some cases better.   SR was interesting, not doing header insertion was quite good.  Suggested SR header processing less demanding than encap.  Exposing something to NW Hardware it is not used to is typically slower, H/W has been optimized for certain use cases.  ILA close to IPv6....
Dave: What is the scope of the measurement, transit only or what?  A: End to end.

ILA not a true 64/64 split anymore.
When my app calls getsockname what do I get?  This is a problem, passive FTP will have challenges with this. Will fail e2e to conformance tests.  You will get the address visible to the rest of the world. This is implemented in the host kernel.   If the translation from SIR can be done in both places the distinction is important.
DP fairly straightforward, overwriting portions of addresses.

ILA is always pairwise transformations, and needs to be undone at the far end to be transparent to the application. TCP and UDP ports are never touched.
Reference topology is not unlike LISP.  ILA Routers and ILA Notes. Routers have a full set of mappings.
Who makes an ILA-R?  Product question, not a protocol question.  Actual process is extremely simple: Overwriting 64 or 128 bits in the DP.   At 10 million entries in some routing systems.

That is where this whole thing could fall down, ILA-R as a peering router, question is size of the forwarding cache.   Someone has to have the whole routing system, forwarding from a source like the internet is not cacheable.  Uplink can have a cache of transformations.   Comms between two nodes in the network that are mobile, they can talk directly.
There are two or three use cases.  Public internet, user mobility.
If I wanted to have wifi connection and LTE connection there is a lot of mapping involved.  What is highest rate of handoff....  VoLTE is worst case today, need to characterize the handoff load.
If an ILA-N has a cache entry it sends to an ILA-R.  But the ILA-R needs to know.

If the ILA-R is connected to the internet a cache is not suitable.  It can be sharded across devices. If I do 100 shards, do I need 100 router...  I need to route to the right box, which means the problem is not solved.
If I need 100 interconnects between 100 routers in a POP it does not make sense.

Privacy Enabled Mapping System
UE has unique identifier. Address based upon location.
If identifier exposed then location can be tracked.
Address changes such that UE is always optimally routable.

Mapping system
NoSQL? DNS like? Key value?

Saleem: DNS is currently not optimized for write.  Engineering issue.
Bob:  To discover a mobile node, DNS fails in may ways.   Cannot handle double jump problem when both nodes move together. We will need a mapping system specifically designed for "where is the device now", needs privacy features etc.  Verizon has 12 anchors for 48 states?  Every operator makes it's own decisions on network design.
ILNP handles double jump problem through network layer signaling.
I look at double jump as moving from cellular to wifi.

We invented DDT to leverage the DNS lookup design without the protocols. LISP-DDT is an experimental RFC.
Pub-sub will go n-squared. Very hard to scale but if we could it would be perfect.
Blockchains suggested?  Unanimous answer is "NO!"
Jon: There are two long term research projects on scaling blockchains. Still at least 3 orders of magnitude off from a useful level of performance. Only 3?
A SBR can help with certain functional aspects of ILNP as an engineering optimization. RFC 6748 outlines tradeoffs and advantages.  Is it like an ILA-N or is it more transport like.  It needs only the sort of state a NAT function would need.  TCP checksum needs modification to ignore the top 64 bits.
Read Bob's draft on privacy attacks. There has to be some bits in the front that identify the set of keys, those are trackable. So all the packets for that individual can be tracked.  If you want to break it all the way up.  Any key or SPI value is trackable and can be associated with a source identity.   Need to start at the address and go all the way up.  IETF needs to take a serious view of all trackable numbers in IETF protocols.
Pick a random number or crypto EID.  Reference to draft..-lisp-eid-anonymity.
Look up different EIDs that map to the same locator...
What can they deduce coming out of the domain.  These are encrypted in the LISP domain, what about outside of it.  Those headers are exposed.
Counter proposal is looking at part of the prefix, cannot even tell they are in the same network.

How to define Privacy?

Vis-à-vis control plane, if there are requirements unmet, we need to address this. Control plane slide is misleading at best.

We cannot start from the POV of making things up and hope someone deploys them.

Road map to proposal for ATIC BOF.  Problem statement is to define a problem to be solved.  Lets get together and define a problem we want to solve.  Mode of operation for years that has gone nowhere.

Problems already solved with tunneling.  You find the anchor...
The point is anchorless mobility will not work. 100M in an ILA-R is an issue.   Need to distinguish between a mapping system and a forwarding cache.  Two scaling aspects of the overall system design.  A DC use case we know works, but has little to do with 5G.

We did MIPv6 in 2004, and when a binding update works, you eliminate anchor points. Does not work in radio access networks as they have their own numerology.  Qualcomm did not implement MIPv6.. that killed it.
Looking at a 20-30 fold densification of radio access.   No idea how we do that.

If we focus in everything, we get nothing.  Handling high speed mobility is one problem.

You want a cross layer architecture, mapping this to engineering solutions, what is the workload, and what is the details of the workload.   It is random movement that is a killer. Trains, buses etc. are relatively easy.

If 5G supports of a lot of direct communication, and its does it scalably, then the mapping system can do it scalable.  Direct communication does that.  Proximity service in the 4G case.

---

From: <[email-masked]>
Date: Thu, 22 Mar 2018 15:28:26 +0000

Dear Dave,
thanks for that.
To all who joined or tried to join the webex: unfortunately due to technical problems the audio was gone - and afterwards the data. We atre very sorry for that! Please look at the minutes below, the slides Behcet sent round, and come back to us with further questions.
Thanks for participation!
Best Regards
Behcet & Dirk

From: 5gangip [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Donnerstag, 22. März 2018 13:48
To: [email-masked]
Subject: [5gangip] Notes from today's meeting

Enjoy
D

Agenda
5G Deployments/Trials
5G CT4 protocol choices
Mapping and ILA

5G Trials/Alex Petrescu

CT4 protocol choices....
No discussion.

ILA /Herbert
Tested GUE, IPv6 etc.   v4 had best performance, v6 not far behind, in some cases better.   SR was interesting, not doing header insertion was quite good.  Suggested SR header processing less demanding than encap..  Exposing something to NW Hardware it is not used to is typically slower, H/W has been optimized for certain use cases.  ILA close to IPv6....

Mapping system

How to define Privacy?

---

From: Behcet Sarikaya <[email-masked]>
Date: Thu, 22 Mar 2018 18:46:24 +0000

Thanks Dave for the detailed notes.

I extracted this:

We did MIPv6 in 2004, and when a binding update works, you eliminate anchor
points. Does not work in radio access networks as they have their own
numerology.  Qualcomm did not implement MIPv6.. that killed it.

Looking at a 20-30 fold densification of radio access.   No idea how we do
that.

On the above point David Lake had stated a requirement for access network.
David can you please remind it? I am trying to collect and document the
requirements as know them. We know them.

Also Lorenzo commented on the BU message but I am not sure if it was as the
one above?

Regards

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 23 Mar 2018 08:08:11 +0000

is there a technical reason we can'tjust re-visit MIPv6 in 5g in 2018?
> _______________________________________________
> 5gangip mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/5gangip
>

---

From: <[email-masked]>
Date: Fri, 23 Mar 2018 09:18:08 +0000

No reason at all why we shouldn't consider all and every technology touted as being mobile friendly.   The question I have is whether that should done in a standards track or somewhere else (IAB Study Group, IRTF group, etc).   It would seem to me that IETF WGs are more suited to formalisation where there is a known problem and a set of potential solutions...

To the specific points (and with apologies for this being so long but I strongly feel we have a lot to discuss):

1) In 4G and proposed in 5G, there is tight integration of RAN capabilities and user service.    The best way to explain this is to look at the only service which offers a guaranteed level of quality today in mobile networks - VoLTE.   By using two bearers between the UE and the base-station and monitoring that very closely, IP traffic associated with the voice call is re-directed across a specific set of radio parameters which have a different numerology to the "default" (read Internet) traffic bearer.   The LTE core will monitor all handovers to ensure that the new serving site is capable of handling the required traffic pattern.  As voice is a known-quantity, an exact amount of RF can be allocated to the UE (within usual operational bounds).   When the VoIP traffic reaches the breakout point (PGW in 4G), it is directed to the IMS core over a dedicated SGi interface.   It is also marked/policed as you would mark/police VoIP traffic in a commercial network (i.e. NOT the Internet 😊 ). 

2) This tight coupling between RAN and IP layers allows up to 9 levels of defined air-interface quality at varying bandwidths.   The operation of the PCRF is essentially an admission system for required outcomes.  However, in 4G, the domain of this outcome is limited to the MNO - there is no way an external party could declare the "need" for a particular quality and have that managed across multiple cells.

3) In 5G, the concept of the PCRF/PCEF is extended to the PCF which in turn may be influenced by MULTIPLE, EXTERNAL AF (Application Functions).  This is important because it is the first time in mobile networks that the idea of allowing external actors to influence and determine packet treatment all the way to the UE has been considered.  You can see a situation where, for example, BBC iPlayer would be able to signal a 4k HD data stream for a specific user including making sure that the OTA numerology was set to support such a stream to the UE and packets directed over that bearer.   Likewise, should the next cell not be able to handle the stream, this can be signalled to the CDN which could then down-rate the video.    There is then a revenue chain possible - I pay the BBC to delivery me high quality video; they signal to the MNO that I want that; the MNO charges an uplift to the BBC to deliver at 4k.   This is a settlement model not possible in 4G. 

4) Densification of wireless is already being seen as a sticky problem in 5G.   Predictions suggest a 20 fold increase in radio coverage but in a mixture of mmWave (high density, low coverage distance, high bandwidth) and low-bands (lower density, high coverage, low bandwidth).  The challenge for the industry is in deploying in the current competitive model of multiple MNOs per country. At least across Europe, cell site installation and planning is a very hot-topic and unpopular with the public.  Network sharing, Neutral Host, single national carriers with MvNOs - all of these models are starting to appear in order to cope with the challenge of having to deploy vast amounts of expensive coverage in a climate of decreasing ARPUs.   The need to manage radio spectrum in the most optimal way possible is real - governments around the world have seen spectrum as a cash-cow....

5) Whilst from a network engineering perspective path-optimisation may seem like the best thing to do, there are cases in mobile networks where it isn’t.   A good example of this would again be the current VoLTE service:

	- Mobile networks are highly sub-divided by nature.   Cells connect to pre-aggregation points, which connect to S-GWs which connect to P-GW(s - country size dependent).
	- Handing over between cells can either be between the cells directly (direct fibre link, microwave link, tunnel via pre-agg site) or with reference back to the S-GW if shared between eNBs or back as far as the P-GW if served by different S-GWs).
	- Operators will try to build their networks so that the majority of handovers take place on the quickest path possible.  There are usually KPIs about maximum handover times, number of allowed lost frames for the various bearer types, etc. 
	- In terms of voice, max round trip time is 150ms.   Packetisation is usually 20ms - overheads take this up to about 35ms leaving around 40ms acceptable gap per leg.  The air interface used for VoLTE relies on a re-transmission scheme to guarantee delivery and this has a operational time of 8ms.   So, only 6 re-transmissions are allowed per voice packet.
	- If the voice service is anchored on the P-GW there is a known, reasonably constant delay - the distance from any eNB to the P-GW will be roughly the same in terms of transport speeds where-ever I am in the country.  In large countries, multiple P-GWs are used and strange things happen as you move between eNBs on different P-GWs but this is usually engineered such that the number of people this would affect is very small.
	- However, latencies on the other paths (S1 handover, X2) will be highly variable as the physical distances between them will be more varied.   You can easily envisage a scenario where a voice call handover would cause a path change length which would become material in terms of the VoIP packet size.   The simple answer is anchor such that UE<->UE media always takes the mostly fixed, longer path.

6) Looking ahead to 5G and mission-critical services, sub-1ms IoT, massive increase in mobile broadband and the VoLTE 75ms requirement becomes a walk-in-the-park.  We need to ensure that any 5G transport network is able to understand not just the packets in-flight but what is required from the RAN in order to support the use-case. 

David

-----Original Message-----
From: Jon Crowcroft [mailto:[email-masked]] 
Sent: 23 March 2018 08:08
To: [email-masked]; Behcet Sarikaya <[email-masked]>
Cc: 5GANGIP <[email-masked]>; Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>; Jon Crowcroft <[email-masked]>
Subject: Re: [5gangip] Notes from today's meeting

> We did MIPv6 in 2004, and when a binding update works, you eliminate 
> anchor points. Does not work in radio access networks as they have 
> their own numerology.  Qualcomm did not implement MIPv6.. that killed 
> it.
> 
> David can you please remind it? I am trying to collect and document 
> the requirements as know them. We know them.
> 
> 
> Also Lorenzo commented on the BU message but I am not sure if it was 
> as the one above?
> 
> 
> Regards
>

---

From: Behcet Sarikaya <[email-masked]>
Date: Fri, 23 Mar 2018 10:27:07 +0000

> is there a technical reason we can'tjust re-visit MIPv6 in 5g in 2018?

Like DLake I also think that MIPv6 and PMIPv6 should be included, these are
the products of dmm and its ancestor WGs, actually that would be the right
thing to do in dmm.

Regarding my question on the access network, I could not get the reply from
David's long reply, from my notes he said something related to always on
operation which sounded like a good requirement to me.

Regards,
Behcet

> > anchor

---

From: Jon Crowcroft <[email-masked]>
Date: Fri, 23 Mar 2018 10:47:23 +0000

so to make something fly as an IETF working group concern, its going to
have to have end-to-end-ness about it - sure we have all these properies
local to the cellular data service provider, but if packets don't leave
that domain, then the IETF probably doesn't have a stake....imho

so while there might be things like 9 air-defined interface levels, unless
there's a corresponding list of 9 diffserv services an ISP could offer,
or when there's some desiderata for delay bounding IoT traffic, unless
(like most actual IoT applications) it goes off over the backhaul, into the
WAN and possibly off into a data center/cloud service, (e.g. see
https://arxiv.org/abs/1803.05368
for some measurements)
then its outside he IETF's bailiwick i believe...

On Fri, Mar 23, 2018 at 9:18 AM, <[email-masked]> wrote:

> No reason at all why we shouldn't consider all and every technology touted
> as being mobile friendly.   The question I have is whether that should done
> in a standards track or somewhere else (IAB Study Group, IRTF group, etc).
>  It would seem to me that IETF WGs are more suited to formalisation where
> there is a known problem and a set of potential solutions...
>
> 1) In 4G and proposed in 5G, there is tight integration of RAN
> capabilities and user service.    The best way to explain this is to look
> at the only service which offers a guaranteed level of quality today in
> mobile networks - VoLTE.   By using two bearers between the UE and the
> base-station and monitoring that very closely, IP traffic associated with
> the voice call is re-directed across a specific set of radio parameters
> which have a different numerology to the "default" (read Internet) traffic
> bearer.   The LTE core will monitor all handovers to ensure that the new
> serving site is capable of handling the required traffic pattern.  As voice
> is a known-quantity, an exact amount of RF can be allocated to the UE
> (within usual operational bounds).   When the VoIP traffic reaches the
> breakout point (PGW in 4G), it is directed to the IMS core over a dedicated
> SGi interface.   It is also marked/policed as you would mark/police VoIP
> traffic in a commercial network (i.e. NOT the Internet 😊 ).
>
> 2) This tight coupling between RAN and IP layers allows up to 9 levels of
> defined air-interface quality at varying bandwidths.   The operation of the
> PCRF is essentially an admission system for required outcomes.  However, in
> 4G, the domain of this outcome is limited to the MNO - there is no way an
> external party could declare the "need" for a particular quality and have
> that managed across multiple cells.
>
> 3) In 5G, the concept of the PCRF/PCEF is extended to the PCF which in
> turn may be influenced by MULTIPLE, EXTERNAL AF (Application Functions).
> This is important because it is the first time in mobile networks that the
> idea of allowing external actors to influence and determine packet
> treatment all the way to the UE has been considered.  You can see a
> situation where, for example, BBC iPlayer would be able to signal a 4k HD
> data stream for a specific user including making sure that the OTA
> numerology was set to support such a stream to the UE and packets directed
> over that bearer.   Likewise, should the next cell not be able to handle
> the stream, this can be signalled to the CDN which could then down-rate the
> video.    There is then a revenue chain possible - I pay the BBC to
> delivery me high quality video; they signal to the MNO that I want that;
> the MNO charges an uplift to the BBC to deliver at 4k.   This is a
> settlement model not possible in 4G.
>
> 4) Densification of wireless is already being seen as a sticky problem in
> 5G.   Predictions suggest a 20 fold increase in radio coverage but in a
> mixture of mmWave (high density, low coverage distance, high bandwidth) and
> low-bands (lower density, high coverage, low bandwidth).  The challenge for
> the industry is in deploying in the current competitive model of multiple
> MNOs per country. At least across Europe, cell site installation and
> planning is a very hot-topic and unpopular with the public.  Network
> sharing, Neutral Host, single national carriers with MvNOs - all of these
> models are starting to appear in order to cope with the challenge of having
> to deploy vast amounts of expensive coverage in a climate of decreasing
> ARPUs.   The need to manage radio spectrum in the most optimal way possible
> is real - governments around the world have seen spectrum as a cash-cow....
>
> 5) Whilst from a network engineering perspective path-optimisation may
> seem like the best thing to do, there are cases in mobile networks where it
> isn’t.   A good example of this would again be the current VoLTE service:
>
>         - Mobile networks are highly sub-divided by nature.   Cells
> connect to pre-aggregation points, which connect to S-GWs which connect to
> P-GW(s - country size dependent).
>         - Handing over between cells can either be between the cells
> directly (direct fibre link, microwave link, tunnel via pre-agg site) or
> with reference back to the S-GW if shared between eNBs or back as far as
> the P-GW if served by different S-GWs).
>         - Operators will try to build their networks so that the majority
> of handovers take place on the quickest path possible.  There are usually
> KPIs about maximum handover times, number of allowed lost frames for the
> various bearer types, etc.
>         - In terms of voice, max round trip time is 150ms.   Packetisation
> is usually 20ms - overheads take this up to about 35ms leaving around 40ms
> acceptable gap per leg.  The air interface used for VoLTE relies on a
> re-transmission scheme to guarantee delivery and this has a operational
> time of 8ms.   So, only 6 re-transmissions are allowed per voice packet.
>         - If the voice service is anchored on the P-GW there is a known,
> reasonably constant delay - the distance from any eNB to the P-GW will be
> roughly the same in terms of transport speeds where-ever I am in the
> country.  In large countries, multiple P-GWs are used and strange things
> happen as you move between eNBs on different P-GWs but this is usually
> engineered such that the number of people this would affect is very small.
>         - However, latencies on the other paths (S1 handover, X2) will be
> highly variable as the physical distances between them will be more
> varied.   You can easily envisage a scenario where a voice call handover
> would cause a path change length which would become material in terms of
> the VoIP packet size.   The simple answer is anchor such that UE<->UE media
> always takes the mostly fixed, longer path.
>
> 6) Looking ahead to 5G and mission-critical services, sub-1ms IoT, massive
> increase in mobile broadband and the VoLTE 75ms requirement becomes a
> walk-in-the-park.  We need to ensure that any 5G transport network is able
> to understand not just the packets in-flight but what is required from the
> RAN in order to support the use-case.
>
>
> David
>
> Cc: 5GANGIP <[email-masked]>; Lake D Mr (PG/R - Elec Electronic Eng) <
> [email-masked]>; Jon Crowcroft <[email-masked]>

---

From: <[email-masked]>
Date: Fri, 23 Mar 2018 10:51:46 +0000

Behcet

Apologies - I tend to write long emails as I dislike the bullet-point culture...

I think that “always on” is too simplistic.  5G is supposed to cope with a wide set of use-cases delivering against a defined outcome which in turn is linked to the ability of the MNOs to charge against an SLA.

Some use-cases may be always on but even this definition hides the level of complexity and the depth of integration we will need to “layer 1” in the RAN.

David

Sent from my iPhone
_____________________________
From: Behcet Sarikaya <[email-masked]>
Sent: Friday, March 23, 2018 10:27 am
Subject: Re: [5gangip] Notes from today's meeting
To: Jon Crowcroft <[email-masked]>
Cc: 5GANGIP <[email-masked]>, Lake D Mr (PG/R - Elec Electronic Eng) <[email-masked]>

On Fri, Mar 23, 2018 at 8:08 AM, Jon Crowcroft <[email-masked]<mailto:[email-masked]>> wrote:
is there a technical reason we can'tjust re-visit MIPv6 in 5g in 2018?

Like DLake I also think that MIPv6 and PMIPv6 should be included, these are the products of dmm and its ancestor WGs, actually that would be the right thing to do in dmm.

Regarding my question on the access network, I could not get the reply from David's long reply, from my notes he said something related to always on operation which sounded like a good requirement to me.

Regards,
Behcet

> [email-masked]<mailto:[email-masked]>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 26 Mar 2018 11:39:44 +0200

Le 23/03/2018 à 11:47, Jon Crowcroft a écrit :
> that domain, then the IETF probably doesn't have a stake.....imho
> 
> so while there might be things like 9 air-defined interface levels, 
> unless there's a corresponding list of 9 diffserv services an ISP could 
> offer,
> (like most actual IoT applications) it goes off over the backhaul, into 
> the WAN and possibly off into a data center/cloud service, (e.g. see
> https://arxiv.org/abs/1803.05368 <https://arxiv.org/abs/1803..05368>

The correct URL is https://arxiv.org/abs/1803.05368 (single dot)

Alex

> 
> On Fri, Mar 23, 2018 at 9:18 AM, <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     No reason at all why we shouldn't consider all and every technology
>     touted as being mobile friendly.   The question I have is whether
>     that should done in a standards track or somewhere else (IAB Study
>     Group, IRTF group, etc).   It would seem to me that IETF WGs are
>     more suited to formalisation where there is a known problem and a
>     set of potential solutions...
> 
>     To the specific points (and with apologies for this being so long
>     but I strongly feel we have a lot to discuss):
> 
>     capabilities and user service.    The best way to explain this is to
>     look at the only service which offers a guaranteed level of quality
>     today in mobile networks - VoLTE.   By using two bearers between the
>     UE and the base-station and monitoring that very closely, IP traffic
>     associated with the voice call is re-directed across a specific set
>     of radio parameters which have a different numerology to the
>     "default" (read Internet) traffic bearer.   The LTE core will
>     monitor all handovers to ensure that the new serving site is capable
>     of handling the required traffic pattern.  As voice is a
>     known-quantity, an exact amount of RF can be allocated to the UE
>     (within usual operational bounds).   When the VoIP traffic reaches
>     the breakout point (PGW in 4G), it is directed to the IMS core over
>     a dedicated SGi interface.   It is also marked/policed as you would
>     mark/police VoIP traffic in a commercial network (i.e. NOT the
>     Internet 😊 ).
> 
>     2) This tight coupling between RAN and IP layers allows up to 9
>     levels of defined air-interface quality at varying bandwidths.   The
>     operation of the PCRF is essentially an admission system for
>     required outcomes.  However, in 4G, the domain of this outcome is
>     limited to the MNO - there is no way an external party could declare
>     the "need" for a particular quality and have that managed across
>     multiple cells.
> 
>     3) In 5G, the concept of the PCRF/PCEF is extended to the PCF which
>     in turn may be influenced by MULTIPLE, EXTERNAL AF (Application
>     Functions).  This is important because it is the first time in
>     mobile networks that the idea of allowing external actors to
>     influence and determine packet treatment all the way to the UE has
>     been considered.  You can see a situation where, for example, BBC
>     iPlayer would be able to signal a 4k HD data stream for a specific
>     user including making sure that the OTA numerology was set to
>     support such a stream to the UE and packets directed over that
>     bearer.   Likewise, should the next cell not be able to handle the
>     stream, this can be signalled to the CDN which could then down-rate
>     the video.    There is then a revenue chain possible - I pay the BBC
>     to delivery me high quality video; they signal to the MNO that I
>     want that; the MNO charges an uplift to the BBC to deliver at 4k. 
>       This is a settlement model not possible in 4G.
> 
>     4) Densification of wireless is already being seen as a sticky
>     problem in 5G.   Predictions suggest a 20 fold increase in radio
>     coverage but in a mixture of mmWave (high density, low coverage
>     distance, high bandwidth) and low-bands (lower density, high
>     coverage, low bandwidth).  The challenge for the industry is in
>     deploying in the current competitive model of multiple MNOs per
>     country. At least across Europe, cell site installation and planning
>     is a very hot-topic and unpopular with the public.  Network sharing,
>     Neutral Host, single national carriers with MvNOs - all of these
>     models are starting to appear in order to cope with the challenge of
>     having to deploy vast amounts of expensive coverage in a climate of
>     decreasing ARPUs.   The need to manage radio spectrum in the most
>     optimal way possible is real - governments around the world have
>     seen spectrum as a cash-cow....
> 
>     5) Whilst from a network engineering perspective path-optimisation
>     may seem like the best thing to do, there are cases in mobile
>     networks where it isn’t.   A good example of this would again be the
>     current VoLTE service:
> 
>     connect to pre-aggregation points, which connect to S-GWs which
>     connect to P-GW(s - country size dependent).
>              - Handing over between cells can either be between the
>     cells directly (direct fibre link, microwave link, tunnel via
>     pre-agg site) or with reference back to the S-GW if shared between
>     eNBs or back as far as the P-GW if served by different S-GWs).
>              - Operators will try to build their networks so that the
>     majority of handovers take place on the quickest path possible. 
>     There are usually KPIs about maximum handover times, number of
>     allowed lost frames for the various bearer types, etc.
>              - In terms of voice, max round trip time is 150ms. 
>       Packetisation is usually 20ms - overheads take this up to about
>     35ms leaving around 40ms acceptable gap per leg.  The air interface
>     used for VoLTE relies on a re-transmission scheme to guarantee
>     delivery and this has a operational time of 8ms.   So, only 6
>     re-transmissions are allowed per voice packet.
>              - If the voice service is anchored on the P-GW there is a
>     known, reasonably constant delay - the distance from any eNB to the
>     P-GW will be roughly the same in terms of transport speeds
>     where-ever I am in the country.  In large countries, multiple P-GWs
>     are used and strange things happen as you move between eNBs on
>     different P-GWs but this is usually engineered such that the number
>     of people this would affect is very small.
>              - However, latencies on the other paths (S1 handover, X2)
>     will be highly variable as the physical distances between them will
>     be more varied.   You can easily envisage a scenario where a voice
>     call handover would cause a path change length which would become
>     material in terms of the VoIP packet size.   The simple answer is
>     anchor such that UE<->UE media always takes the mostly fixed, longer
>     path.
> 
>     6) Looking ahead to 5G and mission-critical services, sub-1ms IoT,
>     massive increase in mobile broadband and the VoLTE 75ms requirement
>     becomes a walk-in-the-park.  We need to ensure that any 5G transport
>     network is able to understand not just the packets in-flight but
>     what is required from the RAN in order to support the use-case.
> 
> 
>     David
> 
>     From: Jon Crowcroft [mailto:[email-masked]
>     <mailto:[email-masked]>]
>     To: [email-masked] <mailto:[email-masked]>; Behcet Sarikaya
>     <[email-masked] <mailto:[email-masked]>>
>     Cc: 5GANGIP <[email-masked] <mailto:[email-masked]>>; Lake D Mr
>     (PG/R - Elec Electronic Eng) <[email-masked]
>     <mailto:[email-masked]>>; Jon Crowcroft
>     <[email-masked] <mailto:[email-masked]>>
>      > [email-masked] <mailto:[email-masked]>
>     <https://www.ietf.org/mailman/listinfo/5gangip>
>      >
> 
> 
> 
>

---

From: Alexandre Petrescu <[email-masked]>
Date: Mon, 26 Mar 2018 11:49:11 +0200

> is there a technical reason we can'tjust re-visit MIPv6 in 5g in 2018?

If it were up to me...

To revisit, I would start looking at the tunnelling mechanism, identify
what's missing from GTP, or how is it too heavy.

For the client side, I would consider talking to the cellular operators
that do put software in the smartphones (e.g. Bouygues puts VoLTE
software in handsets, whereas Free does not put any software in the
handset). These operators are used to put software in the client, and
the Mobile Node entity of MIPv6 protocol is such a client.

For those operators that dont put any software in the handset I would
check who they are hosted by (i.e. on whom do they depend, if they are
MVNO). E.g. in France Free is mostly an MVNO on top of Orange, and it
would be Orange that would need to consider PMIP, not Free.

I would get input from 5G trials and ask them why dont they use IPv6
instead of IPv4. The only 5G trial I am aware of uses IPv4. IPv6 is a
quintessential part of the Mobile IPv6 protocol.

I would talk to an important router manufacturer and ask whether their
HA implementation (Home Agent is an essential entity of the Mobile IPv6
protocol) is still bugged at the lifetime value.

IMHO, these are blocking points in deployment of MIPv6 in cellular networks.

Alex

---

From: <[email-masked]>
Date: Mon, 26 Mar 2018 09:49:52 +0000

Thanks Alex,
for pointing this out!
I already wondered about the broken link ...
Best Regards
Dirk 

-----Original Message-----
From: 5gangip [mailto:[email-masked]] On Behalf Of Alexandre Petrescu
Sent: Montag, 26. März 2018 11:40
To: [email-masked]
Subject: Re: [5gangip] Notes from today's meeting

Le 23/03/2018 à 11:47, Jon Crowcroft a écrit :
> so to make something fly as an IETF working group concern, its going 
> to have to have end-to-end-ness about it - sure we have all these 
> properies local to the cellular data service provider, but if packets 
> don't leave that domain, then the IETF probably doesn't have a 
> stake.....imho
> 
> unless there's a corresponding list of 9 diffserv services an ISP 
> could offer, or when there's some desiderata for delay bounding IoT 
> traffic, unless (like most actual IoT applications) it goes off over 
> the backhaul, into the WAN and possibly off into a data center/cloud 
> service, (e.g. see

Alex

---

From: Behcet Sarikaya <[email-masked]>
Date: Mon, 26 Mar 2018 10:38:31 -0500

Hi Alex,

> quintessential part of the Mobile IPv6 protocol.

Dino was in Pyeong Chang  for the olympics and he is pretty sure that no
trial has happened even in Seoul.
I think that the trials are expected in 2019.

> IMHO, these are blocking points in deployment of MIPv6 in cellular
This is an old issue and I think that dmm people should discuss not us.

BTW in the meeting last week Lorenzo (I think it was him) commented on
Binding Update (BU) message not working, maybe because of security issues
IS the problem.

Behcet