Subject: [68ATTENDEES] Bogus IPv6 adverts

From: Rémi Denis-Courmont <[email-masked]>
Date: Mon, 19 Mar 2007 16:48:31 +0200

Hello,

Sorry for the evil broadcast, but could the gentle owner of Intel (wireless?) 
00:12:F0:5F:C4:EC MAC address stop sending bogus IPv6 radvd that are 
competing with the "normal" ones. Yes, I can (and do) firewall them by hand, 
but...

Thanks in advance,
Regards,

-- 
Rémi Denis-Courmont

_______________________________________________
68ATTENDEES mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/68attendees

---

From: Bernie Hoeneisen <[email-masked]>
Date: Mon, 19 Mar 2007 16:18:18 +0100 (CET)

Hi Remi!

You do not necessairly have to do this by hand (depending on your OS).
My collegue Simon Leinen once has written a little Perl Script (see 
Attachment), which does the job. It works perfectly on my Ubuntu Linux.
Thanks a lot, Simon!

Enjoy!

cheers,
  Bernie

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 19 Mar 2007 16:27:25 +0100

well, basic inspection of the script tells me that:
- it seems restricted to 6to4 advertisers.
- it is very dependent on linux "ip" command. so not usable for other  
OS unless ported.

(no criticism implied, just stating facts and expectations).

Marc.

Le 07-03-19 à 16:18, Bernie Hoeneisen a écrit :

>> <filterBogusIPv6RAs.perl>

-----
IPv6 book: Migrating to IPv6, Wiley, 2006, http://www.ipv6book.ca

---

From: Bernie Hoeneisen <[email-masked]>
Date: Mon, 19 Mar 2007 17:02:30 +0100 (CET)

Hi Marc!

> - it seems restricted to 6to4 advertisers.

Have you seen any other kind of RAs so far?

> - it is very dependent on linux "ip" command. so not usable for other OS 
> unless ported.

Everybody is free to port it to another OS (and send it around).
(It's kind of hard to test without this other OS in question...)

BTW: Has anybody tried the script on OSX? Does it work without 
modifications?

cheers,
  Bernie

---

From: Marc Blanchet <[email-masked]>
Date: Mon, 19 Mar 2007 17:10:46 +0100

> Have you seen any other kind of RAs so far?

I had received 3 prefixes up to now, one of which is 6to4.

>
>> - it is very dependent on linux "ip" command. so not usable for  
>> other OS unless ported.
>

of course. I was just stating the facts of the code you sent.

> BTW: Has anybody tried the script on OSX? Does it work without  

I have a MacOSX, and to my knowledge, the linux "ip" command is not  
available. So it would require some porting work!

Marc.

>>> My collegue Simon Leinen once has written a little Perl Script  
>>> (see Attachment), which does the job. It works perfectly on my  
>>> Ubuntu Linux.
>>> Thanks a lot, Simon!
>>> Enjoy!
>>> cheers,
>>> Bernie

-----

---

From: Jim Martin <[email-masked]>
Date: Mon, 19 Mar 2007 17:12:03 +0100

The offending wireless MAC (and it's concerned owner) has graciously  
stopped by the NOC. We're working on gently silencing it as we speak.  
Thanks for pointing this out!

	- Jim

---

From: David Brossard <[email-masked]>
Date: Mon, 19 Mar 2007 09:38:01 -0700

This offending device has been found and dealt with.

---

From: Mohacsi Janos <[email-masked]>
Date: Mon, 19 Mar 2007 17:46:05 +0100 (CET)

Currently there is still 2 IPv6 routers:
00:0b:bf:a9:70:70 medium pref 2001:df8:0:16::/64
00:0b:bf:a9:6c:70 medium pref 2001:df8:0:16::/64
00:12:f0:5f:c4:ec  finally vanished....
Regards,

Janos Mohacsi
Network Engineer
NIIF/HUNGARNET, HUNGARY
Key 70EF9882: DEC2 C685 1ED4 C95A 145F  4300 6F64 7B00 70EF 9882

On Mon, 19 Mar 2007, Jim Martin wrote:

> stopped by the NOC. We're working on gently silencing it as we speak. Thanks 
> for pointing this out!
>
> 	- Jim
>

---

From: Morgan Sackett <[email-masked]>
Date: Mon, 19 Mar 2007 18:00:58 +0100

There seems to be a feature of Windows XP Internet Connection Sharing  
when IPv6 and is on.  Since it is a gateway, it would decide that it  
is a IPv6 router and start sending RAs.

Please check your machine to make sure that connection sharing is  
disabled while you are on this network.

Thanks!
Morgan

On Mar 19, 2007, at 5:38 PM, David Brossard wrote:

>> Sorry for the evil broadcast, but could the gentle owner of Intel  
>> (wireless?) 00:12:F0:5F:C4:EC MAC address stop sending bogus IPv6  
>> radvd that are competing with the "normal" ones. Yes, I can (and  
>> do) firewall them by hand, but...
>>
>> Thanks in advance,
>> Regards,
>>
>>
>

Morgan Sackett
VP of Engineering

VeriLAN Event Services, Inc.
215 SE Morrison Street Suite 2000F
Portland, OR 97214

Tel: 503 224-8822
Fax: 503 224-8833
Cell: 503 969-2154

[email-masked]
www.verilan.com

This e-mail contains proprietary information and may be confidential.  
If you are not the intended recipient of this e-mail, you are hereby  
notified that any dissemination, distribution or copying of this  
message is strictly prohibited. If you received this message in  
error, please delete it immediately.

---

From: Bill Fenner <[email-masked]>
Date: Mon, 19 Mar 2007 18:15:40 +0100

>00:0b:bf:a9:6c:70 medium pref 2001:df8:0:16::/64

Those are the two actual routers for the site network.

  Bill

---

From: Stewart Bryant <[email-masked]>
Date: Wed, 21 Mar 2007 16:25:27 +0000

I am not sure who to ask about this, but
it seems that the old tradition of an ice cream
break on Thursday afternoon has disappeared at
recent IETFs.

Please can we restore the traditional ice cream
break?

- Stewart

---

From: "Keith Kyzivat" <[email-masked]>
Date: Wed, 21 Mar 2007 18:30:23 +0100

It would make sense, since it seems that the folks in Czechoslovakia have a
particular affinity for Ice Cream -- though it doesn't seem quite as strong
as in Massachusetts, USA.

-- 
Keith Kyzivat

SIPez LLC.
SIP VoIP, IM and Presence Consulting
http://www.SIPez.com
tel: +1 (617) 273-4000
_______________________________________________
68ATTENDEES mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/68attendees

---

From: Nemeth Krisztian <[email-masked]>
Date: Wed, 21 Mar 2007 19:07:48 +0100 (CET)

> It would make sense, since it seems that the folks in Czechoslovakia have a

(Czech & Slovak Republics split in 1993)

---

From: Eric Burger <[email-masked]>
Date: Wed, 21 Mar 2007 19:15:25 +0100

I don¹t know ‹ maybe we should have the community decide.

I also won¹t mind a $1,000 registration fee, either :-)

On 3/21/07 6:30 PM, "Keith Kyzivat" <[email-masked]> wrote:

> particular affinity for Ice Cream -- though it doesn't seem quite as strong as
> in Massachusetts, USA.
> 

_______________________________________________________________________
Notice:  This email message, together with any attachments, may contain
information  of  BEA Systems,  Inc.,  its subsidiaries  and  affiliated
entities,  that may be confidential,  proprietary,  copyrighted  and/or
legally privileged, and is intended solely for the use of the individual
or entity named in this message. If you are not the intended recipient,
and have received this message in error, please immediately return this
by email and then delete it.
_______________________________________________
68ATTENDEES mailing list
[email-masked]
https://www1.ietf.org/mailman/listinfo/68attendees

---

From: "Keith Kyzivat" <[email-masked]>
Date: Wed, 21 Mar 2007 19:27:09 +0100

Slip of the fingers... not meant as anything beyond that.

-- 
Keith Kyzivat

SIPez LLC.

---

From: Nemeth Krisztian <[email-masked]>
Date: Wed, 21 Mar 2007 19:29:44 +0100 (CET)

me neither :)