Subject: [6lo-fragmentation-dt] mailing list, organization, proposal

From: Thomas Watteyne <[email-masked]>
Date: Thu, 25 Jan 2018 12:23:46 +0100

All,

*ML*

Welcome to the 6lo Fragmentation DT. This is a private ML. Here are the
people currently subscribed:

   - Carsten
   - Rahul
   - Pascal
   - Thomas
   - Gabriel

*organization*

I'd like to keep this activity as swift as possible, ideally close the DT
after London.
I don't want to grow this DT, I don't want to pull in all kinds of people.
Let's stay agile.

*proposal*

Our first goal as a DT is to agree on a plan of action, and report back to
Gabriel.
I propose that this DT generates 2 documents:

   - a first informational document
      - summarize fragmentation as standardized now
      - describes Carsten's virtual reassembly buffer implementation
      - discusses its limits
   - a second standards-track document builds upon the first one and adds
   fragment recovery, as detailed in draft-thubert-6lo-forwarding-fragments.
   This document can either be a replacement
   of draft-thubert-6lo-forwarding-fragments, or a rework of it

Please voice your opinion in the next 24h about this plan. The next steps
are to assign editors to each document.

Thomas

-- 
_______________________________________

Thomas Watteyne, PhD
Research Scientist & Innovator, Inria
Sr Networking Design Eng, Linear Tech
Founder & co-lead, UC Berkeley OpenWSN
Co-chair, IETF 6TiSCH

www.thomaswatteyne.com
_______________________________________

---

From: Rahul Jadhav <[email-masked]>
Date: Thu, 25 Jan 2018 18:43:37 +0530

Yes i m ok with the plan.
Can someone please tell me where can I get information about Carstens virtual reassembly buffer implementation? I remember you guys discussing about it during our meet last time but i didn't had a clue!

Thanks,
Rahul 

> On 25-Jan-2018, at 4:53 PM, Thomas Watteyne <[email-masked]> wrote:
> 
> All,
> 
> ML
> 
> Welcome to the 6lo Fragmentation DT. This is a private ML. Here are the people currently subscribed:
> Carsten
> Rahul
> Pascal
> Thomas
> Gabriel
> organization
> 
> I'd like to keep this activity as swift as possible, ideally close the DT after London.
> I don't want to grow this DT, I don't want to pull in all kinds of people. Let's stay agile.
> 
> proposal
> 
> Our first goal as a DT is to agree on a plan of action, and report back to Gabriel.
> a first informational document
> summarize fragmentation as standardized now
> describes Carsten's virtual reassembly buffer implementation
> discusses its limits
> a second standards-track document builds upon the first one and adds fragment recovery, as detailed in draft-thubert-6lo-forwarding-fragments. This document can either be a replacement of draft-thubert-6lo-forwarding-fragments, or a rework of it
> Please voice your opinion in the next 24h about this plan. The next steps are to assign editors to each document.
> 
> Thomas
> 
> -- 
> _______________________________________________
> 6lo-fragmentation-dt mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo-fragmentation-dt

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 25 Jan 2018 14:57:35 +0100

Rahul,
I am putting together a document that details it. I will send it to this ML
when it's ready.
Thomas

On Thu, Jan 25, 2018 at 2:13 PM, Rahul Jadhav <[email-masked]> wrote:

> Can someone please tell me where can I get information about Carstens
> virtual reassembly buffer implementation? I remember you guys discussing
> about it during our meet last time but i didn't had a clue!
>
> Thanks,
> Rahul
>
>    This document can either be a replacement of draft-thubert-6lo-forwarding-fragments,
>    or a rework of it
>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 25 Jan 2018 14:32:36 +0000

I’m good with the plan Thomas;

If people are good to use my draft as starting point for the second document I’m happy to serve as editor, and welcome co authors.

Regards,

Pascal

Le 25 janv. 2018 à 14:14, Rahul Jadhav <[email-masked]<mailto:[email-masked]>> a écrit :

Thanks,
Rahul

On 25-Jan-2018, at 4:53 PM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:

All,

ML

  *   Carsten
  *   Rahul
  *   Pascal
  *   Thomas
  *   Gabriel

organization

proposal

  *   a first informational document
     *   summarize fragmentation as standardized now
     *   describes Carsten's virtual reassembly buffer implementation
     *   discusses its limits
  *   a second standards-track document builds upon the first one and adds fragment recovery, as detailed in draft-thubert-6lo-forwarding-fragments. This document can either be a replacement of draft-thubert-6lo-forwarding-fragments, or a rework of it

Thomas

Thomas Watteyne, PhD

www.thomaswatteyne.com<http://www.thomaswatteyne.com>
_______________________________________
_______________________________________________
6lo-fragmentation-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lo-fragmentation-dt
_______________________________________________
6lo-fragmentation-dt mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lo-fragmentation-dt

---

From: Gabriel Montenegro <[email-masked]>
Date: Thu, 25 Jan 2018 17:58:43 +0000

Thanks Thomas and DT!

Sounds like a good plan, yes. BTW, you’re missing one member as announced in Singapore: Gorry Fairhurst [email-masked]<mailto:[email-masked]>

Please add him.

Thanks,

Gabriel

From: 6lo-fragmentation-dt [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: 25 January, 2018 03:24
To: [email-masked]
Subject: [6lo-fragmentation-dt] mailing list, organization, proposal

All,

ML

  *   Carsten
  *   Rahul
  *   Pascal
  *   Thomas
  *   Gabriel
organization

proposal

Thomas

Thomas Watteyne, PhD

www.thomaswatteyne.com<https://na01.safelinks.protection.outlook.com/?url=http%3A%2F%2Fwww.thomaswatteyne.com&data=02%7C01%7CGabriel.Montenegro%40microsoft.com%7C15a00e9d69f141e613c308d563e62ddc%7Cee3303d7fb734b0c8589bcd847f1c277%7C1%7C0%7C636524762636818621&sdata=C5ElfyQHTVKFSs2oWkh3A%2FP%2Bv1b1iHy4PCTDEajDq5Q%3D&reserved=0>
_______________________________________

---

From: Carsten Bormann <[email-masked]>
Date: Thu, 25 Jan 2018 23:04:40 +0100

On Jan 25, 2018, at 14:13, Rahul Jadhav <[email-masked]> wrote:
> 
> Can someone please tell me where can I get information about Carstens virtual reassembly buffer implementation?

Here:
https://tools.ietf.org/html/draft-bormann-lwig-6lowpan-virtual-reassembly-00

Grüße, Carsten

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 26 Jan 2018 09:08:44 +0100

Arg, I had just written up pretty much the same thing. I'll coordinate with
you offline.

On Thu, Jan 25, 2018 at 11:04 PM, Carsten Bormann <[email-masked]> wrote:

> virtual reassembly buffer implementation?
>
> Here:

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 26 Jan 2018 10:13:48 +0100

Resending this e-mail as I had forgotten to add Gorry to the ML. Sorry,
Gorry!

On Fri, Jan 26, 2018 at 9:08 AM, Thomas Watteyne <[email-masked]>
wrote:

> Arg, I had just written up pretty much the same thing. I'll coordinate
> with you offline.
>

Thomas Watteyne, PhD

www.thomaswatteyne.com

---

From: Rahul Jadhav <[email-masked]>
Date: Fri, 26 Jan 2018 18:49:46 +0530

Thanks Carsten.

> On 26-Jan-2018, at 2:43 PM, Thomas Watteyne <[email-masked]> wrote:
> 
> Resending this e-mail as I had forgotten to add Gorry to the ML. Sorry, Gorry!
> 
>> On Fri, Jan 26, 2018 at 9:08 AM, Thomas Watteyne <[email-masked]> wrote:
>> Arg, I had just written up pretty much the same thing. I'll coordinate with you offline.
>>