Subject: [6lo] draft-ietf-6lo-lowpanz-01 with last call comments addressed

From: Anders Brandt <[email-masked]>
Date: Tue, 21 Jan 2014 14:42:05 +0000

All,

Thanks for taking your time to review this draft.
The comments have been addressed in -01 which was submitted today.

http://tools.ietf.org/html/draft-ietf-6lo-lowpanz-01

Thank you,
  Anders.

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 21 Jan 2014 16:48:37 +0100

Hi Anders,

thanks for the update.

I’m still confused about all the options in this draft (if… MUST/SHOULD/???).
I’ll try to tabulate this in the next couple of days and then build an opinion.

One question that comes to mind is RFC 6282 support.
You (reasonably) say it MUST be supported (i.e. ability to receive), and SHOULD be used (i.e., sent), but this means I still have to implement a decoder for the uncompressed dispatch type even if I never plan to send that dispatch type.

I’m asking because, at the last 6LoWPAN plugtest, it seemed we had more bugs in the code for the uncompressed dispatch type than everywhere else combined.

Have you considered simply taking out the uncompressed dispatch type?
That might be a bit drastic for 802.15.4 (or it might not be), but for a radio newly coming to 6LoWPAN, fewer options means less code and less interop issues, so it will be an overall win.

Grüße, Carsten