Subject: [6lo] Call to confirm a rough consensus on RPL info

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 15 Oct 2014 06:32:10 +0000

Dear all: 

During the 6TiSCH bi-weekly virtual interim on Friday, we agreed that the minimal I-D (draft-ietf-6tisch-minimal) must indicate the compression method for the RPL Information (see RFC 6553), so as to ensure interoperation between 6TiSCH devices.

We discussed our options, basically either a 6lo approach or a Flow Label approach. The rough consensus at the call was to try and focus on a 6lo approach and evaluate where that leads us. 

Because this means that the minimal draft will have a normative reference on a WIP I-D, we recognized that this approach may delay the publication of the final RFC. Per IETF procedures, the minimal draft will be stalled in the RFC editor queue in MISREF state until the 6lo work completes. So the consensus was also to support the 6lo work so as to expedite it as much as possible. 

The idea would be to republish a standard track draft-ietf-6lo- ASAP, based on the existing proposals (which are rapidly converging); then, Xavi would include a normative reference to that work in the minimal I-D before its publication to IESG, which is scheduled in November (yes, this is aggressive).

This is a call to confirm the rough consensus on the ML, open till the next interim call on October 24th. Please provide us with any relevant comment (and participate to the 6lo discussions in the meantime!).

If the result is positive:
- we plan to call for a 6lo WG doc adoption in Hawaii
- we are looking for an aggressive schedule to limit the impact on the publication of the minimal RFC

6TiSCH may host the 6lo discussion so as to:
- benefit from the early morning schedule
- attract more 6TiSCH people to the discussion 

More the published minutes: 
- Webex recording: https://cisco.webex.com/ciscosales/lsr.php?RCID=36a3b7df06694258a3ac65bfc519212f 
- Wiki: https://bitbucket.org/6tisch/meetings/wiki/141010_webex 
- Slides: https://bitbucket.org/6tisch/meetings/src/master/141010_webex/slides_141010_webex.ppt

Cheers,

Pascal

---

From: Xavier Vilajosana <[email-masked]>
Date: Wed, 15 Oct 2014 08:45:53 +0200

All,

I fully support that approach. Hope to contribute and make it happen as
soon as possible.

regards,
Xavi

2014-10-15 8:32 GMT+02:00 Pascal Thubert (pthubert) <[email-masked]>:

> Dear all:
>
> During the 6TiSCH bi-weekly virtual interim on Friday, we agreed that the
> minimal I-D (draft-ietf-6tisch-minimal) must indicate the compression
> method for the RPL Information (see RFC 6553), so as to ensure
> interoperation between 6TiSCH devices.
>
> We discussed our options, basically either a 6lo approach or a Flow Label
> approach. The rough consensus at the call was to try and focus on a 6lo
> approach and evaluate where that leads us.
>
> Because this means that the minimal draft will have a normative reference
> on a WIP I-D, we recognized that this approach may delay the publication of
> the final RFC. Per IETF procedures, the minimal draft will be stalled in
> the RFC editor queue in MISREF state until the 6lo work completes. So the
> consensus was also to support the 6lo work so as to expedite it as much as
> possible.
>
> The idea would be to republish a standard track draft-ietf-6lo- ASAP,
> based on the existing proposals (which are rapidly converging); then, Xavi
> would include a normative reference to that work in the minimal I-D before
> its publication to IESG, which is scheduled in November (yes, this is
> aggressive).
>
> This is a call to confirm the rough consensus on the ML, open till the
> next interim call on October 24th. Please provide us with any relevant
> comment (and participate to the 6lo discussions in the meantime!).
>
> - Webex recording:
> https://cisco.webex.com/ciscosales/lsr.php?RCID=36a3b7df06694258a3ac65bfc519212f
> - Slides:
> https://bitbucket.org/6tisch/meetings/src/master/141010_webex/slides_141010_webex.ppt
>
> Cheers,
>
> Pascal
>
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll
>

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 21 Oct 2014 17:38:18 -0700

+1 on the proposal.

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 22 Oct 2014 00:56:55 +0000

I think I'm +1 on the proposal - was compression of 6553 options the ONLY required compression in the "minimal" case ? (apologies...I wasn't on the call) I did a quick search of minimal-02 and didn't see the word compression anywhere.

Thanks!
Randy

From: Thomas Watteyne <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, October 21, 2014 at 8:38 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Roll] Call to confirm a rough consensus on RPL info

+1 on the proposal.

On Tue, Oct 14, 2014 at 11:45 PM, Xavier Vilajosana <[email-masked]<mailto:[email-masked]>> wrote:
All,

I fully support that approach. Hope to contribute and make it happen as soon as possible.

regards,
Xavi

2014-10-15 8:32 GMT+02:00 Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>>:

Dear all:

Cheers,

Pascal

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

_______________________________________________
Roll mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/roll

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 22 Oct 2014 01:30:03 +0000

Diego,

I am forwarding your request to 6lo. You might want to join the 6lo list as well.

-Samita

From: Prof. Diego Dujovne [mailto:[email-masked]]
Sent: Tuesday, October 21, 2014 6:09 PM
To: Routing Over Low power and Lossy networks
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [Roll] Call to confirm a rough consensus on RPL info

+1!

2014-10-21 21:38 GMT-03:00 Thomas Watteyne <[email-masked]<mailto:[email-masked]>>:
+1 on the proposal.

regards,
Xavi

Dear all:

Cheers,

Pascal

--
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl<http://www.ingenieria.udp.cl>
(56 2) 676 8125

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 21 Oct 2014 19:16:57 -0700

Randy,
Are you alluding to 6554?
Thomas

On Tue, Oct 21, 2014 at 5:56 PM, Turner, Randy <[email-masked]>
wrote:

>
>  I think I’m +1 on the proposal – was compression of 6553 options the
> ONLY required compression in the “minimal” case ? (apologies…I wasn’t on
> the call) I did a quick search of minimal-02 and didn’t see the word
> compression anywhere.
>
>  Thanks!
> Randy
>
>   From: Thomas Watteyne <[email-masked]>
> Reply-To: "[email-masked]" <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>, "
> [email-masked]" <[email-masked]>
>>> During the 6TiSCH bi-weekly virtual interim on Friday, we agreed that
>>> the minimal I-D (draft-ietf-6tisch-minimal) must indicate the compression
>>> We discussed our options, basically either a 6lo approach or a Flow
>>> Label approach. The rough consensus at the call was to try and focus on a
>>> 6lo approach and evaluate where that leads us.
>>>
>>> Because this means that the minimal draft will have a normative
>>> reference on a WIP I-D, we recognized that this approach may delay the
>>> publication of the final RFC. Per IETF procedures, the minimal draft will
>>> be stalled in the RFC editor queue in MISREF state until the 6lo work
>>> completes. So the consensus was also to support the 6lo work so as to
>>> expedite it as much as possible.
>>>
> This e-mail (including any attachments) is confidential and may be legally
> privileged. If you are not an intended recipient or an authorized
> representative of an intended recipient, you are prohibited from using,
> copying or distributing the information in this e-mail or its attachments.
> If you have received this e-mail in error, please notify the sender
> immediately by return e-mail and delete all copies of this message and any
> attachments. Thank you.
>
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Randy Turner <[email-masked]>
Date: Wed, 22 Oct 2014 00:11:50 -0400

Yes, in Pascal's call for consensus he only mentions 6553... Just curious if the phone call consensus was only about requiring compression of 6553 options...or are there any other compression methods that the minimal draft must include

Thanks!
Randy

Sent from my iPad

> On Oct 21, 2014, at 10:16 PM, Thomas Watteyne <[email-masked]> wrote:
> 
> Randy,
>> On Tue, Oct 21, 2014 at 5:56 PM, Turner, Randy <[email-masked]> wrote:
>> 
>> I think I’m +1 on the proposal – was compression of 6553 options the ONLY required compression in the “minimal” case ? (apologies…I wasn’t on the call) I did a quick search of minimal-02 and didn’t see the word compression anywhere.  
>> 
>> Thanks!
>> Randy
>> 
>> Cc: "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
>>> On Tue, Oct 14, 2014 at 11:45 PM, Xavier Vilajosana <[email-masked]> wrote:
>>> All,
>>> 
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 22 Oct 2014 04:13:34 +0000

Forgot to reply to lists as well :)...see my reply to Thomas below

On Oct 22, 2014, at 12:11 AM, "Randy Turner" <[email-masked]<mailto:[email-masked]>> wrote:

Thanks!
Randy

Sent from my iPad

On Oct 21, 2014, at 10:16 PM, Thomas Watteyne <[email-masked]<mailto:[email-masked]>> wrote:

Randy,

On Tue, Oct 21, 2014 at 5:56 PM, Turner, Randy <[email-masked]<mailto:[email-masked]>> wrote:

Thanks!
Randy

+1 on the proposal.

regards,
Xavi

Dear all:

Cheers,

Pascal

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_______________________________________________
6lo mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6lo

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 22 Oct 2014 12:21:09 +0000

Hello Randy:

6553 is where there was a lot to be gained; OTOH, 6554 already optimizes by factoring prefixes. Would you have suggestions for better?

Cheers,

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Randy Turner
Sent: mercredi 22 octobre 2014 06:12
To: Thomas Watteyne
Cc: Routing Over Low power and Lossy networks; Turner, Randy; [email-masked]; [email-masked]
Subject: Re: [6lo] [6tisch] [Roll] Call to confirm a rough consensus on RPL info

Thanks!
Randy

Sent from my iPad

Thanks!
Randy

+1 on the proposal.

regards,
Xavi

Dear all:

Cheers,

Pascal

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 22 Oct 2014 14:24:01 +0200

On 22 Oct 2014, at 14:21, Pascal Thubert (pthubert) <[email-masked]> wrote:
> 
> 6554 already optimizes by factoring prefixes

Well, yes.  It still has a lot of static overhead.
More importantly, in keeping with the routing header construction, it keeps the full list downstream, which appears to me as a big waste of energy.

Grüße, Carsten

---

From: "Turner, Randy" <[email-masked]>
Date: Wed, 22 Oct 2014 12:34:01 +0000

Hi Pascal

I don't have any specific suggestions at the moment, it was more of a clarification question with regards to the general consensus from the last phone call, since I was unable to participate

Thanks!
Randy

On Oct 22, 2014, at 8:21 AM, "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>> wrote:

Hello Randy:

Cheers,

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Randy Turner
Sent: mercredi 22 octobre 2014 06:12
To: Thomas Watteyne
Cc: Routing Over Low power and Lossy networks; Turner, Randy; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [6lo] [6tisch] [Roll] Call to confirm a rough consensus on RPL info

Thanks!
Randy

Sent from my iPad

Thanks!
Randy

+1 on the proposal.

regards,
Xavi

Dear all:

Cheers,

Pascal

---

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Tue, 21 Oct 2014 22:09:02 -0300

+1!

www.ingenieria.udp.cl
(56 2) 676 8125