Subject: [6lo] 6775-update requirements

From: "Turner, Randy" <[email-masked]>
Date: Wed, 8 Oct 2014 14:42:11 +0000

It's good to see the draft 6lo-rfc6775-update-reqs - we have been looking at "cherry-picking" features of RFC 6775 that would benefit larger mesh-based RPL networks.  Specifically, RFC 6775 seems to be the only document that specifies how to disseminate RFC 6282 compression contexts, which can benefit RPL networks as well.

Also, 6775 presumes that in the presence of EUI-64-based addressing, DAD is not required - which would reduce such traffic on a large mesh too.

I think the "RPL Leaf Support" in the draft is a good example of joining these two worlds, but there are other mechanisms in 6775 that might be useful in the broader RPL network.

One topological issue we have with the draft  is that sometimes, we need to combine the LBR/BBR functionality, and there is no "backbone link" to interconnect these nodes - the LBR/BBR nodes have independent WAN connections back to the plant gateway.

In addition to "RPL Leaf Support" we may want to identify other scenarios in which 6775 (or follow on) mechanisms could benefit both networks.  Basically, I think we need guidance in this area.

Randy

P PLEASE CONSIDER OUR ENVIRONMENT BEFORE PRINTING THIS EMAIL.

This e-mail (including any attachments) is confidential and may be legally privileged. If you are not an intended recipient or an authorized representative of an intended recipient, you are prohibited from using, copying or distributing the information in this e-mail or its attachments. If you have received this e-mail in error, please notify the sender immediately by return e-mail and delete all copies of this message and any attachments. Thank you.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 8 Oct 2014 16:19:08 +0000

Hello Randy:

The draft does not intend to force to have a BBR and a backbone. If that is the impression then I have to fix it. Or the BBR may be physically collapsed with the 6LBR since these are logical functions. Also the BBR may we swapped to another router that converts, say, efficnent ND into a LISP or MIPv6 registration over a backhaul.

All in all, the Efficient ND interface provides an abstraction that separates the classical routing on the north from the IoT routing on the south.

I hope that makes sense?

Pascal

From: 6lo [mailto:[email-masked]] On Behalf Of Turner, Randy
Sent: mercredi 8 octobre 2014 16:42
To: [email-masked]'
Subject: [6lo] 6775-update requirements

Randy