Subject: Re: [6lo] New version notification for draft-rizzo-6lo-6legacy-02.txt

From: Marcin Piotr Pawlowski <[email-masked]>
Date: Fri, 03 Oct 2014 13:23:23 +0200

Hello,

First of all thanks for the draft it is very interesting.

I have found two issues:

First, You have stated in the "5. 6TONon-IP Mapping Method" in
"Technology Mapping field" that "For IID which are larger than 32 bits,
a hashing function is used instead of direct mapping" but in the "6.1.
Example 1 - EIB/KNX" the IID is 20 bits of length and You have applied
the hashing function on it instead of direct mapping. Could You clarify
that?

Second, I believe that in "6.2. Example 2 - RFID" at the end of the
first paragraph You should have "RFID technology ID is "4"" instead of "1".

BTW, have You already implemented solution based on this draft?

Thank You for Your time!

Best regards,
mpp

On 09/25/14 10:30, Gianluca Rizzo wrote:
> 
> 
>  
>  
> 
> ------------------------------------------------------------------------
> *Gianluca Rizzo*/
> Senior Researcher,/
> /Institute IIG - Sierre (VS)/
> // 
> /Tel: +41 27 606 9006/
> /Skype ID: gianluca_rizzo/
>  
> 	
> Email : 	[email-masked] <mailto:[email-masked]>
> 	
> 
> 	http://www.hevs.ch <http://www.hevs.ch/>
> ------------------------------------------------------------------------
> *HES-SO Valais-Wallis* • Techno-Pôle 3 • 3960 Sierre
> <http://www.hevs.ch/GoTP>
> +41 27 606 90 01 • [email-masked] <mailto:[email-masked]> •
> www.hevs.ch <http://www.hevs.ch/> 	Valais excellence
> 
> 
> 
>>>> Gianluca Rizzo 9/25/2014 10:18 am >>>
> Hi all,
> I have submitted a new version of the draft draft-rizzo-6lo-6legacy-02
> onIPv6 mapping to non-IP protocols.
> 
> We have introduced some changes with respect to the first version,
> taking into account the feedback received at the 89th meeting in London.
> 
> More specifically:
> - The new version adds some use cases, which help understanding the
> importance of adopting a common IPv6-based
> framework for interaction between things, and the need for legacy
> devices to be
> individually addressable through IPv6.
> 
> -Moreover, we have changed the format of the of the Host ID part of the
> IPv6 address obtained
> from the mapping, in order to support a larger number of legacy protocols.
> 
> -We have discussed briefly some of the security concerns raised.
> 
> -The intended status is now informational.
> 
> 
> Please let me know your comments about the new version.
> 
> Best,
> Gianluca
> 
> Gianluca Rizzo
> Senior Researcher,
> Institute IIG - Sierre (VS)
> 
> Tel: +41 27 606 9006
> Skype ID: gianluca_rizzo
> 
> 
> Email : [email-masked]
> http://www.hevs.ch
> HES-SO Valais-Wallis Techno-Pôle 3 3960 Sierre ( http://www.hevs.ch/GoTP )
> +41 27 606 90 01 [email-masked] www.hevs.ch
> 
> 
> 
> 
> 
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo
>

---

From: "Gianluca Rizzo" <[email-masked]>
Date: Fri, 17 Oct 2014 16:00:56 +0200

Hi Marcin, 

thanks for the appreciation. 

In the next version of the draft we will fix the examples to agree with the proposed mapping method.

We already have some implementations in the context of the IoT6 European project. 

Best,
Gianluca

Gianluca Rizzo
Senior Researcher,

Tel: +41 27 606 9006
Skype ID: gianluca_rizzo

http://www.hevs.ch 

HES-SO Valais-Wallis • Techno-Pôle 3 • 3960 Sierre
+41 27 606 90 01 • [email-masked] • www.hevs.ch

>>> Marcin Piotr Pawlowski <[email-masked]> 10/3/2014 1:23 pm >>>
Hello,

I have found two issues:

Thank You for Your time!

Best regards,
mpp