Subject: [6lo] FW: New Version Notification for draft-thubert-6lo-rfc6775-update-reqs-05.txt

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 27 Oct 2014 16:37:09 +0000

Dear all:

This updates applies a number of changes:

- Erik suggested to make the draft concise, focusing on requirements. This is now most of what is left of the draft.
- Don added requirements from the AMI/AMR space (Don can you please review?)

I did not add the changes from Peter at this round because 1) they were extensive, and 2) a lot of the text is gone anyway. But I owe you that, Peter.

Also, and related, there is an identified need for another pass to add support for non-RPL routing protocols. I hope the list will help clarify what is needed there.

Cheers,

Pascal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: lundi 27 octobre 2014 17:29
To: Pascal Thubert (pthubert); Pascal Thubert (pthubert)
Subject: New Version Notification for draft-thubert-6lo-rfc6775-update-reqs-05.txt

A new version of I-D, draft-thubert-6lo-rfc6775-update-reqs-05.txt
has been successfully submitted by Pascal Thubert and posted to the IETF repository.

Name:		draft-thubert-6lo-rfc6775-update-reqs
Revision:	05
Title:		Requirements for an update to 6LoWPAN ND
Document date:	2014-10-27
Group:		Individual Submission
Pages:		14
URL:            http://www.ietf.org/internet-drafts/draft-thubert-6lo-rfc6775-update-reqs-05.txt
Status:         https://datatracker.ietf.org/doc/draft-thubert-6lo-rfc6775-update-reqs/
Htmlized:       http://tools.ietf.org/html/draft-thubert-6lo-rfc6775-update-reqs-05
Diff:           http://www.ietf.org/rfcdiff?url2=draft-thubert-6lo-rfc6775-update-reqs-05

Abstract:
   Work presented at the ROLL, 6lo, 6TiSCH and 6MAN Working Groups
   suggest that enhancements to the 6LoWPAN ND mechanism are now needed.
   This document elaborates on those requirements and suggests
   approaches to serve them.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Carsten Bormann <[email-masked]>
Date: Mon, 27 Oct 2014 23:33:56 +0100

On 27 Oct 2014, at 23:22, Brett, Patricia (PA62) <[email-masked]> wrote:
> 
> Will the update for routing include discussion of "mesh-under" routing?

Are there any known requirements on updating RFC 6775 for mesh-under routing?
(I.e., what is broken?)

Grüße, Carsten

---

From: "Brett, Patricia (PA62)" <[email-masked]>
Date: Mon, 27 Oct 2014 22:22:03 +0000

Hi Pascal,
Regards,
Pat

-----Original Message-----
From: 6tisch [mailto:[email-masked]] On Behalf Of Pascal Thubert (pthubert)
Sent: Monday, October 27, 2014 12:37 PM
To: [email-masked]
Cc: [email-masked]
Subject: [6tisch] FW: New Version Notification for draft-thubert-6lo-rfc6775-update-reqs-05.txt

Dear all:

Cheers,

Pascal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: lundi 27 octobre 2014 17:29
To: Pascal Thubert (pthubert); Pascal Thubert (pthubert)
Subject: New Version Notification for draft-thubert-6lo-rfc6775-update-reqs-05.txt

Abstract:

The IETF Secretariat

_______________________________________________
6tisch mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6tisch

---

From: "Brett, Patricia (PA62)" <[email-masked]>
Date: Tue, 28 Oct 2014 02:46:07 +0000

Carsten,
Mesh under been in use and working for years in an IEC wireless standard for a low power network. 
As such it should be an option.
Pat

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Monday, October 27, 2014 6:34 PM
To: Brett, Patricia (PA62)
Cc: Pascal Thubert (pthubert); [email-masked]; [email-masked]
Subject: Re: [6tisch] New Version Notification for draft-thubert-6lo-rfc6775-update-reqs-05.txt

Grüße, Carsten

---

From: Carsten Bormann <[email-masked]>
Date: Tue, 28 Oct 2014 07:38:38 +0100

> As such it should be an option.

Certainly.  RFC 6775 was designed to be applicable to both mesh-under and route-over routing.

E.g., it starts out saying:

> 1.3.  Goals and Assumptions
> 
>    The document has the following main goals and assumptions.
> 
>    Goals:
> 
>    o  Optimize Neighbor Discovery with a mechanism that is minimal yet
>       sufficient for the operation in both mesh-under and route-over
>       configurations.
> […]

Now, if there is something amiss about the mesh-under support in RFC 6775, that would be good to know.

Grüße, Carsten

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 28 Oct 2014 07:46:11 +0000

Same here, Pat. There is no anti-mesh-under intention. From the L3 perspective the mesh under looks like one hop and we must cover that case, certainly!

We already have requirements that apply to one L3 hop like the capability to proxy on the backbone, but nothing that is specific to a multi L2 hops mesh under.

If you are aware of requirements that we missed please let us know... Now is the time !

Pascal

---

From: "Brett, Patricia (PA62)" <[email-masked]>
Date: Tue, 28 Oct 2014 11:59:54 +0000

Hi Pascal,
I understood from Pat Kinney that 802 is considering taking up some work w.r.t. mesh under.
Regards,
Pat

-----Original Message-----
From: Pascal Thubert (pthubert) [mailto:[email-masked]] 
Sent: Tuesday, October 28, 2014 3:46 AM
To: Carsten Bormann
Cc: Brett, Patricia (PA62); [email-masked]; [email-masked]
Subject: Re: [6tisch] New Version Notification for draft-thubert-6lo-rfc6775-update-reqs-05.txt

Pascal

Le 28 oct. 2014 à 07:38, Carsten Bormann <[email-masked]> a écrit :

>> [.]

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 28 Oct 2014 15:41:20 +0000

Hello Pat:

Yes, 802.15.10 is working on defining a mesh under L2-Routing technology.
For all I know the scope of the work does not include the upper layer operations, including L3 and neighbor discovery.
IOW, I do not see that this work, if successful, would be pushing anything new onto IETF.

Cheers,

Pascal

> From: Brett, Patricia (PA62) [mailto:[email-masked]]
> Sent: mardi 28 octobre 2014 13:00
> To: Pascal Thubert (pthubert); Carsten Bormann
> Cc: [email-masked]; [email-masked]; Brett, Patricia (PA62)
> Subject: RE: [6tisch] New Version Notification for draft-thubert-6lo-rfc6775-
> update-reqs-05.txt
> 
> Hi Pascal,
> Same here, Pat. There is no anti-mesh-under intention. From the L3
> perspective the mesh under looks like one hop and we must cover that case,
> certainly!
> 
> We already have requirements that apply to one L3 hop like the capability to
> proxy on the backbone, but nothing that is specific to a multi L2 hops mesh
> under.
>

---

From: Brian Haberman <[email-masked]>
Date: Tue, 28 Oct 2014 12:03:19 -0400

Hi Pascal,

On 10/28/14 11:41 AM, Pascal Thubert (pthubert) wrote:
> Hello Pat:
> 
> Yes, 802.15.10 is working on defining a mesh under L2-Routing
> technology. For all I know the scope of the work does not include the
> upper layer operations, including L3 and neighbor discovery. IOW, I
> do not see that this work, if successful, would be pushing anything
> new onto IETF.

Dan Romascanu is our IEEE 802 liaison and could help you get any info
you need on the 802.15.10 effort.

Regards,
Brian