Subject: [6lo] Call for Agenda items (IETF91)

From: Samita Chakrabarti <[email-masked]>
Date: Fri, 10 Oct 2014 15:50:28 +0000

Hello All:

We have requested 2 hours time slot for 6lo WG meeting in IETF91.

Please send  your requests for presentation slots to [email-masked]<mailto:[email-masked]> with the following information:

*         Name of your draft - presenter

*         Short description of the presentation  proposal

WG drafts and the drafts that have had discussions at the WG mailing list will have priorities.
Please note: 2014-10-27 (Monday): Internet Draft submission cut-off (for all drafts, including -00) by UTC 23:59

Best regards,
-Ralph and Samita

---

From: Michael Richardson <[email-masked]>
Date: Sat, 11 Oct 2014 17:23:05 -0400

> Please send your requests for presentation slots to
    > [email-masked]<mailto:[email-masked]> with the
    > following information:

    > * Name of your draft - presenter

               A compression mechanism for the RPL option
                      draft-thubert-6lo-rpl-nhc-01

Not my draft, but I think that 6tisch and ROLL have concluded that this 
is the right direction forward.  We think that this requires 6lo blessing
and/or adoption.

I think that some facetime to solidify this.  Maybe 6lo feels this is 
out of scope for 6lo; let me know.

-- 
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 12 Oct 2014 09:07:35 +0000

+1

I already asked for a slot in Hawaii on that topic. ROLL and 6TiSCH are looking for a firm commitment by 6lo to move the work forward swiftly so as to meet the dependancies we have. 

This obviously comes with the commitment from ROLL and 6TiSCH people to contribute to the 6lo discussion.

And also quite obviously, this does not alter the need the 6man allows LLN devices to set and reset the flow label - at least to 0 - so as to avoid to have to transport 20 bits that are of no use in the LLN.

Cheers,

Pascal

> Le 11 oct. 2014 à 23:23, Michael Richardson <[email-masked]> a écrit :
> 
> 
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 12 Oct 2014 14:16:48 +0200

> This obviously comes with the commitment from ROLL and 6TiSCH people to contribute to the 6lo discussion.

I’m not seeing a ROLL meeting on the Hawaii agenda — will that then be in the 6low (and 6tisch) meetings?

Grüße, Carsten

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Sun, 12 Oct 2014 13:11:36 +0000

I'd say this belongs to 6lo but hopefully will attract people from other groups, Carsten.

Cheers,

Pascal

> Le 12 oct. 2014 à 14:17, Carsten Bormann <[email-masked]> a écrit :
>

---

From: Carsten Bormann <[email-masked]>
Date: Sun, 12 Oct 2014 15:19:09 +0200

>                      draft-thubert-6lo-rpl-nhc-01

To make this discussion more interesting, I just submitted my version of this draft as

	draft-bormann-6lo-rpl-mesh-02

Htmlized:       http://tools.ietf.org/html/draft-bormann-6lo-rpl-mesh-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-bormann-6lo-rpl-mesh-02

This is slightly less efficient for common cases than draft-bormann-6lo-rpl-mesh-01 was, but makes use of the NHC idea in draft-thubert-6lo-rpl-nhc-01.
The main reason I am submitting this is to avoid the extensive consumption of NHC code points that is proposed by draft-thubert-6lo-rpl-nhc-01.

Grüße, Carsten

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 15 Oct 2014 06:41:18 +0000

Hello Carsten and Laurent:

I'm happy that we are rapidly converging. Certainly, our great progress helped a lot the call we are making at 6TiSCH to focus on a 6lo-based approach.

My quick reading is that the differences are now very minor. I think we are ready to document them as an executive summary, and ask for a feedback on the ML. If we do so rapidly, we may be able to publish a common document that would focus on the solution, so as to call for adoption in Hawaii.

Does that work?

Pascal

> -----Original Message-----
> From: 6lo [mailto:[email-masked]] On Behalf Of Carsten Bormann
> Sent: dimanche 12 octobre 2014 15:19
> To: Michael Richardson
> Cc: Samita Chakrabarti; [email-masked]; Ralph Droms (rdroms)
> Subject: Re: [6lo] Call for Agenda items (IETF91)
> 
> This is slightly less efficient for common cases than draft-bormann-6lo-rpl-
> mesh-01 was, but makes use of the NHC idea in draft-thubert-6lo-rpl-nhc-01.
> The main reason I am submitting this is to avoid the extensive consumption
> of NHC code points that is proposed by draft-thubert-6lo-rpl-nhc-01.
> 
> Grüße, Carsten
>

---

From: Carsten Bormann <[email-masked]>
Date: Wed, 15 Oct 2014 09:23:06 +0200

Hi Pascal,

as I said previously [1], I wrote my version of the draft both to focus on the solution that we actually need to standardize and to reduce the codepoint footprint.  There certainly is no point in having two drafts here, so I’m ready to merge.  The “executive summary” of the open technical question is:

1)
Are we ready to allocate 1/4 of the NHC code space to RFC 6553 compression (knowing that RFC 6554 compression is the next thing we probably want to tackle)?

2)
And, if we aren’t ready to do this, is the “escape code” approach of my draft [2] the right one to be more skimpy on code point space?

Grüße, Carsten

[1] https://www.ietf.org/mail-archive/web/6lo/current/msg00693.html
[2] http://tools.ietf.org/html/draft-bormann-6lo-rpl-mesh-02

---

From: Samita Chakrabarti <[email-masked]>
Date: Thu, 16 Oct 2014 01:31:53 +0000

Hi Pascal and Carsten:

Glad to see that there are more than one proposals on the table and they  are converging.

I'm no expert in HC - but from generic design point of view it would be nice to have a solution that
Is 1)  generic and applies to different versions of RPL (as pointed out below) 2) Saving bits in the header 3) less complex from implementation point of view 4) flexible if there are future changes in the base protocols.

How do these two drafts compare  for 3) and 4) ?

Thanks,
-Samita

-----Original Message-----
From: Carsten Bormann [mailto:[email-masked]] 
Sent: Wednesday, October 15, 2014 12:23 AM
To: Pascal Thubert (pthubert)
Cc: Michael Richardson; Samita Chakrabarti; Ralph Droms (rdroms); [email-masked]
Subject: Re: [6lo] Call for Agenda items (IETF91)

Hi Pascal,

as I said previously [1], I wrote my version of the draft both to focus on the solution that we actually need to standardize and to reduce the codepoint footprint.  There certainly is no point in having two drafts here, so I'm ready to merge.  The "executive summary" of the open technical question is:

1)

2)
And, if we aren't ready to do this, is the "escape code" approach of my draft [2] the right one to be more skimpy on code point space?

Grüße, Carsten

On 15 Oct 2014, at 08:41, Pascal Thubert (pthubert) <[email-masked]> wrote:

>> The main reason I am submitting this is to avoid the extensive 
>> consumption of NHC code points that is proposed by draft-thubert-6lo-rpl-nhc-01.
>> 
>> Grüße, Carsten
>>