Subject: [6lo] routing-dispatch (6lorh) change in ownership from 6LO to ROLL

From: Gabriel Montenegro <[email-masked]>
Date: Thu, 17 Mar 2016 22:15:47 +0000

Hi folks,

We've had some discussions among the 6lo and ROLL chairs and personnel as well as the responsible AD's (Brian, Alvaro and Suresh) to the effect that the following draft (aka 6lorh) is better suited for ROLL than 6lo:

*        https://tools.ietf.org/wg/6lo/draft-ietf-6lo-routing-dispatch/

This draft uses the framework established in the paging-dispatch draft, which is clearly in 6lo's scope:

*        https://tools.ietf.org/wg/6lo/draft-ietf-6lo-paging-dispatch/

We're moving 6lorh (routing-dispatch) to ROLL. Sure, 6lorh uses something out of 6lo (the paging-dispatch draft), but it is so specific to ROLL that the document belongs there.

This is analogous to how DHC has operated over many years: base DHCP format changes happen in DHC, but applications of DHC mechanisms specific to any given technology are best developed by the relevant WG (of course, with review by DHC to double-check the use of DHC facilities).

Similarly, 6lo will be in the loop to review routing-dispatch, to make sure it uses paging-dispatch properly. But routing-dispatch is so specific to ROLL that further development, WG LC, IESG processing, etc., will happen under ROLL.

Thanks,

Gabriel (on behalf of ROLL and 6LO chairs)

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Mar 2016 10:46:42 +0000

Hello Gabriel:

That is perfectly fine with me, and I have 2 procedural questions:

1)      Can I submit as draft-roll or do we need an adoption call there?

2)      Draft -6lorh is stable, ready to last call IMHO.  The critical decisions involving formats and header orders are probably already taken. What may be still subject to discussion and that is of specific value to ROLL is bit mapping to protocols or things like that. Since we are transitioning areas, it would be good that 6lo expresses a blessing of the current shape and form so that unless there is a major change, we do not need to recirculate the document again through areas to go to IESG. Based on the fact that 6lo adopted it in the first place, will 6lo be happy that the ROLL WG completes the editorial work on RPL relayed semantics and ships from routing area without handing back the result?

Cheers,

Pascal

From: Gabriel Montenegro [mailto:[email-masked]]
Sent: jeudi 17 mars 2016 23:16
To: [email-masked]; [email-masked]; [email-masked]; Routing Over Low power and Lossy networks <[email-masked]>
Cc: [email-masked]; [email-masked]; Michael Richardson <[email-masked]>; Alvaro Retana (aretana) <[email-masked]>; Suresh Krishnan <[email-masked]>; James Woodyatt ([email-masked]) <[email-masked]>; Ralph Droms <[email-masked]>; Brian Haberman <[email-masked]>
Subject: routing-dispatch (6lorh) change in ownership from 6LO to ROLL

Hi folks,

Thanks,

---

From: Michael Richardson <[email-masked]>
Date: Fri, 18 Mar 2016 08:48:26 -0400

> 1) Can I submit as draft-roll or do we need an adoption call there?

That's a good question.  My instinct is that since the adoption call was
actually done in ROLL already, no.  Drafts can just be adopted by chairs.

    > 2) Draft -6lorh is stable, ready to last call IMHO. The critical
    > decisions involving formats and header orders are probably already
    > taken. What may be still subject to discussion and that is of specific
    > value to ROLL is bit mapping to protocols or things like that. Since
    > we are transitioning areas, it would be good that 6lo expresses a
    > blessing of the current shape and form so that unless there is a major
    > change, we do not need to recirculate the document again through areas
    > to go to IESG. Based on the fact that 6lo adopted it in the first
    > place, will 6lo be happy that the ROLL WG completes the editorial work
    > on RPL relayed semantics and ships from routing area without handing
    > back the result?

So you are perhaps asking for a Consensus call on the shape of the 6LoRH
solution from the 6lo WG?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
IETF ROLL WG outgoing co-chair.    http://datatracker.ietf.org/wg/roll/charter/

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 18 Mar 2016 13:53:14 +0000

Hello Michael
> actually done in ROLL already, no.  Drafts can just be adopted by chairs.

I'm sure you meant adoption done at 6lo. And I agree with you entirely. An adjacent point being that we have a lot of cross participation and that ROLL members actually participated to the call at 6lo which was heavily advertised on 6lo, ROLL, and 6TiSCH.

> solution from the 6lo WG?

Yes, Ideally I'd like to see it as 6lo saying, well, we're done and happy but prior to IESG please review it from the ROLL / RPL perspective to ensure completeness WRT to the aspect relevant to RPL. Maybe all we need os the chairs telling us that they feel the consensus exists at 6lo, and that they are happy to delegate the last call to ROLL?

Take care,

Pascal

---

From: Michael Richardson <[email-masked]>
Date: Fri, 18 Mar 2016 15:46:44 -0400

> I'm sure you meant adoption done at 6lo. And I agree with you
    > entirely. An adjacent point being that we have a lot of cross
    > participation and that ROLL members actually participated to the call
    > at 6lo which was heavily advertised on 6lo, ROLL, and 6TiSCH.

I thought that we did a cross-WG call to adopt it into 6lo.

    > Yes, Ideally I'd like to see it as 6lo saying, well, we're done and
    > happy but prior to IESG please review it from the ROLL / RPL
    > perspective to ensure completeness WRT to the aspect relevant to
    > RPL. Maybe all we need os the chairs telling us that they feel the
    > consensus exists at 6lo, and that they are happy to delegate the last
    > call to ROLL?

I think that would suffice, if ADs approve.

---

From: "Alvaro Retana (aretana)" <[email-masked]>
Date: Fri, 18 Mar 2016 22:27:40 +0000

That works for me.

Thanks!

Alvaro.

Thumb-typed and autocorrected..

---

From: Gabriel Montenegro <[email-masked]>
Date: Fri, 18 Mar 2016 22:40:47 +0000

This document now belongs to ROLL, so it is their decision with their AD on how to progress 6loRH.

As for a blessing from 6lo, I think the point is that this is more a ROLL technology, so it should be ROLL giving it a blessing (or not). 

Sure, we've done a bit of this informally as ROLL participants have been active in 6lo, but what we're doing now is making it a bit more formal, so I'd rather defer to the ROLL chairs and AD for any further discussion and questions on 6loRH. 6lo may have opinions on their usage of the paging-dispatch draft, of course.

When I say more formal I don't mean more time. So, whereas ultimately the draft may change into a draft-ietf-roll, I would imagine that such a step is not a prerequisite for ROLL to issue their last call on the document. Since a revision or more will surely follow eventually, the name change can happen at that time. But again, that is ROLL's call now.

> -----Original Message-----
> From: Alvaro Retana (aretana) [mailto:[email-masked]]
> Sent: Friday, March 18, 2016 15:28
> To: Michael Richardson <[email-masked]>
> Cc: Pascal Thubert (pthubert) <[email-masked]>; Gabriel Montenegro
> <[email-masked]>; draft-ietf-6lo-paging-
> [email-masked]; [email-masked];
> [email-masked]; Routing Over Low power and Lossy networks <[email-masked]>;
> [email-masked]; [email-masked]; Suresh Krishnan
> <[email-masked]>; James Woodyatt ([email-masked])
> <[email-masked]>; Ralph Droms <[email-masked]>; Brian
> Haberman <[email-masked]>
> Subject: Re: routing-dispatch (6lorh) change in ownership from 6LO to ROLL
> 
> That works for me.
> 
> Thanks!
> 
> Alvaro.
> 
> >> perspective to ensure completeness WRT to the aspect relevant to RPL.
> >> Maybe all we need os the chairs telling us that they feel the

---

From: Brian Haberman <[email-masked]>
Date: Fri, 18 Mar 2016 19:13:46 -0400

Works for me as well.

Regards,
Brian

> On Mar 18, 2016, at 6:27 PM, Alvaro Retana (aretana) <[email-masked]> wrote:
> 
> That works for me.
> 
> Thanks!
> 
> Alvaro.
>

---

From: peter van der Stok <[email-masked]>
Date: Mon, 21 Mar 2016 08:44:59 +0100

Happy to collaborate, but still dependent on Ines point of view.
I would suggest that I-D is submitted as ietf-roll-.
That does not need to take time; only the existing draft with a new 
draft identifier.

I prefer to start WGLC during the meeting in B-A, having explained the 
situation.

Anything I am overlooking?

Peter

Brian Haberman schreef op 2016-03-19 00:13:
> _______________________________________________
> Roll mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/roll

---

From: Ines Robles <[email-masked]>
Date: Mon, 21 Mar 2016 23:08:40 +0200

Hi,

> Happy to collaborate, but still dependent on Ines point of view.

It is ok for me, Pascal just submitted the new version. :)
> I prefer to start WGLC during the meeting in B-A, having explained the 
Yes, we can start the WGLC on monday 4th.