Subject: Re: [6lo] WGLC for draft-ietf-6lo-ethertype-request-00.txt

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 20 Apr 2016 17:25:51 +0000

Comments :

'Introduction' section of this draft  indicates a few bullet points on how it might be useful in 802.15.9 and  wifi/Ethernet technologies , but it is not clear to me that if this type is now mandatory for other non-802.15.4  L2 technologies as well.

Can you please add a section on the document on usage with other L2 technologies? Or is this draft only limited to Wifi/Ethernet technologies?

If it applies to other foo L2 technologies, then an explanation is requested  as to when to consider adding this "type" in the solution and whether any existing RFCs( bt-le, lowpanz etc.) require any modification.

Best regards,
-Samita

From: Samita Chakrabarti
Sent: Wednesday, April 20, 2016 10:07 AM
To: [email-masked]
Cc: [email-masked]
Subject: WGLC for draft-ietf-6lo-ethertype-request-00.txt

Hello All:

The WG Last Call for the following document starts today.

Please provide your input on improving the document and comments on proceeding towards the next step.

The LC will end on May 4, 2016.

Thank you.

-Samita & Gabriel

>        Title           : Assignment of an Ethertype for IPv6 with LoWPAN Encapsulation
>        Authors         : Ralph Droms
>                          Paul Duffy
>             Filename        : draft-ietf-6lo-ethertype-request-00.txt
>             Pages           : 4
>             Date            : 2016-04-18
>
> Abstract:
>   When carried over layer 2 technologies such as Ethernet, IPv6
>   datagrams using LoWPAN encapsulation as defined in RFC 4944 must be
>   identified so the receiver can correctly interpret the encoded IPv6
>   datagram.  This document requests the assignment of an Ethertype for
>   that purpose.
>
>
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ietf-6lo-ethertype-request/
>
> There's also a htmlized version available at:
> https://tools.ietf.org/html/draft-ietf-6lo-ethertype-request-00

---

From: Paul Duffy <[email-masked]>
Date: Wed, 20 Apr 2016 16:16:52 -0400

Hi Samita

...

On 4/20/2016 1:25 PM, Samita Chakrabarti wrote:
>
> Comments :
>
> ‘Introduction’ section of this draft  indicates a few bullet points on 
> how it might be useful in 802.15.9 and  wifi/Ethernet technologies , 
> but it is not clear to me that if this type is now mandatory for other 
> non-802.15.4  L2 technologies as well.
>
> Can you please add a section on the document on usage with other L2 
> technologies? Or is this draft only limited to Wifi/Ethernet technologies?
>

 From the intro ...

    o  Usage of LoWPAN encapsulation in conjunction with IEEE 802.15.9
       Multiplexed Data Service [IEEE802159 
<https://tools.ietf.org/html/draft-ietf-6lo-ethertype-request-00#ref-IEEE802159>], which provides the ability
       to perform upper layer protocol dispatch for IEEE 802.15.4
       networks.  Wi-SUN Alliance intends to use the 15.9 Multiplexed
       Data Information Element to dispatch LoWPAN encapsulation frames
       to upper stack layers.  As specified in IEEE 802.15.9, dispatch of
       LoWPAN encapsulation frames will require an Ethertype be assigned
       for LoWPAN encapsulation.

> If it applies to other foo L2 technologies, then an explanation is 
> requested  as to when to consider adding this “type” in the solution 
> and whether any existing RFCs( bt-le, lowpanz etc.) require any 
> modification.
>
> Best regards,
>
> -Samita
>
> *From:*Samita Chakrabarti
> *Sent:* Wednesday, April 20, 2016 10:07 AM
> *To:* [email-masked]
> *Cc:* [email-masked]
> *Subject:* WGLC for draft-ietf-6lo-ethertype-request-00.txt
>
> Hello All:
>

---

From: Samita Chakrabarti <[email-masked]>
Date: Wed, 20 Apr 2016 22:05:35 +0000

Hi Paul,

I understand the quoted part of the intro section below.

I have discussed with Ralph to update with  a little more information/clarification in favor of other 6lo technologies and documents.

Thanks,
-Samita

From: Paul Duffy [mailto:[email-masked]]
Sent: Wednesday, April 20, 2016 1:17 PM
To: Samita Chakrabarti; Ralph Droms (rdroms) ([email-masked])
Cc: [email-masked]
Subject: Re: WGLC for draft-ietf-6lo-ethertype-request-00.txt

Hi Samita

...

      Multiplexed Data Service [IEEE802159<https://tools.ietf.org/html/draft-ietf-6lo-ethertype-request-00#ref-IEEE802159>], which provides the ability

Best regards,
-Samita

From: Samita Chakrabarti
Sent: Wednesday, April 20, 2016 10:07 AM
To: [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: WGLC for draft-ietf-6lo-ethertype-request-00.txt

Hello All:

Thank you.

-Samita & Gabriel