Subject: [6lo] recoverable fragments: should we adapt the fragment size to ECN?

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 21 May 2019 13:05:33 +0000

Dear all:

During the review by Laurent, a question came up on we could change the fragment size when transmitting a datagram.
As it goes we can, because the offset and size are indicated in each fragment. If the MTU goes down and a fragment must be resend, we can also resend a smaller piece with the original fragment sequence and send other fragments with unused sequences for the rest of the original fragment. This is made possible because the sequence is sequential in the bitmap but not in the order of fragments.
That being said, a reaction to an ECN is to reduce the window. At the same time a node could also reduce the datagram size and enable a more streamlined transmission for all.

What do you all think?

Pascal

---

From: Abdussalam Baryun <[email-masked]>
Date: Mon, 27 May 2019 10:13:01 +0200

On Tue, May 21, 2019 at 3:05 PM Pascal Thubert (pthubert) <
[email-masked]> wrote:

> Dear all:
>
> *   During the review by Laurent, a question came up on we could change
> the fragment size when transmitting a datagram. As it goes we can, because
> the offset and size are indicated in each fragment. If the MTU goes down
> and a fragment must be resend, we can also resend a smaller piece with the
> original fragment sequence and send other fragments with unused sequences
> for the rest of the original fragment. This is made possible because the
> sequence is sequential in the bitmap but not in the order of fragments.
> That being said, a reaction to an ECN is to reduce the window. At the same
> time a node could also reduce the datagram size and enable a more
> streamlined transmission for all.   What do you all think? *
>

I think we should not change size to smaller when transmitting, but if
needed it must be limited for special cases.

AB

> *  Pascal   *
>
>
>
>
> * _______________________________________________ 6lo mailing list
> [email-masked] <[email-masked]> https://www.ietf.org/mailman/listinfo/6lo
> <https://www.ietf.org/mailman/listinfo/6lo> *