Subject: [6lo] recoverable fragments: use page 1

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 21 May 2019 13:10:50 +0000

Dear all:

During the review by Laurent, a question came up on whether we could use page 1 for fragments. At the moment the fragment is always before the 6lo routing header so there is no point. But say that we source route the fragments end to end with a 6loRH, e.g., for projected DAO. Then supporting page 1 as well would save a page switch.

What do you all think?

Pascal

---

From: Michael Richardson <[email-masked]>
Date: Tue, 21 May 2019 09:49:31 -0400

Pascal Thubert (pthubert) <[email-masked]> wrote:
    > During the review by Laurent, a question came up on whether we could use page
    > 1 for fragments.

This implies to me that we'd allocate code points for fragments from page 1.

    > At the moment the fragment is always before the 6lo routing
    > header so there is no point. But say that we source route the fragments end
    > to end with a 6loRH, e.g., for projected DAO. Then supporting page 1 as well
    > would save a page switch.

What exactly does it mean to support page 1?
Duplicate code points?
Starting in page 1 mode for fragments?
Allocating all fragment code points from page 1?

Maybe we should have a document about source routing fragments end to end for
projected DAO, and then we can see the full picture.

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 21 May 2019 14:08:48 +0000

I'd expect duplicate the codes just like we did for RFC 6282. This way, if a 6LoRH moved to page 1, we do ,not need to switch back to page 0.
But is there a use case for it?

Pascal

> -----Original Message-----
> From: Michael Richardson <[email-masked]>
> Sent: mardi 21 mai 2019 15:50
> To: Pascal Thubert (pthubert) <[email-masked]>
> Cc: [email-masked]; Laurent Toutain <[email-masked]>
> Subject: Re: [6lo] recoverable fragments: use page 1
> 
> 
> Maybe we should have a document about source routing fragments end to
> end for projected DAO, and then we can see the full picture.
> 
> --
> Michael Richardson <[email-masked]>, Sandelman Software Works  -
> = IPv6 IoT consulting =-
> 
>