Subject: [6lo] RIOT implementation for Selective Fragment Recovery

From: Martine Lenders <[email-masked]>
Date: Tue, 5 Nov 2019 20:48:14 +0100

Hello,

I finally finished a first presentable draft of my Selective Fragment
Recovery implementation for RIOT [1]. It still needs a lot of testing and
thus there are most definitely still some major bugs in there, but feel
free to have a look.

Regarding my previous question [2]: I solved it now by making the node
where the hop-limit is reached the reassembling end-point, which is I
believe most in line with the protocol as it was designed.

Best regards,
Martine

[1] https://github.com/RIOT-OS/RIOT/pull/12648
[2] https://mailarchive.ietf.org/arch/msg/6lo/vWZvBbdjR15vOYNkz-mw6VXBJH0

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 7 Nov 2019 04:23:57 +0000

Fantastic Martine.

Please note that you do not need to send the message in error back in full. Only up to the offset where the error is detected. Since the control is in the first fragment there is no point reassembling in the middle of the network. The hard question that we discuss in the other thread is whether to send back the compressed form and to whom. This was overlooked so far. Forwarding fragments makes it even harder because a problem with the compression may be caused not only by the previous hop but also by the source or even a node in between.

Regards,

Pascal

Le 6 nov. 2019 à 07:23, Martine Lenders <[email-masked]> a écrit :

Hello,

I finally finished a first presentable draft of my Selective Fragment Recovery implementation for RIOT [1]. It still needs a lot of testing and thus there are most definitely still some major bugs in there, but feel free to have a look.

Regarding my previous question [2]: I solved it now by making the node where the hop-limit is reached the reassembling end-point, which is I believe most in line with the protocol as it was designed.

Best regards,
Martine

[1] https://github..com/RIOT-OS/RIOT/pull/12648<https://github.com/RIOT-OS/RIOT/pull/12648>
[2] https://mailarchive.ietf.org/arch/msg/6lo/vWZvBbdjR15vOYNkz-mw6VXBJH0
_______________________________________________
6lo mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/6lo