Subject: [6lo] Feedback on proposed changes to draft-ietf-6lo-deadline-time-05

From: "Shwetha Bhandari (shwethab)" <[email-masked]>
Date: Sat, 8 Feb 2020 00:09:15 +0000

Hello All,

This is to solicit your feedback on the changes the authors would like to make to
draft-ietf-6lo-deadline-time-05 that is currently in AUTH48.
The authors have reworked the math for determining the Deadline
Time Length(DTL). They found errors in the modular arithmetic used for the
range calculation and evaluating Deadline Time(DT) expiry by intermediate
node.

To fix this, below changes are introduced to the approved I-D (05)
o  Fixed the error in the test condition to determine whether or not the deadline time has expired.
o  Introduced a SAFETY_FACTOR to allow more practical determination by intermediate nodes about whether the deadline time has expired.
o  Fixed the error in DTL calculation.

Other than this following changes are made to -05:
o  Removed the text pertaining to wraparound in section 5
o  Replaced the 6tisch terminology with 6tisch architecture
o  Updated the contact information of authors

Attached are the diffs of the proposed changes to the draft
As work group chairs and AD we have reviewed and support the change.

Thanks,
Carles, Suresh and Shwetha

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 10 Feb 2020 06:42:12 +0000

Looks good, Schwetha.

From: 6lo <[email-masked]> On Behalf Of Shwetha Bhandari (shwethab)
Sent: samedi 8 février 2020 01:09
To: [email-masked]
Cc: Carles Gomez Montenegro <[email-masked]>; Suresh Krishnan <[email-masked]>
Subject: [6lo] Feedback on proposed changes to draft-ietf-6lo-deadline-time-05

Hello All,

Thanks,