Subject: [6lo] Benjamin Kaduk's No Objection on draft-ietf-6lo-minimal-fragment-14: (with COMMENT)

From: Benjamin Kaduk via Datatracker <[email-masked]>
Date: Sat, 21 Mar 2020 16:39:28 -0700

Benjamin Kaduk has entered the following ballot position for
draft-ietf-6lo-minimal-fragment-14: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-6lo-minimal-fragment/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you for addressing my Discuss (and Comment) points!

In the security considerations, perhaps "fragment 1" would be
better as "first-fragment" to avoid questions of zero- vs. one-indexing.

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Mar 2020 08:08:25 +0000

Hello again Benjamin:

I published -15 https://www.ietf.org/rfcdiff?url2=draft-ietf-6lo-minimal-fragment-15 with the changes.
I kept the Datagram_Tag uppercased but we can debate that with the RFC editor. 
The lowercase is used in RFC 4944.

Looking at the diffs, I found that I forgot to remove the old version of the text you changed, it is now removed in github.

Again, a great many thanks!!

I guess we're done with both fragment drafts : )

Keep safe,

Pascal

> -----Original Message-----
> From: Benjamin Kaduk via Datatracker <[email-masked]>
> Sent: dimanche 22 mars 2020 00:39
> To: The IESG <[email-masked]>
> Cc: [email-masked]; [email-masked];
> [email-masked]; Carles Gomez <[email-masked]>;
> [email-masked]
> Subject: Benjamin Kaduk's No Objection on draft-ietf-6lo-minimal-fragment-14:
> (with COMMENT)
> 
> When responding, please keep the subject line intact and reply to all email
> addresses included in the To and CC lines. (Feel free to cut this introductory
> paragraph, however.)
> 
> 
> In the security considerations, perhaps "fragment 1" would be better as "first-
> fragment" to avoid questions of zero- vs. one-indexing.
> 
> 
I changed the intro to add " of the datagram" to define it more clearly in the first use:
 "
The routing decision is made on the first
   fragment of the datagram,

" 
and checked it is aligned the use of "first fragment" throughout.

The particular sentence you point out could become
"
The length of the packet is indicated in each fragment (the Datagram_Size field), so node B can allocate the buffer even if the fragment it receives first is not the first fragment.
"