Subject: Re: [6lo] Opsdir last call review of draft-ietf-6lo-plc-05

From: "Liubing (Remy)" <[email-masked]>
Date: Fri, 5 Mar 2021 03:53:01 +0000

Hello Dan,

Thank you very much for your comments. Please see my response below.

Best regards,
Remy

-----邮件原件-----
发件人: Dan Romascanu via Datatracker [mailto:[email-masked]] 
发送时间: 2021年2月12日 18:01
收件人: [email-masked]
抄送: [email-masked]; [email-masked]; [email-masked]; [email-masked]
主题: Opsdir last call review of draft-ietf-6lo-plc-05

Reviewer: Dan Romascanu
Review result: Has Issues

This document describes how IPv6 packets are transported over constrained Power Line Communication (PLC) networks. It is a clear and well-written document and its content is relevant for all operators that will have such networks under their administration. I have however one concern that I would suggest the OPS AD to clarify before approving this document. There is no mention in the document of the operational and manageability aspects. How will these networks be managed, monitored, troubleshooted?  Which existing OAM protocols and procedures apply and will extensions be needed? Are there / will there be any new new interface types ("ifType" values) required as per RFC 8892? Maybe other documents exist in the IEEE or ITU-T that document these aspects - if so it would be useful to reference them. If other documents are in planning in the IETF on this respect - please clarify.

[Remy]That's a very good question. The constrained PLC networks are not managed in the same way as the enterprise network or carrier network. The constrained PLC networks as the other IoT networks, are designed to be self-organized and self-managed. The software or firmware is flushed into the devices before deployment by the vendor or operator. And during the deployment process, no extra configuration is needed to get the device connected to each other. Once a device becomes offline, it will go back to the bootstrapping stage and tries to rejoin the network. The onboard status of the devices and the topology of the PLC network can be visualized via the gateway. The recently-formed iotops WG in IETF is aming to design more features for  the management of IOT networks.

---

From: Dan Romascanu <[email-masked]>
Date: Fri, 5 Mar 2021 10:03:58 +0200

Hi Remy,

Thank you for your response and for addressing my concerns. This makes
sense to me. It would be good to catch this in a short section or
subsection of the document ('Operations and Manageability Considerations'
is a possible title).

Regards,

Dan

On Fri, Mar 5, 2021 at 5:53 AM Liubing (Remy) <[email-masked]>
wrote:

> This document describes how IPv6 packets are transported over constrained
> Power Line Communication (PLC) networks. It is a clear and well-written
> document and its content is relevant for all operators that will have such
> networks under their administration. I have however one concern that I
> would suggest the OPS AD to clarify before approving this document. There
> is no mention in the document of the operational and manageability aspects.
> How will these networks be managed, monitored, troubleshooted?  Which
> existing OAM protocols and procedures apply and will extensions be needed?
> Are there / will there be any new new interface types ("ifType" values)
> required as per RFC 8892? Maybe other documents exist in the IEEE or ITU-T
> that document these aspects - if so it would be useful to reference them.
> If other documents are in planning in the IETF on this respect - please
> clarify.
>
> [Remy]That's a very good question. The constrained PLC networks are not
> managed in the same way as the enterprise network or carrier network. The
> constrained PLC networks as the other IoT networks, are designed to be
> self-organized and self-managed. The software or firmware is flushed into
> the devices before deployment by the vendor or operator. And during the
> deployment process, no extra configuration is needed to get the device
> connected to each other. Once a device becomes offline, it will go back to
> the bootstrapping stage and tries to rejoin the network. The onboard status
> of the devices and the topology of the PLC network can be visualized via
> the gateway. The recently-formed iotops WG in IETF is aming to design more
> features for  the management of IOT networks.
>