Subject: [6tisch-security] agenda for 2014-06-16 6tisch security call

From: Michael Richardson <[email-masked]>
Date: Sun, 15 Jun 2014 22:11:26 -0400

{resending with a sane subject line}

We had a very productive call last week.
Rene has started getting some feedback on the issues that are open.

 -- The URL to access the webex, which will we use for audio only:
   https://cisco.webex.com/cisco/j.php?MTID=m2fe139bf876cea3ec62750cd580b7908

 -- we will use with the etherpad at:
   https://etherpad.mozilla.org/ras5RGrQLA

Agenda for tomorrow:
  1. work on trust/cryptographic details of Joining-Node -> PCE message.
     does it need to be signed?

  2. 6top ideas for PCE->joining node protocol. Will this work as stock
     CoAP/DTLS, or do we need a proxy to help us?

--
Michael Richardson <[email-masked]>, Sandelman Software Works
 -= IPv6 IoT consulting =-

---

From: Michael Richardson <[email-masked]>
Date: Sun, 22 Jun 2014 23:21:23 -0400

> https://cisco.webex.com/cisco/j.php?MTID=m2fe139bf876cea3ec62750cd580b7908

We will attempt to use the IETF etherpad again:
  http://etherpad.tools.ietf.org:9000/p/notes-ietf-89-6tisch-security

    > does it need to be signed?

which I summarized in the email at:
      https://mailarchive.ietf.org/arch/msg/6tisch-security/DT-K0_qd_wd-GmqB4YVqQtbhC6Q
or:   with the thread at:
      http://www.ietf.org/mail-archive/web/6tisch-security/current/msg00175.html

    > CoAP/DTLS, or do we need a proxy to help us?

I would like to focus on item #2.
This is about whether or not the joining node can layer-3 address the PCE,
and whether or not the PCE can address the joining node directly, or if it
needs help from the proxy, and if so, what form does the help take?

We have had part of this discussion before.

I propose that we have no call on 2014-06-30, the draft deadline is July 4,
and we need to get some things in.

I will remind that we worked on a table of contents, posted as:
   http://datatracker.ietf.org/doc/draft-richardson-6tisch-table-of-contents/

a very rough version of a document explaining the "Wireless-HART"/6top method
of doing joining is at:
  https://bitbucket.org/6tisch/draft-richardson-6tisch-security-architecture/src/625fefe5574fe3e4ca3de7b3c14c2c1dcf073ebd/draft-richardson-6tisch-security-6top.xml?at=obiwan

we still need someone to fill in a table of contents from the EAP-TLS point
of view.

---

From: Michael Richardson <[email-masked]>
Date: Mon, 23 Jun 2014 09:53:09 -0400

>https://cisco.webex.com/cisco/j.php?MTID=m2fe139bf876cea3ec62750cd580b7908

This says "meeting cancelled".
I assume it is an administrative oops, stay tuned for another URL, I guess.

I have a bridge that can be used; accessible via SIP: and PSTN, but I will
wait ten minutes before suggesting it.

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Mon, 23 Jun 2014 14:01:24 +0000

If necessary I could create a different webex as well? 
- max

On Jun 23, 2014, at 3:53 PM, Michael Richardson <[email-masked]> wrote:

> _______________________________________________
> 6tisch-security mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch-security

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Mon, 23 Jun 2014 14:10:03 +0000

https://ciscosales.webex.com/ciscosales/e.php?MTID=med0fe95ade4c1e13410b87950c11c337

Dialin: (408) 525-6800
Meeting Number: 204 226 648   	
Meeting Password: letmein	

- max

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Jun 2014 14:12:56 +0000

Let me create a webex and come back to you all...

Cheers,

Pascal

> -----Original Message-----
> From: 6tisch-security [mailto:[email-masked]] On Behalf Of
> Max Pritikin (pritikin)
> Sent: lundi 23 juin 2014 16:01
> To: Michael Richardson
> Cc: [email-masked]
> Subject: Re: [6tisch-security] agenda for 2014-06-23 6tisch security call
> 
> > I have a bridge that can be used; accessible via SIP: and PSTN, but I
> > will wait ten minutes before suggesting it.
> >
> > --

---

From: "Max Pritikin (pritikin)" <[email-masked]>
Date: Mon, 23 Jun 2014 14:21:32 +0000

Thanks to the 4 people that joined this webex. Unfortunately we didn’t achieve quorum and everybody dropped. Hopefully a reschedule discussion will occur now, 

- max

---

From: Michael Richardson <[email-masked]>
Date: Mon, 23 Jun 2014 10:24:37 -0400

The webex was screwed up. Thanks for Max for attempting to rescue.
(And then the Bell guy came to hook up my 50Mb/s VDSL2... it's make before
break, but...)

So can we try again for June 24 10am?
Pascal, can you post a fresh webex URL?

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 23 Jun 2014 14:31:15 +0000

Hello Michael:

I sent an invite. If you did not get it the new webex is as follows:

You are scheduled to host this online meeting. 

Topic: 6TiSCH security 
Date: Monday, June 23, 2014 
Time: 4:00 pm, Europe Summer Time (Paris, GMT+02:00) 
Meeting Number: 202 347 993 
Meeting Password: 6Sec 

------------------------------------------------------- 
To start the online meeting 
------------------------------------------------------- 
1. Go to https://ciscosales.webex.com/ciscosales/j.php?MTID=m51f750a5bb1d5806cce3bf7c068e5790 
2. Log in to your account. 
3. Click "Start Now". 
4. Follow the instructions that appear on your screen. 

---------------------------------------------------------------- 
ALERT - PLEASE READ: DO NOT DIAL THE TOLL FREE NUMBERS FROM WITHIN THE (408) OR (919) AREA CODES 
---------------------------------------------------------------- 
Please dial the local access number for your area from the list below: 
- San Jose/Milpitas (408) area: 525-6800 
- RTP (919) area: 392-3330 

Dialing the WebEx toll free numbers from within 408 or 919 area codes is not enabled (non-Cisco phones). " If you dial the toll-free numbers within the 408 or 919 area codes you will be instructed to hang up and dial the local access number." Please use the call-back option whenever possible and otherwise dial local numbers only. The affected toll free numbers are: (866) 432-9903 for the San Jose/Milpitas area and (866) 349-3520 for the RTP area. 

------------------------------------------------------- 
To join the teleconference only 
------------------------------------------------------- 
1. Dial into Cisco WebEx (view all Global Access Numbers at 
http://cisco.com/en/US/about/doing_business/conferencing/index.html 
2. Follow the prompts to enter the Meeting Number (listed above) or Access Code followed by the # sign. 

San Jose, CA: +1.408.525.6800 RTP: +1.919.392.3330 

US/Canada: +1.866.432.9903 United Kingdom: +44.20.8824.0117 

India: +91.80.4350.1111 Germany: +49.619.6773.9002 

Japan: +81.3.5763.9394 China: +86.10.8515.5666 

To check whether you have the appropriate players installed for UCF (Universal Communications Format) rich media files, go to https://ciscosales.webex.com/ciscosales/systemdiagnosis.php 

http://www.webex.com 

CCM:+14085256800x202347993#

Cheers,

Pascal

> Michael Richardson
> Sent: lundi 23 juin 2014 16:25
> To: [email-masked]
> Subject: [6tisch-security] (no subject)
> 
> 
> a very rough version of a document explaining the "Wireless-HART"/6top
> method of doing joining is at:
>   https://bitbucket.org/6tisch/draft-richardson-6tisch-security-
> architecture/src/625fefe5574fe3e4ca3de7b3c14c2c1dcf073ebd/draft-
> richardson-6tisch-security-6top.xml?at=obiwan
> 
> we still need someone to fill in a table of contents from the EAP-TLS point of
> view.
> 
> --

---

From: Rene Struik <[email-masked]>
Date: Tue, 24 Jun 2014 10:07:43 -0400

Dear colleagues:

I thought we had rescheduled the 6TiSCH security conf call to 10am EDT 
today, June 24, 2014, but did not see anyone online on Webex.

Best regards, Rene

-- 
email: [email-masked] | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 24 Jun 2014 14:13:27 +0000

Hello René:

I missed that discussion. What I did since the webex was lost is create another one on Mondays:

You are the host for this online meeting.
Topic:	6TiSCH security
Date:	Every Monday, from Monday 23 June 2014 to Monday 20 June 2016
Time:	16:00, Europe Summer Time (Paris, GMT+02:00)
Meeting Number:	202 347 993
Meeting Password:	6Sec

To start the online meeting
1.	Go to https://cisco.webex.com/cisco/j.php?MTID=mf0899e407e9726ee6daee7032b007578 
2.	Log in to your account.
3.	Click "Start Now".
4.	Follow the instructions that appear on your screen.

ALERT - PLEASE READ: DO NOT DIAL THE TOLL FREE NUMBERS FROM WITHIN THE (408) OR (919) AREA CODES
Please dial the local access number for your area from the list below:
.	San Jose/Milpitas (408) area:  525-6800
.	RTP (919) area:  392-3330

For assistance
1.	Go to https://cisco.webex.com/cisco/mc
2.	On the left navigation bar, click "Support".
To add this meeting to your calendar program (for example Microsoft Outlook), click this link:
https://cisco.webex.com/cisco/j.php?MTID=m30763e6b62a4467891f27c5cac794925
To check whether you have the appropriate players installed for UCF (Universal Communications Format) rich media files, go to https://cisco.webex.com/cisco/systemdiagnosis.php.
http://www.webex.com
CCM:+14085256800x202347993# 

Cheers,

Pascal

> Rene Struik
> Sent: mardi 24 juin 2014 16:08
> To: Max Pritikin (pritikin); Michael Richardson
> > Thanks to the 4 people that joined this webex. Unfortunately we didn't
> > achieve quorum and everybody dropped. Hopefully a reschedule
> > discussion will occur now,
> >
> > - max
> >
> >>>> I have a bridge that can be used; accessible via SIP: and PSTN, but
> >>>> I will wait ten minutes before suggesting it.
> >>>>
> >>>> --
> >>>> Michael Richardson <[email-masked]>, Sandelman Software
> >>>> Works -= IPv6 IoT consulting =-
> >>>>
> >>>>
> >>>>

---

From: Michael Richardson <[email-masked]>
Date: Tue, 24 Jun 2014 09:00:28 -0400

Due to concern that we don't have a webex setup for 10am yet, and maybe we
are conflicting with the 6top call, and I don't know if we get quorum...
I'm going to cancel the rescheduled 10am call today, and let's have our
final call before IETF90 on Monday June 30, 10am.

---

From: Michael Richardson <[email-masked]>
Date: Fri, 27 Jun 2014 14:04:04 -0400

> Due to concern that we don't have a webex setup for 10am yet, and maybe

And also my appologies, as this email got stuck, and so is really untimely.

Next call on 2014-06-30, 10am.

---

From: Rene Struik <[email-masked]>
Date: Fri, 27 Jun 2014 14:21:28 -0400

Dear colleagues:

I will be traveling on Monday June 30, 2014 and most likely would not 
have internet connectivity. I can dial-in to the call, though.

I will try and dial-in using the US/Canada  phone # and meeting #, as 
indicated below:

US/Canada: +1.866.432.9903
Meeting Number:    202.347.993
{extracted from Pascal Thubert's webex info}

In case this info is incorrect, I can see any corrections till later 
this afternoon (before 5pm EDT).

Best regards, Rene