Subject: [6tisch-security] FW: [IoT-DIR] IETF 92 Bits-n-Bites

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 18 Dec 2014 10:20:29 +0000

-----Original Message-----
From: IoT-DIR [mailto:[email-masked]] On Behalf Of Stephanie McCammon
Sent: mercredi 17 décembre 2014 18:22
To: Aaron Falk; Zach Shelby; [email-masked]; [email-masked]; [email-masked]; [email-masked]; Stephen Farrell; Kathleen Moriarty
Cc: Ray Pelletier; Alexa Morris
Subject: [IoT-DIR] IETF 92 Bits-n-Bites

Hello Everyone,

We are gearing up for IETF 92 BnB in Dallas and one thing that needs to be finalized is the event theme. A suggestion that has come up several times is the topic of security for IoT devices. This is certainly an important topic, and one that should generate a lot of interest, but what we don't know - and why we are contacting all of you - is if it's viable from a demonstration perspective. We need your input and expertise in order to determine if this topic is mature enough to be the focus of an IETF BnB event. Some of our questions are: 

- What are the main known security issues with IoT devices?
- Are there demonstrable solutions that can be featured?
- What companies / organizations are working in this space and might be able to showcase their technology? 

We realize that most of you are probably working diligently to wrap up various projects in time for the holidays, and that this is therefore unlikely to be a top priority at the moment. We understand and are are hoping to schedule a short conference call after the New Year, perhaps the 2nd week of January, to discuss this further. If you are interested and willing to help out, please complete the Doodle poll below so that we can find a date and time that works best for everyone. 

http://doodle.com/8qd5xx94482mkhkq

In the meantime, please feel free to chime in with your thoughts via email, as any opinions and information you share between now and the January conference call will help us with our planning. 

Thanks and Happy Holidays!

Stephanie McCammon
IETF Project Manager
48377 Fremont Blvd, Ste. 117
Fremont, CA 94538
T: +1.510.492.4081
F: +1.510.492.4001

Association Management Solutions (AMS)
Forum Management, Meeting, and Event Planning www.amsl.com

_______________________________________________
IoT-DIR mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/iot-dir

---

From: Rene Struik <[email-masked]>
Date: Thu, 18 Dec 2014 09:37:22 -0500

Hi Pascal:

It may be somewhat early to demonstrate solutions that span the entire 
device lifecycle (to my knowledge, there are none, at least not ones 
that make this a convenient, semi-automatic matter).

I do not think that 6tisch security will be in prototype demo stage by 
March. Nevertheless, of course, we could indicate how things are 
supposed to work there and borrow also from examples of how 802.15, 
wHART, ISA SP100 fit into the mix. This could also have a pointer to 
IPv6 address privacy provisions on 6man.

Not sure whether this is in scope, but I could give a presentation on 
crypto and security technologies that together hold the promise to be a 
good "tool box" for addressing full lifecycle secure deployments. This 
includes support for semi-automatic provisioning, implementation 
security aspects esp. on cheap devices open to physical attacks, secure 
key storage and random number generation, etc. Some of this is not 
material that will end up with an IETF draft (but hooks would be good to 
have), but nevertheless helps in significantly hardening devices and 
networks, when viewed from a system perspective.

Best regards, Rene

On 12/18/2014 5:20 AM, Pascal Thubert (pthubert) wrote:
> 6tisch-security mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch-security

-- 
email: [email-masked] | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 18 Dec 2014 15:07:56 +0000

All good, René, and I'd love to see your presentation. 

Maybe early next year we could dedicate a 6TiSCH call to this?
I did not expect 6TiSCH sec to demo at B'n'B but I wanted to make sure everyone on the list was aware of this, and would eventually use that information.

All the best,

Pascal

> From: Rene Struik [mailto:[email-masked]]
> Sent: jeudi 18 décembre 2014 15:37
> To: Pascal Thubert (pthubert); [email-masked]
> Subject: Re: [6tisch-security] FW: [IoT-DIR] IETF 92 Bits-n-Bites
> 
> Hi Pascal:
> 
> It may be somewhat early to demonstrate solutions that span the entire device
> lifecycle (to my knowledge, there are none, at least not ones that make this a
> convenient, semi-automatic matter).
> 
> I do not think that 6tisch security will be in prototype demo stage by March.
> Nevertheless, of course, we could indicate how things are supposed to work
> there and borrow also from examples of how 802.15, wHART, ISA SP100 fit into
> the mix. This could also have a pointer to
> Not sure whether this is in scope, but I could give a presentation on crypto and
> security technologies that together hold the promise to be a good "tool box" for
> addressing full lifecycle secure deployments. This includes support for semi-
> automatic provisioning, implementation security aspects esp. on cheap devices
> open to physical attacks, secure key storage and random number generation,
> etc. Some of this is not material that will end up with an IETF draft (but hooks
> would be good to have), but nevertheless helps in significantly hardening devices
> and networks, when viewed from a system perspective.
> 
> Best regards, Rene
> 
> 
> > To: Aaron Falk; Zach Shelby; [email-masked];
> > [email-masked]; [email-masked]; [email-masked];
> > Stephen Farrell; Kathleen Moriarty
> > We are gearing up for IETF 92 BnB in Dallas and one thing that needs to be
> finalized is the event theme. A suggestion that has come up several times is the
> topic of security for IoT devices. This is certainly an important topic, and one
> that should generate a lot of interest, but what we don't know - and why we are
> contacting all of you - is if it's viable from a demonstration perspective. We need
> your input and expertise in order to determine if this topic is mature enough to
> be the focus of an IETF BnB event. Some of our questions are:
> >
> > We realize that most of you are probably working diligently to wrap up various
> projects in time for the holidays, and that this is therefore unlikely to be a top
> priority at the moment. We understand and are are hoping to schedule a short
> conference call after the New Year, perhaps the 2nd week of January, to discuss
> this further. If you are interested and willing to help out, please complete the
> Doodle poll below so that we can find a date and time that works best for
> everyone.
> >
> > In the meantime, please feel free to chime in with your thoughts via email, as
> any opinions and information you share between now and the January
> conference call will help us with our planning.
> >
> > Association Management Solutions (AMS) Forum Management, Meeting, and
> > Event Planning www.amsl.com
> >
> >
> >
> >