Subject: Re: [6tisch] New Version Notification for draft-thubert-6tisch-architecture-01.txt

From: Ines Robles <[email-masked]>
Date: Fri, 1 Nov 2013 14:41:01 -0200

Yes, thank u very much Thomas

Kind Regards,

Ines Robles.

>
> ---------- Mensaje reenviado ----------
> From: Thomas Watteyne <[email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc:
> Date: Fri, 1 Nov 2013 09:33:12 -0700
> Subject: Re: [6tisch] New Version Notification for
> draft-thubert-6tisch-architecture-01.txt
> Ines,
>
> 6TiSCH recognizes the wide range of applications and associated
> requirements.The goals if 6TiSCH is therefore to define mechanisms to
> monitor and manage the TSCH schedule. The different mechanisms are
> highlighted in
> http://tools.ietf.org/html/draft-thubert-6tisch-architecture-01#section-8.
> A final solution uses one of these mechanisms, or combines multiple.
>
> With this in mind, the use of RPL varies according to the mechanism you
> are using. In
> http://tools.ietf.org/html/draft-vilajosana-6tisch-minimal-00 for
> example, multi-hop routes are defined by RPL, while
> http://tools.ietf.org/html/draft-ietf-roll-rpl-industrial-applicability-02 uses
> RPL for post-emergency recovery and repair.
>
> I hope this answers your question.
>
> Thomas
>
>
> On Fri, Nov 1, 2013 at 9:20 AM, Ines Robles <
> [email-masked]> wrote:
>
>> Hello,
>>
>> Thanks for these drafts, I have a short question about
>> draft-thubert-6tisch-architecture-01<http://datatracker.ietf.org/doc/draft-thubert-6tisch-architecture/>
>> ,
>>
>> In section 9. Centralized vs. Distributed Routing states:"...It is
>> possible for centralized and distributed routing to share a same topology.
>> In this case, centralizes routes have precedence over distributed routes in
>> case of a conflict...."
>>
>> The reasons why centralizes routes (PCE) have precedence over distributed
>> routes (RPL) is because RPL operations would only apply to emergency repair
>> actions? Is that correct? or, are there additional reasons?  [Source:
>> http://www.ietf.org/mail-archive/web/6tisch/current/msg00270.html]
>>
>> Thank you very much in advance,
>>
>> Kind Regards,
>>
>> Ines Robles.
>>
>>
>>
>> ---------- Mensaje reenviado ----------
>> From: "Pascal Thubert (pthubert)" <[email-masked]>
>> To: "[email-masked]" <[email-masked]>
>> Cc:
>> Date: Tue, 22 Oct 2013 15:17:50 +0000
>> Subject: [6tisch] FW: New Version Notification for
>> draft-thubert-6tisch-architecture-01.txt
>>
>> Dear all;****
>>
>> ** **
>>
>> In prevision of the meeting in Vancouver, most of our pending drafts have
>> been updated and republished with the -6tisch- name:****
>>
>> ** **
>>
>> draft-ohba-6tisch-security-00<http://datatracker.ietf.org/doc/draft-ohba-6tisch-security/>
>> ****
>>
>> Security Framework and Key Management Protocol Requirements for 6TiSCH***
>> *
>>
>> ** **
>>
>> ** **
>>
>> draft-palattella-6tisch-terminology-00<http://datatracker.ietf.org/doc/draft-palattella-6tisch-terminology/>
>> ****
>>
>> Terminology in IPv6 over the TSCH mode of IEEE 802.15.4e****
>>
>> ** **
>>
>> ** **
>>
>> draft-piro-6tisch-security-issues-00<http://datatracker.ietf.org/doc/draft-piro-6tisch-security-issues/>
>> ****
>>
>> A standard compliant security framework for Low-power and Lossy Networks*
>> ***
>>
>> ** **
>>
>> ** **
>>
>> draft-thubert-6tisch-architecture-01<http://datatracker.ietf.org/doc/draft-thubert-6tisch-architecture/>
>> ****
>>
>> An Architecture for IPv6 over the TSCH mode of IEEE 802.15.4e****
>>
>> ** **
>>
>> ** **
>>
>> draft-vilajosana-6tisch-minimal-00<http://datatracker.ietf.org/doc/draft-vilajosana-6tisch-minimal/>
>> ****
>>
>> Minimal 6TiSCH Configuration****
>>
>> ** **
>>
>> ** **
>>
>> draft-wang-6tisch-6top-00<http://datatracker.ietf.org/doc/draft-wang-6tisch-6top/>
>> ****
>>
>> 6TiSCH Operation Sublayer (6top)****
>>
>> ** **
>>
>> ** **
>>
>> draft-watteyne-6tisch-tsch-00<http://datatracker.ietf.org/doc/draft-watteyne-6tisch-tsch/>
>> ****
>>
>> Using IEEE802.15.4e TSCH in an LLN context: Overview, Problem Statement
>> and Goals****
>>
>> ** **
>>
>> ** **
>>
>> ** **
>>
>> We are missing the CoAP draft but it can be found here: ** **
>>
>> draft-sudhaakar-6tisch-coap-00<https://bitbucket.org/6tisch/draft-sudhaakar-6tisch-coap/src/master/draft-sudhaakar-6tisch-coap-00.txt>
>>            6TiSCH Data Model for CoAP****
>>
>> ** **
>>
>> In preparation for the upcoming IETF, you are strongly encouraged to read
>> through your own selection of drafts so as to comment on the ML or during
>> the meeting.****
>>
>> ** **
>>
>> Cheers, ****
>>
>> ** **
>>
>> Pascal****
>>
>> ** **
>>
>>
>>
>>
>> _______________________________________________
>> 6tisch mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/6tisch
>>
>>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 4 Nov 2013 16:06:45 +0000

Hello Ines:

The rationale is that the PCE operation is more expensive but leads to more optimized routes and deterministic forwarding.
If we spend the effort to use a PCE, then we probably want to make sure that the computed optimization is  applied in the network.

Cheers,

Pascal

From: Ines Robles [mailto:[email-masked]]
Sent: vendredi 1 novembre 2013 08:13
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: New Version Notification for draft-thubert-6tisch-architecture-01.txt

Hello,

Thanks for these drafts, I have a short question about draft-thubert-6tisch-architecture-01<http://datatracker.ietf.org/doc/draft-thubert-6tisch-architecture/>,

In section 9. Centralized vs. Distributed Routing states:"...It is possible for centralized and distributed routing to share a same topology. In this case, centralizes routes have precedence over distributed routes in case of a conflict...."

The reasons why centralizes routes (PCE) have precedence over distributed routes (RPL) is because RPL operations would only apply to emergency repair actions? Is that correct? or, are there additional reasons?  [Source: http://www.ietf.org/mail-archive/web/6tisch/current/msg00270.html]

Kind Regards,

Ines Robles.

---------- Mensaje reenviado ----------
From: "Pascal Thubert (pthubert)" <[email-masked]<mailto:[email-masked]>>
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc:
Date: Tue, 22 Oct 2013 15:17:50 +0000
Subject: [6tisch] FW: New Version Notification for draft-thubert-6tisch-architecture-01.txt

Dear all;

In prevision of the meeting in Vancouver, most of our pending drafts have been updated and republished with the -6tisch- name:

Security Framework and Key Management Protocol Requirements for 6TiSCH

Terminology in IPv6 over the TSCH mode of IEEE 802.15.4e

A standard compliant security framework for Low-power and Lossy Networks

An Architecture for IPv6 over the TSCH mode of IEEE 802.15.4e

Minimal 6TiSCH Configuration

6TiSCH Operation Sublayer (6top)

Using IEEE802.15.4e TSCH in an LLN context: Overview, Problem Statement and Goals

We are missing the CoAP draft but it can be found here:

draft-sudhaakar-6tisch-coap-00<https://bitbucket.org/6tisch/draft-sudhaakar-6tisch-coap/src/master/draft-sudhaakar-6tisch-coap-00.txt>                           6TiSCH Data Model for CoAP

In preparation for the upcoming IETF, you are strongly encouraged to read through your own selection of drafts so as to comment on the ML or during the meeting.

Cheers,

Pascal

---

From: Ines Robles <[email-masked]>
Date: Mon, 4 Nov 2013 16:47:23 -0200

Hello,

Thank you very much Pascal. I understood.

Kind Regards,

Ines.

2013/11/4 Pascal Thubert (pthubert) <[email-masked]>

>  Hello Ines:
>
>
>
> The rationale is that the PCE operation is more expensive but leads to
> more optimized routes and deterministic forwarding.
>
> If we spend the effort to use a PCE, then we probably want to make sure
> that the computed optimization is  applied in the network.
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* Ines Robles [mailto:[email-masked]]
> *Sent:* vendredi 1 novembre 2013 08:13
> *To:* Pascal Thubert (pthubert)
> *Cc:* [email-masked]
> *Subject:* Re: New Version Notification for
> been updated and republished with the -6tisch- name:
>
>
>
> and Goals
>            6TiSCH Data Model for CoAP
>
>
>
> the meeting.