Subject: [6tisch] minutes webex 1 November 2013

From: Thomas Watteyne <[email-masked]>
Date: Fri, 1 Nov 2013 11:12:46 -0700

All,

You will find the minutes of this week's webex below.

FYI, all the minutes and slides are archived a
https://bitbucket.org/6tisch/meetings/.

Thanks to Xavi and Pascal for taking notes!

As usual, please fix anything we might have missed directly in the e-mail
and reply.

Thomas

-----

Minutes Webex 01 November 2013, 6TiSCH WG

Note: timestamps in PDT.
Taking notes *(using Etherpad)*

   1. Xavi Vilajosana
   2. Pascal Thubert
   3. Thomas Watteyne

Present *(alphabetically)*

   1. Pascal Thubert
   2. Thomas Watteyne
   3. Diego Dujovne
   4. Nicola Accettura
   5. Pouria Zand
   6. Qin Wang
   7. Rouhallah Nabati
   8. Tina Tsou
   9. Xavi Vilajosana

Recording

   - Webex recording (audio+slides,streaming)
   -
   https://cisco.webex.com/ciscosales/lsr.php?AT=pb&amp;SP=MC&amp;rID=72726942&amp;rKey=b79c6eccafdd6f9<https://cisco.webex.com/ciscosales/lsr.php?AT=pb&SP=MC&rID=72726942&rKey=b79c6eccafdd6f9>
    *[65min]*

Slides

   - slides_131101_webex.ppt<https://bitbucket.org/6tisch/meetings/src/master/131101_webex/slides_131101_webex.ppt>
(uploaded
   in Webex)
   - 6tisch_ietf88_vancouver.ppt<https://bitbucket.org/6tisch/meetings/src/master/131105_ietf88_vancouver/6tisch_ietf88_vancouver.ppt>
(shared
   live in Webex)

Action Items

   1. *Thomas* to ask Dominique Barthel whether available to take notes on
   Etherpad.
   2. *Pascal* to ask to Michael Richardson as Jabber proxy.
   3. *Thomas* to reduce number of slides in TSCH presentation.
   4. *Thomas* to verify agenda in slides is the official one.
   5. *Thomas* to remove slide 26.
   6. *Thomas* to remove information data model title and move slide to
   first slide on data models.
   7. *Thomas* to go through each presentation and add bullet point
   indicating that has been renamed to 6TiSCH.
   8. *Xavi* to send a reworked of 6top focusing on API first.
   9. *Xavi* to rework 6top and minimal draft slides to reduce. Move some
   slides to the end.
   10. *Pascal* to clean up slot allocation slides, and resend a shorter
   version to Thomas.

Agenda

   - Administrivia *[2min]*
      - Approval agenda
      - Approval minutes last call
   - IETF 88 Vancouver
      - overview slides
   - Slot allocation principles
   - AOB *[1min]*

Minutes

   - *[08.03]* Meeting starts
   - *[08.03]* Administrivia
      - Approval agenda

      No concerns raised. Agenda approved.

      - Approval minutes last call

      No concerns raised. Minutes approved.

      - *[08.04]* IETF 88 Vancouver
      - *Thomas* sharing ppt live to make editions
      - Missing person to take Etherpad notes.
      - *[Xavi]* agrees to take notes.

      Action item: *Thomas* to ask Dominique Barthel whether available to
      take notes on Etherpad.

      - Missing person to interface to jabber room

      Action item: *Pascal* to ask to Michael Richardson as Jabber proxy.

      - *[Xavi]* Who presents the terminology draft?
         - *Pascal* will present terminology and charter.
         - *Thomas* will present TSCH draft.
      - TSCH drafts has too many slides.

      Action item: *Thomas* to reduce number of slides in TSCH presentation.

      - Agenda is not up to date in slides.

      Action item: *Thomas* to verify agenda in slides is the official one.

      - Usual way to present is to explain the changes since last version.

      Action item: *Thomas* to remove slide 26.

      - Information and data models slide - need to decide if we keep it
      with architecture or goes to the data models part
      - *Pouria* agrees to present it if needs to be moved to the data
      model part.

      Action item: *Thomas* to remove information data model title and move
      slide to first slide on data models.

      - Should we remove slide 34?
      - Move to beginning and make it status slides.
      - Thomas checks with Pouria whether the latest is correctly uploaded

      Action item: *Thomas* to go through each presentation and add bullet
      point indicating that has been renamed to 6TiSCH.

      - Pascal indicates that some text in the end of the 6top draft is
      somewhat off charter and probably belongs to architecture. Maybe
the draft
      name should be more specific to indicate that it covers API /
info model as
      opposed to scheduling, forwarding, 6top to 6top etc.

      Action item: *Xavi* to send a reworked of 6top focusing on API first.

      - Yoshihiro presents it own set of slides.
      - *[Xavi]* About OTF, suggests to keep the objective slide and
      present in a broad sense what OTF is and why it is interesting. Renamed
      slide to GOAL.
      - Security draft: it is hard to discuss as we do not have the
      background. We keep first slide to introduce the topic to be discussed in
      London.

      Action item: *Xavi* to rework 6top and minimal draft slides to
      reduce. Move some slides to the end.

      - *[08.47]* Slot allocation principles
      - Pascal presents the slides about "Slot allocation principles"
      - *[Thomas]* 6top misses a functionality to allocate blocks of cells
      (a.k.a. chunks).
      - *[Thomas]* next-cell usage requires some changes in some header, we
      need to make clear how 6top deal with that.

      Action item: *Pascal* to clean up slot allocation slides, and resend
      a shorter version to Thomas.

      - *[Diego]* In this context, what is the difference between a chunk
      and bundle.
      - *[Pascal]*
         - bundle: a bunch of cells that together provide a link
         abstraction between 2 nodes (more capacity on a link)
         - chunk: a collection of cells in the schedule that can be used by
         a node to talk to any others.
      - *[Thomas]* These are new ideas that need to be discussed on the ML.
      Let's make sure it can be done and discuss the pros/cons.
   - *[09.06]* AOB

   No AOB raised.

   - *[09.09]* Meeting ends
      - *[Pascal]* reminds that IETF meeting can be followed by jabber,
      live audio stream and webex.

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 1 Nov 2013 14:22:24 -0700

All,

A quick errata to the minutes.

The link to the webex recording is:
https://cisco.webex.com/ciscosales/lsr.php?AT=pb&SP=MC&rID=72726942&rKey=b79c6eccafdd6f92

I've also corrected https://bitbucket.org/6tisch/meetings/wiki/131101_webex.

Thanks to Pouria for seeing this.

Thomas

On Fri, Nov 1, 2013 at 11:12 AM, Thomas Watteyne <[email-masked]
> wrote:

>    https://cisco.webex.com/ciscosales/lsr.php?AT=pb&SP=MC&rID=72726942&rKey=b79c6eccafdd6f92
>     *[65min]*
>
> Slides
>
>    - slides_131101_webex.ppt<https://bitbucket.org/6tisch/meetings/src/master/131101_webex/slides_131101_webex.ppt> (uploaded
>    in Webex)
>    - 6tisch_ietf88_vancouver.ppt<https://bitbucket.org/6tisch/meetings/src/master/131105_ietf88_vancouver/6tisch_ietf88_vancouver.ppt> (shared
>    live in Webex)
>
> Action Items
>
>    1. *Thomas* to ask Dominique Barthel whether available to take notes
>    on Etherpad.
>       Action item: *Thomas* to remove information data model title and
>       move slide to first slide on data models.
>
>       Action item: *Thomas* to go through each presentation and add
>       bullet point indicating that has been renamed to 6TiSCH.
>
>       somewhat off charter and probably belongs to architecture. Maybe the draft
>       name should be more specific to indicate that it covers API / info model as
>       - *[Thomas]* 6top misses a functionality to allocate blocks of
>       cells (a.k.a. chunks).
>       - *[Thomas]* next-cell usage requires some changes in some header,
>       we need to make clear how 6top deal with that.
>
>       Action item: *Pascal* to clean up slot allocation slides, and
>       resend a shorter version to Thomas.
>
>          - chunk: a collection of cells in the schedule that can be used
>          by a node to talk to any others.
>       - *[Thomas]* These are new ideas that need to be discussed on the
>       ML. Let's make sure it can be done and discuss the pros/cons.
>    - *[09.06]* AOB
>
>    No AOB raised.
>
>    - *[09.09]* Meeting ends