Subject: [6tisch] About the paper "Packet Reservation Multiple Access for Local Wireless Communications"

From: "Prof. Diego Dujovne" <[email-masked]>
Date: Wed, 4 Dec 2013 16:47:51 -0200

Dear all,
           I went through the paper "Packet Reservation Multiple Access for
Local Wireless Communications"*, *recommended by Prof. Wolisz. As far as I
can understand, the paper
defines:
- Subsec. A: Information packet categories: Periodic and Random.
- "Information Frames" on sec. II, subsect. B.  On the proposed topology
(Base Station - Terminals) each terminal has a frame reservation register,
with one bit per slot in the frame.
- Finally, on subsec. D, "Reservations", it states that the base station
(as a centralized system)
provides an ACK to the source station after a successful reception. When
the source station
receives the ACK to a periodic Information packet, it reserves that slot in
future frames
for its exclusive use.
When a station stops sending periodic Information packets, the base station
broadcasts
that this slot is free in the ACK packet, so the stations can contend for
that slot.
On the other hand, Random Information packets do not reserve a slot, they
only
contend until a transmission succeeds on unreserved slots.

My point of view is that our goal is not to use contention as a reservation
mechanism, to support the concept of deterministic networking.

On the other hand, if there is no contention, and there is a collision,
(except something like the Capture Effect phenomena happens) none of the
packets will be acknowledged.

If there is no contention, but there is no collision, then, the solution
would be "First arrived, first served" to reserve a slot, while the lack of
periodic update from the terminal may free the slot.

Any thoughts?

                                                 Diego

-- 
DIEGO DUJOVNE
Académico Escuela de Ingeniería en Informática y Telecomunicaciones
Facultad de Ingeniería UDP
www.ingenieria.udp.cl
(56 2) 676 8125

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 4 Dec 2013 18:42:41 -0800

Diego, Adam,

Interesting paper, especially since the problem statement is similar to
6TiSCH, even with the fact that it describes a technique designed for
wireless voice networks. Certainly very cool considering the paper was
written in 1986 (a empirical verification that activity tends to operate in
cycles).

The similarities with 6TiSCH are fun to see: multiple terminals competing
for access to a common wireless medium, using time slots grouped in time
frames, with immediate acknowledgment of the each data. It's also nice to
see that the radios' data rates (720kbps) and packet length (72bytes) are
similar to today's 2.4GHz IEEE802.15.4.

Of course, there are also differences. Not so much in the fact that the
system uses single wireless channel (which can be worked around), but more
in the types of traffic and the reaction to contention. As you point out,
"periodic" packets experiencing contention are dropped, whereas "random"
packets are queued.

The core idea is simple: a node contends for a slot, other nodes overhear
the base station's ACK and mark the slot as reserved in a utilization
bitmap. The sender node reuses the same slot in each slotframe iteration,
until it doesn't have anything more to say, in which case it returns to
"available" state, and cleared from the motes' bitmap. Applies perfectly to
voice, in which a "session" is opened for multiple minutes with a steady
flow of data.

A hurdle to directly use this approach for 6TiSCH is the fact that the AP
manages the schedule on a packet-by-packet basis. I'm not sure how to
generalize this to a multi-hop mesh. Also, all the nodes have to listen for
all the ACKs to keep and up-to-date utilization bitmap, so not really
targeted at today low-power requirements. The idea of piggybacking usage
information in an ACK does look very similar to Pascal's more bit.

Thanks for suggesting the fun read!

Thomas

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 6 Dec 2013 11:07:38 +0000

Hello Thomas:

Thanks or the great review! A few comments inline

From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: jeudi 5 décembre 2013 03:43
To: [email-masked]
Subject: Re: [6tisch] About the paper "Packet Reservation Multiple Access for Local Wireless Communications"

Diego, Adam,

Interesting paper, especially since the problem statement is similar to 6TiSCH, even with the fact that it describes a technique designed for wireless voice networks. Certainly very cool considering the paper was written in 1986 (a empirical verification that activity tends to operate in cycles).

The similarities with 6TiSCH are fun to see: multiple terminals competing for access to a common wireless medium, using time slots grouped in time frames, with immediate acknowledgment of the each data. It's also nice to see that the radios' data rates (720kbps) and packet length (72bytes) are similar to today's 2.4GHz IEEE802.15.4.

Of course, there are also differences. Not so much in the fact that the system uses single wireless channel (which can be worked around), but more in the types of traffic and the reaction to contention. As you point out, "periodic" packets experiencing contention are dropped, whereas "random" packets are queued.

[PT] Yes, we tend to call periodic "CBR", or "buffered". This is typically Time Sensitive traffic "deterministic", for which our mac is optimized. The problem is really with the optimization of time slots allocation for statistically multiplexed traffic, VBR.

The core idea is simple: a node contends for a slot, other nodes overhear the base station's ACK and mark the slot as reserved in a utilization bitmap. The sender node reuses the same slot in each slotframe iteration, until it doesn't have anything more to say, in which case it returns to "available" state, and cleared from the motes' bitmap. Applies perfectly to voice, in which a "session" is opened for multiple minutes with a steady flow of data.

[PT] Bu is really designed for one hop (AP-STA model) though it could probably progress recursively.

A hurdle to directly use this approach for 6TiSCH is the fact that the AP manages the schedule on a packet-by-packet basis. I'm not sure how to generalize this to a multi-hop mesh. Also, all the nodes have to listen for all the ACKs to keep and up-to-date utilization bitmap, so not really targeted at today low-power requirements. The idea of piggybacking usage information in an ACK does look very similar to Pascal's more bit.

[PT] Our angle is probably to let the parent manage the schedule and tell the child which time slot to us. We have discussed 2 bits. The one I think you are referring to is when the child sends a packet over the bundle and knows that it needs more slots than left the bundle has to exhaust its queues. We need to name that bit, like 'need-more' It can ask from a one shot or a permanent increase on the bundle, and the parent will return the additional cell in the ack. I think that you are talking about that model?

The cool difference the parent will not have to expose the whole schedule to the clients for picking when the schedule grows quite large. Note that if we pursue along that path for permanent cells, we'll have to find a way for the child to confirm that it understand that it owns the cell.

The other bit we were talking about has to do with co-next slots, that are part of the bundle but only used if the previous slot has a 'more' bit set. This is appropriate to reserve space for bursts without having to claim it every time. Co-next slots that are not used may be reattributed dynamically by the parent upon a 'need-more' request.

[PT] +1
Thomas