Subject: [6tisch] 6TiSCH milestones

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Tue, 10 Dec 2013 22:07:08 +0000

Dear all:

It is now time for this WG to expose the timeline that we are committing to the IESG for the execution of our goals.
At the weekly call last Friday we proposed the following:

-             12/2013 - WG to adopt 6TiSCH terminology
-             12/2013 - WG to adopt IEEE802.15.4e TSCH overview
-             12/2013 - WG to adopt 6TiSCH architecture
-             12/2013 - WG to adopt 6TiSCH minimal configuration
-             04/2014 - WG to adopt 6top draft(s)
-             04/2014 - WG to adopt 6TiSCH data model for CoAP
-             11/2014 - Submit first draft of 6TiSCH minimal configuration to the IESG
-             11/2014 - Submit first draft of 6top draft(s) to the IESG
-             11/2014 - Submit first draft of 6TiSCH data model for CoAP to the IESG
-             12/2014 - Submit first draft of 6TiSCH terminology to the IESG
-             12/2014 - Submit first draft of 6TiSCH architecture to the IESG
-             12/2014 - Evaluate WG progress, propose new charter to the IESG

This appears feasible though it was commented that the mapping between the YANG API and the 15.4e commands, that is necessary to validate the data model, may be on the tight side for last call at CYE.

What do you think?

Thomas and Pascal

---

From: Michael Richardson <[email-masked]>
Date: Wed, 11 Dec 2013 08:36:03 -0500

> At the weekly call last Friday we proposed the following:

I think that this is fine as an overcall goals, but as I mentioned at the mic
at the last plenary, WGs need to have more detailed milestones, as there are
numerous events before "submit first draft".

Let me propose a few milestones for over the summer 2014:

- get and deal with SecDir Early review of architecture.
- get YANG review from Operations Directorate (does such a thing exist?)

- I think that the PCE<->mode protocol is contained within the 6tisch data
  model for CoAP???  is that correct?

    > ?             11/2014 ? Submit first draft of 6TiSCH minimal
    > configuration to
    > the IESG

My second comment from last plenary was that this is really just the first
step of the IESG process, and might be the 50% point of the draft lifetime.
So, I encourage to add an indication of when the second draft to the IESG
will occur!  In most cases, there will be no significant protocol affecting
changes, so it doesn't affect the implementation schedule(s), but it does
make it clearer to the authors that they would continue to have work to do.

    > This appears feasible though it was commented that the mapping between
    > the YANG API and the 15.4e commands, that is necessary to validate the
    > data model, may  be on the tight side for last call at CYE.

so do it earlier?

ps:my suggestions certainly are not IETF normative, but I think that there is
general agreement that it is important.

--
Michael Richardson <[email-masked]>, Sandelman Software Works

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Thu, 12 Dec 2013 01:03:59 +0000

Hello Michael

+1 for the Yang review, that should happen during the fall if we want to make our dates.

For the secdir, I agree there is a need there as well. My take to simplify that step would be to split the security part from the architecture at least for a while, and operate both documents in parallel.
After secdir review, we could merge back if that helps the future reader.

Finally for the IESG review, I'd expect that most documents could go through in a matter of 6months at most, but maybe again the architecture. 
For that one, we should be more conservative and expect a full year before RFC publication.

What do others think?

Pascal

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of Michael
> Richardson
> Sent: mercredi 11 décembre 2013 08:36
> To: [email-masked]
> Cc: Pascal Thubert (pthubert)
> Subject: Re: [6tisch] 6TiSCH milestones
> 
> 
> I think that this is fine as an overcall goals, but as I mentioned at the mic at the
> last plenary, WGs need to have more detailed milestones, as there are numerous
> events before "submit first draft".
> 
> My second comment from last plenary was that this is really just the first step of
> the IESG process, and might be the 50% point of the draft lifetime.
> So, I encourage to add an indication of when the second draft to the IESG will
> occur!  In most cases, there will be no significant protocol affecting changes, so
> it doesn't affect the implementation schedule(s), but it does make it clearer to
> the authors that they would continue to have work to do.
>

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 11 Dec 2013 18:23:41 -0800

I'd like to discuss your question about the PCE<-> mote protocol
specifically.

You make a very good point. The 6top interface draft only defines a YANG
model, not the protocol itself. Currently,
http://tools.ietf.org/html/draft-sudhaakar-6tisch-coap-00 does define a
protocol, but there is consensus that a data model driven API (a la
RESTCONF [1]) is the way to go.

That being said, there exists no constrained version of RESTCONF. We have
discussed it in Vancouver and several times since, but I believe we need to
agree on (1) where this work goes (6lo and netconf seem to make sense) and
(2) what the timeline is.

Thomas

[1] http://tools.ietf.org/html/draft-bierman-netconf-restconf-02#section-1.2

On Wed, Dec 11, 2013 at 5:03 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> For the secdir, I agree there is a need there as well. My take to simplify
> that step would be to split the security part from the architecture at
> least for a while, and operate both documents in parallel.
> Finally for the IESG review, I'd expect that most documents could go
> through in a matter of 6months at most, but maybe again the architecture.
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>