Subject: [6tisch] YANG model compiler?

From: Qin Wang <[email-masked]>
Date: Tue, 10 Dec 2013 09:33:08 +0800

Hi all,

Since YANG is a kind of language to describe data model, I wonder if there
is a compiler or some sort of tool to check the syntax of a data model
expressed in YANG. Is there somebody knowing it?

Thanks
Qin

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 9 Dec 2013 17:50:31 -0800

Qin,
Adding Martin Bjorklund (editor RFC6020).
Thomas

On Mon, Dec 9, 2013 at 5:33 PM, Qin Wang <[email-masked]> wrote:

> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Martin Bjorklund <[email-masked]>
Date: Tue, 10 Dec 2013 08:20:52 +0100 (CET)

Hi,

> > expressed in YANG. Is there somebody knowing it?

There are a couple of open source and commercial YANG validators and
"compilers".  The most widely used is probably pyang - available from
http://code.google.com/p/pyang/.  A few others are listed at
http://www.yang-central.org/twiki/bin/view/Main/YangTools - here you
will also find emacs and vim modes.

/martin

---

From: Qin Wang <[email-masked]>
Date: Thu, 12 Dec 2013 08:37:28 +0800

Hi Martin,

Thank you very much!!!

Qin