Subject: [6tisch] Fwd: http://tools.ietf.org/pdf/draft-ietf-netmod-iana-timezones-03.pdf

From: Qin Wang <[email-masked]>
Date: Fri, 6 Dec 2013 08:36:29 +0800

---------- Forwarded message ----------
From: Qin Wang <[email-masked]>
Date: Thu, Dec 5, 2013 at 11:10 AM
Subject: Re:
http://tools.ietf.org/pdf/draft-ietf-netmod-iana-timezones-03.pdf
To: "Pascal Thubert (pthubert)" <[email-masked]>
Cc: "Xavi Vilajosana ([email-masked])" <
[email-masked]>, Thomas Watteyne <[email-masked]>

Hi All,

In the draft-ietf-netmod-iana-timezones-03.pdf , it is said "The
iana-timezones module is intended to reflect the IANA "timezone database"".
 Taking it as example, I think we need to express the data in MIB/PIB one
by one in the similar way, which will become 6top YANG model. Correct? If
yes, then my question is:

(1) The database expressed in YANG should be (6top-MIB + TSCH-PIB), or
(6top-MIB + TSCH-PIB + 15.4-PIB)?
(2) The detailed expression of the database in YANG will be part of
Architecture draft, or 6top interface draft? In another word, how do we
organize the two documents? I think we can have more parallelism if we can
clarify the coverage of the two drafts. What do you think?

Thanks
Qin

On Thu, Dec 5, 2013 at 9:06 AM, Qin Wang <[email-masked]> wrote:

> Pascal,
>
> In the thread "6top Data Model vs 6top API", we have had discussion on how
> to design RFC for 6top in YANG. I think that is useful for this work.
>
> Thanks
> Qin
>
>
> On Wed, Dec 4, 2013 at 6:59 PM, Pascal Thubert (pthubert) <
> [email-masked]> wrote:
>
>>  Good example of yang.
>>
>>
>>
>> My suggestion is that I work with Thomas on extracting text from 6top to
>> archi, so as to parallelize the study on Yang,
>>
>>
>>
>> From what I see in the attached the exercise looks doable, what do you
>> think?
>>
>>
>>
>> : )
>>
>>
>>
>> Pascal
>>
>>
>>
>
>

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 5 Dec 2013 17:10:42 -0800

Qin,

My 2 cents.

I believe we have no choice but to have a way to access the 15.4 PIB. I
would therefore include the 15.4 PIB, or at least the parameters we need to
access (at least the security related MAC PIB attributes, i.e. Table 60 in
IEEE802.15.4-2011). If there is some push-back during process, we can adapt.

As for the database, since the YANG derives directly from it, the 6top
interface draft might be a good home for it.

Thomas

On Thu, Dec 5, 2013 at 4:36 PM, Qin Wang <[email-masked]> wrote:

>> In the thread "6top Data Model vs 6top API", we have had discussion on
>> how to design RFC for 6top in YANG. I think that is useful for this work.
>>
>> Thanks
>> Qin
>>
>>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Qin Wang <[email-masked]>
Date: Fri, 6 Dec 2013 15:49:18 +0800

Thomas,

Can we define them as two kinds of resources, i.e. (1) 6top-MIB+TSCH-PIB,
(2) 15.4-PIB? Then, for example, when CoAP is used as implementation, two
URIs can be used accordingly. Just thought.

Thanks
Qin

On Fri, Dec 6, 2013 at 9:10 AM, Thomas Watteyne
<[email-masked]>wrote:

>>>> My suggestion is that I work with Thomas on extracting text from 6top
>>>> to archi, so as to parallelize the study on Yang,
>>>>
>>>>
>>>>

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 5 Dec 2013 23:57:37 -0800

Qin,

In my mind, each YANG entry will be mapped to a different URI when
translated to CoAP, resulting in a data model driven API [1].

Are you suggesting to use different YANG modules for the two?

Thomas

[1] http://tools.ietf.org/html/draft-bierman-netconf-restconf-02#section-1.2

On Thu, Dec 5, 2013 at 11:49 PM, Qin Wang <[email-masked]> wrote:

> On Fri, Dec 6, 2013 at 9:10 AM, Thomas Watteyne <
> [email-masked]> wrote:
>
>> Qin,
>>
>> My 2 cents.
>>

---

From: Qin Wang <[email-masked]>
Date: Fri, 6 Dec 2013 16:15:56 +0800

Thomas,

Maybe I should say different URI path instead of different URI.

In the current version of draft-sudhaakar-6tisch-coap, Figure 3 lists the
URI path of 6top-MIB as /6t/. What I suggest is to use two URI path to
express (6top-MIB+TSCH-PIB) and 15.4-PIB, respectively. For example,
(6top-MIB+TSCH-PIB) is expressed as /6t/, and 15.4-PIB is expressed as
/154/. The advantage to express them separately is that we can just use
SET/GET as RPC, and then management entity can translate the RPC to 6top
commands or 15.4 SET/GET according to the data's URI path.

Just thought.

Qin

On Fri, Dec 6, 2013 at 3:57 PM, Thomas Watteyne
<[email-masked]>wrote:

> [1]
> http://tools.ietf.org/html/draft-bierman-netconf-restconf-02#section-1.2
>
>
>>>>>> From what I see in the attached the exercise looks doable, what do
>>>>>> you think?
>>>>>>
>>>>>>
>>>>>>
>>>>>> : )
>>>>>>
>>>>>>
>>>>>>
>>>>>> Pascal
>>>>>>
>>>>>>
>>>>>>
>>>>>
>>>>>
>>>>
>>>>

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 6 Dec 2013 00:17:11 -0800

+1

On Fri, Dec 6, 2013 at 12:15 AM, Qin Wang <[email-masked]> wrote:

> On Fri, Dec 6, 2013 at 3:57 PM, Thomas Watteyne <
>>> Can we define them as two kinds of resources, i.e. (1)
>>> 6top-MIB+TSCH-PIB, (2) 15.4-PIB? Then, for example, when CoAP is used as
>>> implementation, two URIs can be used accordingly. Just thought.
>>>
>>> Thanks
>>> Qin
>>>
>>>
>>>>>> In the thread "6top Data Model vs 6top API", we have had discussion
>>>>>> on how to design RFC for 6top in YANG. I think that is useful for this work.
>>>>>>
>>>>>> Thanks
>>>>>> Qin
>>>>>>
>>>>>>
>>>>>>> My suggestion is that I work with Thomas on extracting text from
>>>>>>> 6top to archi, so as to parallelize the study on Yang,
>>>>>>>
>>>>>>>
>>>>>>>

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Mon, 9 Dec 2013 15:54:39 +0100

sorry I am late on that. I like your point Qin. +1

X

On Fri, Dec 6, 2013 at 9:17 AM, Thomas Watteyne
<[email-masked]>wrote:

>>>>> I believe we have no choice but to have a way to access the 15.4 PIB.
>>>>> I would therefore include the 15.4 PIB, or at least the parameters we need
>>>>> to access (at least the security related MAC PIB attributes, i.e. Table 60
>>>>> in IEEE802.15.4-2011). If there is some push-back during process, we can
>>>>> adapt.
>>>>>
>>>>>  On Thu, Dec 5, 2013 at 4:36 PM, Qin Wang <[email-masked]>wrote:
>>>>>
>>>>>>
>>>>>>
>>>>>> (1) The database expressed in YANG should be (6top-MIB + TSCH-PIB),
>>>>>> or (6top-MIB + TSCH-PIB + 15.4-PIB)?
>>>>>> On Thu, Dec 5, 2013 at 9:06 AM, Qin Wang <[email-masked]>wrote:
>>>>>>
>>>>>>> Pascal,
>>>>>>>