Subject: [6tisch] terminology discussion

From: Maria Rita PALATTELLA <[email-masked]>
Date: Sun, 15 Dec 2013 01:56:05 +0000

All,

During the last webex, we agreed to split the definition of cell. Below is a proposal. Once we reach rough consensus, I will update the terminology draft.

Cell: A single element in the TSCH sloframe, identified by a slotOffset, a channelOffset, a slotframe_ID and Hopping_Sequence_ID. A cell can be scheduled or unscheduled.

unscheduled cell: A cell which is not used by the IEEE802.15.4e TSCH implementation.

scheduled cell: A cell which is assigned a MAC-layer slotframe identifier, a neighbor MAC address (possible the broadcast address), and one or more of the following flags: TX, RX, shared, timeskeeping, A scheduled cell can be used by the IEEE802.15.4e TSCH implementation to communicate. A scheduled cell can be a hard cell or a soft cell.

to schedule a cell: the action of turning an unscheduled cell into a scheduled cell.

broadcast cell: a scheduled cell with neighbor MAC address the broadcast address

hard cell: A scheduled cell which the 6top sublayer cannot reallocate.

soft cell: A scheduled cell which the 6top sublayer can reallocate.

to reallocate a cell: the action by the 6top sublayer of changing the slotOffset and/or channelOffset of a soft cell.

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 16 Dec 2013 17:47:56 -0800

+1

I believe this reflects the discussions we had during the last call. These
definitions could replace the (long) definition of cell in
http://tools.ietf.org/html/draft-ietf-6tisch-terminology-00.

What do others think?

On Sat, Dec 14, 2013 at 5:56 PM, Maria Rita PALATTELLA <
[email-masked]> wrote:

>   All,
>
>  During the last webex, we agreed to split the definition of cell. Below
> is a proposal. Once we reach rough consensus, I will update the terminology
> draft.
>
>  Cell: A single element in the TSCH sloframe, identified by a slotOffset,
> a channelOffset, a slotframe_ID and Hopping_Sequence_ID. A cell can be
> scheduled or unscheduled.
>
>  scheduled cell: A cell which is assigned a MAC-layer slotframe
> identifier, a neighbor MAC address (possible the broadcast address), and
> one or more of the following flags: TX, RX, shared, timeskeeping, A
> scheduled cell can be used by the IEEE802.15.4e TSCH implementation to
> communicate. A scheduled cell can be a hard cell or a soft cell.
>
>  to reallocate a cell: the action by the 6top sublayer of changing the
> slotOffset and/or channelOffset of a soft cell.
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Qin Wang <[email-masked]>
Date: Wed, 18 Dec 2013 00:29:54 +0800

Hi Maria Rita and Thomas,

I think the definition is accurate except the relationship between cell and
slotframe. According to my understanding, from TSCH point of view, there
are one or more than one slotFrames, and a cell is associated with a
specific slotFrame-ID. Right? If yes, I would suggest the following
modification in the sentence 1 and 3.

(1) Cell: A single element in a TSCH sloframe, identified by a slotOffset,
a channelOffset, a slotframe_ID and Hopping_Sequence_ID. A cell can be
scheduled or unscheduled.

(3) scheduled cell: A cell, with a specific slotframe-ID, which is assigned
a neighbor MAC address (possible the broadcast address), and one or more of
the following flags: TX, RX, shared, timeskeeping, A scheduled cell can be
used by the IEEE802.15.4e TSCH implementation to communicate. A scheduled
cell can be a hard cell or a soft cell.

What do you think?

Qin

On Tue, Dec 17, 2013 at 9:47 AM, Thomas Watteyne <[email-masked]
> wrote:

>>  Cell: A single element in the TSCH sloframe, identified by a
>> slotOffset, a channelOffset, a slotframe_ID and Hopping_Sequence_ID. A cell
>> can be scheduled or unscheduled.
>>

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 17 Dec 2013 09:58:13 -0800

Qin, all,

For cell, what about:

Cell: A single element in *the* TSCH *schedule*, identified by a
slotOffset, a channelOffset, a *slotframeHandle*. A cell can be scheduled
or unscheduled.

Changes and justification:

   - Since the cell is identified by a slotFrameHandle, I believe it is
   clear that a cell is associated with a specific slotFrame, which allows us
   to use the more generic term "TSCH schedule"
   - Where possible, I believe we should stick with already existing
   terminology. Table 44d of IEEE802.15.4e-2012 calls the identifer of a
   sloframe the "slotframeHandle". Maybe stick with that?
   - I have removed the statement "and Hopping_Sequence_ID". I would argue
   that the hopping sequence is not identifying the cell.

For scheduled cell, what about:

scheduled cell: A cell which is assigned a neighbor MAC address (possible
the broadcast address), and one or more of the following flags: TX, RX,
shared, timeskeeping. A scheduled cell can be used by the IEEE802.15.4e
TSCH implementation to communicate. A scheduled cell can be a hard cell or
a soft cell.

Changes and justification:

   - changed command to dot. I imagine this was a typo.
   - I removed the statement "with a specific slotframe-ID". If we agree
   that "scheduled cell" inherits from "cell", then the attributes of a cell
   (e.g. the slotframeHandle) also apply to a scheduled cell.

Thomas

On Tue, Dec 17, 2013 at 8:29 AM, Qin Wang <[email-masked]> wrote:

> I think the definition is accurate except the relationship between cell
> and slotframe. According to my understanding, from TSCH point of view,
> there are one or more than one slotFrames, and a cell is associated with a
> (3) scheduled cell: A cell, with a specific slotframe-ID, which is
> assigned a neighbor MAC address (possible the broadcast address), and one
> or more of the following flags: TX, RX, shared, timeskeeping, A scheduled
> cell can be used by the IEEE802.15.4e TSCH implementation to communicate. A
> scheduled cell can be a hard cell or a soft cell.
>
> What do you think?
>
> Qin
>
>
> On Tue, Dec 17, 2013 at 9:47 AM, Thomas Watteyne <
> [email-masked]> wrote:
>
>> +1
>>
>> I believe this reflects the discussions we had during the last call.
>> These definitions could replace the (long) definition of cell in
>>>  During the last webex, we agreed to split the definition of cell.
>>> Below is a proposal. Once we reach rough consensus, I will update the
>>> terminology draft.
>>>

---

From: Qin Wang <[email-masked]>
Date: Wed, 18 Dec 2013 02:21:31 +0800

+1

Qin

On Wed, Dec 18, 2013 at 1:58 AM, Thomas Watteyne <[email-masked]

>    - I have removed the statement "and Hopping_Sequence_ID". I would
>    argue that the hopping sequence is not identifying the cell.
>
>> (1) Cell: A single element in a TSCH sloframe, identified by a

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 18 Dec 2013 01:25:49 +0000

I'm in but for one point:

What gets reallocated is a unit of transmission, which moves from a cell to another.
We do not have a term for that unit of transmission (frame + ack), so we confuse it with the cell where the unit of transmission happens.
When we say that we reallocate the cell this is an abuse of language; in fact we transfer the unit of transmission from one cell to another.

Should we have a crisper language? Or define the cell as the unit of transmission?

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: lundi 16 décembre 2013 17:48
To: Maria Rita PALATTELLA
Cc: [email-masked]
Subject: Re: [6tisch] terminology discussion

+1

I believe this reflects the discussions we had during the last call. These definitions could replace the (long) definition of cell in http://tools.ietf.org/html/draft-ietf-6tisch-terminology-00.

What do others think?

On Sat, Dec 14, 2013 at 5:56 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
All,

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 19 Dec 2013 09:31:59 -0800

Pascal,
I understand the subtle point you make. I would, however, lean towards not
changing the meaning of "cell", which refers to a coordinate in the TSCH
schedule.
For me, the "scheduled cell" is really the "unit of transmission" you
describe.
Do you have an alternative proposal?

On Tue, Dec 17, 2013 at 5:25 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  I’m in but for one point:
>
>
>
> We do not have a term for that unit of transmission (frame + ack), so we
> confuse it with the cell where the unit of transmission happens.
>
> When we say that we reallocate the cell this is an abuse of language; in
> fact we transfer the unit of transmission from one cell to another.
>
>
>
> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Thomas
> Watteyne
> *Sent:* lundi 16 décembre 2013 17:48
> *To:* Maria Rita PALATTELLA
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] terminology discussion
>
>
>
> +1
>
>
>
> During the last webex, we agreed to split the definition of cell. Below is
> a proposal. Once we reach rough consensus, I will update the terminology
> draft.
>
>
>
> Cell: A single element in the TSCH sloframe, identified by a slotOffset, a
> channelOffset, a slotframe_ID and Hopping_Sequence_ID. A cell can be
> scheduled cell: A cell which is assigned a MAC-layer slotframe identifier,