Subject: [6tisch] updated milestones proposal

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 13 Dec 2013 17:11:06 +0000

Dear WG:

We had a number of good exchanges on the ML and during the last two weekly calls on our milestones;
As a result, we are now suggesting the following:

12/2013 - WG to adopt 6TiSCH terminology
12/2013 - WG to adopt IEEE802.15.4e TSCH overview
12/2013 - WG to adopt 6TiSCH architecture
12/2013 - WG to adopt 6TiSCH minimal configuration
04/2014 - WG to adopt 6top draft(s)
04/2014 - WG to adopt 6TiSCH data model for CoAP
08/2014 - Submit YANG data model in 6top draft for preliminary OPSDIR review
08/2014 - Submit 6TiSCH architecture for preliminary SECDIR review
11/2014 - Submit first draft of 6TiSCH minimal configuration to the IESG
11/2014 - Submit first draft of 6top draft(s) to the IESG
11/2014 - Submit first draft of 6TiSCH data model for CoAP to the IESG
12/2014 - Submit first draft of 6TiSCH terminology to the IESG
12/2014 - Submit first draft of 6TiSCH architecture to the IESG
12/2014 - Evaluate WG progress, propose new charter to the IESG
06/2015 - 6TiSCH Minimal and 6top draft(s) in RFC publication queue
12/2015 - 6TiSCH architecture and terminology in RFC publication queue

On the side: we do not yet have a clear idea of which interop test we can run and when. So we chose not to commit them on the milestones at this time. Still, we have a good hope to be able to run such test during the upcoming IETF meetings.

Cheers,

Pascal

---

From: Qin Wang <[email-masked]>
Date: Sat, 14 Dec 2013 02:59:12 +0800

Hi Pascal,

In the milestone list, it is said that "04/2014 - WG to adopt 6top draft(s)"
and "08/2014 - Submit YANG data model in 6top draft for preliminary OPSDIR
review". I wonder if the YANG data model in the second item is part of the
6top draft(s) in the first item or a different one.

Thanks
Qin

On Sat, Dec 14, 2013 at 1:11 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> On the side: we do not yet have a clear idea of which interop test we can
> run and when. So we chose not to commit them on the milestones at this
> time. Still, we have a good hope to be able to run such test during the
> upcoming IETF meetings.
>
> Cheers,
>
> Pascal
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 13 Dec 2013 19:02:36 +0000

It is, Qin.

Should we wait till we have the final cut on what the drafts are?

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: vendredi 13 décembre 2013 13:59
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tisch] updated milestones proposal

Hi Pascal,

In the milestone list, it is said that "04/2014 - WG to adopt 6top draft(s)" and "08/2014 - Submit YANG data model in 6top draft for preliminary OPSDIR review". I wonder if the YANG data model in the second item is part of the 6top draft(s) in the first item or a different one.

Thanks
Qin

On Sat, Dec 14, 2013 at 1:11 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear WG:

Cheers,

Pascal
_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Qin Wang <[email-masked]>
Date: Sat, 14 Dec 2013 03:17:37 +0800

Pascal,

Now, we are going to cut original 6top draft into two parts, one is called
6top-interface and another one is called 6top-sublayer. 6top-interface is
for the current charter and 6top-sublayer is for the next version of
charter. The 6top-interface draft mainly includes 6top commands and YANG
data model.

What do you think about the split? Should we ask ML if the split suitable
or not?

Thanks
Qin

On Sat, Dec 14, 2013 at 3:02 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Qin Wang
> *Sent:* vendredi 13 décembre 2013 13:59
> *To:* Pascal Thubert (pthubert)
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] updated milestones proposal
>
>
>
> Hi Pascal,
>
>
>
> In the milestone list, it is said that "04/2014 - WG to adopt 6top
> draft(s)" and "08/2014 - Submit YANG data model in 6top draft for
> preliminary OPSDIR review". I wonder if the YANG data model in the second
> item is part of the 6top draft(s) in the first item or a different one.
>
>
>
> Thanks
>
> Qin
>
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 13 Dec 2013 23:38:43 +0000

You already did, Qin, and that's a good thing :)

I do agree with your split that matches my reading of the charter; additionally, I'd think that we could extract section 3, or make a summarized version of it, out of 6top and fit it in the architecture. What do the 6top authors think of this?

Cheers,

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: vendredi 13 décembre 2013 14:18
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tisch] updated milestones proposal

Pascal,

Now, we are going to cut original 6top draft into two parts, one is called 6top-interface and another one is called 6top-sublayer. 6top-interface is for the current charter and 6top-sublayer is for the next version of charter. The 6top-interface draft mainly includes 6top commands and YANG data model.

What do you think about the split? Should we ask ML if the split suitable or not?

Thanks
Qin

On Sat, Dec 14, 2013 at 3:02 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
It is, Qin.

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Qin Wang
Sent: vendredi 13 décembre 2013 13:59
To: Pascal Thubert (pthubert)
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] updated milestones proposal

Hi Pascal,

Thanks
Qin

Cheers,

Pascal

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Sat, 14 Dec 2013 06:10:50 +0100

Hi,

I agree with the way is splitted now and I also agree on having an
overview/introduction of sectiion 3 in the architecture draft as we
discussed earlier.

:-)
Regards,
Xavi

On Sat, Dec 14, 2013 at 12:38 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  You already did, Qin, and that’s a good thing J
>
>
>
> I do agree with your split that matches my reading of the charter;
> additionally, I’d think that we could extract section 3, or make a
> summarized version of it, out of 6top and fit it in the architecture. What
> do the 6top authors think of this?
>
>
>
> Cheers,
>
>
>
> Pascal
>
>
>
> *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* vendredi 13 décembre 2013 14:18
>

---

From: Qin Wang <[email-masked]>
Date: Sat, 14 Dec 2013 22:43:54 +0800

+1

Qin

On Sat, Dec 14, 2013 at 1:10 PM, Xavier Vilajosana Guillen <
[email-masked]> wrote:

>> Now, we are going to cut original 6top draft into two parts, one is
>> called 6top-interface and another one is called 6top-sublayer.
>> 6top-interface is for the current charter and 6top-sublayer is for the next
>> version of charter. The 6top-interface draft mainly includes 6top commands
>> and YANG data model.
>>
>>
>>
>> preliminary OPSDIR review". I wonder if the YANG data model in the
>> second item is part of the 6top draft(s) in the first item or a different
>> one.
>>
>>
>>
>> Thanks
>>
>> Qin
>>
>>
>>

---

From: Thomas Watteyne <[email-masked]>
Date: Mon, 16 Dec 2013 17:45:25 -0800

+1

On Sat, Dec 14, 2013 at 6:43 AM, Qin Wang <[email-masked]> wrote:

>>> On the side: we do not yet have a clear idea of which interop test we
>>> can run and when. So we chose not to commit them on the milestones at this

---

From: Qin Wang <[email-masked]>
Date: Wed, 18 Dec 2013 00:14:11 +0800

Hi all,

After I try the YANG model tool pyang-1.4.1, I realize that it could be
better to write YANG model of 6top in a separate file, instead of as part
of 6top-interface draft, so as we can use the tool to valid the 6top YANG
model, and translate it into other format if needed later.

What do you think?

Qin

On Tue, Dec 17, 2013 at 9:45 AM, Thomas Watteyne <[email-masked]
> wrote:

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Tue, 17 Dec 2013 18:40:41 +0100

I think that we should do in both ways, the model should be in the draft
and we should provide a .yaml file so it can be downloaded.

regards from Munich!
X

On Tue, Dec 17, 2013 at 5:14 PM, Qin Wang <[email-masked]> wrote:

> On Tue, Dec 17, 2013 at 9:45 AM, Thomas Watteyne <
> [email-masked]> wrote:
>
>> +1
>>
>>

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 17 Dec 2013 10:17:51 -0800

Qin,

While it is convenient (and necessary) to have the YANG model in a separate
file when using pyang, the draft cannot have any "attachments". This means
that the YANG models needs to appear inside the draft when submitted.

That being said, and to second Xavi's suggestion, I believe it's easy
enough to work on the YANG model in a different file in the repo, and copy
it into a dedicated section of the draft right before submitting it.

Unfortunately, I don't know of any "include" capabilities in the XML which
allow a dynamic include when compiling the TXT.

For readability, I would recommend the YANG model appears as one block
inside a section dedicated just to that, possibly at the end of the
6top-interface draft.

Thomas

---

From: Qin Wang <[email-masked]>
Date: Wed, 18 Dec 2013 02:27:16 +0800

Xavi and Thomas,

I agree with you that we edit YANG model in a different file and copy it
into 6top-interface draft later as a section.

Thanks
Qin

On Wed, Dec 18, 2013 at 2:17 AM, Thomas Watteyne <[email-masked]

> Qin,
>
> While it is convenient (and necessary) to have the YANG model in a
> separate file when using pyang, the draft cannot have any "attachments".
> This means that the YANG models needs to appear inside the draft when
> submitted.
>
>>>>>>> On the side: we do not yet have a clear idea of which interop test
>>>>>>> we can run and when. So we chose not to commit them on the milestones at
>>>>>>> this time. Still, we have a good hope to be able to run such test during
>>>>>>> the upcoming IETF meetings.
>>>>>>>
>>>>>>> Cheers,
>>>>>>>
>>>>>>> Pascal