Subject: [6tisch] draft on 6top interface

From: Qin Wang <[email-masked]>
Date: Wed, 4 Dec 2013 11:04:35 +0800

Hi All,

The feedback from ML and IETF88 suggests to split the current version of
6top draft (http:// <http://tools.ietf.org/html/draft-wang-6tisch-6top-00>
tools.ietf.org/html/draft-wang-6tisch-6top-00) . To meet the requirement of
current charter, we can split it into two parts:

(1) 6top interface to upper layer, including the description on data model,
and 6top API. For the data model expression, YANG could be a candidate.

(2) 6top protocol, including 6top<=>6top communication protocol, IE and
message format, monitoring mechanism, and other internal functions.

We are going to focus on part (1) firstly, leave part (2) to the next step,
and target to complete part (1) before next IETF meeting.

What do you think? Any comments and suggestion are welcome.

Thanks
Qin

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 3 Dec 2013 22:50:12 -0800

Qin,
I believe this will answer the IETF88 discussed perfectly. Please let me
know if you need help setting up the repository.
Thomas

On Tue, Dec 3, 2013 at 7:04 PM, Qin Wang <[email-masked]> wrote:

> tools.ietf.org/html/draft-wang-6tisch-6top-00) . To meet the requirement
> of current charter, we can split it into two parts:
>
> (1) 6top interface to upper layer, including the description on data
> model, and 6top API. For the data model expression, YANG could be a
> candidate.
>
> We are going to focus on part (1) firstly, leave part (2) to the next
> step, and target to complete part (1) before next IETF meeting.
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: Qin Wang <[email-masked]>
Date: Thu, 5 Dec 2013 10:49:15 +0800

Thomas,

Many thanks! I think we need setting up the repository, then we can work at
same page. Xavi, what do you think?

Qin

On Wed, Dec 4, 2013 at 2:50 PM, Thomas Watteyne
<[email-masked]>wrote:

>> 6top draft (http://<http://tools.ietf.org/html/draft-wang-6tisch-6top-00>

---

From: Xavier Vilajosana Guillen <[email-masked]>
Date: Thu, 5 Dec 2013 13:40:06 +0100

Hi Qin,

yes, Thomas can you setup the new repo¿

thanks!
X

On Thu, Dec 5, 2013 at 3:49 AM, Qin Wang <[email-masked]> wrote:

> Thomas,
>
> Many thanks! I think we need setting up the repository, then we can work
> at same page. Xavi, what do you think?
>
> Qin
>
>
> On Wed, Dec 4, 2013 at 2:50 PM, Thomas Watteyne <
> [email-masked]> wrote:
>
>> Qin,
>>> tools.ietf.org/html/draft-wang-6tisch-6top-00) . To meet the
>>> requirement of current charter, we can split it into two parts:
>>>

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 5 Dec 2013 17:14:34 -0800

Of course. Any tentative abbreviation, to use a the repo name?
Thomas

On Thu, Dec 5, 2013 at 4:40 AM, Xavier Vilajosana Guillen <
[email-masked]> wrote:

>>>> The feedback from ML and IETF88 suggests to split the current version
>>>> of 6top draft (http://<http://tools.ietf.org/html/draft-wang-6tisch-6top-00>

---

From: Qin Wang <[email-masked]>
Date: Fri, 6 Dec 2013 13:25:05 +0800

Thomas, Xavi and all,

Regarding to the content of 6top interface draft, here is what I'm thinking.

1. introduction
2. 6top Commands.
3. 6top Generic Data Model, i.e. detailed Operation and MIB description in
YANG
4. Consideration on Data Model Implementation. In this section, we describe
how a management entity translates the data message to 6top commands or
15.4 SET/GET.

Just thought. Please input your comments and suggestions.

Regarding to the repo name, I do not have good idea. What is your
suggestion?

Thanks
Qin

On Fri, Dec 6, 2013 at 9:14 AM, Thomas Watteyne
<[email-masked]>wrote:

>>>> I believe this will answer the IETF88 discussed perfectly. Please let
>>>> me know if you need help setting up the repository.
>>>> Thomas
>>>>
>>>>
>>>>> (2) 6top protocol, including 6top<=>6top communication protocol, IE
>>>>> and message format, monitoring mechanism, and other internal functions.
>>>>>

---

From: Thomas Watteyne <[email-masked]>
Date: Thu, 5 Dec 2013 22:04:09 -0800

Qin,
Looks good to me. As things progress, maybe 2&3 will be relatively related.
Thomas

On Thu, Dec 5, 2013 at 9:25 PM, Qin Wang <[email-masked]> wrote:

> 4. Consideration on Data Model Implementation. In this section, we
> describe how a management entity translates the data message to 6top
> commands or 15.4 SET/GET.
>
> On Fri, Dec 6, 2013 at 9:14 AM, Thomas Watteyne <
>>>> Many thanks! I think we need setting up the repository, then we can
>>>> work at same page. Xavi, what do you think?
>>>>
>>>> Qin
>>>>
>>>>
>>>>>  On Tue, Dec 3, 2013 at 7:04 PM, Qin Wang <[email-masked]>wrote:
>>>>>
>>>>>>  Hi All,
>>>>>>