Subject: [6tisch] terminology - discussion cell vs unit of transmission

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 10 Feb 2014 10:22:03 +0000

Dear all,
As discussed during last call on Friday 2/7/14, to avoid abuse of notation, we need to have two distinct terms in our terminology draft: cell and unit of transmission.
We already have the following definition for cell
Cell: A single element in the TSCH schedule, identified by a slotOffset, a channelOffset, a slotframeHandle. A cell can be scheduled or unscheduled.

-- BTW: we agreed to keep TSCH schedule (vs TSCH slotframe) --
Let's now try to agree on  a possible definition of unit of transmission.
unit of transmission:  data frame (or packet) sent over a two neighbors connection, within a cell.
Shall we update the definition of un/scheduled cell, according to this?
unscheduled cell: (old DEF) A cell which is not used by the IEEE802.15.4e TSCH implementation -> (new DEF)  A cell which is not used by the IEEE802.15.4e TSCH implementation for exchanging an unit of transmission.
scheduled cell: (old DEF)  A cell which is assigned a neighbor MAC address (possible the broadcast address), and one or more of the following flags: TX, RX, shared, timeskeeping. A scheduled cell can be used by the IEEE802.15.4e TSCH implementation to communicate. A scheduled cell can be a hard cell or a soft cell. -> (new DEF) A cell which is assigned a neighbor MAC address (possible the broadcast address), and one or more of the following flags: TX, RX, shared, timeskeeping. A scheduled cell can be used by the IEEE802.15.4e TSCH implementation to communicate, i.e., to exchange a unit of transmission, that can be hard or soft.
Because hard and soft attributes refer to the unit of transmission, shall we also update the definition of hard and soft cell?
hard cell: (old DEF) A scheduled cell which the 6top sublayer cannot reallocate. -> (new DEF) the unit of transmission within an hard cell cannot be reallocated by 6top sublayer
soft cell: (old DEF)  A scheduled cell which the 6top sublayer can reallocate. -> (new DEF)  the unit of transmission within a soft cell can be reallocated by 6top sublayer
to reallocate a cell:  (old DEF)  the action by the 6top sublayer of changing the slotOffset and/or channelOffset of a soft cell. -> (new DEF) the action by the 6top sublayer of moving a unit of transmission from a soft cell to another, identified by a different slotOffset and/or channelOffset.

What do you think? Please let me know, so I can update the draft, and submit the new version before the cutoff date. Thank you!
Maria Rita

---

From: Pieter De Mil <[email-masked]>
Date: Mon, 10 Feb 2014 12:06:36 +0100

Hi,

I would use “frame” instead of “data frame”, because a “frame” is the unit of transmission on layer 2. 

About the “two neighbors connection” : what if you have a broadcast cell? You might have n neighbors, and n could be 0.

Best
Pieter

On 10 Feb 2014, at 11:22, Maria Rita PALATTELLA <[email-masked]> wrote:

> Let’s now try to agree on  a possible definition of unit of transmission.
> 
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 10 Feb 2014 11:18:16 +0000

Hello Pieter,
Many thanks for your prompt feedback. I do agree with both points.
About the second one, what about: TSCH connection, or neighbors connection? By doing so we keep it general, and we include all cases (unicast, broadcast).
The definition should be:
unit of transmission:  frame sent over a TSCH connection , within a cell.
Thanks
Maria Rita

From: Pieter De Mil [mailto:[email-masked]]
Sent: Monday, February 10, 2014 12:07 PM
To: Maria Rita PALATTELLA
Cc: [email-masked]
Subject: Re: [6tisch] terminology - discussion cell vs unit of transmission

Hi,

I would use "frame" instead of "data frame", because a "frame" is the unit of transmission on layer 2.

About the "two neighbors connection" : what if you have a broadcast cell? You might have n neighbors, and n could be 0.

Best
Pieter

On 10 Feb 2014, at 11:22, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

What do you think? Please let me know, so I can update the draft, and submit the new version before the cutoff date. Thank you!
Maria Rita
_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Qin Wang <[email-masked]>
Date: Mon, 10 Feb 2014 22:06:57 +0800

Hi Maria Rita,

I'm confused on the definition of "unit of transmission". Actually, I don't
understand why we need to introduce the term "unit of transmission" which
almost equals to the term "frame" in layer-2. I think the original
motivation to introduce "unit of transmission" is to find a term to
represent the organic (x,y) in the Matrix [slotOffset, channelOffset], so
as to distinguish from "cell". Maybe I miss something.

Thanks
Qin

On Mon, Feb 10, 2014 at 6:22 PM, Maria Rita PALATTELLA <
[email-masked]> wrote:

>   Dear all,
>
> As discussed during last call on Friday 2/7/14, to avoid abuse of
> notation, we need to have two distinct terms in our terminology draft: cell
> and unit of transmission.
>
> *Cell:* A single element in the TSCH schedule, identified by a
> slotOffset, a channelOffset, a slotframeHandle. A cell can be scheduled or
> unscheduled.
>
> *unit of transmission:  data frame (or packet) sent over a two neighbors
> connection, within a cell. *
>
> *unscheduled cell: *(old DEF) A cell which is not used by the
> IEEE802.15.4e TSCH implementation *-*> (new DEF)  A cell which is not
> used by the IEEE802.15.4e TSCH implementation *for exchanging an unit of
> transmission.*
>
> *scheduled cell:* (old DEF)  A cell which is assigned a neighbor MAC
> address (possible the broadcast address), and one or more of the following
> flags: TX, RX, shared, timeskeeping. A scheduled cell can be used by the
> IEEE802.15.4e TSCH implementation to communicate. A scheduled cell can be a
> hard cell or a soft cell. -> (new DEF) A cell which is assigned a
> neighbor MAC address (possible the broadcast address), and one or more of
> the following flags: TX, RX, shared, timeskeeping. A scheduled cell can be
> used by the IEEE802.15.4e TSCH implementation to communicate, *i.e., to
> exchange a unit of transmission, that can be hard or soft.*
>
> Because hard and soft attributes refer to the unit of transmission, shall
> we also update the definition of hard and soft cell?
>
> *hard cell:* (old DEF) A scheduled cell which the 6top sublayer cannot
> reallocate. -> (new DEF) the unit of transmission within an hard cell
> cannot be reallocated by 6top sublayer
>
> *soft cell:* (old DEF)  A scheduled cell which the 6top sublayer can
> reallocate. -> (new DEF)  the unit of transmission within a soft cell can
> be reallocated by 6top sublayer
>
> *to reallocate a cell:*  (old DEF)  the action by the 6top sublayer of
> changing the slotOffset and/or channelOffset of a soft cell. -> (new DEF)
> the action by the 6top sublayer of *moving a unit of transmission from a
> soft cell to another*, identified by a different slotOffset and/or
> channelOffset.
>
>
>
> What do you think? Please let me know, so I can update the draft, and
> submit the new version before the cutoff date. Thank you!
>
> Maria Rita
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 10 Feb 2014 14:42:37 +0000

Hi Qin,
The idea was to distinguish the cell that is actually an element within the matrix (slotoffset, channelOffset), from what is contained within the cell itself, i.e., the unit of transmission.
The unit of transmission should represent the communication that takes place within a cell.
For instance, let's consider the action of reallocate, actually we do not move the cell. The cell is still in the same position in the matrix, but we do move the unit of transmission from a cell to another, within the matrix.
Does this make more sense?
Thank you
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Monday, February 10, 2014 3:07 PM
To: Maria Rita PALATTELLA
Cc: [email-masked]; [email-masked]
Subject: Re: [6tisch] terminology - discussion cell vs unit of transmission

Hi Maria Rita,

I'm confused on the definition of "unit of transmission". Actually, I don't understand why we need to introduce the term "unit of transmission" which almost equals to the term "frame" in layer-2. I think the original motivation to introduce "unit of transmission" is to find a term to represent the organic (x,y) in the Matrix [slotOffset, channelOffset], so as to distinguish from "cell". Maybe I miss something.

Thanks
Qin

On Mon, Feb 10, 2014 at 6:22 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,
As discussed during last call on Friday 2/7/14, to avoid abuse of notation, we need to have two distinct terms in our terminology draft: cell and unit of transmission.
We already have the following definition for cell
Cell: A single element in the TSCH schedule, identified by a slotOffset, a channelOffset, a slotframeHandle. A cell can be scheduled or unscheduled.

---

From: Qin Wang <[email-masked]>
Date: Mon, 10 Feb 2014 23:04:44 +0800

Hi Maria Rita,

I agree we need two terms to express (1) the element within the matrix
(slotOffset, channelOffset) for given slotframeHandle, (2) the element
within the TSCH schedule, which is identified by a slotOffset, a
channelOffset, a slotframeHandle and used for communication. If "cell" is
used to represent the element in (1) and "unit of transmission" is used to
represent the element in (2), then, the action of reallocation is
re-binding the element in TSCH schedule to another element in (slotOffset,
channelOffset) matrix with same slotframeHandle.

The main point is the "unit of transmission" is a element in TSCH schedule,
instead of the frame/packet sent. What do you think?

Thanks
Qin

On Mon, Feb 10, 2014 at 10:42 PM, Maria Rita PALATTELLA <
[email-masked]> wrote:

>  Hi Qin,
>
> The idea was to distinguish the cell that is actually an element within
> the matrix (slotoffset, channelOffset), from what is contained within the
> cell itself, i.e., the unit of transmission.
>
> For instance, let's consider the action of reallocate, actually we do not
> move the cell. The cell is still in the same position in the matrix, but we
> do move the unit of transmission from a cell to another, within the matrix.
>
> *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* Monday, February 10, 2014 3:07 PM
> *To:* Maria Rita PALATTELLA
> *Cc:* [email-masked]; [email-masked]
>
> *Subject:* Re: [6tisch] terminology - discussion cell vs unit of
> transmission
>
>
>
> Hi Maria Rita,
>
>
>
> I'm confused on the definition of "unit of transmission". Actually, I
> don't understand why we need to introduce the term "unit of transmission"
> which almost equals to the term "frame" in layer-2. I think the original

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 10 Feb 2014 15:31:43 +0000

Sent: Monday, February 10, 2014 4:05 PM

Hi Maria Rita,

I agree we need two terms to express (1) the element within the matrix (slotOffset, channelOffset) for given slotframeHandle, (2) the element within the TSCH schedule, which is identified by a slotOffset, a channelOffset, a slotframeHandle and used for communication. If "cell" is used to represent the element in (1) and "unit of transmission" is used to represent the element in (2), then, the action of reallocation is re-binding the element in TSCH schedule to another element in (slotOffset, channelOffset) matrix with same slotframeHandle.

The main point is the "unit of transmission" is a element in TSCH schedule, instead of the frame/packet sent. What do you think?

Qin, I do agree that a unit of transmission is not just a frame/packet. Unlike the cell that is a static element within a matrix, IMHO the unit of transmission refers to the action (i.e., communication) happening within the cell.

With your definitions above, I think we are re-opening the discussion about cell. Right now, we have:
Cell: A single element in the TSCH schedule, identified by a slotOffset, a channelOffset, a slotframeHandle. A cell can be scheduled or unscheduled.
Thus, it corresponds to your (2).

What do the other think about?

Thanks
Maria Rita

Thanks
Qin

On Mon, Feb 10, 2014 at 10:42 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Hi Qin,

From: Qin Wang [mailto:[email-masked]<mailto:[email-masked]>]
Sent: Monday, February 10, 2014 3:07 PM
To: Maria Rita PALATTELLA
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi Maria Rita,

Thanks
Qin

---

From: Qin Wang <[email-masked]>
Date: Mon, 10 Feb 2014 23:57:20 +0800

Maria Rita,

If we say a cell can be scheduled or unscheduled, then I think the
scheduled cells and only the scheduled cells  will appear in TSCH schedule,
because TSCH schedule is a set of (slotOffset, channelOffset,
slotframeHandle) used by L2 to Tx/Rx packet. But, if Tx/Rx a packet in a
specific element of TSCH schedule is decided by TSCH according to the
packets in the queues instead of 6top, that implies the action may or may
not actually happen. What do you think?

Thanks
Qin

On Mon, Feb 10, 2014 at 11:31 PM, Maria Rita PALATTELLA <
[email-masked]> wrote:

> *Sent:* Monday, February 10, 2014 4:05 PM
>
> The main point is the "unit of transmission" is a element in TSCH
> schedule, instead of the frame/packet sent. What do you think?
>
>
>
> Qin, I do agree that a unit of transmission is not just a frame/packet.
> Unlike the cell that is a static element within a matrix, IMHO the unit of
> transmission refers to the action (i.e., communication) happening within
> the cell.
>
>
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Mon, 10 Feb 2014 16:09:37 +0000

Qin,
Thanks for trying to further clarify these concepts.
I see your point. For sure the TSCH schedule includes all the scheduled cells, and as you pointed out, even though a cell has been scheduled, the actual TX/RX operation will occur according to the packets available in the queue.
Maybe we should move one step backward, and accept the abuse of notation, given that is hard to define a clear limit between them... and often the two concepts coexist.
What does Pascal, and others think about?
Thanks
Maria Rita

Sent: Monday, February 10, 2014 4:57 PM

Maria Rita,

If we say a cell can be scheduled or unscheduled, then I think the scheduled cells and only the scheduled cells  will appear in TSCH schedule, because TSCH schedule is a set of (slotOffset, channelOffset, slotframeHandle) used by L2 to Tx/Rx packet. But, if Tx/Rx a packet in a specific element of TSCH schedule is decided by TSCH according to the packets in the queues instead of 6top, that implies the action may or may not actually happen. What do you think?

Thanks
Qin

On Mon, Feb 10, 2014 at 11:31 PM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:

Hi Maria Rita,

Thanks
Maria Rita

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

---

From: Thomas Watteyne <[email-masked]>
Date: Tue, 11 Feb 2014 11:05:45 -0800

Maria Rita, all,

Thanks for working on these definitions. From this discussion, it looks
like the term "unit of transmission" creates more confusion that it clear
things up. Personally, I'm fine with talking about a "cell" to refer to a
position in the matrix, and a "scheduled cell" to refer to a cell over
which nodes communicate.

Thoughts?

Thomas

On Mon, Feb 10, 2014 at 8:09 AM, Maria Rita PALATTELLA <
[email-masked]> wrote:

> I see your point. For sure the TSCH schedule includes all the scheduled
> cells, and as you pointed out, even though a cell has been scheduled, the
> actual TX/RX operation will occur according to the packets available in the
> queue.
>
> Maybe we should move one step backward, and accept the abuse of notation,
> given that is hard to define a clear limit between them... and often the two
> concepts coexist.
>
> *Sent:* Monday, February 10, 2014 4:57 PM
>

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Wed, 12 Feb 2014 09:51:02 +0000

Thomas, I do agree with you, and if nobody disagrees, I will keep the definition of cell, (un)scheduled cells, etc. and omit the one of unit of transmission.

Btw, Pascal, shall we add also the definition of spectrum usage matrix (based on the last discussion we had on chunks)?

Channel Usage Matrix: matrix of height equal to the number of available channels (or channel offsets), representing the spectrum(channel) distribution among the different (RPL parent) nodes in the networks.
Every single element of the matrix belongs to a specific chunk. It has to be noticed that such matrix, even though it includes all the cells grouped in chunks,  belonging to different slotframes, is different from the TSCH schedule.

Thanks for your comments!
Maria Rita

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Tuesday, February 11, 2014 8:06 PM
To: Maria Rita PALATTELLA
Cc: Qin Wang; [email-masked]; [email-masked]
Subject: Re: [6tisch] terminology - discussion cell vs unit of transmission

Maria Rita, all,

Thanks for working on these definitions. From this discussion, it looks like the term "unit of transmission" creates more confusion that it clear things up. Personally, I'm fine with talking about a "cell" to refer to a position in the matrix, and a "scheduled cell" to refer to a cell over which nodes communicate.

Thoughts?

Thomas

On Mon, Feb 10, 2014 at 8:09 AM, Maria Rita PALATTELLA <[email-masked]<mailto:[email-masked]>> wrote:
Qin,

Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Maria Rita

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 12 Feb 2014 10:18:04 +0000

It seems useful Maria Rita, so I'd say we do.

I like channel usage/distribution matrix, CUD matrix.

What do others think ?

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Maria Rita PALATTELLA
Sent: mercredi 12 février 2014 10:51
To: Thomas Watteyne
Cc: [email-masked]; Qin Wang; [email-masked]
Subject: Re: [6tisch] terminology - discussion cell vs unit of transmission

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: Tuesday, February 11, 2014 8:06 PM
To: Maria Rita PALATTELLA
Cc: Qin Wang; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [6tisch] terminology - discussion cell vs unit of transmission

Maria Rita, all,

Thoughts?

Thomas

Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Maria Rita

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

---

From: Qin Wang <[email-masked]>
Date: Wed, 12 Feb 2014 22:29:39 +0800

Hi Maria Rita and Pascal,

I do agree it is very useful to introduce a definition corresponding to
the  Matrix of communication resource, which is different from TSCH
schedule. But, regarding to the name of the Matrix, I'm not sure "Channel
Usage Matrix" is better, or "Timeslot&Channel Usage Matrix" is better, or
something else.

In addition, I remember Chunk is optional. If so, it is likely unnecessary
to connect the Matrix with Chunk in definition.

What do you think?

Thanks
Qin

On Wed, Feb 12, 2014 at 6:18 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Maria Rita
> PALATTELLA
> *Sent:* mercredi 12 février 2014 10:51
> *To:* Thomas Watteyne
> *Cc:* [email-masked]; Qin Wang; [email-masked]
>
> Thomas, I do agree with you, and if nobody disagrees, I will keep the
> definition of cell, (un)scheduled cells, etc. and omit the one of unit of
> transmission.
>
>
>
> Btw, Pascal, shall we add also the definition of spectrum usage matrix
> (based on the last discussion we had on chunks)?
>
>
>
> *Channel Usage Matrix**: matrix of height equal to the number of
> available channels (or channel offsets), representing the spectrum(channel)
> distribution among the different (RPL parent) nodes in the networks.  *
>
> *Every single element of the matrix belongs to a specific chunk. It has to
> be noticed that such matrix, even though it includes all the cells grouped
> in chunks,  belonging to different slotframes, is different from the TSCH
> schedule.*
>
>
>
> *From:* [email-masked] [mailto:[email-masked]<[email-masked]>]
> *On Behalf Of *Thomas Watteyne
> *Sent:* Tuesday, February 11, 2014 8:06 PM
> *Cc:* Qin Wang; [email-masked]; [email-masked]

---

From: Maria Rita PALATTELLA <[email-masked]>
Date: Thu, 13 Feb 2014 09:02:57 +0000

Qin, for me "Timeslot&Channel usage Matrix" looks more like the normal TSCH schedule...while the CUD (channel usage/distribution) matrix should provide a picture of the chunks, and how the spectrum has been distributed, in order to re-use the same channels, without creating interference...
Do you agree?
Pascal, please, point out if my understanding is wrong. Thanks
Maria Rita

From: Qin Wang [mailto:[email-masked]]
Sent: Wednesday, February 12, 2014 3:30 PM
To: Pascal Thubert (pthubert)
Cc: Maria Rita PALATTELLA; Thomas Watteyne; [email-masked]; [email-masked]
Subject: Re: [6tisch] terminology - discussion cell vs unit of transmission

I do agree it is very useful to introduce a definition corresponding to the  Matrix of communication resource, which is different from TSCH schedule. But, regarding to the name of the Matrix, I'm not sure "Channel Usage Matrix" is better, or "Timeslot&Channel Usage Matrix" is better, or something else.

In addition, I remember Chunk is optional. If so, it is likely unnecessary to connect the Matrix with Chunk in definition.

What do you think?

Thanks
Qin

On Wed, Feb 12, 2014 at 6:18 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
It seems useful Maria Rita, so I'd say we do.

What do others think ?

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Maria Rita PALATTELLA
Sent: mercredi 12 février 2014 10:51
To: Thomas Watteyne
Cc: [email-masked]<mailto:[email-masked]>; Qin Wang; [email-masked]<mailto:[email-masked]>

Maria Rita, all,

Thoughts?

Thomas

Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Maria Rita

Thanks
Qin

Hi Maria Rita,

Thanks
Qin

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 14 Feb 2014 07:12:31 +0000

I agree with Maria Rita here,

We can find a better term in the future but for this round we probably can live with "CUD matrix".

Cheers,

Pascal

From: Maria Rita PALATTELLA [mailto:[email-masked]]
Sent: jeudi 13 février 2014 10:03
To: Qin Wang; Pascal Thubert (pthubert)
Cc: Thomas Watteyne; [email-masked]; [email-masked]
Subject: RE: [6tisch] terminology - discussion cell vs unit of transmission

Cc: Maria Rita PALATTELLA; Thomas Watteyne; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

What do you think?

Thanks
Qin

What do others think ?

Pascal

Maria Rita, all,

Thoughts?

Thomas

Maria Rita,

Thanks
Qin

Hi Maria Rita,

Thanks
Maria Rita

Thanks
Qin

Hi Maria Rita,

Thanks
Qin