Subject: [6tisch] Fwd: Fw: New Version Notification for draft-wang-6tisch-6top-interface-01.txt

From: Qin Wang <[email-masked]>
Date: Wed, 12 Feb 2014 02:29:00 +0800

Hi all,

The new version of draft-wang-6tisch-6top-interface has just published.
http://www.ietf.org/internet-drafts/draft-wang-6tisch-6top-interface-01.txt.
Please review it. Any comments and suggestions are welcome.

Thanks
Qin

---------- Forwarded message ----------

-----原始邮件-----
发件人: [email-masked]
发送时间: 2014-02-12 01:12:36 (星期三)
收件人: "Xavier Vilajosana" <[email-masked]>, "Thomas Watteyne" <
[email-masked]>, "Thomas Watteyne" <[email-masked]>, "Qin Wang"
<[email-masked]>, "Qin Wang" <[email-masked]>, "Xavier
Vilajosana" <[email-masked]>
抄送:
主题: New Version Notification for draft-wang-6tisch-6top-interface-01.txt

A new version of I-D, draft-wang-6tisch-6top-interface-01.txt
has been successfully submitted by Qin Wang and posted to the
IETF repository.

Name:           draft-wang-6tisch-6top-interface
Revision:       01
Title:          6TiSCH Operation Sublayer (6top) Interface
Document date:  2014-02-11
Group:          Individual Submission
Pages:          28
URL:
http://www.ietf.org/internet-drafts/draft-wang-6tisch-6top-interface-01.txt
Status:
https://datatracker.ietf.org/doc/draft-wang-6tisch-6top-interface/
Htmlized:
http://tools.ietf.org/html/draft-wang-6tisch-6top-interface-01
Diff:
http://www.ietf.org/rfcdiff?url2=draft-wang-6tisch-6top-interface-01

Abstract:
   This document defines a generic data model for the 6TiSCH Operation
   Sublayer (6top), using the YANG data modeling language.  This data
   model can be used for future network management solutions defined by
   the 6TiSCH working group.  This document also defines a list commands
   internal to the 6top sublayer.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 12 Feb 2014 08:22:57 +0000

Thanks a bunch Qin!

In order to refer to the new spec, I changed the archi as follows:

7.  TSCH and 6top
7.1.  6top
   6top is a logical link control sitting between the IP layer and the
   TSCH MAC layer, which provides the link abstraction that is required
   for IPv4 and IPv6 operations.  The 6top operations are specified in
   [I-D.wang-6tisch-6top].  In particular, 6top provides a management
   interface that enables an external management entity to schedule
   cells and slotframes, and allows the addition of complementary
   functionality, for instance to support a dynamic schedule management
   based on observed resource usage as discussed in section Section 8.2.
   The 6top data model and management interfaces are further discussed
   in Section 8.3.

…

8.3.  Remote Monitoring and Schedule Management
   The 6top interface document [I-D.wang-6tisch-6top-interface]
   specifies the Generic Data Model that can be used to access and
   program resources at the 6top sublayer.  Abstract methods are
   suggested for use by a management entity in the device.  The data
   model also enables remote control operations on the 6top sublayer.
   [I-D.sudhaakar-6tisch-coap] defines an mapping of 6top's set of
   commands described in [I-D.wang-6tisch-6top-interface] to CoAP
   resources.

…

All : is that OK? Any suggestion to improve this text?

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]] On Behalf Of Qin Wang
Sent: mardi 11 février 2014 19:29
To: [email-masked]
Subject: [6tisch] Fwd: Fw: New Version Notification for draft-wang-6tisch-6top-interface-01.txt

Hi all,

The new version of draft-wang-6tisch-6top-interface has just published.  http://www.ietf.org/internet-drafts/draft-wang-6tisch-6top-interface-01.txt. Please review it. Any comments and suggestions are welcome.

Thanks
Qin

---------- Forwarded message ----------

-----原始邮件-----
发件人: [email-masked]<mailto:[email-masked]>
发送时间: 2014-02-12 01:12:36 (星期三)
收件人: "Xavier Vilajosana" <[email-masked]<mailto:[email-masked]>>, "Thomas Watteyne" <[email-masked]<mailto:[email-masked]>>, "Thomas Watteyne" <[email-masked]<mailto:[email-masked]>>, "Qin Wang" <[email-masked]<mailto:[email-masked]>>, "Qin Wang" <[email-masked]<mailto:[email-masked]>>, "Xavier Vilajosana" <[email-masked]<mailto:[email-masked]>>
抄送:
主题: New Version Notification for draft-wang-6tisch-6top-interface-01.txt

Name:           draft-wang-6tisch-6top-interface
Revision:       01
Title:          6TiSCH Operation Sublayer (6top) Interface
Document date:  2014-02-11
Group:          Individual Submission
Pages:          28
URL:            http://www.ietf.org/internet-drafts/draft-wang-6tisch-6top-interface-01.txt
Status:         https://datatracker.ietf.org/doc/draft-wang-6tisch-6top-interface/
Htmlized:       http://tools.ietf.org/html/draft-wang-6tisch-6top-interface-01
Diff:           http://www.ietf.org/rfcdiff?url2=draft-wang-6tisch-6top-interface-01

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: Qin Wang <[email-masked]>
Date: Wed, 12 Feb 2014 21:45:17 +0800

Hi Pascal,

It looks very good. Just one thing, we are trying to publish -00 version of
6top-sublayer draft, to replace  [I-D.wang-6tisch-6top] before deadline. I
will let you know our progress.

Thanks
Qin

On Wed, Feb 12, 2014 at 4:22 PM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> *From:* 6tisch [mailto:[email-masked]] *On Behalf Of *Qin Wang
> *Sent:* mardi 11 février 2014 19:29
> *To:* [email-masked]
> *Subject:* [6tisch] Fwd: Fw: New Version Notification for
> draft-wang-6tisch-6top-interface-01.txt
>
>
>
> Hi all,
>
>
>
> [email-masked]>, "Thomas Watteyne" <[email-masked]>, "Qin
> Wang" <[email-masked]>, "Qin Wang" <[email-masked]>,
> "Xavier Vilajosana" <[email-masked]>
> 抄送:

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Wed, 12 Feb 2014 17:07:30 +0000

That would be great Qin!

We can always move 3.1 later as we talk about adoption and match with charter.

Cheers,

Pascal

From: Qin Wang [mailto:[email-masked]]
Sent: mercredi 12 février 2014 14:45
To: Pascal Thubert (pthubert)
Cc: [email-masked]
Subject: Re: [6tisch] Fwd: Fw: New Version Notification for draft-wang-6tisch-6top-interface-01.txt

Hi Pascal,

It looks very good. Just one thing, we are trying to publish -00 version of 6top-sublayer draft, to replace  [I-D.wang-6tisch-6top] before deadline. I will let you know our progress.

Thanks
Qin

On Wed, Feb 12, 2014 at 4:22 PM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Thanks a bunch Qin!

7.  TSCH and 6top
7.1.  6top

…

…

Cheers,

Pascal

From: 6tisch [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Qin Wang
Sent: mardi 11 février 2014 19:29
To: [email-masked]<mailto:[email-masked]>
Subject: [6tisch] Fwd: Fw: New Version Notification for draft-wang-6tisch-6top-interface-01.txt

Hi all,

Thanks
Qin

---------- Forwarded message ----------

-----原始邮件-----
发件人: [email-masked]<mailto:[email-masked]>
发送时间: 2014-02-12 01:12:36 (星期三)
收件人: "Xavier Vilajosana" <[email-masked]<mailto:[email-masked]>>, "Thomas Watteyne" <[email-masked]<mailto:[email-masked]>>, "Thomas Watteyne" <[email-masked]<mailto:[email-masked]>>, "Qin Wang" <[email-masked]<mailto:[email-masked]>>, "Qin Wang" <[email-masked]<mailto:[email-masked]>>, "Xavier Vilajosana" <[email-masked]<mailto:[email-masked]>>
抄送:
主题: New Version Notification for draft-wang-6tisch-6top-interface-01.txt

Abstract:

The IETF Secretariat

---

From: Thomas Watteyne <[email-masked]>
Date: Wed, 12 Feb 2014 10:38:13 -0800

Pascal,

Can I suggest the following slight rewording of 8.3:

8.3.  Remote Monitoring and Schedule Management
   The 6top interface document [I-D.wang-6tisch-6top-interface]
   specifies the Generic Data Model that can be used to access and
   program resources at the 6top sublayer.  Abstract methods are
   suggested for use by a management entity in the device.  The data
   model also enables remote control operations on the 6top sublayer.
   [I-D.sudhaakar-6tisch-coap] defines a first mapping of 6top's set of
   commands described in [I-D.wang-6tisch-6top-interface] to CoAP
   resources; more mappings are expected to be defined by the 6TiSCH
   working group for example to allow for distributed schedule
   management.

Thanks,
Thomas

On Wed, Feb 12, 2014 at 9:07 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

> *From:* Qin Wang [mailto:[email-masked]]
> *Sent:* mercredi 12 février 2014 14:45
> *To:* Pascal Thubert (pthubert)
> *Cc:* [email-masked]
> *Subject:* Re: [6tisch] Fwd: Fw: New Version Notification for
> It looks very good. Just one thing, we are trying to publish -00 version
> of 6top-sublayer draft, to replace  [I-D.wang-6tisch-6top] before
> deadline. I will let you know our progress.
>
>
>
> Thanks
>
> Qin
>
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>