Subject: [6tisch] chunk and 6top interface

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 10 Feb 2014 18:43:57 +0000

Dear Qin and all:
Reading 6top interface, I figure that the most generic interface to describe which cells fit in which chunk is the enumeration in the draft.
But that can be a lot of information to carry for a large Slotframe. So I thought, maybe we could express a chunk as a base slot and channel  offset and then a increment in slot offset and channel offset. The chunk would comprise for all n the base slot channel plus n * slot offset at N%16 + channel offset. Something like that would allow a much more compressed description of the chunk.

What do you think?

---

From: Qin Wang <[email-masked]>
Date: Tue, 11 Feb 2014 03:41:23 +0800

Pascal,

Here is my understanding about your scheme.

Given a base slotOffset (denoted as slotBase), a  slot incremental
(slotStep), a base channel (channelBase), and a channel incremental
(channelStep), and size of chunk (denoted as M),
Then,
chunk = { (slotOffset(i), channelOffset(i)),
               where i=0..M-1,
               slotOffset(i)= (slotBase + i * slotStep) % slotframeLen,
               channelOffset(i) = (channelBase + i * channelStep) % 16
             }

Correct?

Qin

On Tue, Feb 11, 2014 at 2:43 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Dear Qin and all:
>
>  Reading 6top interface, I figure that the most generic interface to
> describe which cells fit in which chunk is the enumeration in the draft.
>
> But that can be a lot of information to carry for a large Slotframe. So I
> thought, maybe we could express a chunk as a base slot and channel  offset
> and then a increment in slot offset and channel offset. The chunk would
> comprise for all n the base slot channel plus n * slot offset at N%16 +
> channel offset. Something like that would allow a much more compressed
> description of the chunk.
>
>
>
> What do you think?
>
>
>
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch
>
>

---

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Mon, 10 Feb 2014 19:49:02 +0000

Correct Qin 😊

Pascal

Le 10 févr. 2014 à 20:41, "Qin Wang" <[email-masked]<mailto:[email-masked]>> a écrit :

Pascal,

Given a base slotOffset (denoted as slotBase), a  slot incremental (slotStep), a base channel (channelBase), and a channel incremental (channelStep), and size of chunk (denoted as M),
Then,
chunk = { (slotOffset(i), channelOffset(i)),
               where i=0..M-1,
               slotOffset(i)= (slotBase + i * slotStep) % slotframeLen,
               channelOffset(i) = (channelBase + i * channelStep) % 16
             }

Correct?

Qin

On Tue, Feb 11, 2014 at 2:43 AM, Pascal Thubert (pthubert) <[email-masked]<mailto:[email-masked]>> wrote:
Dear Qin and all:
Reading 6top interface, I figure that the most generic interface to describe which cells fit in which chunk is the enumeration in the draft.
But that can be a lot of information to carry for a large Slotframe. So I thought, maybe we could express a chunk as a base slot and channel  offset and then a increment in slot offset and channel offset. The chunk would comprise for all n the base slot channel plus n * slot offset at N%16 + channel offset. Something like that would allow a much more compressed description of the chunk.

What do you think?

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

---

From: Qin Wang <[email-masked]>
Date: Tue, 11 Feb 2014 04:04:22 +0800

Pascal,

I think it is a good scheme for PCE or other management entity to ask nodeA
Delegate a chunk of cells. But, from the chunk management point of view, I
think every cell of the chunk has to have an entry in the nodeA MIB,
because nodeA chooses cell discretely for appropriating/unappropriating.
Right?

Qin

On Tue, Feb 11, 2014 at 3:49 AM, Pascal Thubert (pthubert) <
[email-masked]> wrote:

>  Correct Qin 😊
>
> Pascal
>
> Le 10 févr. 2014 à 20:41, "Qin Wang" <[email-masked]> a écrit :
>
>   Pascal,
>