Subject: Re: [6tisch] Gen-ART LC review of draft-ietf-6tisch-tsch-05

From: Jari Arkko <[email-masked]>
Date: Thu, 5 Mar 2015 15:50:36 +0200

Thanks for your review, Roni.

Jari

On 16 Feb 2015, at 14:52, Roni Even <[email-masked]> wrote:

> I am the assigned Gen-ART reviewer for this draft. For background on Gen-ART, please see the FAQ at <http://wiki.tools.ietf.org/area/gen/trac/wiki/GenArtfaq>.
> 
> Please resolve these comments along with any other Last Call comments you may receive.
> 
> Document:  draft-ietf-6tisch-tsch-05
> Reviewer: Roni Even
> Review Date:2015–2-16
> IETF LC End Date: 2015–2-20
> IESG Telechat date:
>  
> Summary: This draft is ready for publication as an Informational  RFC.
>  
>  
> Major issues:
>  
> Minor issues:
>  
>  
> Nits/editorial comments:
> 
> Some abbreviations are used before they are specified: LLC, WPAN, EB
> 
> I was wondering what the purpose of Appendix B is, does it provide any requirements, in which case it should be part of the main document with normative language.
>

---

From: Thomas Watteyne <[email-masked]>
Date: Fri, 6 Mar 2015 10:25:48 +0100

Roni,

Thanks a lot for your review, this is very helpful.

Please find my comments inline. I propose to publish a new version (-06)
which addresses your points.

Thanks for pointing this out. I have revised the text to include their
definition before their first use.

I was wondering what the purpose of Appendix B is, does it provide any
> requirements, in which case it should be part of the main document with
> normative language.

Appendix B does not provide any requirements, but highlights some key
features of the IEEE802.15.4e standard. I can make this clearer by changing:

OLD
This section lists features of TSCH which we believe are important and
beneficial to the work of 6TiSCH.
NEW
This section details features of IEEE802.15.4e TSCH which might be
interesting for the work of 6TiSCH. It does not define any requirements.

I hope this answers your questions.

Thomas

---

From: "Roni Even" <[email-masked]>
Date: Sat, 7 Mar 2015 08:52:09 +0200

Hi Thomas,

Thanks, the new text for appendix  makes it clear

Roni

From: [email-masked] [mailto:[email-masked]] On Behalf Of Thomas Watteyne
Sent: 06 March, 2015 11:26 AM
To: Roni Even
Cc: [email-masked]
Subject: Re: Gen-ART LC review of draft-ietf-6tisch-tsch-05

Roni,

Please find my comments inline. I propose to publish a new version (-06) which addresses your points.

Thanks for pointing this out. I have revised the text to include their definition before their first use.

Appendix B does not provide any requirements, but highlights some key features of the IEEE802.15.4e standard. I can make this clearer by changing:

OLD

This section lists features of TSCH which we believe are important and beneficial to the work of 6TiSCH.

NEW

This section details features of IEEE802.15.4e TSCH which might be interesting for the work of 6TiSCH. It does not define any requirements.

Thomas