Subject: Re: [6tisch] IEEE 802.15.4e Dissector

From: <[email-masked]>
Date: Tue, 17 Mar 2015 10:41:27 +0000

Hello all,

It looks like there are two on-going Wireshark dissector developments for 15.4e TSCH.
One is led by Peter De Mil https://github.com/pdemil/802154e-wireshark, and one led by Vincent Ladeveze  https://openwsn.atlassian.net/wiki/display/OW/Wireshark+dissector+development
I understand the latter one is a "hack" into the Wireshark code, while the former one is a regular plug-in.
Besides this, can anybody provide feedback on either of these? Which one do you use (maybe even another one)? Praises and grieves?
Thanks

Dominique

De : 6tisch [mailto:[email-masked]] De la part de rahul sen
Envoyé : mardi 12 août 2014 11:35
À : [email-masked]
Objet : Re: [6tisch] IEEE 802.15.4e Dissector

I think there are some new developments on the dissectors, i found some new developments on OpenWSN site

https://openwsn.atlassian.net/wiki/display/OW/Wireshark+dissector+development

What is the difference between pdemil's version and this. If somebody can point out new files in this setup, it would be helpful for me to compile for my setup.

On Tuesday, 12 August 2014 2:32 PM, rahul sen <[email-masked]<mailto:[email-masked]>> wrote:

Modified files are attached. these are just modified version of pdemil's 802.15.4e Wireshark diisector. I've just added the channel field in the dissector to distinguish between different channels. Channel information is passed by sniffer hardware, if u want u can remove this information. Apart from some VC++ based modifications, these files are similar to pdemil's version.

If u don't know how to compile dissectors for wireshark, there are some good tutorials on net.

On Wednesday, 6 August 2014 7:40 PM, Michael Hylkema <[email-masked]<mailto:[email-masked]>> wrote:

You had indicated via an IETF forum back in October of last year that you'd had success compiling pdemil's 802.15.4e Wireshark dissector for Windows.  Did you end up sharing the file somewhere?  I'd love to get access to any updated work for this endeavor.

Thanks!
Michael Hylkema

_______________________________________________
6tisch mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/6tisch

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Pieter De Mil <[email-masked]>
Date: Tue, 17 Mar 2015 14:44:34 +0100

Hi,

2 years ago, we started with option A: the packet-zep.c file contains a small check on the ZEP version number.
    if (zep_data.version>=3) {
	/* IEEE 802.15.4e dissector */	
	next_dissector = ieee802154e_handle;
    }

You can find more info on the other/better options on https://github.com/pdemil/802154e-wireshark/wiki/IEEE-802.15.4e-wireshark-dissector

My ieee802154e dissector is a copy of the ieee802154 dissector. I’ve added the IE list function ( dissect_ieee802154e_ielist), but didn’t change the other functions.
Vincent’s ieee802154e dissector is a copy of this, so I think both dissector developments are the same at this point: regular plug-in (but requires an updated packet-zep).

Vincent: can you explain what you have changed or added for "Interaction with related protocols (6lowpan etc)”?

Best,
Pieter De Mil

On 17 Mar 2015, at 11:41, [email-masked] wrote:

> I understand the latter one is a “hack” into the Wireshark code, while the former one is a regular plug-in.
> On Tuesday, 12 August 2014 2:32 PM, rahul sen <[email-masked]> wrote:
>  
> 
> On Wednesday, 6 August 2014 7:40 PM, Michael Hylkema <[email-masked]> wrote:
>  
> 
> [email-masked]
> [email-masked]