Subject: [6tisch] Minutes, 06 March 2015 interim, 6TiSCH WG

From: "Pascal Thubert (pthubert)" <[email-masked]>
Date: Fri, 6 Mar 2015 17:24:54 +0000

Note: timestamps in PST. Connection details

  _____  

*	Webex: https://ciscosales.webex.com/ciscosales/j.php?ED=219615007
<https://ciscosales.webex.com/ciscosales/j.php?ED=219615007&UID=481905242&PW
=NZTRkNDAwOTE1&RT=MiMyMw%3D%3D>
&UID=481905242&PW=NZTRkNDAwOTE1&RT=MiMyMw%3D%3D
*	Etherpad:
http://etherpad.tools.ietf.org:9000/p/6tisch?useMonospaceFont=true
*	Topic: 6TiSCH Bi-Weekly
*	Time: 8:00 am, Pacific Daylight Time (San Francisco, GMT-07:00)
*	Meeting Number: 206 802 913
*	Meeting Password: sixtus
*	CCM: +14085256800x206802913 Resources

  _____  

*	Webex recording:
https://cisco.webex.com/ciscosales/lsr.php?RCID=4fb54e240de94990b52e6d94170b
6804
*	Wiki: https://bitbucket.org/6tisch/meetings/wiki/150306_webex
*	Slides:
https://bitbucket.org/6tisch/meetings/src/master/150306_webex/slides_150306_
webex.ppt Taking notes (using Etherpad)

  _____  

1.	Xavi Vilajosana
2.	Pascal Thubert
3.	Thomas Watteyne Present (alphabetically)

  _____  

1.	Thomas Watteyne
2.	Pascal Thubert
3.	Chonggang Wang
4.	Deji Chen
5.	Diego Dujovne
6.	Nicola Accettura
7.	Pat Kinney
8.	Patrick Wetterwald
9.	Pouria Zand
10.	Qin Wang
11.	Raghuram Sudhaakar
12.	Rene Struik
13.	Savio Sciancalepore
14.	Xavi Vilajosana
15.	Sedat Gormus
16.	Zhuo Chen Action Items

  _____  

1.	TODO Agenda

  _____  

*	Administrivia [2min]

*	Approval agenda
*	Approval minutes last call

*	update plugtest [15min]
*	IETF92 Dallas meeting: goals, agenda [20min]
*	architecture draft last call [10min]
*	minimal draft wrap-up [10min]
*	AOB [3min] Minutes

  _____  

*	[07.05] Meeting starts

*	minutes starts
*	Pascal reminds Note Well
*	Objective of the meeting: preparation for the IETF meeting

*	Administrivia

*	Approval agenda

Agenda is approved. No issues are raised.

*	Approval minutes last call

Last call minutes are approved. No issues are raised.

·        [07.08] update plugtest

*	Thomas presents on behalf of Miguel.
*	Prague ETSI plugtest
*	First plugtest about the minimal draft 
*	17-19 july before IETF 93 (most likely in same hotel that IETF
*	group of experts* 
*	task to be done: develop the test list develop and implement the
golden board and code running there technical support
*	Several milestones from now to july. objective to have everything
ready by 17th of July. Report later.
*	Website will be hosted by ETSI.

o   Needs to register to the event. Registration opens the 27th of march,
closes in June

o   2nd plugtest ? Japan or Argentina (November or March). also need to
discuss scope.

*	Questions are encouraged, can contact Miguel by email

·        [07.??] IETF92 Dallas meeting: goals, agenda

*	2 sessions. monday afternoon. unchartered items. Thursday morning,
chartered topics + security
*	cutoff date next monday.
*	goal is to define detnet. Gap analysis with PCE. Identify what is
being done today and see what 6tisch covers.
*	figure out relation to other groups
*	dynamic scheduling in general. OTF
*	rechartering. what on that topic might be part of the new charter

o   regarding chartered items session

*	last call for tsch and architecture
*	discuss about what to do for header compression in minimal
*	plugtest
*	security
*	rechartering

o   The detnet hour will cover OTF and then discussion about centralized
approaches. 

o   Use cases and requirements for tracks. *

o   10min per draft in the chartered session 2.5h

*	6top is core and needs to be complete. 
*	second part, security and status from the security design team. Also
ideas for rechartering * ACTION: WG Chairs to Contact meetecho for remote
meeting participants.

·        [07.27] architecture draft last call the draft will be generated in
volumes

*	the new security text in the architecture draft is not final. It
still do not have the consensus from the security team. 
*	needs feedback for that part.
*	will be published on Monday.
*	Rene: Changing 2 words on the section. 
*	TW: Can this be resolved in the ML?
*	Rene: complains about the low activity in the ML. 

*	No proposal submitted by everybody on how to improve PSK problems.

*	Discuss of how the overall architecture of the overall joining
process should be. 
*	According to Rene. There is no technical justification about the
comments made to Rene´s proposal.
*	PT: I was asking to Rene to describe how ISA100 works during a year.

*	TW: the idea of the next IETF meeting is to charter security.
*	Rene: does not support the removal of the section proposed by Rene
in the architecture . [07.??] minimal draft wrap-up

*	Security in minimal: what to say 
*	there will be a network wide network key. 
*	The join process is only for autonomic and scalable network
bootstrapping. 
*	all the nodes have the same key or we have 2 keys? one for the
beacon and one for the data. 
*	how the keys get there is out of scope. 
*	in a network we use 1 key for beacon and another for data 
*	key for data and different key for data. data is authenticated. 
*	 

*	[07.??] AOB

OTF question about the use of shared cells on reservation. T

*	it seems a confusion with soft cells.
*	move to the ML and at the WG meeting. 
*	No 6tisch call next time. INformal calls to synchronize slides. USe
case prepared for the track case.
*	[08.13] Meeting ends

*

---

From: Rene Struik <[email-masked]>
Date: Fri, 06 Mar 2015 12:49:23 -0500

Hi Pascal:

Please see below for some suggested improvements to the minutes.

On 3/6/2015 12:24 PM, Pascal Thubert (pthubert) wrote:
> ------------------------------------------------------------------------
>
>   * Webex:
>     https://ciscosales.webex.com/ciscosales/j.php?ED=219615007&UID=481905242&PW=NZTRkNDAwOTE1&RT=MiMyMw%3D%3D
>   * Etherpad:
> ------------------------------------------------------------------------
>
>   * Webex recording:
>     https://cisco.webex.com/ciscosales/lsr.php?RCID=4fb54e240de94990b52e6d94170b6804
>     https://bitbucket.org/6tisch/meetings/src/master/150306_webex/slides_150306_webex.ppt
>     Taking notes /(using Etherpad)/
>
> ------------------------------------------------------------------------
>
>  1. Xavi Vilajosana
>  2. Pascal Thubert
>  3. Thomas Watteyne Present /(alphabetically)/
>
> ------------------------------------------------------------------------
>
>  1. Thomas Watteyne
>  2. Pascal Thubert
>  3. Chonggang Wang
>  4. Deji Chen
>  5. Diego Dujovne
>  6. Nicola Accettura
>  7. Pat Kinney
>  8. Patrick Wetterwald
>  9. Pouria Zand
> 10. Qin Wang
> 11. Raghuram Sudhaakar
> 12. Rene Struik
> 13. Savio Sciancalepore
> 14. Xavi Vilajosana
> 15. Sedat Gormus
> ------------------------------------------------------------------------
>
>  1. TODO Agenda
>
> ------------------------------------------------------------------------
>
>   * Administrivia /[2min]/
>       o Approval agenda
>       o Approval minutes last call
>   * update plugtest /[15min]/
>   * IETF92 Dallas meeting: goals, agenda /[20min]/
>   * architecture draft last call /[10min]/
>   * minimal draft wrap-up /[10min]/
>   * AOB /[3min]/ Minutes
>
> ------------------------------------------------------------------------
>
>   * /[07.05]/ Meeting starts
>       o minutes starts
>       o Pascal reminds Note Well
>       o Objective of the meeting: preparation for the IETF meeting
>   * Administrivia
>       o Approval agenda
>
>       o Approval minutes last call
>
> ·/[07.08]/ update plugtest
>
>       o Thomas presents on behalf of Miguel.
>       o Prague ETSI plugtest
>       o First plugtest about the minimal draft
>       o 17-19 july before IETF 93 (most likely in same hotel that IETF
>       o group of experts*
>       o task to be done: develop the test list develop and implement
>         the golden board and code running there technical support
>       o Several milestones from now to july. objective to have
>         everything ready by 17th of July. Report later.
>       o Website will be hosted by ETSI.
>
> oNeeds to register to the event. Registration opens the 27th of march, 
> closes in June
>
> o2nd plugtest ? Japan or Argentina (November or March). also need to 
> discuss scope.
>
>       o Questions are encouraged, can contact Miguel by email
>
> ·/[07.??]/ IETF92 Dallas meeting: goals, agenda
>
>       o 2 sessions. monday afternoon. unchartered items. Thursday
>         morning, chartered topics + security
>       o cutoff date next monday.
>       o goal is to define detnet. Gap analysis with PCE. Identify what
>         is being done today and see what 6tisch covers.
>       o figure out relation to other groups
>       o dynamic scheduling in general. OTF
>       o rechartering. what on that topic might be part of the new charter
>
> oregarding chartered items session
>
>           + last call for tsch and architecture
>           + discuss about what to do for header compression in minimal
>           + plugtest
>           + security
>           + rechartering
>
> oThe detnet hour will cover OTF and then discussion about centralized 
> approaches.
>
> oUse cases and requirements for tracks. *
>
> o10min per draft in the chartered session 2.5h
>
>       o 6top is core and needs to be complete.
>       o second part, security and status from the security design
>         team. Also ideas for rechartering * ACTION: WG Chairs to
>         Contact meetecho for remote meeting participants.
>
> ·/[07.27]/ architecture draft last call the draft will be generated in 
> volumes
>
RS>>
The Section 13 security text was provided for inclusion in the 
architecture draft, with unanimous consensus by those on the 6TiSCH 
security calls. Please also see the minutes of those calls (which I 
provided pointers to in my previous email). So, not sure why this still 
permeates in the minutes.
<<RS
>   * Rene: Changing 2 words on the section.
RS>>
This lacks some context: this refers to suggested disposition of 
Jonathan Simon's comments on the architecture draft (according to oral 
info on phone call, to the commenters' satisfaction).
<<RS
>   * Rene: complains about the low activity in the ML.
RS>>
I would not call this complaining, since it is simply a matter of fact. 
What about: RS commented that there was low activity level on the ML.
<<RS
>
>  *
>
>
>       o No proposal submitted by everybody on how to improve PSK problems.
RS>> This is not "Rene's proposal": the text in Section 13 was what was 
provided by the 6TiSCH Security design team, with unanimous consensus by 
those who participated on the 6tisch security calls in January. For 
feedback on comments made on Section 13 of the architecture, please see 
the detailed technical rationale for disposition (this is not 
position-based arguing, simply comment disposition based on technical 
arguments).
<<RS
>   * PT: I was asking to Rene to describe how ISA100 works during a year.
RS>> Not sure what this is all about. Besides, if one really wishes to 
criticize, why not do this in private, instead of polluting minutes with 
this?
<<RS
>     in the architecture .
/RS>> Again, the text was proposed by the 6TiSCH security team to Pascal 
Thubert for inclusion with the architecture draft. The forelast version 
was circulated by Pascal Th to the 6TiSCH mailing list regulars to 
double check. All of this suggests that this was not just one person 
pushing for something, but something the 6TiSCH security design team 
wanted to get off their to-do list.
<<RS
/
>
>   * /[07.??]/ minimal draft wrap-up
>       o Security in minimal: what to say
>       o there will be a network wide network key.
>       o The join process is only for autonomic and scalable network
>         bootstrapping.
>       o all the nodes have the same key or we have 2 keys? one for the
>       o how the keys get there is out of scope.
>       o in a network we use 1 key for beacon and another for data
>       o key for data and different key for data. data is authenticated.
>      o
>
RS>> I miss some discussion on testing with one key for regular data 
protection and using no key in enhanced beacons.
<<RS
>   * /[07.??]/ AOB
>   * No 6tisch call next time. INformal calls to synchronize slides.
>     USe case prepared for the track case.
>   * /[08.13]/ Meeting ends
>      o
>
>
>
> _______________________________________________
> 6tisch mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6tisch

-- 
email: [email-masked] | Skype: rstruik
cell: +1 (647) 867-5658 | US: +1 (415) 690-7363