Subject: [6tisch] Informal 6LO Security Discussion during IETF 92

From: James Woodyatt <[email-masked]>
Date: Fri, 20 Mar 2015 22:36:06 +0100

Everyone—

I've been asked to organize an informal gathering during IETF 92 for the
purpose of discussing and understanding the various proposals for work in
6LO and related groups in the area of security protocols, and to consider
whether asking the 6LO chairs to form a design team at this time is
appropriate.

This would not be an IETF meeting, and we would not have a written agenda
or a meeting room with presentation equipment. It would be an informal
discussion.

I already know of some drafts in this category, but it would help to know
if I missed any, so I can make sure their authors are invited to the
gathering:

  I-D.sarikaya-6lo-cga-nd
  I-D.mglt-6lo-aes-implicit-iv
  I-D.mglt-6lo-diet-esp (and related)
  I-D.thaler-6lo-privacy-addrs
  I-D.richardson-6tisch--security-6top

To start off, I've created a Doodle pool <
https://doodle.com/88z8uczakdumqs39> to gauge interest and converge on a
suitable time slot. If you're interested in attending, please register your
opinion about where and when to meet using the poll, or by emailing
[email-masked] directly. I'm the administrator of the poll, so if you
have a suggested time slot that I didn't list (I just listed evening slots
immediately following the close of all the official IETF business) then
please alert me directly, and I'll add it.

-- 
james woodyatt <[email-masked]>
Nest Labs, Communications Engineering

---

From: James Woodyatt <[email-masked]>
Date: Mon, 23 Mar 2015 00:00:55 +0100

Everyone—

Doodle is silently timezone sensitive but doesn't make it obvious how to
set the timezone for a meeting, other than the default: local time for the
administrator. So, when I was choosing times thinking everyone would see
local time unadorned with timezone, everyone else was getting ridiculous
meeting times. I have edited the poll to add the time slots I was
originally trying to set, adjusted for US Central timezone. I did not
remove the original slots. Please revisit the poll.

On Fri, Mar 20, 2015 at 10:36 PM, James Woodyatt <[email-masked]> wrote:

> [email-masked] directly. I'm the administrator of the poll, so if
> you have a suggested time slot that I didn't list (I just listed evening
> slots immediately following the close of all the official IETF business)
> then please alert me directly, and I'll add it.
>
>
> --

---

From: peter van der Stok <[email-masked]>
Date: Sun, 22 Mar 2015 14:36:43 +0100

There is also kumar-6lo-selective-bootstrap

peter

James Woodyatt schreef op 2015-03-20 22:36:
> Everyone—
> 
> I've been asked to organize an informal gathering during IETF 92 for
> the purpose of discussing and understanding the various proposals for
> work in 6LO and related groups in the area of security protocols, and
> to consider whether asking the 6LO chairs to form a design team at
> this time is appropriate.
> 
> This would not be an IETF meeting, and we would not have a written
> agenda or a meeting room with presentation equipment. It would be an
> informal discussion.
> 
> I already know of some drafts in this category, but it would help to
> know if I missed any, so I can make sure their authors are invited to
> the gathering:
> 
>   I-D.sarikaya-6lo-cga-nd
> To start off, I've created a Doodle pool
> <https://doodle.com/88z8uczakdumqs39 [1]> to gauge interest and
> converge on a suitable time slot. If you're interested in attending,
> please register your opinion about where and when to meet using the
> poll, or by emailing [email-masked] directly. I'm the
> administrator of the poll, so if you have a suggested time slot that I
> didn't list (I just listed evening slots immediately following the
> close of all the official IETF business) then please alert me
> directly, and I'll add it.
> 
> --
> 
> Links:
> ------
> [1] https://doodle.com/88z8uczakdumqs39
> 
> _______________________________________________
> 6lo mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/6lo

---

From: Samita Chakrabarti <[email-masked]>
Date: Mon, 23 Mar 2015 06:17:19 +0000

Hello 6lo WG colleagues:

James, Gabriel and I ( along with Ralph) are trying to arrange this meeting  to get an idea what folks are thinking about 6lo-security, bootstrapping options etc.. Since we don’t have enough WG time and many last minute security related requests  – we thought of having an informal discussions which will  give the participants/us an  idea how we should approach solving the security at the 6lo-level and what  the key questions are.

For example: one question comes up often how to tie the multi-level security with a common information ?

Please fill in the Doodle poll before the 6lo session – so we can have a concrete plan that we can announce at the meeting ☺

Also, it’ll be a good opportunity to have an  informal get together and it  should be fun!

Meeting place suggestions are welcome – please let James know on a unicast message ☺

Best regards and see you many of you f2f  at the 6lo meeting!

-Samita

From: 6lo [mailto:[email-masked]] On Behalf Of James Woodyatt
Sent: Sunday, March 22, 2015 4:01 PM
To: [email-masked]
Cc: [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]; [email-masked]
Subject: Re: [6lo] Informal 6LO Security Discussion during IETF 92

Everyone—

Doodle is silently timezone sensitive but doesn't make it obvious how to set the timezone for a meeting, other than the default: local time for the administrator. So, when I was choosing times thinking everyone would see local time unadorned with timezone, everyone else was getting ridiculous meeting times. I have edited the poll to add the time slots I was originally trying to set, adjusted for US Central timezone. I did not remove the original slots. Please revisit the poll.

On Fri, Mar 20, 2015 at 10:36 PM, James Woodyatt <[email-masked]<mailto:[email-masked]>> wrote:
Everyone—

I've been asked to organize an informal gathering during IETF 92 for the purpose of discussing and understanding the various proposals for work in 6LO and related groups in the area of security protocols, and to consider whether asking the 6LO chairs to form a design team at this time is appropriate.

This would not be an IETF meeting, and we would not have a written agenda or a meeting room with presentation equipment. It would be an informal discussion.

I already know of some drafts in this category, but it would help to know if I missed any, so I can make sure their authors are invited to the gathering:

  I-D.sarikaya-6lo-cga-nd

To start off, I've created a Doodle pool <https://doodle.com/88z8uczakdumqs39> to gauge interest and converge on a suitable time slot. If you're interested in attending, please register your opinion about where and when to meet using the poll, or by emailing [email-masked]<mailto:[email-masked]> directly. I'm the administrator of the poll, so if you have a suggested time slot that I didn't list (I just listed evening slots immediately following the close of all the official IETF business) then please alert me directly, and I'll add it.

--
james woodyatt <[email-masked]<mailto:[email-masked]>>
Nest Labs, Communications Engineering

--
james woodyatt <[email-masked]<mailto:[email-masked]>>
Nest Labs, Communications Engineering

---

From: James Woodyatt <[email-masked]>
Date: Mon, 23 Mar 2015 09:52:22 -0500

Everyone—

Here is the Doodle poll: <https://doodle.com/88z8uczakdumqs39>. I have
removed the confusing entries from the list of available options. The
currently winning choice is Thursday evening at 7:00p. I haven't got any
ideas for a location yet. Unless anybody has a better suggestion, the hotel
saloon is the default. In the event we choose a different venue, I'll show
up at the saloon 15 minutes early to collect people who didn't get the news.

I'd like to close the Doodle poll soon? Can everyone with an interest in
choosing a time for the gathering please get their votes registered before
the start of the afternoon sessions today? I'll announce the winning time
then.

On Mon, Mar 23, 2015 at 1:17 AM, Samita Chakrabarti <
[email-masked]> wrote:

>  Hello 6lo WG colleagues:
>
>
>
> James, Gabriel and I ( along with Ralph) are trying to arrange this
> meeting  to get an idea what folks are thinking about 6lo-security,
> bootstrapping options etc.. Since we don’t have enough WG time and many
> last minute security related requests  – we thought of having an informal
> discussions which will  give the participants/us an  idea how we should
> approach solving the security at the 6lo-level and what  the key questions
> are.
>
>
>
> Please fill in the Doodle poll before the 6lo session – so we can have a
> concrete plan that we can announce at the meeting J
>
>
>
> Meeting place suggestions are welcome – please let James know on a unicast
> message J
>
>
>
> *From:* 6lo [mailto:[email-masked]] *On Behalf Of *James Woodyatt
> *Sent:* Sunday, March 22, 2015 4:01 PM
> *To:* [email-masked]
> *Cc:* [email-masked];
> [email-masked];
> [email-masked];
> [email-masked]; [email-masked];
> [email-masked]
> *Subject:* Re: [6lo] Informal 6LO Security Discussion during IETF 92
>
>
>
> Everyone—
>
>
>
> purpose of discussing and understanding the various proposals for work
> in 6LO and related groups in the area of security protocols, and to
> consider whether asking the 6LO chairs to form a design team at this time
> is appropriate.
>
>
>

---

From: James Woodyatt <[email-masked]>
Date: Mon, 23 Mar 2015 18:50:17 -0500

> the start of the afternoon sessions today? I'll announce the winning time

Poll is now closed. The gathering will be held in a location yet to be
determined Thursday evening [US Central] at 7:00pm.

---

From: James Woodyatt <[email-masked]>
Date: Thu, 26 Mar 2015 11:07:50 -0500

Everyone—

Our informal gathering to discuss matters related to 6LO and security, and
to decide whether to advise the chairs to form a design team, will be a
happening this evening at the following coordinates:

  Time: 7:00p to 8:00p
  Room: Pavillion

We have the Pavillion room for an hour, and no food or drink is provided,
so let's see if our gathering can last that long. If it must last longer,
then we will have to migrate into the hotel bar or something. The room is
on the map printed in the IETF schedule you all received on registration.
It's on the Terrace level. From the elevators, you must walk outside and
across the terrace to find it.

Wear your best infosec hipster outfit. Strike a pose. It should be fun.